English:

The Free and Open Productivity Suite
New: Apache OpenOffice 4.1.1 released!



OpenOffice.org Writer for Microsoft Word users:

How to perform common tasks



Title:

OpenOffice.org Writer for Microsoft Word users

Version:

1.0

First edition:

May 2004

First English
edition:

May 2004



Contents

Overview ii

Terminology 1

Set up the program to work your way 2

Write, edit, and review documents 3

Control page layout 4

Use templates and styles 6

Use fields 7

Work with large or complex documents 8

Work with graphics 9





Overview

Experienced users of Microsoft Word may take awhile to discover how to do common tasks in OOoWriter, because some of the menus and the terminology are a bit different. In a few cases no direct equivalent method is available.

This document summarizes my research and experiments with OOoWriter 1.1.1, Microsoft Word 2000, and Word 2002 (XP) running on Windows ME. You may find some differences if you're using another operating system or another version of OpenOffice.org.

This document covers only some of the things a former user of Word might wish to know.

Copyright and trademark information

The contents of this document are subject to the Public Documentation License Version 1.0 (the "License"); you may only use this document if you comply with the terms of this License. A copy of the License is available at http://www.openoffice.org/licenses/PDL.rtf.

The Original Documentation is Chapter 10, "Moving from Microsoft Word" in Taming OpenOffice.org Writer 1.1. The Initial Writer of the Original Documentation is Jean Hollis Weber © 2003. All Rights Reserved. Initial Writer contact:
jean@taming-openoffice-org.com. The Initial Writer contact is for reporting errors in the documentation. For questions regarding how to use the software, subscribe to the Users Mailing List and post your question there: http://support.openoffice.org/index.html.

All trademarks within this guide belong to legitimate owners.

Feedback

Please direct any comments or suggestions about this document to:
dev@documentation.openoffice.org

Acknowledgments

Thanks to everyone who made constructive suggestions for changes and additions to this document, including Andrew Brown, Daniel Carrera, and Ian Laurenson.

Modifications and updates

Version

Date

Description of Change

0.1

18 June 2003

Draft issued for comment.

1.0

9 May 2004

First release, after updating for OOo1.1.1 and incorporating suggestions from reviewers



Terminology

Most functions and controls have the same or similar names in Microsoft Word and OpenOffice.org Writer, but a few are different. This table compares some common terms in the two programs.

Microsoft Word

OpenOffice.org Writer

Office Assistant

Help Agent

ScreenTips or ToolTips

Tips

Wildcards

Regular expressions

(no equivalent)

Long-click (click and hold on an icon to display a tear-off toolbar)

Smart tags

Do not exist in OOo



Set up the program to work your way

Most functions are found in similar places in both programs, but a few are slightly different, and the degree of control varies. This table summarizes where to find the setup choices.

To do this...

in Microsoft Word...

in OpenOffice.org Writer...

Turn off Office Assistant (Help Agent)

Help > Microsoft Word Help > Options

Tools > Options > OpenOffice.org > General

Turn off autocompletion


Tools > AutoCorrect/AutoFormat > Word Completion tab, deselect Enable Word Completion.

Set up document window (rulers, status bar, default toolbars, etc)

View > select required items

View > select required items

Change measurement system

Tools > Options... > General

Tools > Options... > Text Document > General

Customize toolbars

Tools > Customize

View > Toolbars > Customize (or)
Tools > Configure (or)
Right-click on toolbar > Customize or Configure

Customize menus

Tools > Customize

Tools > Configure

Display font names in their font (in toolbar drop-down font list)

Tools > Customize > Options

Tools > Options > OpenOffice.org > View, select Preview in fonts lists

Always show full menus (include unavailable and little-used items)

Tools > Customize > Options

Tools > Options > OpenOffice.org > View, select Inactive menu items

Show/hide ScreenTips (ToolTips) on toolbars

Tools > Customize > Options

Help > Tips, uncheck

Always create backup copy

Tools > Options > Save

Tools > Options > Load/Save > General

Autosave every x minutes

Tools > Options > Save

Tools > Options > Load/Save > General

Show paragraph marks, tabs, etc.

Tools > Options > View

Tools > Options > Text Document > Formatting Aids

Change file locations

Tools > Options > File Locations

Tools > Options > OpenOffice.org > Paths

Change user information

Tools > Options > User Information

Tools > Options > OpenOffice.org > User Data

Set up AutoCorrect and AutoFormat options

Tools > AutoCorrect Options

Tools > AutoCorrect/AutoFormat > Options tab



Write, edit, and review documents

Most writing, editing, and reviewing techniques in OOoWriter are similar to those in Microsoft Word, but the details often vary.

To do this...

in Microsoft Word...

in OpenOffice.org Writer...

Jump quickly to other parts of a document

Edit > Go to (or)
Outline view

Edit > Navigator (or F11), double-click on required heading, figure, table, etc.

Choose language for spelling checker

Tools > Language > Set Language

Tools > Options > Language Settings > Language. (Note: OpenOffice.org has no grammar checker.)

Ignore some text when checking spelling

Select text; Tools > Language > Set Language > Do not check
(or) Format > Style > Modify> Format > Language

Select text; right-click > Character > Font > Language = [None] or the real language of the selected text, if that is foreign.

Recheck spelling

Tools > Spelling & Grammar > Recheck Document

Always rechecks

Find and replace text, formatting, and styles

Edit > Replace > More; choices as needed

Edit > Find&Replace; details are a bit different

Use wildcards (regular expressions) in find and replace

Edit > Replace > More > select Use Wildcards checkbox

Edit > Find&Replace; select Regular Expressions checkbox. Wildcards differ from those in MSWord.

Choose, create, or edit a custom dictionary

Tools > Options > Spelling & Grammar > Custom Dictionaries

Tools > Options > Language Settings > Writing Aids

Create exception (exclude) dictionary

File > New, type words, Save As > text only, file extension .EXC

As for custom dictionary, but select Exception [-] checkbox

Track changes (choose options)

Tools > Options > Track Changes

Tools > Options > Text Document > Changes

Protect document for editing

Tools > Protect Document

Edit > Changes > Protect Records

Mark and track changes

(Word 2000) Tools > Track Changes > Highlight Changes

Edit > Changes > Record

Insert comments associated with a change

Highlight text; Insert > Comment

Edit > Changes > Comment

Insert notes (comments not associated with a change)

Highlight text; Insert > Comment

Insert > Note

Show changes as pop-up text

Options > View > Screentips

Help > Tips (and) Help > Extended Tips

Merge documents

Tools > Merge Documents

Edit > Changes > Merge Document

Accept or reject changes

View > Toolbars > Reviewing

Edit > Changes > Accept or Reject

Change document properties

File > Properties

File > Properties

Get a word count

Tools > Word Count (can get word count for selection)

File > Properties > Statistics tab.
(Cannot get word count for selection without using add-in macro.)

Create AutoText entry

Select text; Insert > AutoText > New

Select text; Edit > AutoText (or) CTRL+F3

Insert AutoText

Type shortcut and press F3

Type shortcut and press F3 (or)
type Name of AutoText entry and press Enter. OOo distinguishes between the “name” and the “shortcut” of an AutoTextentry; Word does not.

Control page layout

This section covers such things as margins, headers and footers, columns, and frames.

OOoWriter controls basic page setup somewhat differently than Word does.

Microsoft Word page setup

Page setup (paper size, orientation, margins, and so on) is a property of the document as a whole. To change the setup for a page, you need to define a separate section with the changed setup. For example, if you specify headers and footers, they apply to the entire document, unless you change them in specific sections.

OpenOffice.org Writer page setup

Page setup is a property of the page style. You can define many page styles—for example, First Page, Left Page, Index Page, and Default. If you change the page layout for one page style, only that style will be affected.

When you set up a page style, you can specify which page style applies to the next page, so when text flows from one page to the next, the correct page style will automatically apply to the following pages. For example, you could specify a First Page style to be followed by a Left Page style, to be followed by a Right Page style, to be followed by a Left Page style—a common setup in books.

To do this...

in Microsoft Word...

in OpenOffice.org Writer...

Define margins

File > Page Setup > Margins

Format > Page >Page

Specify different headers and footers on first, odd, and even pages

File > Page Setup > Layout > Headers and Footers section

Define different page styles for First, Left (even), and Right (odd) pages, using Header and Footer tabs

Edit headers and footers

View > Headers and Footers, then type or insert fields; can also double-click in existing header or footer regions

After you have specified Header and Footer areas for a page, they are always active. Single-click to type or insert fields

Change from roman to arabic page numbers in the footer of a page

Insert a section break, deselect “Same as Previous” in the second section, define a new footer with page numbers restarting at 1 in arabic numerals

Insert a manual page break and apply a different page style

Use paragraph styles for page layout

Can define paragraph styles with offset from left margin, with heading styles aligned left or right

Can define paragraph styles with offset from left margin, with heading styles aligned left or right

Use columns for page layout

Insert continuous sections to switch from single to multiple columns on one page

Format > Page > Columns (or)
Insert/Format > Section > Columns (or) other methods

Use frames or text boxes for page layout

Frames are used in Word 97 but mostly replaced by text boxes in Word2000 and 2002; can be linked to flow text from one to next, as in a newsletter

Insert > Frame (can link frames to flow text from one to next, as in a newsletter); “text boxes” are fields, not positioning devices

Use tables for page layout

Table > Insert > Table (use dialog to format)

Insert > Table (use dialog to format)

Put portrait headers on landscape pages

Use rotated text box linked to header

Use rotated text in a frame

Set first page number to greater than 1

Insert > Page Numbers > Format

In first paragraph on first page, Format > Paragraph > Text Flow > Breaks, select Enable and With Page Style, choose the page style, specify the page number.

View and edit facing pages

File > Print Preview; click Zoom button to enable editing

File > Page Preview shows pages on wrong sides of screen, so you may want to insert a blank page before the first page while writing a draft. You cannot edit in page preview mode.



Use templates and styles

A full discussion of the similarities and differences in the use of templates and styles would take too long for this summary document, but the following table should get you started.

To do this...

in Microsoft Word...

in OpenOffice.org Writer...

Find which template is associated with a document

Tools > Templates and Add-ins

File > Document Properties > General tab.

Specify default template

"Normal" template is default

File > Templates > Organize, choose any template to be the default

Create a new template

File > Save As, set type to Document Template (.DOT)

File > Templates > Save

Edit a template

File > Open, choose template

File > Templates > Edit

Copy styles between templates

Tools > Templates and Add-ins > Organizer

File > Templates > Organize. Copy styles with Ctrl + drag and drop between templates and documents

Create a new document from a template

File > New (opens a list of templates)

File > New > Templates and Documents

Apply a different template to a document

Tools > Templates and Add-ins > Attach, select template, Open

Start a new document based on the different template; copy contents of old document into new document.

Apply a style to text

(Word 2000) Select from Style List or Style dialog
(XP) Can also use task pane.

Format > Styles (or press F11), double-click style in list; after one use, paragraph styles appear in Apply Style list on Formatting object bar.

Change a style definition

(Word 2000) Format > Style > Modify; (XP) can also select in task pane and click Modify

Select style in Stylist, right-click, choose Modify; or Format > Styles > Catalog, select style, click Modify.

Create a new style

Format > Style > New

Format > Styles > Catalog, click New.

Use outline numbering

Format > Style, select style > Format > Numbering

Tools > Outline Numbering



Use fields

A full discussion of the similarities and differences in the use of fields would take too long for this summary document, but the following table should get your started.

Major differences exist in the use of cross-references.

To do this...

in Microsoft Word...

in OpenOffice.org Writer...

Insert a field

Insert > Field
(or) CTRL+F9 for blank field

Insert > Fields

Define a number range field

Insert > Field, use SEQ (sequence)

Insert > Fields > Other > Variables > Number range

Insert a bookmark

Select text; Insert > Bookmark

Select text; Insert > Bookmark

Insert a cross-reference to a bookmark

Insert > Cross Reference, choose Bookmark as type

Insert > Cross Reference > Bookmark

Insert a cross-reference to a heading

Insert > Cross Reference, choose Heading as type

Either bookmark the heading or use Insert > Cross Reference > Set Reference to mark the heading, then Insert > Cross Reference > Insert Reference

Insert a cross-reference to a figure or table

Insert > Cross Reference, choose type

Insert > Cross Reference > Insert Reference > Figure (or Table)

Insert a cross-reference from document A to an item in document B

Use Includetext fields

Keep a manual list of cross-reference names (case sensitive) when you set them in document B. When you insert the cross-reference in document A, you must type the name of the item (in document B) in the Name box on the Fields dialog instead of selecting the name from the Selection list.

Use conditional content

Use IF or other fields, or styles (all workarounds)

Insert > Fields > Other > Variables (among other ways)



Work with large or complex documents

A full discussion of the similarities and differences in working with large or complex documents would take too long for this summary document, but the following table should get your started.

Major differences exist in the use of master documents. The table does not attempt to summarize all these differences. Other how-to documents are being written to describe the use of master documents in detail.

To do this...

in Microsoft Word...

in OpenOffice.org Writer...

Create a table of contents, list of figures, or an alphabetic index

Insert > Index and Tables

Insert > Indexes and Tables > Indexes and Tables

Insert index entries

ALT+SHIFT+X

Insert > Indexes and Tables > Entry (or) click Insert Index Marker icon

Create a bibliographic database

Use database, e.g. Microsoft Access

Tools > Bibliography Database

Insert bibliographic references into text

Link to field in database

Insert > Indexes and Tables > Bibliographic Entry

Insert footnotes and endnotes

Insert > Footnote

Insert > Footnote (or) click Insert Footnote Directly icon

Insert other files

Insert > File, choose Insert or As Link

Insert > File

Cross-reference between documents

Use Includetext fields

Keep a manual list of cross-reference names (case sensitive) when you set them in document A. To insert a cross-reference from document A to an item in document B, you must type the name of the item in the Name box instead of selecting it from the Selection list.

Use master documents

Not recommended

File > Send > Create Master Document; use Navigator to insert subdocuments



Work with graphics

Most graphics work should be done outside Word or Writer, with the graphic files embedded or linked to the Word or Writer file. However, you can do some simple graphics using the drawing tools in Word or Writer. This table covers the basics.

To do this...

in Microsoft Word...

in OpenOffice.org Writer...

Create Drawing objects

(Word 2000) View > Toolbars > Drawing; (XP) Insert > Picture > New Drawing

Click Show Draw Functions icon

Combine graphics objects and drawing objects

(Word 2000) Edit > Picture > Reset Picture Boundary; (XP) Use drawing canvas

Place all objects in a frame

Insert graphics files into a text document (embed or link)

Insert > Picture > From File, choose Insert or As Link

Insert > Graphics > From File

Anchor graphics

Format > Picture > Layout > Advanced > Picture Position

Use icons on Graphics object bar, or right-click and choose from pop-up menu, or click Format > Graphics

Wrap text around graphics

Format > Picture (or Object) > Layout

Use icons on Graphics object bar, or right-click and choose from pop-up menu, or click Format > Graphics > Wrap

Crop graphics

Format > Picture > Cop, (or) click Crop tool on Picture toolbar

Format > Graphics > Crop

Create captions for graphics

Select graphic; Insert > Reference > Caption

Select graphic; Insert > Caption

Annotate graphics

Use drawing objects; group, or place in frame or on drawing canvas (XP)

Place all objects in a frame

Insert watermark

Format > Background > Printed Watermark > Picture (or Text) Watermark

Format > Page Style > Background
(or) create drawing object, Arrange > To Background, Anchor > To Page



Use keyboard shortcuts

This table summarizes some of the built-in keyboard shortcuts used in Microsoft Word and their equivalents in OpenOffice.org Writer. Functions without built-in keyboard shortcuts can be performed using toolbar icons, or you could assign your own key combinations.

Table contributed by Ian Laurenson.

To do this...

in Microsoft Word...

in OpenOffice.org Writer...

Underline words not spaces

Control + Shift + W

No equivalent

Change font size

Control + Shift + P

No standard equivalent

Thesaurus

Shift + F7

Control + F7

Show/hide non-printing characters

Control + Shift + *

Control + F10

Hanging Indent

Control + T

No standard equivalent

Unhang” Indent

Control + Shift + T

No standard equivalent

Indent

Control + M

No standard equivalent

UnIndent”

Control + Shift + M

No standard equivalent

Superscript

Control + Shift =

Control+Shift+P

Subscript

Control + =

Control + Shift + B

Remove character formatting

Control + Spacebar

Right click > Default

Remove paragraph formatting

Control + Q

No equivalent

Jump to previous edit point

Shift + F5

Need to use the reminders on the Navigator



Apache Software Foundation

Copyright & License | Privacy | Website Feedback | Contact Us | Donate | Thanks

Apache, the Apache feather logo, and OpenOffice are trademarks of The Apache Software Foundation. OpenOffice.org and the seagull logo are registered trademarks of The Apache Software Foundation. Other names appearing on the site may be trademarks of their respective owners.