English:

The Free and Open Productivity Suite
New: Apache OpenOffice 4.1.0 released!


Troubleshooting Common Problems


[Troubleshooting Common Problems]
[2.0]
First edition: [2006-02-23]
First English edition: [2006-02-23]

Contents

Contents i

Overview ii

Copyright and trademark information ii

Feedback ii

Acknowledgments ii

Modifications and updates ii

Error Message contains “Get Storage: "No Content"” 1

Multi-user installations: 1

Single-user installations: 1

Outline numbering is not retained after a save 3

The page count includes the title page. How do I offset the page count? 4

Document prints or exports with blank pages 5

General error or General input/output error 6

Recovering content from a damaged OpenOffice.org file 7

Opening Microsoft Works Documents in OpenOffice.org 2.x 8

Some recipients of my files can't open them 9

Corrupt or incomplete installation or download 10

Repeatedly prompted to register 11

Spell checking problems 13

Adding new fonts to OpenOffice.org 14

Public Documentation License, Version 1.0 15



Overview

Extracts from the Documentation Project User Guide.

Copyright and trademark information

The contents of this Documentation are subject to the Public Documentation License, Version 1.0 (the "License"); you may only use this Documentation if you comply with the terms of this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf

The Original Documentation is Troubleshooting Common Problems. The Initial Writer(s) of the Original Documentation is/are G. Roderick Singleton © 2006. All Rights Reserved. (Initial Writer contact(s):grsingleton@openoffice.org].)

Contributor(s): walteram@openoffice.org.

Portions created by walteram@openoffice.org are Copyright (C)2006. All Rights Reserved. (Contributor contact(s):walteram@openoffice.org).

All trademarks within this guide belong to legitimate owners.

[Note: a copy of the PDL is included in this template and is also available at: http://www.openoffice.org/licenses/PDL.rtf.]

Feedback

Please direct any comments or suggestions about this document to:
walteram@openoffice.org .

Acknowledgments

walteram@openoffice.org has contributed this HOW-TO and is basing it on the User Guide Troubleshooting Chapter.

Modifications and updates

Version

Date

Description of Change

[1.0]

[2006-02-23]

[grs: Initial edition issued for comment]

[1.1]

[2006-08-01]

[wam: Edited for clarity/format, added parts from User Guide]

[2.0]

[2006-08-19]

[wam: Added and edited new sections]



Error Message contains “Get Storage: "No Content"”

The full error message reads:

OpenOffice can not be started due to an error in accessing the OpenOffice.org configuration data.

Please contact your system administrator.

The following internal error has occurred: Get Storage:  "No Content"

Often this message occurs because there is a file called Common.xcu that sometimes gets corrupted. In most cases, it seems that this file ends up being filled with 0s (zeros). The problem seems to occur more often under Windows®, possibly as a result of a crash or improper exit while OpenOffice.org was open.

Under Windows®

To locate this file under Windows®, it is easiest to use Windows® Explorer's Find function (sometimes called Search).

Multi-user installations:

Where OpenOffice.org is installed as multi-user under Windows® NT/2000/XP, this file is likely to be in a special system user directory. Therefore, having administrator rights and enabling the option to view system directories in Explorer is essential before using the Find function. This particular file should be found in C:\Documents and Settings\<username>\Application Data\OpenOffice.org<release>\user\registry\data\org\openoffice\Office\Common.xcu where <username> is an actual user name and <release> is the release of OpenOffice.org.

Once the file is located, make sure OpenOffice.org is closed and simply rename the file (for example, to something like Common.xcu.old). Restart OpenOffice.org and a new Common.xcu is created and the problem should disappear.

Single-user installations:

Where OpenOffice.org is installed for a single user, this file is likely to be in C:\Program Files\OpenOffice.org<release>\<username>\registry\data\org\openoffice\Office\Common.xcu where <username> is an actual user name and <release> is the release of OpenOffice.org. However, if the OS is NT/2000/XP, this file could still be in a special system user directory. Therefore, having administrator rights and enabling the option to view system directories in Explorer is essential before using the Find function. For Windows® 95/98/ME, the location should be as mentioned above in this section, though C:\Windows\Application Data\OpenOffice.org2\user\registry\data\org\openoffice\office\Common.xcu might be a good place to look.

Again, once the file is located, simply rename the file (for example to something like Common.xcu.old). Now restart OpenOffice.org and a new Common.xcu is created and the problem should have disappeared.

Note: there may be files called Common.xcu under paths such as C:\<some path>\.OpenOffice.org<release>\share\registry\...... et cetera where <release> is the release of OpenOffice.org. The difference being here share appears in place of the user name. Do NOT delete these files!

UNIX systems

The default location of this file under a UNIX installation (single or multi-user) is $HOME/ .openoffice.org<release>/user/registry/data/org/openoffice/Office/Common.xcu where $HOME is the user's home directory. As above, simply rename the file (for example to something like Common.xcu.old) and restart OpenOffice.org. A new Common.xcu is created and the problem should have disappeared.

Outline numbering is not retained after a save

This is issue, 27534 (see http://qa.openoffice.org/issues/show_bug.cgi?id=27534), which is fixed in release 1.1.4. However, in documents generated by OpenOffice.org1.1.0 up to 1.1.3, one must employ a workaround to achieve expected behavior. The problem is that a line in settings.xml is being set incorrectly when a document is saved. Unfortunately, the only way to fix this is to manually edit the .sxw file.

The following provides a procedure to follow:

  1. Make a temporary directory in which to unzip the .sxw file. For example, my_text.

  2. Change into this directory.

  3. Use unzip or similar zipfile utility to unpack the problem document file.

  4. Edit settings.xml and locate the line that looks like the following:

    <config:config-item config:name="UseOldNumbering" config:type="boolean">false</config:config-item>

  5. Change the value from false to true.

  6. Now using zip or similar utility, repack the files in the temporary directory under a new file name and give it the .sxw extension. With Linux the command could be:

    zip -r my_new_fixed_document.sxw *

  7. Open the fixed document in OpenOffice.org and verify the numbering.

If a copy of StarOffice 6.0 is available, one can get the same effect by opening and saving the document in StarOffice 6.0. By doing so, this line will be removed totally. Likewise, OpenOffice.org1.0 might also work.

In either case , when the document is opened using OpenOffice1.1.x, the line, described above, is added with value true and there will be no further problems with outline numbering.





The page count includes the title page. How do I offset the page count?

If one has a title page or cover page in the document, Writer's page count field still counts those pages and the page count will be too high.

Unfortunately, there is no way to offset the page count field. Using a formula instead will insert the proper page count. Here's the procedure:

Place the cursor in the header or footer where the corrected page count should appear.

Press the F2 key to bring up the formula bar. Type in the formula =page - 1 (the = will already be there). The page variable is the number of pages in the document, not the page currently selected. Subtract the number of pages that should not be counted in the page count (in this example, 1, for a title page).

Press the Enter key to insert the formula.

Choose Tools > Update > Fields from the menu (or press F9) to force the formula to refresh. (Otherwise, the page count formula result will display as 0.)

To edit this formula again later, place the cursor immediately before the formula, and press F2.

Note: Every time the page count changes, refresh the formula again.



Document prints or exports with blank pages

This issue, 3910 (see http://qa.openoffice.org/issues/show_bug.cgi?id=3910), is affected by the book-centric paradigm of left/right, even/odd pages that is so deeply ingrained into OpenOffice.org that it applies even when using nothing but the Default page style.

  1. Create a Title page style from Default or First Page.

  2. Lay out the title page as desired.

  3. Next, select Insert > Manual Break... and specify Next Style as First Page. Check the box marked Change page number and set the number to 1. This results in the phantom page which the following steps will correct.

  4. Select the Styles and Formatting window and modify the First page style layout to be Left Only.

  5. The status bar will now show Page 1 2/2, which is what is wanted. The page style following First Page is Default and the page numbering will proceed without surprises from there.



General error or General input/output error

This error message indicates that the files script.xlc and dialog.xlc could be missing or corrupted. In UNIX-based environments, look for them in the directory
$HOME/.openoffice.org<release>/user/basic
or, in Windows ®:
C:\Document and Settings\<username>\Application Data\OpenOffice.org<release>\user\basic

To fix the problem, exit OpenOffice.org (including the Quickstarter, if it is running) and copy the files as detailed below.

In UNIX-based environments, copy from the directory
<where_OOo_is_installed>/presets/basic/
to
$HOME/.openoffice.org<release>/user/basic

On a Windows® computer, copy from
C:\Program Files\OpenOffice.org<release>\presets\basic
to
C:\Documents and Settings\<username>\Application Data\OpenOffice.org<release>\user\basic

Note: To be absolutely safe, one could also delete the local settings directory. By doing this, however, all personal settings and customizations could be lost.



Recovering content from a damaged OpenOffice.org file

The following set of instructions may or may not work, depending on how badly the file is damaged. The steps outlined assume the user has some basic technical skills. Prerequisites for using this method are:

Steps for recovering the file:

  1. Make a backup of the file.

  2. Create a directory in which to work.

  3. Use the zip utility of your choice to unpack the damaged OpenOffice.org file into the directory created in step 2.

Note: sometimes changing the extension of the OpenOffice.org file to zip is required.

  1. Use OpenOffice.org to create a new empty file of the same type as the damaged one and save it.

  2. Repeat Steps 2 and 3 with the new empty file.

  3. Replace the contents.xml file in the directory created in Step 5 with the contents.xml from the damaged file unpacked in Step 3.

  4. Use the zip utility to repackage the files and directories in the directory created in Step 6.

  5. Rename the new zipfile with the extension used with the original file.

  6. Open the new file in OpenOffice.org and fix any formatting problems including inserting graphics. These can be found in the appropriate sub-directory of the directory created in Step 3.

  7. If the content is recovered using this method, delete the various folders that were created and the other OpenOffice.org files you no longer need.

OpenOffice.org has a good recovery mechanism and users should enable IT by going to Tools > Options > Load/Save > General andmaking sure the following options are checked:



Opening Microsoft Works Documents in OpenOffice.org 2.x

Matt Godfrey has contributed this workaround for Microsoft Works users.

After hours of tinkering, here is a free workaround to get .wps files into OpenOffice.org 2.x. This has been tested and works on Windows ® XP and 2000 with OpenOffice.org 2.x. Please verify and report any success or problems to dev@documentation.openoffice.org.

Here are the steps:

  1. Download and install the free, as of August 4th, 2006, Word Viewer 2003 from Microsoft.

  2. Download and install the free, as of August 4th, 2006, Works 6.0 Converter for Works and Word Users from Microsoft.

  3. Start Microsoft Office Word Viewer 2003 from Start > (All) Programs.

  4. An Open dialog appears. At the bottom of this dialog ensure that the Files of type drop-down is set to All Files(*.*).

  5. Now browse to your .wps file and select it.

  6. Click Open. A warning dialog will appear. If you trust this file et cetera, click Yes and, like magic, your .wps will open!

  7. Choose Edit > Select All then Edit > Copy.

  8. Now open OpenOffice.org 2.x Writer and do Edit > Paste.

  9. You should now see the text of your document in OpenOffice.org 2.x.

  10. Choose File > Save As and save your document in your preferred format and location.

Some recipients of my files can't open them

Sadly, not everyone uses OpenOffice.org as their office productivity suite. Due to this, sometimes others who receive OpenOffice.org files can not open them.

There are a couple ways to help these unfortunates. One way, of course, is to tell them to head to http://www.openoffice.org/ and download their own copy. Additionally, they may be able to find a viewer that supports the OpenOffice.org file format.

The other ways involve work on your part.

If you do not know which application they will be viewing your file in (Microsoft Word versus Lotus WordPro, do the following before sending your file:

  1. Click File > Export as PDF....

  2. Choose the location in which to save the file.

  3. Enter a name for the file in the File Name box.

  4. Click Save.

  5. In the resulting PDF Options dialog, you can change any settings or just click Export.

  6. Send them the resulting PDF file. Almost everyone these days has the free Adobe Acrobat Reader, which is all that is needed to read PDF files. See http://www.adobe.com/.

If you do know which application they will use to view your file, do the following:

  1. Click File > Save As....

  2. Choose a location in which to save the file.

  3. Enter a name for the file in the File Name box.

  4. Click the Save as type drop-down and choose the appropriate file type, such as Microsoft Word 97/2000/XP (.doc).

  5. Send the resulting file.

Note: Often, you will see a pop-up window cautioning you that the document may contain formatting that cannot be saved in the file type you are using. This is a fairly common occurrence and may not effect the look and functionality of your file.



Corrupt or incomplete installation or download

When attempting to download and install OpenOffice.org, users will occasionally receive an error message that the downloaded package was corrupt. Additionally, other problems make occur during installation.

The first step is to reboot the computer and try again. If the download did not take too long, try downloading again, particularly if the error message is that the downloaded package is corrupt. If downloading is a long process, try using that installation package again.

If the download completed but installation did not complete, disconnect from the internet, turn off any virus scanning applications and try the installation again.

If the computer's operating system is Microsoft Windows, you may need to check Add/Remove Programs and attempt to uninstall OpenOffice.org if it appears in the list of installed programs.

There have been reports that installation issues have been solved by upgrading the Windows Installer. Go to http://www.microsoft.com/downloads/ and search All Downloads for “Windows Installer Update.” The Microsoft Installer Cleanup Utility may also be helpful. At this time, August 14th, 2006, it is available at http://support.microsoft.com/default.aspx?scid=kb;en-us;290301. This utility can be used to remove installation information for a program, such as OpenOffice.org.

The download file itself may actually be corrupt. The best way to check this is to compare its MD5 checksum with the published checksum for the package. More information on MD5 can be found at http://www.openoffice.org/dev_docs/using_md5sums.html. The checksum list for OpenOffice.org2.0.3 can be found at http://download.openoffice.org/2.0.3/md5sums.html.

If the download is corrupt, visit http://download.openoffice.org/ for other download options.



Repeatedly prompted to register

Occasionally, after OpenOffice.org is installed and the registration screen acknowledged, subsequent restarts of OpenOffice.org will also request registration. This article assumes that you have responded to the request for registration at least once.

One possible reason for the recurring prompt has to do with OpenOffice.org needing to write the response to the registration prompt to a file. If the permissions on that file do not allow the user that OpenOffice.org is running under to modify files in that directory, that change cannot be made. The target file is the common.xcu file.

The default location of this file under a UNIX installation (single or multi-user) is $HOME/ .openoffice.org<release>/user/registry/data/org/openoffice/Office/Common.xcu where $HOME is the user's home directory.

With a Windows installation, the file will be in one of the following locations:

C:\Documents and Settings\<username>\Application Data\OpenOffice.org<release>\user\registry\data\org\openoffice\Office\Common.xcu

C:\Program Files\OpenOffice.org<release>\<username>\registry\data\org\openoffice\Office\Common.xcu

C:\Windows\Application Data\OpenOffice.org2\user\registry\data\org\openoffice\office\Common.xcu

where <username> is an actual user name and <release> is the release of OpenOffice.org. For further information on these directories and why common.xcu would be in one rather than another, please see the section Error Message contains “Get Storage: "No Content"”.

If the permissions are set correctly, check inside the file for the following:

  <node oor:name="Misc">
   <prop oor:name="FirstRun" oor:type="xs:boolean">
    <value>true</value>
   </prop>
  </node>



To turn off the prompt for registration, change true to false.

Another similar solution involves editing the Setup.xcu file. This file has the following property:

<prop oor:name="FirstStartWizardCompleted" oor:type="xs:boolean">
<value>true</value>
</prop>

which, as seen here, should be set to true.

You should be able to find this file as described below.

On UNIX-based machines:

$HOME/.openoffice.org<release>/user/registry/data/org/openoffice/setup.xcu

With a Windows installation the file should be in one of the following directories:

C:\Documents and Settings\<username>\Application Data\OpenOffice.org<release>\user\registry\data\org\openoffice\Setup.xcu

C:\Program Files\OpenOffice.org<release>\<username>\registry\data\org\openoffice\Setup.xcu

C:\Windows\Application Data\OpenOffice.org2\user\registry\data\org\openoffice\Setup.xcu

It is always a good idea to back up files, usually by simply copying them, before editing them.



Spell checking problems

Various spell checking problems can be solved by following the same general hints.

Verify the default language for your installation:

  1. Click Tools > Options > Language Settings > Languages.

  2. Verify the setting for Default languages for documents. Those entries with the spellcheck symbol (ABC and a check mark) have a spellcheck dictionary installed.

Further, since language is part of the character formatting, it is important to ensure that the entire text, or at least a particular section of it, is set to the correct language.

  1. Select the particular text or use Edit > Select All to select the entire document.

  2. Click Format > Character.... > Font

  3. On the Font tab, just about in the middle of the dialog box, is the drop-down for Language. This should be set to the correct language for the selected text

Note: If the Language drop-down is blank or empty, there are multiple languages set in the selected text. Selecting a particular language in the drop-down will set all the selected text to that language.

Using File > Wizards > Install new dictionaries... should bring up DicOOo, a utility that will assist in the download of spellcheck, hyphenation and thesaurus dictionaries in various languages.

In Tools > Options > Language Settings > Writing Aids, in the Options section, is a checkbox marked Check in all languages. This checkbox allows spell checking to occur against all the languages that have spellcheck dictionaries installed. Thus, if you use Swiss German words in an otherwise American English document, the spellcheck will not mark the correctly spelled Swiss German words as being misspelled American English words.

For more information, open Help > OpenOffice.org Help > Index and enter spellcheck as the search term.



Adding new fonts to OpenOffice.org

In general, the fonts installed on a computer are simply available to OpenOffice.org, just as they are to any other application on the system. If new fonts are obtained, they would be installed as prescribed in the operating system documentation. Other so-called third-party applications may also exist for installing fonts.

OpenOffice.org Help contains some information about installing fonts in UNIX. For more information, open Help > OpenOffice.org Help > Index and enter fonts;adding under UNIX as the search term. This Help topic, in particular, states that a default printer must be set up in order for OpenOffice.org to see available fonts.

Additionally, the OpenOffice.org installation includes a wizard to assist with downloading and installing selected fonts. Obviously you will need an Internet connection to install these fonts.

Click File > Wizards > Install fonts from the web.... Click the link for your language and follow the directions. You will need to restart both OpenOffice.org and the QuickStarter.



Public Documentation License, Version 1.0

1.0 DEFINITIONS.

1.1. "Commercial Use" means distribution or otherwise making the Documentation available to a third party.

1.2. "Contributor" means a person or entity who creates or contributes to the creation of Modifications.

1.3. "Documentation" means the Original Documentation or Modifications or the combination of the Original Documentation and Modifications, in each case including portions thereof.

1.4. "Electronic Distribution Mechanism" means a mechanism generally accepted for the electronic transfer of data.

1.5. "Initial Writer" means the individual or entity identified as the Initial Writer in the notice required by the Appendix.

1.6. "Larger Work" means a work which combines Documentation or portions thereof with documentation or other writings not governed by the terms of this License.

1.7. "License" means this document.

1.8. "Modifications" means any addition to or deletion from the substance or structure of either the Original Documentation or any previous Modifications, such as a translation, abridgment, condensation, or any other form in which the Original Documentation or previous Modifications may be recast, transformed or adapted.  A work consisting of editorial revisions, annotations, elaborations, and other modifications which, as a whole represent an original work of authorship, is a Modification.  For example, when Documentation is released as a series of documents, a Modification is:

A. Any addition to or deletion from the contents of the Original Documentation or previous Modifications.

B. Any new documentation that contains any part of the Original Documentation or previous Modifications.

1.9. "Original Documentation" means documentation described as Original Documentation in the notice required by the Appendix, and which, at the time of its release under this License is not already Documentation governed by this License.

1.10. "Editable Form" means the preferred form of the Documentation for making Modifications to it. The Documentation can be in an electronic, compressed or archival form, provided the appropriate decompression or de-archiving software is widely available for no charge.

1.11. "You" (or "Your") means an individual or a legal entity exercising rights under, and complying with all of the terms of this License or a future version of this License issued under Section 5.0 ("Versions of the License"). For legal entities, "You" includes any entity which controls, is controlled by, or is under common control with You. For purposes of this definition, "control" means (a) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (b) ownership of more than fifty percent (50%) of the outstanding shares or beneficial ownership of such entity.

2.0 LICENSE GRANTS.

2.1  Initial Writer Grant.

The Initial Writer hereby grants You a world-wide, royalty-free, non-exclusive license to use, reproduce, prepare Modifications of, compile, publicly perform, publicly display, demonstrate, market, disclose and distribute the Documentation in any form, on any media or via any Electronic Distribution Mechanism or other method now known or later discovered, and to sublicense the foregoing rights to third parties through multiple tiers of sublicensees in accordance with the terms of this License. 

The license rights granted in this Section 2.1 ("Initial Writer Grant") are effective on the date Initial Writer first distributes Original Documentation under the terms of this License.

2.2. Contributor Grant.

Each Contributor hereby grants You a world-wide, royalty-free, non-exclusive license to use, reproduce, prepare Modifications of, compile, publicly perform, publicly display, demonstrate, market, disclose and distribute the Documentation in any form, on any media or via any Electronic Distribution Mechanism or other method now known or later discovered, and to sublicense the foregoing rights to third parties through multiple tiers of sublicensees in accordance with the terms of this License. 

The license rights granted in this Section 2.2 ("Contributor Grant") are effective on the date Contributor first makes Commercial Use of the Documentation.

3.0 DISTRIBUTION OBLIGATIONS.

3.1. Application of License.

The Modifications which You create or to which You contribute are governed by the terms of this License, including without limitation Section 2.2 ("Contributor Grant").  The Documentation may be distributed only under the terms of this License or a future version of this License released in accordance with Section 5.0 ("Versions of the License"), and You must include a copy of this License with every copy of the Documentation You distribute. You may not offer or impose any terms that alter or restrict the applicable version of this License or the recipients' rights hereunder. However, You may include an additional document offering the additional rights described in Section 3.5 ("Required Notices").

3.2. Availability of Documentation.

Any Modification which You create or to which You contribute must be made available publicly in Editable Form under the terms of this License via a fixed medium or an accepted Electronic Distribution Mechanism.

3.3. Description of Modifications.

All Documentation to which You contribute must identify the changes You made to create that Documentation and the date of any change. You must include a prominent statement that the Modification is derived, directly or indirectly, from Original Documentation provided by the Initial Writer and include the name of the Initial Writer in the Documentation or via an electronic link that describes the origin or ownership of the Documentation.  The foregoing change documentation may be created by using an electronic program that automatically tracks changes to the Documentation, and such changes must be available publicly for at least five years following release of the changed Documentation.

3.4. Intellectual Property Matters.

Contributor represents that Contributor believes that Contributor's Modifications are Contributor's original creation(s) and/or Contributor has sufficient rights to grant the rights conveyed by this License.

3.5. Required Notices.

You must duplicate the notice in the Appendix in each file of the Documentation. If it is not possible to put such notice in a particular Documentation file due to its structure, then You must include such notice in a location (such as a relevant directory) where a reader would be likely to look for such a notice, for example, via a hyperlink in each file of the Documentation that takes the reader to a page that describes the origin and ownership of the Documentation.  If You created one or more Modification(s) You may add your name as a Contributor to the notice described in the Appendix.

You must also duplicate this License in any Documentation file (or with a hyperlink in each file of the Documentation) where You describe recipients' rights or ownership rights.

You may choose to offer, and to charge a fee for, warranty, support, indemnity or liability obligations to one or more recipients of Documentation. However, You may do so only on Your own behalf, and not on behalf of the Initial Writer or any Contributor. You must make it absolutely clear than any such warranty, support, indemnity or liability obligation is offered by You alone, and You hereby agree to indemnify the Initial Writer and every Contributor for any liability incurred by the Initial Writer or such Contributor as a result of warranty, support, indemnity or liability terms You offer.

3.6.  Larger Works.

You may create a Larger Work by combining Documentation with other documents not governed by the terms of this License and distribute the Larger Work as a single product. In such a case, You must make sure the requirements of this License are fulfilled for the Documentation.

4.0  APPLICATION OF THIS LICENSE.

This License applies to Documentation to which the Initial Writer has attached this License and the notice in the Appendix.

5.0  VERSIONS OF THE LICENSE.

5.1. New Versions.

Initial Writer may publish revised and/or new versions of the License from time to time. Each version will be given a distinguishing version number.

5.2. Effect of New Versions.

Once Documentation has been published under a particular version of the License, You may always continue to use it under the terms of that version. You may also choose to use such Documentation under the terms of any subsequent version of the License published by______________________ [Insert name of the foundation, company, Initial Writer, or whoever may modify this License]. No one other than ________________________[Insert name of the foundation, company, Initial Writer, or whoever may modify this License] has the right to modify the terms of this License. Filling in the name of the Initial Writer, Original Documentation or Contributor in the notice described in the Appendix shall not be deemed to be Modifications of this License.

6.0 DISCLAIMER OF WARRANTY.

DOCUMENTATION IS PROVIDED UNDER THIS LICENSE ON AN "AS IS'' BASIS, WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE DOCUMENTATION IS FREE OF DEFECTS, MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE OR NON-INFRINGING. THE ENTIRE RISK AS TO THE QUALITY, ACCURACY, AND PERFORMANCE OF THE DOCUMENTATION IS WITH YOU. SHOULD ANY DOCUMENTATION PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL WRITER OR ANY OTHER CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY DOCUMENTATION IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.

7.0 TERMINATION.

This License and the rights granted hereunder will terminate automatically if You fail to comply with terms herein and fail to cure such breach within 30 days of becoming aware of the breach. All sublicenses to the Documentation which are properly granted shall survive any termination of this License. Provisions which, by their nature, must remain in effect beyond the termination of this License shall survive.

8.0 LIMITATION OF LIABILITY.

UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER IN TORT (INCLUDING NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL THE INITIAL WRITER, ANY OTHER CONTRIBUTOR, OR ANY DISTRIBUTOR OF DOCUMENTATION, OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER DAMAGES OR LOSSES ARISING OUT OF OR RELATING TO THE USE OF THE DOCUMENTATION, EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES.

9.0 U.S. GOVERNMENT END USERS.

If Documentation is being acquired by or on behalf of the U.S. Government or by a U.S. Government prime contractor or subcontractor (at any tier), then the Government's rights in Documentation will be only as set forth in this Agreement; this is in accordance with 48 CFR 227.7201 through 227.7202-4 (for Department of Defense (DOD) acquisitions) and with 48 CFR 2.101 and 12.212 (for non-DOD acquisitions).

10.0 MISCELLANEOUS.

This License represents the complete agreement concerning the subject matter hereof. If any provision of this License is held to be unenforceable, such provision shall be reformed only to the extent necessary to make it enforceable. This License shall be governed by California law, excluding its conflict-of-law provisions. With respect to disputes or any litigation relating to this License, the losing party is responsible for costs, including without limitation, court costs and reasonable attorneys' fees and expenses. The application of the United Nations Convention on Contracts for the International Sale of Goods is expressly excluded. Any law or regulation which provides that the language of a contract shall be construed against the drafter shall not apply to this License.

Appendix

Public Documentation License Notice

The contents of this Documentation are subject to the Public Documentation License Version 1.0 (the "License"); you may only use this Documentation if you comply with the terms of this License. A copy of the License is available at http://www.openoffice.org/licenses/PDL.rtf.

The Original Documentation is _________________. The Initial Writer of the Original Documentation is ______________________ (C) ____. All Rights Reserved. (Initial Writer contact(s):_______________[Insert hyperlink/alias].)

Contributor(s): ______________________________________.

Portions created by ______ are Copyright (C)_________[Insert year(s)]. All Rights Reserved.   (Contributor contact(s):________________[Insert hyperlink/alias]).

Note: The text of this Appendix may differ slightly from the text of the notices in the files of the Original Documentation. You should use the text of this Appendix rather than the text found in the Original Documentation for Your Modifications.



Apache Software Foundation

Copyright & License | Privacy | Website Feedback | Contact Us | Donate | Thanks

Apache, the Apache feather logo, and OpenOffice are trademarks of The Apache Software Foundation. OpenOffice.org and the seagull logo are registered trademarks of The Apache Software Foundation. Other names appearing on the site may be trademarks of their respective owners.