Deutsch:

Die freie und offene Büro-Software
Apache OpenOffice 4.1.1 ist verfügbar!

Häufig gestellte Fragen zur Tabellenkalkulation CALC

Fragen

  1. Die Funktion SVERWEIS bringt in CALC nicht die erwarteten Ergebnisse
  2. Die Seitenansicht zeigt keine Seite an
  3. Wie öffne ich eine Datei, in der als Feldbegrenzer Tab-Stopps (Tabulatoren) eingegeben sind? Was passiert, wenn ich andere Feldbegrenzer habe (z.B. Anführungszeichen)?
  4. Ich sehe "###" in einer Zelle, die vorher Daten enthielt. Wie mache ich meine Daten wieder sichtbar?
  5. Wie kann ich dafür sorgen, dass ein Text in einer Zelle umgebrochen wird?
  6. Wie wähle ich eine oder mehrere Zeilen meiner Tabelle, die auf jeder Seite wiederholt werden sollen?
  7. Ich möchte in der Tabelle keine Großbuchstaben am Anfang eines Satzes. Was soll ich tun?
  8. Ich arbeite mit einer ziemlich großen Tabelle. Gibt es eine Möglichkeit die Spaltenüberschriften und die Zeilenbezeichnungen sichtbar zu lassen, wenn ich mich in der Tabelle nach unten und nach rechts bewege?
    1. Fixierung einer Zeile oder/und Spalte
    2. Tabellenfenster teilen
  9. Wie drucke ich meine Tabelle(n) richtig?
    1. Anpassung anhand der Seitenansicht
    2. Anpassung anhand der Seitenumbruch-Vorschau
  10. Wie kann ich in meiner Tabellenkalkulation eine lange Titel-Zelle über mehrere Spalten erweitern?
  11. Wie drehe ich einen Spalten-Titel, damit er schräg oder senkrecht gestapelt über meiner sehr schmalen Spalte sitzt?
  12. Wie erzeuge ich ein Diagramm, das automatisch auf dem neuesten Stand ist, wenn sich die Daten ändern?
  13. Wie schütze ich Zellen oder eine Tabelle in meiner Tabellenkalkulation gegen Änderungen?
    1. Eine ganze Tabelle schützen
    2. Einzelne Zellen oder Zellbereiche schützen
  14. Wie speichere ich Tabellendaten als CSV (Textformat)?
  15. Einige von den Zeilen/Spalten in meinem Tabellenblatt sind versteckt. Wie kann ich diese wieder sichtbar machen?
  16. Wie formatiere ich Zellen in einer OOo Tabellenkalkulation so, dass die Zeilennummern automatisch erscheinen?
  17. Kann ich reguläre Ausdrücke (Wildcards) verwenden, die sowohl von Excel® als auch von CALC verstanden werden?
  18. Wie kann ich verhindern, das CALC ein Datum bei der Eingabe 1/2 als ½ darstellt?
  19. Wie kann ich Variablen bei Formeln verwenden?
  20. Wie berechne ich Zeitabstände so, dass sie sowohl von CALC als auch von Excel® verwendet werden können?
  21. Wie bekomme ich ein berechnetes Datum in einen Text eingebunden?
  22. Wo erhalte ich weitere Hilfe?

Antworten

1. Die Funktion SVERWEIS bringt in CALC nicht die erwarteten Ergebnisse

Wenn bei der Funktion SVERWEIS (Suchkriterium; Matrix; Index; Sortiert) das Argument Sortiert nicht angegeben ist, muss die Matrix sortiert sein; d.h. ein fehlendes Argument Sortiert wird als WAHR interpretiert.

Wenn das Argument Sortiert bei unsortierten Listen nicht auf FALSCH gesetzt ist (oder fehlt), tritt ein Fehler auf. Dies passiert häufig bei der Übernahme von Dokumenten aus Excel und älteren OpenOffice.org-Versionen.

nach oben

2. Die Seitenansicht zeigt keine Seite an

Löschen Sie unter Format > Druckbereiche... > Entfernen den/die Druckbereich(e). Daraufhin wird auch in der Seitenansicht wieder alles angezeigt.

nach oben

3. Wie öffne ich eine Datei, in der als Feldbegrenzer Tab-Stopps (Tabulatoren) eingegeben sind? Was passiert, wenn ich andere Feldbegrenzer habe (z.B. Anführungszeichen)?

Wenn die CSV-Datei noch nicht die Endnung .txt (oder .csv) hat, so benennen Sie die Datei bitte zunächst entsprechend um.

Weiterlesen: Für eine detailliertere Beschreibung empfehlen wir Ihnen das OpenOffice.org-Wiki.

nach oben

4. Ich sehe "###" in einer Zelle, die vorher Daten enthielt. Wie mache ich meine Daten wieder sichtbar?

Wenn der Inhalt einer Zelle die angezeigte Breite der Spalte überschreitet, wird statt dessen "###" angezeigt. Die Zahl hat also mehr Stellen, als in der Spaltenbreite angezeigt werden können. Wenn man die Zahl sehen will, muss man die Spaltenbreite verändern:

Bewegen Sie den Mauszeiger im Spaltenkopf in den rechten Zwischenraum der zu vergrößernden Spalte und der angrenzenden Spalte. Beispiel: Spalte A ist zu schmal. Bewegen Sie die Maus im Spaltenkopf (grauer Bereich mit Anzeigen der Spalten A, B, C...) zwischen Spalte A und B. Sie werden sehen, dass der Mauszeiger sein Aussehen verändert. Von einem Zeiger wird er genau auf der Trennung zwischen zwei Spalten zu einem Pfeil, der nach zwei Seiten zeigt. Damit können Sie Breite der Spalte links davon verändern. Halten Sie die linken Maustaste und ziehen Sie die Spalte nach links bis die Zahlen unten in der Spalte sichtbar werden.

Tipp: Ein Doppelklick auf diesen Bereich stellt automatisch die optimale Spaltenbreite ein; d.h. die Spalte wird so weit verbreitert, wie es die breiteste Zelle in der Spalte benötigt.

Wenn der Zellinhalt ein Text ist, dann sehen Sie am rechten Rand der Zelle ein kleines rotes Dreieck (statt wie bei Zahlen "###"). Dies weist darauf hin, dass sich in der Zelle noch Text befindet, den Sie in der aktuellen Darstellung nicht sehen können.

nach oben

5. Wie kann ich dafür sorgen, dass ein Text in einer Zelle umgebrochen wird?

Wählen Sie:

Wenn Sie einen festen Zeilenumbruch an einer bestimmten Stelle im Text erzeugen wollen, bewegen Sie Ihren Cursor an diese Stelle innerhalb des Textes und betätigen Sie die Tastenkombination Strg+Enter. Wenn Sie einen Zeilenumbruch in einem schon bestehenden Text einfügen wollen, führen Sie einen Doppelklick auf die Zelle aus, um den Text bearbeiten zu können, und geben Sie dann Strg+Enter ein.

nach oben

6. Wie wähle ich eine oder mehrere Zeilen meiner Tabelle, die auf jeder Seite wiederholt werden sollen?

Führen Sie folgende Schritte aus:

  1. Markieren Sie die Zeile(n), die wiederholt werden soll(en). (Maus auf die Zeilennummer(n) am linken Rand!)
  2. Dann wählen Sie: Einfügen > Namen > Festlegen
  3. Es erscheint der Dialog Namen festlegen. Dort geben Sie Ihrer Auswahl eine Namen, z.B. "meineKopfzeilen". Dieser Name darf keine Leerzeichen enthalten!
  4. Klicken Sie auf Zusätze.
  5. In Bereichsart aktivieren Sie Wiederholungszeile.
  6. Klicken Sie auf Hinzufügen.
  7. Klicken Sie auf OK.
  8. Wählen Sie nun aus dem Menü Format > Druckbereiche > Bearbeiten.
  9. Aus dem Listenfeld Wiederholungszeile wählen Sie "meineKopfzeilen" (oder wie auch immer Sie den markierten Bereich zuvor genannt haben).
  10. Klicken Sie OK.

Tipp: Wählen Sie zunächst einmal aus dem Listenfeld Druckbereich "Keiner", damit Sie erkennen, wie Ihre Seiten insgesamt aussehen würden. Machen Sie sich mit dem Begriff "Druckbereich" vertraut. Danach wählen Sie den Bereich, den sie tatsächlich drucken wollen.

Wenn Sie nun drucken, werden diese Kopfzeilen auf jeder Seite wiederholt. Sie sehen diese Veränderungen nicht am normalen Bildschirm! Benutzen Sie Datei > Seitenansicht um das Druckbild vor dem Drucken zu sehen. Beachten Sie bitte, dass bei dem Schritt Wiederholungszeile eine Eingabe in der Form $1:$3 erlaubt ist. Dies bedeutet, dass die Zeilen 1 bis 3 auf jeder Seite wiederholt werden.

Weiterlesen: Für eine detailliertere Beschreibung empfehlen wir Ihnen dasOpenOffice.org-Wiki.

nach oben

7. Ich möchte in der Tabelle keine Großbuchstaben am Anfang eines Satzes. Was soll ich tun?

Führen Sie folgende Schritte aus:

  1. Rufen Sie den Dialog Extras > Autokorrektur, Register Optionen auf.
  2. Deaktivieren der Option Jeden Satz mit einem Großbuchstaben beginnen.
  3. Beenden Sie den Dialog mit einem Klick auf OK.
nach oben

8. Ich arbeite mit einer ziemlich großen Tabelle. Gibt es eine Möglichkeit die Spaltenüberschriften und die Zeilenbezeichnungen sichtbar zu lassen, wenn ich mich in der Tabelle nach unten und nach rechts bewege?

Sie haben zwei Möglichkeiten um das gewünschte Resultat zu erzielen:

nach oben

8.1 Fixierung einer Zeile oder/und Spalte

Tipp: Wenn Sie gleichzeitig Zeilen und Spalten fixieren wollen, wählen Sie die obere linke Ecke, die nicht fixiert werden soll, und wählen dann Fenster > Fixieren. Wenn Sie also beispielsweise nur die oberste Zeile (Zeile 1) und gleichzeitig die erste Spalte (Spalte A) fixieren wollen, klicken Sie in die Zelle B2 und fixieren dann. nach oben

8.2 Tabellenfenster teilen

Es ist aber auch noch möglich, das Tabellenfenster auf eine andere Art zu teilen: Ganz oben am rechten Scrollbalken (über dem Pfeil) sehen sie eine kleine schwarze Linie. Wenn Sie den Mauszeiger über diese kleine schwarze Linie führen, bemerken Sie, dass sich der Mauszeiger verändert (Doppelstrich mit einem Pfeil nach oben und unten). Wenn der Mauszeiger sich verändert, klicken und ziehen Sie mit linken Maustaste eine waagrechte Tabellenteilung. Die senkrechte Teilung erreichen Sie an der Stelle des unteren Scrollbalkens rechts.

nach oben

9. Wie drucke ich meine Tabelle(n) richtig?

Der beste Weg eine große Tabellenkalkulation auszudrucken, ist zunächst eine Vorschau des Ausdrucks aufzurufen und dann die Druckeinstellungen so anzupassen, dass man zu einem wirkungsvollem Ergebnis gelangt:

nach oben

9.1 Anpassung anhand der Seitenansicht

nach oben

9.2 Anpassung anhand der Seitenumbruch-Vorschau

Hinweis: Wenn in der Seitenumbruch-Vorschau alles grau erscheint, bedeutet das, dass kein Druckbereich festgelegt ist. Wenn ein Druckbereich festgelegt ist, wird der Druckbereich mit einen weißen Hintergrund und mit einen blauen Umriss erscheinen. Ein graues Seite N, wobei "N" die Seitenfolge für die Tabelle ist, wird in der Mitte des Druckbereiches erscheinen. Wenn kein Bereich zum Drucken festgelegt ist, ziehen Sie einfach mit der Maus aus der linken oberen Ecke des Bereiches, der ausgedruckt werden soll, mit der Maus den Bereich auf, der gedruckt werden soll.

nach oben

10. Wie kann ich in meiner Tabellenkalkulation eine lange Titel-Zelle über mehrere Spalten erweitern?

Folgen Sie diesen Anweisungen:

Oft soll der Text im Titelbereich zentriert werden. Dies erreichen Sie folgendermaßen: nach oben

11. Wie drehe ich einen Spalten-Titel, damit er schräg oder senkrecht gestapelt über meiner sehr schmalen Spalte sitzt?

nach oben

12. Wie erzeuge ich ein Diagramm, das automatisch auf dem neuesten Stand ist, wenn sich die Daten ändern?

Beachten Sie: Das ist eine allgemeine Einstellung und wird für alle Diagramme in der Tabelle übernommen. Ist dies nicht erwünscht, dann kann man die Aktualisierung auf Auf Nachfrage einstellen.

nach oben

13. Wie schütze ich Zellen oder eine Tabelle in meiner Tabellenkalkulation gegen Änderungen?

Der Zellenschutz ist zunächst einmal für alle Zellen standardmäßigen aktiv.

nach oben

13.1 Eine ganze Tabelle schützen

Um das ganze Tabellenblatt gegen unerwünschte Änderungen zu schützen, wählen Sie Extras > Dokument schützen > Tabelle.... Danach können Sie ein Kennwort eingeben, das nochmals bestätigt werden muss. Ihre Tabelle kann nun nicht mehr von Unbefugten verändert werden. Möchten Sie selbst Änderungen an der Tabelle vornehmen, müssen Sie den Schutz zunächst deaktivieren. Dies erfolgt in der gleichen Reihenfolge über Extras > Dokument schützen. Der Menüpunkt Tabelle... hat nun ein Häkchen davor, was bedeutet, dass die Tabelle geschützt ist. Klicken Sie darauf und geben das festgelegte Kennwort ein, bestätigen es nochmals und die Tabelle ist wieder editierbar.

nach oben

13.2 Einzelne Zellen oder Zellbereiche schützen

Falls Sie nur einzelne Zellen schützen möchten, müssen Sie zunächst den Zellschütz für alle Zellen der Tabelle deaktivieren.

nach oben

14 Wie speichere ich Tabellendaten als CSV (Textformat)?

nach oben

15. Einige von den Zeilen/Spalten in meinem Tabellenblatt sind versteckt. Wie kann ich diese wieder sichtbar machen?

Mit dem Einblenden-Befehl kann man Zeilen oder Spalten in einem Tabellenblatt wieder einblenden. Ob Zeilen oder Spalten ausgeblendet sind, sehen Sie daran, dass Zeilen oder Spalten nicht fortlaufend durch Zahlen/Buchstaben benannt sind. Um Spalten einzublenden markieren Sie die Spalte vor und nach der ausgeblendeten Spalte. Beispiel: Spalte D ist ausgeblendet. Sie erkennen es daran, dass die Spaltenköpfe die Bezeichnung A | B | C | E | zeigen.

Um Zeilen einzublenden gehen Sie analog vor, indem Sie die Zeilenköpfe auf der linken Seite der Tabelle vor und nach der ausgeblendeten Zeile markieren. Sie können auch alle ausgeblendeten Spalten und Zeilen auf einmal einblenden:

nach oben

16. Wie formatiere ich Zellen in einer OOo Tabellenkalkulation so, dass die Zeilennummern automatisch erscheinen?

Eine Möglichkeit (dieses Beispiel nimmt an, dass Sie Ihre erste Nummer in die Zelle A1 schreiben):

  1. Geben Sie die Formel "=ZEILE(A1)" in die Zelle A1 ein und drücken die Eingabetaste.
  2. Markieren Sie die Zelle erneut, indem Sie die Zelle anklicken.
  3. Die Zelle erhält einen Rahmen und im unteren, rechten Eck ein kleines Quadrat.
  4. Wenn Sie die dieses Quadrat mit der linken Maustaste anfassen und nach unten ziehen, wird die Formel nach unten kopiert und angepasst.
    Aus der Formel "=ZEILE(A1)" wird in Zelle A2 "=ZEILE(A2)" usw.

Sie können bei Bedarf die Nummerierung erweitern, indem Sie die letzte nummerierte Zelle anfassen und weiter nach unten ziehen wie unter 4 beschrieben.

nach oben

17. Kann ich reguläre Ausdrücke (Wildcards) verwenden, die sowohl von Excel® als auch von CALC verstanden werden?

Um in CALC reguläre Ausdrücke zu verwenden, muß unter Extras > Optionen > OpenOffice.org CALC > Berechnen die Option Reguläre Ausdrücke in Formeln ermöglichen eingeschaltet sein.

(Diese Einstellung ist normalerweise bei der Installation vorhanden).

Bei Excel® werden die Wildcards "*" bzw. "?" verwendet. Bei CALC werden dafür reguläre Ausdrücke wie ".*" oder ".?" verwendet. Dies ist notwendig, da CALC sehr differenzierte reguläre Ausdrücke ermöglicht.
Da diese beiden Darstellungen nicht kompatibel sind, können reguläre Ausdrücke nicht in Excel® und in CALC verwendet werden. Dies muss bei den Formeln berücksichtigt werden.

Ein Beispiel, für eine Formel, bei der ursprünglich reguläre Ausdrücken verwendet wurden:
Die Formel zählt alle Zellen, in denen der Buchstabe "G" vorkommt.

Original:

Neu:

Die Formeln müssen als Matrixformeln markiert werden.

nach oben

18. Wie kann ich verhindern, das CALC ein Datum bei der Eingabe 1/2 als ½ darstellt?

nach oben

19. Wie kann ich Variablen bei Formeln verwenden?

  1. Der gewünschte Wert wird in eine Zelle geschrieben. z.Bsp ''xxx'' in die Zelle ''A1''
  2. Die Zelladresse wird in der Formel an Stelle des Werts verwendet. z.Bsp. "=FINDEN(A1;D4)" (sucht xxx in der Zelle D4)

Tipp: Damit leichter verständlich wird, was die Variable bedeuten soll, kann man der Zelle, die die Variable enthält, einen Namen geben.
Im Beispiel: SUCH als Name für A1, die Formel lautet dann: "=FINDEN(SUCH;D4)"
Dies hilft auch später die Zelle wieder zu finden, in der die Variable steht, falls der Wert verändert werden soll.

nach oben

20. Wie berechne ich Zeitabstände so, dass sie sowohl von CALC als auch von Excel® verwendet werden können?

(Heute() wird von B11 abgezogen)
normale Zeitabstandsberechnung in Calc:

kompatible Zeitabstandsberechnung:

nach oben

21. Wie bekomme ich ein berechnetes Datum in einen Text eingebunden?

Eine einfache Verknüpfung wie "="Starttext: " & (B1+14) & " :Endtext"" führt zu: "Starttext: 39747 :Endtext"
Um das Datum als Datum anzuzeigen, muss das Datum formatiert werden: "="Starttext: " & TEXT(B1+14;"tt.mm.jjjj") & " :Endtext"" führt zu "Starttext: 26.10.2008 :Endtext"

nach oben

22. Wo erhalte ich weitere Hilfe?

Sollten Sie Ihr Problem mit den Hilfen auf dieser Seite nicht lösen können und benötigen Sie deshalb persönliche Hilfe, so wenden Sie sich mit Ihrer Frage am einfachsten an die Users-Mailingliste. Informationen zum An- und Abmelden erhalten Sie unter http://de.openoffice.org/probleme.html.
Möglicherweise finden Sie aber die Lösung Ihres Problems auch in der Dokumentation, in den Foren oder unter www.ooowiki.de.

nach oben

 

zurück zur Dokumentations-Hauptseite | zurück zur Übersichtsseite der deutschsprachigen FAQs

Valid XHTML 1.0 Transitional

Apache Software Foundation

Apache Software Foundation

Copyright & License | Privacy | Website Feedback | Contact Us | Donate | Thanks

Apache, the Apache feather logo, and OpenOffice are trademarks of The Apache Software Foundation. OpenOffice.org and the seagull logo are registered trademarks of The Apache Software Foundation. Other names appearing on the site may be trademarks of their respective owners.