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What is Draw?

Draw is a vector graphics drawing program. It offers a series of
powerful tools that enable you to quickly create all sorts of graphics.
Vector graphics store and display an image as vectors (two points and
a line) rather than a collections of pixels (dots on the screen). Vector
graphics allow for easier storage and scaling of the image.

Draw is perfectly integrated into the OpenOffice.org suite, and this
makes exchanging graphics with all components of the suite very easy.
For example, if you create an image in Draw, reusing it in a Writer
document is as simple as copying and pasting. You can also work with
drawings directly from within Writer and Impress, using a subset of the
functions and tools from Draw.

Draw’s functionality is very extensive and complete. Although it was
not designed to rival high-end graphics applications, Draw possesses
more functions than the majority of drawing tools that are integrated
into office productivity suites.

A few examples of drawing functions might whet your appetite: layer
management, magnetic grid point system, dimensions and
measurement display, connectors for making organization charts, 3D
functions enabling small three-dimensional drawings to be created
(with texture and lighting effects), drawing and page style integration,
and Bézier curves, to name a few.

This chapter introduces some of Draw’s features, but it does not
attempt to cover all of the them. See the Draw Guide and the
application Help for more information.

The Draw workspace

The main components of the Draw workspace are shown in Figure 1.

You can surround the drawing area with toolbars and information
areas. The number and position of the visible tools vary with the task
at hand or user preferences. Therefore, your setup may appear a little
different. For example, many people put the main Drawing toolbar on
the left-hand side of the workspace, not at the bottom as shown here.

You can split drawings in Draw over several pages. Multipage drawings
are used mainly for presentations. The Pages pane, on the left side of
the Draw window in Figure 1 gives an overview of the pages that you
create. If the Pages pane is not visible on your setup,you can enable it
from the View menu (View > Page Pane).

The Draw workspace 5
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Figure 1. Initial Draw window

Rulers

You should see rulers (bars with T () PR SRR SR
numbers) on the upper and left-hand
side of the workspace. These show
the size of a selected object on the
page (see the gray double lines,
highlighted in Figure 2). When no :
object is selected, they show the :;
location of the mouse pointer, which '
helps to accurately position drawing Figure 2: Rulers show the size
objects. You can also use the rulers to 0f the selected object

manage object handles and guide lines, making it easier to position
objects. The page margins in the drawing area are also represented on
the rulers. You can change the margins directly on the rulers by
dragging them with the mouse.

=
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To modify the units of measurement of S T T e e

Millimeter —_—

the rulers, right-click on one of the Centimeter
rulers. The two rulers can have different : Meter
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units. . e
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é Mileg
Point

Pica

in

Fjgure 3. Ruler units

Status bar

The Status bar is located at the bottom of the workspace. The middle
part of the Status bar shows Draw-specific fields, as identified in
Figure 4.

For details on the contents and use of these fields, please refer to the
Draw Guide.

The sizes are given in the current measurement unit (not to be
confused with the ruler units). This unit is defined in Tools >
Note Options > OpenOffice.org Draw > General, where you can
also change the scale of the page. Another way to change the
scale is to double-click on the number shown in the status bar.

Rk
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Figure 4: Items on the Draw status bar

Toolbars

The various Draw toolbars can be displayed or hidden according to
your needs.

To display or hide the toolbars, click View > Toolbars. On the menu
that appears, choose which toolbars you want to display.
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You can also select the buttons that you wish to appear on the
corresponding toolbar. On the View > Toolbars menu, select
Customize, click on the Toolbars tab, select the toolbar you want to
change, and then select the desired buttons for that toolbar.

Many toolbar buttons are marked with a small arrow beside the button.
The arrow indicates that this button has additional functions. Click the
arrow and a submenu or toolbar appears, showing its additional
functions (see Figure 5). Most buttons marked with the small arrow
can become floating toolbars.

To make a submenu into a floating toolbar, click the area at the top of
the submenu, drag it across the screen, and then release the mouse
button. Floating toolbars can be docked on an edge of the screen or
within one of the existing toolbar areas at the top of the screen, as
described in Chapter 1.

Click here and drag
to float the toolbar

i
Figure 5. An arrow next to a button
Iindicates additional functions

Click the arrow on the title bar of a floating toolbar to display
additional functions (see Figure 6).

Loom @ =
¥ Visible Buttons k| '-'!'l_‘ Zoom In
® Q@RS
Customize Toolbar... |« 'E:\LJ Zoom Out
Dock Toolbar W e Zoom 100%
Dock All Toolbars g_ﬁ" Zoom Previous
Lﬁ’ * Zoom Mext
« ‘7 Zoom Page
Close Toolbar — 2
w L:J\. Zoom Page Width
vy _l‘h{ Optimal
« f7h  Object Zoom
w My Shift

Figure 6. An arrow on a floating toolbar indicates
additional functions
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The tools available in the various toolbars are explained in the
following sections. The appearance of the toolbar icons may vary with
your operating system and the selection of icon size and style in Tools
> Options > OpenOffice.org > View.

Standard toolbar
The Standard toolbar looks like this:

‘8 H = B & V| & - 28 @R-1 3D,
It is the same for all parts of OpenOffice.org.

Line and Filling toolbar
The Line and Filling toolbar lets you modify the main properties of a
drawing object. See page 28 for details.

A O = v!| oo 2| EEEak  v| & lcdor v |EHEwer v| O

If the selected object is text, the toolbar changes to the one shown
below, which is similar to the Formatting toolbar in Writer.

A= =
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Drawing toolbar

The Drawing toolbar is the most important toolbar in Draw. It contains
all the necessary functions for drawing various geometric and freehand
shapes and organizing them on the page.

K/ ome[T| 2 % 0O @ OO Rk K MREIG -

Color Bar
To display the Color Bar, use View > Toolbars > Color Bar. The
toolbar then appears at the bottom of the workspace.

AAREEEEREN . [ ] EEN SEEENEEEEEENEEEEEEEEEEN
SEEEER u EEEEEER O ECEEN

This toolbar lets you rapidly choose the color of the objects in your
drawing. The first box in the panel corresponds to transparency (no
color).

You can access several specialized color palettes in Draw, as well as
change individual colors to your own taste. This is done using the Area
dialog, reached by choosing Format > Area or the pouring can icon on
the Line and Filling toolbar.

On the Area dialog, choose the tab marked Colors.
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Figure 7. Changing the color palette

To load another palette, click on the Load Color List button (circled).
The file selector dialog asks you to choose one of the standard OOo
palettes (files bearing the file extension *.soc). For example, web.soc
is a color palette that is adapted to creating drawings that are going to
appear in Web pages. The colors will correctly display on workstations
with screens displaying at least 256 colors.

The color selection box also lets you individually change any color by
modifying the numerical values in the fields provided to the right of the
color palette. You can use the color schemes known as CMYK (Cyan,
Magenta, Yellow, Black), RGB (Red, Green, Blue) or HSB (Hue,
Saturation, Brightness).

Clicking on the Edit button opens a special dialog to allow setting
individual colors (see Figure 8). Many more input possibilities are
available in this dialog.

In the lower area you can enter values in the RGB and CMYK models
as well as the HSB (Hue, Saturation and Brightness) model.

The two color fields at lower right show the value of the color as
selected (left) and the currently set value from the color value fields
(right).

For a more detailed description of color palettes and their options, see
Chapter 8 (Tips and Tricks) in the Draw Guide.
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Figure 8. Defining color schemes

Options toolbar

The Options toolbar lets you activate or deactivate various drawing
aids. The Options toolbar is not displayed by default. To display it,
select View > Toolbars > Options. The most important options to
learn when starting to work in Draw are enclosed in red. The functions
of the various icons are described in Table 1.

o & 4 #
|| O/ o S8 5o
Figure 9: Options toolbar

Table 1: Functions on the Options toolbar

Icon Function

ﬁ‘} Rotation mode after clicking object

- Display (or hide) the grid

+ Display (or hide) the guides

o Display (or hide) guides when moving

e Snap to grid

40 Snap to guides

ﬁ" Snap to page margins
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Icon Function

uh Snap to object borders
IZE" Snap to object points

ABC Allow quick editing

FEC Select text area only
Double-click to edit text
] Simple handles

T1 Large handles

& Create object with attributes
Picture placeholders
o Contour mode

om Text placeholders

EI:'_'_'_; Line contour only

Ead Exit all groups

Positioning objects with snap functions

In Draw, objects can be positioned to grid points, to special snap points
and lines, to object frames, to single object points, or to page edges.
This function is known as Snap. In this manner objects can be very
accurately positioned in a drawing.

If you want to use the snap function, it is much easier to work with the
highest practical zoom value. It is possible to use two different snap
functions at the same time, for example snap to a guide line and to the
page edge. It is best, however, to activate only those functions that you
really need.

This section describes the snap-to-grid function. For more information
about this and the other snap functions, see Chapter 8 (Tips and
Tricks) and Chapter 10 (Advanced Draw Techniques) in the Draw
Guide.
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Snap to grid

Use this function to move an object exactly to a grid point (see Figure
10). This function can be switched on and off with View > Grid >

Figure 10: With snap to grid,
objects align to the grid precisely.

Showing the grid

Make the grid visible under View > Grid > Display Grid.
Alternatively turn the grid on and off with the icon  on the Options
toolbar.

Configuring the grid

The color, spacing, and resolution of the grid points can be individually
chosen for each axis.The spacing between the lines is defined in the
Grid options dialog under the Drawing area of the OOo options (Tools
> Options > OpenOffice.org Draw > Grid). In the dialog shown in
Figure 11, you can set the following parameters:

« Vertical and horizontal spacing of the dots in the grid. You can
also change the unit of measurement used in the general Draw
options (Tools > Options > OpenOffice.org Draw > General).

« The resolution is the size of the squares or rectangles in the grid.
If the resolution is Horizontal 1cm, Vertical 2cm, the grid consists
of rectangles 2cm high and 1cm wide.

« Subdivisions are additional points that appear along the sides of
each rectangle or square in the grid. Objects snap to subdivisions
as well as to the corners of the grid.

« The pixel (pix element) size of the snap area defines how close

you need to bring an object to a snap point or line before it will
snap to it.

Positioning objects with snap functions 13



Grid
Snap to grid

i

Resolution Subdivision
Horizontal 0.50cm = Haorizontal 10 % point(s)
Vertical 0.50cm = Vertical 10 % point(s)
[] Synchronize axes

Snap Snap position
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Figure 11. Setting grid options

Changing the color of the grid points

The default grid dots are light gray, which can be hard to see. To
improve visibility, go to Tools > Options, then OpenOffice.org >
Appearance (Figure 12).

Color scheme

Scheme OpenOffice.org - Save...

Custom colors

On [User interface elements ‘Color setting |Preview |
MNULES dLRYTUOrma Autﬂmai‘Jc -

Drawing / Presentation

Grid - Black -

Basic Syntax Highlighting

I

Identifier [ | Automatic |~
Comment [ | Automatic |~
Number [ | Automatic |~
string [ | Automatic |~
Operator [T 1 Automatic |~ 3

Figure 12: Changing the grid color
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In the Drawing / Presentation section, you can change the color of the
grid points. On the Color Settings pulldown menu, select a more
suitable/visible color, for example black.

Positioning objects with helper lines

To simplify the positioning of objects it is possible to make visible
guiding lines—extensions of the edges of the object—while it is being
moved. These guiding lines have no snap function.

The guiding lines can be (de-)activated under Tools > Options >
OpenOffice.org Draw > View > Guides when moving, or by
clicking on the —jicon on the Options toolbar.

The basic drawing shapes

Draw provides a wide range of shapes, located in palettes accessed
from the Drawing Toolbar. This chapter describes only a few of the
basic shapes; see the Draw Guide for a complete description of the
shapes available. These shapes include rectangles and squares; circles,
ellipses, and arcs; 3D objects; curves; lines and arrows; text; and
connectors.

When you draw a basic shape or select one for editing, the Info field in
the status bar changes to reflect the action taken: Line created, Text
frame xxyy selected, and so on.

Figure 13 shows part of the Drawing toolbar with the icons needed in
the following sections. The Texticon is also included.

R/ =@ T|2-*%-—-
Figure 13: Part of the Drawing toolbar

Drawing a straight line

Let’s start by drawing the simplest of shapes: a straight line. Click on
the Line icon ~~ on the Drawing Toolbar and place the mouse pointer
where you want to start the line. Drag the mouse while keeping the
button pressed. Release the mouse button when you want to end the
line.

A blue or green selection handle appears at each end of the line,
showing that this is the currently selected object. The colors depend on
the selection mode (green for simple selection and blue when in point
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edit mode). This effect is easily apparent if on the Options toolbar both
Simple Handles and Large Handles are switched on.

Starting Point

Figure 14: Drawing a straight line
Hold down the Shift key while drawing the line to restrict the angle of
the line to a multiple of 45 degrees (0, 45, 90, 135, and so on.

Hold down the Control key (Ctrl in PCs) to snap the end of the line to
the nearest grid point.

The effect of the Ctrl key depends on the settings of the Snap to
Grid option on the View->Grid menu:

Note Snap to Grid on: Cirl deactivates the snap option for this
activity.
Snap to Grid off: Cirl activates the snap option for this activity.

The spacing (resolution) of the grid points can be adjusted under Tools
> Options > OpenOffice.org-Draw > Grid. See also Chapter 8 (Tips
and Tricks) in the Draw Guide.

Hold down the Alf key to extend the line symmetrically outward from
the start point (the line extends to each side of the start point equally).
This lets you draw straight lines by starting from the middle of the line.

The line just drawn has all the default attributes, such as color and line
type. To change the line attributes, click on the line to select it and
then use the tools in the Line and Filling toolbar; or for more control,
right-click on the line and choose Line to open the Line dialog.

Drawing an arrow

Arrows are drawn like lines. Draw classifies arrows as a subgroup of
lines: Lines with arrowheads. They are shown in the information field
on the status bar only as lines. Click on the Line Ends with Arrow
icon - to draw an arrow.
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Drawing lines and arrows

Click on the small black triangle on the Lines and Arrows icon to
open a floating toolbar with ten tools for drawing lines and arrows
(Figure 15). Alternatively, you can click directly on the symbol to
repeat the last-used command chosen from this toolbar. In both cases,
the last-used command will be stored on the toolbar to make it quicker

to call it up again.

—

Line with Arrow/Circle

Llne with Arrow/Square
Line Ends with Arrow

Ty Dlmensinn Line

H —TLine with Arrows

Line {45°) - \
Line with Square/Arrow
Line Starts with Arrow
e wit

Lin Circle/Arrow

Line

Figure 15: Lines and Arrows toolbar

Drawing a rectangle or square

Drawing rectangles is similar to drawing straight lines, except that you
use the Rectangle icon [ from the Drawing Toolbar. The (imaginary)

line drawn with the mouse corresponds to the diagonal of the
rectangle. In addition, the outline of the future rectangle changes
shape as you drag the mouse around. The outline is shown as a dashed
line until you release the mouse button, when the rectangle is drawn.

Starting point

Figure 16: Drawing a rectangle

Hold down the Shift key to draw a square. Hold down the Alt key to
draw a rectangle starting from its center. To combine the effects, hold

down both the Shift and Alt keys simultaneously.
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Drawing a circle or ellipse
To draw an ellipse (also called an oval) or a circle, use the Ellipse icon

@ from the Drawing Toolbar. (A circle is simply an ellipse where the
two axes are the same length.) The ellipse drawn is the largest ellipse
that would fit inside the (imaginary) rectangle drawn with the mouse.

Starting point

Figure 17: Drawing an ellipse

There are three other ways to draw an ellipse or circle:
- Hold down the Shift key while drawing to force the ellipse to be a
circle.
« Hold down the Alt key to draw a symmetrical ellipse or circle
from the center instead of dragging corner to corner.
« Hold down the Control key while drawing to snap the ellipse or
circle to grid lines.

If you first press and hold the Control key and then click on one
of the icons (Line, Rectangle, Ellipse, or Text), an object is

Note drawn automatically in the work area—the size, shape, and
color are all standard values. These attributes can be changed
later, if desired.

Drawing curves

The tools for drawing curves or polygons are on the toolbar that
appears when you click the Curve icon -4- on the Drawing toolbar.

This toolbar contains eight tools (Figure 18).

Hovering the mouse over this icon gives a tooltip of Curve. If
Note you convert the icon to a floating toolbar, however, the title is
Lines, as shown in Figure 18.
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Figure 18: Floating Curves toolbar (incorrectly titled “Lines”)

If you move the mouse cursor over one of the icons, a tooltip pops up
with a description of the function. For a more detailed description of
the handling of Bézier curves (curves and filled curves), see Chapter
10 (Advanced Draw Techniques) in the Draw Guide.

Polygons
Draw the first line from the start point with the left mouse button
held down. As soon as you release the mouse button, a first corner
point is drawn, and you can move the mouse to see how the second
line will look. Every mouse click sets another corner point. A double-
click ends the drawing. A filled polygon automatically joins the last
point to the first point to close off the figure and fills it with the
current standard fill color. A polygon without filling will not be
closed at the end of the drawing.

Polygon 45°
Just as with ordinary polygons, these will be formed from lines but
with angles of 45 or 90 degrees between them.

Freeform Line
With this tool you can draw just like with a pencil. Press and hold
the left mouse button and move the mouse. It is not necessary to end
the drawing with a double-click. Just release the mouse button and
the drawing is completed. If you have selected Freeform Line, Filled,
the end point is joined automatically to the start point and the object
is filled with the appropriate color.

Writing text

Use the Text tool T to write text and select the font, color, size, and
other attributes. Click on an empty space in the workspace to write the
text at that spot or drag an area to write inside the dragged frame.
Press Enterto drop to the next line.

When you have finished typing text, click outside the text frame.
Double-click on the text at any time to edit it.
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When you type text, the upper toolbar includes the usual paragraph
attributes: indents, first line, and tab stops.

You can change the style of all or part of the text. The Styles and
Formatting window also works here (select Format > Styles and
Formatting or press F11 to launch), so you can create Graphics styles
that you can reuse for other text frames. Graphics styles affect all of
the text within a text frame. To style parts of the text, use direct
formating with the toolbar.

Text frames can also have fill colors, shadows, and other attributes,
just like any other Draw object. You can rotate the frame and write the
text at any angle. These options are available by right-clicking on the
object.

Use the Callout tool, located on the Drawing toolbar, to create callouts
(also known as captions or figure labels).

If you double-click on an object or press F2 (or the Text icon in the
Drawing toolbar) when an object is selected, text is written in the
center of the object and remains within the object. Nearly any kind of
object contains such an additional text element. These texts have slight
differences to those in text frames concerning position and
hyphenation.

For more about text, see Chapter 2 (Drawing Basic Shapes) and
Chapter 10 (Advanced Draw Techniques) in the Draw Guide.

Gluepoints and connectors

All Draw objects have associated invisible gluepoints. Most objects
have four gluepoints, as shown in Figure 19.

_______________________

Figure 19: Four gluepoints

Gluepoints are different from handles (the small blue or green squares
around an object). Use the handles to move or resize an object; use the
gluepoints to attach connectors to an object.

You can add more gluepoints, and customize gluepoints, using the
toolbar of the same name. Gluepoints become visible when you click
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the Gluepoints icon ¥/ on the Drawing toolbar and then move the end
of a connector over the object.

Connectors are a type of line or arrow whose ends dock to glue points
on other objects. When you move the other object, the connector
moves with it. Connectors are particularly useful for making
organizational charts. You can reorganize the blocks of your chart and
all the connected objects stay connected.

Figure 20 shows two Draw objects and a connector.

Figure 20: A connector between two objects

Draw has a range of advanced connector functions. You can change
connector types using the context menu or by opening the floating
Connectors toolbar (click on the Connector icon = -). For more about
connectors and gluepoints, see Chapter 9 (Organization Charts, Flow
Diagrams, and More) in the Draw Guide.

Drawing geometric shapes

Geometric shapes include basic shapes, symbol shapes, block arrows,
flowcharts, callouts, and stars.

Figure 21 shows part of the Drawing toolbar with the icons necessary
for the following sections. They open floating toolbars with the relevant
work tools. The use of all these tools is similar to that of the Rectangle
tool, even though they produce different geometric shapes.

GO0k

Figure 21: Part of the main Drawing toolbar
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Basic shapes

The Basic Shapes icon |<> - makes available the
range of tools for drawing basic shapes.

If you choose the rectangle tool from this
toolbar, it looks the same as a rectangle drawn
using the Rectangle tool on the Drawing
toolbar. The only differences you will see are in
the information field in the status bar.

Symbol shapes

The Symbol Shapes icon © brings you to an
array of tools for drawing the various symbol
shapes.

Block arrows
The Block Arrows icon “° opens the Block Arrows

Basic Shapes ¥ X
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Flowcharts
The tools for drawing flowcharts are accessed by Flowchart v x
clicking on the Flowcharts icon ©-. Do o008
The creation of flowcharts, organization charts, and D eCdw
similar planning tools are described in Chapter 9 Oo0dnN®®
(Organization Charts, Flow Diagrams, and More) in X&AYVAD
the Draw Guide. a8 oo
Callouts
Use the Callouts icon “~ to open the Callouts |callouts - x
toolbar.
10 ¢ &3 ,0,0 0
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Stars and banners

These tools are associated with the Stars icon

—— Stars and Ban... ~ X

ok SR G i
4109 0

You can add text to all these shapes. See Chapter 2 (Drawing Basic
Shapes) and Chapter 10 (Advanced Draw Techniques) in the Draw
Guide for details.

Selection modes

There are three selection modes: moving and changing size, rotating,
and editing points.

The default mode for selecting objects depends on whether the Points

button on the Drawing toolbar is active (appears lit) ™ or not inactive
(appears dark or dimmed) .

In standard mode (when you begin a new drawing),
the Points button is not active, and the default mode
is for selections to be moved or changed in size; these
selections are indicated by small green squares.

When the Points button is active, the default mode is
for selections to be edited; these selections are
indicated by blue squares. Some objects will have one
or more extra handles, which are larger or colored
differently. This is explained in more detail in the
Draw Guide.

Selections for rotating objects are indicated by small
red circles and a symbol representing the center of
rotation. To choose these selections, click on the
Effects drop-down button ¢ - from the Drawing
toolbar.
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Changing the selection mode

To go from one mode to another, you can do one of the following:
« Toggle the Points button on the Drawing toolbar to switch from

the simple selection mode to the Points mode “'. You can also use
the keyboard shortcut F8 (Points).

« Choose the Effects drop-down button from the Drawing toolbar
& - to activate the Rotation mode for a selected object.

« If you often work in Rotation mode, you can choose the Rotation
Mode after Clicking Object button ¢ from the Options bar, you
can cycle through normal and rotation modes just by clicking on
the object. This can be more convenient than clicking the object,
then clicking the Rotate button from the Drawing Toolbar.

Selecting objects

Direct selection

To select an object, the easiest way is to click directly on it. For objects
that are not filled, click directly on the object's outline to select it.

Selection by framing

You can select several objects by using the mouse to
drag a large rectangle around the objects, as shown.
For this to work, the Select & icon on the Drawing
toolbar must be active. Only objects that lie entirely
within the rectangle are selected.

Selecting hidden objects

Even if objects are located behind others and not visible, they can still
be selected. To select an object that is covered by another object, hold
down the Alt key and click the object. To select an object that is
covered by several objects, hold down the Alt key and click through the
objects until you reach the required underlying object. To cycle
through the objects in reverse order, hold down the Alt+Shift keys
when you click. To help in making accurate selections, you can check
the number and type of the selected objects, shown at the left of the
status bar.
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There may be some variation in the use of the Alt key on
different operating systems. In general the Alt key on a
Windows computer functions as described above, but on a
Linux system it usually does not. If the Alt key on your system
does not operate as described above, use the Tab key method
described below.

Note

To select an object that is covered by another object using the
keyboard, press Tab to cycle through the objects, stopping at the
object you wish to select. To cycle through the objects in reverse order,
press Shift+Tab. This may not be practical if you have a large number
of objects in your drawing.

When you click on the selected object, its outline
appears briefly through the objects on top of the
selected object.

In the illustration to the right, the square located
beneath the circle was selected in this way (the circle
was made transparent in order to see the square).

Arranging objects

In a complex drawing, you may have objects stacked up, one on top of
the other, with the result that a particular object is hidden by one or
more other objects above it. You can rearrange the stacking order of
objects (move an object to the front or to the back of the stack) by
selecting the object, clicking Modify > Arrange and selecting the
appropriate Bring Forward or Send Backward option, or by right-
clicking the object and selecting Arrange from the context menu, then
selecting from the list of Bring Forward or Send Backward options.

On the Drawing toolbar, the Arrange tear-off menu on the £ - button
contains the above options. A keyboard shortcut is Shift+Ctri++ to
bring an object to the top, and Shift+Ctri+— to send an object to the
bottom.

Draw also provides tools for aligning multiple objects; details are given
in the Draw Guide.

Selecting several objects

To select or deselect several objects one by one, press the Shift key
and click on the various objects to be selected or deselected. One click
on an object selects it; a second click deselects it.
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Moving and dynamically adjusting an
object’s size

There are several ways of moving or changing the size of an object.
The method described here will be called dynamic in the sense that it
is carried out using the mouse.

When you dynamically change an object, remember to check the
central area of the status bar at the bottom of your screen. This area
shows detailed information about the ongoing manipulation. For
example, during resizing, you will see the following information
displayed. This information changes when the mouse is moved.

Object position Object dimensions Current proportional page size
14,06 /13.29 % 12.66x0.59 || 75% || * Slide 1 / 2 (Layout) | Default

Dynamic movement of objects

To move an object, select it and then click within
the object’s border and hold down the left mouse
button while moving the mouse. To drop the

object at its new location, release the mouse !
button.

During movement, the shape of the object P .
appears as dotted lines to help with
repositioning.

If you have selected Guides when moving in
Tools > Options > OpenOffice.org Draw >

View, then during movement, dotted lines
appear, to help with repositioning. e IR RRED }:’
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Dynamic size modification of objects

To change the size of an object (or group of oo R
selected objects) with the mouse, you need to move '
one of the handles located around the selection. As -

shown in the following illustration, the outline of
the resulting new object appears as a dotted line.

The results differ depending on which handle you use. If you choose a
corner handle, you will resize the object along two axes at the same
time. If you use a side handle, the objects will only be resized along
one axis.

If you press the Shift key at the same time as you carry out the
resizing operation, the size change will be carried out
symmetrically with respect to the two axes; this enables you to
keep the aspect (height/length) ratio of the object.

Note

Rotation

Rotating an object lets you move the object around an axis. To do this
dynamically, use the red handles, as you do when changing the size of
the object.

Rotation works in a slightly different way for 3D objects
because the rotation occurs in 3D space and not in one plane.
See Chapter 7 (Working with 3D Objects) in the Draw Guide
regarding rotation when Edit Points mode is active.

Note

To rotate an object (or a group of objects), drag the red corner handle
points of the selection with the mouse. The mouse cursor takes the
shape of an arc of a circle with an arrow at each end. A dotted outline
of the object being rotated appears and the current angle of rotation is
dynamically shown in the status bar.

Rotations are made about an axis which is displayed as a small symbol.
You can move the axis of rotation with the mouse, as shown in
Figure 22.

If you hold down the Shift key during the rotation, the operation will be
carried out in increments of 15°.
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‘ Centre of Rotation |

Figure 22: Rotating an object

Inclination and perspective

To slant or shear objects, use the red handles located at the midpoint
of an edge of the selected objects. The mouse pointer changes to a =
when the pointer hovers over one of these midpoint handles. Not every
object can be slanted—basic shapes can be rotated but not slanted.

The slant axis is the point directly opposite the midpoint handle to be
used for shearing the object. This point stays fixed in location; the
other sides and edges move in relation to it as the mouse is dragged
(make sure that the = handle icon is showing before dragging).

As with rotation, you can set the inclination to occur as steps of 15° by
pressing the Shift key while moving the handle.

Editing objects

To change an object’s attributes (such as color, border width, among
others) you can use the Line and Filling toolbar or the context menu.

If the Line and Filling toolbar (Figure 23) is not visible, you can display
it using View > Toolbars > Line and Filling. From here you can edit
the most common object attributes. You can also open the Line dialog
by clicking on the Line ¢ icon and the Area dialog by clicking on the

Area & icon to see more options.
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Figure 23: Line and Filling toolbar

When you select text, this toolbar changes to show text formatting
options (Figure 24).
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Figure 24: Line and Filling toolbar (when text is selected)

The context menu

When an object is selected, you can right-click on the object to bring
up a context menu, which provides additional access to the options
shown above and another way to change an object’s attributes. The
entries with a small arrow on the right-hand side contain a submenu.

Editing lines and borders

Lines (like arrows) and the borders of an N ¢
object are managed through the same dialog. \ R
An object’s border is just another type of line. N <

'0

You can change some properties from the Line and Filling toolbar. To
see more options, select the object and click on the Line § icon or
right-click on the object and choose Line from the context menu. This
opens the Line dialog.

Common line properties

In most cases the property you want to change is the line’s style (solid,
dashed, invisible, and so on), its color, or its width. These options are
all available from the Line and Filling toolbar (Figure 23).

You can also edit these properties from the Line dialog, where you can
also change the line’s transparency. Figure 25 illustrates different
degrees of transparency.
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Figure 25: The vertical lines have different
levels of transparency (0%, 25%, and 50%).

Drawing arrows

Arrowheads (and other line endings, usually referred to
collectively as arrows) are a line property. Select a line and
click on the Arrow Style = - icon. This opens the
Arrowheads menu.

Several types of arrowheads are available. Each end of the
line can have a different arrowhead (or no arrowhead).

Arrowheads are only applicable to lines. They have no
effect on an object’s border.

Customizing line and arrow styles

Arrowheads | |

=—-

TrANTHATATY
LoV vE [ Tay

You can modify the line and arrow styles and create your own. See
Chapter 4 (Changing Object Attributes) in the Draw Guide for details.

Editing the inside (fill) of an object

The OpenOffice.org term for the inside of an object is Area fill. The
area fill of an object can be a uniform color, a gradient, a hatching, or a
pattern from an image. It can be made partly or wholly transparent

and can throw a shadow.
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In most cases, you will choose one of the standard fill options, which
are all available from the Line and Filling toolbar. You can also define
your own area fills; see Chapter 4 of the Draw Guide for details.

Adding a shadow

In Draw, shadows are considered an area
property. Click on the Shadow 0 icon on the Line
and Filling toolbar.

You can customize the position, distance, color,
and transparency of shadows.

Adding transparency

You can make objects partly or fully transparent, or even with a
varying degree of transparency (as a gradient).

Using styles

Suppose that you want to apply the same area fill, line thickness, and
border to a set of objects. This repetitive process can be greatly
simplified by the use of styles. Styles allow you to define a formatting
template (a style) and then to apply that style to multiple objects. For
more about styles, see Chapter 3 (Using Styles and Templates) for
more information.

Special effects

With Draw, you can apply many special effects to objects and groups of
objects. This section describes a few of these effects. Others include
distorting, shadows, and transparency. See the Draw Guide for
examples of the many effects available.

Flip an object

Select an object and click on the Flip icon g. You will
see a dashed line through the middle of the object.
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This dashed line is the axis of symmetry. The object
will be reflected about this line. Move one or both
ends of the line with your mouse to set the axis.

Then, grab any one of the eight green handles and
move it across to the other side of the dashed line.
The new position of the figure is shown dashed until
the mouse is released.

If you hold down the Shift key while moving the line, the line will

Note rotate in 45-degree increments.

Mirror copies

Officially, this useful command does not (yet) exist in Draw. It can,
however, be easily emulated.

Move the axis of symmetry to the desired location of the mirror axis.
Copy the object to the clipboard. Flip the object, then click on an
empty area of the Draw screen in order to deselect the object. Paste
from the clipboard to put a copy of the object in its original location
and now you have a mirror copy.

Distorting an image

There are three tools on the Effects menu that let you drag the
corners and edges of an object to distort the image.

The Distort tool distorts an object in perspective, the Set to Circle
(slant) and Set in Circle (perspective) tools both create a pseudo
three-dimensional effect. See Chapter 4 of the Draw Guide for details.

Dynamic gradients

You can control transparency gradients in the same manner as color
gradients. Both types of gradient can be used together. With a
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transparency gradient, the direction and degree of an object’s fill color
changes from opaque to transparent (in a regular gradient, the fill
changes from one color to another, but the degree of transparency
remains the same). See Chapter 4 of the Draw Guide for details.

Duplication

Duplication makes copies of an object while applying a set of changes
(such as color or rotation) to the duplicates. The result of a duplication
is a new group.

To start duplication, click on an object or group and choose Edit >
Duplicate. The dialog shown in Figure 26 appears.

The options chosen in Figure 26 applied to a blue rectangle produce
the following result.

Duplicate
Mumber of copies 10 =
X axis 0.50cm =
Y axis 0.50cm (%]
Angle 10 degrees [3]

Enlargement

Width 0.00cm |3

Height 0.00cm %]
Colors

Start I Blue 7 [v]

end e v

Figure 26: Duplicating an object
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Cross-fading

Cross-fading transforms a shape from one form to another, with
OpenOffice.org handling all of the intermediate transitions. The result
is a new group of objects including the two end points and the
intermediate steps.

To carry out a cross-fade, select both objects (hold the Shift key while
selecting each object in turn) and then choose Edit > Cross-fading
The following dialog appears.

Cross-fading E

Settings [

oK |

Increments 16 s
Cross-Fade attribukes [ Gance ]
Same orientation [ Help ]

On the dialog choose the number of increments (transition steps). You
probably want to have Cross-fade attributes and Same orientation both
checked. The end result is shown in Figure 27.

o
v

Figure 27: Cross-fading example

=)

Combining multiple objects

Using Draw, you can combine drawing objects together in two distinct
ways: grouping and combining. These two methods allow you to treat
multiple objects as one unit, or to merge objects to form a new shape.

Grouping is like putting objects in a container. You can move them as a
group and apply global changes to them. A group can always be
undone and the objects that make up the group can always be
manipulated separately.

A combination is a permanent fusion of objects leading to a new object.
The original objects are no longer available as individual entities and
the operation is not reversible.
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Grouping by common selection

When several objects are selected, any operations you carry out are
applied to all of the objects. For example, you can rotate a group of
objects in its entirety. Groups obtained through common selection of
several objects are undone as soon as you click outside the group.
However, you can group objects and keep those selected objects
grouped together.

Maintaining groups and undoing groups

To group selected objects, right-click and choose Group from the pop-
up menu. You can also use the keyboard shortcut Control+Shift+G or
choose Modify > Group from the menu bar.

When objects are grouped, any editing operations carried out on that
group are applied to all members of the group. If you click on one
member of the group, the whole group is selected.

The objects of a group retain their own individual properties. To undo a
group, right-click and choose Ungroup from the pop-up menu, use the
keyboard shortcut Control+Alt+Shift+G or choose Modify >
Ungroup from the menu bar.

You can edit a member of a group individually without breaking the
group. To do this, right-click and choose Enter group or double-click
on the group.

Combining objects

In contrast to grouping functions, combinations create a new object;
subsequent “un-combining” in the same manner as ungrouping is not
possible. Select a collection of objects, then right-click and choose
Combine from the pop-up menu.

After you have selected more than one object, the Merge, Subtract,
and Intersect functions can be reached in the Modify > Shapes menu
or though the group’s right-click menu under the heading Shapes.

Aids for positioning objects

Draw has various tools to help you arrange the objects with respect to
each other:

« Moving an object to the front or to the back
« Aligning objects with respect to each other
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« Distributing the distance and space between objects

See Chapter 5 (Combining Multiple Objects) in the Draw Guide for
more information.

Editing pictures

Draw contains a number of functions for editing raster graphics
(bitmaps)—for example, photos, scanned pictures, and so on—including
import and and export as well as conversion from one format to
another. Draw can read in all the usual range of graphic file formats.
However, it does not have the same capabilities as the specialized
raster graphics programs like Adobe Photoshop or The Gimp.

See Chapter 6 (Editing Pictures) in the Draw Guide for details.

Working with 3D objects

Although Draw does not match the functionality of the leading drawing
or picture editing programs, it does offer a wide array of tools and
methods to produce and edit very good 3D drawings and pictures.

Draw offers two types of 3D objects: the ones carried forward from
OOo version 1, 3D bodies, and the ones newly introduced in version 2,
3D shapes. Depending on which type you choose, there are different
possibilities for further editing of the object (rotation, illumination,
perspective). Setting up and editing 3D objects is simpler with 3D
shapes than with 3D bodies, but 3D bodies currently allow for more
customizing than 3D shapes.

See Chapter 7 (Working with 3D Objects) in the Draw Guide for details.

Inserting pictures from other sources

You can add pictures from several sources:

« The Gallery—see Chapter 11 (Graphics, the Gallery, and
Fontwork)

« Directly from a scanner (Insert > Picture > Scan)

« Images created by another program, including photographs from
a digitial camera (Insert > Picture > From File)

Draw provides tools for working with bitmap images such as
photographs: the Picture toolbar and the bitmap image management
palette. See the Draw Guide for details and examples.
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Exchanging objects with other programs

To save a Draw image in a foreign format, use File > Export. Draw
can save to many graphic file formats, as listed in Chapter 3 (File
Management).

You can also export Draw files to HTML, PDF, or Flash. PDF export is
the same as for any part of OpenOffice.org, as described in Chapter 10
(Printing, E-mailing, and Exporting). Flash export creates a .swf file.

HTML export uses a conversion wizard that creates as many web
pages as there are pages in your Draw document. You can optionally
choose to display the pages in frames with a navigator and can set an
index page. For more information, see Chapter 12 (Creating Web
Pages: Saving Documents as HTML Files).
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