Differences in use between Writer and Word
Contents

Overview ..................................................................................................................................... 3
Acknowledgments .................................................................................................................. 3
Modifications and updates ........................................................................................................ 3
Views ........................................................................................................................................ 1
Status bar ................................................................................................................................ 1
Navigator .................................................................................................................................. 1
Stylist ........................................................................................................................................ 2
Keyboard ................................................................................................................................... 2
Multiple selections and tables ................................................................................................. 3
Comparison of key short-cuts ................................................................................................. 3
Mouse use .................................................................................................................................. 4
Tables .......................................................................................................................................... 4
Header Rows ............................................................................................................................. 4
Turning off header rows ........................................................................................................... 5
Adjusting column widths and row heights using the keyboard .............................................. 5
Copying and pasting cells in a table ........................................................................................ 5
Inserting and deleting rows or columns ................................................................................. 5
Equal row heights and column widths .................................................................................... 6
Splits and merges ..................................................................................................................... 6
Preventing accidental change to cell contents ....................................................................... 6
Sorting ....................................................................................................................................... 6
Entering numbers and formulas .............................................................................................. 6
Creating a table from a data source ......................................................................................... 7
Charts in Writer ....................................................................................................................... 7
Customizing the user interface ............................................................................................... 8
Write, edit, and review documents .......................................................................................... 9
Control page layout ................................................................................................................ 10
Word notion of page layout ...................................................................................................... 10
Writer notion of page layout .................................................................................................... 10

Differences in use between Writer and Word

i
Comparison for page layout ........................................................................................................ 11
Use templates and styles .............................................................................................................. 12
  Font size ........................................................................................................................................ 12
  Space between paragraphs and page breaks before ............................................................... 13
Fields ............................................................................................................................................. 13
Work with large or complex documents ..................................................................................... 14
Work with graphics ....................................................................................................................... 14
Mail Merge .................................................................................................................................... 15
  Creation of the Mail Template (main document) ...................................................................... 15
  Selecting records for the merge ................................................................................................. 16
  Viewing merged data .................................................................................................................. 16
  Eliminating blank lines ............................................................................................................... 16
  Merging ........................................................................................................................................ 16
  Mailing Labels ............................................................................................................................. 16
  Merge to e-mail ............................................................................................................................ 17
Envelopes ...................................................................................................................................... 17
  Adding an envelope ..................................................................................................................... 17
  Removing an envelope ................................................................................................................ 17
Page styles and page numbering ................................................................................................. 18
  Modify a page style ..................................................................................................................... 18
  Create a style ................................................................................................................................ 18
  The Page style dialog .................................................................................................................. 18
Page breaks and page numbering ................................................................................................. 19
  Changing the style used for a page and changing the numbering sequence .......................... 19
  To insert page numbering .......................................................................................................... 20
  Page numbers on portrait and landscape pages in the same place and orientation .............. 20
Conditional text ............................................................................................................................ 21
Master documents ............................................................................................................................ 22
Overview

This document summarizes the differences in use between OpenOffice.org Writer 1.1.x and Microsoft Word (various versions).

Acknowledgments

This document was written by Ian Laurenson.


The section on mail merge is based on a “how-to” document written by Sophie Gautier.

Modifications and updates

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>3 October 2004</td>
<td>First publication.</td>
</tr>
</tbody>
</table>
Views

Word has 4 views (depending on the version) called:

Normal: Recommended view (by Microsoft) for doing most of your typing and editing. Writer has no real equivalent view.

Page or Print Layout: This shows the document (more or less) as it will print. This is the closest equivalent to the main view in Writer.

Online Layout: In theory, this shows the document as if viewed on-line. Writer's equivalent is a view option called Online Layout. To access this view, select View > Online Layout.

Outline View: For working with heading hierarchies. Writer has the Navigator, which is detailed later in this chapter.

Writer also has an HTML source view that only shows when editing an HTML document. To access this view, select View > HTML – Source.

When field codes are turned on, Writer displays less information about the field than does Word. To get detailed information, right click the field > Fields... (or select field > Edit > Fields...).

Status bar

The status bar is similar to Word's except it does not show the current location of the cursor on the page (row number and number of characters across). It does however show the position within a table in spreadsheet style format, e.g., Top left cell =A1.

Navigator

Word doesn't have a similar concept to the Navigator and, in the author's opinion, it is such a useful tool it is worth taking the time to learn more about it.

To launch the Navigator, press F5 or click the navigator icon on the Function Bar. To get a detailed description of what each of the buttons do, press Shift + F1 and hover over the buttons.

The Headings at the top of the list box in the Navigator are the closest equivalent to Word’s Outline View.

With the List Box on there is a drop-down list box at the bottom of the navigator. With this list box it is possible to select any of the open Writer documents so that their contents are available for dragging and dropping. What happens when the selection is dropped is determined by the drag mode specified by the Drag Mode button. Press and hold the Drag Mode button to see the available options.

When viewing a master document the Navigator is quite different. For more details see the chapter on Master Documents.
Note: Graphics, indexes, OLE objects, and references cannot be dragged and dropped when in the Insert as link or Insert as Copy modes.

Stylist

For a more detailed guide on using styles, see “Use templates and styles” on page 12.

Use Shift + F1 to check out the different buttons on the Stylist. Use the bottom list box to change the style group that is displayed. For example, Applied Styles only shows those styles that have been used in the document.

Keyboard

When some text has a character attribute at the end of a paragraph (say bold or a hyperlink) but the new text doesn't require that attribute then press the right arrow key before typing.

Deleting paragraph marks: pressing Delete at the end of a paragraph effectively moves the text of the following paragraph into the current paragraph, and the paragraph formatting of the top paragraph remains. Press Backspace at the start of a paragraph and the format of the lower paragraph remains.

Hint: An aid to remember this is: the format of the paragraph that has the cursor will be the format of the combined paragraph, unless the current paragraph is empty; in that case, backspacing will leave the previous paragraph's formatting.

Control + Home when in tables: In Word Control + Home always positions the cursor to the top of the document, in Writer Control + Home first positions the cursor at the start of the cell, then the start of the table and then the start of the document. Control + End has similar behavior.

How to select multiple parts of the text

To copy, cut, format, or delete parts of the text in different areas of the document use:

• Control + selection with one click, double-click or sliding.

or

1) Click once on the field "STD" (STanDard) in the status bar
   The field now shows "EXT" (EXTended selection).

2) Another click and it changes to "ADD" (ADD to selection).

Note: the ADD mode is the equivalent to Control + click and EXT is equivalent to Shift + click.
Multiple selections and tables

The following limitations apply when selections involve tables:

• It is possible to have multiple selections within a cell, but only one selection is possible that involves more than one cell.

• A selection that starts in a table can not extend beyond the table.

• A selection that starts outside a table will include the entire table (that is, a selection cannot start outside a table and also contain a portion of a table).

Comparison of key short-cuts

Table 1: Word vs Writer different default key shortcuts (incomplete)

<table>
<thead>
<tr>
<th>Function</th>
<th>Word standard shortcut</th>
<th>Writer standard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Underline words not spaces</td>
<td>Control + Shift + W</td>
<td>No equivalent</td>
</tr>
<tr>
<td>Change font size</td>
<td>Control + Shift + P</td>
<td>No standard equivalent</td>
</tr>
<tr>
<td>Thesaurus</td>
<td>Shift + F7</td>
<td>Control + F7</td>
</tr>
<tr>
<td>Show/hide non-printing</td>
<td>Control + Shift + *</td>
<td>Control + F10</td>
</tr>
<tr>
<td>characters</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hanging Indent</td>
<td>Control + T</td>
<td>No standard equivalent</td>
</tr>
<tr>
<td>“Unhang” Indent</td>
<td>Control + Shift + T</td>
<td>No standard equivalent</td>
</tr>
<tr>
<td>Indent</td>
<td>Control + M</td>
<td>No standard equivalent</td>
</tr>
<tr>
<td>“UnIndent”</td>
<td>Control + Shift + M</td>
<td>No standard equivalent</td>
</tr>
<tr>
<td>Superscript</td>
<td>Control + Shift =</td>
<td>Control + Shift + P</td>
</tr>
<tr>
<td>Subscript</td>
<td>Control + =</td>
<td>Control + Shift + B</td>
</tr>
<tr>
<td>Remove character formatting</td>
<td>Control + Spacebar</td>
<td>Right click &gt; Default</td>
</tr>
<tr>
<td>Remove paragraph formatting</td>
<td>Control + Q</td>
<td>No equivalent</td>
</tr>
<tr>
<td>Jump to previous edit point</td>
<td>Shift + F5</td>
<td>Need to use the reminders on the Navigator</td>
</tr>
<tr>
<td>Shift paragraph up</td>
<td>No equivalent</td>
<td>Control + Up</td>
</tr>
<tr>
<td>Shift paragraph down</td>
<td>No equivalent</td>
<td>Control + Down</td>
</tr>
</tbody>
</table>

See AltKeyHandler.sxw (available from http://homepages.paradise.net.nz/hillview/OOo/) for macros that extend Writer's key shortcut ability.
Mouse use

Some differences are:

- Right click displays a context menu, but for the current cursor position not the pointer position.
- No quick selection of rows or columns in tables.
- Triple click selects current line or current cell when cursor is in a table.
- No quick selection of paragraphs or lines by clicking to the left of the paragraph.
- *Control + Click* doesn't select a sentence.

To select sentences easily, customize the keyboard:

1) **Tools > Configure... > Keyboard.**
2) For Category select **Navigate**.
3) Assign key shortcuts for **Select to Next/Previous sentence**.
4) Alternatively assign key shortcuts for **To next/previous sentence** and use *F8* (extend selection) and the assigned keys.

Tables

The menu option to insert a table is in the **Insert** menu. The other menu options for tables are in the **Format** menu (rather than having their own menu). The menu options and **Tables object** toolbar become visible when the cursor is in a table.

Tables are like one special paragraph so when selecting text using the keyboard (*Shift + arrow*) from, say, above the paragraph, the whole table is selected followed by the line below it.

Tables without borders can be hard to spot – they don't have a thin gray line like tables in Word. To display the thin gray line, use **Tools > Options > OpenOffice.org > Appearance** and select the "Table boundaries" checkbox.

The page formatting of long skinny tables into newspaper style columns when the table crosses a page break appears to be unreliable.

Header Rows

By default new tables have a header row.

To have more than one row for a header row (copied from help):

1) Select the first row of the table.
2) Right-click and choose **Cell – Split**.

Differences in use between Writer and Word
3) In the Split area, enter the number of rows that you want to include in the header.

4) In the Direction area, click in the Horizontally check box. If you want the rows to have equal heights, select the Into equal proportions check box.

5) Click OK.

Turning off header rows

Simply delete the rows. To keep the contents of the header rows, insert the required number of rows, copy and paste the heading rows into the new rows, then delete.

Adjusting column widths and row heights using the keyboard

Use the 3 buttons on the Table object toolbar to set what happens to the overall width of the table:

- **Table: Fixed**: Overall width of the table stays the same, but the adjoining column shrinks or grows correspondingly.

- **Table: Fixed Proportional**: The current column and the end column change by corresponding amounts, keeping the overall width the same.

- **Table: Variable**: Only the current column changes so the overall width of the table changes.

Use Alt and the arrow keys as follows to adjust the width of columns (or height of rows):

- *Alt* and arrow keys adjusts the right side (bottom for rows).

- *Alt + Shift* and arrow keys adjusts the left side (top for rows).

- *Alt + Control* + left or right arrow keys adjusts the current cell only.

Copying and pasting cells in a table

Writer never inserts new rows or columns when pasting data – it always overwrites the contents of the cells. This makes it clear as to what will happen. To avoid overwriting cells, first insert the required number of rows or columns.

Inserting and deleting rows or columns

Inserting is always below for rows and to the right for columns (opposite of Word).

*Note: This is a surprising inconsistency as Calc inserts above and to the left.*

To insert rows or columns using the keyboard: *Alt + Insert*, arrow key. To delete rows or columns using the keyboard: *Alt + Delete*, arrow key. The insertion or deletion is in the direction of the arrow key. For example, *Alt + Insert, Up* inserts a row above the current row.
Equal row heights and column widths

On the Tables object toolbar there is a long click button called Optimize. This presents a tear-off menu for easily adjusting row heights and column widths to being the same.

Splits and merges

To merge cells – do this last, as you would in Word.

To split or merge cells: Select cells to be merged then Format > Cell.

To split a table (horizontally): Format > Split Table.

To join two tables they need to be one below the other, then Format > Merge Tables. If there is a table above and below the current table the user will be prompted which one they wish to join.

Preventing accidental change to cell contents

To prevent accidental change to cell contents: Select the cells, Format > Cells > Protect.

This is not a security feature as the cells aren't password protected but does prevent accidentally changing a cell.

Sorting

To sort a table:

1) Select the cells to be sorted; don't include the headings. The option to sort only becomes available when there is something selected.

2) Tools > Sort.

Unlike Word, the sort dialog uses column number rather than the names of the column.

Entering numbers and formulas

Unlike Word, tables in Writer can work much more like spreadsheets. For example calculated values change as the data is input (no more selecting and pressing F9 to update calculated results).

With number recognition turned on, when entering a number Writer will automatically format the number according to a specified number format. To change this behavior, right-click when the cursor is in a table > Number Recognition.

To change the number format: Select the cells, Format > Number Format...
To enter a formula like SUM():

1) Select the cell where the result is to go.
2) Press F2 to display the Formula bar.
3) Click and hold Formula button to display formula menu.
4) Select desired function (list separator is for separating constants, e.g. =mean 5 | 12 | 20).
5) Click and drag on cells to input ranges.
6) Press Enter to finish.

To enter a formula like “this cell plus that cell minus that cell”:

1) Select the cell where the result is to go.
2) Press F2 to display the Formula bar.
3) Click on a cell.
4) Type or select the desired operator.
5) Click on the next cell.
6) Repeat steps 4 and 5 until done.
7) Press Enter to finish.

Creating a table from a data source

To create a table from a data source:

1) Display the Data source viewer (F4).
2) In the Data explorer window navigate to the desired table or query.
3) Drag the name of the table or query into the document.
4) Select the desired fields and set other properties as required in the dialog.

Charts in Writer

Charts copied from a Calc spreadsheet and pasted into a Writer document are, by default, embedded objects. Unlike doing this in Microsoft Office, only the relevant data for the chart is embedded. In Microsoft Office copying and pasting a chart also embeds it, but if the Excel workbook was 8 mb in size (not unrealistic for a spreadsheet) then each chart pasted into a Word document would increase the Word document by 8 mb.

Linking of charts does not exist.
## Customizing the user interface

Most functions are found in similar places in both programs, but a few are slightly different, and the degree of control varies. This table summarizes where to find the setup choices.

Table 2: Customizing the user interface

<table>
<thead>
<tr>
<th>To do this...</th>
<th>In Word...</th>
<th>In Writer...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change measurement system</td>
<td>Tools &gt; Options... &gt; General</td>
<td>Tools &gt; Options... &gt; Text Document &gt; General</td>
</tr>
<tr>
<td>Turn off Autocompletion</td>
<td>Not applicable</td>
<td>Tools &gt; AutoCorrect/AutoFormat. In the “Word completion” tab, untick Word Completion.</td>
</tr>
<tr>
<td>Turn on/off Help Agent</td>
<td>Help &gt; Microsoft Word Help &gt; Options</td>
<td>Help &gt; Help Agent</td>
</tr>
<tr>
<td>Set up document window (rulers, status bar, default toolbars, etc)</td>
<td>View &gt; select required items</td>
<td>View &gt; select required items</td>
</tr>
<tr>
<td>Customize toolbars</td>
<td>Tools &gt; Customize</td>
<td>Tools &gt; Configure</td>
</tr>
<tr>
<td>Customize menus</td>
<td>Tools &gt; Customize</td>
<td>Tools &gt; Configure</td>
</tr>
<tr>
<td>Display font names in their font (in toolbar drop-down font list)</td>
<td>Tools &gt; Customize &gt; Options</td>
<td>Tools &gt; Options &gt; OpenOffice.org &gt; View, select Preview in fonts lists</td>
</tr>
<tr>
<td>Always show full menus (include unavailable and little-used items)</td>
<td>Tools &gt; Customize &gt; Options</td>
<td>Tools &gt; Options &gt; OpenOffice.org &gt; View, select Inactive menu items</td>
</tr>
<tr>
<td>Show/hide ScreenTips (ToolTips) on toolbars</td>
<td>Tools &gt; Customize &gt; Options</td>
<td>Help &gt; Tips to uncheck</td>
</tr>
<tr>
<td>Always create backup copy</td>
<td>Tools &gt; Options &gt; Save</td>
<td>Tools &gt; Options &gt; Load/Save &gt; General</td>
</tr>
<tr>
<td>Autosave every x minutes</td>
<td>Tools &gt; Options &gt; Save</td>
<td>Tools &gt; Options &gt; Load/Save &gt; General</td>
</tr>
<tr>
<td>Show paragraph marks, tabs, etc.</td>
<td>Tools &gt; Options &gt; View</td>
<td>Tools &gt; Options &gt; Text Document &gt; Formatting Aids</td>
</tr>
<tr>
<td>Change file locations</td>
<td>Tools &gt; Options &gt; File Locations</td>
<td>Tools &gt; Options &gt; OpenOffice.org &gt; Paths</td>
</tr>
<tr>
<td>Change user information</td>
<td>Tools &gt; Options &gt; User Information</td>
<td>Tools &gt; Options &gt; OpenOffice.org &gt; User Data</td>
</tr>
<tr>
<td>Set up AutoCorrect and AutoFormat options</td>
<td>Tools &gt; AutoCorrect Options</td>
<td>Tools &gt; AutoCorrect/AutoFormat &gt; Options</td>
</tr>
</tbody>
</table>
Write, edit, and review documents

Most writing, editing, and reviewing techniques in OOoWriter are similar to those in Microsoft Word, but the details often vary.

Table 3: Write, edit and review documents

<table>
<thead>
<tr>
<th>To do this...</th>
<th>In Word...</th>
<th>In Writer...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jump quickly to other parts of a</td>
<td>Edit &gt; Go to</td>
<td>Edit &gt; Navigator (or F11), double-click on required</td>
</tr>
<tr>
<td>document</td>
<td></td>
<td>heading, figure, table, etc.</td>
</tr>
<tr>
<td>Choose language for spelling</td>
<td>Tools &gt; Language &gt; Set Language</td>
<td>Tools &gt; Options &gt; Language Settings &gt; Language. (Note:</td>
</tr>
<tr>
<td>checker</td>
<td></td>
<td>OpenOffice.org has no grammar checker.)</td>
</tr>
<tr>
<td>Ignore some text when checking</td>
<td>Select text; Tools &gt; Language &gt; Set Language &gt; Do</td>
<td>Select text; right-click &gt; Character &gt; Font &gt; Language</td>
</tr>
<tr>
<td>spelling</td>
<td>not check (or) Format &gt; Style &gt; Modify &gt; Format &gt;</td>
<td>= [None] or the real language of the selected text, if</td>
</tr>
<tr>
<td></td>
<td>Language</td>
<td>that is foreign.</td>
</tr>
<tr>
<td>Recheck spelling</td>
<td>Tools &gt; Spelling &amp; Grammar &gt; Recheck Document</td>
<td>Always rechecks</td>
</tr>
<tr>
<td>Find and replace text, formatting,</td>
<td>Edit &gt; Replace &gt; More; choices as needed</td>
<td>Edit &gt; Find &amp; Replace; details are a bit different</td>
</tr>
<tr>
<td>and styles</td>
<td></td>
<td>Edit &gt; Find &amp; Replace, select Regular expressions;</td>
</tr>
<tr>
<td>Use wildcards in find and replace</td>
<td>Edit &gt; Replace &gt; More &gt; select Use Wildcards</td>
<td>wildcards themselves are different See the section</td>
</tr>
<tr>
<td></td>
<td>checkbox</td>
<td>on Regular expressions in the differences in use</td>
</tr>
<tr>
<td></td>
<td></td>
<td>between Microsoft Office &amp; OpenOffice.org.</td>
</tr>
<tr>
<td>Choose, create, or edit a custom</td>
<td>Tools &gt; Options &gt; Spelling &amp; Grammar &gt; Custom</td>
<td>Tools &gt; Options &gt; Language Settings &gt; Writing Aids</td>
</tr>
<tr>
<td>dictionary</td>
<td>Dictionaries</td>
<td></td>
</tr>
<tr>
<td>Create exception (exclude) dictionary</td>
<td>File &gt; New, type words, Save As &gt; text only, file</td>
<td>As for custom dictionary, but select Exception [-]</td>
</tr>
<tr>
<td></td>
<td>extension .EXC</td>
<td>checkbox</td>
</tr>
<tr>
<td>Track changes (choose options)</td>
<td>Tools &gt; Options &gt; Track Changes</td>
<td>Tools &gt; Options &gt; Text Document &gt; Changes</td>
</tr>
<tr>
<td>Protect document for editing</td>
<td>Tools &gt; Protect Document</td>
<td>Edit &gt; Changes &gt; Protect Records</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(Password needs to be at least 5 characters)</td>
</tr>
<tr>
<td>Mark and track changes</td>
<td>(Word 2000) Tools &gt; Track Changes &gt; Highlight</td>
<td>Edit &gt; Changes &gt; Record</td>
</tr>
<tr>
<td></td>
<td>Changes</td>
<td></td>
</tr>
<tr>
<td>Insert comments associated with a</td>
<td>Highlight text; Insert &gt; Comment</td>
<td>Edit &gt; Changes &gt; Comment</td>
</tr>
<tr>
<td>change</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Insert notes (comments not associated</td>
<td>Highlight text; Insert &gt; Comment</td>
<td>Insert &gt; Note</td>
</tr>
<tr>
<td>with a change</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Overview

<table>
<thead>
<tr>
<th><strong>To do this...</strong></th>
<th><strong>In Word...</strong></th>
<th><strong>In Writer...</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Show changes as pop-up text</td>
<td>Options &gt; View &gt; Screentips</td>
<td>Help &gt; Tips (and) Help &gt; Extended Tips</td>
</tr>
<tr>
<td>Merge documents</td>
<td>Tools &gt; Merge Documents</td>
<td>Edit &gt; Changes &gt; Merge Document</td>
</tr>
<tr>
<td>Accept or reject changes</td>
<td>View &gt; Toolbars &gt; Reviewing</td>
<td>Edit &gt; Changes &gt; Accept or Reject</td>
</tr>
<tr>
<td>Change document properties</td>
<td>File &gt; Properties</td>
<td>File &gt; Properties</td>
</tr>
<tr>
<td>Get a word count</td>
<td>Tools &gt; Word Count (can get word count for selection)</td>
<td>File &gt; Properties &gt; Statistics tab.¹</td>
</tr>
<tr>
<td>Create AutoText entry</td>
<td>Select text; Insert &gt; AutoText &gt; New</td>
<td>Edit &gt; AutoText (or) Control + F3</td>
</tr>
<tr>
<td>Insert AutoText</td>
<td>Type shortcut and press F3</td>
<td>Type shortcut and press F3; or type Name and press Enter. Writer distinguishes between the “name” and the “shortcut” of an autotext. Word does not.</td>
</tr>
</tbody>
</table>

AutoText in Writer always ends with a paragraph mark. So for a short in-line shortcut, better to use AutoCorrect.

### Control page layout

This section covers such things as margins, headers, and footers.

Writer and Word have somewhat different notions of page layout.

#### Word notion of page layout

Page layout is a property of the document as a whole. If you change the page layout (for instance, set the document to landscape), it changes for the entire document. You can then arrange for specific sections to have a different layout.

#### Writer notion of page layout

Page layout is a property of the page style (for example, First Page, Index and Default). If you change the page layout for one page style (for instance, set Default to have a header with page numbers) only that style will be affected.

Using page styles gives Writer some very useful features. For instance, you can define the First Page page style so that, after you have typed the first page, the style switches to Index (or any other style you choose). You can then set Index so that it is followed by Default.

¹To get word count for selection, use the wordcount macro at: [http://www.darwinwars.com/lunatic/bugs/oo_macros.html](http://www.darwinwars.com/lunatic/bugs/oo_macros.html). This does selections, and will do footnotes for OOo1.1 and above. OOo 2.0 will have a Word Count feature for selections.
### Comparison for page layout

Table 4: Control page layout

<table>
<thead>
<tr>
<th>To do this...</th>
<th>In Word...</th>
<th>In Writer...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define margins</td>
<td>File &gt; Page Setup &gt; Margins</td>
<td>Format &gt; Page &gt; Page</td>
</tr>
<tr>
<td>Specify different headers and footers on first, odd, and even pages</td>
<td>File &gt; Page Setup &gt; Layout &gt; Headers and Footers section</td>
<td>Define different page styles for First, Left (even), and Right (odd) pages, using Header and Footer tabs</td>
</tr>
<tr>
<td>Edit headers and footers</td>
<td>View &gt; Headers and Footers, then type or insert fields; can also double-click in existing header or footer regions</td>
<td>After you have specified Header and Footer areas for a page, they are always active. Single-click to type or insert fields</td>
</tr>
<tr>
<td>Change from roman to arabic page numbers in the footer of a page</td>
<td>Insert a section break, deselect “Same as Previous” in the second section, define a new footer with page numbers restarting at 1 in arabic numerals</td>
<td>Insert a manual page break and apply a different page style</td>
</tr>
<tr>
<td>Use paragraph styles for page layout</td>
<td>Can define paragraph styles with offset from left margin, with heading styles aligned left or right</td>
<td>Can define paragraph styles with offset from left margin, with heading styles aligned left or right</td>
</tr>
<tr>
<td>Use columns for page layout</td>
<td>Insert continuous sections to switch from single to multiple columns on one page</td>
<td><strong>Format &gt; Page &gt; Columns</strong> (or) <strong>Insert/Format &gt; Section &gt; Columns</strong> (or) other methods</td>
</tr>
<tr>
<td>Use frames or text boxes for page layout</td>
<td>Frames are used in Word 97 but mostly replaced by text boxes in Word2000 and 2002; can be linked to flow text from one to next, as in a newsletter</td>
<td><strong>Insert &gt; Frame</strong> (can link frames to flow text from one to next, as in a newsletter); “text boxes” are fields, not positioning devices</td>
</tr>
<tr>
<td>Use tables for page layout</td>
<td>Table &gt; Insert &gt; Table (use dialog to format)</td>
<td><strong>Insert &gt; Table</strong> (use dialog to format)</td>
</tr>
<tr>
<td>Put portrait headers on landscape pages</td>
<td>Use rotated text box linked to header</td>
<td>Use rotated text in a frame</td>
</tr>
<tr>
<td>Set first page number to greater than 1</td>
<td>Insert &gt; Page Numbers &gt; Format</td>
<td>In first paragraph on first page, <strong>Format &gt; Paragraph &gt; Text Flow &gt; Breaks</strong>, select Enable and With Page Style, choose the page style, specify the page number</td>
</tr>
<tr>
<td>View and edit facing pages</td>
<td>File &gt; Print Preview; click Zoom button to enable editing</td>
<td><strong>File &gt; Page Preview</strong>; cannot edit when previewing; shows pages on wrong sides of screen</td>
</tr>
<tr>
<td>Reduce page count by 1</td>
<td>File &gt; PagePreview, Click ShrinkToFit button.</td>
<td>See <a href="http://homepages.paradise.net.nz/hillview/OOo/ShrinkToFit.sxw">http://homepages.paradise.net.nz/hillview/OOo/ShrinkToFit.sxw</a>.</td>
</tr>
</tbody>
</table>
Use templates and styles

Table 5: Use templates and styles.

<table>
<thead>
<tr>
<th>To do this...</th>
<th>In Word...</th>
<th>In Writer...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find which template is associated with a document</td>
<td>Tools &gt; Templates and Add-ins</td>
<td>File &gt; Document Properties &gt; General tab.</td>
</tr>
<tr>
<td>Specify default template</td>
<td>&quot;Normal&quot; template is default</td>
<td>File &gt; Templates &gt; Organize lets you set any template as default</td>
</tr>
<tr>
<td>Create a new template</td>
<td>File &gt; Save As, set type to Document Template (.DOT)</td>
<td>File &gt; Templates &gt; Save</td>
</tr>
<tr>
<td>Edit a template</td>
<td>File &gt; Open, choose template</td>
<td>File &gt; Templates &gt; Edit</td>
</tr>
<tr>
<td>Copy styles between templates</td>
<td>Tools &gt; Templates and Add-ins &gt; Organizer</td>
<td>File &gt; Templates &gt; Organize.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>There, you can copy styles with drag and drop between templates and documents.</td>
</tr>
<tr>
<td>Create a new document from a template</td>
<td>File &gt; New (opens a list of templates)</td>
<td>File &gt; New &gt; Templates and Documents</td>
</tr>
<tr>
<td>Apply a different template to a document</td>
<td>Tools &gt; Templates and Add-ins &gt; Attach, select template, Open</td>
<td>Start a new document based on the different template; copy contents of old document into new document.</td>
</tr>
<tr>
<td>Apply a style to text</td>
<td>(Word 2000) Select from Style List or Style dialog (XP) Can also use task pane.</td>
<td>Format &gt; Styles (or press F11), double-click style in list; after one use, paragraph styles appear in Apply Style list on Formatting object bar.</td>
</tr>
<tr>
<td>Change a style definition</td>
<td>(Word 2000) Format &gt; Style &gt; Modify; (XP) can also select in task pane and click Modify</td>
<td>Select style in Stylist, right-click, choose Modify; or Format &gt; Styles &gt; Catalog, select style, click Modify.</td>
</tr>
<tr>
<td>Create a new style</td>
<td>Format &gt; Style &gt; New</td>
<td>Format &gt; Styles &gt; Catalog, click New or Right click in Stylist New.</td>
</tr>
<tr>
<td>Use outline numbering</td>
<td>Format &gt; Style, select style &gt; Format &gt; Numbering</td>
<td>Tools &gt; Outline Numbering</td>
</tr>
<tr>
<td>Drop caps</td>
<td>Format &gt; Drop Cap... One character only, can not be part of a style.</td>
<td>Format &gt; Paragraph &gt; Drop Caps Drop caps are able to be part of a style. Can be &gt;= 1 char or word.</td>
</tr>
</tbody>
</table>

Font size

When a style is based on another style, it is possible to set the font to being a percentage of the font size of the original style. In the font size field simply type the number followed by a percentage sign, e.g. 120%. This way, changes to the underlying style will be better reflected in this style. To change it back to being an absolute font size type the number followed by the characters “pt”, e.g. 12pt. It is also possible to specify how many points larger or smaller: e.g. +2pt for 2 points larger, or -2pt for two points smaller.
Space between paragraphs and page breaks before

In Writer, some paragraph properties behave differently to the way they behave in Word. Specifically:

- Space before if at the top of a page is ignored.
- Space between paragraphs: the greatest of space above and space below for the two paragraphs is applied.
- Page break before: if at the top of a page, doesn't create a blank page.

This makes using styles possible without having to apply direct paragraph formatting to fix issues afterwards.

Fields

For a comparison of fields between Writer and Word see the File Sharing chapter.

Table 6: Use of fields

<table>
<thead>
<tr>
<th>To do this...</th>
<th>In Word...</th>
<th>In Writer...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert a field</td>
<td>Insert &gt; Field (or) CTRL+F9 for blank field</td>
<td>Insert &gt; Fields</td>
</tr>
<tr>
<td>Define a number range field</td>
<td>Insert &gt; Field, use SEQ (sequence)</td>
<td>Insert &gt; Fields &gt; Other &gt; Variables &gt; Number range</td>
</tr>
<tr>
<td>Insert a bookmark</td>
<td>Select text; Insert &gt; Bookmark</td>
<td>Select text; Insert &gt; Bookmark</td>
</tr>
<tr>
<td>Insert a cross-reference to a bookmark</td>
<td>Insert &gt; Cross Reference, choose Bookmark as type</td>
<td>Insert &gt; Cross Reference &gt; Bookmark²</td>
</tr>
<tr>
<td>Insert a cross-reference to a heading</td>
<td>Insert &gt; Cross Reference, choose Heading as type</td>
<td>Either bookmark the heading or use Insert &gt; Cross Reference &gt; Set Reference to mark the heading, then Insert &gt; Cross Reference &gt; Insert Reference.</td>
</tr>
<tr>
<td>Insert a cross-reference to a figure or table</td>
<td>Insert &gt; Cross Reference, choose type</td>
<td>Insert &gt; Cross Reference &gt; Insert Reference &gt; Figure (or Table)</td>
</tr>
<tr>
<td>Use conditional content</td>
<td>Use IF or other fields, or styles (all workarounds)</td>
<td>Insert &gt; Fields &gt; Other &gt; Variables (among other ways)</td>
</tr>
</tbody>
</table>

Work with large or complex documents

Major differences exist in the use of master documents. The table does not attempt to summarize all these differences.

Table 7: Work with large or complex documents.

<table>
<thead>
<tr>
<th>To do this...</th>
<th>In Word...</th>
<th>In Writer...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a table of contents, list of figures, or an alphabetic index</td>
<td>Insert &gt; Index and Tables</td>
<td>Insert &gt; Indexes and Tables &gt; Indexes and Tables</td>
</tr>
<tr>
<td>Insert index entries</td>
<td>ALT+SHIFT+X</td>
<td>Insert &gt; Indexes and Tables &gt; Entry (or) click Insert Index Marker icon</td>
</tr>
<tr>
<td>Create a bibliographic database</td>
<td>Need to use other package</td>
<td>Tools &gt; Bibliography Database</td>
</tr>
<tr>
<td>Insert bibliographic references into text</td>
<td>Link to field in database</td>
<td>Insert &gt; Indexes and Tables &gt; Bibliographic Entry</td>
</tr>
<tr>
<td>Insert footnotes and endnotes</td>
<td>Insert &gt; Footnote</td>
<td>Insert &gt; Footnote (or) click Insert Endnote Directly icon</td>
</tr>
<tr>
<td>Insert other files</td>
<td>Insert &gt; File, choose Insert or As Link</td>
<td>Insert &gt; File</td>
</tr>
<tr>
<td>Cross-reference between documents</td>
<td>Use Includetext fields</td>
<td>Currently have to remember the name of the set reference. Reference will show correctly when in master document. File &gt; Send &gt; Create Master Document; use Navigator to insert subdocuments</td>
</tr>
<tr>
<td>Use master documents</td>
<td>Some experts do not recommend using Master Documents in Word.</td>
<td></td>
</tr>
</tbody>
</table>

Work with graphics

Most graphics work should be done outside Word or Writer, with the graphic files embedded or linked to the Word or Writer file. However, you can do some simple graphics using the drawing tools in Word or Writer. This table covers the basics.

Table 8: Work with graphics.
<table>
<thead>
<tr>
<th><strong>To do this...</strong></th>
<th><strong>In Word...</strong></th>
<th><strong>In Writer...</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Create Drawing objects</td>
<td>(Word 2000) View &gt; Toolbars &gt; Drawing; (XP) Insert &gt; Picture &gt; New Drawing</td>
<td>Click <strong>Show Draw Functions</strong> icon</td>
</tr>
<tr>
<td>Combine graphics objects and drawing objects</td>
<td>(Word 2000) Edit &gt; Picture &gt; Reset Picture Boundary; (XP) Use drawing canvas</td>
<td>Place all objects in a frame</td>
</tr>
<tr>
<td>Insert graphics files into a text document (embed or link)</td>
<td>Insert &gt; Picture &gt; From File, choose Insert or As Link</td>
<td><strong>Insert</strong> &gt; <strong>Graphics</strong> &gt; <strong>From File</strong></td>
</tr>
<tr>
<td>Anchor graphics</td>
<td>Format &gt; Picture &gt; Layout &gt; Advanced &gt; Picture Position</td>
<td>Use icons on <strong>Graphics object bar</strong>, or right-click and choose from pop-up menu, or click <strong>Format</strong> &gt; <strong>Graphics</strong></td>
</tr>
<tr>
<td>Wrap text around graphics</td>
<td>Format &gt; Picture (or Object) &gt; Layout</td>
<td>Use icons on <strong>Graphics object bar</strong>, or right-click and choose from pop-up menu, or click <strong>Format</strong> &gt; <strong>Graphics</strong> &gt; <strong>Wrap</strong></td>
</tr>
<tr>
<td>Crop graphics</td>
<td>Format &gt; Picture &gt; Crop, (or) click Crop tool on Picture toolbar</td>
<td><strong>Format</strong> &gt; <strong>Graphics</strong> &gt; <strong>Crop</strong> (No tool for dragging crop area)</td>
</tr>
<tr>
<td>Create captions for graphics</td>
<td>Select graphic; Insert &gt; Reference &gt; Caption</td>
<td>Select graphic; <strong>Insert</strong> &gt; <strong>Caption</strong></td>
</tr>
<tr>
<td>Annotate graphics</td>
<td>Use drawing objects; group, or place in frame or on drawing canvas (XP)</td>
<td>Place all objects in a frame</td>
</tr>
<tr>
<td>Insert watermark</td>
<td>Format &gt; Background &gt; Printed Watermark &gt; Picture (or Text) Watermark</td>
<td><strong>Format</strong> &gt; <strong>Page Style</strong> &gt; <strong>Background</strong> (or) create drawing object, <strong>Arrange</strong> &gt; <strong>To Background</strong>, <strong>Anchor</strong> &gt; <strong>To Page</strong></td>
</tr>
</tbody>
</table>

### Mail Merge

A lot of this section is based on a “howto” written by Sophie Gautier, titled “How to do a “mail merge” from a Calc spreadsheet”. The original is at: [http://documentation.openoffice.org/HOW_TO/word_processing/writer2_EN.html](http://documentation.openoffice.org/HOW_TO/word_processing/writer2_EN.html).

### Creation of the Mail Template (main document)

1) In Writer create a document that is going to be the mail template.

2) Save the file but don't close it.

3) **View** > **Data Sources** (or press the **F4** key). The registered data sources will be displayed in the data source viewer.

4) Select the source of data for the mail merge. Click on the little cross next to the data source name to display its content tree. Clicking on the name of a table to display the
fields and their records in the right side of the data source viewer. See the chapter on Data Sources for information on registering a data source.

**To add the fields into your document**
Click and drag the desired fields (one at a time) to the desired places in your document.

**Selecting records for the merge**
To select a record, click on the gray rectangle to its right. A small arrow will be displayed and the record will be highlighted.
To select records that are not consecutive, hold the Control key down while making selections.

*Note: For selecting records based on a criteria see the chapter on Data Sources.*

**Viewing merged data**
To see your document as it will be when merged, click the Data to fields button. To view different records, simply select the records in the data source viewer.

**Eliminating blank lines**
If a field might be blank, then the process to suppress the potentially blank line is:
1) In the mail template, place the cursor before the field.
2) Control+F2 (or Insert > Fields > Other...) to open the Fields dialog.
3) Switch to the Functions tab.
4) Select the field style Hidden Paragraph and type in the Condition area “not(field name)”.
5) Click on the Insert button to insert the function into the document.

**Merging**
1) Click the mail merge button.
2) Choose whether to use all the records, the currently selected records (option becomes available when records are selected; see Selecting records for the merge above).
3) Choose whether to send the merge to printer or file. When sending to file, a separate file is created for each record; the files are named according to your options but with an appended number to ensure that they are unique.
Mailing Labels

The easiest way to create mailing labels is:

1) **File > New > Labels.**
2) Select database from the list of registered databases (see the chapter on Data Sources).
3) Select the table within the database.
4) Select each field and click the left facing arrow to move the field into the Label text area.
5) Tidy the Label text area (press Enter between the address fields).
6) Select the brand and type of label for the labels to be printed on. If the correct brand and type isn't listed use the **Format** tab to specify the layout.
7) Click the **Options** tab, ensure **Entire page** is chosen. The **Synchronize contents** checkbox is so that changes made to the first label are propagated through the remaining labels.
8) Click **New Document**.
9) Merge as above.

Merge to e-mail

There is no option for merging to e-mail.

Envelopes

From the forums some people have had difficulty with envelopes. From brief experimentation the author hasn't had any problems with OpenOffice.org 1.1.1 and above.

Adding an envelope

**Insert > Envelope...**

Removing an envelope

1) Place the cursor at the beginning of the envelope page.
2) If the **Stylist** is not open, press **F11** or use **Format > Stylist** to display it.
3) Change to the Page Styles options. It's the fourth icon from the left.
4) Double Click on **Default**.
5) Remove the remaining elements.
Page styles and page numbering

Modify a page style

In Writer all pages have a page style. To modify the page style of the page where the cursor is positioned, use Format > Page.

Warning: As the page style is being changed, all pages with this style will be changed as well.

Create a style

To create a new page style:

1) If the Stylist isn't currently displayed, press F11 to display it.
2) Click Page Styles in the Stylist (fourth icon from left).
3) Right click in the Stylist > New.

The Page style dialog

Organizer tab

Name: Nothing tricky here, simply a name to help the user remember what the settings are for.

Next style: This setting specifies what page style to use at the next page break (manual or automatic) for any page that has this page style. Set it to a different page style when the page style is only for one page (such as the first page of each chapter), otherwise this should be the same as Name to keep the same page style for the following pages.

Page tab

Paper format settings: Format is the paper size, the other settings have the same names in Word (on the paper size tab of page setup).

Margin settings: Same as for Word. Each setting represents the distance from the edge of the page, but see Header/footer tabs below as the location of headers and footers relative to the margins is different.

Layout settings: Page Layout is for specifying whether the page style is mirrored – used for left and right pages. There are more options here than in Word, but there isn't a different first page option – that's because it is handled by the Next style setting as mentioned above in Organizer tab. Format refers to the format of page numbers. Register true is to make the text line up better at the top of the page (see help for more details).

Background tab

For specifying a background color or graphic (watermark). (An alternative to this with more flexibility is to create a drawing object, then use Arrange > To Background, Anchor > To Page.)
Header/footer tabs

Headers and footers are printed between the margins of the page rather than in the top or bottom margins as they are in Word. Another way of saying this is that for the top of a page the area between the edge of the page and the top margin is always blank, next is the header, and after the header, the main text area for the page.

Auto height allows the header or footer to grow and shrink depending on their contents.

Spacing specifies the distance between the header/footer and the main text area on the page. Dynamic spacing allows the header/footer to expand into the area between the header/footer and the main text area.

The left and right margins are indenting from the margins of the page and cannot have negative values.

The More button is for specifying borders and backgrounds for the header/footer area. In some versions of Word this approach was used to create a watermark. Since it is possible to have graphics in the background of the main document, this is not the required way of having a watermark in Writer.

Borders/columns footnote tabs

These tabs are for specifying the borders (lines around the outside), number and widths of newspaper style columns and defining the area for footnotes (if any) for the page style.

Page breaks and page numbering

Changing the style used for a page and changing the numbering sequence

To insert a page break and change page style or page numbering method1:

1) Control + Enter.
2) Cursor will be in the first paragraph of the new page.
3) Format > Paragraph...
4) Breaks will be enabled.
5) Select With Page style, specify the page style to use and specify the page number to start from.

To insert a page break and change page style or page numbering method2:

1) Insert > Manual break...
2) By default it will specify Page breaks.
3) Choose the Page style.
4) Select Change page number.
5) Enter the new starting page number.

**To insert page numbering**

1) Define a page style with header or footer turned on.

2) Position the cursor in the header or footer (use the mouse or key shortcut Control + PageUp for Header or Control + PageDown for footer).

3) Optionally type: **Page** space.

4) **Insert > Fields > Page Number.**

5) Optionally type **space “of” space** **Insert > Fields > Page Count.**

To insert a field that calculates a different page count (for example, when you have a title page but want to have the remaining pages say page 1 of 2 (instead of page 1 of 3):

1) Press **F2** to display the **text formula bar.**

2) Type **=page – 1.**

3) Press **Enter.**

*Note: Unfortunately this field doesn't automatically update, so press F9 to update it before printing.*

**Page numbers on portrait and landscape pages in the same place and orientation**

1) Create a style for landscape pages. Set the margins for the landscape style such that they correspond with the portrait style when rotated (top = left, bottom = right, left = bottom and right = top). For page numbering on left, turn on headers; on right – footers. Select **Use dynamic spacing.**

2) Create a style for the landscape header or footer based on the style for the portrait header or footer. (In the Stylist, select the style that is used for the portrait header or footer > right click > **New**.) Change the font position to 270°. If the page numbering is on the bottom choose left alignment, for the top choose right.

3) Insert the page break and choose the page style just created (see above); don't change the numbering.

4) In the relevant header/footer (as per step 1) insert the page number field.

*Differences in use between Writer and Word 20*
Conditional text

In Word the only way to have conditional text is with the “if” field. The equivalent in Writer is the field “Conditional text”.

To insert a conditional field in Writer: Insert > Fields > Other > Functions > Conditional text or Control + F2 > Functions > Conditional text.

There is also a field “Hidden text” that hides the text when the condition is true.

Working with the relevant fields for conditional text, both in Word and in Writer, means that only small amounts of text can be conditional. However, there are times when having whole paragraphs or sections of text be conditionally hidden is very convenient. Some examples:

- A test so that the same document can be used for the test itself and for the model answers.
- Technical documents where the same document with variations can be used for similar models of equipment.

Writer provides a field for conditionally hiding paragraphs and the ability to conditionally hide sections. Here's an example to show how this could be done:

1) Ensure that hidden text is viewable: Tools > Options > Text Document > Formatting Aids, tick both “Hidden text” and “Hidden paragraphs”.

Note: Conditionally hidden sections are not visible regardless of these settings if the condition for hiding them is true.

2) At the top of the document: Insert > Fields > Other > Variables.

3) Name: DocType. Value: Model Answers.

4) At the start of a one paragraph answer: Insert > Fields > Other > Functions > Hidden Paragraph. For the condition type DocType == “Test” (To make this easier to insert repeatedly, create an autocorrect entry).

5) For longer answers: Enter the model answer, select it, Insert > Section..., tick Hide, and enter DocType == “Test” for the condition.

6) To print the document for a test, double click the field at the top of the document created in steps 2 and 3, and change the value to Test. Print as usual.

Note 1: The field “Input list” has a name but this is not a variable so its value cannot be used in the condition.

Note 2: It is easiest if the selection doesn't include the last paragraph to keep adding sections. But if the last paragraph is selected simply move to the end of the document (Control + End) then press Alt + Enter.
Master documents

Help covers using the basics of using master documents, or see “Work with large or complex documents” on page 14, or for even more information see the chapter on Master Documents in the User’s Guide.

It is possible to insert cross-references across sub-documents but the names of the references must be typed in rather than selected from a list.

Use Insert > Fields > Other... > References.

A macro to help insert references to headings, including references across documents that will be sub documents, in a master document, is available in a document called OutlineCrossRef3.sxw available from http://homepages.paradise.net.nz/hillview/ OOo/.

Note: There is no way to have a landscape page in a sub-document and that page remaining a landscape page when included in the master document. The only workaround is to have the landscape page be part of the master document rather than a sub-document.