Draw Guide:
A guide to using the Draw component of OpenOffice.org

Title: Draw Guide: A guide to using the Draw component of OpenOffice.org
Version: 1.0
First edition: October 2004
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>vi</td>
</tr>
<tr>
<td>Copyright and trademark information</td>
<td>vi</td>
</tr>
<tr>
<td>Feedback</td>
<td>vi</td>
</tr>
<tr>
<td>Acknowledgments</td>
<td>vi</td>
</tr>
<tr>
<td>Modifications and updates</td>
<td>vi</td>
</tr>
<tr>
<td><strong>Introduction to Draw</strong></td>
<td>1</td>
</tr>
<tr>
<td>The Workplace</td>
<td>2</td>
</tr>
<tr>
<td>The Toolbars</td>
<td>3</td>
</tr>
<tr>
<td>The Function Bar</td>
<td>3</td>
</tr>
<tr>
<td>The Object Bar</td>
<td>4</td>
</tr>
<tr>
<td>The Main Toolbar</td>
<td>4</td>
</tr>
<tr>
<td>The Color Bar</td>
<td>5</td>
</tr>
<tr>
<td>The Option Bar</td>
<td>6</td>
</tr>
<tr>
<td>The Rulers</td>
<td>6</td>
</tr>
<tr>
<td>The Status Bar</td>
<td>7</td>
</tr>
<tr>
<td><strong>Drawing Basic Shapes</strong></td>
<td>8</td>
</tr>
<tr>
<td>Drawing a segment of a straight line</td>
<td>8</td>
</tr>
<tr>
<td>Drawing a rectangle</td>
<td>11</td>
</tr>
<tr>
<td>Drawing a circle</td>
<td>11</td>
</tr>
<tr>
<td><strong>The Basic Drawing Shapes</strong></td>
<td>12</td>
</tr>
<tr>
<td>The Texts</td>
<td>12</td>
</tr>
<tr>
<td>Rectangles and Squares</td>
<td>14</td>
</tr>
<tr>
<td>Circles, Ellipses and Arcs</td>
<td>14</td>
</tr>
<tr>
<td>3D Objects</td>
<td>16</td>
</tr>
<tr>
<td>Curves</td>
<td>17</td>
</tr>
<tr>
<td>Lines and Arrows</td>
<td>18</td>
</tr>
<tr>
<td>Connectors</td>
<td>19</td>
</tr>
<tr>
<td>Connector drawing basics</td>
<td>19</td>
</tr>
<tr>
<td>Connector toolbar</td>
<td>21</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Entering Position and Size data</td>
<td>46</td>
</tr>
<tr>
<td>Size Data Entry</td>
<td>46</td>
</tr>
<tr>
<td>Angle of Rotation Data Entry</td>
<td>46</td>
</tr>
<tr>
<td>Inclination Data Entry</td>
<td>47</td>
</tr>
<tr>
<td>Using the Stylist</td>
<td>48</td>
</tr>
<tr>
<td>Applying a Style</td>
<td>49</td>
</tr>
<tr>
<td>Changing a Style</td>
<td>51</td>
</tr>
<tr>
<td>Creating a New Style</td>
<td>51</td>
</tr>
<tr>
<td>Special Transformations</td>
<td>51</td>
</tr>
<tr>
<td>Flip</td>
<td>52</td>
</tr>
<tr>
<td>3D Rotation Objects</td>
<td>53</td>
</tr>
<tr>
<td>Distort</td>
<td>56</td>
</tr>
<tr>
<td>Dynamic Transparency Gradient Definition</td>
<td>57</td>
</tr>
<tr>
<td>Dynamic Gradient Definition</td>
<td>58</td>
</tr>
<tr>
<td>Managing 3D Objects and Bitmaps</td>
<td>59</td>
</tr>
<tr>
<td>Managing 3D Objects</td>
<td>59</td>
</tr>
<tr>
<td>Rotating 3D objects</td>
<td>59</td>
</tr>
<tr>
<td>3D effects</td>
<td>60</td>
</tr>
<tr>
<td>Buttons available in pages</td>
<td>60</td>
</tr>
<tr>
<td>Favorites page</td>
<td>60</td>
</tr>
<tr>
<td>Geometry Management page</td>
<td>62</td>
</tr>
<tr>
<td>Shading page</td>
<td>65</td>
</tr>
<tr>
<td>Illumination page</td>
<td>67</td>
</tr>
<tr>
<td>Texture Management page</td>
<td>68</td>
</tr>
<tr>
<td>Materials Management page</td>
<td>71</td>
</tr>
<tr>
<td>Managing Bitmaps</td>
<td>72</td>
</tr>
<tr>
<td>The Bitmap Image Toolbar</td>
<td>72</td>
</tr>
<tr>
<td>Bitmap Image Management Palette</td>
<td>73</td>
</tr>
<tr>
<td>Combining Multiple Objects</td>
<td>78</td>
</tr>
<tr>
<td>Grouping and Combining Objects</td>
<td>78</td>
</tr>
<tr>
<td>Grouping Functions</td>
<td>78</td>
</tr>
</tbody>
</table>
Group by common selection
Maintaining groups and group dissociation
Editing individual objects in a group
Combination Functions
Shape Merge Functions
    Merge
    Subtract
    Intersect
Putting the Shape Merge Functions to use
Aids for Object Positioning
    Aligning Objects
    Distribution of Objects
    Managing Object Arrangement
Additional Tools
    Drawing Aid Tools
        Choosing Scale and Managing Zoom Values
            Zoom using the status bar
            Zoom Toolbar
    Managing Layers
    Placing Objects
        The Magnetic Grid
        Capture Lines
        Dynamic insertion of a capture line
        Manual Insertion of a snap point or snap line
        Snapping to object border
        Snapping to page
        Displaying guides
Specific Functions
    Duplication
    Cross-Fading
    Exchanging Objects with Other Programs
Reminder Concerning Image Formats........................................................................................................ 103
The Web export function.................................................................................................................................... 104
Overview

This document describes how to use Draw, the vector drawing component of OpenOffice.org (OOo).

Copyright and trademark information

The contents of this Documentation are subject to the Public Documentation License, Version 1.0 (the "License"); you may only use this Documentation if you comply with the terms of this License. A copy of the License is available at:

http://www.openoffice.org/licenses/PDL.rtf

The Original Documentation is Draw Guide: A guide to using the Draw component of OpenOffice.org. The Initial Writer(s) of the Original Documentation is/are Linda Worthington © 2004. All Rights Reserved. (Initial Writer contact(s): lindaw65@earthlink.net. The Initial Writer contact(s) is to report errors in the documentation. For questions regarding how to use the software, subscribe to the Users Mail List and post your question there: http://support.openoffice.org/index.html.)

All trademarks within this guide belong to legitimate owners.

Feedback

Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org.

Acknowledgments

Thanks to Daniel Carrera, Carol Leather and Jean Hollis Weber for reviewing this chapter. Original French document written by Michel Pinquier, translated to English by Alex Thurgood and previous content revised by Jim Taylor.

Modifications and updates

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>28 November 2004</td>
<td>First published version of complete Draw Guide</td>
</tr>
</tbody>
</table>
**Introduction to Draw**

**Draw** is a vector graphics drawing tool. It offers a series of powerful tools that enable you to quickly create all sorts of graphics.

It is perfectly integrated into the OpenOffice.org suite, and this makes exchanging graphics with all modules of the suite very easy. For example, it is relatively simple to draw an image and reuse it in the Writer and Impress modules. You can also work directly from within Writer and Impress, using a subset of the functions and tools from the **Draw** module.

The **Draw** module functionality is very extensive and complete. Even though it was not designed to rival high end graphics applications, it still possesses more functions than the majority of drawing tools that are integrated into office productivity suites.

A few examples of drawing functions might whet your appetite: layer management, magnetic grid point system, dimensions and measurement display, connectors for making organization charts, 3D functions enabling small three-dimensional drawings to be created (with texture and lighting effects), drawing and page style integration, and Bezier curves, just to name a few.

This document only describes the functions associated with **Draw**. Some notions such as file management or the way the OpenOffice.org environment works are mentioned only briefly as these are covered elsewhere in the guide.
The Workplace

The main components of the **Draw** interface have the appearance shown in Figure 1.

![Figure 1 - The Draw workplace](image)

The major area located in the center of the screen is the one in which your drawings will be made. It is surrounded by toolbars and information areas, the number and position of which can vary according to the particular organization you have chosen for your workplace. The small icons in each toolbar are called **buttons**. The picture above illustrates one of many possibilities.
The Toolbars

The various Draw toolbars can be displayed or hidden according to your needs. To display or hide the toolbars, simply click on any toolbar with the right mouse button. A menu will appear that lets you choose which of the four principal toolbars to display: the Function Bar, the Main Toolbar, the Object Bar and the Option Bar. This menu also lets you select the buttons that you wish to appear on the corresponding toolbar. All you have to do is select the option Visible Buttons, and then select the desired buttons for that toolbar. Each toolbar has a different list of buttons. Two additional toolbars, plus a toolbar customizing function, are available from the Menu Bar by clicking View > Toolbars.

Many toolbar buttons are marked with a small arrow in the upper right corner of the button. The arrow indicates that this button has additional functions. If you long-click (left-click and hold), a submenu appears showing its additional functions.

You may wish to keep this submenu displayed on your screen, but in a different position than the default location. You can make this submenu into a floating toolbar by detaching and repositioning it. Click the submenu title bar and drag it to your desired screen location, then release the mouse button. Most buttons marked with the small arrow can become floating toolbars. The floating toolbar capability is common to all modules of the OpenOffice.org suite.

The tools available in the various toolbars are explained in the following paragraphs.

The Function Bar

The Function Bar is displayed as follows:

It is the same for all of the modules of the OpenOffice.org suite and is not described in detail here.

1 All references to mouse clicks are relative to the default right-handed mouse configuration. Left-handed users can translate the mouse clicks to their left-handed mouse configuration.
The Object Bar

The Object Bar gives you a preview, and lets you modify the major characteristics of the drawing objects that you are handling. The icons displayed will vary as a function of the object that is selected. Sometimes more than one object bar is applicable for the selected object; in this case a triangle is displayed at the right end – click on this triangle to toggle through each of the available object bars.

![Object Bar]

In the example above, the available functions enable you to change the color of the line drawn, the fill color, etc., of the object currently selected. If the selected object is text, the toolbar will have the following appearance:

![Text Toolbar]

The Main Toolbar

This toolbar is the most important in the Draw module. It contains all the necessary functions to enable drawing of various geometric and freehand shapes and for their organization on the page.

![Main Toolbar]

The toolbar is shown here horizontally, but by default it is placed vertically on the left-hand side of the workspace. As for other toolbars in OpenOffice.org, the buttons having a small rightward pointing arrow enable you to gain access to further functionality. For example, if you click on the icon representing a rectangle, the following window appears:

![Rectangle Window]

It is therefore possible to choose the type of rectangle you want to draw (for example, straight or rounded, filled or empty, and so on). What's more, if you choose another option from the icon with the arrow, this new option will be displayed as the default for all following operations carried out using this button.
The Color Bar

To display the Color Bar, you need to use View > Toolbars > Color Bar. The toolbar then appears at the bottom of the workspace.

This toolbar lets you rapidly choose the color of the objects in your drawing. The first box in the panel corresponds to transparency (no color). The color palette that is shown by default can be changed via the menu Format > Area as shown below. Choose the tab marked Colors.

If you click on the Load Color List button that is circled, the file selector asks you to choose a palette file (bearing the file extension .soc). Several palettes are supplied as standard with OpenOffice.org. For example, web.soc is a color palette that is particularly adapted to creating drawings that are going to appear in web pages, because the colors will be correctly displayed on workstations with screens displaying at least 256 colors.

The color selection box also lets you individually change any color by modifying the numerical values that you can enter in the fields provided to the right of the color palette. You can also click on Edit to display a dialog box making the choice of colors easier.

You can use the color schemes known as CMYK (Cyan, Magenta, Yellow, Black), RGB (Red, Green, Blue) or HSB (Hue, Saturation, Brightness).
Introduction to Draw

The Option Bar

This toolbar lets you activate or deactivate various mechanisms that make drawing easier. As opposed to the other toolbars, the Option Bar isn't displayed by default. In order to display it, from the menu bar click View > Toolbars > Option Bar. When it is displayed, it can generally be found at the bottom of the screen and looks like this:

![Option Bar Image]

The Rulers

On the upper and left-hand side of the workspace, you should see the rulers. These indicate the sizes of the objects that have been drawn. The movement of the mouse in the workspace shows up on the rulers to help you position objects precisely.

The page margins in the drawing area are also represented on the rulers. It is possible to change the margins directly on the rulers by dragging them with the mouse.

You can also directly modify the units of measurement of the rulers by clicking on one of the two rulers with the right mouse button:
Introduction to Draw

As you can see from the illustration, the two rulers can have different units.
The rulers are also used to manage handle points and capture lines that make positioning objects easier.

**The Status Bar**

The Status Bar is located at the bottom of the screen. We shall look more closely at the middle part of this area, since it is particularly relevant to the Draw module. The three areas of interest to us are as follows:

The sizes are given in the current unit (not to be confused with the ruler units). This unit can be defined via **Tools > Options > Draw > General**. This dialog box also lets you change the scale of the page. You can also change the scale by double-clicking on the number shown in the status bar.
Drawing Basic Shapes

This chapter will teach you the basic methods for drawing simple shapes. In the remainder of this document, we'll use the term *objects* to designate the various shapes drawn (whether they're simple lines, rectangles or more complicated shapes). This is common notation in vector drawing software.

The following three sections illustrate how to draw three basic shapes: a straight line, a rectangle and a circle. This illustration shows the buttons on the Main Toolbar that correspond to the next three sections.

**Drawing a segment of a straight line**

Let's get started with drawing the simplest of shapes, a segment of a straight line. To begin, click on the Lines and Arrows button on the Main Toolbar. The default line on the Main Toolbar Lines and Arrows button is an arrow. To change to a line, long-click the Arrow Style button to see a list of all the different arrow heads and tails available on line segments.
To draw a straight line segment, click the straight line button and place the mouse cursor at the point where you wish to start drawing.

Drag the mouse while keeping the button pressed down. Let go of the mouse button when you want to stop drawing the line. Two blue or green handle points located at each end of the line will appear, showing that this is the currently selected object. The handle colors depend on the default select mode (they will be green for simple selection and blue when in point edit mode).

While drawing the segment, if you hold down the Shift key as well, you will force the line to be drawn at angle which is a multiple of 45° with respect to the horizontal. The star in dots shows the angles that are permitted for the straight line when the Shift key is pressed.
If you replace the Shift key with the Control key [Ctrl], the constraining angle will be 15°. You can set this angle in the Tools > Options > Drawing > Grid dialog box.

If you hold down the [Alt] key, the line will be drawn symmetrically with respect to the start point. This technique lets you draw straight lines by starting from the middle of the line.

Note: You must press the left mouse button BEFORE you press the [Alt] key to draw your line. Pressing the [Alt] key first will cause you to move the program panel instead of drawing a line.

The line you draw will have the default attributes (color, line type, and arrow style). You can change the line attributes by activating (clicking) the line. Right-click and select the line, and then make your attribute changes with the menu provided. You can reach this same dialog box by clicking the line button on the object bar.
**Drawing a rectangle**

Drawing rectangles is similar to drawing straight line segments, except that you use the Rectangle button from the Main Toolbar.

The line drawn with the mouse shows the diagonal of the rectangle.

If you hold the [Shift] key, you will get a square and the [Alt] key enables you to draw a rectangle starting from its center.

**Drawing a circle**

To draw an ellipse or a circle, use the Ellipse button from the Main Toolbar.

The ellipse or circle is defined by a rectangle that is linked to the diagonal drawn with the mouse. The diameter of the ellipse or circle corresponds to the longest side of the rectangle.

Extended functions shown by long-clicking the Ellipse button include circles, ellipses, ellipse and circle pies, segments, arcs, filled and non-filled closed shapes.
There are three other ways to draw an ellipse or circle:

- Shift-circle - forces the ellipse to be a circle.
- Alt-circle - draws a symmetrical ellipse or circle from the center instead of dragging corner to corner.

**Note:** You must press the left mouse button BEFORE you press the [Alt] key to draw your circle. Pressing the [Alt] key first will cause you to move the program panel instead of drawing a circle.

- Ctrl-circle - snaps to grid lines.

## The Basic Drawing Shapes

This section provides a complete overview of the various basic objects that you can draw in the Draw module. These objects can then be edited, combined, and manipulated to create more complex shapes. In the preceding pages, we have seen how to use some of these basic drawing shapes.

All of the tool palettes described here can be displayed from the Main Toolbar.

## The Texts

The text mode palette looks like this:

The Text tool lets you write text in the default font, color and size.

If you click on an empty space in the workspace, the text will be written at that spot. If you click on an object, the text will be written in the center of the object and will remain within the object, and the border of the object will become the text's frame.

When you've finished typing your text, click inside the frame. If you wish, you can drop to the following line by pressing the [Enter] key. The text can be edited at all times by clicking...
When you type your text, you will notice that the upper ruler includes the usual paragraph attributes: indents, first line, tab stops.

You can, as in Writer, change the style of all or part of the characters you enter. The Stylist also works here, so you can create styles that you can use again in other text frames exactly as you would with Writer.

The text frames can also be manipulated just like any other draw objects. You can assign them fill colors, shadows etc. You can also rotate the frame and write the text at any angle.

The Fit Text To Frame tool lets you type in text, but you can also change the size of the resulting text by manipulating the object's selection handles.

In the example above, the same text has been duplicated, but the selection rectangle has been changed. In order to make the effect clearer, we have displayed the border of the rectangle.

The Callout tool in the palette is used for creating captions (callouts or figure labels). In fact it's a tool that puts a frame around text and provides a connector (an articulated arrow). This tool has been used many times for the captions in this manual.
Rectangles and Squares

This toolbar palette has 8 tools:

- **Square**
- **Rectangle**
- **Rounded Rectangle**
- **Rounded Square**

These buttons let you draw filled or empty rectangles.

These buttons let you draw filled or empty squares.

**Note:** If you hold the [Shift] key down when drawing a rectangle, you will create a square.

These buttons let you draw filled or empty rounded rectangles.

These buttons let you draw filled or empty rounded squares.

Circles, Ellipses and Arcs

- **Elliptical Section**
- **Circular Section**
- **Elliptical Segment**
- **Circular Segment**
- **Circle**
- **Ellipse**
- **Arc of an ellipse**
- **Arc of a circle**
These two tools let you draw empty or filled ellipses.

These two buttons let you draw empty or filled circles.

**Note:** Drawing an ellipse while holding down the [Shift] key at the same time also lets you draw a circle.

These two buttons let you draw an elliptical sector. Here's the way to do this:

First draw the ellipse. Then indicate on the ellipse with the mouse the position of the first segment and then repeat this for the second segment. You will note the particular shape of the mouse cursor when drawing the elliptical sector.

These two tools let you draw circular sectors. The way to draw them is similar to that for elliptical sectors.

You can also draw elliptical segments. An elliptical segment is an ellipse that has been cut into two along a straight line segment. The idea is simple: first draw the ellipse, then place the first and second segment points. You will note the particular shape of the mouse cursor.

These two buttons let you draw circular segments.

This button lets you draw an elliptical arc. This works in a similar way to elliptical sectors, except that the resulting figure isn't closed.

Here again, note the shape of the mouse cursor. Just like with sectors and segments, arcs can be changed at any time.

The last tool in the ellipse palette lets you draw circular arcs.
**3D Objects**

Draw lets you draw three dimensional objects. The 3D object palette offers a choice of 8 basic primitives that can be used to create more complex objects through merging or combination.

The creation of a 3D object always works in the same way: click on the associated button and then draw a rectangle on the work area corresponding to the foreground area of the object to be drawn. A cube silhouette (boundary box) that will contain the future object is displayed.

- **Sphere**
- **Cylinder**
- **Cube**
- **Cone**
- **Pyramid**
- **Half-sphere**
- **Torus**
- **Shell**

This tool creates a cube. More generally, this tool can be used to create 3D parallelepipeds. If you want to draw a cube, press down the Ctrl key [Ctrl] while drawing your shape.

This tool lets you draw a sphere. In reality, the object drawn by default with this tool is an ellipsoid. To obtain a sphere, just press the Ctrl key while drawing.

This tool lets you draw a cylinder.

This tool lets you draw a cone.
This tool draws a pyramid.
This one lets you draw a torus (a ring).
And this one a shell or cup shape; that is, a hollowed out hemisphere.
This button lets you draw a complete hemisphere; that is, filled.

**Curves**

The curve palette offers 8 tools for drawing non-linear profiles.

These icons represent the basic tools for drawing curves. The resulting curve can be manipulated by Bezier curves as we have seen previously. The principle behind the tools is as follows:

Click on the drawing area to position the first point. Keeping the mouse button pressed down, move the mouse to draw the tangent to the curve that passes through the start point. Let go of the mouse button and move the mouse to draw the curve.

To finish the shape, double-click on the left mouse button. This operation can be repeated immediately starting from the newly created end point.

The shape you create will be filled or empty depending on the button you pressed. Where the shape is filled, a segment will be drawn from the start point to the end point. The object that results can be manipulated like any other, but you can also play with the tangents of the object in **edit points** mode.
This tool lets you create polygons. A polygon is a series of straight segments. The way it works is fairly simple: just click on the workspace to set the first point, move the mouse to the next position where you want to set a second point and click, and a segment will be drawn between the two. The polygon is drawn by repeating this procedure until all of the points have been drawn. When you have finished, double-click on the mouse to release the polygon from edit mode. If you chose to create a closed shape, a segment will link the start point to the end of the last segment that you have drawn.

This tool is similar to the previous one, but various segments will all have angles that are a multiple of 45° in relation to a horizontal axis. The shape drawn will be open or filled depending on the button chosen.

When you click on these buttons, you can draw a freehand line. The principle behind this is as follows: move the mouse and at the same time hold down the left mouse button. The movement of the mouse as shown on screen will become the curve that is drawn. OpenOffice.org actually draws a curve composed of several control points. You can check this by switching into edit points mode. Here again, depending on the icon chosen, you can draw a closed or open freehand curve.

**Lines and Arrows**

- Line ends with arrow
- Line (45°)
- Line with arrow/circle
- Line with square/arrow
- Line starts with arrow
- Line with circle/arrow
- Line with arrow/square
- Dimension line
- Line with arrows

This button corresponds to the simplest of drawing shapes, a straight line segment.

The line drawn will begin or end with an arrow.

The two ends of the segment are made up of a circle at one end and an arrow at the other.
The two ends of the segment will be made up of a square at one end and an arrow at the other.

The segments drawn will have an angle that is a multiple of 45° to the horizontal axis. You can get the same effect by pressing the Ctrl key when you draw your line.

This button lets you display the dimensions of the object being drawn. A dimension object includes a double-headed arrow, two segments that indicate the extremities of the measured zone, and a measure in the current unit of measure.

If a dimensioned object is resized, the corresponding change in size is recalculated automatically and displayed. If you group an object with dimensions, any change in the size of the object will be reflected in the sizes reported in the dimensions. In such a case, we call them associated dimensions. The dimensions can be configured using a dialog box that is available from the local dimensions menu.

The dimensions are shown as default in the unit of measurement corresponding to that of the sheet. You can change the units using the menu Format > Dimensions.

The Dimensioning options dialog lets you set up the positions of the elements that make up the dimension. You can enter line thicknesses, distance and overhang to the guide marks, text position and also change the unit of measurement displayed (or even not to display the unit of measurement).

You can also set the line type and text attributes using the classical available functions already discussed.

With this tool; you can draw a segment bearing arrows at each end.

**Connectors**

Connectors are a particular type of curve, the ends of which are attached to gluepoints on other objects, and which stick to these gluepoints when the associated object is moved. They are particularly useful for making organizational charts. You can reorganize the blocks of your chart while keeping the links between them.

OpenOffice.org Draw has a whole panoply of functions that are really quite remarkable as far as connectors are concerned. Finding the various functions is not at first sight very easy, but we shall look at the ways of making them visible.

**Connector drawing basics**

The principle behind drawing a connector is as follows: all objects have gluepoints associated with them. The gluepoints are invisible by default. The connectors you can draw position themselves automatically onto the gluepoints of the object. Draw sets the default number of gluepoints for an object to 4. We will see later how you can change the position of the gluepoints and add new ones.
The default gluepoints are located at the centers of the lines forming the edges of the selection rectangle around an object. As you can see on the following figure, this means that the gluepoints are not necessarily located on the contour of the object:

When you move one of the ends of a connector over an object, its gluepoints become visible. You can drop the end of the connector onto one of the gluepoints. Afterwards, whenever either the connector or the object are moved, the end of the connector will remain attached to the object gluepoint.

You can also drop the end of the connector onto the object. In this case, when you move the object or the connector, OpenOffice.org will automatically choose the best gluepoint in order to avoid a too lengthy connector:

Wherever possible, OpenOffice.org will attempt to avoid drawing the connector over the top of the object.

You can always break the link between a connector and an object by moving the end of the connector away from the gluepoint to which it was attached.

As with all objects, control points are associated with connectors in order to facilitate their drawing. The main control point is located in the middle of the connector and lets you decide on the size of each segment either side of the control point.
**Connector toolbar**
The connector toolbar contains a large number of buttons.

As shown by the figure above, the connectors can be grouped into four categories. Each category is subdivided into 7 connector types depending on the arrowhead for each end.

- The buttons in this row let you draw traditional connectors like the ones you have seen on the previous pages.
- These connectors are made up of a line segment and two smaller segments at the horizontal or vertical ends.
- These connectors are comprised of a simple straight line.
- These connectors are based on Bezier curves.

**Editing Gluepoints**
Gluepoint management is handled by a special toolbar. This toolbar isn't visible by default. To display it, press the button in the option toolbar.

The gluepoint toolbar looks like this:

Here's a brief description of the way these buttons work:
This button lets you insert a new gluepoint. If the object is filled, the point can be inserted anywhere within the object and not only on its contour. After you've chosen this tool, click on the object to add the gluepoints.

The gluepoints remain visible for as long as the button is pressed down. They are displayed as little blue crosses and the gluepoint that is currently selected appears highlighted. You can move the gluepoints with the mouse and delete them with the [Del] key.

These four buttons let you choose the directions of movement that are allowed around the junction of a connector gluepoint. You can also select several of these buttons for any given gluepoint. Here's an example of their use:

Here's a very simple drawing to which a gluepoint has been added.

By default, connector lines can attach themselves to this point from any direction. Now click on the . The effect of this is to force any connector placed on the gluepoint to come in from the left as shown in the following drawing:
If, when you are in gluepoint edit mode, you click on the button, you can add a new possible direction to a gluepoint. If we keep the preceding example, this would give:

![Image of a blue oval with a connector]

The addition of this extra direction enabled OpenOffice.org to draw a shorter connector.

When this button is pressed (as it is by default), any resizing of an object will cause gluepoints to move with the associated object. If this button is deactivated, the gluepoint will not move, as shown by the following illustrations:

![Image of a blue oval with and without gluepoints]

When the button is deactivated, the last six buttons on the toolbar that were grayed out now become usable. These buttons let you choose how the glue points will be rearranged when the object is re dimensioned.

These three buttons let you choose the horizontal positioning of the gluepoint. You can choose to maintain the same position with respect to the left edge (1st button), with respect to the center (2nd button) or with respect to the right edge (3rd button).

These three buttons let you choose the vertical positioning of the gluepoint. You can choose to maintain the same position with respect to the upper edge (1st button), with respect to the center (2nd button) or with respect to the lower edge (3rd button).
In this chapter, we shall look at the tools and functions that let you modify existing drawings. All of the functions apply to the selected object or group of objects. The selected object differentiates itself from any others by small colored squares or circles located around the object (this is also true when several objects are selected simultaneously). In the rest of this document, we these points *handles*.

These handles form a rectangular frame that is just big enough to contain the object. Where several objects are selected, the frame around them corresponds to the smallest rectangle that can contain all of the objects. This frame is called the *selection rectangle*.

If the Option Bar is displayed, it is possible to change the size of the handles using two buttons: 'Simple Handles' shows the handles as flat squares, and 'Large Handles' shows the handles in a larger size. You can combine the effects obtained by pressing on both buttons. You can thus have large handles having a 3-D shape or small handles having no 3-D shape. This illustration shows the location of the handles and other buttons:

![Diagram of selection modes](image)

**Selection modes**

There are three selection modes.

Selections used to move or change size are indicated by small green squares. This is the default selection mode when the Edit Points button is not pressed.

Selections for rotating objects are indicated by small red circles and a symbol representing the center of rotation.
Selections for the Edit Points mode are indicated by blue squares. An extra, larger handle also appears on most drawings. When the Edit Points button is pressed, this is the default mode.

The default mode for selecting objects is set by the activation or deactivation of the Edit Points button.

**Changing the selection mode**

To go from one mode to another, you can do the following:

- Choose the Edit Points button from the Options Bar to switch from simple selection mode to Edit Points mode. You can also use the keyboard shortcut $F8$ (Edit Points).
- Press the Rotate button from the Main Toolbar to activate the rotation mode for a selected object.
- By choosing the Rotation Mode after Clicking Object button from the Options Bar, you can cycle through normal and rotation modes just by clicking on the object. This could be more convenient than clicking the object, then clicking the Rotate button from the Main Toolbar.

**Selecting Objects**

**Direct selection**

To select an object, the easiest way is to click directly on it. For objects that are not filled, you have to click directly on the object's outline to select it.

**Selection by framing**

You can select several objects by dragging a large rectangle around the objects with the select button:

For an object to be selected, it must be entirely within the rectangle.

---

2 Keyboard shortcuts can be configured by the user (Tools > Configure > Keyboard).
Selecting hidden objects

When objects are located behind others, they can still be selected. To select an object that is covered by another object, hold down Alt and click the object. To select an object that is covered by several objects, hold down Alt and click through the objects until you reach the required underlying object. To cycle through the objects in reverse order, hold down Alt+Shift when you click.

There may be some variation in the use of the Alt key on different operating systems. For example, in my Linux system, the Alt key does not function as described here.

To select an object that is covered by another object using the keyboard, press Tab to cycle through the objects. To cycle through the objects in reverse order, press Shift+Tab.

The easiest method is to use the Tab key to cycle through the objects, stopping at the object you wish to select. (This may not be practical if you have a large number of objects in your drawing.) When you click on your selected object, its outline will appear briefly through the objects on top of the selected object.

In the illustration below, the square located beneath the circle was selected in this way (the circle was made transparent in order to see the square):

Arranging objects

In a complex drawing, you may have objects stacked up, one on top of the other. You can rearrange stacked objects by clicking Modify > Arrange and selecting the appropriate Bring Forward or Send Back options, or by right-clicking the object and picking Arrange from the context menu. A keyboard shortcut is Shift+Ctrl ++ to bring an object to the top, and Shift+Ctrl+- to send an object to the bottom.

Selecting several objects

In order to select or deselect several objects one by one, press the Shift key and click on the various objects to be selected or deselected.
Moving and Dynamically Adjusting the Size of an Object

There are several ways of moving or changing the size of an object. The method described here will be called *dynamic* in the sense that it is carried out using the mouse.

When you dynamically change an object, remember to check the left hand area of the status bar at the bottom of your screen. This shows detailed information about the ongoing manipulation. For example, during a resizing manipulation, you will see the following information displayed:

The information displayed changes when the mouse is moved.

**Dynamic movement of objects**

To move an object, select it and then click within the selection frame and hold down the left mouse button while moving the mouse. In order to drop the object at its new location, let go of the mouse button. During movement, the shape of the object appears as dotted lines to help with repositioning.

**Dynamic size modification of objects**

In order to change the size of an object (or group of selected objects) with the mouse, you need to move one of the handles located around the selection. As shown in the following illustration, the outline of the resulting new object appears as a dotted line.

The results will differ depending on which handle you use. If you choose a corner handle you will resize the object along two axes at the same time. If, on the other hand, you use a side handle the objects will only be resized along one axis.
Note: If you press the \textit{Shift} key at the same time as you carry out the resizing operation, the size change will be carried out symmetrically with respect to the two axes, which enables you to keep the height/length ratio of the object. With the \textit{Alt} key, the object is resized symmetrically starting from its center.

**Rotating an Object**

Rotation of an object lets you slant an object along an axis. In order to do this dynamically, you use the red handles, as with changing the size of the object.

Rotation works in a slightly different way for 3-D objects (since the rotation occurs in 3D space and not in one plane).

To rotate an object (or a group of objects), drag the red corner handle points of the selection with the mouse. The mouse cursor takes the shape of an arc of a circle with two arrows at each end. As with the preceding operations, a dotted outline of the object being rotated appears and the current angle of rotation is dynamically shown in the status bar.

Rotations are made about an axis which is displayed as a small symbol. You can move the axis of rotation with the mouse, as shown below:

![Axis of rotation](image)

If you hold down the \textit{Shift} key during the rotation, the operation will be carried out in increments of 15°.

**Inclination**

To incline or slant an object, use the red handles located on one of the edges of the selected object. The inclination axis is shown as the nearest handle to the opposite edge:

![Inclination](image)
Editing Objects Part I

This operation functions in the same manner as rotation in that you can set the inclination to occur as steps of 15° by pressing the Shift key during movement of the handle.

Editing Object Points

Draw offers a complete set of tools that let you accurately edit the contour of an object. As we shall see, the functions related to editing points work substantially in the same way as on curves. To make the most of these tools, you'll have to convert your objects into curves, as will be described later on.

Direct operation

Some objects can be manipulated in 'Edit Points' mode without having to convert them into curves. When you do this you act directly on the properties of the object. The objects involved are defined by the presence of one or more extra handle points. When you manipulate this handle (which is generally larger in size than the other selection handles), you will obtain various effects. The mouse cursor takes the shape of a folded hand when it passes over one of these points. Here is the complete list of the objects concerned.

Rectangle or square.

In this example, you can make the corners more or less rounded.

Arcs or ellipses.

In this example, you can change the associated angles. Arcs have two control handles.

Circular or elliptical segments.

In this example, you can change the position of the edge of the segment.
How curves work

Editing curves works on the basis of a method called Bezier curves\(^3\). The complete study of such curves goes beyond this particular work. We shall cover the basics of this quite powerful method of editing the contour of an object.

Editing a point in a Bezier curve uses several mechanisms as represented in the drawing on the left: The main point is called the junction point. Two tangents project from this point, enabling manipulation of the curve that passes through the junction point. The basic idea is that, around the junction point, the two sides of the curve 'flatten' out more or less along the tangent depending upon the size and position of the tangent.

You can create all manner of shapes by moving either the junction point itself, or one or both of the round handle points at either end of the tangent.

The Bezier Curve Toolbar

When you work in edit point mode, the object bar changes as shown in Figure 8.

On this toolbar, some buttons can be pressed or not. Their behavior is then different. The role of the three buttons enabling you to choose the type of tangent will be described in the following chapter. They are the sixth, seventh, and eighth buttons in the toolbar. The functioning of the other remaining buttons will be described in relation to working examples.

The three kinds of tangent

Three buttons in the toolbar let you select the type of tangent and convert from one type to another. Only one of these buttons can be depressed at any given time.

The \(\circ\) button lets you work with a symmetrical tangent. Any movement of one or the other of the handles will be carried over symmetrically to the other one.

---

\(^3\) Bezier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, who developed the technique in the 1960s. The technology was intended to make modeling the surface of vehicles easier.
The button lets you separate the lengths of the two parts of a tangent. In the drawing opposite, you can clearly see that the curve is flatter on the longest side of the tangent. This kind of tangent is known as a smooth junction. This button is not to be confused with the preceding one, since their representations are fairly similar.

It is also possible to completely detach both sides of the tangent. In this case, the central point is known as the inflexion point. Using this technique, you can draw spikes and troughs in objects. Use the button to create an inflexion point around the selected point.

**Examples**

The following examples start from a filled circle. As mentioned earlier, in order to use the Edit Points mode, you need to convert the object to a curve. This can be done on the selected object by clicking the right mouse button or by choosing **Modify > Convert > To Curve** from the Menu Bar.

You will notice that after conversion, the handles located in the corners of the rectangle have disappeared. This behavior is normal in that the handles which are used in Edit Points mode are located along the trace of the drawn object.

The Move Points mode is the default mode when editing points. If it hasn't been activated, click on the button. When this mode is active, the mouse cursor has the following shape when it is hovered over an edit point:

Movement of the junction point is one of the easiest manipulations to do. The drawing opposite illustrates how an egg can be drawn very easily by starting from a circle and dragging the the top edit point upwards.
To change the location of the tangents, just move the circular handles at each end. The mouse cursor will then look like this:

This button lets you add an extra point to an existing curve. Just click with the left mouse button on the curve at the spot where you want to insert a point and then move the mouse slightly, in any direction, while holding down the button. If you just click, the new point will not be added.

The tangent attributes that are associated with the new point will depend on the buttons that are pressed in the toolbar.

This button has the opposite effect: it subtracts one or more points from the curve. The resulting curve will stretch itself automatically around the remaining points after subtraction.

Firstly, select one or more points to delete.

You can select several points by holding down the Shift key (1).

Then click on the button. The selected points disappear from the curve that will then reform around the remaining points (2).

Note: You can also delete the selected points using the Del key on your keyboard.
The object rotation button 🔄 can be used in Edit Point mode. In this case, it can be used to move a point around the contour of an object.

Switch into rotation mode by clicking on the 🔄 button. You will notice that in rotation mode, all of the tangent points become red dots.

Select the point to be moved and then drag it around the contour while keeping the left mouse button pressed down (➊). When you let go of the mouse button, the point will be moved to the new position (➋).

If you move one of the handles located at the end of the tangents during rotation, you will make the object rotate in exactly the same way as with the usual rotation operations.

This button lets you cut a curve at the height of the selected handle. If the object is filled, it will be emptied insofar as the curve that represented the edge is no longer closed.

Check that you have selected the correct handle (➊), press on the 🔄 button (➋) and notice that the object is no longer filled. You can then check by moving the point, that the curve has indeed been separated (➌).

>Note: if you have an open curve, the start point of the curve is larger than the others.
You can also separate a curve at several points simultaneously. Just keep the Shift key pressed down and select all of the points at which the cut should occur.

The button lets you close an existing curve. Select an open curve and click on this icon to close it.
The Select Points button functions as a switch. It works as follows.

If you have two points linked together by a straight line (you don't need to have a curve between the points) and you insert a new point between them that is set at an angle to the initial straight line (and hence the two endpoints), you will have a drawing similar to that illustrated in ➊.

If the Select Points switch is deactivated, and you move the point you've just inserted, to bring it back close to its initial position in the straight line, you will have a drawing similar to that illustrated in ➋.

If the switch is activated, moving the point back towards the axis of the initial straight line will cause the line to snap into place and the new point will be hidden from view (as illustrated in ➌). The new point will not have physically disappeared however, and you can bring it back into view by just dragging the mouse cursor (represented by a cross-hair) away from the axis of the straight line.
This chapter describes how to change object attributes, use the Stylist to apply attributes to objects, and apply special transformations to objects.

**Changing Object Attributes**

Each object comes with a set of associated attributes that characterize the appearance of the object. These attributes, such as color, the contour type, line thickness, etc., can be modified whenever you want.

A toolbar and a dialog box are dedicated to the modification of these attributes. The main attributes can be directly modified from the object toolbar (located by default above the workspace). Depending on the currently selected object, the Object Bar changes appearance.

The default Object toolbar is applicable to all objects:

![Object toolbar](image)

When editing texts, a new toolbar appears:

![Text toolbar](image)

This toolbar is split into two parts. To go from one to the other, use the arrow button located at the right end of the Object toolbar. The second part of the toolbar will then appear; it is the default Object toolbar shown above.

**Changing Attributes using the Context Menu**

When an object is selected, a right mouse button click on the object brings up a context menu that provides yet another way to access the functions for changing object attributes.
The Object Toolbar

The buttons in the Object toolbar let you change the following properties.

**Line type**

Clicking this button opens a dialog box in which you can choose the properties of the currently selected line. If you want to change the properties of arrows, the line, its thickness or color, you can also directly use the four areas provided in the toolbar, as described later in this section.

The Line dialog box has three tabs. The first tab lets you edit the most common properties of the line. Notice that transparency and the pointedness of the ends of the line are only editable from within this dialog. Select the Synchronize ends checkbox to force the arrow ends of a line to be the same.
The second tab lets you finely tune the type of line you want to have. Using this dialog, you can define the appearance, number, size, width and spacing of the dashes or dots making up the line. With the Add button, you can create a new type of line and insert it into the Type list. You can also modify or delete existing line styles. The Load Line Style and Save Line Style icon buttons are there to help you save a new definition or read one from disk (file extension .sod).

The third tab lets you add new end types (styles) to the line. As you can see, there is no way to draw the end types using the dialog box.
Choosing line attributes from the object toolbar

The Arrow Style (line ends) button located to the right of Line button on the Object toolbar lets you directly choose the line ends in a small window. You can choose each end independently of the other.

Note: If you frequently need to use this function, don't forget that you can detach the window by clicking on it with the mouse button and dragging it (by its title bar) to a new spot. That way it will stay visible on the workspace.
The drop-down menu located to the right of the Arrow Style button lets you directly choose the line type without going through the corresponding dialog box.

The next area concerns the width (thickness) of the line expressed in the current unit of measurement. You can enter this value manually in the area provided or use the spinbox to change the value.

The drop-down box to the right of the line width box lets you choose the line color. The various colors available in the color palette are displayed.

Area Fill

The Area fill button and dialog box let you choose the fill mode for the selected object.

The Area dialog box has several tabs, which are described on the following pages.
The first tab, Area, lets you make a quick selection of the type of fill that you want, whereas the other tabs let you change, delete or add a given fill type. The four possible fill types are:

- simple color
- gradient
- hatching
- bitmap

The Shadow tab lets you choose whether to apply a shadow to your object. The shadow lets you simulate the floating of an object above the drawing area.
The shadow will match the contour of the object that has been selected. This tab also lets you set the color and distance with respect to the object, position, and transparency of the shadow.

The figures shown above have a gray shadow with 50% transparency.

The Transparency tab lets you set the fill transparency of the selected object. For example, you can set the transparency to be non-uniform.

You can preview the current gradient (the result of your selections) in the area on the right-hand side of the dialog box.
The Colors tab lets you edit the palette of available colors. You can choose the fill color of an object by clicking on one of the colored squares and then clicking OK.

Several gradients are predefined. The parameters used to define the gradients are similar to those that are available for transparency.
The Hatching tab lets you define a hatch motif. Indicate the spacing between the lines (in the current unit of measurement), hatching angle, line type (simple, double, triple), and color.

The seventh and final tab, Bitmaps, lets you cover selected objects with a pattern obtained from a bitmap image. Any of the bitmap formats recognized by OpenOffice.org can be used.

In order for the mapping of the image onto the selected object to be of sufficient quality, it is necessary to use bitmap images that contain repeating patterns. Use the Import button to create a new pattern from an existing file.
The Pattern Editor on the left lets you draw a simple pattern from two colors. To draw a pattern, click on the various boxes in the grid, using either mouse button. The mouse button toggles between the foreground and background color. Your bitmap pattern will display in the preview pane in the lower part of the window.

**Choosing area fill patterns from the object toolbar**

The two drop-down lists located on the right of the object toolbar enable quick selection of a fill pattern without having to go through the dialog boxes that have just been described. The first list lets you choose the fill type (Color, Gradient, Hatching and Bitmap), and the second list is used to select the specific fill. The content of the second list depends on the choice (Color, Gradient, Hatching and Bitmap) made in the first one.

If you choose Invisible in the first list, the selected objects will become transparent - that is, no fill at all.

The last button on the object toolbar enables and disables the placing of a shadow on the selected objects. It functions as a toggle switch.

**The Text Object Edit Toolbar**

When the selected object is a text frame, the toolbar doubles up to add extra buttons dedicated to formatting text. Click the blue triangle at the right hand end of the toolbar to display the Text Object Edit Toolbar.

This toolbar comprises the usual text functions (similar to those that can be found in the Writer module) that let you set the font, paragraph alignment, etc. These are fairly standard and will not be discussed in more detail here.

**Manual Editing of Object Size and Position**

The preceding sections were devoted to dynamic modification of the attributes of one or more objects, with dynamic meaning that all changes were carried out with the mouse. This technique has the advantage that you can continuously see the changes being made, but with the disadvantage that it is not very precise.
When an object is selected, pressing the F4 key (Position and Size) or using the right-click menu and choosing Position and Size displays a dialog box with four tabs, where you can enter precise values concerning size and position.

**Entering Position and Size data**
Use the Position and Size tab on this dialog to enter the position data for the X and Y axes in the current unit of measurement, and the size data described in the next paragraph. You can also indicate the base point for the object. Click a base point in the grid, and then enter the destination coordinates to where you want to shift the object relative to the base point that you selected in the Position Y and Position X boxes. The base points correspond to the selection handles on an object.

If you select either of the Protect checkboxes, the object can no longer be moved. You'll have to deselect the box to move the object again.

**Size Data Entry**
The Position and Size tab is also used to specify the size of objects. If the Keep ratio checkbox is selected, any changes made to one of the dimensions will automatically be applied to the other dimension, which enables the length/width ratio of the object to be maintained. If the object is a text frame containing text, two further tickboxes are available, to let you automatically adapt the width and height of the frame around the text.

As with the preceding dialog, you have to indicate the Base Point with respect to which the change will take place. For example, if you click on the center Base point, any size change will be made symmetrically with respect to the center of the object.

**Angle of Rotation Data Entry**
The Rotation tab lets you specify the position of the axis and angle of rotation of the object. You also have to define the base point from which the axis of rotation is measured, as
described in the preceding topic. The zone marked Default Settings lets you quickly choose the angle of rotation in 45° steps.

**Inclination Data Entry**
The last tab of this dialog is used to enter the rounded corners (corner radius) and the angle of inclination of the object. Illustration 90 shows a rectangle that has been slanted by 15 degrees and had its corners rounded by a 0.5 cm radius.
Using the Stylist

The application of the same style to several different objects can soon turn out to be a tedious job with the drawing tools. Fortunately, OpenOffice.org comes to the rescue with the Stylist. This window, as in the Writer module, lets you define particular styles and apply them in a single operation to several objects simultaneously. Some of the Stylist functions that relate to the use of the OpenOffice.org Impress module will not be described here.

You can show and hide the Stylist with the button on the Function Bar or by pressing the F11 key. The Stylist appears as a floating toolbar window. You can click in the title bar of the Stylist and drag it to a convenient location on your display.
Applying a Style

To apply an existing style to one or more objects, all you have to do is select them and double-click on the required style. You can also use the Fill All mode. When this button is pressed, the mouse cursor changes into a paint can; then just select all of the objects to which you want to apply the current style.

In the following example, we will create a particular style comprising a shadow, a thick blue border, and brick motif bitmap fill.

The first step is to create the style. To do this, select the object whose style you wish to add to the list of styles, then click the Create Style button in the Stylist window. Type the name of your new style in the Create Style dialog box.
The next step is to apply your new style to other objects. Select your new style, Brick wall with border and shadow, then click the Apply Style button (the paint can button), then click the objects to which you wish to apply this new style. The new style will be applied to the objects as you click on them.

If you first press the paint can button, click on the graphic object to see your new style attributes applied immediately:

![Illustration 21 - Applying a style](Image)
**Changing a Style**

All of the objects memorize the style that has been applied to them. If you modify the basic style, all of the objects that are associated with this style will be modified as well. To change a style, use one of these methods:

- You can directly change the style of an object by applying the various techniques that have been described earlier in this document, then simply click on the Update Style button.

- You can also change a style directly in the Stylist. Just right-click on the name of the style and choose Modify.

**Creating a New Style**

There are two ways of creating a new style:

- Right-click in the Stylist and choose New from the pop-up menu. Enter all of the style options in the dialog box, name the style, and click OK. The new style will appear in the list.

- You can also use the method known as copying by example, by creating a new style from the properties of an object. Choose an object from which you want to create a style, and then click on the New style from selection button in the Stylist. A dialog will ask you to enter the new style name; this name will appear in the list afterwards.

**Special Transformations**

In the toolbar, the rotation button gives you access to a sub-menu of functions grouped under the heading Effects. Each button is associated with a set of special transformation functions. The submenu window looks like this:
**Flip**

This function lets you flip an object with respect to a given axis that you can define precisely. Here's an example explaining how this tool works:

Here's the object you want to modify.

Once you've clicked on the Flip button, a red axis of symmetry with two handles appears in the center of the object. The flip will occur with respect to this axis.

The axis of symmetry can be moved by dragging it with the mouse. You can also change its angle by pulling on one of the handles.

When the axis of symmetry is where you want it, you can proceed to next step. Click on one of the handles of the object, and keeping the mouse button pressed, drag it onto the red axis. A mirror image is projected onto the other side of the axis as a dotted outline.
Release the mouse button and the flip transformation is complete.

3D Rotation Objects

This function lets us enter the world of three-dimensional objects. With this tool you can get a 3D object by rotating a profile that you've drawn about an axis of rotation. It's useful for drawing common objects found in daily life, such as vases, glasses or bottles. Here are some examples of 3D drawings obtained from simple profiles:

The profile can be open or closed. The way this tool works is similar to that used for reflection. An axis is positioned around which the rotation occurs. Here's an illustration of the way it works:
Here's the start profile. It was made with the polygon drawing tool.

When you click on the button, a red axis with a handle at each end shows up at the edge of the profile.

The resulting profile is displayed on the other side of the axis to give you an idea of the result.

So that the resulting drawing looks like a glass, you need to move the axis of rotation itself by dragging it to the other side of the profile. The resulting form is drawn around the axis of symmetry.

You can incline the axis by moving the handles located at the ends.

---

4 Another way to do this is to use the Flip effect on the 2D polygon drawing, then use the 3D rotation effect.
To see the end result, click on the 2D object that you've created.

To make the object more visible, we changed the color to blue and applied a 50% transparency.
**Distort**

This tool lets you distort an object by freely moving the handles located at the edges of its selection rectangle. A rectangle can for example be easily transformed into the following shape:

![Distorted Rectangle](image)

The principle behind distortion is very simple: by moving the selection handles located at the corners of the rectangle, you can stretch the object as you wish. If you move the handles located on the edges, you can slant or incline the object.

*Note: When you choose to distort an object with this function, OpenOffice.org will ask you first of all to transform the object into a curve (as for the point edit mode). This transformation is irreversible.*
Dynamic Transparency Gradient Definition

The transparency dialog box lets you adjust all of the parameters linked to this, but it's not always easy to see what your changes will look like before you've saved them.

The dynamic transparency gradient definition function lets you adjust the transparency attribute of an object. It is very easy to use. When you click on the button, an arrow appears on the selected object.

By moving the two squares at each end, you dynamically change the transparency of the object. The black square lets you choose the opaque side and the white square the transparent side. You can click on one of the boxes in the color palette to change the color of the object (and thereby the color of the opaque side). Click outside the object to apply the transparency changes.

Note: The changes that you can do using the arrow will depend on the type of transparency that you've chosen. For example, with axial transparency, the square located at the center of the object can not be moved, and you'll only be able to carry out operations on the other square. In a transparent square, the arrow can be moved as you wish.
Dynamic Gradient Definition

This tool works just like the tool for managing transparency. It is only activated if the selected object is filled with a gradient. Clicking on the gradient button will display an arrow on the selected object.

The two ends of the arrow correspond to the start and end colors of the gradient. You can change the colors of the two squares by clicking on a box in the color palette and dragging it on the required square. The squares and the arrow can be moved freely. The movements of the squares show up immediately on the gradient of the selected object. Click outside the object to apply the changes to the gradient.

Note: The changes that you can carry out on the arrow will depend on the type of gradient that you've chosen. For example, for a linear gradient, the start and end squares of the gradient will always be situated to either side of the center point of the object.
Managing 3D Objects and Bitmaps

This chapter describes the tools and functions that let you create powerful 3D drawings and work with bitmaps such as photographs.

Managing 3D Objects

Even though OpenOffice.org does not claim to rival leading 3D image software packages, it contains a number of tools that let you create powerful 3D drawings.

Rotating 3D objects

The rotation function also works with 3D objects, but differently from flat objects. Rotation acts in a three-dimensional space as shown in Figure 22.

For 3D objects, the axis of rotation is indicated by the symbol $\Theta$.

<table>
<thead>
<tr>
<th>To do this</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate the object about the x-axis.</td>
<td>Move the left and right (edge) handles.</td>
</tr>
<tr>
<td>Rotate the object about the y-axis.</td>
<td>Move the top and bottom (edge) handles.</td>
</tr>
<tr>
<td>Rotate the object about the z-axis (the axis</td>
<td>Move the corner handles.</td>
</tr>
<tr>
<td>coming out of the page).</td>
<td></td>
</tr>
<tr>
<td>Re-locate the axis of rotation.</td>
<td>Move the $\Theta$ symbol.</td>
</tr>
</tbody>
</table>
Managing 3D Objects and Bitmaps

3D effects

3D objects have their own configuration dialog. This dialog is called the 3D Controller or the 3D Effects dialog. Click on the button to display it (Main toolbar). The dialog contains several pages that can be selected through the buttons at the top. This chapter discusses each of these pages in turn.

Buttons available in pages

All of the pages have the following buttons:

- Convert a 2D object into a 3D object. This function is also available through the context menu Right-click > Convert > to 3D
- Create a 3D cone object.
- Activate or deactivate perspective display for the selected object.
- Do not apply the light and texture parameters to the selected object. Only apply 3D attributes.
- Apply all attributes to the selected object.
- Apply changes to the selected object.

Favorites page

The Favorites page lets you apply 3D attributes to any 3D object.

---

5 There is a slight inconsistency between the bubble help that you get when the mouse crosses over the button and the actual name of the dialog when displayed.
To apply a 3D attribute to a selected object, choose an example from the **Favorites** zone and click the ✓ button. (The objects laid out as an example are the same as those that are available through the Gallery, which is described later in this document.) Note that only the attributes are applied; no objects are transformed. For example, a circle will not turn into a torus if you click on the first image of the Favorites page, but it will receive the attributes of the torus, including the blue color.

If the selected object is not a 3D object, it is converted into one. The operation that converts a 2D object into a 3D object is called an *extrusion*.

To apply a 3D attribute, choose one of the attributes from the examples shown and click on ✓.

This mechanism lets you create a variety of objects. Some examples are shown below.

As an example, this is how the circle above was created:

1) Draw a circle.

2) Go to **Modify > Convert > To 3D** to change the circle to 3D.
**Geometry Management page**

The Geometry Management page lets you define the geometric settings that are linked to a 3D object. To access this page, go to **Format > 3D Effects > Geometry**.

The **Rounded edges** parameter applies when you turn a 2D shape into a 3D shape. It defines the degree of rounding of edges during conversion, as shown in Figure 23.

![3D Effects](image)

This parameter is particularly useful for texts that have been extruded into 3D shapes.

The **Scaled depth** will define the dimension ratio between the front face and the back face of the object. By default, the scale is set to 100%, which means that both faces will have the same dimensions. If you set the scaled depth to 50%, for example, with the cube above, you get the object shown in Figure 24.

![Figure 23 - Rounded edges with (a) 0% rounding and (b) 25% rounding](image)
Managing 3D Objects and Bitmaps

Here you can see that the front face has a length and breadth that is 50% smaller than the back face. It is even possible to set the scaled depth to more than 100% and thus have a front face that is larger than the back face.

The Rotation angle parameter is useful for some shapes that are made by revolving a profile about an axis. This parameter lets you decide whether or not the rotation will be complete (360°). Figure 25 shows what you can obtain with a hemisphere and a value of 270°.

The Depth parameter lets you define the depth of a 2D object that has been transformed into a 3D object. This value can be changed at any time. The parameter doesn't apply to 3D primitives.

The two following parameters (Horizontal and Vertical segments) let you define the number of segments for the rounded shapes. The higher the number, the smoother the surface of the shape will be, but the longer it will take to display. In Figure 26, the left-hand sphere is made up of 10 horizontal and vertical segments, whereas the right-hand sphere is made up of 25 segments.

The five following buttons (called Normals) let you modify the normals of your 3D objects. A normal is a straight line that is directed perpendicularly across the surface of an object.

Note: Format > 3D > Geometry to access this menu.
Figure 27 shows a few normals drawn on a sphere with 10 segments.

![Figure 27 - Object Normals](image)

Normals let you define the exterior aspect of an object and its interactions with textures and lighting. When you change the normal mode (also known as the *projection mode*), you act on the geometry of an object. Here's a description of the functions that act on normals.

- Corresponds to the projection mode illustrated above, wherein each of the faces is visible.

- Lets you create smooth surfaces. Where a sphere is concerned, we obtain a perfect sphere:

![Figure 28 - Sphere with smooth faces](image)

I have kept the normals drawn on the shape so that you'll remember that the faces are still present even if they can't be seen.

- Lets you choose the object-specific rendering that is best suited to the object.

- Lets you invert the normals. Since normals help you to define how an object is lit, you can simulate an interior lighting by inverting the normals. The following is an example of two cups. The first has the normals set to the default value and the second has the normals inverted:

![Figure 29 - Inverting normals](image)

The second cup seems to be lit from the interior.
Double-sided illumination lets you light an object from the inside and outside.

Lets you create double or single-sided 3D objects. When the extrusion function is used, the resulting objects are closed (for example, a square will give a cube). If you use this function, Draw will produce open objects.

Here's an example of extruding an empty rectangle:

![Figure 30 - Single-sided object](image)

**Shading page**

The Shading page covers the parameters linked to the shading of objects (such as shading type and shadow).

---

6 In the online help, this button is called 'double-sided'.

---
The **Shading mode** refers to the method that Draw uses to render objects and their interaction with light. Draw offers three choices: Flat, Phong and Gouraud.

- **Flat** is the quickest technique, but it also gives the worst results (all of the faces are visible).
- **Phong** is an intermediate technique.
- **Gouraud** renders objects with the highest quality.

In the above drawing, flat shading (left) is clearly less attractive, whereas it is more difficult to distinguish between Phong (middle) and Gouraud shading (right). One might simply note that the shading appears to be more realistic with Gouraud shading than with Phong shading.

The **shadow** area of the dialog lets you display shadows under 3D objects. By changing the surface angle, you can obtain shadows that look more elongated or less elongated:

The first 3D sphere has a shadow with a surface angle of 0° (the paper is vertical) and the second has a surface angle of 45° (paper inclined at 45°).

You can also see that the shadow is displayed in such a way that it corresponds to the angle of illumination of the sphere.

The other parameters on this page let you define the **focal length** and **distance** of the virtual camera that displays the 3D object. The closer the camera (focal distance), the greater the effect of perspective. In Figure 33, the same box is shown on the right, but with a shorter focal distance for the one on the left:

These two settings belong to the selected object(s). In general, it is better for these settings to be the same for all 3D objects in the drawing.
Illumination page

Use the Illumination page to define the way in which 3D objects are illuminated. Contrary to most 3D drawing software, the parameters can be set for each object independently of the others. However, in order for the drawing to be coherent, set these parameters the same way for all 3D objects.

This page lets you select 8 different light sources to illuminate the currently selected object. For each light source, you can specify its color and position with respect to the object.

In order to choose the current light source, use the buttons representing a small lightbulb. The bulbs that are lit correspond to an active light source and those that are not correspond to an inactive light source. Double-click on a button to active or deactivate the corresponding light source. A button that appears pressed down indicates the currently selected light source.

Figure 33 - Examples of different focal lengths
The color can be chosen from the dropdown list or by using the small button on the right of the list. The position of the light source is defined by moving the colored dot with the mouse or the slider bars on the small inset drawing located in the lower area of the page. Then click the ✔️ button to implement the light source setting.

**Texture Management page**

The Texture Management page lets you manage the properties of a bitmap texture applied to an object.

Before using this page, we'll look at the two ways you can apply bitmapped images to an object.

- Use the fill option and select a bitmap motif.
- Use the Gallery. To apply a texture, first display the gallery (Tools > Gallery). Then drag and drop the motif with the mouse while pressing the Shift+Control keys.
The first method is better in that you can easily choose the number of tiles of the bitmap motif to be applied. To obtain the bitmap application settings dialog, select **Format > Area** and make your background edits there.

Figure 36 shows a few examples of what one can do by changing the default parameters when applying a bitmap to a cube.

**Note:** The checkbox **Tiled** in the dialog lets you specify whether you want the motif to be repeated (as in the cube top left) or not (as in the bottom right cube).
Managing 3D Objects and Bitmaps

We have just seen how to change the number of tilings of the bitmap pattern. Now let's look at the method that Draw uses to project the image onto the object. This is done on the Texture Management page.

First, you can choose to project the image in black and white ( выполняется в черно-белом режиме) or in color ( выполняется в цветном режиме).

The **Mode** chosen will tell Draw whether you want to manage lighting and shadow on the selected object. In Figure 37, the first sphere corresponds to the setting **Only Texture** and the second (more realistic) to the setting **Texture and Shading**.

![Figure 36 - Examples of applying bitmaps](image)

Figure 36 - Examples of applying bitmaps

![Figure 37 - Example of texture settings](image)

Figure 37 - Example of texture settings

The six following buttons (Projection X / Y) let you specify the type of projection used to draw the motif on the object. The settings on the X and Y axes are as follows: Object-Specific ( специфический для объекта), Parallel ( параллельный) and Circular ( круговой). Generally, the default setting of Object-Specific can be left as it is because it gives the best results.

**Note**: **Format > 3D > Textures** to access this menu.
Materials Management page

The Materials Management page concerns the use of materials on the surface of 3D objects. This page lets you give objects the appearance of commonly used materials such as plastic or metal.

The drop down list **Favorites** lets you choose a predefined texture. The default choices are Metal, Gold, Chrome, Plastic and Wood (see Figure 38).

The parameters that need to be defined are the default color of the object, lighting, and the color and intensity of the spot. The spot shows how the light reacts on the object.

Note that materials are compatible with textures. The use of materials generally lets you accentuate the effect of any applied textures.
Managing Bitmaps

Up to now, we have only dealt with vector drawings. Draw also includes functions for managing bitmaps, such as photographs.

We won't deal very much with the bitmap editing tools since other programs (such as The Gimp) have more advanced functionality.

The Bitmap Image Toolbar

When a bitmap image is selected in the workspace, a dedicated toolbar is displayed (Figure 39).

Note: Any changes you make to a bitmap will change only a copy of the image file in your document. The original image will not be modified.

The type of display for the image. The four options are:

- Default
- Grayscale: displays the bitmap with 256 levels of gray
- Monochrome: transforms the image into a black and white representation
- Watermark: fades the colors of the bitmap image to make it extremely pale

These controls let you modify the level of each of the primary colors in the image.

You can set each color level from –100% (no color) to +100% (full intensity).

Adjust the brightness of the image. The parameter can be set from –100% (totally black) to +100% (totally white).

Adjust the contrast of the image from –100% (least contrast) to +100% (most contrast).

Adjust the gamma level from 0.10 to 10. This control lets you effectively set the monitor balance for an image created on one computer when the image is loaded on another computer.
Adjust the transparency of the image from 0% (opaque) to 100% (totally transparent).

This tool lets you crop an image. When you click on this button, the dialog box shown in Figure 40 appears:

![Figure 40 - Cropping an image](image)

The dialog in Figure 40 lets you do the following:

- Cut out a part of the contour of the image. To do this, just change the values in the **Crop** section (such as **Left** and **Right**). The preview display area show the new image frame.
- Change the scale of the image up to 100%.
- Change the size of the bitmap in the current measurement unit.

**Bitmap Image Management Palette**

The leftmost button on the bitmap toolbar lets you display and pick the bitmap filters. OpenOffice.org offers 10 filters.

Inverts the colors in an image. The result looks like a color negative. This filter is useful for resetting the colors in a scanned negative.
Managing 3D Objects and Bitmaps

Smoothes an image.

Sharpens an image.

Rids your image of noise pixels.
Applies a solarization effect to an image. A dialog box lets you choose the degree of solarization for the image.

Applies an aging effect to the image. You can set the degree of aging via a dialog box.

The Posterize filter lets you reduce the number of colors in an image. You can choose the number of colors in the dialog box. The result is an image that looks a bit like a drawing.
The pop art filter applies an effect that transforms the image into something resembling a pop art drawing:

Simulates a charcoal drawing effect

Applies a relief aspect to your image.
The mosaic filter transforms the image into a pixellated mosaic.
Combining Multiple Objects

This chapter describes the tools and functions that let you combine several objects together so that changes can be carried out to the group, or new objects can be created from the group.

Grouping and Combining Objects

Draw contains a number of mechanisms that let you combine several objects together so that changes can be carried out to the group, or new objects can be created from the group.

*Grouping* lets you temporarily combine objects to carry out global changes to them. A group can always be undone and the objects that make up the group can always be manipulated separately.

A *combination* is a permanent fusion of objects leading to a new object. The initial objects are no longer available as individual entities and the operation is therefore irreversible (unless you use the Edit/Undo function which is dependent on the number of undo steps set under Options).

Whatever you decide to do, several objects need to be selected for these functions to work. Just a quick reminder on how to select multiple objects: click on each object while holding down the Shift key or draw a rectangle around the objects that you wish to include in the selection.

Grouping Functions

**Group by common selection**

When several objects are selected, any operations you carry out are applied to all of the objects. For example, you can rotate a group of objects in its entirety. Groups obtained through common selection of several objects are undone as soon as you click outside the group. However, there is also a way to group objects and keep those selected objects grouped together.

**Maintaining groups and group dissociation**

To group selected objects, you can right-click and choose *Group* from the context menu. You can also use the keyboard shortcut *Control + Shift + G*. It is also possible to go via the main menu *Modify > Group*.

When objects are grouped, all of the editing operations carried out on that group are applied to all members of the group. If you click on one of the members of the group, the whole of the group will be selected. This method is thus safer than direct selection, which is best left to simple drawings.
As indicated at the beginning of the chapter, the objects of a group maintain their individuality and it is possible to undo a group via the context menu (Ungroup) or using the keyboard shortcut \textit{Alt + Control + Shift + G} or even the main menu \textbf{Modify > Ungroup}.

\textbf{Editing individual objects in a group}

The objects in a group keep all of their properties, and it is always possible to edit each object individually without breaking the group. To do this, you need to use the function \textbf{Enter group} that is available through the right-click menu or the \texttt{F3} key. You can also enter a group by double-clicking on it, and then click on the desired individual object.

Once you have entered this mode, you can click on and edit each object separately.

To leave this mode, use the function \textbf{Exit group} or keyboard shortcut \textit{Control + F3}. You can also double-click anywhere outside of the group.

When you work inside a group, the objects that are not within the group can no longer be selected and appear grayed out.

Here's an example of the use of this function.

\begin{figure}
\centering
\includegraphics[width=0.5\textwidth]{example1.png}
\caption{The 2D shapes above form part of a group. The 3D sphere is not part of the group. When the group is selected (as above) and you press the F3 key, you get the following:}
\end{figure}

The sphere moves out of focus to indicate that it isn't part of the group and that you can't select it. In this mode, you can select any one of the objects in the group and edit it individually.

\begin{figure}
\centering
\includegraphics[width=0.5\textwidth]{example2.png}
\caption{The sphere moves out of focus to indicate that it isn't part of the group and that you can't select it. In this mode, you can select any one of the objects in the group and edit it individually.}
\end{figure}
In the example given, we are going to rotate the straight rectangle. After you rotate the rectangle, you can press Control + F3 to leave the group, and the sphere will become available for selection once again.

Notice that you can create nested groups, or groups of groups. In this case, OpenOffice.org keeps the initial group hierarchy. If you ungroup a group made of other groups, you will be left with individual groups that you can then ungroup further.

**Combination Functions**

In contrast to grouping functions, combinations create a new object. To use this function: choose all of the objects that you want to combine, then right-click and choose the option Combine from the context menu. The keyboard shortcut is Control + Shift + K.
The result of the combination is given in the following illustration:

![Combined Objects Illustration]

At first glance, this can seem rather surprising. Fortunately, once you have understood the rules governing combination in OpenOffice.org, it will become clear:

- The attribute of the resulting object is the attribute of the object that is the furthest back from the viewer. In our example, it is the circle. The resulting drawing has the same color, line thickness, etc., as the circle.

- The result of the combination is a Bezier curve.

- Where the objects overlap, the overlapping zones will be represented as a filled or empty zone depending on the number of overlaps. When there is an even number of overlaps, you get an empty space (represented by a 'hole') in the drawing. When the overlaps are odd in number, you get a filled area. In our example, we can count the number of superpositions:

![Superposition Count]

**Shape Merge Functions**

The functions Merge, Subtract, and Intersect, can be reached though the group's context menu, under the heading Shapes.

**Merge**

The result of applying the Merge function to the shapes corresponds to the greatest surfaces of the selected objects being merged into one object (also known as a union).
**Subtract**

Subtraction will take away from the lowermost layered object the area corresponding to the overlap from the uppermost object, and the uppermost object will disappear:
**Intersect**
Intersecting two objects leads to an object that just represents the area of overlap between the two selected objects.
**Putting the Shape Merge Functions to use**

The following example illustrates how complex shapes can be created by using the Shape Merge functions.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Draw an ellipse and then a rectangle overlapping half of its width.</td>
</tr>
<tr>
<td>2.</td>
<td>Select both shapes and pick Shapes, <em>subtract</em> from the context menu.</td>
</tr>
<tr>
<td>3.</td>
<td>This is the shape that results.</td>
</tr>
<tr>
<td>4.</td>
<td>Draw another rectangle and position over the top half of the ellipse, <em>subtract</em> again.</td>
</tr>
<tr>
<td>5.</td>
<td>The shape is now beginning to resemble a knife blade.</td>
</tr>
<tr>
<td>6.</td>
<td>Draw a small ellipse covering just the lower corner to create a notch in the blade.</td>
</tr>
<tr>
<td>7.</td>
<td>After <em>subtracting</em> again the knife blade is complete.</td>
</tr>
<tr>
<td>8.</td>
<td>To make the handle draw a rectangle and an ellipse as shown.</td>
</tr>
<tr>
<td>9.</td>
<td>This time use the <em>merge</em> function to add the shapes together.</td>
</tr>
<tr>
<td>10.</td>
<td>A touch of 3D adds some depth to our basic knife.</td>
</tr>
</tbody>
</table>
Aids for Object Positioning

The Draw module has various tools that are designed to help in the positioning of objects, in order to change the alignment of objects and the relative “front to back” ordering of objects. These tools can be reached through two icons in the left hand toolbar.

- This button gives you access to the object alignment toolbar.
- This button gives you access to the object layering toolbar.

Aligning Objects

The alignment toolbar has six buttons as shown below:

This toolbar can be detached from the main lefthand toolbar and remain visible in the workspace. The buttons become active when objects are selected. The toolbar lets you align any selected objects in a certain way.

To show what can be done, let's start from the following two objects:
Combining Multiple Objects

All of the objects are aligned on their left side.

All of the objects are centered vertically.

All of the objects are aligned on their right side.

All of the objects are aligned on their upper side.
Combining Multiple Objects

All of the objects are horizontally centered.

All of the objects are aligned on the lower side.

Distribution of Objects

When several objects are selected, Draw provides ways to let you distribute these objects harmoniously, both vertically and horizontally. To display the object distribution dialog box (Figure 41), right-click and choose Distribution from the context menu of the selected objects (you need at least three objects for this option to show up in the menu).

![Object distribution dialog](image)

Figure 41 - Object distribution dialog

The various options let you choose the distribution of the objects independently along a horizontal and vertical axis. The option None additionally enables you to choose to have the objects distributed along one or none of the axes.
Combining Multiple Objects

The objects are distributed horizontally from their left side.

The objects are distributed horizontally from their middle (in reality it is the middle of the selection rectangle around each object).

The objects are distributed by introducing the same horizontal spacing between two objects.

The objects are distributed horizontally from their right side.

The objects are distributed vertically from their upper side.

The objects are distributed vertically from their middle.

The objects are distributed by introducing the same vertical space between them.

The objects are distributed vertically from their lower side.
Managing Object Arrangement

The toolbar for object arrangement is as shown below. The toolbar lets you manage the relative superposition of objects. This toolbar can be detached.

![Toolbar for object arrangement](image)

The examples given below should help you understand the principles behind the idea.

![Original group of objects](image)

*Figure 42. Original group of objects*

This is the original group of objects.

![Selected square](image)

The square was selected.

This button brings the selected object to the top of the pile of objects. As shown in the drawing opposite, the square is now on top of the pile.

![Bring to Front](image)

*Figure 43 - Bring to Front*
The square was selected.
This button brings the selected object forward one layer. The square has been moved in front of the triangle, but is still behind the circle.

The circle was selected.
This button moves an object back one layer. In the drawing opposite, the circle has been moved behind the triangle, but is still in front of the square.

The circle was selected.
This button will send the selected object to the bottom of the pile. This is what happened to the circle in the drawing opposite.

This button moves one object in front of another chosen object.
The object to be moved is selected first (in this case the triangle).
After you click on the button, the mouse cursor turns into a hand to designate the object in front of which the selected object will be placed (in this case the circle).
Combining Multiple Objects

The result of the arrangement is shown on the left.

For this button to work, you need to have at least two objects selected. The order of the selected objects is inverted in the pile of objects. In the example opposite, the square and the circle that were selected have had their positions inverted.
Additional Tools

This chapter describes the many ways that Draw can help you create drawings more easily.

Drawing Aid Tools

This section describes the drawing aid tools that Draw provides.

Choosing Scale and Managing Zoom Values

To help you work with greater precision in certain areas of your drawings, Draw has a variety of tools that let you adjust the magnification of the drawing.

Zoom using the status bar

The current zoom value is displayed in the status bar:

![Figure 50 - Zoom status in status bar](image)

If you double-click on the zoom value, a window is displayed in which you can change the zoom percentage value:

![Figure 51 - Zoom Definition dialog](image)

You can choose from one of the preset zoom values:

- **Optimal** sets the zoom to show the objects of your drawing at the maximum useful scale
- **Page Width** sets the right and left edges of the page to the size of the working area
- **Whole Page** lets you see the whole page

You can also enter the zoom value directly into the **Variable box**.
Zoom Toolbar

OpenOffice.org provides a toolbar that deals entirely with zoom functions (see Figure 52). It is a floating toolbar that can be reached by clicking the Zoom button in the main toolbar.

Figure 52 - Zoom Toolbar

This button zooms in by a factor of 2 each time it is clicked. You can also use the + key from the number keypad.

This button zooms out by a factor of 2 each time you click on it. You can also use the - key from the number keypad.

This button shows the image on the screen at true size, where 1 cm on the screen corresponds to 1 cm on the drawing. In order for this tool to work, your monitor's driver needs to be correctly installed.

This button takes you back to the preceding zoom value.

This button takes you to the next zoom level (providing the zoom function has been used at least once before). Both buttons work in the same way as the right and left arrow buttons in the toolbar of most internet browsers.

This button shows the whole page.

This button sets the zoom width of the page to that of the work area.

This button selects a zoom factor that displays the objects in the work zone in the most optimal way.

This button lets you zoom in on selected objects.

This button lets you move the visible work area currently under zoom to another part of the page, much like in PDF viewing software. The mouse cursor turns into a hand and you just drag the hand to the area of the page you want to see.
Managing Layers

Draw has a workspace that can optionally comprise a series of layers on which you can draw the different parts of your drawing. The biggest advantage to layers is that they can be displayed or hidden at will. This technique is often used in architecture, for example. The basic layer contains the base plan of the building, then various layers are used to represent piping, electrical circuits, furniture, dimensions, etc.

Layer management is handled by a particular mode available in Draw. To activate it, use View > Layer from the menu bar, or click on the appropriate icon at the bottom left hand corner of the workspace:

![Layer mode management](image)

When you switch to layer mode, tabs listing all of the available layers are shown at the bottom of the workspace. By default, the following three layers are always present: Layout, Controls, and Dimensions.

To activate a layer, click on its tab. The default behavior for the drawing tools is to place the drawing on the currently selected layer. In the example above, the drawings are placed on the default layer named Layout. (The default layer names for user-created layers are sequentially numbered starting from “Layer4”.)

If you right-click on a layer tab, a menu will appear that lets you insert or delete a layer, rename an existing layer or modify it. Choosing Modify displays the following dialog box:

![Modify Layer dialog](image)

The Modify Layer dialog lets you specify whether a layer will be visible, whether it will be printed when the drawing is printed (which is useful when you want to annotate the drawing and don't want the annotations to appear in the printed version), and whether it will be protected.

All of the drawings in any given protected layer are protected against change (movement, resizing, etc.).
Once you are in layer mode, you can insert, modify, delete, or rename layers by clicking **Edit > Layer** on the top menu bar, as show in Figure 55.

![Figure 55 Adding and managing layers](image)

### Placing Objects

**Draw** contains a few functions to help you with placement of objects on a worksheet, or with respect to each other. The techniques described here are known as capture, snapping, and placement techniques. All of the functions are accessible through the Option Toolbar.

![Figure 56 - Snap tools](image)
The snap tools are divided into 3 groups: the magnetic grid, snap lines, and snap points. Using these tools allows you to drag an object and have it “snap” tightly to a specific spot. The object will not just move when you click the snap to object button, for example. You have to click the button and then move the object.

**The Magnetic Grid**

One way of snapping objects into position is through the magnetic grid. This tool comprises a grid of points to which objects can be snapped. In order to use the grid, click on the button in the options toolbar to display the grid, and then click on the button to activate it. The work area will then be filled with a set of dots, as shown below.

![Displaying the Magnetic Grid](image)

When the grid is active, drawing shapes can be done easily by using the dots to guide you: In the following example, the object handles are positioned exactly on the dots in the grid.

![Drawing an object using the grid](image)

The spacing between the dots can be defined in the Grid Options dialog. Grid options are located under the Drawing area of the OOo options. *(Tools > Options)*

With this dialog box, you can set the following parameters:

- Vertical and horizontal spacing of the dots in the grid. The default values are given in the unit of measurement actually being used, but you can also change that.
- The resolution that corresponds to the number of subdivisions.
- The pixel size of the snap area. When the mouse cursor is closer to a dot or snap line than the number of pixels given here, the object will snap to it.
Capture Lines

Capture or snap lines are horizontal or vertical lines to which you can snap objects.

In order to see the snap lines, you have to select the button in the options toolbar, and the button lets you activate them.

Dynamic insertion of a capture line

You can add a snap line by sliding the mouse cursor from the vertical ruler (for vertical snap lines) or from the horizontal ruler (for horizontal snap lines) into the workspace.

In the example in Figure 60, a horizontal snap line was made by sliding the mouse cursor (while holding the left mouse button down) from the upper ruler onto the workspace. You can then align objects onto this line, as shown in Figure 61:
You can always relocate a snap line with the mouse. However, moving snap lines will not move any objects that have been snapped to that line.

**Manual Insertion of a snap point or snap line**

You can manually insert a snap point or a snap line using the **Insert > Insert snap point/line**. The following dialog box is displayed:

With this dialog, you can define the X and Y coordinates of the snap point, the X coordinate of a vertical snap line, or the Y coordinate of a horizontal snap line.

A snap point looks like this:

Snap points can also be moved to another position on the workspace with the mouse. You can also edit a snap point or snap line by right-clicking on it and choosing Edit from the context menu.

**Snapping to object border**

The button lets you activate snapping to an object border, where a selected object will be snapped to the border of another object that is nearest to the mouse pointer.

In the example above, the blue circle has been snapped to the border of the yellow ellipse (in fact, to the left vertex of the border).
**Snapping to page**
If you click on the button, you can snap your objects to the margins of your workspace. The snap can be made to the margin or to the limits of the workspace, as shown below:

![Figure 65 - Snapping to margins](image)

**Displaying guides**
The button lets you display the vertical and horizontal guides during movement of objects.

![Figure 66 - Guides when moving objects](image)
**Specific Functions**

Draw contains several advanced functions that are useful in certain specific instances (web images and data exchange).

**Duplication**

This function duplicates a given shape while at the same time enabling you to change the options applied to the duplicated shapes.

To start duplication, click on an object (or on a group of selected objects), then choose **Edit > Duplicate**.

The following dialog box appears:

![Figure 67 - Duplication Dialog](https://via.placeholder.com/150)

You can choose:

- The number of copies
- The displacement along the X and Y axes between two copies
- The angle of rotation between two copies
- The change in size between each copy
- The colors of the starting and ending copies.

The options above applied to a blue rectangle produce the following result:
The end result of a duplication is a new group.

**Cross-Fading**

This operation lets you transform a shape from one form to another, with OpenOffice.org handling all of the intermediate transitions. The result of such an operation is a new group. Here's an example of its use.

We'll start with the following two shapes and carry out the cross-fade in 4 steps to obtain the following drawing:
To carry out a cross-fade, you first need to select both objects and then choose **Edit > Cross-fading**. The following dialog will appear:

![Cross-fade options](image)

The number of increments corresponds to the number of intermediate steps that the program will generate.

The starting object is in the back and the ending object is in the front. If both objects are at the same relative level, **Cross-fade** works from top to bottom of the workspace. You can use the **Arrange** tool to set the relative levels of the objects. If you select the **Cross-fade attributes** checkbox, **Draw** will apply at each step a change in the object’s attributes in order to carry out a smooth transition from the attributes in the first shape to those in the second shape. In the above example, the color has changed from blue to yellow. If this checkbox isn't selected, each object created in the intermediate steps will have the same attributes as the first object.

If you don't select the checkbox marked **Same orientation**, the cross-fade won't be carried out in a 2-dimensional array and you'll get the following result:

You can clearly see from this example that **Draw** seems to pivot the intermediate steps in a 3D array to transform the first shape to the second.
Note: In order for the cross-fade to function, the objects need to have attributes that are similar. It is, for example, impossible to carry out a cross-fade between a shape filled with a simple color and another shape filled with a bitmap image.

**Exchanging Objects with Other Programs**

This section describes a few ways of exchanging data between the various modules in the OpenOffice.org suite and Draw and other programs.

**Reminder Concerning Image Formats**

As mentioned in several places in this document, Draw is essentially a vector graphics tool, and even if it has a few bitmap handling functions, it is advisable to save your vector work in a vector graphics format, rather than in bitmap format.

The major advantage of vector files is apparent when they are displayed zoomed or when you resize them. The following image shows a comparison of the degree of detail between a vector image on the left and a bitmap image on the right when enlarged 700 times.
Note that it is the same basic object in both cases.

To convert an object, just click on the context menu of the object, and two options will be displayed: Convert to meta file and Convert to bitmap\(^7\). The conversion of a vector object into a bitmap should only be done when no other alternative is available (for example, for use for the Web or in a program that only accepts this type of image)\(^8\).

**The Web export function**

Saving a Draw image in a foreign format is done via the option *Export* in the *File* menu. The default option proposes saving in HTML format using a conversion wizard.

This function will create as many web pages as there are pages in your Draw document. You can optionally choose to display the pages as frames with a navigator and can even set an index page\(^9\).

For example, you might start from the page shown in Figure 74 (note the various tabbed pages).

![Figure 74 - Document to save as HTML](image)

\(^7\) Depending on the complexity of the object, the conversion to metafile function may lead to a bitmap.

\(^8\) The tool for defining image maps for the web doesn't accept OpenOffice.org native file formats, only bitmaps and metafiles.

\(^9\) This wizard is exactly the same as that contained within OpenOffice.org Impress.
The result will look as follows:

![Web page generated by OpenOffice.org export](image)

The following is a description of the various pages in the wizard. You will note that you can choose to create the web page at any moment by clicking on the **Create** button, so you're not obliged to continue to the end of the wizard.

![HTML Export – Choosing your design](image)

The first page lets you choose the design for all of the pages, either from an existing design, either from an existing design or even create a new one.
On this page you can choose how you want to be able to navigate your web document: either via simple pages, frames (see Figure 75) or scripted page (via ASP or Perl, unfortunately no direct support for PHP as yet).

You can also decide here to insert an index page.

On the third page, you decide how the images will be saved (GIF or JPEG) and their associated parameters.

The fourth page lets you enter details about the author.
On this page, you choose the navigation button style that is used to move from page to another. If you decide not to choose any, OpenOffice.org will create a text navigator.

The last page lets you define the color scheme for the created pages. You can save your scheme so that you will find it again on the first page of your HTML export wizard.

On the export page, if you don't use the default option, OpenOffice.org will suggest several vector or bitmap formats.