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Overview

Overview

This document describes some of the methods that a user can use to insert Special Characters 
into OpenOffice.org documents. The methods here are tried and tested but there is no guarantee 
that any or all will work on every system. Three of the methods, using the Special Characters 
dialogue, the AutoCorrect Replace list and Macros, will probably work in OpenOffice.org on 
all platforms. The final method requires some operating system level configuration of the 
keyboard but is extremely flexible and uses key combinations that should work on most UNIX, 
Mac or Windows systems. Selecting the 'best' method depends on how often you need this 
function. The special Characters dialogue is practical for rarely used characters. Macros which 
are assigned to buttons, menu items and shortcut keys, are practical when the characters are 
needed more often, but they become impractical when you need several dozens. In that case, 
key combinations, like deadkeys, Multi_key and Mode_switch, can be a better solution. The 
advantage of key combinations is, that they are available in all X applications.
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Introduction

Introduction

OpenOffice.org offers several ways in which Special characters can be inserted.

• Use the Special Characters dialogue.

• Add the characters to the AutoCorrect/AutoFormat Replace list.

• Create Macros and assign these to buttons, menu items or shortcut keys.

• Use Key Combinations using deadkeys, Multi_keys and/or Mode_switch.

The first three methods are effective only in OpenOffice.org applications whereas the last 
method, Key combinations , is particularly effective on X11-based systems and has the 
advantage that it can also be used by most X applications and is also available on Windows 
systems.

Before deciding which method is best for your needs, see OpenOffice.org Help fpr a short 
tutorial on inserting Special Characters. To get to it 
Click on Help > Contents > Index >Search Term and enter the following:

special characters; inserting (tutorial)

In this Help document, there is a bullet section that states: “in any text input field (such as the 
URL field of the Function Bar or in the input fields in the Find&Replace dialogue) you can 
press Shift+Ctrl+S to call the Special Characters dialogue.” This key sequence is very useful 
to remember.

How to Handle Special Characters in OpenOffice.org 1



Inserting Special Characters from the Menu

Inserting Special Characters from the Menu

The availability of special characters depends on which font you use. For example, your 
document uses Times New Roman so go to Insert>Special Character to insert the 
Copyright symbol ( © ). In this case, the font  has this glyph. However, let us take another 
scenario with another font, say Caption, and try repeating the action. The next two screen shots 
might help to explain this.

As you can see, the Caption font is not as complete as for Times New Roman. In fact it has 
only 14 rows of characters and no Subset list box in the dialogue. Since there is no copyright 
special character available; trying to insert one will fail.
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Inserting Special Characters from the Menu

There are two ways that can be uses to insert special characters using the menu methods:

Insert > Special Character from the drop down menu.

or 

Click the Insert button on the Main tool bar to open the floating toolbar, then click 
the Insert Special Character button.

The following annotated screen shots illustrate second  process since employing the 
OpenOffice.org tools is some times not obvious.

which brings up the floating window as shown below:
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Inserting Special Characters from the Menu

The Special Characters dialogue opens with the current font selected in the same 
manner as invoking it from the Insert menu.

The Font list box shows a list of available fonts. The Subset list box shows the character 
subsets that are available in the selected font. The Character table shows all characters that are 
available in the selected font. Every selected character will be added to the Characters field at 
the bottom of the dialogue. On the right side, below the buttons, an enlarged view of the 
selected character is shown as well as the Unicode and the ANSI code (in parenthesis). The 
Delete button or Alt+D will remove all characters from the Characters field. Click Cancel 
or press the Esc key to close the dialogue without inserting a character. Click OK or press the 
Enter key to insert the characters from the Characters field.

Summary

Using the mouse: Using the mouse, click Insert on the toolbar to open the menu, then 
select Special Characters to open the dialogue. Use the mouse to select the list boxes 
and use the scroll bar to scroll up or down to locate the character you need. Use the Subset list 
box to jump to the desired subset, or use the scrollbar on the right side of the character table. 
Click a character in the Character table to select it. The Delete button will remove all 
characters from the Characters field. Click Cancel to close the dialogue without inserting a 
character. Click OK to insert the characters from the Characters field.

Using the keyboard: Use the Tab key to navigate between the list boxes, character table and 
buttons. Type one or more letters to select another font or subset. For example: type 'c' to move 
to the first font name that starts with a 'C', type 'ch' to move to the first font name that starts 
with 'Ch'. Use the Home, End, PageUp, PageDown, Up and Down keys to scroll 
up or down. Use the Arrow keys to navigate through the character table, or press a key to jump 
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Inserting Special Characters from the Menu

to the respective character. Press the Space bar to select a character. Alt+D  removes all 
characters from the Characters field. Press the Esc key to close the dialogue without 
inserting a character. Press the Enter key to insert the characters from the Characters 
field.
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Using the AutoCorrect Replace List

Using the AutoCorrect Replace List

To implement this method, do the following:

Select Tools > AutoCorrect/AutoFormat to open the dialogue.

Using Shift+Ctrl+S to bring up the Special Character dialogue box also works for 
inserting  characters into the text input fields of the AutoCorrect dialogue. However, the 
Font list box is disabled, which means that it is impossible to select another font.

Note: This AutoReplace function works only when the languages in the Replacements and exceptions for 
language list box and in Format > Character > Language are the same. 

Adding special characters to the AutoCorrect Replace list is fairly straight forward. 
Here is a tested way to do it:

a) Open the Special Character dialogue. 

b) Select the desired characters and insert them all in a document, for example: á é ĉ. 

c) Copy (Ctrl+C) the entire string to the clipboard. 
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Using the AutoCorrect Replace List

d) Open the AutoCorrect/AutoFormat dialogue. 

e) Select the desired language in the Replacements and exceptions for language list box.

f) Paste (Ctrl+V) the string in the With input field. 

g) Choose an easy to remember combination for the first character, and type it in the Replace 
input field. For example: character+\ for characters with grave accents, character+/ for 
characters with acute accents. 

h) Select all characters except the first one in the With input field and cut (Ctrl+X) these 
characters to the clipboard. 

i) Click the New button to add the replacement to the list. 

j) Paste (Ctrl+V) the new string in the With input field. 

k) Choose a combination for the first character, and type it in the Replace input field. Repeat 
steps (g) to (k) until all characters are entered.

Note: It is not possible to add single uppercase characters to the Replace list when the single lowercase 
character is already present. When the entry a/ is present in the list to be replaced by á, OpenOffice.org changes 
A/ to á  as well. To add accented uppercase characters to the list, either use a combination like AA/ or aa/ to be 
replaced by Á. Another possibility is to select the accented lowercase character in the document and select 

Format > Case/Characters > Uppercase.

For example:

Replace With
a/ á
AA/ Á
a: ä

Table 1

The following screen shot shows the contents of the AutoCorrect Replace list after adding these 
three new replacements :
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Using the AutoCorrect Replace List
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Using Macros to Insert Special Characters

Using Macros to Insert Special Characters

Using macros to manage Special Character needs is made easy with the Macro Recorder that 
comes with OpenOffice.org releases later than 1.1. This section describes how to use the 
recorder to enable Special Characters in OpenOffice.org. Because macros that are recorded by 
navigating with the keyboard often behave better than macros which record mouse clicks, the 
following procedure will employ only keyboard navigation. 

Note: Keys used in this section are based upon the 101 keyboard found with most Windows and Linux systems.

Recording the Macro 

i. Choose Tools > Macros > Record Macro, a small Record Macro dialogue 
appears.

ii. Press Alt+Tab or click in the document to put the focus back to the document window.

iii.Choose Insert > Special Character (Alt+I P) to open the Special Characters 
dialogue. 

iv. By default, the focus is in the first cell in the Character table; however, if the dialogue box 
was opened previously, then the focus could be anywhere in the table. To ensure that the 
macro behaves the same, regardless of the current focus, press the Home key which will 
change the focus to the first cell in the table. 

v. Use the Arrow keys to navigate to the desired character. 

vi. Press the Space bar to select the character.
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Using Macros to Insert Special Characters

vii.Press Enter to insert the character and close the dialogue.

viii.Click Stop Recording in the Record Macro dialogue and the Macro dialogue will 
open.

Saving the Macro 

1. Select the file in which to save the macro, the default is Module1 in the 
$HOME/install_dir/user/basic/Standard 
(%HOME%\install_dir\user\basic\Standard in windows) directory. Macros 
stored in this file are available to all OpenOffice.org applications.

2. Enter a name for the macro in the Macro name field. In this example, the name is 
“SPchar”
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Using Macros to Insert Special Characters

3. Click the Save button to save the macro as part of Standard.
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Using Macros to Insert Special Characters

Assigning the Macro 

1. Select Tools > Macros > Macro to open the Macro dialogue.

2. Select the file in the Macro from list, select the macro in the Existing macros list.

3. Click the Assign button, the Configuration dialogue opens.

4. At this point choose how the macro should be assigned. e.g. a shortcut key, a toolbar button 
or a menu item. The following sections provide step-by-step instructions for each 
procedure: KB for keyboard, TB for Toolbar and M for Menu.

5. Click the Close button to close the Macro dialogue.
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Using Macros to Insert Special Characters

Assign the Macro to a Keyboard Shortcut Key (KB)
KB-1.Select the Keyboard tab.

KB-2.For shortcut keys to be available in all applications, select the OpenOffice.org 
radio button.

KB-3.Select OpenOffice.org BASIC Macros in the Category list. 

KB-4.Click on the +-symbol to expand the list. 

KB-5.Select the file in which the macro is saved. 

KB-6.Click on the +-symbol to expand this list. 

KB-7.Select the Module where the macro is saved. 

KB-8.Select the macro in the Functions list. 

KB-9.Select the keys in the Shortcut keys list. 

KB-10.Click the Modify button.

KB-11.Click OK.
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Using Macros to Insert Special Characters

Assign the Macro to a Toolbar Button (TB)

TB-1.Select the Toolbars tab.

TB-2.Click the Customize button. 

TB-3.Select the toolbar where the button has to be added from the Toolbars list box. 

TB-4.Select OpenOffice.org BASIC Macros in the Available buttons list. 

TB-5.Click on the +-symbol. 

TB-6.Select the file in which the macro is saved. 

TB-7.Click on the +-symbol. 

TB-8.Select the Module where the macro is saved. 

TB-9.Click on the +-symbol. 

TB-10.Select the macro. 

TB-11.Click the Add─> button to add the macro to the Buttons in use list, the new button will 
be added after the selected item. 

TB-12.Click the Move Up or Move Down button to move the button to another position. 

TB-13.Click the Icons button to add an icon to the toolbar button.

TB-14.Click Apply.

TB-15.Click OK.
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Using Macros to Insert Special Characters

Voila a new icon on the main toolbar
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Using Macros to Insert Special Characters

Assign the Macro to a Menu Item (M)
M-1.Select the Menu tab.

M-2.Select the menu item after which to insert the new menu in the Menu entries list. 

M-3.Select OpenOffice.org BASIC Macros in the Category list. 

M-4.Click on the +-symbol. 

M-5.Select the file where the macro is saved. 

M-6.Click on the +-symbol. 

M-7.Select the Module where the macro is saved. 

M-8.Select the macro in the Functions list.

M-9.Click the New button.

M-10.Click OK.

How to Handle Special Characters in OpenOffice.org 16

Illustration 7



Using Macros to Insert Special Characters

A new item is in the Insert menu:
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Using Key combinations to insert Special Characters Under UNIX

Using Key combinations to insert Special Characters 
Under UNIX

Using key combinations to produce special characters is independent of language and locale 
settings. However, you must make some changes at system level to enable this feature. This 
section explains how to accomplish this in relatively easy steps. 

First, assuming windows or Linux, you should set your keyboard to us_intl. Other systems 
should be similar but may require a bit of research to discover equivalents. This method is 
enabled for production of this document. For example, while the language for this document is 
set to English (USA), one can still enter foreign characters, such as, the French ĉ, the German 
ß, the Spanish ñ, or the Scandinavian ø. 

Setting up

Using Deadkeys
Deadkeys are keys that seemingly do nothing when pressed once. When the key is pressed a 
second time, the expected character appears, or when another key is pressed, an accented 
character appears. Not all characters produce an accented character when pressed after a 
deadkey. Some of the most well-known accents in western European languages are: grave and 
acute accents, circumflex, tilde, and diaeresis (or Umlaut in German, trema in Dutch). Whether 
an accented character appears after pressing a deadkey plus another key, depends upon the font 
that is used. To be able to use deadkeys, the system must be configured to support these via the 
keyboard. On most systems, the utility to configure the keyboard is called kbdconfig. 

This is an excerpt from a typical /etc/X11/XF86Config: 

Section "InputDevice"
  
# Specify which keyboard LEDs can be user-controlled (eg, 
with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, 
modify the
# lines below (which are the defaults).  For example, for a 
non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
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Using Key combinations to insert Special Characters Under UNIX

#
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbRules" "xfree86"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us_intl"
EndSection
#XkbVariant "" #XkbOptions ""

When XkbdVariant is set to "nodeadkeys", deadkeys are disabled. Please, read your 
distribution's set up manual, or the man pages, for more information.

To type an accented character: Press the deadkey once, then press the character key. To type 
one of the deadkey characters: Press the deadkey once and press the Space bar, or press the 
deadkey twice. See the chapter Customize Keymappings for a description of how to assign 
and customize deadkeys. On page 24, there are two tables showing frequently used accented, 
lowercase and uppercase, characters.

Multi_key 
Multi_key combinations produce characters that are combinations of two characters, like the  
(th) and  (ss). To type a multi-character: Press and hold the Multi_key down, press the two 
character keys. See the chapter Customize Keymappings for a description of how to assign the 
Multi_key. A list of sequence Definitions for the Multi_key can be found in the file Compose 
in the directory 
/usr/X11R6/lib/X11/locale/[charset], where [charset] is the used 
character set, for example iso8859-1 or en_US.UTF-8.

Mode_switch 
Mode_switch key combinations produce special characters and symbols, like © and € . To type 
a special character: Press and hold the Mode_switch key down, press the character key. 

The section, Customize Keymappings, describes how to assign and customize the 
Mode_switch and the resulting characters.
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Customize Keymappings

Keymappings can be customized by creating a usermodmap file or by editing the existing 
usermodmap file. To get a list of the current keymappings open an XTerm and type the 
following command: $ xmodmap -pke > keymappings See the xmodmap man page 
for descriptions of the options and some examples.

The file keymappings is a plain ASCII text file. Use a text editor to edit these keycodes, or, 
when you prefer to use Writer, be sure to save the file as a plain text (*.txt) file. The first 
few lines look like this:

keycode   8 =
keycode   9 = Escape
keycode  10 = 1 exclam
keycode  11 = 2 at
keycode  12 = 3 numbersign
keycode  13 = 4 dollar
keycode  14 = 5 percent
keycode  15 = 6 dead_circumflex asciicircum asciicircum
keycode  16 = 7 ampersand
keycode  17 = 8 asterisk
keycode  18 = 9 parenleft dead_breve dead_breve

 
Every keycode has a maximum of four key mappings: normal, shifted, modified and modified 
shifted. To use the Multi_key and the Mode_switch, they must be assigned to a keycode. 
The Left and Right Windows-Logo keys are good candidates. Their keycodes are: 

keycode 115 = Super_L
keycode 116 = Super_R 

Change these for example to: 

keycode 115 = Multi_key 
keycode 116 = Mode_switch

For example, here are two lines from a generated keymappings file:

keycode 26 = e E 
keycode 27 = r R paragraph registered 

Since keycode 26 has no additional characters assigned, this key could be used for the Euro 
currency symbol. To find the name of a character, open the file 
/usr/include/X11/keysymdef.h in an editor or file viewer. This is a definition file 
with the names of all available characters. The section #ifdef XK_LATIN1 includes the 
line #def XK_currency and the section #ifdef XK_CURRENCY includes the line 
#def XK_EuroSign. To assign the Euro sign to the E key (e), and the currency 
symbol to the shifted E key (E), append the words EuroSign and currency to the 
keycode:

keycode 26 = e E EuroSign currency 

To test this new key assignment, save the keymappings file, and in an Xterm, type the 
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following command: $ xmodmap keymappings. Now, in a Writer document, or any X 
application, press and hold down the Mode_switch key and press the E key, the € should 
appear; press and hold down the Mode_switch key and press Shift+E, the ¤ should 
appear.

It is also possible to switch the deadkeys back to normal keys. Say you need the apostrophe 
and double quotes more frequently than the deadkeys, change: 

keycode 48 = dead_acute dead_diaeresis apostrophe quotedbl
to 

keycode 48 = apostrophe quotedbl dead_acute dead_diaeresis 
Now you can type normal apostrophes and double quotes, and when a deadkey character is 
needed, for example an é, press and hold down the Mode_switch key, press the apostrophe 
key (') and then the E key.

To make these changes permanent, rename the file keymappings to .Xmodmap. When the 
X server is started, one of the files that is run, is /etc/X11/xinit/xinitrc. This shell 
script checks the existence of a usermodmap. When found this file is used. These lines are 
from the xinitrc shell script: 

...
userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
userxkbmap=$HOME/.Xkbmap
...

By using a personal .Xmodmap file, each user can personalize their keymappings for their on-
going needs.
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Using Key combinations to insert Special Characters 
Under Windows

Change or add Keyboards

In order to be able to enter special characters directly from the keyboard, the type of keyboard 
must be changed to a configuration that supports this feature. Microsoft Windows allows a 
number of different keyboard languages and layouts. Installation of the "typical", or "default" 
options provides capabilities for French, Spanish, and other Western European languages.

To change the keyboard languages and layout, click the Start button, then choose Settings,  
Control Panel, and Keyboard (or Regional and Language Options). Click the "Language" or 
"Input Locales" tab. Add a language and give it properties - one of which is the US-
International English keyboard (see below). Use Apply to finish the process; the Windows 
installation CD is usually needed. The keyboard and multi language sections in Start - Help 
provide details. 

The US-International English keyboard layout is installed as above (choose English as the 
language and US-International as the layout in properties) and has these features: 

• It uses the following intuitive methods which work with most (or all) Windows 
applications, while keeping the familiar QWERTY keyboard. (e.g. French uses 
AZERTY with letters a/q and z/w interchanged) 

• Press one of the five modifier keys `  '  "  ~  ^ , then the letter to be modified. 
( ' then a = á, " then u = ü, ' then c = ç, etc. )

• Press the right alt key + another key. Examples: 
right alt  + , = ç (or ' + c)  
               + ? = ¿  
               + ! = ¡  
               + c = ©  

   + 5 = Euro currency symbol 

• The US-International English keyboard layout is installed as shown below (choose 
English as the language and US-International as the layout in properties). It uses the 
following intuitive method which works with most Windows applications, while keeping 
the familiar qwerty keyboard.
To use, press one of the five (in purple below) punctuation keys ` ' " ~ ^ , then the 
letter to be modified.(' then a = á, " then u = ü, ' then c = ç, etc). Or use the right 
alt key  + another key:
right alt  + ? = ¿,+ ! = ¡, + c = ©, + e = é plus all those shown in the image below. Also +5 
is Euro.
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Note that this maintains the "qwerty" layout. However, each modifier key `  '  "  ~  ^  must be 
followed by pressing the space bar if it is actually intended. The system is smart enough to accept 
words requiring an apostrophe, such as it's, without the space bar.

• To install both the US-International English keyboard layout and United States 
English:

• One can fool a Win 9X system by adding an unused language, such as 
Icelandic. Then change its layout to the US-International in the language 
properties or layout section.

• Windows XP allows both. Click Start, Settings, Control Panel,  
Regional.options, Languages, Details, Settings, Add. Set Input Language to 
English - United States. Set Keyboard layout/IME to United States-
International. Press Apply and OK.

• If you are having punctuation key troubles such as your computer's quote and 
apostrophe key behaving strangely, the cause may be that your keyboard was 
accidentally set to the International English Keyboard. The solution is to reset it to a 
standard English or United States keyboard.

Character Map 

• This is useful for the infrequent accent or symbol. It is located at Start - Programs - 
Accessories - System Tools - Character Map (OR click Start, Run, and type 
charmap). After choosing a font, double click the desired character(s). After clicking 
Copy, return to your document and paste. Some fonts (such as Symbol, Webding, and 
Wingding) provide Greek, icons, arrows and symbols. This system may fail if a 
particular combination of keystrokes, as seen in the lower right of the window, has been 
reserved for another application.

Alt key sequences

Windows users can also insert special characters using the Alt key plus a number. For example, 
Atl+0150  inserts an  'en' dash which appears as – using the Times Roman Font.. TO use this 
feature users must have and enhanced keyboard. 

Please see http://www.starr.net/is/type/altnum.htm for one list of key sequences.
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Changing Keyboard Layout under Linux.

Changing Keyboard Layout under Linux.

For those who may need to work in languages where the keyboard layout for that language is 
not compatible with the keymapping method outlined previously, there are system level tool 
that will permit setting the layout to the needed local. On Linux, use 

setxkbmap gr where gr is the locale for the language needed.

To reset the keyboard to North American US English enter:

setxkbmap us

setxkbmap has many command line switches available  for more complicated scenarios. In 
this case, please check the distribution manpage for setxkbmap() for details of how to use this 
tool.

Other tools may exist that can make switching easier but at the time of writing this  document 
none were as universally available as this one.

On most windows  releases, you can enable  keyboard switching from the control panel which, 
in turn, provides a icon in the panel for switching.
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Deadkeys: accented lowercase characters

grave acute diaeresis tilde circumflex

`a à 'a á "a ä ~a ã ^a â

`e è 'e é "e ë ^e ê

`i ì 'i í "i ï ^i î

`o ò 'o ó "o ö ~o õ ^o ô

`u ù 'u ú "u ü ^u û

'y ý "y ÿ

'c ć

~n ñ

Deadkeys: accented uppercase characters

grave acute diaeresis tilde circumflex

`A À 'A Á "A Ä ~A Ã ^A Â

`E È 'E É "E Ë ^E Ê

`I Ì 'I Í "I Ï ^I Î

`O Ò 'O Ó "O Ö ~O Õ ^O Ô

`U Ù 'U Ú "U Ü ^U Û

'Y Ý "Y Ÿ

'C Ć

~N Ñ
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Appendix 1 – Keymapping Patch file

The following is a patch file, created using

diff -c keymappings.orig keymappings,

that you may use as a model to modify your local needs:

*** keymappings.orig 2004-05-03 13:17:15.000000000 -0400
--- keymappings 2004-05-03 13:28:42.000000000 -0400
***************
*** 16,22 ****
  keycode  23 = Tab ISO_Left_Tab
  keycode  24 = q Q
  keycode  25 = w W
! keycode  26 = e E
  keycode  27 = r R
  keycode  28 = t T
  keycode  29 = y Y
--- 16,22 ----
  keycode  23 = Tab ISO_Left_Tab
  keycode  24 = q Q
  keycode  25 = w W
! keycode  26 = e E EuroSign currency
  keycode  27 = r R
  keycode  28 = t T
  keycode  29 = y Y
***************
*** 105,112 ****
  keycode 112 = KP_Divide XF86_Ungrab
  keycode 113 = Alt_R Meta_R
  keycode 114 =
! keycode 115 = Super_L
! keycode 116 = Super_R
  keycode 117 = Menu
  keycode 118 =
  keycode 119 =
--- 105,112 ----
  keycode 112 = KP_Divide XF86_Ungrab
  keycode 113 = Alt_R Meta_R
  keycode 114 =
! keycode 115 = Multi_key
! keycode 116 = Mode_switch
  keycode 117 = Menu
  keycode 118 =
  keycode 119 =
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1.0 DEFINITIONS. 

1.1. "Commercial Use" means distribution or otherwise 
making the Documentation available to a third party. 

1.2. "Contributor" means a person or entity who creates or 
contributes to the creation of Modifications. 

1.3. "Documentation" means the Original Documentation or 
Modifications or the combination of the Original 
Documentation and Modifications, in each case including 
portions thereof.

1.4. "Electronic Distribution Mechanism" means a mechanism 
generally accepted for the electronic transfer of data. 

1.5. "Initial Writer" means the individual or entity identified 
as the Initial Writer in the notice required by the Appendix. 

1.6. "Larger Work" means a work which combines 
Documentation or portions thereof with documentation or 
other writings not governed by the terms of this License. 

1.7. "License" means this document. 

1.8. "Modifications" means any addition to or deletion from 
the substance or structure of either the Original 
Documentation or any previous Modifications, such as a 
translation, abridgment, condensation, or any other form in 
which the Original Documentation or previous Modifications 
may be recast, transformed or adapted.  A work consisting of 
editorial revisions, annotations, elaborations, and other 
modifications which, as a whole represent an original work of 
authorship, is a Modification.  For example, when 
Documentation is released as a series of documents, a 
Modification is: 

A. Any addition to or deletion from the contents of the 
Original Documentation or previous Modifications. 

B. Any new documentation that contains any part of the 
Original Documentation or previous Modifications. 

1.9. "Original Documentation" means documentation 
described as Original Documentation in the notice required by 
the Appendix, and which, at the time of its release under this 
License is not already Documentation governed by this 
License. 

1.10. "Editable Form" means the preferred form of the 
Documentation for making Modifications to it. The 
Documentation can be in an electronic, compressed or 
archival form, provided the appropriate decompression or de-
archiving software is widely available for no charge. 

1.11. "You" (or "Your") means an individual or a legal entity 
exercising rights under, and complying with all of the terms of 
this License or a future version of this License issued under 
Section 5.0 ("Versions of the License"). For legal entities, 
"You" includes any entity which controls, is controlled by, or 
is under common control with You. For purposes of this 
definition, "control" means (a) the power, direct or indirect, to 
cause the direction or management of such entity, whether by 

contract or otherwise, or (b) ownership of more than fifty 
percent (50%) of the outstanding shares or beneficial 
ownership of such entity.

2.0 LICENSE GRANTS. 

2.1  Initial Writer Grant. 

The Initial Writer hereby grants You a world-wide, royalty-
free, non-exclusive license to use, reproduce, prepare 
Modifications of, compile, publicly perform, publicly display, 
demonstrate, market, disclose and distribute the 
Documentation in any form, on any media or via any 
Electronic Distribution Mechanism or other method now 
known or later discovered, and to sublicense the foregoing 
rights to third parties through multiple tiers of sublicensees in 
accordance with the terms of this License.  

The license rights granted in this Section 2.1 ("Initial Writer 
Grant") are effective on the date Initial Writer first distributes 
Original Documentation under the terms of this License. 

2.2. Contributor Grant. 

Each Contributor hereby grants You a world-wide, royalty-
free, non-exclusive license to use, reproduce, prepare 
Modifications of, compile, publicly perform, publicly display, 
demonstrate, market, disclose and distribute the 
Documentation in any form, on any media or via any 
Electronic Distribution Mechanism or other method now 
known or later discovered, and to sublicense the foregoing 
rights to third parties through multiple tiers of sublicensees in 
accordance with the terms of this License.  

The license rights granted in this Section 2.2 ("Contributor 
Grant") are effective on the date Contributor first makes 
Commercial Use of the Documentation. 

3.0 DISTRIBUTION OBLIGATIONS. 

3.1. Application of License.

The Modifications which You create or to which You 
contribute are governed by the terms of this License, including 
without limitation Section 2.2 ("Contributor Grant").  The 
Documentation may be distributed only under the terms of 
this License or a future version of this License released in 
accordance with Section 5.0 ("Versions of the License"), and 
You must include a copy of this License with every copy of 
the Documentation You distribute. You may not offer or 
impose any terms that alter or restrict the applicable version of 
this License or the recipients' rights hereunder. However, You 
may include an additional document offering the additional 
rights described in Section 3.5 ("Required Notices"). 

 3.2. Availability of Documentation.

Any Modification which You create or to which You 
contribute must be made available publicly in Editable Form 
under the terms of this License via a fixed medium or an 
accepted Electronic Distribution Mechanism. 

3.3. Description of Modifications.
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All Documentation to which You contribute must identify the 
changes You made to create that Documentation and the date 
of any change. You must include a prominent statement that 
the Modification is derived, directly or indirectly, from 
Original Documentation provided by the Initial Writer and 
include the name of the Initial Writer in the Documentation or 
via an electronic link that describes the origin or ownership of 
the Documentation.  The foregoing change documentation 
may be created by using an electronic program that 
automatically tracks changes to the Documentation, and such 
changes must be available publicly for at least five years 
following release of the changed Documentation. 

3.4. Intellectual Property Matters.

Contributor represents that Contributor believes that 
Contributor's Modifications are Contributor's original 
creation(s) and/or Contributor has sufficient rights to grant the 
rights conveyed by this License.

3.5. Required Notices.

You must duplicate the notice in the Appendix in each file of 
the Documentation. If it is not possible to put such notice in a 
particular Documentation file due to its structure, then You 
must include such notice in a location (such as a relevant 
directory) where a reader would be likely to look for such a 
notice, for example, via a hyperlink in each file of the 
Documentation that takes the reader to a page that describes 
the origin and ownership of the Documentation.  If You 
created one or more Modification(s) You may add your name 
as a Contributor to the notice described in the Appendix. 

You must also duplicate this License in any Documentation 
file (or with a hyperlink in each file of the Documentation) 
where You describe recipients' rights or ownership rights. 

You may choose to offer, and to charge a fee for, warranty, 
support, indemnity or liability obligations to one or more 
recipients of Documentation. However, You may do so only 
on Your own behalf, and not on behalf of the Initial Writer or 
any Contributor. You must make it absolutely clear than any 
such warranty, support, indemnity or liability obligation is 
offered by You alone, and You hereby agree to indemnify the 
Initial Writer and every Contributor for any liability incurred 
by the Initial Writer or such Contributor as a result of 
warranty, support, indemnity or liability terms You offer. 

 3.6.  Larger Works.

You may create a Larger Work by combining Documentation 
with other documents not governed by the terms of this 
License and distribute the Larger Work as a single product. In 
such a case, You must make sure the requirements of this 
License are fulfilled for the Documentation.

4.0  APPLICATION OF THIS LICENSE. 

This License applies to Documentation to which the Initial 
Writer has attached this License and the notice in the 
Appendix.

5.0  VERSIONS OF THE LICENSE. 

5.1. New Versions.

Initial Writer may publish revised and/or new versions of the 

License from time to time. Each version will be given a 
distinguishing version number. 

5.2. Effect of New Versions.

Once Documentation has been published under a particular 
version of the License, You may always continue to use it 
under the terms of that version. You may also choose to use 
such Documentation under the terms of any subsequent 
version of the License published 
by______________________ [Insert name of the foundation, 
company, Initial Writer, or whoever may modify this License]. 
No one other than ________________________[Insert name 
of the foundation, company, Initial Writer, or whoever may 
modify this License] has the right to modify the terms of this 
License. Filling in the name of the Initial Writer, Original 
Documentation or Contributor in the notice described in the 
Appendix shall not be deemed to be Modifications of this 
License.

6.0 DISCLAIMER OF WARRANTY. 

DOCUMENTATION IS PROVIDED UNDER THIS 
LICENSE ON AN "AS IS'' BASIS, WITHOUT WARRANTY 
OF ANY KIND, EITHER EXPRESSED OR IMPLIED, 
INCLUDING, WITHOUT LIMITATION, WARRANTIES 
THAT THE DOCUMENTATION IS FREE OF DEFECTS, 
MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE 
OR NON-INFRINGING. THE ENTIRE RISK AS TO THE 
QUALITY, ACCURACY, AND PERFORMANCE OF THE 
DOCUMENTATION IS WITH YOU. SHOULD ANY 
DOCUMENTATION PROVE DEFECTIVE IN ANY 
RESPECT, YOU (NOT THE INITIAL WRITER OR ANY 
OTHER CONTRIBUTOR) ASSUME THE COST OF ANY 
NECESSARY SERVICING, REPAIR OR CORRECTION. 
THIS DISCLAIMER OF WARRANTY CONSTITUTES AN 
ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY 
DOCUMENTATION IS AUTHORIZED HEREUNDER 
EXCEPT UNDER THIS DISCLAIMER.

7.0 TERMINATION. 

This License and the rights granted hereunder will terminate 
automatically if You fail to comply with terms herein and fail 
to cure such breach within 30 days of becoming aware of the 
breach. All sublicenses to the Documentation which are 
properly granted shall survive any termination of this License. 
Provisions which, by their nature, must remain in effect 
beyond the termination of this License shall survive. 

8.0 LIMITATION OF LIABILITY. 

UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL 
THEORY, WHETHER IN TORT (INCLUDING 
NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL 
THE INITIAL WRITER, ANY OTHER CONTRIBUTOR, 
OR ANY DISTRIBUTOR OF DOCUMENTATION, OR 
ANY SUPPLIER OF ANY OF SUCH PARTIES, BE 
LIABLE TO ANY PERSON FOR ANY DIRECT, 
INDIRECT, SPECIAL, INCIDENTAL, OR 
CONSEQUENTIAL DAMAGES OF ANY CHARACTER 
INCLUDING, WITHOUT LIMITATION, DAMAGES FOR 
LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER 
FAILURE OR MALFUNCTION, OR ANY AND ALL 
OTHER DAMAGES OR LOSSES ARISING OUT OF OR 
RELATING TO THE USE OF THE DOCUMENTATION, 
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EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED 
OF THE POSSIBILITY OF SUCH DAMAGES. 

9.0 U.S. GOVERNMENT END USERS. 

If Documentation is being acquired by or on behalf of the U.S. 
Government or by a U.S. Government prime contractor or 
subcontractor (at any tier), then the Government's rights in 
Documentation will be only as set forth in this Agreement; 
this is in accordance with 48 CFR 227.7201 through 
227.7202-4 (for Department of Defense (DOD) acquisitions) 
and with 48 CFR 2.101 and 12.212 (for non-DOD 
acquisitions).

10.0 MISCELLANEOUS. 

This License represents the complete agreement concerning 
the subject matter hereof. If any provision of this License is 
held to be unenforceable, such provision shall be reformed 
only to the extent necessary to make it enforceable. This 
License shall be governed by California law, excluding its 
conflict-of-law provisions. With respect to disputes or any 
litigation relating to this License, the losing party is 
responsible for costs, including without limitation, court costs 
and reasonable attorneys' fees and expenses. The application 
of the United Nations Convention on Contracts for the 
International Sale of Goods is expressly excluded. Any law or 
regulation which provides that the language of a contract shall 
be construed against the drafter shall not apply to this License.

Appendix 

Public Documentation License Notice 

The contents of this Documentation are subject to the Public 
Documentation License Version 1.0 (the "License"); you may 
only use this Documentation if you comply with the terms of 
this License. A copy of the License is available at 
http://www.openoffice.org/licenses/PDL.rtf. 

The Original Documentation is _________________. The 
Initial Writer of the Original Documentation is 
______________________ (C) ____. All Rights Reserved. 
(Initial Writer contact(s):_______________[Insert 
hyperlink/alias].)

Contributor(s): 
______________________________________. 

Portions created by ______ are Copyright 
(C)_________[Insert year(s)]. All Rights Reserved.   
(Contributor contact(s):________________[Insert 
hyperlink/alias]).

Note: The text of this Appendix may differ slightly from the 
text of the notices in the files of the Original Documentation. 
You should use the text of this Appendix rather than the text 
found in the Original Documentation for Your Modifications.
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