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Using spreadsheets in Impress
A spreadsheet embedded in Impress includes most of the functionality 
of a spreadsheet in Calc and is therefore capable of performing 
complex calculations and data analysis. However, if you need to 
analyze your data or apply formulas, these operations are best 
performed in a Calc spreadsheet and the results displayed in an 
embedded Impress spreadsheet.

Many people also use spreadsheets in Impress for creating complex 
tables or presenting data in a tabular format. However, for this 
purpose you may find the new Table Design feature (described in 
Chapter 3) more suitable.

Inserting a spreadsheet
To add a spreadsheet to a slide, select the corresponding layout in the 
list of predefined layouts in the Tasks pane, as shown in Figure 1.

Figure 1: The spreadsheet layout in the Tasks pane

This inserts a placeholder for a spreadsheet in the center of a slide, as 
shown in Figure 2. Double-click inside the frame to enter the edit 
mode, shown in Figure 3, where you can insert data and modify the 
formatting of the spreadsheet. See “Entering data” on page 8 and 
“Formatting spreadsheet cells” on page 8.

It is also possible to insert a spreadsheet as an OLE object as described 
in “Inserting other objects” on page 21.
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Figure 2: A slide ready to host a spreadsheet

Figure 3: A spreadsheet in edit mode. Note the active cell  
and the smalle black resizing handles on the gray border

When editing a spreadsheet, some of the contents of the main menu 
bar change, as does the Formatting toolbar (see Figure 4), to show 
entries and tools that support working with the spreadsheet.
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Figure 4: The menu bar and the formatting toolbar in 
spreadsheet editing mode

One of the most important changes is the presence of the Formula 
toolbar, just below the Formatting toolbar. The Formula toolbar 
contains (from left to right):

• The active cell reference or the name of the selected range
• The Formula Wizard button
• The Sum and Formula buttons or the Cancel and Accept buttons 

(depending on the contents of the cell)
• A long edit box to enter or review the contents of a cell

If you are familiar with Calc, you will immediately recognize the tools 
and the menu items since they are much the same.

Resizing and moving a spreadsheet
When resizing or moving a spreadsheet, ignore the first row and the 
first column (easily recognizable because of their light gray 
background) and the horizontal and vertical scroll bars). They are only 
used for editing purposes and will not be included in the visible area of 
the spreadsheet on the slide.

To resize the area occupied by the spreadsheet:

1) Double-click to enter the edit mode, if it is not already active. 
Notice the black handles found in the gray border surrounding 
the spreadsheet (see Figure 3).

2) Move the mouse over one of the handles. The cursor changes 
shape to give a visual representation of the effects applied to the 
area.

3) Click and hold the left mouse button and drag the handle. The 
corner handles resize the two sides forming the corner 
simultaneously, while the handles in the middle of the sides 
modify one dimension at a time.
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You can move the spreadsheet (change its position within the slide) 
whether in edit mode or not. In both cases:

1) Move the mouse over the border until the cursor changes shape.
2) Click and hold the left mouse button and drag the spreadsheet to 

the desired position.
3) Release the mouse button.

When selected but not in edit mode (green handles), the spreadsheet 
object is treated like any other object, therefore resizing it results in 
changing the scale rather than the spreadsheet area. This is not 
recommended, because it may distort the fonts and picture shapes.

Moving around the spreadsheet

How a spreadsheet is organized
A spreadsheet consists normally of multiple tables which in turn 
contain cells. However, in Impress only one of these tables can be 
shown at any given time on a slide.

The default for a spreadsheet embedded in Impress is one single table 
called Sheet 1. The name of the table is shown at the bottom of the 
spreadsheet area (see Figure 3).

If required, you can add other sheets. To do that:
1) Right-click on the bottom area near the existing tab.
2) Select Insert > Sheet from the pop-up menu.

Just like in Calc, you can rename a sheet or move it to a different 
position using the same pop-up menu or the Insert menu on the main 
menu bar.

Note
Even if you have many sheets in your embedded spreadsheet, 
only one sheet—the one which is active when leaving the 
spreadsheet edit mode—is shown on the slide.

Each of the sheets is further organized into cells. Cells are the 
elementary unit of the spreadsheet. They are identified by a row 
number (shown on the left hand side on gray background) and a 
column letter (shown in the upper part again on gray background). For 
example, the top left cell is identified as A1, while the third cell in the 
second row is C2. All data, whether text or numbers, is input in a cell.
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Moving the cursor to a cell
To move around the spreadsheet and select the cell which has the 
focus, you can:

• Use the arrow keys.
• Left-click with the mouse on the desired cell.
• Use the combinations Enter and Shift+Enter to move one cell 

down or one cell up respectively; Tab key and Shift+Tab key to 
move one cell to the right or to the left respectively. 

Other keyboard shortcuts are available to move quickly to certain cells 
of the spreadsheet. Refer to Chapter 5 (Getting Started with Calc) in 
the Getting Started guide for further information.

Entering data
Keyboard input is received by the active cell, identified by a thick black 
border (see Figure 3 where cell B3 is active). The cell reference (or 
coordinates) is also shown on the left hand end of the formula bar.

To insert data, first select the cell to make it active, then type in it. 
Note that the input is also added to the main part of the formula bar 
where it may be easier to read.

Impress will try to automatically recognize the type of contents (text, 
number, date, time, and so on) of a cell and apply default formatting to 
it. Note how the formula bar icons change according to the type of 
input, displaying Accept and Reject buttons ( ) whenever the input 
is not a formula. Use the green Accept button to accept the input made 
in a cell or simply select a different cell. In case Impress wrongly 
recognized the type of input, you can change it using the toolbar 
shown in Figure 4, or from Format > Cells in the main menu bar.

Tip

Sometimes it is useful to treat numbers as text (for example, 
telephone numbers) and to prevent Impress from removing the 
leading zeros or right align them in a cell. To force Impress to 
treat the input as text, type a single apostrophe  '  (U + 00B4) 
before entering the number.

Formatting spreadsheet cells
Normally, for the purpose of a presentation, it may be necessary to 
increase considerably the size of the font as well as matching it to the 
style used in the presentation.
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The fastest and most flexible way to format the embedded spreadsheet 
is to make use of styles. When working on an embedded spreadsheet, 
you can access the cell styles created in Calc and use them. However, 
the best approach is to create specific cell styles for presentation 
spreadsheets, as the Calc cell styles are likely to be unsuitable when 
working within Impress.

To apply a style (or indeed manual formatting of the cell attributes) to 
a cell or group of cells simultaneously, first select the range to which 
the changes will apply. A range consists of one or more cells, normally 
forming a rectagular area. A selected range consisting of more than 
one cell can be recognized easily because all its cells except the active 
one have a black background. To select a multiple-cell range:

1) Click on the first cell belonging to the range (either the left top 
cell or the right bottom cell of the rectangular area).

2) Keep the left mouse button pressed and move the mouse to the 
opposite corner of the rectangular area which will form the 
selected range.

3) Release the mouse button.

To add further cells to the selection, hold down the Control key and 
repeat the steps 1 to 3 above.

Tip

You can also click on the first cell in the range, hold down the 
Shift key, and click in the cell in the opposite corner. Refer to 
Chapter 5 (Getting Started with Calc) in the Getting Started 
book for further information on selecting ranges of cells.

Some shortcuts are very useful to speed up the selection:
• To select the whole visible sheet, click at the intersection between 

the rows indexes and the column indexes, or press Control+A.
• To select a column, click on the column index at the top of the 

spreadsheet.
• To select a row, click on the row index on the left hand side of the 

spreadsheet.

Once the range is selected, you can modify the formatting, such as font 
size, alignment (including vertical alignment), font color, number 
formats, borders, background and so on. To access these settings, 
choose Format > Cells from the main menu bar (or right-click and 
choose Format Cells from the pop-up menu). This command opens the 
dialog box shown in Figure 5.
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Figure 5: The Format Cells dialog box consists of 7 pages

If the text does not fit the width of the cell, you can increase the width 
by hovering the mouse over the line separating two columns and, when 
the mouse cursor changes shape, clicking the left button and dragging 
the separating line to the new position. A similar procedure can be 
used to modify the height of a cell (or group of cells).

To insert rows and columns in a spreadsheet, use the Format menu or 
right-click on the row and column headers and select the appropriate 
option from the pop-up menu. To merge multiple cells, select the cells 
to be merged and select Format > Merge cells from the main menu 
bar. To de-merge a group of cells, select the group and again Format > 
Merge Cells (which will now have a checkmark next to it).

When you are satisfied with the formatting and the appearance of the 
table, exit the edit mode by clicking outside the spreadsheet area. Note 
that Impress will display exactly the section of the spreadsheet which 
was on the screen before leaving the edit mode. This allows you to hide 
additional data from the view, but it may cause the apparent loss of 
rows and columns. Therefore, take care that the desired part of the 
spreadsheet is showing on the screen before leaving the edit mode.
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Inserting a chart
To add a chart to a slide, select the corresponding layout in the list of 
predefined layouts in the task pane or use the Insert Chart feature.

Creating a chart in AutoLayout
1) In the Tasks pane, choose a layout that contains a chart (look for 

the vertical bars). See Figure 6.

Figure 6: Examples of layouts with charts

2) Double-click the chart icon in the center of the chart area. A full-
sized chart appears that has been created using sample data. See 
Figure 7.

3) To enter your own data in the chart, see “Entering chart data” on 
page 15.
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Figure 7: Chart made with sample data

Creating a chart using the Insert Chart feature

1) Select Insert > Chart, or click the Insert Chart icon  on the 
Standard toolbar. A chart appears that has been created using 
sample data. See Figure 7.

2) To enter your own data in the chart, see “Entering chart data” on 
page 15.

Choosing a chart type
A wide range of chart types and variations are available (see “Chart
types” on page 13). To choose a chart type:

1) Double-click the sample chart. The window changes; the side 
panes are gone and the main toolbar shows tools specific for 
charts. The chart itself now has a gray border. (If the main toolbar 
is not showing, select View > Toolbars > Main Toolbar.)

2) Click the Chart Type icon  or select Format > Chart Type , 
or right-click on the chart and choose Chart Type. The Chart 
Type dialog box appears. See Figure 8.
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Figure 8: Chart Type dialog box showing two-dimensional charts

3) As you change selections in the left-hand list, the chart examples 
on the right, and the chart in the main window, both change. If 
you move the Chart Type dialog box to one side, you can see the 
full effect in the main window.

4) As you change chart types, other selections become available on 
the right-hand side. For example, some chart types have both 
three-dimensional and two-dimensional variants; 3D charts have 
further choices of shape for the columns or bars.

5) Choose the chart characteristics you want, and then click OK. 
The Chart Type dialog box closes and you return to the edit 
window.

Now you can continue to format the chart, add data to the chart, or 
click outside the chart to return to normal view.

Chart types
Your data can be presented with a number of different charts; choose a 
chart type that best suits the message you want to convey to your 
audience. The following summarizes the uses of the chart types. For 
more detail, see Chapter 4 (Creating Charts and Graphs) in the Calc 
Guide.

Column charts
Column charts are commonly used for data that shows trends over 
time. They are best for charts that have a relatively small number of 
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data points. (For large time series, a line chart would be better.) It is 
the default chart type.

Bar charts
Bar charts are excellent for giving an immediate visual impact for 
data comparison where time is not important, for example to 
compare the popularity of a few products in a marketplace.

Pie charts
Pie charts are excellent when you need to compare proportions, for 
example, comparisons of departmental spending: what the 
department spent on different items or what different departments 
spent. They work best with smaller numbers of values, about half a 
dozen; more than this and the visual impact begins to fade.
This is one of the charts that can profitably be made into a 3D chart. 
It can then be tilted, given shadows, and generally turned into a 
work of art. You can choose to explode the pie chart, but this is an 
all or nothing option.

Donut charts
If you want to show the proportional nature of your data but want to 
include more than one data series, a donut chart is your best option. 
The extra layer attempts to give pies another dimension of time. 
However, two or three data series are all you can include before it 
becomes meaningless. As with pie charts, you can explode the 
pieces of a donut chart.

Area charts
An area chart is a version of a line or column graph. It may be useful 
where you wish to emphasize volume of change. Area charts have a 
greater visual impact than a line chart, but the data you use will 
make a difference. You may need to use transparency values in an 
area chart.

Line charts
A line chart is a time series with a progression. It is ideal for raw 
data, and useful for charts with plentiful data that shows trends or 
changes over time where you want to emphasize continuity. On line 
charts, the x-axis is ideal to represent time series data. 3D lines 
confuse the viewer, so just using a thicker line often works better.

Scatter or XY charts
Scatter charts are great for visualizing data that you have not had 
time to analyze, and they may be the best for data when you have a 
constant value with which to compare the data; for example weather 
data, reactions under different acidity levels, conditions at altitude, 
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or any data which matches two series of numeric data. In contrast to 
line charts, the x-axis are the left to right labels which usually 
indicate a time series.

Net charts
A net chart is similar to polar or radar graphs. They are useful for 
comparing data that are not time series, but show different 
circumstances, such as variables in a scientific experiment or 
direction. The poles of the net chart are the y-axes of other charts. 
Generally, between three and eight axes are best; any more and this 
type of chart becomes confusing.

Stock charts
A stock chart is a specialized column graph specifically for stocks 
and shares. You can choose traditional lines, candlestick, and two-
column type charts. The data required for these charts is quite 
specialized, with series for opening price, closing price, and high 
and low prices. Of course the x-axis represents a time series.

Column and line charts
A column and line chart is a combination of two other chart types. It 
is useful for combining two distinct but related data series, for 
example sales over time (column) and the profit margin trends (line).

Entering chart data

Opening a chart data window
1) If the chart is not already in edit mode (with a gray border), 

double-click it. The main toolbar now shows tools specifically for 
charts. (If the main toolbar is not showing, select View > 
Toolbars > Main Toolbar.)

2) Click the Chart Data icon  or select View > Chart Data 
Table, or right-click on the chart and choose Chart Data Table. 
The Data Table dialog box (Figure 9) appears.

Tip
If you drag the Data Table dialog box so that your chart is 
visible, you can then immediately see the results of each change 
after clicking in a different cell.
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Figure 9: Data Table dialog box

Entering data
Enter data in the Data Table dialog box.

• Insert buttons insert a row or column.
• Delete buttons remove the information from a selected row or 

column.
• Move buttons move the contents of the selected column to the 

right, or move the contents of the selected row down.
• Input fields and cells are where you insert data. Type or paste 

information into the boxes within the desired rows and columns.

Formatting the chart
In addition to the wide range of chart type and appearance choices 
available through the Chart Type dialog box, Impress provides other 
ways to customize a chart. This section introduces some of them. Refer 
to Chapter 4 (Creating Charts and Graphs) in the Calc Guide for more 
details.

Adding or removing elements from a chart
The default chart includes only two elements: the chart wall and the 
legend (also known as the key). You can add other elements using the 
Insert menu, as shown in Figure 10. The various choices open dialog 
boxes in which you can specify details. 
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Figure 10: Insert menu for charts

Using the Format menu
The format menu has many options for formatting and fine-tuning the 
look of your charts.

Double-click the chart so that it is enclosed by a gray border. Click 
Format in the main menu. See Figure 11.

Figure 11: Chart format menu

• Object Properties opens a dialog box in which you can specify the 
area fill, borders, transparency, characters, font effects, and 
position of the selected element of the chart.

Inserting a chart 17



• Position and Size opens the Position and Size dialog box (see 
“Resizing and moving the chart”).

• Arrangement provides two choices: Bring Forward and Send 
Backward, of which only one may be active for specific items. 
Use these choices to arrange overlapping data series.

• Title formats the titles of the chart and its axes.
• Axis formats the lines that create the chart as well as the font of 

the text that appears on both the X and Y axes.
• Grid formats the lines that create a grid for the chart.
• Legend formats the location, borders, background, and type of 

the legend.
• Chart Wall, Chart Floor, and Chart Area are described in the 

following sections.
• Chart Type changes what kind of chart is displayed and whether 

it is two- or three-dimensional.
• 3D View formats the various viewing angles of 3D chart.

Note
Chart Floor and 3D View are only available for a 3D chart. 
These options are unavailable (grayed out) if a 2D chart is 
selected.

The two main areas of the chart control different settings and 
attributes for the chart. See Figure 12.

Figure 12: The Chart wall and Chart area

• Chart wall contains the graphic of the chart displaying the data.
• Chart area is the area surrounding the chart graphic. The 

(optional) chart title and the legend (key) are in the chart area.
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Note
Chart Floor, from the Format menu, is only available for 3D 
charts and has the same formatting options as 3Chart Area and 
Chart Wall.

Knowing the difference between the chart wall and chart area is 
helpful when formatting a chart.

Resizing and moving the chart
You can resize or move all elements of a chart at the same time, in two 
ways: interactively, or by using the Position and Size dialog box. You 
may wish to use a combination of both methods: interactive for quick 
and easy change, then the dialog box for precise sizing and positioning.

To resize a chart interactively:
1) Click on the chart to select it. Green sizing handles appear around 

the chart.
2) To increase or decrease the size of the chart, click and drag one 

of the markers in one of the four corners of the chart. To maintain 
the correct ratio of the sides, hold the Shift key down while you 
click and drag.

To move a chart interactively:
1) Click on the chart to select it. Green sizing handles appear around 

the chart.
2) Hover the mouse pointer anywhere over the chart. When it 

changes shape, click and drag the chart to its new location.
3) Release the mouse button when the element is in the desired 

position.

To resize or move a chart using the Position and Size dialog box:
1) Click on the chart to select it. Green sizing handles appear around 

the chart.
2) Choose Format > Position and Size from the menu bar, or 

right-click and choose Position and Size from the pop-up menu, 
or press F4. For more about the use of this dialog box, see 
Chapter 6 (Formatting Graphic Objects).

Moving chart elements
You may wish to move or resize individual elements of a chart, 
independent of other chart elements. For example, you may wish to 
move the legend to a different place. Pie charts allow moving of 
individual wedges of the pie (in addition to the choice of “exploding” 
the entire pie).
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1) Double-click the chart so that is enclosed by a gray border.
2) Click any of the elements—the title, the legend, or the chart 

graphic—to select it. Green resizing handles appear.
3) Move the pointer over the selected element. When it changes 

shape, click and drag to move the element.
4) Release the mouse button when the element is in the desired 

position.

Note

If your graphic is 3D, round red handles appear which control 
the three-dimensional angle of the graphic. You cannot resize or 
reposition the graphic while the round red handles are showing. 
With the round red handles showing, Shift + Click to get the 
green resizing handles. You can now resize and reposition your 
3D chart graphic. See the following tip.

Tip
You can resize the chart graphic using its green resizing handles 
(Shift + Click, then drag a corner handle to maintain the 
proportions). However, you cannot resize the title or the key.

Changing the chart area background
1) The chart area is the area surrounding the chart graphic, 

including the (optional) main title and key.
2) Double-click the chart so that it is enclosed by a gray border.
3) Select Format > Chart Area. The Chart Area window appears. 

See Figure 13.
4) Choose the desired format settings.

Changing the chart graphic background
The chart wall is the area that contains the chart graphic.

1) Double-click the chart so that it is enclosed by a gray border.
2) Select Format > Chart Wall. The Chart Wall window appears. 

It has the same formatting options as described in “Changing the
chart area background” above.

3) Choose your settings and click OK.
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Figure 13: Chart Area dialog box

Inserting other objects
Impress offers the capability of inserting in a slide various types of 
objects such as music or video clips, Writer documents, Math formulas, 
generic OLE objects and so on. A typical presentation may contain 
movie clips, sound clips, OLE objects and formulas; other objects are 
less frequently used since they do not appear during a slide show.

This section covers the part of the Insert menu shown in Figure 14.

Figure 14: Part of the Insert menu
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Movies and sound
To insert a movie clip or a sound into a presentation, select Insert > 
Movie and Sound. Select the media file to insert from the dialog box, 
to place the object on the slide.

To insert media clips directly from the Gallery:
1) If not already open, open the Gallery by selecting Tools > 

Gallery.
2) Browse to the Theme containing media files (for example the 

Sounds theme).
3) Click on the movie or sound to be inserted and drag it into the 

slide area.

The Media Playback toolbar (Figure 15) is automatically opened (by 
default, at the bottom of the screen, just above the Drawing toolbar; it 
can also be made floating). You can preview the media object as well as 
resize it. If the toolbar does not open, select View > Media Playback.

Figure 15: The media playback toolbar (movie clip)

The Media Playback toolbar contains the following tools:
• Add button: opens a dialog box where you can select the media 

file to be inserted.
• Play, Pause, Stop buttons: control the media playback.
• Repeat button: if pressed, the media will restart when finished.
• Playback slider: selects the position within the media clip.
• Timer: displays the current position of the media clip.
• Mute Button: when selected, the sound will be suppressed.
• Volume Slider: adjusts the volume of the media clip.
• Scaling drop-down menu: (only available for movies) allows 

scaling of the movie clip.

The movie will start playing as soon as the slide is shown during the 
presentation.

Note that Impress will only link the media clip, therefore when the 
presentation is moved to a different computer, the link will most likely 
be broken and as a consequence the media clip will not play. An easy 
workaround that prevents this from happening is the following:

1) Place the media file to be included in the presentation in the same 
folder where the presentation is stored.
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2) Insert the media file in the presentation.
3) When sending the presentation to a different computer, send also 

the media file and place both files in the same folder on the target 
computer.

Impress offers the possibility to preview the media clips that are to be 
inserted by means of the provided media player. To open it select Tools 
> Media Player. The media player is shown in Figure 16. Its toolbar is 
the same as that of the Media Playback toolbar described above.

Figure 16: The embedded media player

OLE objects
Use an OLE (Object Linking and Embedding) object to insert in a 
presentation either a new document or an existing one. Embedding 
inserts a copy of the object and details of the source program in the 
target document, that is the program which is associated to the file 
type in the operating system. The major benefit of an OLE object is 
that it is quick and easy to edit the contents just by double-clicking on 
it. You can also insert a link to the object that will appear as an icon 
rather than an area showing the contents itself.

To create and insert a new OLE object:
1) Select Insert > Object > OLE object from the main menu. This 

opens the dialog box shown in Figure 17.
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Figure 17: Insert OLE Object dialog box

2) Select Create new and select the object type among the available 
options.

Note
“Further objects” is only available under a Windows operating 
system. It does not appear in the list under any other system.

3) Click OK. An empty container is placed in the slide.
4) Double-click on the OLE object to enter the edit mode of the 

object. The application devoted to handling that type of file will 
open the object.

Note

If the object inserted is handled by OpenOffice.org, then the 
transition to the program to manipulate the object will be 
seamless; in other cases the object opens in a new window and 
an option in the File menu becomes available to update the 
object you inserted.

To insert an existing object:
1) Select Insert > Object > OLE object from the main menu.
2) In the Insert OLE Object dialog box (Figure 17), select Create 

from file. The dialog box changes to look like Figure 18.

Figure 18: Inserting an object as a link
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3) To insert the object as a link, select the Link to file checkbox. 
Otherwise, the object will be embedded.

4) Click Search, select the required file in the file picker window, 
then click Open. A section of the inserted file is shown on the 
slide.

Other OLE objects
Under Windows, the Insert OLE Object dialog box has an extra entry, 
Further objects, as shown in Figure 17.

1) Double-click on the entry Further objects to open the dialog box 
shown in Figure 19.

Figure 19: Advanced menu to insert an OLE object under 
Windows  

2) Select Create New to insert a new object of the type selected in 
the Object Type list, or select Create from File to create a new 
object from a file.

3) If you choose Create from File, the dialog box shown in Figure
20 opens. Click Browse and choose the file to insert. The inserted 
file object is editable by the Windows program that created it.

If instead of inserting an object, you want to insert a link to an 
object, select the Display As Icon checkbox.
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Figure 20: Insert object from a file

Formulas
Use Insert > Object > Formula to create a Math object in a slide. 
When editing a formula, the main menu changes into the Math main 
menu.

Care should be taken about the font sizes used in order to make them 
comparable to the font size used in the rest of the slide. To change the 
font attributes of the Math object, select Format > Font Size from the 
main menu bar. To change the font type, select Format > Fonts from 
the main menu bar.

For additional information on how to create formulas, refer to Chapter 
9 (Getting Started with Math) in the Getting Started guide, or Chapter 
16 (Math Objects) in the Writer Guide.

Note that unlike in Writer, a formula in Impress is treated as an object, 
therefore it will not be automatically aligned with the rest of the text. 
The formula can be however moved around (but not resized) as any 
other object.

Inserting the contents of a file
You can insert the contents of a file into a presentation. The types of 
file accepted are OpenOffice.org Draw file, HTML files or plain text 
files.

Select Insert > File from the main menu to open a file picker window. 
If there is an internet connection, it is also possible to insert in the file 
name field a URL. Select the file and click Insert.
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