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What is Impress?
Impress is OpenOffice.org’s presentations (slide show) component. You 
can create slides that contain many different elements, including text, 
bulleted and numbered lists, tables, charts, clip art, and a wide range 
of graphic objects. Impress, in common with the other components of 
OpenOffice.org, has access to the spelling checker and thesaurus and 
comes with pre-packaged text styles, background styles, and a handy 
online help.

This chapter introduces the Impress user interface and describes how 
to create a simple slide show using the Presentation Wizard.

To use Impress for more than very simple slide shows, refer to the 
other chapters in this guide for explanations of the program’s many 
features.

Note
Drawings are created in the same way with Impress as they are 
with Draw. Refer to the Draw Guide for details on how to use the 
drawing facilities.

Parts of the main Impress window
The main Impress window (Figure 1) has three parts: the Slides pane, 
the Workspace, and the Tasks pane. Additionally, several toolbars can 
be displayed or hidden during the creation of a presentation.

Tip

You can remove the Slides pane or Tasks pane from view by 
clicking the X in the upper right corner. You can also show or 
hide these panes using View > Slide Pane or View > Task 
Pane.

Slides pane
The Slides pane contains thumbnail pictures of the slides in your 
presentation, in the order they will be shown (unless you change the 
order, as described in Chapter 9). Clicking a slide in this pane selects it 
and places it in the Workspace. While it is there, you can apply any 
changes desired to that particular slide.
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Figure 1: Main window of Impress

Several additional operations can be performed on one or more slides 
in the Slides pane:

• Add new slides at any place within the presentation after the first 
slide.

• Mark a slide as hidden so that it will not be shown as part of the 
slide show.

• Delete a slide from the presentation if it is no longer needed.
• Rename a slide.
• Copy or move the contents of one slide to another (copy and 

paste, or cut and paste, respectively).

It is also possible to perform the following operations, although there 
are more efficient methods than using the Slides pane as you will see 
in this chapter.

• Change the slide transition following the selected slide or after 
each slide in a group of slides.

• Change the sequence of slides in the presentation.
• Change the slide design. (A window opens allowing you to load 

your own design.)
• Change slide layout for a group of slides simultaneously. (This 

requires using the Layouts section of the Tasks pane.)
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Tasks pane
The Tasks pane has five sections:

Master Pages
Here you define the page style for your presentation. Impress 
contains 28 prepackaged Master Pages (slide masters). One of them
—Default—is blank, and the rest have a background.

Tip

Press F11 to open the Styles and Formatting window, where you 
can modify the styles used in any slide master to suit your 
purposes. This can be done at any time. See Chapter 2 for more 
information.

Layout
Twenty prepackaged layouts are shown. You can choose the one you 
want, use it as it is or modify it to your own requirements. At 
present it is not possible to create custom layouts.

Table Design
Eleven standard table styles are provided in this pane. You can 
further modify the appearance of a table with the selections to show 
or hide specific rows and columns, or to apply a banded appearance 
to the rows and columns.

Custom Animation
A variety of animations for selected elements of a slide are listed. 
Animation can be added to selected elements of a slide, and it can 
also be changed or removed later.

Slide Transition
Fifty-six transitions are available, including No Transition. You can 
select the transition speed (slow, medium, fast). You can also choose 
between an automatic or manual transition, and how long you want 
the selected slide to be shown (automatic transition only).

Workspace
The Workspace has five tabs: Normal, Outline, Notes, Handout, and 
Slide Sorter, as seen in Figure 5. These five tabs are called View 
Buttons. There are also many toolbars that can be used during slide 
creation; they are revealed by selecting them with View > Toolbars. 
The actual Workspace section is below the View Buttons. This is where 
you assemble the various parts of your selected slide.
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Each view is designed to ease the completion of certain tasks. In 
summary:

• Normal view is the main view for creating individual slides. Use 
this view to format and design slides and to add text, graphics, 
and animation effects.

• Outline view shows topic titles, bulleted lists, and numbered lists 
for each slide in outline format. Use this view to rearrange the 
order of slides, edit titles and headings, rearrange the order of 
items in a list, and add new slides.

• Notes view lets you add notes to each slide that are not seen 
when the presentation is shown.

• Slide Sorter view shows a thumbnail of each slide in order. Use 
this view to rearrange the order of slides, produce a timed slide 
show, or add transitions between selected slides.

• Handout view lets you print your slides for a handout. You can 
choose one, two, three, four, or six slides per page from Tasks 
pane > Layouts. Thumbnails can be re-arranged in this view by 
dragging and dropping them.

Normal view
There are two ways to place a slide in the Slide Design area of the 
Normal view: clicking the slide thumbnail in the Slides pane or using 
the Navigator.

To open the Navigator, click the Navigator button in the Standard 

Toolbar  or press Ctrl+Shift+F5 and select a slide by scrolling down 
the Navigator list until you find the one you want and then double-click 
it. For more about using the Navigator, see page 13.

Outline view
Outline view contains all of the slides of the presentation in their 
numbered sequence. Only the text in each slide is shown. Slide names 
are not included.

Outline view serves at least two purposes.
1) Making changes in the text of a slide:

• Add or delete text in a slide just as in the Normal view.
• Move the paragraphs of text in the selected 

slide up or down by using the up and down 
arrow buttons (Move Up or Move Down) on 
the Text Formatting toolbar.
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• Change the outline level for any of the paragraphs in a slide 
using the left and right arrow buttons (Promote or Demote).

• Both move a paragraph and change its outline level using a 
combination of these four arrow buttons.

2) Comparing the slides with your outline (if you have prepared one 
in advance). If you notice from your outline that another slide is 
needed, you can create it directly in the Outline view or you can 
return to the Normal view to create it, then return to review all 
the slides against your outline in the Outline view.
If a slide is not in the correct sequence, you can move it to its 
proper place:
a) Click the slide icon of the slide you wish to move, as indicated 

in Figure 2.
b) Drag and drop it where you want it.

Figure 2: Outline view

Notes view
Use the Notes view to add notes to a slide:

1) Click the Notes tab in the Workspace (Figure 3).
2) Select the slide to which you will add notes.

• Double-click the slide in the Slide pane, or
• Double-click the slide’s name in the Navigator.

3) In the text box below the slide, click on the words Click to add 
notes and begin typing.
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You can resize the notes text box using the green resizing handles and 
move it by placing the pointer on the border, then clicking and 
dragging. To make changes in the text style, press the F11 key to open 
the Styles and Formatting window.

Figure 3: Adding notes in Notes View

Slide Sorter view
The Slide Sorter view contains all of the slide thumbnails (Figure 4). 
Use this view to work with a group of slides or with only one slide.

Figure 4: Slide Sorter view
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Change the number of slides per row, if desired:
1) Check View > Toolbars > Slide View to show the Slide view 

toolbar (Figure 5).

Figure 5: Slide Sorter and Slide 
View toolbars

2) Adjust the number of slides (up to a maximum of 15).
3) After you have adjusted the number of slides per row, 

View > Toolbars > Slide View will remove this toolbar from 
view.

To move a slide in a presentation using the Slide Sorter:
1) Click the slide. A thick black border is drawn around it.
2) Drag and drop it to the location you want.

• As you move the slide, a black vertical line appears to one side 
of the slide.

• Drag the slide until this black vertical line is located where 
you want the slide to be moved.

To select a group of slides, use one of these methods:
• Use the Control (Ctrl) key: Click on the first slide and, while 

pressing Control, select the other desired slides.
• Use the Shift key: Click on the first slide, and while pressing the 

Shift key, select the final slide in the group. This selects all of the 
other slides in between the first and the last.

• Use the cursor: Click on the first slide to be selected. Hold down 
the left mouse button. Drag the cursor to the last slide thumbnail. 
A dashed outline of a rectangle forms as you drag the cursor 
through the slide thumbnails and a thick black border is drawn 
around the selected slides. Make sure the rectangle includes all 
the slides you want to select.

To move a group of slides:
1) Select the group.
2) Drag and drop the group to their new location. The same vertical 

black line appears to show you where the group of slides will go.

Note
Selection of a group of slides works in a rectangular fashion. 
Slides that do not fall within a rectangular area cannot be 
grouped.
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You can work with slides in the Slide Sorter view just as you can in the 
Slide pane.

To make changes, right-click a slide and do the following, using the 
pop-up menu:

• Add a new slide after the selected slide.
• Delete or rename the selected slide.
• Change the Slide Layout.
• Change the Slide Transition.

– For one slide, click the slide to select it. Then add the desired 
transition.

– For more than one slide, select the group of slides and add the 
desired transition.

• Mark a slide as hidden. Hidden slides will not be shown in the 
slide show.

• Copy or cut and paste a slide.

Handout view
Handout view is for setting up the layout of your slides for a printed 
handout. Click the Handout tab in the workspace, then choose Layouts 
in the tasks pane (Figure 6). You can then choose to print one, two, 
three, four, or six slides per page.

Figure 6: Handout layouts

To print a handout:
1) Select the slides using the Slide Sorter. (Use the steps listed in 

selecting a group of slides on page 10.)
2) Select File > Print or press Control+P to open the Print dialog 

box.
3) Select Options in the bottom left corner of the Print dialog box.
4) Check Handouts in the Contents section, and then click OK.
5) Click OK to close the Print dialog box.
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Toolbars
The various Impress toolbars can be displayed or hidden by clicking 
View > Toolbars and selecting from the menu. You can also select the 
icons that you wish to appear on each toolbar. For more information, 
refer to Chapter 1 (Introducing OpenOffice.org) in the Getting Started 
guide.

Many of the toolbars in Impress are similar to the toolbars in OOo 
Draw. Refer to the Draw Guide for details on the functions available 
and how to use them.

Status Bar

The status bar, positioned at the bottom of the Impress window, 
contains information that you may find useful when working on a 
presentation.
From left to right, you will find:

• A general information area, which changes depending on the 
selection: For example:
– Text area—”TextEdit: Paragraph x, Row y, Column z”
– Charts, spreadsheets—”Embedded object (OLE) ‘ObjectName’ 

selected”
– Graphics—”Bitmap with transparency selected”

• The position of the cursor or of the top left corner of the selection 
measured from the top left corner of the slide.

• The width and height of the selection or of the text box where the 
cursor is.

• The zoom level of the workarea.
• A modified flag, showing a star when the file needs saving.
• A flag indicating if the document is digitally signed.
• The slide number currently displayed in the workarea.
• The slide master associated to the slide currently in the workarea.

Tip
Right-clicking on the slide master area of the Status bar you can 
quickly apply a different slide master to the current slide.

In case you do not need the information in the Status Bar you can hide 
it by selecting View > Status Bar from the main menu.
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Navigator
The Navigator (Figure 7) displays all objects 
contained in a document. It provides another 
convenient way to move around a document 
and find items in it. The Navigator button is 
located on the Standard toolbar. You can also 
display the Navigator by choosing Edit > 
Navigator on the menu bar or pressing 
Ctrl+Shift+F5.

The Navigator is more useful if you give your 
objects (pictures, spreadsheets, and so on) 
meaningful names, instead of leaving them 
as the default “Object 1” and “Picture 1” 
shown in Figure 7.

Creating a new presentation
This section shows you how to set up a new presentation using the 
Presentation Wizard.

Planning the presentation
The first thing to do is decide what you are going to do with the 
presentation. For example, putting a group of digital photos together in 
a presentation requires very little planning. However, using a 
presentation to increase the knowledge of others about your topic 
requires much more planning.

You need to ask and answer many questions before you begin creating 
a presentation. If you are not acquainted with creating presentations, 
the answers will be more general. Those who have created a variety of 
presentations in the past will want to have more specific answers.

Who is to see the presentation? How will it be used? What is the 
subject matter? What should be in its outline? How detailed should the 
outline be? Will an audio file be played? Is animation desirable? How 
should the transition between slides be handled? These are some of the 
many questions that should be asked, answered, and written down 
before creating the presentation.

Again, it is not always necessary at this point to have specific answers 
to every question. Making an outline is extremely important. You may 
already know exactly what some of the slides will contain. You may 
only have a general idea of what you want on some of the slides. That 
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is alright. You can make some changes as you go. Change your outline 
to match the changes you make in your slides.

The important part is that you have a general idea of what you want 
and how to get it. Put that information on paper. That makes it much 
easier to create the presentation.

Using the Presentation Wizard
You can start Impress in several ways:

• From the system menu or the OpenOffice.org Quickstarter. 
Details vary with your operating system; see the Getting Started 
guide if you need more information.

• From any open component of OOo, click the triangle to the right 
of the New icon on the main toolbar and select Presentation from 
the drop-down menu (Figure 8).

Figure 8: Opening the presentation wizard

• From any open component of OOo, choose File > New > 
Presentation.

When you start Impress, the Presentation Wizard (Figure 9) appears.

Tips

If you do not want the wizard to start every time you start 
Impress, select the Do not show this wizard again checkbox.
Leave the Preview checkbox selected, so templates, slide 
designs, and slide transitions appear in the preview box as you 
choose them.
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Figure 9. Using the Presentation Wizard to choose the 
type of presentation 

1) Select Empty presentation under Type. It creates a presentation 
from scratch.

Note

From template uses a template design already created as the 
basis for a new presentation. The wizard changes to show a list 
of available templates. Choose the template you want. More 
details can be found in Chapter 2.
Open existing presentation continues work on a previously 
created presentation. The wizard changes to show a list of 
existing presentations, from which you can choose the one you 
want.

2) Click Next. The Presentation Wizard step 2 appears. Figure 10 
shows the Wizard as it appears if you selected Empty 
presentation at step 1. If you selected From template, an example 
slide is shown in the Preview box.

3) Choose a design under Select a slide design. The slide design 
section gives you two main choices: Presentation Backgrounds 
and Presentations. Each one has a list of choices for slide designs. 
If you want to use one of these other than <Original>, click it to 
select it.
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Impress provides about 25 types of Presentation Backgrounds that you 
can select from the list shown in Figure 10. <Original> is an empty 
background. You can also select among three predefined 
Presentations: <Original>, Introducing a New Product, and 
Recommendation of a Strategy.

Figure 10. Selecting a slide design using the 
Presentation Wizard

To start with a blank presentation, select <Original>. Click an item to 
see a preview of the slide design in the Preview window.

Note

Introducing a New Product and Recommendation of a Strategy 
are pre-packaged presentation templates. They can be used to 
create a presentation by choosing From template in the first 
step (Figure 9).

Select how the presentation will be used under Select an output 
medium. Generally, presentations are created for computer screen 
display, so you would select Screen.

Click Next. The Presentation Wizard step 3 appears (Figure 14).

In this step you can choose the desired slide transition from the Effect 
drop-down menu. Select the desired speed for the transition between 
the different slides in the presentation from the Speed drop-down 
menu. Medium is a good choice for now.

Click Create. A new presentation is created.
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Figure 11: Selecting a slide transition effect

Tip

You might want to accept the default values for both Effect and 
Speed unless you are skilled at doing this. Both of these values 
can be changed later while working with Slide transitions and 
animations. These two are explained in more detail in Chapter 
9 (Slide Shows).

Note
If you selected From template on step 1 of the Wizard, the Next 
button will be active on step 3 and other pages will be available.

Formatting a presentation
Now put your presentation together based on your outline.

Caution

Remember to save frequently while working on the presentation, 
to prevent any loss of information should something unexpected 
occur. You might also want to activate the AutoRecovery function 
(Tools > Options > Load/Save > General). Make sure Save 
AutoRecovery information every is selected and that you have 
entered a recovery frequency.
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Creating the first slide
The first slide is normally a title slide. Decide which of the layouts will 
best suit your purposes for this first slide: simplicity would be 
appropriate in this instance. You can use the pre-packaged layouts 
available in the Layout section of the Tasks pane. Suitable layouts are 
Title Slide (which also contains a section for a subtitle) or Title Only, 
however all but one layout (the blank one) contains a title section, so 
you are not restricted to the two layouts described here.

Tip

If you do not know the names for the pre-packaged layouts, you 
can use the tooltip feature. Position the cursor on an icon in the 
Layout section (or on any toolbar icon) and its name will be 
displayed in a small rectangle.
If the tooltips are not enabled, you can enable them. From the 
main menu, select Tools > Options > OpenOffice.org > 
General > Help and mark the Tips checkbox. If the Extended 
tips checkbox is also marked, you will get more detailed tooltip 
information, but the tooltip names themselves will not be 
provided.

Select a layout in the Layout section of the Tasks pane by clicking on it: 
it appears in the Workspace. To create the title, click on Click to add 
title (assuming the Blank Slide layout was not used) and then type the 
title text. Adjustments to the formatting of the title can be done by 
pressing the F11 key, right-clicking the Title presentation style entry, 
and selecting Modify from the pop-up menu.

If you are using the Title Slide layout, click on “Click to add text” to add 
a subtitle. Proceed as above to make adjustments to the formatting if 
required.

Inserting additional slides
The steps for inserting additional slides are basically the same as for 
selecting the title page. It is a process that has to be repeated for each 
slide. Unless you are using more than one slide master, your only 
concern is the Layouts section of the Tasks pane (Figure 12).
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Figure 12: Choosing a slide layout

First insert all the slides your outline indicates you will need. Only 
after this should you begin adding special effects such as custom 
animation and slide transitions.

Step 1: Insert a new slide. This can be done in a variety of ways—take 
your pick.

• Insert > Slide.
• Right-click on the present slide, and select Slide > New Slide 

from the pop-up menu.
• Click the Slide icon in the Presentation toolbar (Figure 13).

Figure 13: Presentation toolbar

Step 2: Select the layout slide that bests fits your needs.

Step 3: Modify the elements of the slide. At this stage, the slide 
consists of everything contained in the slide master, as well as the 
chosen layout slide, so this includes removing unneeded elements, 
adding needed elements (such as pictures), and inserting text.

Caution
Changes to any of the pre-packaged layouts can only be made 
using View > Normal, which is the default. Attempting to do this 
by modifying a slide master may result in unpredictable results 
and requires extra care as well as some trials and errors.
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1) Remove any element on the slide that is not required (Figure 14).
c) Click the element to highlight it. (The green squares show it is 

highlighted.)
d) Press the Delete key to remove it.

Figure 14: Deleting an element of a slide

Tip
Sometimes you will accidentally select the wrong layout slide or 
decide to change it. This is safe and does not cause loss of the 
contents already on the slide.

2) Add any elements to the slide that you do need.
e) Adding pictures to the clipart frame, if your chosen layout 

includes one:
i. Double-click the picture within the frame. The Insert 

picture dialog box opens.
ii. Browse to the location of the picture you want to include. 

To see a preview of the picture, check Preview at the 
bottom of the Insert picture dialog box.

iii. Select the picture and click Open.
iv. Resize the picture as necessary. Follow the directions in 

the Caution note below.
f) Adding pictures from graphic files to places other than the 

clipart frame:
v. Insert > Picture > From File. The Insert picture dialog 

box opens.
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vi. Browse to the graphic file. To see a preview of the picture, 
check Preview at the bottom of the Insert picture dialog 
box. Select a picture and click Open.

vii. Move the picture to its location.
viii. Resize the picture, if necessary.

g) Adding OLE Objects is an advanced technique covered in 
Chapter 7 (Inserting spreadsheets, charts, and objects).

Caution

When resizing a graphic, right-click the picture. Select Position 
and Size from the context menu and make sure that Keep ratio 
is selected. Then adjust the height or width to the size you need. 
(As you adjust one dimension both dimensions will change.) 
Failure to do so will cause the picture to become distorted. 
Remember also that resizing a bitmap image will reduce its 
quality; better by far to create an image of the desired size 
outside of Impress.

3) Adding text to a slide: If the slide contains text, click on Click to 
add an outline in the text frame and then type your text. The 
Outline styles from 1 to 10 are automatically applied to the text as 
you insert it. You can change the outline level of each paragraph 
as well as its position within the text using the arrow buttons on 
the Text Formatting toolbar (see “Outline view” on page 7).

Step 4: To create additional slides, repeat steps 1–3.

Modifying the appearance of slides
To change the background and other characteristics of all slides in the 
presentation, you need to modify the slide master or choose a different 
slide master.

A Slide Master is a slide with a specified set of characteristics which is 
used as the beginning point for creating other slides. These 
characteristics include the background, objects in the background, 
formatting of any text used, and any background graphics.

Note

OOo uses three interchangeable terms for this one concept. 
Master slide, slide master, and master page all refer to a slide 
that is used to create other slides. This book, however, will use 
only the term slide master, except when describing the user 
interface.

Impress has five pre-packaged slide masters, found in the Master 
Pages section of the Tasks pane (Figure 2). You can also create and 
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save additional slide masters. See Chapter 2 for information on 
creating and modifying slide masters.

Modifying the slide show
Now review the entire presentation and answer some questions. Run 
the slide show at least once before answering them. You might want to 
add some questions of your own.

1) Are the slides in the correct order? If not, some of them will need 
to be moved.

2) Would an additional slide make a particular point clearer? If so, 
another slide needs to be created.

3) Would some custom animations help some of the slides? 
(Advanced technique.)

4) Should some of the slides have a different slide transition than 
others? The transition of those slides should be changed.

5) Do some of the slides seem unnecessary? Delete the affected slide 
or slides after checking if they are indeed unnecessary.

Caution

If one or more slides seems to be unnecessary, hide the slide or 
slides, and view the slide show a few more times to make sure. 
To hide a slide, right-click the slide in the Slides pane. Select 
Hide Slide in the pop-up menu. Do not delete a slide until you 
have done this, otherwise you may have to create that slide 
again.

Once you have answered these and your own questions, you should 
make the necessary changes. This is done most easily in the Slide 
Sorter view (see page 9). If you need one or more new slides, create 
them using the steps listed in “Inserting additional slides” on page 18.

Renaming slides
Right-click on a thumbnail in the Slides pane or the Slide Sorter and 
choose Rename Slide from the pop-up menu. In the Name field, 
delete the old name of the slide and type the new name. Click OK to 
save the change.

Custom animations
If you know how to add a custom animation to a slide and wish to do 
so, do it now. Custom animations are found on the Tasks pane. This is 
an advanced technique and is explained in Chapter 9 (Slide shows).
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Slide transitions
Your first slide show should probably have the same slide transition for 
all slides. Setting Advance slide to On mouse click is the default and 
a simple setting. If you want each slide to be shown for a specific 
amount of time, click Automatically after and enter the number of 
seconds. Click Apply to all slides.

Transition choices are found on the Tasks pane. For more information 
about slide transitions, see Chapter 9 (Slide Shows).

Tip

The Slide transition section has a very useful choice: Automatic 
preview. Select its checkbox. Then when you make any changes 
in a slide transition, the new slide is previewed in the Slide 
Design area, including its transition effect.

Running the slide show
To run the slide show, do one of the following:

• Click Slide Show > Slide Show on the main menu bar.
• Click the Slide Show button on the Presentation toolbar (Figure

13) or the Slide Sorter toolbar (Figure 5).
• Press F5 or F9.

If the slide transition is Automatically after x seconds, let the slide 
show run by itself.

If the slide transition is On mouse click, do one of the following to 
move from one slide to the next.

• Use the arrow keys on the keyboard to go to the next slide or to 
go back to the previous one.

• Click the mouse button to advance to the next slide.
• Press the Spacebar on the keyboard to advance to the next slide.

When you advance past the last slide, the message “Click to exit 
presentation...” appears. Click the mouse or press any key to exit the 
presentation.

To exit the slide show at any time, including at the end, press the Esc 
key.
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