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Introduction
This chapter covers the basics of working with text in Writer, the word-
processing component of OpenOffice.org (OOo). It assumes that you 
are familiar with the use of a mouse and keyboard and that you have 
read about Writer’s menus and toolbars and other topics covered in 
Chapter 1 (Introducing Writer).

We recommend that you also follow the suggestions in Chapter 2 
(Setting up Writer) about displaying formatting aids, such as end-of-
paragraph marks, and selecting other setup options.

When you have read this chapter, you should know how to:
• Select, cut, copy, paste, and move text
• Find and replace text
• Insert special characters
• Format paragraphs and characters
• Create numbered or bulleted lists
• Check spelling, use language tools, use the thesaurus, and choose 

hyphenation options
• Use the autocorrection, word completion, autotext, and line 

numbering features
• Track changes, undo and redo changes, and insert notes
• Link to other parts of a document

Selecting text
Before you can do anything with text, you need to select it. Selecting 
text in Writer is similar to selecting anything in other applications.

In addition to selecting blocks of text, you can select items that are not 
consecutive, and columns (vertical blocks) of text.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 1) using the 
mouse:

1) Select the first piece of text.
2) Hold down the Control (Ctrl) key and use the mouse to select the 

next piece of text.
3) Repeat as often as needed.
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Now you can work with the selected text (copy it, delete it, change the 
style, or whatever).

Note
Macintosh users: substitute the Command key when 
instructions in this chapter say to use the Control key.

To select nonconsecutive items using the keyboard:
1) Select the first piece of text. (For more information about 

keyboard selection of text, see the topic “Navigating and 
Selecting with the Keyboard” in the OpenOffice.org Help (F1).)

2) Press Shift+F8. This puts Writer in “ADD” mode. The word ADD 
appears on the Status Bar.

3) Use the arrow keys to move to the start of the next piece of text 
to be selected. Hold down the Shift key and select the next piece 
of text.

4) Repeat as often as needed.

Now you can work with the selected text.

Figure 1: Selecting items that are not next to each other

Press Esc to exit from this mode.

Selecting a vertical block of text
You can select a vertical block or “column” of text that is separated by 
spaces or tabs (as you might see in text pasted from e-mails, program 
listings, or other sources), using OOo’s block selection mode. To 
change to block selection mode, use Edit > Selection Mode > Block 
Area, or click several times in the status bar on STD until it changes to 
BLK.

Now highlight the selection, using mouse or keyboard, as shown in 
Figure 2.
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Figure 2: Selecting a vertical block of text

Cutting, copying, and pasting text
Cutting and copying text in Writer is similar to cutting and copying text 
in other applications. You can copy or move text within a document, or 
between documents, by dragging or by using menu selections, icons, or 
keyboard shortcuts. You can also copy text from other sources such as 
Web pages and paste it into a Writer document.

To move (cut and paste) selected text using the mouse, drag it to the 
new location and release it. To copy selected text, hold down the 
Control key while dragging. The text retains the formatting it had 
before dragging.

After selecting text, you can use the mouse or the keyboard for these 
operations.

Cut: Use Edit > Cut or the keyboard shortcut Control+X or the 
Cut icon on the toolbar.

Copy: Use Edit > Copy or the keyboard shortcut Control+C or the 
Copy icon.

Paste: Use Edit > Paste or the keyboard shortcut Control+V or 
the Paste icon.

The result of a paste operation depends on the source of the text to be 
pasted. If you simply click on the Paste icon, any formatting the text 
has (such as bold or italics) is retained. Text pasted from Web sites and 
other sources may also be placed into frames or tables. If you do not 
like the results, click the Undo icon or press Control+Z.

To make the pasted text take on the formatting of the surrounding text 
where it is to be pasted, choose:

• Edit > Paste Special
• or click the triangle to the right of the Paste icon
• or click the Paste icon without releasing the left mouse button

Then select Unformatted text from the resulting menu.
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The range of choices on the Paste Special menu varies depending upon 
the origin and formatting of the text (or other object) to be pasted. See 
Figure 3 for an example with text on the clipboard.

Figure 3: Paste Special menu

This example includes the formatting option DDE link. DDE is an 
acronym for Dynamic Data Exchange, a mechanism whereby selected 
data in document A can be pasted into document B as a linked, ‘live’ 
copy of the original. It would be used, for example, in a report written 
in Writer containing time-varying data, such as sales results sourced 
from a Calc spreadsheet. The DDE link ensures that, as the source 
spreadsheet is updated so is the report, thus reducing the scope for 
error and reducing the work involved in keeping the Writer document 
up to date.

Moving paragraphs quickly
With the cursor anywhere in the paragraph:

1) Press and hold the Control+Alt keys.
2) While holding the Control+Alt keys down, press the up-arrow or 

down-arrow key.

The paragraph will move to a new location either before the previous 
paragraph or after the next paragraph in your document. To move 
more than one paragraph at a time, select at least part of all 
paragraphs (including the end of the first paragraph you want to move 
and the start of the last) before pressing the Control+Alt+arrow keys.

If you are using Solaris, the key combination is Control+AltGr+arrow 
keys.

Tip
If your paragraphs suddenly jumped from one place to another, 
the most likely reason is that you have accidentally pressed 
one of these key combinations.
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Note

In some machines the Control+Alt+arrow key combination is 
reserved for screen flipping. You have to deactivate or assign 
different key combination for screen flipping (usually through 
display / graphics adapter settings in your computer) before 
using this feature.

Finding and replacing text
When looking for certain words in a 3000-word essay, it is inefficient to 
go through every word manually. Writer has a Find and Replace 
feature that automates the process of searching for text inside a 
document.

In addition to finding and replacing words and phrases, you can:
• Use wildcards and regular expressions to fine-tune a search.
• Find and replace specific formatting.
• Find and replace paragraph styles.

To display the Find & Replace dialog box (Figure 4), use the keyboard 
shortcut Control+F or select Edit > Find & Replace.

Figure 4: The Find & Replace dialog box

1) Type the text you want to find in the Search for box.
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2) To replace the text with different text, type the new text in the 
Replace with box.

3) You can select various options, such as matching the case, 
matching whole words only, or doing a search for similar words. 
(See below for some other choices.)

4) When you have set up your search, click Find. To replace text, 
click Replace instead.

Tip
If you click Find All, Writer selects all instances of the search 
text in the document. Similarly, if you click Replace All 
button, Writer replaces all matches.

Caution
Use Replace All with caution; otherwise, you may end up with 
some hilarious (and highly embarrassing) mistakes. A mistake 
with Replace All might require a manual, word-by-word 
search to fix, if not discovered in time to undo.

Use wildcards (regular expressions)
Wildcards (also known as regular expressions) are combinations of 
characters that instruct OOo how to search for something. Regular 
expressions are very powerful but not very intuitive. They can save 
time and effort by combining multiple finds into one.

Table 1 shows a few of the regular expressions used by OOo.

Tip
The online help describes many more regular expressions and 
their uses.

Note

One of the most common mistakes when using regular 
expressions is to try to search for a character that is defined as 
a wildcard, such as brackets or dots. If you need to search for 
such a character, type a backslash (\) before it. This instructs 
OOo to treat the character following the backslash as a normal 
character. For example, to find the text $5.00 ($ and . are 
wildcard characters), you would conduct a search using \
$5\.00.

To use wildcards and regular expressions when searching and 
replacing:

1) On the Find & Replace dialog box, click More Options to see 
more choices. On this expanded dialog box (Error: Reference
source not found), select the Regular expressions option.
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2) Type the search text, including the wildcards, in the Search for 
box and the replacement text (if any) in the Replace with box. Not 
all regular expressions work as replacement characters; the line 
break (\n) is one that does work.

3) Click Find, Find All, Replace, or Replace All (not 
recommended).

Table 1. Examples of search wildcards (regular expressions)

To find Use this 
expression Examples and comments

Any single 
character

. b.d finds bad, bud, bid, and bed.

Characters at the 
beginning of a 
paragraph

^chars ^term

Characters at the 
end of a paragraph

chars$ term.$

One of the specified 
characters

[xyz] b[iu]n finds bin and bun.

Any single 
character in this 
range

[x-y] [r-t]eed finds reed, seed, and teed; 
ranges must be in alphabetically 
ascending order.

Any single 
character except 
the characters 
inside the brackets

[^x] p[^a]st finds post and pest, but not 
past.

The beginning of a 
word

\<start \<log finds logbook and logistics, but 
not catalog.

The end of a word end\> log\> finds catalog, but not logistics.

A paragraph marker $ Does not work as a replacement 
character. Use \n instead.

An empty paragraph ^$

A tab character \t

A line break \n Finds a line break that was inserted 
with Shift+Enter. When used as a 
replacement character, it inserts a 
paragraph marker.
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Find and replace specific formatting
A very powerful use of Find & Replace takes advantage of the format 
option. For example, you might want to replace underlined words with 
italics.

On the Find & Replace dialog box (with More Options displayed, as in 
Figure 4):

1) To search for text with specific formatting, enter the text in the 
Search for box. To search for specific formatting only, delete any 
text in the Search for box.

2) Click Format to display the Text Format (Search) dialog box. The 
tabs on this dialog box are similar to those on the Paragraph 
format and Paragraph Style dialog boxes. Choose the formats you 
want to search for and then click OK. The names of selected 
formats appear under the Search for box. For example, you might 
search for all text in 14-point bold Helvetica.

3) To replace text, enter the replacement text in the Replace with 
box.
To search for specific text with specific formatting (for example, 
the word hello in bold), specify the formatting, put the text in the 
Search for box and leave the Replace with box blank.
To remove specific character formatting, click Format, select the 
Font tab, then select the opposite format (for example, No Bold). 
The No Format button on the Find & Replace dialog box clears 
all previously selected formats.

4) Click Find, Find All, Replace, or Replace All.

Tip

Unless you plan to search for other text using those same 
attributes, click No Format to remove the attributes after 
completing your search. If you forget to do this, you may 
wonder why your next search fails to find words you know are 
in the document.

Find and replace paragraph styles
If you combine material from several sources, you may discover that 
lots of unwanted paragraph styles have suddenly shown up in your 
document. To quickly change all the paragraphs of one (unwanted) 
style to another (preferred) style:

1) On the expanded Find & Replace dialog box (Figure 4), select 
Search for Styles. (If you have attributes specified, this option is 

12 Working with Text



labeled Including Styles.) The Search for and Replace with boxes 
now contain a list of styles.

2) Select the styles you want to search for and replace.
3) Click Find, Find All, Replace, or Replace All.

Inserting special characters
A “special” character is one not found on a standard English keyboard. 
For example, © ¾ æ ç ñ ö ø ¢ are all special characters. To insert a 
special character:

1) Place the cursor in your document where you want the character 
to appear.

2) Click Insert > Special Character to open the Special 
Characters dialog box (Figure 5).

3) Select the characters (from any font or mixture of fonts) you wish 
to insert, in order; then click OK. The selected characters are 
shown in the lower left of the dialog box. As you select each 
character, it is shown on the lower right, along with the numerical 
code for that character.

Tip
Notice that the characters selected appear in the bottom-left 
corner of the dialog box.

Note
Different fonts include different special characters. If you do 
not find a particular special character you want, try changing 
the Font selection.

Figure 5: The Special Characters dialog box, where you can 
insert special characters.
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Inserting non-breaking spaces and hyphens

Non-breaking spaces
To prevent two words from being separated at the end of a line, press 
Control+spacebar after the first word.

Non-breaking hyphen
You can use a non-breaking hyphen in cases where you do not want the 
hyphen to appear at the end of a line, for example in a number such as 
123-4567. To insert a non-breaking hyphen, press 
Shift+Control+minus sign.

Inserting dashes
To enter en and em dashes, you can use the Replace dashes option 
under Tools > AutoCorrect > Options (Figure 14). This option 
replaces two hyphens, under certain conditions, with the 
corresponding dash.

In the following table, the A and B represent text consisting of letters A 
to z or digits 0 to 9.

Text that you type: Result
A - B (A, space, minus, space, B) A – B (A, space, en-dash, space, B)

A -- B (A, space, minus, minus, space, B) A – B (A, space, en-dash, space, B)

A--B (A, minus, minus, B) A—B (A, em-dash, B)

A-B (A, minus, B) A-B (unchanged)

A -B (A, space, minus, B) A -B (unchanged)

A --B (A, space, minus, minus, B) A –B (A, space, en-dash, B)

Another means of inserting en or em dashes is through the Insert > 
Special Characters menu. Select the U+2013 or U+2014 character, 
respectively.

A third method uses keyboard shortcuts. These shortcuts vary 
depending on your operating system.

Tip

You can also record macros to insert en and em dashes and 
assign those macros to unused key combinations, for example 
Ctrl+Shift+N and Ctrl+Shift+M. For more information, see 
Chapter 17 (Customizing Writer).
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Windows
Hold down one of the Alt keys and type on the numeric keypad: 0150 
for an en dash or 0151 for an em dash. The dash appears when you 
release the Alt key.

Tip

On a keyboard with no numeric keypad, use a Fn (Function) 
key combination to type the numbers. (The Fn key is usually to 
the right of the left-hand Ctrl key on the keyboard.) 
For example, on a US keyboard layout, the combination for an 
en dash should be Alt+Fn+mjim and for an em dash it should 
be Alt+Fn+mjij.

Linux
Hold down the Compose key and type two hyphens and a period for 
an en dash, or three hyphens for an em dash. The dash appears 
when you release the Compose key.

Tip
The key that operates as a Compose key varies with the Linux 
distribution. It is usually one of the Alt or Win keys, but may be 
another key, and should be user-selectable.

Mac OS X
Hold down the Option (Alt) key and type a hyphen for an en dash. 
For an em dash, the combination is Shift+Option+Hyphen.

Formatting paragraphs
You can apply many formats to paragraphs using the buttons on the 
Formatting toolbar. Figure 6 shows the Formatting toolbar as a floating 
toolbar, customized to show only the buttons for paragraph formatting.

Tip

It is highly recommended that you use paragraph styles rather 
than manually formatting paragraphs, especially for long or 
standardized documents. For information on the advantages of 
styles and how to use them, see Chapters 6 and 7.
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1 Open Styles and 
Formatting Window

5 Align Right 10 Numbering On/Off
6 Justified 11 Bullets On/Off

2 Apply Style 7 Line Spacing: 1 12 Decrease Indent
3 Align Left 8 Line Spacing: 1.5 13 Increase Indent
4 Centered 9 Line Spacing: 2 14 Paragraph format dialog

Figure 6: Formatting toolbar, showing icons for paragraph formatting

Figure 7 shows examples of the text alignment options.

Figure 7: Text alignment options

When using justified text, the last line is by default aligned to the left; 
however, if so desired, you can also align the last line to the center of 
the paragraph area or justify it so that spaces are inserted between the 
words in order to fill the whole line. In the case where the last line 
consists of a single word, you can also have this word stretched to 
cover the whole line. Figure 8 shows an example of the effect obtained 
when setting each of these options.

Figure 8: Four choices for the last line of a justified paragraph

These options are controlled in the Alignment page of the Format > 
Paragraph dialog box (see Figure 9).
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Figure 9: Options for the last line of a justified paragraph

Setting tab stops and indents
The default tab stops affect two things: tabs within paragraphs (as 
shown in Figure 10) and the indentation of entire paragraphs by using 
the Increase Indent button on the Formatting toolbar.

Using the default tab stops to space out material on a page is not 
recommended, for two reasons:

• If you use the default tab interval and then send the document to 
someone who has chosen a different default tab interval, tabbed 
material will change to use the other person’s settings.

• Any changes you make to the default tab stops affect existing 
default tab stops (in any document you open afterwards) as well 
as tab stops you insert after making the change.

Both cases may cause a major formatting problem, as illustrated in 
Figure 10.

Figure 10: Default tab settings might be different

To avoid these unwanted changes, do not use the default tabs. Instead, 
define your own tab stops in paragraph styles or individual paragraphs 
as described in “Defining your own tab stops and indents” on page 18.

Tip
Depending on what you are trying to accomplish a borderless 
table is often a better choice than using tabs.
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To set the measurement unit and the spacing of default tab stops, use 
Tools > Options > OpenOffice.org Writer > General. On this page, 
make any required changes in the Settings section (Figure 11) and 
click OK to save.

Figure 11: Selecting a measurement unit and 
default tab stop spacing.

You can also set or change the measurement unit of the ruler itself by 
right-clicking on the ruler to open a list of units, as shown in Figure 12. 
Click on one of them to change the ruler to that unit. This change does 
not affect the measurement unit chosen in the Options.

Figure 12: Ruler showing default tab stops

The horizontal ruler shows both the default tab stops and any that you 
have defined.

Defining your own tab stops and indents
To set your own tab stops for one or more selected paragraphs, use the 
Tabs page of the Paragraph dialog box. To reach this page, you can 
either:

• Double-click anywhere between the left and right indent icons on 
the ruler itself to open the Tabs page of the Paragraph dialog box, 
or

• Right-click on the paragraph, choose Paragraph from the pop-up 
menu, and choose the Tabs page.

Similarly, you can change the tabs defined in the paragraph style. 
Right-click on the paragraph, choose Edit Paragraph Style from the 
pop-up menu, and choose the Tabs page. See Chapter 7 (Working with 
Styles) for more information.

18 Working with Text



To change the indentation of one or more selected paragraphs, use the 
Indents & Spacing page of the Paragraph dialog box. To reach this 
page, you can either:

• Double-click on a part of the ruler that is not between the left and 
right indent icons, or 

• Right-click on the paragraph, choose Paragraph from the pop-up 
menu, and choose the Indents & Spacing page.

Similarly, you can change the indentation defined in the paragraph 
style. Right-click on the paragraph, choose Edit Paragraph Style from 
the pop-up menu, and choose the Indents & Spacing page. See Chapter 
7 (Working with Styles) for more information.

Formatting characters
You can apply many formats to characters using the buttons on the 
Formatting toolbar.  Figure 13 shows the Formatting toolbar as a 
floating toolbar, customized to show only the buttons for character 
formatting.

Tip
It is highly recommended that you use character styles rather 
than manually formatting characters. For information on styles 
and how to use them, see Chapters 6 and 7.

1 Open Styles and 
Formatting Window

6 Italic 12 Font Color
7 Underline 13 Highlighting

2 Apply Style 8 Superscript 14 Background Color
3 Font Name 9 Subscript 15 Open Character Format 

Dialog4 Font Size 10 Increase Font
5 Bold 11 Reduce Font

Figure 13: Formatting toolbar, showing icons for character formatting

Tip
To remove manual formatting, select the text and click Format 
> Default  Formatting or right-click and select Default 
Formatting from the pop-up menu.
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Autoformatting
Writer can be set to automatically format parts of a document 
according to the choices made on the Options page of the AutoCorrect 
dialog box (Tools > AutoCorrect > Options). See Figure 14.

Figure 14: Autoformat choices on the Options page of 
the AutoCorrect dialog box

The Help describes each of these choices and how to activate the 
autoformats. Some common unwanted or unexpected formatting 
changes include:

• Horizontal lines. If you type three or more hyphens (---), 
underscores (___) or equal signs (===) on a line and then press 
Enter, the paragraph is replaced by a horizontal line as wide as 
the page minus any indentation of the preceding paragraph of 
which the line is the lower border.

• Bulleted and numbered lists. A bulleted list is created when you 
type a hyphen (-), asterisk (*), or plus sign (+), followed by a 
space or tab at the beginning of a paragraph. A numbered list is 
created when you type a number followed by a period (.), followed 
by a space or tab at the beginning of a paragraph. Automatic 
numbering is only applied to paragraphs formatted with the 
Default, Text body or Text body indent paragraph styles.
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Tip
If you notice unexpected formatting changes occurring in your 
document, this is the first place to look for the cause.

To turn autoformatting on or off, go to Format > AutoFormat (Figure
15) and select or deselect the items on the submenu.

Figure 15: Turning autoformatting on or off

• While Typing automatically formats the document while you 
type.

• If While Typing is deselected, you can select Apply to 
automatically format the file.

• Apply and Edit Changes automatically formats the file and then 
opens a dialog box where you can accept or reject the changes.

Creating numbered or bulleted lists
There are several ways to create numbered or bulleted lists:

• Use autoformatting, as described above.
• Use list styles, as described in Chapter 7 (Working with Styles).
• Use the Numbering and Bullets icons on the paragraph 

formatting toolbar (see Figure 6). This last method is described 
here.

To produce a numbered or bulleted list, select the paragraphs in the 
list and then click on the appropriate icon on the toolbar.
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Note
It is a matter of personal preference whether you type your 
information first, then apply Numbering/Bullets or apply these 
as you type.

Using the Bullets and Numbering toolbar
You can create a nested list (where one or more list items has a sublist 
under it, as in an outline) by using the buttons on the Bullets and 
Numbering toolbar (Figure 16). You can move items up or down the 
list, create subpoints, and even change the style of bullets.

1 Bullets On/Off 7 Move Down (One Level) 
with Sub-points

12 Move Down in Sub-points
2 Numbering On/Off
3 Numbering Off 8 Insert Unnumbered Entry 13 Restart Numbering
4 Up One Level 9 Move Up 14 Bullets and Numbering
5 Down One Level 10 Move Down
6 Move Up (One Level) 

with Sub-points
11 Move Up in Sub-points

Figure 16: Bullets and Numbering toolbar

Tip
It is possible to move a list entry up, together with all of its 
sub-entries. Do this by clicking the Promote One Level With 
Subpoints button.

If you create a nested list using the predefined styles, all the levels of 
the list (up to 10) apply the same numbering (or bullet), however in 
many circumstances you will want to use a combination of numbering 
formats and bullets when creating nested lists. Such lists with a 
mixture of numbering formats and bullets can be easily configured as 
described in the following example. Additional information on lists and 
in particular the technique to create your own list style is described in 
Chapter 7 (Working with Styles).
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Tip

When creating nested lists one option is to enter all the list 
paragraphs first and apply the levels afterwards.
You can use keyboard shortcuts to move paragraphs up or 
down the outline levels. Place the cursor at the beginning of 
the numbered paragraph and press:
Tab Down a level
Shift+Tab Up a level
To insert a tab stop at the beginning of a numbered paragraph 
(that is, after the number but before the text), press 
Control+Tab.

Example: configuring a nested list
We will use a numbering style to produce the following effect:
  I.  Level-1 list item

      A. Level-2 list item

           i. Level-3 list item

              a) Level-4 list item

This example uses one of the supplied styles, Numbering 1, however if 
you intend to reuse this type of nested list you can also create a new 
style as illustrated in Chapter 7 (Working with Styles).

1) Create the first item and apply the Numbering 1 style from the 
Styles and Formatting window.

2) Select Format > Bullets and Numbering to open the dialog 
that controls the appearance of the list.

3) Go to the Outline page (Figure 17), where you will find that one 
style matches our requirements. Click once on that style.

4) To modify the layout of the list, use the Options tab (Figures 18 
and 19). Notice that the preview on the right shows the outline 
selected. In the Level box on the left, select 1, then 2, 3, and 4 
and see how the information in the Numbering and After boxes 
changes.
Use the Options page to set different punctuation; for example, a 
period (full stop) after “a” on level 4 instead of a parenthesis.

To make the indentation at each level greater or less than the 
default, change it on the Position page. Select the level, then 
make any changes in the indentation, spacing, or numbering 
alignment.

5) Repeat for each level as required, then click OK.
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Figure 17: Choosing a predefined outline-numbering style

Figure 18: Checking the outline numbering for level-1 list items

Figure 19: Numbering style for level-2 list items
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Tip

With outline numbering you can define different bullet styles 
for the different levels of a bullet list. Use the Bullets tab of the 
Bullets and Numbering dialog box (not shown) to select the 
basic style. Return to the Options tab to customize the bullet 
for each indent level. Here you can set bullets to any 
character. See the Graphics tab for more bullets.

Using footnotes and endnotes
Footnotes appear at the bottom of the page on which they are 
referenced. Endnotes are collected at the end of a document.

To work effectively with footnotes and endnotes, you need to:
• Insert footnotes.
• Define the format of footnotes.
• Define the location of footnotes on the page; see the discussion of 

page styles in Chapter 7 (Working with Styles).

Inserting footnotes/endnotes
To insert a footnote or an endnote, put the cursor where you want the 
footnote/endnote marker to appear. Then select Insert > Footnote 
from the menu bar or click the Insert Footnote Directly or Insert 
Endnote Directly icon on the Insert toolbar (see Figure 20).

Figure 20: Using the Insert Footnote Directly icon on the toolbar

A footnote (or endnote) marker is inserted in the text, and the cursor is 
relocated to the footnote area at the bottom of the page (or to the 
endnote area at the end of the document). Type the footnote or 
endnote content in this area.

If you use Insert > Footnote, the Insert Footnote dialog box (Figure
21) is displayed. Here you can choose whether to use the automatic 
numbering sequence specified in the footnote settings and whether to 
insert the item as a footnote or an endnote.
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Figure 21: Inserting a footnote directly

If you use the Insert Footnote Directly or Insert Endnote Directly 
icon, the footnote or endnote automatically takes on the attributes 
previously defined in the Footnote Settings dialog box (Figure 22).

You can edit an existing footnote or endnote the same way you edit any 
other text.

To delete a footnote or endnote, delete the footnote marker. The 
contents of the footnote or endnote are deleted automatically, and the 
numbering of other footnotes or endnotes is adjusted automatically.

Defining the format of footnotes/endnotes
To format the footnotes themselves, click Tools > Footnotes. On the 
Footnote Settings dialog box (Figure 22), choose settings as required. 
The Endnotes page has similar choices.

Figure 22: Defining footnote formatting
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To define the characteristics of the character styles Footnote anchor, 
Footnote characters, and so on, see Chapter 7 (Working with Styles).

Checking spelling
Writer provides a spelling checker, which can be used in two ways.

AutoSpellcheck checks each word as it is typed and displays a 
wavy red line under any misspelled words. Once the word is 
corrected, the red wavy line disappears.

To perform a separate spelling check on the document (or a text 
selection) click the Spelling and Grammar button. This checks 
the document or selection and opens the Spelling dialog box 
(Figure 23) if any misspelled words are found.

Figure 23: The Spelling dialog box

Here are some more features of the spelling checker:
• You can right-click on a word with a wavy underline, to open a 

powerful context menu. If you select from the suggested words on 
the menu, the selection will replace the misspelled word in your 
text. Other menu options are discussed below.

• You can change the dictionary language (for example, Spanish, 
French, or German) on the Spelling dialog box.

• You can add a word to a dictionary. Click Add in the Spelling 
dialog box and pick the dictionary to add it to.
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• The Options dialog box of the Spelling tool has a number of 
different options such as whether to check uppercase words and 
words with numbers. Here you can also manage custom 
dictionaries, that is, add or delete dictionaries and add or delete 
words in a dictionary.

Using language tools
OOo provides some tools that make your work easier if you mix 
multiple languages within the same document or write documents in 
various languages.
You can set the language for the whole document, individual 
paragraphs, or even individual words and characters. In versions 
earlier than OOo 3.0 it was necessary to use styles in order to insert 
within a document paragraphs or individual groups of characters that 
use a different language, while now this can be conveniently done from 
the main menu.

Tip

Using character and paragraph styles is still the preferred 
method, as styles allow a greater level of control and make 
changing language much faster. See Chapter 7 (Working with 
Styles) for information on how to manage the language 
settings of a style.

The main advantage of changing the language is that you can then use 
the correct dictionaries to check spelling and apply the localized 
versions of Autocorrect replacement tables, thesaurus, and 
hyphenation rules.
The language tools can be found in Tools > Languages on the main 
menu, as shown in Figure 24.

Figure 24: The Language menu 
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The following options are available:
• For selection: select this option to apply a specified language to 

the selected text (the selection can comprise only a few 
characters or several paragraphs).

• For paragraph: select this option to apply the specified language 
to the paragraph where the cursor is located.

• For all text: select this option to apply the specified language to 
all the document.

An alternative way to the menu above that allows you to change the 
language of a whole document is the use of Tools > Options > 
Language Settings > Languages. In the Default languages for 
documents section of the options dialog (Figure 25) you can choose a 
different language for all the text.

Caution

Unlike the menu tool that applies to the individual document, 
a change in the default language from the Options dialog is 
a general change of settings of OOo and will therefore apply 
to all the documents created in the future. If you want to 
change the language for the current document only, be sure 
to select the For the current document only option.

Spelling checking is available only for those languages in the list which 
have the symbol  next to them. If you do not see the symbol next to 
your preferred language, you can install the additional dictionary using 
Tools > Languages > More dictionaries online.

Figure 25: Options available in the Languages settings

The language used for checking spelling is also shown in the status 
bar, next to the page style in use.

You can also configure the language for a paragraph or a group of 
characters as None. This option is particularly useful in the case 
where you insert in the document text that you do not want to 
spellcheck, such as web addresses or programming language snippets.
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Using the thesaurus
The thesaurus offers alternative words and phrases. Select the word or 
phrase you want to find alternatives for and select Tools > Language 
> Thesaurus or press Control+F7. Click on a meaning to show 
alternative words and phrases for that meaning of the word. For 
example, when given the word “house”, the thesaurus offers several 
meanings, including “dwelling”, “legislature”, and “sign of the zodiac”. 
If you click on “dwelling”, you will see “dwelling”, “home”, “domicile”, 
“abode”, and other alternatives, as shown in Figure 26.

Note
If the current language does not have a thesaurus installed, 
this feature is disabled.

Figure 26: The thesaurus offers alternatives to words

Hyphenating words
To turn automatic hyphenation of words on or off:

1) Press F11 to open the Styles and Formatting window (Figure 27).

Figure 27: Modifying a style

30 Working with Text



2) On the Paragraph Styles page of the Styles and Formatting 
window, right-click on Default and select Modify.

3) On the Paragraph Style dialog box, select the Text Flow tab 
(Figure 28).

4) Under Hyphenation, select or deselect the Automatically option.
5) Click OK to save.

Figure 28: Turning on automatic hyphenation

Note

Turning on hyphenation for the Default paragraph style affects 
all other paragraph styles that are based on Default. You can 
individually change other styles so that hyphenation is not 
active; for example, you might not want headings to be 
hyphenated. Any styles that are not based on Default are not 
affected. For more on paragraph styles, see Chapter 6 
(Introduction to Styles) and Chapter 7 (Working with Styles).

You can also set hyphenation choices through Tools > Options > 
Language Settings > Writing Aids. In Options, near the bottom of 
the dialog box, scroll down to find the hyphenation settings (see 
Figure 29).

Figure 29: Setting hyphenation options

To change the minimal number of characters for hyphenation, the 
minimum number of characters before a line break, or the minimum 
number of characters after a line break, select the item, and then click 
Edit.
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Hyphenate without inquiry specifies that you will never be asked to 
manually hyphenate words that the hyphenation dictionary does not 
recognize. If this box is not selected, when a word is not recognized, a 
dialog box will open where you can manually enter hyphens.

Hyphenate special regions specifies that hyphenation will also be 
carried out in footnotes, headers, and footers.

Note

Hyphenation options set on the Writing Aids dialog box are 
effective only if hyphenation is turned on through paragraph 
styles.
Choices on the Writing Aids dialog box for “characters before 
line break” and “characters after line break” override settings 
in paragraph styles for “characters at line end” and 
“characters at line begin”.

To enter a conditional hyphen inside a word, press Control+minus 
sign. The word is hyphenated at this position when it is at the end of 
the line, even if automatic hyphenation for this paragraph is switched 
off.

Using AutoCorrect
Writer’s AutoCorrect function has a long list of common misspellings 
and typing errors, which it corrects automatically. For example, “hte” 
will be changed to “the”. Select Tools > AutoCorrect to open the 
AutoCorrect dialog box. There you can define what strings of text are 
corrected and how. In most cases, the defaults are fine.

Tip
AutoCorrect is automatically turned on. To turn it off, uncheck 
Format > AutoFormat > While Typing.

• To stop Writer replacing a specific spelling, use Tools > 
AutoCorrect > Replace, highlight the word pair and click 
Delete.

• To add a new spelling to correct, type it into the Replace and With 
boxes and click New.

• See the different pages of the dialog box for the wide variety of 
other options available to fine-tune AutoCorrect.

Tip
AutoCorrect can be used as a quick way to insert special 
characters. For example, (c) will be autocorrected to ©. You 
can add your own special characters.
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Using word completion
If Word Completion is enabled, Writer tries to guess which word you 
are typing and offers to complete this word for you. To accept the 
suggestion, press Enter. Otherwise, continue typing.

Tip
Many people prefer not to use Word Completion. If you do not 
want to use it, select Tools > AutoCorrect > Word 
Completion and deselect Enable word completion.

You can customize word completion from the Tools > AutoCorrect > 
Word Completion page (Figure 30).

Figure 30: Customizing word completion

• Add (append) a space automatically after an accepted word.
• Show the suggested word as a tip (hovering over the word) rather 

than completing the text as you type.
• Change the maximum number of words remembered for word 

completion and the length of the smallest words to be 
remembered.

• Delete specific entries from the word completion list.
• Change the key that accepts a suggested entry—the options are 

right arrow, End key, Return (Enter), Space bar, and Tab.
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Note
Automatic word completion only occurs after you type a word 
for the second time in a document.

Using AutoText
AutoText allows you to assign text, tables, graphics, and other items to 
a key combination. For example, rather than typing “Senior 
Management”, you just have to type “sm” and press F3. Or you can 
save a formatted Tip (like the one on this page) as AutoText and then 
insert a copy by typing “tip” and pressing F3.

To assign some text to an AutoText shortcut:
1) Type the text into your document.
2) Select the text.
3) Go to Edit > AutoText (or press Control+F3).
4) Enter a name for your shortcut. Writer will suggest a one-letter 

shortcut, which you can change.
5) Click the AutoText button on the right of the AutoText dialog box 

and select New (text only) from the menu.
6) Click Close to return to your document.

To insert AutoText, type the shortcut and press F3.

Tip
If the only option under the AutoText button is Import, either 
you have not entered a name for your AutoText or there is no 
text selected in the document.

AutoText is especially powerful when assigned to fields. See Chapter 
14 (Working with Fields) for more information.

Line numbering
Line numbering puts line numbers in the margin. The line numbers are 
displayed on screen and are printed. Figure 31 shows an example with 
numbering on every line.

Click Tools > Line Numbering and select the Show numbering 
option in the top left corner. Then click OK.
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Figure 31: Line numbering example

You can choose how many lines are numbered (for example, every line 
or every tenth line), the numbering type and whether numbers restart 
on each page. In addition, a text separator (any text you choose) can be 
set on a different numbering scheme (one every 12 lines, for example).

Figure 32: The Line Numbering dialog box

Undoing and redoing changes
To undo the most recent change, press Control+Z, click the Undo icon 

 on the Standard toolbar, or select Edit > Undo from the menu bar.

The Edit menu shows the latest change that can be undone.

Figure 33: Edit > Undo last action
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Click the small triangle to the right of the Undo icon to get a list of all 
the changes that can be undone (Figure 34). You can select multiple 
changes and undo them at the same time.

Figure 34: List of actions that can be undone

After changes have been undone, Redo becomes active. To redo a 
change, select Edit > Redo, or press Control+Y or click on the Redo 

icon . As with Undo, click on the triangle to the right of the arrow to 
get a list of the changes that can be reapplied.

To modify the number of changes OpenOffice.org remembers, select 
Tools > Options > OpenOffice.org > Memory and change Undo: 
Number of steps. Be aware that asking OOo to remember more 
changes makes it consume more memory.

Tracking changes to a document
You can use several methods to keep track of changes made to a 
document.

• Make your changes to a copy of the document (stored in a 
different folder, under a different name, or both), then use Writer 
to combine the two files and show the changes you made. Click 
Edit > Compare Document. This technique is particularly 
useful if you are the only person working on the document, as it 
avoids the increase in file size and complexity caused by the other 
methods.

• Save versions that are stored as part of the original file. However, 
this method can cause problems with documents of nontrivial size 
or complexity, especially if you save a lot of versions. Avoid this 
method if you can.

• Use Writer’s change marks (often called “redlines” or “revision 
marks”) to show where you have added or deleted material or 
changed formatting. Later, you or another person can review and 
accept or reject each change.
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Tip
Not all changes are recorded. For example, changing a tab 
stop from align left to align right and changes in formulas 
(equations) or linked graphics are not recorded.

Preparing a document for review
When you send a document to someone else to review or edit, you may 
want to prepare it first so that the editor or reviewer does not have to 
remember to turn on the revision marks. After you have protected the 
document, any user must enter the correct password in order to turn 
off the function or accept or reject changes.

1) Open the document. To check whether it contains multiple 
versions, click File > Versions. If multiple versions are listed, 
save the current version as a separate document with a different 
name and use this new document as the review copy.

2) With the review copy open, make sure that change recording is 
turned on. The Edit > Changes > Record menu item has a 
check mark next to it when recording is turned on.

3) Click Edit > Changes > Protect Records. On the Enter 
Password dialog box, type a password (twice) and click OK.

Note
Passwords must contain at least five characters. It is not 
necessary to password protect the document while preparing it 
for review.

Recording changes
See Chapter 2 (Setting up Writer) for instructions on setting up how 
your changes will be displayed.

1) To begin tracking (recording) changes, click Edit > Changes > 
Record. To show or hide the display of changes, click Edit > 
Changes > Show.

Tip

Hold the mouse pointer over a marked change; you will see a 
Help Tip showing the type of change, the author, date, and 
time of day for the change. If Extended Tips are enabled, you 
will also see any comments recorded for this change.

2) To enter a comment on a marked change, place the cursor in the 
area of the change and then click Edit > Changes > Comment. 
(See Figure 35.) In addition to being displayed as an extended tip, 
the comment is also displayed in the list in the Accept or Reject 
Changes dialog box.
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Figure 35: Inserting a comment during 
change recording

To move from one marked change to the next, use the arrow 
buttons. If no comment has been recorded for a change, the Text 
field is blank.

Tip
See also “Inserting notes” on page 40 for a way to annotate 
text that is not associated with a recorded change.

3) To stop recording changes, click Edit > Changes > Record 
again.

Accepting or rejecting changes and comments
1) Click Edit > Changes > Accept or Reject. The Accept or Reject 

Changes dialog box (Figure 36) opens.
2) When you select a change in the dialog box, the actual change is 

highlighted in the document, so you can see what the editor 
changed.

3) Click Accept or Reject to accept or reject the selected change. 
You can also click Accept All or Reject All if you do not want to 
review the changes individually.

Changes that have not yet been accepted or rejected are displayed in 
the list. Accepted changes are removed from the list and appear in the 
text without any marking.
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Figure 36: The List tab of the Accept or Reject Changes dialog box

To show only the changes of certain people or only the changes on 
specific days or various other restrictions, use the Filter page (Figure
37) on the Accept or Reject Changes dialog box. After specifying the 
filter criteria, return to the List page to see those changes that meet 
your criteria.

Figure 37: The Filter page of the Accept or Reject Changes dialog box
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Merging modified documents
The processes discussed to this point are effective when you have one 
reviewer at a time. Sometimes, however, multiple reviewers all return 
edited versions of a document at the same time. In this case, it may be 
quicker to review all of these changes at once, rather than one review 
at a time. For this purpose, you can merge documents in Writer.

To merge documents, all of the edited documents need to have 
recorded changes in them.

1) Open one copy.
2) Click Edit > Changes > Merge Document and select and insert 

another copy of the document to be merged with the first.
3) After the documents merge, the Accept or Reject Changes dialog 

box opens, as in Figure 36, showing changes by more than one 
reviewer. If you want to merge more documents, close the dialog 
box and then repeat step 2.

4) Repeat until all copies are merged.

All recorded changes are now included in the open copy. Save this file 
under another name.

Comparing documents
Sometimes reviewers may forget to record the changes they make. 
This is not a problem with Writer because you can find the changes if 
you compare documents.

In order to compare documents, you need to have the original 
document and the one that is edited. To compare them:

1) Open the edited document. Select Edit > Compare Document.
2) The Insert dialog box appears. Select the original document and 

click Insert.

Writer finds and marks the changes and displays the Accept or Reject 
Changes dialog box. From this point, you can go through and accept or 
reject changes procedure as described earlier.

Inserting notes
During the review process you may want to insert annotations in the 
text either for your own benefit or for the benefit of the other 
reviewers. The use of notes in a Writer document has been vastly 
improved in OOo3. Unlike the previous versions where notes were 
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identified by small yellow marks and somewhat difficult to read, notes 
are now displayed at the side of the page and color-coded according to 
the user who created them.

To insert a note in the text, place the cursor in the place the note 
refers to and select Insert > Note or press Ctrl + Alt + N. The anchor 
point of the note is connected by a dotted line to a box on the right-
hand side of the page where you can type the text of the note. OOo 
automatically adds at the bottom the author of the note as well as a 
time stamp indicating when the note was created. Figure 38 shows an 
example of text with notes from two different authors.

Figure 38: Notes in OOo 3

Select Tools > Options > User Data to configure the name you want 
to appear in the Author field of the note, or to change it.

If more than one person edits the document, each author is 
automatically allocated a different background color.

Right-clicking on the note pops up a menu where you can delete the 
current note, all the notes from the same author, or all the notes in the 
document. From this menu, you can also apply some basic formatting 
to the notes text. You can also change font type, size, and alignment 
from the main menu.

To navigate from one note to the other, open the Navigator (F5), 
expand the Notes section, and click on the note text to move the cursor 
to the anchor point of the note in the document. Right-click on the note 
to quickly edit or delete it.
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You can also navigate the notes using the keyboard. Use 
Ctrl+Alt+Page Down to move to the next note and Ctrl+Alt+Page Up 
to move to the previous note.

Linking to another part of a document
If you type in references to other parts of the document, those 
references can easily get out of date if you reorganize the order of 
topics, add or remove material, or reword a heading, OOo provides 
three ways to ensure that your references are up to date, by inserting 
links to other parts of the same document or to a different document.

• Hyperlinks
• Cross-references
• Bookmarks

The first two methods have the same result if you Control+click the 
link when the document is open in OOo: you are taken directly to the 
cross-referenced item. However, they also have two major differences: 

• The text in a hyperlink does not automatically update if you 
change the text of the linked item (although you can change it 
manually), but changed text does automatically update in a cross-
reference.

• When using a hyperlink, you do not have a choice of the content 
of the link (for example text or page number), but when using a 
cross-reference, you do have several choices, including 
bookmarks.

Using hyperlinks
To insert a cross-reference as a hyperlink in your document, use the 
Navigator:

1) Open the documents containing the items you want to cross-
reference.

2) Open the Navigator (by clicking its icon, choosing Edit > 
Navigator, or pressing F5.

3) Click the arrow next to the Drag Mode icon  and select 
Insert as Hyperlink.

4) In the list at the bottom of the Navigator, select the document 
containing the item that you want to cross-reference.

5) In the Navigator list, select the item that you want to insert as a 
hyperlink.
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6) Drag the item to where you want to insert the hyperlink in the 
document. The name of the item is inserted in the document as an 
active hyperlink.

Using cross-references
To ensure that references update if you reword a heading, caption, or 
other linked item, use automatic cross-references. See “Using 
automatic cross-references” in Chapter 14 (Working with Fields) for 
details.

Using bookmarks
Bookmarks are listed in the Navigator and can be accessed directly 
from there with a single mouse click. In HTML documents, bookmarks 
are converted to anchors that you can jump to by hyperlink. For more 
about bookmarks, see “Using bookmarks” in Chapter 14 (Working with 
Fields).

Working with hyperlinks
When you type text (such as a website address or URL) that can be 
used as a hyperlink, and then type a space, OOo formats the URL 
automatically, creating the hyperlink and applying to the text a color 
and underlining. If this does not happen, you can enable this feature 
using Tools > AutoCorrect > Options and selecting the URL 
Recognition option.

Tip

If you do not want OOo to convert a specific URL to a hyperlink, 
select Edit > Undo Insert from the menu bar or press 
Control+Z immediately after the formatting has been applied.
To change the color of hyperlinks, go to Tools > Options > 
OpenOffice.org > Appearance, scroll to Unvisited links and/or 
Visited links, select those options, pick the new colors and click 
OK. Caution: this will change the color for all hyperlinks in all 
components of OpenOffice.org—this may not be what you want.
In Writer and Calc, you can also change the Internet link 
character style or define and apply new styles to selected links.

Inserting hyperlinks
You can also insert and modify links using the Hyperlink dialog (Figure

39). To display the dialog, click the Hyperlink icon  on the Standard 
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toolbar or select Insert > Hyperlink from the menu bar. To turn 
existing text into a link, highlight it before opening the Hyperlink 
dialog.

Figure 39. Hyperlink dialog showing details for Internet links

On the left hand side, select one of the four types of hyperlink:
• Internet: a web address, normally starting with http://
• Mail & News: for example an email address.
• Document: the hyperlink points to another document or to 

another place in the presentation.
• New document: the hyperlink creates a new document. 

The top right part of the dialog changes according to the choice made 
for the hyperlink type. A full description of all the choices, and their 
interactions, is beyond the scope of this chapter. Here is a summary of 
the most common choices used in presentations.

For an Internet type hyperlink, choose the type of hyperlink (choose 
between Web, FTP or Telnet), and enter the required web address 
(URL).

For a Mail and News type hyperlink, specify whether it is a mail or 
news link, the receiver address and for email, also the subject.

For a Document type hyperlink, specify the document path (the Open 
File button opens a file browser); leave this blank if you want to link to 
a target in the same presentation. Optionally specify the target in the 
document (for example a specific slide). Click on the Target icon to 
open the Navigator where you can select the target, or if you know the 
name of the target, you can type it into the box.
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For a New Document type hyperlink, specify whether to edit the newly 
created document immediately or just create it (Edit later) and the 
type of document to create (text, spreadsheet, etc.). For a presentation, 
Edit now is the more likely choice. The Select path button opens a 
directory picker.

The Further settings section in the bottom right part of the dialog is 
common to all the hyperlink types, although some choices are more 
relevant to some types of links.

• Set the value of Frame to determine how the hyperlink will open. 
This applies to documents that open in a Web browser.

• Form specifies if the link is to be presented as text or as a button.
• Text specifies the text that will be visible to the user.
• Name is applicable to HTML documents. It specifies text that will 

be added as a NAME attribute in the HTML code behind the 
hyperlink.

• Event button: this button will be activated to allow OOo to react 
to events for which the user has written some code (macro). This 
function is not covered in this book.

Editing hyperlinks
To edit a hyperlink, you can either click anywhere in the link text, or 
position the cursor in the link text using the arrow keys, and then open 
the Hyperlink dialog by clicking the Hyperlink icon on the Standard 
toolbar or selecting Edit > Hyperlink from the menu bar.

To activate a hyperlink, that is, to open the URL in your default 
browser, it is necessary to hold down the Control key while clicking on 
the link. A tooltip is displayed reminding you to press the Control key 
when the mouse pointer hovers over the hyperlink text.

Tip

If you need to edit several hyperlinks, you can leave the 
Hyperlink dialog open until you have edited all of them. Be 
sure to click Apply after each one. When you are finished, 
click Close.
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Switching between insert and overwrite 
mode
With the keyboard, press Insert to toggle between overwrite mode and 
insert mode. In insert mode, any text after the cursor position moves 
forward to make room for the text you type; in overwrite mode, text 
after the cursor position is replaced by the text you type. The current 
mode is displayed on the Status Bar.

With the mouse, click in the area on the Status Bar that indicates the 
current mode in order to switch to the other mode.

Counting the words in a selection
Select a block of text and choose Tools > Word Count. OOo displays 
the number of words and characters in the selection as well as the 
number of words in the document. You can also see the number of 
words and characters (and other information) in the entire document 
in File > Properties > Statistics.

Tip

If you are writing a document which needs to contain a fixed 
number of words, you may want to insert in the header or 
footer of the document a word count field so that you can 
quickly check where you are.
To do that, move the cursor into the header or footer, then 
select Insert > Field > Other. In the dialog box that opens, 
go to the Document page and select Statistics as the Type, 
Words in the Select list, and Arabic (1 2 3) as the Format, 
then click Insert.
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