Getting Started Guide

Chapter 4
Getting Started with Writer

Word Processing with OpenOffice.org
Copyright

This document is Copyright © 2005–2008 by its contributors as listed in the section titled Authors. You may distribute it and/or modify it under the terms of either the GNU General Public License, version 3 or later, or the Creative Commons Attribution License, version 3.0 or later.

All trademarks within this guide belong to their legitimate owners.

Authors

Agnes Belzunce   Daniel Carrera
Spencer E. Harpe Peter Hillier-Brook
Peter Kupfer     Gary Schnabl
Janet Swisher    Jean Hollis Weber
Linda Worthington Michele Zarri

Feedback

Please direct any comments or suggestions about this document to: authors@user-faq.openoffice.org

Publication date and software version

Published 13 October 2008. Based on OpenOffice.org 3.0.
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copyright</td>
<td>2</td>
</tr>
<tr>
<td>What is Writer?</td>
<td>5</td>
</tr>
<tr>
<td>The Writer interface</td>
<td>5</td>
</tr>
<tr>
<td>Status bar</td>
<td>6</td>
</tr>
<tr>
<td>Document views</td>
<td>7</td>
</tr>
<tr>
<td>Moving quickly through a document</td>
<td>8</td>
</tr>
<tr>
<td>Working with documents</td>
<td>9</td>
</tr>
<tr>
<td>Saving as a Microsoft Word file</td>
<td>9</td>
</tr>
<tr>
<td>Working with text</td>
<td>10</td>
</tr>
<tr>
<td>Selecting items that are not consecutive</td>
<td>10</td>
</tr>
<tr>
<td>Selecting a vertical block of text</td>
<td>11</td>
</tr>
<tr>
<td>Cutting, copying, and pasting text</td>
<td>12</td>
</tr>
<tr>
<td>Finding and replacing text and formatting</td>
<td>12</td>
</tr>
<tr>
<td>Inserting special characters</td>
<td>14</td>
</tr>
<tr>
<td>Setting tab stops and indents</td>
<td>14</td>
</tr>
<tr>
<td>Checking spelling</td>
<td>15</td>
</tr>
<tr>
<td>Using language tools</td>
<td>16</td>
</tr>
<tr>
<td>Using AutoCorrect</td>
<td>18</td>
</tr>
<tr>
<td>Using word completion</td>
<td>18</td>
</tr>
<tr>
<td>Using AutoText</td>
<td>19</td>
</tr>
<tr>
<td>Inserting dashes and non-breaking spaces</td>
<td>20</td>
</tr>
<tr>
<td>Formatting text</td>
<td>20</td>
</tr>
<tr>
<td>Using styles</td>
<td>20</td>
</tr>
<tr>
<td>Formatting paragraphs</td>
<td>20</td>
</tr>
<tr>
<td>Formatting characters</td>
<td>21</td>
</tr>
<tr>
<td>Autoformatting</td>
<td>22</td>
</tr>
<tr>
<td>Creating numbered or bulleted lists</td>
<td>23</td>
</tr>
<tr>
<td>Hyphenating words</td>
<td>24</td>
</tr>
<tr>
<td>Undoing and redoing changes</td>
<td>25</td>
</tr>
<tr>
<td>Formatting pages</td>
<td>26</td>
</tr>
</tbody>
</table>
Which layout method to choose..........................................................26
Creating headers and footers..........................................................28
Numbering pages.............................................................................29
Changing page margins...................................................................30
Adding notes to a document.............................................................31
Creating a table of contents.............................................................33
Creating indexes and bibliographies................................................34
Working with graphics......................................................................34
Printing from Writer........................................................................34
  Quick printing..................................................................................34
  Controlling printing.........................................................................35
Selecting print options for a document.............................................36
Printing in black and white on a color printer..................................37
Previewing pages before printing.....................................................37
Printing a brochure.........................................................................38
Printing envelopes..........................................................................39
Printing labels..................................................................................41
Sending a fax using Writer...............................................................43
  Sending a fax through the Print dialog............................................43
  Adding a Fax icon to the toolbar....................................................43
Tracking changes to a document......................................................44
Using mail merge..............................................................................44
Using master documents..................................................................45
Creating fill-in forms........................................................................45
Using fields.......................................................................................45
Using cross-references....................................................................46
Using bookmarks.............................................................................47
What is Writer?

Writer is the word processor component of OpenOffice.org (OOo). In addition to the usual features of a word processor (spell checking, thesaurus, hyphenation, autocorrect, find and replace, automatic generation of tables of contents and indexes, mail merge and others), Writer provides these important features:

- Templates and styles (see Chapter 3)
- Powerful page layout methods, including frames, columns, and tables
- Embedding or linking of graphics, spreadsheets, and other objects
- Built-in drawing tools
- Master documents—to group a collection of documents into a single document
- Change tracking during revisions
- Database integration, including a bibliography database
- Export to PDF, including bookmarks (see Chapter 10)
- And many more

These features are covered in detail in the *Writer Guide*.

The Writer interface

The main Writer workspace is shown in Figure 1. The menus and toolbars are described in Chapter 1 (Introducing OpenOffice.org).

Some other features of the Writer interface are covered in this chapter.

![Figure 1: The main Writer workspace in Print Layout view](image)
Status bar

The Writer status bar provides information about the document and convenient ways to quickly change some document features. From left to right, the fields are as follows.

Page number
Shows the current page number, the sequence number of the current page (if different), and the total number of pages in the document. For example, if you restarted page numbering at 1 on the third page, its page number is 1 and its sequence number is 3.
To jump to the location of a bookmark, right-click on this field. A list of bookmarks pops up; click on the required one.
To jump to a specific page in the document, double-click in this field. The Navigator opens. Click in the Page Number field and type the required page number.

Page style
Shows the style of the current page. To change the page style, right-click on this field. A list of page styles pops up; choose a different style by clicking on it.
To edit the page style, double-click on this field. The Page Style dialog opens.

Language
Shows the language for the selected text.
Click to open a menu where you can choose another language for the selected text or for the paragraph where the cursor is located. You can also choose None to exclude the text from spellchecking or choose More... to open the Character dialog.

Insert mode
Click to toggle between Insert and Overwrite modes when typing.

Selection mode
Click to toggle between STD (Standard), EXT (Extend), ADD (Add) and BLK (Block) selection. EXT is an alternative to Shift+click when selecting text. See “Working with text” on page 10 for more information about ADD and BLK.

Digital signature
If the document has been digitally signed, an icon shows in this part of the Status bar. You can double-click the icon to view the certificate.
Section or object information
When the cursor is on a section or object (such as a picture), information about that item appears in this field. For details, consult the Help or the Writer Guide.

View layout
Click the appropriate icon to change between single page, side-by-side, and book layout views (Figure 2). You can edit the document in any view.

![Figure 2: View layouts: single, side-by-side, book.](image)

Zoom
To change the view magnification, drag the Zoom slider or click on the + and – signs or click on the slider itself. You can also right-click on the zoom level percentage to select a magnification value. Zoom interacts with the selected view layout to determine how many pages are visible in the document window.

Document views
Writer has several ways to view a document: Print Layout, Web Layout, and Full Screen. To access these and other choices, go to the View menu and click on the required view. (When in Full Screen view, press the Esc key to return to either Print or Web Layout view.)
When in Web Layout, you can use the Zoom slider on the Status bar, as described above. In Print Layout, you can use both the Zoom slider and the View Layout icons on the Status bar.

![Zoom & View Layout dialog](image)

**Figure 3: Choosing Zoom and View Layout options.**

You can also choose View > Zoom from the menu bar to display the Zoom & View Layout dialog (see Figure 3), where you can set the same options as on the Status bar. In Web Layout view, most of the choices are not available.

**Moving quickly through a document**

In addition to the navigation features of the Status bar (described above), you can use the main Navigator window and the Navigation toolbar as described in Chapter 1 (Introducing OpenOffice.org).

In Writer, you can also display the Navigation toolbar by clicking on the small Navigation icon near the lower right-hand corner of the window below the vertical scroll bar, as shown in Figure 4.

![Navigation toolbar](image)

**Figure 4: Navigation icons.**

The Navigation toolbar (Figure 5) shows icons for all the object types shown in the Navigator, plus some extras (for example, the results of a Find command).
Click an icon to select that object type. Now all the **Previous** and **Next** icons (in the Navigator itself, in the Navigation Toolbar, and on the scroll bar) will jump to the next object of the selected type. This is particularly helpful for finding items like index entries, which can be difficult to see in the text. The names of the icons (shown in the tooltips) change to match the selected category; for example, **Next Graphic**, **Next Bookmark**, or **Continue search forward**.

For more uses of the Navigator in Writer, see the *Writer Guide*.

**Working with documents**

Chapter 1 (Introducing OpenOffice.org) includes instructions on starting new documents, opening existing documents, and saving documents. Chapter 3 (Using Styles and Templates) covers how to create a document from a template.

**Saving as a Microsoft Word file**

To save a document as a Microsoft Word file:

1) First save your document in OOo’s format (.odt). If you do not, any changes you made since the last time you saved will appear only in the Microsoft Word version of the document.

2) Then click **File > Save As**. The Save As window (Figure 6) appears.

3) In the **Save as type** drop-down menu, select the type of Word format you need.

4) Click **Save**.

From this point on, *all changes you make to the document will occur only in the Microsoft Word document*. You have actually changed the name of your document. If you want to go back to working with the OOo version of your document, you must open it again.
To have OOo save documents by default in the Microsoft Word file format, go to **Tools > Options > Load/Save**. See “Choosing options for loading and saving documents” in Chapter 2 (Setting up OpenOffice.org).

![Figure 6. Saving a file in Microsoft Word format](image)

### Working with text

Working with text (selecting, copying, pasting, moving) in Writer is similar to working with text in any other program. OOo also has some convenient ways to select items that are not next to each other, select a vertical block of text, and paste unformatted text.

### Selecting items that are not consecutive

To select nonconsecutive items (as shown in Figure 7) using the mouse:

1. Select the first piece of text.
2. Hold down the *Control* key and use the mouse to select the next piece of text.
3. Repeat as often as needed.

Now you can work with the selected text (copy it, delete it, change the style, or whatever).
Macintosh users: substitute the Command key when instructions in this chapter say to use the Control key.

The Country of the Blind

Three hundred miles and more from Chimborazo, one hundred from the snows of Cotopaxi, wastes of Ecuador’s Andes, there lies that mysterious mountain valley, cut off from all the world that men might through frightful gorges and over an icy pass into its squalid meadows, and dither indeed or so of Peruvian half-breeds fleeing from the lust and tyranny of an evil Spanish ruler. Then the stupendous outbreak of Mindehamba, when it was night in Quito for seventeen days, and that Yaguachi and all the fish floating dying even as far as Guayaquil, everywhere along the Río were landslips and swift streamings and sudden floods, and once whole side of the old Bridge came down in thunder, and cut off the Country of the Blind for ever from the exploring foot these early settlers had chanced to be on the other side of the gorges when the world had so itself, and he perforce had to forget his wife and his child and all the friends and possession.

Figure 7: Selecting items that are not next to each other

To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of text, see the topic “Navigating and selecting with the keyboard” in the Help.)

2) Press Shift+F8. This puts Writer in Add mode. The word ADD appears on the status bar.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down the Shift key and select the next piece of text.

4) Repeat as often as needed.

5) Now you can work with the selected text.

6) Press Esc to exit from this mode.

Selecting a vertical block of text

You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might see in text pasted from e-mails, program listings, or other sources), using OOo’s block selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or click several times in the status bar on STD until it changes to BLK.

Now highlight the selection, using mouse or keyboard, as shown in Figure 8.
Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. You can use the mouse or the keyboard for these operations.

Cut: Use **Edit > Cut** or **Control+X** or the **Cut** icon on the toolbar.

Copy: Use **Edit > Copy** or **Control+C** or the **Copy** icon.

Paste: Use **Edit > Paste** or **Control+V** or the **Paste** icon.

If you simply click on the **Paste** icon, any formatting the text has (such as bold or italics) is retained. To make the pasted text take on the formatting of the surrounding text where it is being pasted, click the triangle to the right of the **Paste** icon and select **Unformatted text** from the menu (Figure 9).

Finding and replacing text and formatting

Writer has a Find and Replace feature that automates the process of searching for text inside a document. In addition to finding and replacing words and phrases, you can:

- Use regular expressions (wildcards) to fine-tune a search (see the Help for details).
- Find and replace specific formatting (see the **Writer Guide**).
- Find and replace paragraph styles (see the **Writer Guide**).

To display the Find & Replace dialog (Figure 10), use the keyboard shortcut **Control+F** or select **Edit > Find & Replace**.
Type the text you want to find in the **Search for** box.

To replace the text with different text, type the new text in the **Replace with** box.

You can select various options such as matching the case, matching whole words only, or doing a search for similar words. (See below for some other choices.)

When you have set up your search, click **Find**. To replace text, click **Replace** instead.

---

**Tip**

If you click **Find All**, OOo selects all instances of the search text in the document. Similarly, if you click **Replace All**, OOo will replace all matches.

---

**Figure 10**: Expanded Find & Replace dialog

---

**Caution**

Use **Replace All** with caution; otherwise, you may end up with some hilarious (and highly embarrassing) mistakes. A mistake with **Replace All** might require a manual, word-by-word, search to fix.
**Inserting special characters**

A *special character* is one not found on a standard English keyboard. For example, © ¾ æ ç ñ ö ø ¢ are all special characters. To insert a special character:

1) Place the cursor where you want the character to appear.
2) Click **Insert > Special Character** to open the Special Characters window (Figure 11).
3) Select the characters you wish to insert, in order, then click **OK**. The selected characters are shown in the lower left of the dialog. As you select a character, it is shown on the lower right, along with its numerical code.

---

**Note**

Different fonts include different special characters. If you do not find a particular special character, try changing the **Font** selection.

---

**Figure 11**: The Special Characters window, where you can insert special characters.

---

**Tip**

Notice that the characters selected appear in the bottom-left corner of the window.

---

**Setting tab stops and indents**

The horizontal ruler shows both the default tab stops and any that you have defined. To set the measurement unit and the spacing of default tab stops, go to **Tools > Options > OpenOffice.org Writer > General**.

You can also set or change the measurement unit by right-clicking on the ruler to open a list of units, as shown in Figure 12. Click on one of them to change the ruler to that unit.
Double-click on a blank part of the ruler to open the Indents & Spacing page of the Paragraph dialog. Double-click on the ruler itself to open the Tabs page of the Paragraph dialog (Figure 13) and fine-tune tab stop settings.

![Figure 12: Ruler showing default tab stops](image)

**Figure 12: Ruler showing default tab stops**

**Figure 13: The Tabs page of the Paragraph dialog**

### Checking spelling

Writer provides a spelling checker, which can be used in two ways.

- **AutoSpellcheck** checks each word as it is typed and displays a wavy red line under any misspelled words. When the word is corrected, the line disappears.

- To perform a separate spelling check on the document (or a text selection) click the **Spellcheck** button. This checks the document or selection and opens the Spellcheck dialog if any misspelled words are found.
Here are some more features of the spelling checker:

- Right-click on a word with a wavy underline to open a menu. If you select from the suggested words on the menu, the selection will replace the misspelled word in your text.
- You can change the dictionary language (for example, to Spanish, French or German) on the Spellcheck dialog.
- You can add a word to the dictionary. Click Add in the Spellcheck dialog and pick the dictionary to add it to.
- The Options dialog of the Spellcheck tool has a number of different options such as whether to check uppercase words and words with numbers. It also allows you to manage custom dictionaries, that is, add or delete dictionaries, and add or delete words in a dictionary.
- On the Font tab of the Paragraph Styles dialog, you can set paragraphs to be checked in a specific language (different from the rest of the document). See Chapter 7 (Working with Styles) in the Writer Guide for more information.

Using language tools

OOo provides some tools that make your work easier if you mix multiple languages within the same document or write documents in various languages.

You can set the language for the whole document, selected paragraphs, or even individual words or characters. In versions earlier than OOo 3.0 it was necessary to use styles in order to insert within a document paragraphs or individual groups of characters that use a different language, while now this can be conveniently done from the main menu.

Tip

Using character and paragraph styles is still the preferred method, as styles allow a greater level of control and make changing the language much faster. See Chapter 7 (Working with Styles) in the Writer Guide for information on how to manage the language settings of a style.

The main advantage of changing the language is that you can then use the correct dictionaries to check spelling and apply the localized versions of Autocorrect replacement tables, thesaurus, and hyphenation rules.

The language tools can be found in Tools > Languages on the main menu, as shown in Figure 14.
The following options are available:

- **For selection**: select this option to apply a specified language to the selected text (the selection can comprise only a few characters or several paragraphs).
- **For paragraph**: select this option to apply the specified language to the paragraph where the cursor is located.
- **For all text**: select this option to apply the specified language to all the document.

An alternative way to change the language of a whole document is to use Tools > Options > Language Settings > Languages. In the Default languages for documents section of the Options dialog (Figure 15), you can choose a different language for all the text.

*Caution*

Unlike the menu tool that applies to the individual document, a change in the default language from the Options dialog is a general change of settings of OOo and will therefore apply to all the documents created in the future. If you want to change the language for the current document only, be sure to select the For the current document only option.

Spell checking is available only for those languages in the list that have the symbol 🛏️ next to them. If you do not see the symbol next to your preferred language, you can install the additional dictionary using Tools > Languages > More dictionaries online.

**Figure 14: The Language menu**

**Figure 15: Options available in the Languages settings**

*Working with text*
The language used for checking spelling is also shown in the status bar, next to the page style in use.

You can also configure the language for a paragraph or a group of characters as None. This option is particularly useful in the case where you insert in the document text that you do not want to spellcheck, such as web addresses or programming language snippets.

**Using AutoCorrect**

Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it corrects automatically. For example, “hte” will be changed to “the”. Select **Tools > AutoCorrect** to open the AutoCorrect dialog. There you can define which strings of text are corrected and how. In most cases, the defaults are fine.

<table>
<thead>
<tr>
<th>Tip</th>
<th>AutoCorrect is turned on by default. To turn it off, uncheck Format &gt; AutoFormat &gt; While Typing.</th>
</tr>
</thead>
</table>

To stop Writer from replacing a specific spelling, use **Tools > AutoCorrect > Replace**, highlight the word pair and click **Delete**.

To add a new spelling to correct, type it into the **Replace** and **With** boxes and click **New**.

See the different tabs of the dialog for the wide variety of other options available to fine-tune AutoCorrect.

<table>
<thead>
<tr>
<th>Tip</th>
<th>AutoCorrect can be used as a quick way to insert special characters. For example, (c) will be autocorrected to ©. You can add your own special characters.</th>
</tr>
</thead>
</table>

**Using word completion**

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to complete the word for you. To accept the suggestion, press **Enter**. Otherwise continue typing.

<table>
<thead>
<tr>
<th>Tip</th>
<th>Many people prefer not to use Word Completion. If you do not want to use it, select <strong>Tools &gt; AutoCorrect &gt; Word Completion</strong> and uncheck Enable Word Completion.</th>
</tr>
</thead>
</table>
You can customize word completion from the **Tools > AutoCorrect > Word Completion** page:

- Add (append) a space automatically after an accepted word.
- Show the suggested word as a tip (hovering over the word) rather than completing the text as you type.
- Change the maximum number of words remembered for word completion and the length of the smallest words to be remembered.
- Delete specific entries from the word completion list.
- Change the key that accepts a suggested entry—the options are *Right arrow, End key, Return (Enter), and Space bar*.

**Note**  
Automatic word completion only occurs after you type a word for the second time in a document.

**Using AutoText**

AutoText allows you to assign text, tables, graphics and other items to a key combination. For example, rather than typing “Senior Management” every time you use that phrase, you might just type “sm” and press *F3*. Or you can save a formatted Note (like the one on this page) as AutoText and then insert a copy by typing “note” and pressing *F3*.

To assign some text to an AutoText shortcut:

1) Type the text into your document.
2) Select the text so it is highlighted.
3) Select **Edit > AutoText** (or press *Control+F3*).
4) Enter a name for your shortcut. Writer will suggest a one-letter shortcut, which you can change.
5) Click the **AutoText** button on the right and select **New (text only)** from the menu.
6) Click **Close** to return to your document.

**Tip**  
If the only option under the AutoText button is Import, either you have not entered a name for your AutoText or there is no text selected in the document.

AutoText is especially powerful when assigned to fields. See Chapter 14 (Working with Fields) in the *Writer Guide* for more information.
Inserting dashes and non-breaking spaces

You can insert a dash by using the Special Characters window or by using AutoCorrect. For more about AutoCorrect, see “Controlling OOO’s AutoCorrect functions” in Chapter 2 (Setting up OpenOffice.org) and “Using AutoCorrect” on page 18 in this chapter.

– is an en-dash; that is, a dash the width of the letter “n” in the font you are using. It is U+2013 (scroll down to the General Punctuation section in the Special Characters window). To enter an en-dash using AutoCorrect, type at least one character, a space, one or two hyphens, another space, and at least one more letter, then a space. The one or two hyphens will be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the font you are using. It is U+2014. To enter it using AutoCorrect, type at least one character, two hyphens, and at least one more character, then a space. The two hyphens will be replaced by an em-dash.

To insert a non-breaking space (to keep characters together, for example in a telephone number), press Control+Space on the keyboard.

Formatting text

Using styles

Styles are central to using Writer. Styles enable you to easily format your document consistently, and to change the format with minimal effort. Often, when you format your document in Writer, you are using styles whether you realize it or not. A style is a named set of formatting options. Writer defines several types of styles, for different types of elements: characters, paragraphs, pages, frames, and lists. See Chapter 3 (Using Styles and Templates).

Formatting paragraphs

You can apply many formats to paragraphs using the buttons on the Formatting toolbar. Figure 16 shows the Formatting toolbar as a floating toolbar, customized to show only the buttons for paragraph formatting. The appearance of the icons may vary with your operating
system and the selection of icon size and style in Tools > Options > OpenOffice.org > View.

**Tip**

It is highly recommended that you use paragraph styles rather than manually formatting paragraphs, especially for long or standardized documents. For information on the advantages of styles, and how to use them, see Chapter 13 (Working with Styles) in this book and Chapters 6 and 7 in the Writer Guide.

---

**Figure 16:** The Formatting toolbar, showing icons for paragraph formatting.

Figure 17 shows examples of the different alignment options.

---

**Figure 17:** Different text alignment options.

---

**Formatting characters**

You can apply many formats to characters using the buttons on the Formatting toolbar. Figure 18 shows the Formatting toolbar as a floating toolbar, customized to show only the buttons for character formatting.

---

**Tip**

It is highly recommended that you use character styles rather than manually formatting characters. For information on the advantages of styles, and how to use them, see Chapter 6 (Introduction to Styles) in the Writer Guide.
The appearance of the icons may vary with your operating system and the selection of icon size and style in Tools > Options > OpenOffice.org > View.

Tip To remove manual formatting, select the text and click Format > Default Formatting, or right-click and select Default Formatting.

Autoformatting

You can set Writer to automatically format parts of a document according to the choices made on the Options page of the AutoCorrect dialog (Tools > AutoCorrect > Options).

Tip If you notice unexpected formatting changes occurring in your document, this is the first place to look for the cause.

Some common unwanted or unexpected formatting changes include:

- Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal signs (===) on a line and then press Enter, the paragraph is replaced by a horizontal line as wide as the page. The line is actually the lower border of the preceding paragraph.

- Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star (*), or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list is created when you type a number followed by a period (.), followed by a space or tab at the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted with the Default, Text body or Text body indent paragraph styles.
To turn autoformatting on or off, go to **Format > AutoFormat** and select or delete the items on the sub menu.

### Creating numbered or bulleted lists

There are several ways to create numbered or bulleted lists:

- Use autoformatting, as described above.
- Use list (numbering) styles, as described in Chapters 6 (Introduction to Styles) and 7 (Working with Styles) in the *Writer Guide*.
- Use the Numbering and Bullets icons on the paragraph formatting toolbar (see Figure 16). This method is described here.

To produce a numbered or bulleted list, select the paragraphs in the list, and then click the appropriate icon on the toolbar.

**Note**

It is a matter of personal preference whether you type your information first, then apply Numbering/Bullets, or apply them as you type.

### Using the Bullets and Numbering toolbar

You can create nested lists (where one or more list items has a sublist under it, as in an outline) by using the buttons on the Bullets and Numbering toolbar (Figure 19). You can move items up or down the list, or create subpoints, and even change the style of bullets. Use **View > Toolbars > Bullets and Numbering** to see the toolbar.

The appearance of the icons may vary with your operating system and the selection of icon size and style in **Tools > Options > OpenOffice.org > View**.

![Figure 19: Bullets and Numbering toolbar](image)

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Bullets On/Off</td>
</tr>
<tr>
<td>2</td>
<td>Numbering On/Off</td>
</tr>
<tr>
<td>3</td>
<td>Numbering Off</td>
</tr>
<tr>
<td>4</td>
<td>Up One Level</td>
</tr>
<tr>
<td>5</td>
<td>Up One Level</td>
</tr>
<tr>
<td>6</td>
<td>Move Up (One Level) with Sub-points</td>
</tr>
<tr>
<td>7</td>
<td>Move Down (One Level) with Sub-points</td>
</tr>
<tr>
<td>8</td>
<td>Insert Unnumbered Entry</td>
</tr>
<tr>
<td>9</td>
<td>Move Up</td>
</tr>
<tr>
<td>10</td>
<td>Move Down</td>
</tr>
<tr>
<td>11</td>
<td>Move Up in Sub-points</td>
</tr>
<tr>
<td>12</td>
<td>Move Down in Sub-points</td>
</tr>
<tr>
<td>13</td>
<td>Restart Numbering</td>
</tr>
<tr>
<td>14</td>
<td>Bullets and Numbering</td>
</tr>
</tbody>
</table>


**Hyphenating words**

To turn automatic hyphenation of words on or off:

1) Press *F11* to open the Styles and Formatting window (Figure 20).

2) On the Paragraph Styles page of the Styles and Formatting window, right-click on **Default** in the list and select **Modify**.

![Figure 20: Modifying a style](image)

3) On the Paragraph Style dialog, go to the **Text Flow** page (see Figure 21).

4) Under Hyphenation, select or deselect the **Automatically** option. Click **OK** to save.

---

**Note**

Turning on hyphenation for the Default paragraph style affects all other paragraph styles that are based on Default. You can individually change other styles so that hyphenation is not active; for example, you might not want headings to be hyphenated. Any styles that are not based on Default are not affected. For more on paragraph styles, see Chapter 6 (Introduction to Styles) and Chapter 7 (Working with Styles) in the *Writer Guide*.

![Figure 21: Turning on automatic hyphenation](image)
You can also set hyphenation choices through Tools > Options > Language Settings > Writing Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings (Figure 22).

![Figure 22: Setting hyphenation options]

**Note**

Hyphenation options set on the Writing Aids dialog are effective only if hyphenation is turned on through paragraph styles.

Choices on the Writing Aids dialog for “characters before line break” and “characters after line break” override settings in paragraphs styles for “characters at line end” and “characters at line begin”.

To enter a conditional hyphen inside a word, press Control+minus sign. The word is hyphenated at this position when it is at the end of the line, even if automatic hyphenation for this paragraph is switched off.

To insert a non-breaking hyphen, press Control+Shift+minus sign.

### Undoing and redoing changes

To undo the most recent change, press Control+Z, or click the Undo icon on the Standard toolbar, or select Edit > Undo from the menu bar.

The Edit menu shows the latest change that can be undone, as shown in Figure 23.

![Figure 23: Edit > Undo last action]

Click the small triangle to the right of the Undo icon to get a list of all the changes that can be undone (Figure 24). You can select multiple changes and undo them at the same time.
After changes have been undone, **Redo** becomes active. To redo a change, select **Edit > Redo**, or press *Control+Y* or click on the Redo icon 🔄. As with Undo, click on the triangle to the right of the arrow to get a list of the changes that can be reapplied.

To modify the number of changes OpenOffice.org remembers, select **Tools > Options > OpenOffice.org > Memory** and change **Undo number of steps**. Be aware that asking OOo to remember more changes consumes more computer memory.

## Formatting pages

Writer provides several ways for you to control page layouts:

- Page styles
- Columns
- Frames
- Tables
- Sections

For more information, see Chapter 4 (Formatting Pages) in the **Writer Guide**.

---

| **Tip** | Page layout is usually easier if you show text, object, table, and section boundaries in **Tools > Options > OpenOffice.org > Appearance**, and paragraph ends, tabs, breaks, and other items in **Tools > Options > OpenOffice.org Writer > Formatting Aids**. |

---

### Which layout method to choose?

The best layout method varies depending on what the final document should look like and what sort of information will be in the document. Here are some examples.
For a book similar to this user guide, with one column of text, some figures without text beside them, and some other figures with descriptive text, use page styles for basic layout, and tables to place figures beside descriptive text when necessary.

For an index or other document with two columns of text, where the text continues from the left-hand column to the right-hand column and then to the next page, all in sequence (also known as “snaking columns” of text), use page styles (with two columns). If the title of the document (on the first page) is full-page width, put it in a single-column section.

For a newsletter with complex layout, two or three columns on the page, and some articles that continue from one page to some place several pages later, use page styles for basic layout. Place articles in linked frames and anchor graphics to fixed positions on the page if necessary.
For a document with terms and translations to appear side-by-side in what appear to be columns, use a table to keep items lined up, and so you can type in both “columns”.

Creating headers and footers

A header is an area that appears at the top of a page. A footer appears at the bottom of the page. Information, such as page numbers inserted into a header or footer, displays on every page of the document with that page style.

To insert a header, click Insert > Header > Default (or the page style, if not Default) as shown in Figure 25.

![Figure 25: Inserting headers and footers](image)

Other information such as document titles and chapter titles is often put into the header or footer. These items are best added as fields. That way, if something changes, the headers and footers are updated automatically. Here is one common example.

To insert the document title into the header:

1) Click File > Properties > Description and type a title for your document.
2) Add a header (Insert > Header > Default).
3) Place the cursor in the header part of the page.
4) Select **Insert > Fields > Title**. The title should appear on a gray background (which does not show when printed and can be turned off).

5) To change the title for the whole document, go back to **File > Properties > Description**.

Fields are covered in detail in Chapter 14 (Working with Fields) in the *Writer Guide*.

For more about headers and footers, see Chapter 4 (Formatting Pages) and Chapter 6 (Introduction to Styles) in the *Writer Guide*.

**Numbering pages**

To automatically number pages:

1) Insert a header or footer, as described in “Creating headers and footers” on page 28.

2) Place the cursor in the header or footer where you want the page number to appear and click **Insert > Fields > Page Number**.

**Including the total number of pages**

To include the total number of pages (as in “page 1 of 12”):

1) Type the word “page” and a space, then insert the page number as above.

2) Press the spacebar once, type the word “of” and a space, then click **Insert > Fields > Page Count**.

---

**Note**

The Page Count field inserts the total number of pages in the document, as shown on the Statistics tab of the document’s Properties window (**File > Properties**). If you restart page numbering anywhere in the document, then the total page count may not be what you want. See Chapter 4 (Formatting Pages) in the *Writer Guide* for more information.

---

**Restarting page numbering**

Often you will want to restart the page numbering at 1, for example on the page following a title page or a table of contents. In addition, many documents have the “front matter” (such as the table of contents) numbered with Roman numerals and the main body of the document numbered in Arabic numerals, starting with 1.

You can restart page numbering in two ways.
**Method 1:**

1) Place the cursor in the first paragraph of the new page.
2) Click **Format > Paragraph**.
3) On the Text Flow tab of the Paragraph dialog (Figure 21 on page 24), select **Breaks**.
4) Select **Insert** and then **With Page Style** and specify the page style to use.
5) Specify the page number to start from, and then click **OK**.

---

**Tip**

Method 1 is also useful for numbering the first page of a document with a page number greater than 1. For example, you may be writing a book, with each chapter in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with page 25 and Chapter 3 with page 51.

---

**Method 2:**

1) **Insert > Manual break.**
2) By default, **Page break** is selected on the Insert Break dialog (Figure 26).
3) Choose the required page **Style**.
4) Select **Change page number**.
5) Specify the page number to start from, and then click **OK**.

---

![Insert Break Dialog]

*Figure 26: Restarting page numbering after a manual page break*

---

**Changing page margins**

You can change page margins in two ways:

- Using the page rulers—quick and easy, but does not have fine control.
Using the Page Style dialog—can specify margins to two decimal places.

**Note** If you change the margins using the rulers, the new margins affect the page style and will be shown in the Page Style dialog the next time you open it.

To change margins using the rulers:
1) The gray sections of the rulers are the margins (see Figure 27). Put the mouse cursor over the line between the gray and white sections. The pointer turns into a double-headed arrow.
2) Hold down the left mouse button and drag the mouse to move the margin.

![Figure 27: Moving the margins](image)

**Tip** The small arrows on the ruler are used for indenting paragraphs. They are often in the same place as the page margins, so you need to be careful to move the margin marker, not the arrows. Place the mouse pointer between the arrows and, when the pointer turns into a double-headed arrow, you can move the margin (the indent arrows will move with it).

To change margins using the Page Style dialog:
1) Right-click anywhere on the page and select **Page** from the pop-up menu.
2) On the **Page** tab of the dialog, type the required distances in the Margins boxes.

**Adding notes to a document**

The use of notes in a Writer document has been improved in OOo3. Notes are now displayed at the side of the page and color-coded according to the user who created them.
To insert a note in the text, place the cursor in the text and select **Insert > Note** or press *Ctrl+Alt+N*. The anchor point of the note is connected by a dotted line to a box on the right-hand side of the page where you can type the text of the note. OOo automatically adds at the bottom of the note the name or initials of the author and a time stamp. Figure 28 shows an example of text with notes from two different authors.

Select **Tools > Options > User Data** to configure the name you want to appear in the Author field of the note, or to change it.

If more than one person edits the document, each author is automatically allocated a different background color.

![Figure 28: Notes in OOo3](image)

Right-clicking on any note pops up a menu where you can delete the current note, all the notes from the same author, or all the notes in the document. From this menu, you can also apply some basic formatting to the text of the notes. You can also change the font type, size, and alignment from the main menu.

To navigate from one note to the other, open the Navigator (*F5*), expand the Notes section, and click on the note text to move the cursor to the anchor point of the note in the document. Right-click on the note to quickly edit or delete it.

You can also navigate the notes using the keyboard. Use *Ctrl+Alt+Page Down* to move to the next note and *Ctrl+Alt+Page Up* to move to the previous note.
Creating a table of contents

Writer’s table of contents feature lets you build an automated table of contents from the headings in your document. Before you start, make sure that the headings are styled consistently. For example, you can use the *Heading 1* style for chapter titles and the *Heading 2* and *Heading 3* styles for chapter subheadings.

Although tables of contents can be customized extensively in Writer, often the default settings are all you need. Creating a quick table of contents is simple:

1) When you create your document, use the following paragraph styles for different heading levels (such as chapter and section headings): *Heading 1*, *Heading 2*, and *Heading 3*. These are what will appear in your table of contents. You can use more levels of headings, but the default setting is to use only the first three levels in the table of contents.

2) Place the cursor where you want the table of contents to be inserted.

3) Select **Insert > Indexes and Tables > Indexes and Tables**.

4) Change nothing in the Insert Index/Table dialog. Click **OK**.

If you add or delete text (so that headings move to different pages) or you add, delete, or change headings, you need to update the table of contents. To do this:

1) Place the cursor within the table of contents.

2) Right-click and select **Update Index/Table** from the pop-up menu.

---

**Note**

If you cannot place your cursor in the table of contents, choose **Tools > Options > OpenOffice.org Writer > Formatting Aids**, and then select **Enable** in the **Cursor in protected areas** section.

You can customize an existing table of contents at any time. Right-click anywhere in it and select **Edit Index/Table** from the pop-up menu. Chapter 12 (Creating Tables of Contents, Indexes and Bibliographies) of the *Writer Guide* describes in detail all the customizations you can choose.
Creating indexes and bibliographies

Indexes and bibliographies work in a similar way to tables of contents. Chapter 12 (Creating Tables of Contents, Indexes and Bibliographies) in the *Writer Guide* describes the process in detail.

In addition to alphabetical indexes, other types of indexes supplied with Writer include those for illustrations, tables, and objects, and you can even create a user-defined index. For example, you might want an index containing only the scientific names of species mentioned in the text, and a separate index containing only the common names of species. Before creating some types of indexes, you first need to create index entries embedded in your Writer document.

Working with graphics

Graphics in Writer are of three basic types:

- Image files, including photos, drawings, scanned images, and others
- Diagrams created using OOo’s drawing tools
- Charts created using OOo’s Chart facility.

See Chapter 11 (Graphics, the Gallery, and Fontwork).

Printing from Writer

Writer provides a range of choices when printing.

Quick printing

Click the *Print File Directly* icon to send the entire document to the default printer defined for your computer.

| Note | You can change the action of the *Print File Directly* icon to send the document to the printer defined for the document instead of the default printer for the computer. Go to *Tools > Options > Load/Save > General* and select the *Load printer settings with the document* option. |
**Controlling printing**

For more control over printing, use **File > Print** to display the Print dialog (Figure 29).

On the Print dialog, you can choose:

- Which printer to use (if more than one are installed on your system) and the properties of the printer—for example, orientation (portrait or landscape), which paper tray to use, and what paper size to print on. The properties available depend on the selected printer; consult the printer’s documentation for details.

- What pages to print, how many copies to print, and in what order to print them. Use dashes to specify page ranges and commas or semicolons to separate ranges; for example: 1, 5, 11–14, 34–40. *Selection* is the highlighted part of a page or pages.

- What items to print. Click the **Options** button to display the Printer Options dialog (Figure 30).

![Figure 29. The Print dialog](image)

*Printing from Writer* 35
Selecting print options for a document

Selections on the Printer Options dialog apply to this printing of this document only.

To specify default printing options, you need to use two pages in Tools > Options: OpenOffice.org – Print (see Chapter 2) and OpenOffice.org Writer – Print (which looks very similar to the Printer Options dialog).

Some items of interest on the Printer Options dialog include:

- In the Contents section, you might choose not to print graphics or page background in drafts, for example (to save toner or ink).
- In the Pages section, you can choose:
  - Print only left (even-numbered) pages or only right (odd-numbered) pages. These settings are useful when you want to print on both sides of the page, but do not have a printer that handles this automatically.
  - Print in reversed page order.
  - Brochure—the results of this selection are discussed in “Printing a brochure” on page 38.
- In the Notes section, you can choose whether to print any notes that have been added to your document (using Insert > Note), and where to print the notes.
Printing in black and white on a color printer

You may wish to print documents in black and white on a color printer, to save expensive color ink or toner. Common uses are for drafts or documents to be photocopied in black and white. Several choices are available.

To print the current document in black and white or grayscale:

1) Click File > Print to open the Print dialog.
2) Click Properties to open the properties dialog for the printer. The available choices vary from one printer to another, but you should find an option for Color. See your printer’s help or user manual for more information.
3) The choices for color may include black and white or grayscale. Choose one of these. Grayscale is best if you have any graphics in the document. Click OK to confirm your choice and return to the Print dialog, then click OK again to print the document.

To set up OOo to print all color text and graphics as grayscale:

1) Click Tools > Options > OpenOffice.org > Print.
2) Select the Convert colors to grayscale option. Click OK to save the change.

To set up OOo Writer to print all color text as black, and all graphics as grayscale:

1) Click Tools > Options > OpenOffice.org Writer > Print.
2) Under Contents, select the Print black option. Click OK to save the change.

Previewing pages before printing

The normal page view in Writer shows you what each page will look like when printed, but it shows only one page at a time. If you are designing a document to be printed double-sided, you may want to see what facing pages look like. OOo provides two ways to do this:

- View Layout (editable view) —see “View layout” on page 7.
- Page Preview (read-only view) —from which you can print multiple pages onto one sheet of paper.

To use Page Preview:

1) Click File > Page Preview, or click the Page Preview button 📃.
The Writer window changes to display the current page and the following page, and shows the **Page Preview** toolbar in place of the Formatting toolbar.

![Page Preview toolbar](image)

**Figure 31. Page Preview toolbar**

2) Click the **Book Preview** icon to display left and right pages in their correct orientation.

3) To print the document from this page view, click the **Print page view** icon to open the Print dialog. Choose your options and click **OK** to print as usual.

4) To choose margins and other options for the printout, click the **Print options page view** icon to display the Print Options dialog.

![Print Options dialog](image)

**Figure 32. Print Options dialog**

**Printing a brochure**

You can print a document with two pages on each side of a sheet of paper, arranged so that when the printed pages are folded in half, the pages are in the correct order to form a booklet or brochure.

To print a brochure on a single-sided printer:

1) Plan your document so it will look good when printed half size (choose appropriate margins, font sizes, and so on). Click **File > Print**. In the Print dialog, click **Properties** and be sure the printer is set to the same orientation (portrait or landscape) as specified in the page setup for your document. (Usually the orientation does not matter, but it does for brochures.)
2) Click **Options**. In the Pages section of the Printer Options dialog, choose **Brochure** and **Right pages**. Click **OK** twice to print the first side of each page.

3) Flip the pages and put them back into the printer, in the correct orientation to print on the blank side. You may need to experiment a bit to find out what the correct arrangement is for your printer.

4) Click **File > Print** and check **Properties** to make sure the printer setup is still correct.

5) Click **Options** again. In the Pages section of the Printer Options dialog, choose **Brochure** and **Left page**. Click **OK** twice to print the second sides.

6) If your printer can do double-sided, then click on the options for **Left pages, Right pages, and Brochure**, and it should not only do those but collate too.

**Printing envelopes**

Printing envelopes involves two steps: setup and printing.

To set up an envelope to be printed by itself or with your document:

1) Click **Insert > Envelope** from the menu bar.

2) In the Envelope dialog, start with the **Envelope** tab (Figure 33). Verify, add, or edit the information in the Addressee and Sender boxes (the “from” on the envelope).

You can type information directly into the Addressee and Sender boxes, or use the right-hand drop-down lists to select the database or table from which you can draw the envelope information, if desired. See Chapter 11 (Using Mail Merge) in the **Writer Guide** for details on how to print envelopes from a database.

3) On the **Format** page (Figure 34), verify or edit the positioning of the addressee and the sender information. The preview area on the lower right shows the effect of your positioning choices.

To format the text of these blocks, click the **Edit** buttons to the right. In the drop-down list you have two choices: Character and Paragraph.

- In Character, you can choose Fonts (Sizes...), Fonts Effects (Underlining, Color...), Position (Rotating/scaling...), Hyperlink, Background and more.

- In Paragraph, you can choose Indents & Spacing, Alignment, Text Flow, Tabs, Drop Caps, Borders and Backgrounds.
4) In the lower left of this page, choose the envelope format from the drop-down list. The width and height of the selected envelope then show in the boxes below the selected format. If you chose a pre-existing format, just verify these sizes. If you chose User defined in the Format list, then you can edit the sizes.

5) After formatting, go to the Printer page (Figure 35) to choose printer options such as envelope orientation and shifting. You may need to experiment a bit to see what works best for your printer.
You can also choose a different printer or alter printer setup (for example, specify the tray that holds envelopes) for this print job.

![Figure 35. Choosing printer options for an envelope](image)

6) When you have finished formatting and are ready to print, click either the **New Doc** or **Insert** button to finish. **New Doc** makes only an envelope or starts a new document with the envelope. **Insert** inserts the envelope into an existing document as page 1. To not proceed with this envelope, click **Cancel** or press the **Esc** key. You can also click **Reset** to remove your changes and return to the original settings when the dialog opened.

7) When the Envelope dialog closes, you are returned to your document, which now has the envelope in the same file as the document. Save this file before you do anything else.

To print the envelope:

1) Choose **File > Print** from the menu bar.
2) On the Print dialog, under **Print range**, choose **Pages** and type 1 in the box. Click **OK** to print.

### Printing labels

Labels are commonly used for printing address lists (where each label shows a different address), but they can also be used for making multiple copies of one label only, for example return-address stickers.

To print labels:

1) Choose **File > New > Labels** on the menu bar. The Labels dialog opens.

2) On the **Labels** page, fill in your own label text in the **Inscription** box, or use the **Database** and **Table** drop-down lists to choose the
required information, as described in Chapter 11 (Using Mail Merge) in the *Writer Guide*.

![Image of Labels dialog, Labels page]

**Figure 36. Labels dialog, Labels page**

3) Select the label stock in the **Brand** drop-down list. The types for that brand then appear in the **Type** drop-down list. Select the size and type of labels required. You can also select User in the **Type** drop-down list and then make specific selections on the **Format** page.

4) On the **Format** page (Figure 37), choose the pitch, sizes, margins, columns and rows for user-defined labels, or just verify with a brand of label stock you have loaded into the printer.

![Image of Labels dialog, Format page]

**Figure 37. Labels dialog, Format page**
5) Click **Save** to save your new format.

6) When you have finished formatting, click **New Document** to make your sheet of labels or click **Cancel** (or press the *Esc* key). You can also click **Reset** to remove your changes and return to the original settings when the dialog opened. On the **Options** page, choose to print the entire page of labels or one single label, then select which one by the column and row. You can also change printer setup.

7) You can print right away using the **Print File Directly** icon on the toolbar or by choosing **File > Print** from the menu bar, or you can save the file to print later.

![Figure 38. Labels dialog, Options page](image)

**Sending a fax using Writer**

To send a fax directly from OpenOffice.org, you need a fax modem and a fax driver that allows applications to communicate with the fax modem.

**Sending a fax through the Print dialog**

1) Open the Print dialog by choosing **File > Print** and select the fax driver in the **Name** list.

2) Click **OK** to open the dialog for your fax driver, where you can select the fax recipient.

**Adding a Fax icon to the toolbar**

You can configure OpenOffice.org so that a single click on an icon automatically sends the current document as a fax. See Chapter 14 (Customizing OpenOffice.org) for instructions.
Tracking changes to a document

You can use several methods to keep track of changes made to a document.

1) Make your changes to a copy of the document (stored in a different folder, or under a different name, or both), then use Writer to combine the two files and show the differences. Click Edit > Compare Document. This technique is particularly useful if you are the only person working on the document, as it avoids the increase in file size and complexity caused by the other methods.

2) Save versions that are stored as part of the original file. However, this method can cause problems with documents of non-trivial size or complexity, especially if you save a lot of versions. Avoid this method if you can.

3) Use Writer’s change marks (often called “redlines” or “revision marks”) to show where you have added or deleted material, or changed formatting. Later, you or another person can review and accept or reject each change. Click Edit > Changes > Record. Details are in the Writer Guide.

Tip Not all changes are recorded. For example, changing a tab stop from align left to align right, and changes in formulas (equations) or linked graphics are not recorded.

Using mail merge

Writer provides very useful features to create and print:

- Multiple copies of a document to send to a list of different recipients (form letters)
- Mailing labels
- Envelopes

All these facilities, though different in application, are based around the concept of a registered data source (a spreadsheet or database containing the name and address records and other information), from which is derived the variable information necessary to their function.

Chapter 11 (Using Mail Merge) in the Writer Guide describes the process.
Using master documents

Master documents are typically used for producing long documents such as a book, a thesis, or a long report; or when different people are writing different chapters or other parts of the full document, so you don’t need to share files. A master document joins separate text documents into one larger document, and unifies the formatting, table of contents (ToC), bibliography, index, and other tables or lists.

Yes, master documents do work in Writer. However, until you become familiar with them, you may think that master documents are unreliable or difficult to use. See Chapter 13 (Working with Master Documents) in the Writer Guide.

Creating fill-in forms

A standard text document displays information: a letter, report, or brochure, for example. Typically the reader may edit everything or nothing in any way. A form has sections that are not to be edited, and other sections that are designed for the reader to make changes. For example, a questionnaire has an introduction and questions (which do not change) and spaces for the reader to enter answers.

Forms are used in three ways:

- To create a simple document for the recipient to complete, such as a questionnaire sent out to a group of people who fill it in and return it.
- To link into a database or data source and allow the user to enter information. Someone taking orders might enter the information for each order into a database using a form.
- To view information held in a database or data source. A librarian might call up information about books.

Writer offers several ways to fill information into a form, including check boxes, option buttons, text boxes, pull-down lists and spinners. See Chapter 15 (Using Forms in Writer) in the Writer Guide.

Using fields

Fields are extremely useful features of Writer. They are used for data that changes in a document (such as the current date or the total number of pages) and for inserting document properties such as name, author, and date of last update. Fields are the basis of cross-
referencing (see below); automatic numbering of figures, tables, headings, and other elements; and a wide range of other functions—far too many to describe here. See Chapter 14 (Working with Fields) in the *Writer Guide* for details.

## Using cross-references

If you type in references to other parts of the document, those references can easily get out of date if you reword a heading, add or remove figures, or reorganize topics. Replace any typed cross-references with automatic ones and, when you update fields, all the references will update automatically to show the current wording or page numbers. The *Cross-references* tab of the Fields dialog lists some items, such as headings, bookmarks, figures, tables, and numbered items such as steps in a procedure.

To insert a cross-reference to a heading or other text:

1) In your document, place the cursor where you want the cross-reference to appear.

2) If the Fields dialog is not open, click **Insert > Cross-reference**. On the *Cross-references* tab, in the *Type* list, select the type of item to be referenced (for example, *Heading* or *Figure*).

![Fields dialog with Cross-references tab highlighted](image)

*Figure 39: The Cross-references tab of the Fields dialog*
You can leave this page open while you insert many cross-references.

3) Click on the required item in the *Selection* list, which shows all the items of the selected type. In the *Format* list, choose the format required. Usually this will be **Reference** (to insert the full text of the heading or caption), **Category and Number** (to insert the word “Figure” or “Table” and its number, but without the caption text), Numbering (to insert only the figure or table number, without the word “Figure” or “Table”), or **Page** (to insert the number of the page the referenced text is on). Click **Insert**.

---

**Using bookmarks**

Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse click. You can cross-reference to bookmarks, as described above. In HTML documents, bookmarks are converted to anchors that you can jump to using a hyperlink.

1) Select the text you want to bookmark. Click **Insert > Bookmark**.

2) On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks. Type a name for this bookmark in the top box, and then click **OK** to save.

![Insert Bookmark dialog]

*Figure 40: Inserting a bookmark*