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What is OpenOffice.org?
OpenOffice.org (OOo) is both a software product and a community of 
volunteers who produce and support the software.

Note
Because someone else owns the trademark OpenOffice, the 
correct name for both the open-source project and its software is 
OpenOffice.org.

The OpenOffice.org software is a freely available, full-featured office 
suite.

OOo 3 is a major upgrade of an already feature-rich office suite. If you 
have used previous versions of OOo, please look over the new features 
list on the OOo wiki.

OOo’s native file format is OpenDocument, an open standard format 
that is being adopted by governments worldwide as a required file 
format for publishing and accepting documents. OOo can also open 
and save documents in many other formats, including those used by 
several versions of Microsoft Office.

OOo includes the following components.

Writer (word processor)
Writer is a feature-rich tool for creating letters, books, reports, 
newsletters, brochures, and other documents. You can insert graphics 
and objects from other components into Writer documents. Writer can 
export files to HTML, XHTML, XML, Adobe’s Portable Document 
Format (PDF), and several versions of Microsoft Word files. It also 
connects to your email client.

Calc (spreadsheet)
Calc has all of the advanced analysis, charting and decision-making 
features expected from a high-end spreadsheet. It includes over 300 
functions for financial, statistical, and mathematical operations, among 
others. The Scenario Manager provides “what if” analyses. Calc 
generates 2-D and 3-D charts, which can be integrated into other OOo 
documents. You can also open and work with Microsoft Excel 
workbooks and save them in Excel format. Calc can export 
spreadsheets to Adobe’s PDF and to HTML.
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Impress (presentations)
Impress provides all the common multimedia presentation tools, such 
as special effects, animation, and drawing tools. It is integrated with 
the advanced graphics capabilities of OOo’s Draw and Math 
components. Slideshows can be further enhanced with Fontwork’s 
special effects text, as well as sound and video clips. Impress is 
compatible with Microsoft’s PowerPoint file format and can also save 
your work in numerous graphics formats, including Macromedia Flash 
(SWF).

Draw (vector graphics)
Draw is a vector drawing tool that can produce everything from simple 
diagrams or flowcharts to 3-D artwork. Its Smart Connectors feature 
allows you to define your own connection points. You can use Draw to 
create drawings for use in any of OOo’s other components, and you can 
create your own clipart and add it to the Gallery. Draw can import 
graphics from many common formats and save them in over 20 formats 
including PNG, HTML, PDF, and Flash.

Base (database)
Base provides tools for day-to-day database work within a simple 
interface. It can create and edit forms, reports, queries, tables, views, 
and relations, so that managing a connected database is much the 
same as in other popular database applications. Base provides many 
new features, such as the ability to analyze and edit relationships from 
a diagram view. Base incorporates HSQLDB as its default relational 
database engine. It can also use dBASE, Microsoft Access, MySQL, or 
Oracle, or any ODBC- or JDBC-compliant database. Base also provides 
support for a subset of ANSI-92 SQL.

Math (formula editor)
Math is OOo’s formula or equation editor. You can use it to create 
complex equations that include symbols or characters not available in 
standard font sets. While it is most commonly used to create formulas 
in other documents, such as Writer and Impress files, Math can also 
work as a stand-alone tool. You can save formulas in the standard 
Mathematical Markup Language (MathML) format for inclusion in 
webpages and other documents not created by OOo.
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The advantages of OpenOffice.org
Here are some of the advantages of OpenOffice.org over other office 
suites:

• No licensing fees. OOo is free for anyone to use and distribute at 
no cost. Many features that are available as extra cost add-ins in 
other office suites (like PDF export) are free with OOo. There are 
no hidden charges now or in the future.

• Open source. You can distribute, copy, and modify the software 
as much as you wish, in accordance with either of OOo’s Open 
Source licenses.

• Cross-platform. OOo3 runs on several hardware architectures 
and under multiple operating systems, such as Microsoft 
Windows, Mac OS X, Linux, and Sun Solaris.

• Extensive language support. OOo’s user interface is available 
in over 40 languages, and the OOo project provides spelling, 
hyphenation, and thesaurus dictionaries in over 70 languages and 
dialects. OOo also provides support for both Complex Text Layout 
(CTL) and Right to Left (RTL) layout languages (such as Hindi, 
Hebrew, and Arabic).

• Consistent user interface. All the components have a similar 
“look and feel,” making them easy to use and master.

• Integration. The components of OpenOffice.org are well 
integrated with one another.
– All the components share a common spelling checker and 

other tools, which are used consistently across the suite. For 
example, the drawing tools available in Writer are also found 
in Calc, with similar but enhanced versions in Impress and 
Draw.

– You do not need to know which application was used to create 
a particular file (for example, you can open a Draw file from 
Writer).

• Granularity. Usually, if you change an option, it affects all 
components. However, OOo options can be set at a component 
level or even document level.

• File compatibility. In addition to its native OpenDocument 
formats, OOo includes PDF and Flash export capabilities, as well 
as support for opening and saving files in many common formats 
including Microsoft Office, HTML, XML, WordPerfect, and Lotus 
123 formats. New in OOo3 (using an extension): the ability to 
import and edit some PDF files.
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• No vendor lock-in. OOo3 uses OpenDocument, an XML 
(eXtensible Markup Language) file format developed as an 
industry standard by OASIS (Organization for the Advancement of 
Structured Information Standards). These files can easily be 
unzipped and read by any text editor, and their framework is open 
and published.

• You have a voice. Enhancements, software fixes, and release 
dates are community-driven. You can join the community and 
affect the course of the product you use.

You can read more about OpenOffice.org, its mission, history, licensing, 
and other organizational information on the OpenOffice.org website.

Minimum requirements
OpenOffice.org 3 requires one of the following operating systems:

• Microsoft Windows 98, Windows ME, Windows 2000 (Service 
Pack 2 or higher), Windows XP, Windows 2003, or Windows Vista

• GNU/Linux Kernel version 2.2.13 and glibc 2.2.0 or newer
• Mac OS X 10.4.x, X11 required; Mac OS X 10.5+ without X11
• Solaris version 8 or higher

Some OpenOffice.org features (wizards and the HSQLDB database 
engine) require that the Java Runtime Environment (JRE) be installed 
on your computer. Although OOo will work fine without Java support, 
some features will not be available. You can download OOo with or 
without JRE included. If you have a slow machine and do not often 
need the features requiring JRE, you can try to disable it to speed up 
the loading of the program.

For a more detailed (and up-to-date) listing of requirements, see 
 http://www.openoffice.org/dev_docs/source/sys_reqs_30.html.

How to get the software
Many new computers come with OpenOffice.org installed. In addition, 
most Linux distributions, such as Ubuntu, include OpenOffice.org.
If you need to install it yourself, it’s very easy to do. You can download 
the OpenOffice.org installation package from the project’s home page 
or by using a Peer to Peer client such as BitTorrent. Instructions for 
BitTorrent are here.
The installation package is approximately 150MB. People with slow 
Internet connections may prefer to purchase a copy on a CD or DVD 
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from a third-party distributor. The project maintains a list of 
distributors, but the distributors are not connected with, nor endorsed 
by, OpenOffice.org.

How to install the software
Information on installing and setting up OpenOffice.org on the various 
supported operating systems is given here: 
http://download.openoffice.org/ common/instructions.html

You can also download the more detailed Setup Guide (in several 
languages) from http://documentation. 
openoffice.org/setup_guide2/index.html

How to get help
This book and the other OOo user guides and help and user support 
systems assume that you are familiar with your computer and basic 
functions such as starting a program, opening and saving files.

Help system
OOo comes with an extensive Help system. This is your first line of 
support for using OOo.

To display the full Help system, press F1 or select OpenOffice.org 
Help from the Help menu. In addition, you can choose whether to 
activate tooltips, extended tips, and the Help Agent (using Tools > 
Options > General).

If tooltips are enabled, place the mouse pointer over any of the icons to 
see a small box (“tooltip”) with a brief explanation of the icon’s 
function. For a more detailed explanation, select Help > What's This? 
and hold the pointer over the icon.

Free online support
The OpenOffice.org community not only develops software, but 
provides free, volunteer-based support. Users of OOo can get 
comprehensive online support from community venues such as 
newsgroups, forums, or mailing lists. There are also numerous 
websites run by users that offer free tips and tutorials.
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Free OpenOffice.org support

Users Mailing List

Free community support provided by a network of 
hundreds of experienced users. You must be 
subscribed to post messages. To subscribe, send a 
blank email to 
users-subscribe@openoffice.org
List archives are here:
http://www.openoffice.org/servlets/ SummarizeList? 
listName=users

Documentation 
Project

Templates, user guides, how-tos, and other 
documentation. http://documentation.openoffice.org/
See also the Documentation wiki, 
http://wiki.services.openoffice.org/ 
wiki/Documentation

Native Language 
Project

Information, resources, and mail lists in your 
language. 
http://projects.openoffice.org/native-lang.html

Mac Support Support for installing and using OOo on Mac OS X. 
http://porting.openoffice.org/mac/index.html

OpenOffice.org 
Community Forum

Extensive discussion forum for OpenOffice.org issues 
from setup to advanced programming features. 
http://user.services.openoffice.org/en/forum/

OpenOffice.org 
Macro Information

Andrew Pitonyak, the author of OpenOffice.org 
Macros Explained, maintains this site which provides 
extensive documentation on OOo's macro capability. 
Many good referral links are also provided: 
http://www.pitonyak.org/oo.php

Read more about the support options for OOo at 
http://support.openoffice.org/index.html

Paid support and training
Alternatively, you can pay for support services. Service contracts can 
be purchased from a vendor or consulting firm specializing in 
OpenOffice.org. 

OOo is supported by Sun Microsystems, Inc. under the Sun Software 
Support program, which includes two levels of support that cover 
extended business hours or around-the-clock service for mission-
critical deployments.
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A list of independent consultants and the services they offer, listed 
alphabetically by region and then by country, is provided on the 
OpenOffice.org website.

Extensions and add-ons
Several websites provide extensions and add-ons to enhance 
OpenOffice.org. The following table lists a few of these websites. See 
Chapter 14 (Customizing OpenOffice.org) for more information.

Free OOo templates, artwork, addons, and other resources

OpenOffice.org 
Extensions

The official repository for extensions to OOo. 
Most are free, but some are not. 
http://extensions.services.openoffice.org/

OOExtras
Provides templates, samples, and macros in 
several languages. 
http://ooextras.sourceforge.net/

OOoMacros
A repository for OOo macros and add-ons and 
documentation about writing macros or 
extending OOo. http://www.ooomacros.org/

Open Clip Art Library An archive of clip art that can be used for free 
for any use. http://www.openclipart.org/

Starting OpenOffice.org
The most common way to launch any component of OOo is by using the 
system menu, the standard menu from which most applications are 
started. On Windows, it is called the Start menu. On GNOME, it is 
called the Applications menu. On KDE it is identified by the KDE logo. 
On Mac OS X, it is the Applications menu.

When OOo was installed on your computer, in most cases a menu entry 
for each component was added to your system menu. (If you are using 
a Mac, see note below.) The exact name and location of these menu 
entries depends on the operating system and graphical user interface.

Note for Mac users
You should see the OpenOffice.org icon in the Applications folder. 
When you double-click this icon, a text document opens in Writer. To 
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open the other components (Draw, Calc, Impress, Base), go to the File 
menu of the Writer window and select the component you want.

OOo does not automatically put a shortcut icon on the desktop, but you 
can add one if you wish. If you don’t know how to add shortcut icons 
for launching programs, please consult the help for your operating 
system.

Starting from an existing document
You can start OOo by double-clicking the filename of an OOo document 
in a file manager such as Windows Explorer. The appropriate 
component of OOo will start and the document will be loaded.

Note for Windows users
If you have associated Microsoft Office file types with OOo, then when 
you double-click on a *.doc (Word) file, it opens in Writer; *.xls (Excel) 
files open in Calc, and *.ppt (Powerpoint) files open in Impress.

If you did not associate the file types, then when you double-click on a 
Microsoft Word document, it opens in Microsoft Word (if Word is 
installed on your computer), Excel files open in Excel, and Powerpoint 
files open in Powerpoint.

You can use another method to open Microsoft Office files in OOo and 
save in those formats from OOo. See “Opening an existing document” 
on page 20 for more information.

Using the Quickstarter under Windows
The Quickstarter is an icon that is placed in the Windows system tray 
during system startup. It indicates that OpenOffice.org has been 
loaded and is ready to use. (The Quickstarter loads library .DLL files 
required by OOo, thus shortening the startup time for OOo components 
by about half.) If the Quickstarter is disabled, see “Reactivating the
Quickstarter” if you want to enable it.

Using the Quickstarter icon
Right-click the Quickstarter icon in the system tray to open a pop-up 
menu from which you can open a new document, open the Templates 
and Documents dialog, or choose an existing document to open. You 
can also double-click the Quickstarter icon to display the Templates 
and Documents dialog.
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Figure 1: Quickstarter popup menu

Disabling the Quickstarter
To close the Quickstarter, right-click on the icon in the system tray, and 
then click Exit Quickstarter on the pop-up menu. The next time the 
computer is restarted, the Quickstarter will be loaded again.

To prevent OpenOffice.org from loading during system startup, 
deselect the Load OpenOffice.org during system start-up item on 
the pop-up menu. You might want to do this if your computer has 
insufficient memory, for example.

Reactivating the Quickstarter
If the Quickstarter has been disabled, you can reactivate it by selecting 
the Load OpenOffice.org during system start-up checkbox in Tools 
> Options > OpenOffice.org > Memory.

Using the Quickstarter in Linux
Some installations of OpenOffice.org under Linux have a Quickstarter 
that looks and acts like the one described above for Windows (the 
checkbox on the Memory page is labeled Enable systray 
quickstarter).

Preloading OOo under Linux/KDE
In Linux/KDE, you can use KDocker to have OOo loaded and ready for 
use at startup. KDocker is not part of OOo; it is a generic “systray app 
docker” that is helpful if you open OOo often.
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Starting from the command line
You may want to start OOo from the command line (using the keyboard 
instead of the mouse). Why? Well, by using the command line, you have 
more control over what happens when OOo is started. For example, 
using the command line, you can tell Writer to load a document and 
print it immediately, or to start without showing the splash screen.

Note Most users will never need to do this.

There is more than one way to start OOo from the command line, 
depending on whether you have installed a customized version or the 
standard download from the OOo website.

If you installed using the download on the OOo website, you can start 
Writer by typing at the command line:

soffice -writer
or 

swriter

Writer will start and create a new document. Likewise, you can start 
other OOo components from the command line:

Type of document Component Command-line option

Text Writer -writer

Spreadsheet Calc -calc

Drawing Draw -draw

Presentation Impress -impress

Formula Math -math

Web page Writer -web

To see a list of options you can use when starting Writer at the 
command line, type:

soffice -?

Below is a list of some of the more popular options.
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Option Description

-help Get a complete list of options.

-nologo Do not show the startup screen.

-show <odp-file> Start presentation immediately.

-view <documents ...> Open documents in viewer (read-only) mode.

-minimized Start OOo minimized.

-norestore Suppress restart/restore after fatal errors.

-invisible No startup screen, no default document and 
no UI. This is useful for third-party 
applications that use functionality provided 
by OOo.

If you have a customized version of OOo (such as the one provided by 
Linux Mandrake or Gentoo), you can start Writer by typing at the 
command line:

oowriter

Note
Although the command syntax differs, the effect is identical: it 
starts OOo with an empty Writer document.

Parts of the main window
The main window is similar in each component of OOo, although some 
details vary. See the component chapters in this book for descriptions 
of those details.

Common features include the menu bar, standard toolbar, and 
formatting toolbar at the top of the window and the status bar at the 
bottom.

Menu bar
The Menu bar is located across the top of the screen, just below the 
Title bar. When you choose one of the menus, a submenu drops down 
to show commands.

• File contains commands that apply to the entire document such 
as Open, Save, and Export as PDF.

• Edit contains commands for editing the document such as Undo 
and Find & Replace. It also contains commands to cut, copy and 
paste selected parts of your document.
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• View contains commands for controlling the display of the 
document such as Zoom and Web Layout.

• Insert contains commands for inserting elements into your 
document such as Header, Footer, and Picture.

• Format contains commands, such as Styles and Formatting and 
AutoFormat, for formatting the layout of your document.

• Table shows all commands to insert and edit a table in a text 
document.

• Tools contains functions such as Spelling and Grammar, 
Customize, and Options.

• Window contains commands for the display window.
• Help contains links to the OpenOffice.org Help file, What’s This?, 

and information about the program.

Toolbars
OOo has several types of toolbars: docked, floating, and tear-off. 
Docked toolbars can be moved to different locations or made to float, 
and floating toolbars can be docked.

The top docked toolbar (default position) is called the Standard 
toolbar. The Standard toolbar is consistent across the OpenOffice.org 
applications.

The second toolbar across the top (default location) is the Formatting 
toolbar. It is a context-sensitive bar that shows the relevant tools in 
response to the cursor’s current position or selection. For example, 
when the cursor is on a graphic, the Formatting bar provides tools for 
formatting graphics; when the cursor is in text, the tools are for 
formatting text.

Displaying or hiding toolbars
To display or hide toolbars, choose View > Toolbars, then click on the 
name of a toolbar in the list. An active toolbar shows a checkmark 
beside its name. Tear-off toolbars are not listed in the View menu.

Submenus and tear-off toolbars
Toolbar icons with a small triangle to the right will display submenus, 
tear-off toolbars, and other ways of selecting things, depending on the 
icon.

Figure 2 shows a tear-off toolbar from the Drawing toolbar.
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The tear-off toolbars can be floating or docked along an edge of the 
screen or in one of the existing toolbar areas. To move a floating tear-
off toolbar, drag it by the title bar. See “Moving toolbars” below.

Figure 2: Example of a tear-off toolbar

Moving toolbars
To move a docked toolbar, place the mouse pointer over the toolbar 
handle, hold down the left mouse button, drag the toolbar to the new 
location, and then release the mouse button (Figure 3).

To move a floating toolbar, click on its title bar and drag it to a new 
location (Figure 4).

Figure 3: Moving a docked toolbar

Figure 4: Moving a floating toolbar
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Floating toolbars
OOo includes several additional context-sensitive toolbars, whose 
defaults appear as floating toolbars in response to the cursor’s current 
position or selection. For example, when the cursor is in a table, a 
floating Table toolbar appears, and when the cursor is in a numbered 
or bullet list, the Bullets and Numbering toolbar appears. You can dock 
these toolbars to the top, bottom, or side of the window, if you wish 
(see “Moving toolbars” on page 17).

Docking/floating windows and toolbars
Toolbars and some windows, such as the Navigator and the Styles and 
Formatting window, are dockable. You can move, re-size or dock them 
to an edge.

To dock a window or toolbar, do one of 
the following:

• Click on the title bar of the 
floating window and drag it to 
the side until you see the outline 
of a box appear in the main 
window, then release the window. 
This method depends on your 
system’s window manager 
settings, so it may not work for 
you.

• Hold down the Control key and 
double-click on a vacant part of 
the floating window to dock it in 
its last position. If that does not 
work, try double-clicking without 
using the Control key.

To undock a window, hold down the 
Control key and double-click on a 
vacant part of the docked window.

Note
The Styles and Formatting window can also be docked or 
undocked by using Control+double-click on the gray area next 
to the icons at the top of the window.
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Customizing toolbars
You can customize toolbars in several ways, including choosing which 
icons are visible and locking the position of a docked toolbar. You can 
also add icons and create new toolbars, as described in Chapter 14.

To access a toolbar’s customization options, use the down-arrow at the 
end of the toolbar or on its title bar (see Figure 6).

Figure 6: Customizing toolbars

To show or hide icons defined for the selected toolbar, choose Visible 
Buttons from the drop-down menu. Visible icons have a checkmark 
next to them. Click on icons to select or deselect them.

Right-click (context) menus
You can quickly access many menu functions by right-clicking on a 
paragraph, graphics, or other object. A context menu will pop up. 
Often the context menu is the fastest and easier way to reach a 
function. If you’re not sure where in the menus or toolbars a function is 
located, you can often find it by right-clicking.

Starting a new document
You can create a new, blank document in OOo in several ways.

When OOo is open but no document is open (for example if you close 
all the open documents but leave the program running), a Welcome 
screen is shown. Click one of the icons to open a new document of that 
type, or click the Templates icon to start a new document using a 
template.

You can also start a new document in one of the following ways. If a 
document is already open in OOo, the new document opens in a new 
window.

• Use File > New and choose the type of document.
• Use the arrow next to the New button on the main toolbar. From 

the drop-down menu, select the type of document to be created.
• Press Control+N on the keyboard.
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• Use File > Wizards for some types of documents.

Opening an existing document
When no document is open, the Welcome screen provides an icon for 
opening an existing document.

You can also open an existing document in one of the following ways. If 
a document is already open in OOo, the second document opens in a 
new window.

• Click File > Open.
• Click the Open button on the main toolbar.
• Press Control+O on the keyboard.

In each case, the Open dialog appears. Select the file you want, and 
then click Open.

In the Open dialog, you can reduce the list of files by selecting the type 
of file you are looking for. For example, if you choose Text documents 
as the file type, you will only see documents Writer can open (including 
.odt, .doc, .txt); if you choose Spreadsheets, you will see .ods, .xsl, and 
other files that Calc opens.

You can also open an existing document that is in an OpenDocument 
format by double-clicking on the file’s icon on the desktop or in a file 
manager such as Windows Explorer.

If you have associated Microsoft Office file formats with OOo, you can 
also open these files by double-clicking on them.

Note
Under Microsoft Windows you can use either the OOo Open and 
Save As dialogs or the ones provided by Microsoft Windows. 
See “Using the Open and Save As dialogs” on page 22.

Saving documents
To save a new document:

1) Choose File > Save.
2) When the Save As dialog appears, enter the file name and verify 

the file type (if applicable).

To save an open document with the current file name, choose File > 
Save. This will overwrite the last saved state of the file.
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Password protection
To protect an entire document from being viewable without a 
password, use the option on the Save As dialog to enter a password. 
This option is only available for files saved in OpenDocument formats 
or the older OpenOffice.org 1.x formats.

1) On the Save As dialog, select the checkbox beside Save with 
password, and then click Save. You will receive a prompt:

2) Type the same password in the Password field and the Confirm 
field, and then click OK. If the passwords match, the document is 
saved password protected. If the passwords do not match, you 
receive the prompt to enter the password again.

Note
Passwords must contain a minimum of 5 characters. Until you 
have entered 5 characters, the OK button remains inactive.

OOo uses a very strong encryption mechanism which makes it almost 
impossible to recover the contents of a document in case you lose the 
password.

Saving a document automatically
You can choose to have OpenOffice.org save files for you automatically. 
Automatic saving, like manual saving, overwrites the last saved state of 
the file. To set up automatic file saving:

1) Choose Tools > Options > Load/Save > General.
2) Mark Save AutoRecovery information every, and set the time 

interval.

Renaming and deleting files
You can rename or delete files within the OOo dialogs, just as you can 
in your usual file manager. However, you cannot copy or paste files 
within the dialogs.
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Using the Open and Save As dialogs
You can choose whether to use the OpenOffice.org Open and Save As 
dialogs or the ones provided by your operating system. To view or 
change which type of dialog OpenOffice.org uses:

1) Choose Tools > Options > OpenOffice.org > General.
2) Select the Use OpenOffice.org dialogs checkbox.

This section discusses the OpenOffice.org Open and Save As dialogs. 
See Figure 7 for an example of the Save As dialog; the Open dialog is 
similar.

The three buttons in the top right of the OOo Open and Save As dialogs 
are, from left to right:

• Go Up One Level in the folder (directory) hierarchy. This is a 
long-click button if you want to go up higher than just one level.

• Create New Folder.
• View Menu.

Figure 7: The OpenOffice.org Save As dialog, showing 
some of the Save formats
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For OpenOffice.org documents that have been saved with more than 
one version, use the version drop-down to select which version you 
wish to open in read-only mode. For Microsoft Office documents, only 
the current version can be opened.

Use the Files of type field to specify the type of file to be opened or 
the format of the file to be saved.

The Read-only checkbox opens the file for reading and printing only. 
Consequently, most of the toolbars disappear, and most menu options 
are disabled. An Edit File button is displayed on the Standard toolbar 
to open the file for editing.

It is possible to open files from the Web using URLs.

Using the Navigator
The Navigator displays all objects contained in a document, collected 
into categories. For example, in Writer it displays Headings, Tables, 
Text frames, Notes, Graphics, Bookmarks, and other items (see 
Figure 8.

Figure 8: The Navigator

In Calc it shows Sheets, Range Names, Database Ranges, Graphics, 
Drawing Objects, and other items. In Impress and Draw it shows 
Slides, Pictures, and other items. Click the + sign by any of the 
categories to display the list of objects in that category.
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To open the Navigator, click its icon on the Standard toolbar, or 
press F5, or choose Edit > Navigator on the main menu bar. You can 
dock the Navigator to either side of the main OOo window or leave it 
floating (see “Docking/floating windows and toolbars“ on page 18).

To hide the list of categories and show only the toolbars at the top, 

click the List Box On/Off icon ( ). Click this icon again to show the 
list box.

The Navigator provides several convenient ways to move around a 
document and find items in it:

• When a category is showing the list of objects in it, double-click 
on an object to jump directly to that object’s location in the 
document. Objects are much easier to find if you have given them 
names when creating them, instead of keeping OOo’s default 
graphics1, graphics2, Table1, Table2, and so on—which may not 
correspond to the position of the object in the document.
If you only want to see the content in a certain category, highlight 
the category and click the Content View icon. Until you click the 
icon again, only the objects of that category will be displayed.

• Click the  (second icon from the left at the top of the 
Navigator) to display the Navigation toolbar (Figure 9). Here you 
can pick one of the categories and use the Previous and Next 
icons to move from one item to the next. This is particularly 
helpful for finding items like bookmarks and indexes, which can 
be difficult to see. The names of the icons (shown in the tooltips) 
change to match the selected category; for example, Next 
Graphic or Next Bookmark.

Figure 9: Navigation toolbar

• To jump to a specific page in the document, type its page number 
in the box at the top of the Navigator.

A bit of experimentation with the other icons will demonstrate their 
functions. Some component-specific uses are described in the chapters 
on Writer and the other components.
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Closing a document
To close a document, click File > Close.

You can also close a document by clicking on the Close icon on the 
document window. This button looks like the red X shown in Figure 10.

If more than one OOo window is open, each window looks like the 
sample shown on the left in Figure 10. Closing this window leaves the 
other OOo windows open.

If only one OOo window is open, it looks like the sample shown on the 
right in Figure 10. Notice the small black X below the large red X. 
Clicking the small X closes the document but leaves OOo open. 
Clicking the large red X closes OOo completely.

Figure 10. Close icons 

If the document has not been saved since the last change, a message 
box is displayed. Choose whether to save or discard your changes.

• Save: The document is saved and then closed.
• Discard: The document is closed, and all modifications since the 

last save are lost.
• Cancel: Nothing happens, and you return to the document.

Caution Not saving your document could result in the loss of recently 
made changes, or worse still, your entire file.

Closing OpenOffice.org
To close OOo completely, click File > Exit, or close the last open 
document as described in “Closing a document” on page 25.

If all the documents have been saved, OOo closes immediately. If any 
documents have been modified but not saved, a warning message 
appears. Follow the procedure in “Closing a document” to save or 
discard your changes.
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