# Contents

Overview ........................................................................................................................................... ii

Feedback ........................................................................................................................................ ii

Acknowledgments ....................................................................................................................... ii

Modifications and updates ........................................................................................................... ii

Creating a table of contents ........................................................................................................ 1

Opening Writer’s table of contents feature ................................................................................ 1

Using the Index/Table tab ............................................................................................................ 2

Using the Entries tab ................................................................................................................... 4

Using the Styles tab ..................................................................................................................... 6

Using the Columns tab ................................................................................................................ 7

Using the Background tab ......................................................................................................... 8

Saving the table of contents ...................................................................................................... 9

Maintaining a table of contents ................................................................................................... 10

Editing a table of contents ......................................................................................................... 10

Updating a table of contents ....................................................................................................... 10

Deleting a table of contents ....................................................................................................... 10

Creating an alphabetic index ...................................................................................................... 11

Adding index entries .................................................................................................................. 11

Inserting an index into the document ........................................................................................ 13

Generating the index ................................................................................................................ 16

Modifying the display of index entries ...................................................................................... 16

Viewing and editing existing index entries ................................................................................ 17

Creating and using other types of indexes ................................................................................ 18

Creating a bibliography ............................................................................................................. 19

Creating, adding and maintaining entries within a bibliographic database ......................... 19

Adding a reference (citation) into a document .......................................................................... 22

Formating the bibliography ....................................................................................................... 22

Generating the bibliography ..................................................................................................... 25

Updating and editing an existing bibliography ......................................................................... 25
Overview

This chapter shows you step-by-step how to create and maintain a table of contents, an index and a bibliography for a text document using OpenOffice.org Writer 1.1.X. To understand the instructions, you need to have a basic familiarity with Writer and styles.

Copyright and trademark information

The contents of this Documentation are subject to the Public Documentation License, Version 1.0 (the "License"); you may only use this Documentation if you comply with the terms of this License. A copy of the License is available at: http://www.openoffice.org/licenses/PDL.rtf.

The Original Documentation is Creating and Maintaining a Table of Contents, Index and Bibliography. The Initial Writer of the Original Documentation is Catherine Waterman © 2004. All Rights Reserved. (Initial Writer contact: sparkovich@att.net.)

Portions covering Index and Bibliographies created by Paul Miller are Copyright © 2004. All Rights Reserved. (Contact: paul_m_nz@hotmail.com.)

Contact the Initial Writers only to report errors in the documentation. For questions regarding how to use the software, subscribe to the Users Mail List and post your question there: http://support.openoffice.org/index.html.

All trademarks within this guide belong to legitimate owners.

Feedback

Please direct any comments or suggestions about this document to: authors@user-faq.openoffice.org.

Acknowledgments

Thanks to Sophie Gautier, author of the French native-language document, Comment insérer une Table des Matières, which was used as a reference.

Many thanks to Jean Hollis Weber, who has provided, as a reference, details concerning creation and style for indexes and bibliographies.

Modifications and updates

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td></td>
<td>First published edition.</td>
</tr>
</tbody>
</table>
Creating a table of contents

Writer’s table of contents feature lets you build an automated table of contents from the headings in your document. Before you start, make sure that the headings in your document are styled consistently. For example, you can use the Heading 1 style for chapter titles and the Heading 2 and Heading 3 styles for chapter subheadings.

This section shows you how to:

• Open Writer’s table of contents feature.
• Use Writer’s table of contents feature to customize your document’s table of contents.
• Save the table of contents.

Opening Writer’s table of contents feature

To open Writer’s table of contents feature and insert a new table of contents in your document, follow these steps:

1) Place the cursor at the point in your document when you want to insert the table of contents.

2) From the main menu, choose Insert > Indexes and Tables > Indexes and Tables. The Insert Index/Table window opens.

3) Click the Index/Table tab if it isn’t already displayed.

![Figure 1. Index/Table tab of Insert Index/Table dialog](image)
Creating a table of contents

The Insert Index/Table window (Figure 1) has five tabs. All of them can be used when creating a table of contents:

- Use the **Index/Table** tab to set the attributes of the table of contents.
- Use the **Entries** and **Styles** tabs to format the entries in the table of contents.
- Use the **Background** tab to add color or a graphic to the background of the table of contents.
- Use the **Columns** to put the table of contents into a number of individual columns.

The preview box, located on the left-hand side of each tab, shows as you work how the table of contents will look. (If you don’t see the preview box, select the **Preview** checkbox in the lower right-hand corner of the window.)

**Using the Index/Table tab**

Use the **Index/Table** tab, pictured in Figure 1, to set the attributes of the table of contents.

**Setting basic attributes**

To set the basic attributes of the table of contents:

1) From the **Type** drop-down list in the **Type and title** area of the tab, select **Table of Contents** if it isn’t already selected.

2) From the drop-down list in the **Create index/table** area, select **Entire document**. There is an additional option to create a table for just the current chapter. For more information refer to **Help > Contents**.

3) In the **Create from** area, check the **Outline** checkbox.

4) In the **Create from** area, clear the **Index marks** checkbox.

**Adding a title**

If you’d like the table of contents to have a title, enter it in the **Title** field. (If Writer entered a title in this field automatically, you can change it by simply typing over the value.) To delete the title, clear the **Title** field.

**Protecting against manual changes**

To protect the table of contents from being changed accidentally, select the **Protected against manual changes** checkbox. If this box is checked, the table of contents can only be changed using the context menu or the Insert Table/Index window. If the box isn’t checked, the table of contents can be changed directly on the document page, just like other text.

**Changing the number of levels**

By default, Writer evaluates 10 levels of headings when it builds the table of contents. To change the number of levels evaluated, enter the desired number in the **Evaluate up to level** spin box.
Assigning custom styles

Writer automatically assigns to the table of contents all paragraphs formatted with the default heading styles (Heading 1, Heading 2, and so on). To assign paragraphs formatted with custom styles, follow these steps:

1) In the Create from area, select the Additional Styles checkbox.

2) Click the (...) button to the right of the checkbox. The Assign Styles window (Figure 2) opens.

3) In the Not applied column, click the style that you want to assign to the table of contents.

4) Use the >> button to move the selected style to the desired outline level. For example, if you want paragraphs formatted with the selected style to appear as top-level entries in the table of contents, click the >> button once to move the style into the 1 column. To move the style in the opposite direction, use the << button.

5) Click OK to save your changes and return to the Index/Table tab, or click Cancel to return without saving your changes.
Using the Entries tab

Use the Entries tab, pictured in Figure 3, to format the entries in the table of contents. For each outline level, you can add and delete elements, such as chapter numbers, and you can also apply character styles to individual elements.

![Entries tab of Insert Index/Table dialog](image)

To begin, click a level number in the Level column to select the outline level whose elements you want to format. (You’ll be able to apply your changes to all outline levels later.) The Structure line displays the elements for entries in that level. Each button on the Structure line represents one element:

- The E# button represents the chapter number.
- The E button represents the entry text.
- The T button represents a tab stop.
- The # button represents the page number.
- The LS button represents the start of a hyperlink. (This button doesn’t appear on the default Structure line.)
- The LE button represents the end of a hyperlink. (This button doesn’t appear on the default Structure line.)

Each white field on the Structure line represents a blank space.

Note: If the chapter number defined for your document includes the word “Chapter” before the number itself, then the E# field in the table of contents will also include the word “Chapter”. If you want to include the chapter number with the page number (for example, in the style “1-1, 1-2, ...”), you will find that the page number appears in the table of contents as “Chapter 1-1”, which is probably not what you want.
Deleting elements
To delete an element from the Structure line, click the button that represents that element and then press the Delete key on your keyboard. For example, to delete a tab stop, click the T button and then press the Delete key.

Adding elements
To add an element to the Structure line, follow these steps:

1) Place your cursor in the white field to the left of where you want to insert the element.
2) Click one of the five buttons that are just below the Structure line. (For example, to add a tab stop, click the Tab stop button.) A button representing the new element appears on the Structure line.

Note that if you insert a hyperlink, you must indicate both the beginning and end of the link. For example, to change the default Structure line so that the chapter number and the entry text form a hyperlink, follow these steps:

1) On the Structure line, place your cursor in the white field to the left of the E# button. (Recall that the E# button represents the chapter number.)
2) Click the Hyperlink button. An LS button, representing the start of the hyperlink, appears on the Structure line.
3) On the Structure line, place your cursor in the white field to the right of the E button. (Recall that the E button represents the entry text.)
4) Click the Hyperlink button again. An LE button, representing the end of the hyperlink, appears on the Structure line.

Applying character styles
To apply a character style to an element on the Structure line:

1) On the Structure line, click the button that represents the element to which you want to apply a style.
2) From the Character Style drop-down list, select the desired style. Writer applies the selected style to the selected element.

To view or edit the attributes of a character style, select the style from the Character Style drop-down list and then click the Edit button.

Applying changes to all outline levels
To apply the displayed structure and formatting to all outline levels, click the All button.

Tab position
When checked, this ensures that the entries are displayed indented according to the settings of their individual formats.
Using the Styles tab

Use the Styles tab, pictured in Figure 4, to apply paragraph styles to the table of contents. You can apply a different paragraph style to each outline level of the table.

To apply a paragraph style to an outline level, follow these steps:

1) In the Levels list box, select the desired outline level by clicking it.
2) In the Paragraph Styles list box, click the paragraph style that you want to apply.
3) Click the < button to apply the selected paragraph style to the selected outline level.

To remove paragraph styling from an outline level:

1) In the Levels list box, select the desired outline level by clicking it.
2) Click the Default button.

To view or edit the attributes of a paragraph style, click the style in the Paragraph Styles list box and then click the Edit button.
Creating a table of contents

Using the Columns tab

Use the Columns tab, pictured in Figure 5 to change the number of columns the table of contents is displayed in.

![Columns tab](image)

Figure 5. Columns tab

Adding multiple columns

To display the table of contents in more than one column (which is the default), follow these steps:

1) Either enter the number of columns desired in the box labeled as Columns, or select the icon that represents the number of columns wanted.

2) If you want the columns to be evenly distributed according to the page width, then the Autowidth box should be checked (which it is by default). If unchecked you can manually set each of the following by altering the associated spin box:
   - **Width** between each of the columns (if the default settings are not sufficient)
   - **Spacing** between each of the columns (if the default settings are not sufficient)

3) You can choose to have a separator line between the columns if required. The default is **none**; however this can be changed by selecting the following options
   - **Line**: The width of the line.
   - **Height**: The height of the line.
   - **Position**: Relative position of the line to the table (top, middle, or bottom), if the height is less than 100%.
From the As drop-down list, select Graphic. The Background tab displays the graphics options.

**Using the Background tab**

Use the Background tab, pictured in Figure 6, to add color or a graphic to the background of the table of contents.

**Adding color**

To add color to the background of the table of contents, simply click the desired color in the color grid.

![Figure 6. Background tab of Insert Index/Table dialog, showing Color choices](image)

**Adding a graphic**

To add a graphic to the background of the table of contents, follow these steps:

1) From the As drop-down list, select Graphic. The Background tab now displays the graphics options, as shown in Figure 7.

2) Click the Browse button. The Find Graphics window opens.

3) Find the graphic file that you want to use and then click the Open button. The Find Graphics window closes and the selected graphic appears in the graphic preview box on the right-hand side of the Background tab. (If you don’t see the graphic, check the Preview check box underneath the graphic preview box.)

4) In the Type area of the Background tab, choose how you want the background graphic to appear:
• To position the graphic in a specific location in the background, select **Position** and then click the desired location in the position grid.

• To stretch the graphic so that it fills the entire background area, select **Area**.

• To repeat the graphic across the entire background area, select **Tile**.

![Figure 7. Graphics options on the Background tab of the Insert Index/Table dialog](image)

**Deleting color or graphics**

To delete color or graphics from the table background, follow these steps:

1) From the **As** drop-down list, select **Color**.

2) Click **No Fill** on the color grid.

**Saving the table of contents**

To save the table of contents so that it appears in your document, click **OK**. The Insert Index/Table window closes and the table of contents appears in your document.
Maintaining a table of contents

This section shows you how to:

• Edit an existing table of contents.
• Update a table of contents when changes are made to the document.
• Delete a table of contents.

Editing a table of contents

To edit an existing table of contents:

1) Click anywhere in the table of contents and then right-click. The context menu appears.
2) From the context menu, choose Edit Index/Table. The Insert Index/Table window opens and you can edit and save the table using the four tabs described in the previous section.

Updating a table of contents

To update a document’s table of contents when changes are made to the document:

1) Click anywhere in the table of contents and then right-click. The context menu appears.
2) From the context menu, choose Update Index/Table. Writer updates the table of contents to reflect the changes in the document.

Note: Writer does not update the table of contents automatically. You must do it manually, as described above.

Deleting a table of contents

To delete the table of contents from a document:

1) Click anywhere in the table of contents and then right-click. The context menu appears.
2) From the context menu, choose Delete Index/Table. Writer deletes the table of contents.

Note: Writer won’t prompt you to confirm the delete! Use caution when deleting a table of contents.
Creating an alphabetic index

An alphabetic index is a useful tool for referencing entries (either words or phrases) throughout the document in a single place. This section shows you how to:

- Add index entries
- Create an alphabetic index
- Modify the display of index entries
- View and edit existing index entries

Adding index entries

In order to create an alphabetic index, you must first create some entries. Follow these steps to add these index entries:

1) Either highlight the word of phrase that you want to add to an index, or leave the cursor at the beginning of the word of phrase.

2) Select Insert > Indexes and Tables > Entry to display a dialog similar to that shown in Figure 8.

![Insert Index Entry dialog](image)

*Figure 8. Inserting Index entries*

The dialog can also be opened by selecting the Insert index marker on the toolbar shown after a long click on the Insert icon (as shown in Figure 9).
3) Below is a brief explanation of the fields and how to use them:

- **Index** – the type of index that is being created (default is Alphabetical).
- **Entry** – the word of phrase that is to be added (taken from the current document).
- **1st Key** – this is used for grouping similar entries (refer to further explanation below).
- **2nd Key** – as for 1st Key.
- **Main entry** – this defines whether the entry is the main one for the document. If this is to be the page numbered entry (if there are multiple instances in the document) then this should be checked.
- **Apply to all similar texts** – check this box if you want additional words within the document indexed. The sub checkboxes (Match case & Whole words only) become available if this is selected to refine how additional entries should be treated.

4) Click **Insert** to create the entry.

5) You can add multiple index entries by keeping the dialog open and overwriting the **Entry** field with additional words of phrases.

6) Once satisfied with the entries added, select **Close** to close the dialog box.

**Note:** Once a word of phrase has been added as an index, a gray background is added to each instance for easy reference.

**Key explanation**

If you wish to group similar words within the index, then you can define what word will be used as the keys.

For example, you might want to create an index similar to this:

```
OpenOffice.org
    Writer .......... 5
    Calc .......... 10
    Impress ....... 15
```

To achieve this, use *OpenOffice.org* as the 1st **Key**. The subentries (with the page numbers showing) are the indexed entries. You can also add a 2nd **Key** which adds another layer of grouping, but this is not commonly required.
Inserting an index into the document

Now that there are index entries, you can create the index using these steps:

1) Place the cursor where you want to add the index and click **Insert > Indexes and Tables > Indexes and tables**. Initially, the dialog as shown in Figure 1 on page 1 is displayed. From field **Type** select **Alphabetical Index** to ensure that the index context options are shown.

2) A dialog box similar to Figure 10 is shown.

There are five tabs concerned with the creation of an index. Each will be discussed separately in the following sections.

**Index/Table tab**

The basic settings are selected on this tab. Each of them is defined further:

1) If you’d like the Index to have a title, enter it in the **Title** field. (If Writer entered a title in this field automatically, you can change it by simply typing over the value.) To delete the title, clear the **Title** field.

![Figure 10. Main index/table dialog](image)

2) To protect the index from being changed accidentally, check the **Protected against manual changes** check box. If this box is checked, the index can only be changed using the context menu or the Insert Table/Index window. If the box isn’t checked, the index can be changed directly on the document page, just like other text.

3) From the drop-down list in the Create index/table area, select **Entire document**. There is an additional option to create an index for just the current chapter. For more information refer to **Help > Contents**.
4) Various other options can be selected based on how you want the index to handles entries:

- **Combine identical entries.** Defines how identical entries are dealt with. Normally each instance of an indexed word or phrase will be shown in the index, however these can be combined using the **Combine identical entries with p or pp.** If you want a page range displayed select **Combine with** - (which will produce something similar to (23-31)). **Case sensitive** should be selected if you want to different entries based on what letters are capitalized.

- **AutoCapitalize entries** – if you want writer to automatically capitalize entries regardless of how they show within the document itself.

- **Keys as separate entries** – if you wish to have the keys have their own page numbers, select this option.

- **Concordance file.** This enables a set listing of words to be imported (select using the **File** button and then used within the index. The concordance file has a special file format; for further information, refer to **Help > Contents**.

- **Sort.** This defines how the entries are sorted when displayed.

- When all options are set as wanted

Care should be used when using a concordance file since if not kept up to date there may be lots of out of date entries that are not relevant.

**Entries tab**

This tab deals with setting exactly how and what will be displayed for each of the entries. The screen is similar to Figure 11.

To begin, click a level number in the **Level** column to select the index level whose elements you want to format. (You’ll be able to apply your changes to all index levels later.) The **Structure** line displays the elements for entries in that level.

You probably want to keep all formatting the same regardless of the level and this can be done by selecting the **All** button once changes have been made.

Each button on the Structure line represents one element:

- The **E** button represents the entry text.
- The **T** button represents a tab stop.
- The **#** button represents the page number.
- The **CI** button represents chapter information. This may not be displayed immediately, but can be added.

Each white field on the Structure line represents a blank space.

To delete an element from the Structure line, click the button that represents that element and then press the **Delete** key on your keyboard. For example, to delete a tab stop, click the **T** button and then press the **Delete** key.
To add an element to the Structure line, follow these steps:

1) Place your cursor in the white field to the left of where you want to insert the element.

2) Click one of the buttons that are just below the Structure line. (For example, to add a tab stop, click the Tab stop button.) A button representing the new element appears on the Structure line.

Each of the items that can be added to the Structure line may have additional formatting that may be added. For example, you may wish to have the page number a different size font from the rest of the index text. To do this you need to apply a character style to one of the elements in the Structure.

To apply a character style to an element on the Structure line:

1) On the Structure line, click the button that represents the element to which you want to apply a style.

2) From the Character Style drop-down list, select the desired style. Writer applies the selected style to the selected element.

To view or edit the attributes of a character style, select the style from the Character Style drop-down list and then click the Edit button.

Figure 11. Entries tab for creating an alphabetical index

Additional formatting can be applied using the options in the Format section.
Creating an alphabetic index

- **Alphabetical delimiter.** This will display, as a means of separating index entries, the first letter of all the subsequent index entries. For example:

  A
  apple, 4
  author, 10
  B
  break, 2
  bus, 4

- **Key separated by commas.** Arranges the entries in the index on the same line but separated by commas.

- **Tab position relative to paragraph style indent.** When checked, this option ensures that the entries are displayed indented according to the settings of their individual formats.

**Styles tab**
Refer to “Using the Styles tab” on page 6, for how to use this tab.

**Columns tab**
Refer to “Using the Columns tab” on page 7, for how to use this tab.

**Background tab**
Refer to “Using the background tab” on page 8, for how to use this tab.

**Generating the index**
To generate the index so that it appears in your document, click **OK**. The Insert Index/Table window closes and the index appears in your document.

**Modifying the display of index entries**
To modify the display of index entries:

1) Click anywhere in the index and then right-click. The context menu appears.

2) From the context menu, choose **Edit Index/Table.** The Insert Index/Table window opens and you can edit and save the index using the five tabs described in the previous chapter.

To update index entries and delete the index, follow the process described in the sections “Updating a table of contents” and “Deleting a table of contents” on page 10.
viewing and editing existing index entries

Once you have added the initial entries you may wish to make some amendments or add some new ones. You can view and edit these using the following steps:

1) Place your cursor next to an existing index entry (they are shaded gray for convenience) and select Edit > Index Entry. Alternatively you can right-click on the word or phrase and from the context menu select Index Entry.

2) You will be presented with a dialog box similar to Figure 12,

3) You can move through the various index entries using the forward and back buttons (indicated on the Figure 12). If there is more than one entry for a single word or phrase then each of the entries will be scrolled through.

4) You can make the necessary modifications or additions to the index entries and, when finished, click OK.

![Edit Index Entry dialog box](image)

**Figure 12. Viewing and editing index entries**
Creating and using other types of indexes

An alphabetical index is not the only index that is built into Writer. There are various other types of indexes, including indexes for illustrations, tables and objects. There is also the option to create a user-defined index.

These can be created using the following steps:

1) Place your cursor where you want the index created.

2) On the Insert Index/Table dialog from Insert > Indexes and tables > Indexes and tables (shown in Figure 13), in the dropdown selection field, Type, select the index wanted,

![Figure 13. Creation of other types of indexes](Image)

3) Modify the various tabs, which are very similar to those discussed in previous sections,

4) Select OK once everything has been set and the index will be inserted.
Creating a bibliography

A bibliography is useful for displaying references used throughout a document. These are either stored in a bibliographic database or within the document itself.

This chapter shows you how to:

• Create, add and maintain entries within a bibliographic database
• Add a reference into a document
• Format the bibliography
• Update and edit an existing bibliography

Creating, adding and maintaining entries within a bibliographic database

Although you can use references within the document itself, creating a bibliographic database allows reuse in other documents and saves a lot of time.

For most of this section the database used is the sample one that comes with Writer.

Create a bibliographic database

Follow these steps to create a bibliographic database:

1) Select Tools > Bibliography database and a dialog similar to that shown in Figure 14 is shown.

2) The top portion of the screen can be used to filter for specific records within the database.
   • You can arrange the way the columns are laid out by selecting the Column Arrangement button.
   • You can select an alternative data source (another database or table) by selecting the Data Source button.

3) The middle portion of the screen shows each of the records in a layout similar to that of a spreadsheet. Additional fields can be viewed by scrolling the screen to the right.

4) The bottom portion of the screen shows the contents of the selected record.
Creating a bibliography

Figure 14. Bibliography database main screen

You can modify the type of columns (for example, the size of specific database columns) for any of the columns by doing the following:

1) Open the data source window, by pressing $F4$ or clicking **Tools > Data Sources**. There will be a screen similar to Figure 15.

2) Make sure that the Bibliography database is selected as well as the correct table. You may have to expand some levels to be able to select the correct ones.

Figure 15. Data Source view of Bibliography database

3) Right-click on the table entry and select **Edit Table** from the menu. This will display the Table Design window, which should look similar to Figure 16.

4) You can now select each of the columns and modify the **Field Type** as required.

5) When finished, if you close the Table Design window without saving the table, you will be asked to confirm whether you want the changes saved.

Creating and Maintaining a Table of Contents, Index and Bibliography
Adding entries to the database

To add entries to the database, follow these steps:

1) Using the lower portion of the screen from Figure 14 you can add records directly into the database.

2) Complete each of the fields as required. Use the Tab key to move between fields.

3) It is best to use a unique name in the short name. This is used when inserting entries into documents.

4) To complete the entry move to the last field and tab once more.

**Note**: If your document requires [Author, date] style referencing, you need to put this information in the appropriate format in the **Identifier** field of the database. If a simple numbering system (for example, [1],[2], etc.) is to be used within the document, then a unique reference of some sort is required. (Writer will autonumber these based on the position within the document.)

Maintaining entries in the database

Maintain entries in the database using the same screen as in the previous section. Click on the appropriate field and modify the text as appropriate.

Modified entries will be automatically saved to the database when the cursor moves off the record.
Adding a reference (citation) into a document

To add references from the bibliographic database into a document, follow these steps:

1) Place the cursor where you want the reference to appear.

2) Select Short name will be used or numbering Insert > Indexes and tables > Bibliographic entry and you will get a dialog similar to that shown in Figure 17.

3) The Author and Title of the reference selected in the Short Name field are shown, to use as a guide.

4) To insert the reference into the document, click Insert. If you wanted to insert a reference from the document itself (although not recommended) then select the radio button From document content.

5) You can change the placement of your cursor and insert another reference using the same dialog. You don’t need to close and reopen it.

6) When you have finished inserting all the references, select Close and you will be returned to the document.

Formatting the bibliography

To create the bibliography, follow these steps:

1) Place your cursor at the point where you wish to insert the bibliography.

2) Select Insert > Indexes and tables > Indexes and tables and change the Type to Bibliography, to see a dialog similar to that shown in Figure 18.

The Insert/Index Table window has five tabs. All of them can be used when creating a bibliography and will be discussed separately.
Creating a bibliography

Figure 18. Formatting bibliographic entries

**Index/Table tab**

The basic settings are selected on this tab.

1) If you’d like the bibliography to have a title, enter it in the **Title** field. (If Writer entered a title in this field automatically, you can change it by simply typing over the value.) To delete the title, clear the **Title** field.

2) To protect the bibliography from being changed accidentally, check the **Protected against manual changes** checkbox. If this box is checked, the bibliography can only be changed using the context menu or the Insert Table/Index window. If the box isn’t checked, the bibliography can be changed directly on the document page, just like other text.

3) To simply have the bibliographic entries numbered within the body of the document (for example, [1], [2], ...) then select **Number entries**. If however you wish to have the field **Identifier** (from the database) appear in the document, then clear this checkbox.

4) Select the type of brackets that you want the referenced entries, within the body of the document, to display.

5) Define the sorting that is required. Currently only alphabetic is supported.
Entries tab

The structure of this tab is similar to that of the previous sections (see Figure 19).

![Entries tab for bibliographies](image)

**Figure 19. Entries tab for bibliographies**

You can define how the entry will appear based on the **Type** of the entry, or simply apply the same format to all entries by selecting the **All** button.

The **Structure** of the entry is based on the fields available in the bibliographic database. The ones shown by default are:

- **Sh** – short name
- **Au** – Author
- **Ti** – Title
- **Ye** – Year

Sorting can be achieved by modifications to the **Sort by** options and **Sort keys** can be used to group similar references.

**Styles tab**

Refer to “Using the Styles tab” on page 6, for how to use this tab.

**Columns tab**

Refer to “Using the Columns tab” on page 7, for how to use this tab.

**Background tab**

Refer to “Using the background tab” on page 8, for how to use this tab.
Creating a bibliography

Generating the bibliography

To generate the bibliography so that it appears in your document, click OK. The Insert Index/Table window closes and the bibliography appears in your document.

Updating and editing an existing bibliography

To modify the display of bibliography entries:

1) Click anywhere in the bibliography and then right-click. The context menu appears.

2) From the context menu, choose Edit Index/Table. The Insert Index/Table window opens and you can edit and save the table using the five tabs described in the previous section.

Updating bibliography entries and deleting the bibliography follow the same process as described in the sections “Updating a table of contents” on page 10 and “Deleting a table of contents” on page 10.