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Overview

Overview

This chapter builds on the material covered in the chapter “General Differences in Use
between OpenOffice.org and Microsoft Office.” It explores some of the differences is use
specific to the difference in use of the spreadsheet component in Microsoft Office (MSO) and
OpenOffice.org (OOo).

Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License,
Version 1.0 (the "License"); you may only use this Documentation if you comply with the
terms of this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf

The Original Documentation is Differences in Use between Calc and Excel: . The Initial
Writer(s) of the Original Documentation is/are Ian Laurenson © 2004. All Rights Reserved.
(Initial Writer contact(s): hillview@paradise.net.nz. The Initial Writer contact(s) is to report
errors in the documentation. For questions regarding how to use the software, subscribe to the
Users Mail List and post your question there: http://support.openoffice.org/index.html)

All trademarks within this guide belong to legitimate owners.

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org
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Hollis Weber.
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Separating parameters in functions

Separating parameters in functions

The single biggest difference between Calc and Excel is that Calc uses semicolons to separate
parameters in a function and commas for separating non-contiguous ranges. This usage is the
reverse of Excel.

Interpreting cell contents

In Excel if a cell contains text that can be interpreted as a number then Excel will in some
situations attempt to do so. In Calc if a cell is defined as text, even if the cell contains a
number then that cell is treated as it is defined as text, which typically means the numeric
value zero.

For example, if cell A1 is formatted as text and contains the character “1” in Excel a formula
=A1+1 would return the value 2, in Calc it would return the value 1.

Limitations

Calc only supports 32,000 rows compared to Excel's 65,536. OOo2.0 due out March 2005
supports 65,536 rows.

The maximum number of sheets in Calc is 256 (Excel is only limited by available PC
memory).

Form fields

List boxes in Calc can either have multi-selection or not, whereas Excel has two multi-
selection modes: multi and extend. In Excel a multi-selection listbox's link to a cell is ignored
(at least in Excel2000; author hasn't checked Excel XP). In Calc the link works, but if more
than one item is selected the cell's value is set to #N/A.

In Calc each option button has its own link to a cell setting its value to true or false
depending on whether the option is selected. In Excel the cell link returns the number of the
selected option button.

Scroll bars and spinners are not implemented in Calc, although numeric fields can optionally
have spin buttons.
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Named ranges and “Natural Language” formulas

Named ranges and “Natural Language”
formulas

It is possible in some versions of Excel to have the same range name on different sheets, but
this is not possible in Calc.

Calc does have “Natural Language.” This is where column and/or row labels are used
(without defining them as range names) in a formula. In Excel to refer to a cell a space is
used between the label names; in Calc an exclamation mark (sometimes called pling) “!” is
used. In Calc the names are enclosed in single quotes (done automatically by Calc if the label
starts with a letter and only has alphanumeric characters). To turn this feature on/off use:
Tools > Options... > Spreadsheet > Calculate >Automatically find column and row
labels.

Array formulas

Calc supports array formulas (formulas entered using Control+Shift+Enter), but there are
two things which Excel can do that Calc can't do.

In Excel it is possible to have an array formula with two ranges in the formula and Excel
matches each cell in the ranges to get a result. For example, {=SUM(IF(A2:A5=1;B2:B5))}
would work like SUMIF and sum those cells in column B where in the same row column A
contained a 1. Calc returns “Err504” which is an “error in parameter”. Often this can be
worked around by using SUMIF, COUNTIF, or the database functions.

Array constants are not available in OpenOffice.org. The workaround is to have the constant
values in cells on a sheet and refer to them.

Note: OpenOffice.org help refers to array functions as matrix functions.

Optional parameters in formulas

Some formulas have more than one optional parameter at the end of the parameter list.  In
Excel it is possible to leave an optional parameter blank and specify a later parameter, but
this is not possible in Calc.

For example, in Excel to calculate an annuity the formula =PV(0.05,10,100,,1) returns -$810.78;
in Calc =PV(0.05;10;100;;1) returns Err:511.

The workaround is to put values in for the missing parameters. For the above example
putting a zero in for the blank parameter returns the same result for the annuity.
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Functions

Functions

Statistical, engineering, and financial functions
The statistical functions return slightly different results. They are the same up to at least 5
decimal places, but after that there is a discrepancy. Gnumeric (another open source
spreadsheet package) returns exactly the same results as Excel (based on the author's simple
tests). The author hasn't compared the results returned by a statistical package such as R or
SAS for the statistical functions.

In Excel some of the financial functions accept string parameters for dates; in OpenOffice.org
they require a serial number, although you can simply type in the dates in date format without
quotes.

Analysis ToolPak functions
The function EFFECT provided by the Analysis ToolPak for Excel is converted to
EFFECT_ADD in Calc and returns the same results.

Other functions not implemented / imported
Only three other functions are not imported: INFO, GETPIVOTDATA, and HYPERLINK.
Hyperlinks are supported but not as a function – use the Hyperlink button on the Function
bar.

DataPilot / Pivot Table

DataPilots are Calc's equivalent to Excel's Pivot Tables. However there are a number of
limitations. Pivot tables import from Excel into Calc, but as soon as they are worked on these
limitations become apparent. The limitations are:

● There is no PivotChart facility, but a DataPilot can be used as the data source for a
chart.

● Page fields have not been implemented, but there is a filter option which gives similar
functionality.

● You can have no more than 8 fields in the data, row, or column areas.

● There is no ability to group data (e.g., for a date field, grouping by month can't be
done). The workaround is to create a new column with a formula for calculating the
grouping, e.g., =Month().

● You can't define different formats for different fields.

● There are no calculated fields.

● There is no ability to show data fields as things like “Difference From” or “% of.”
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DataPilot / Pivot Table

● The Application Program Interface specification is incomplete for writing macros that
work with DataPilots—for example, the ability to control via another program, such as
OpenOffice.org's own macro language, BASIC, whether the tables have grand totals;
or having access to DataPilots created from external data.

AutoFilter

There are a number of AutoFilter differences between Excel and Calc:

● There is only one AutoFilter active for a spreadsheet document at a time. The rows
remain hidden but the drop downs in the first row disappear on applying AutoFilter
elsewhere.

● The remaining visible row numbers don't change color to warn that there is a filter in
place.

● Error values don't show as an option in the drop down lists when cells in the column
have errors.

● In the drop down lists, the equivalent to Excel's “Custom” is called “Standard.”

● The top 10 in the drop down list is literal, but to get the same degree of control, use
Standard and specify “largest”, “largest%”, “smallest” or “smallest%” in the condition
field.

● Use regular expressions for specifying criteria to select rows based upon the text in the
cells. To do this: Choose “Standard” from the drop-down list, click More so that the
rest of the dialog is displayed, check regular expressions. Table 1  has some examples
to help an Excel user to use regular expressions.

Table 1: Example regular expressions for AutoFilter

Excel custom command Comparison Field Equivalent Regular
Expression

Begins with x = ^x.*

Does not begin with x <> ^x.*

Ends with x = .*x$

Does not end with x <> .*x$

Contains x = .*x.*

Does not contain x <> .*x.*

The user is not limited to these regular expressions; they are included here to show how to
achieve the same result for AutoFilter in Calc as can be achieved in Excel.
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Text to columns

Text to columns

There is not an option to do this in Calc. See http://ooomacros.org/user.php#104183 for a
macro to do this.

Solver

There is no equivalent in Calc to the Solver add-in for Excel. But a working macro prototype
has been developed and is available from
http://www.openoffice.org/nonav/issues/showattachment.cgi/16029/SolverPrototype.sxc.

Charts

Chart types that Excel provides that Calc doesn't:

• Bar of pie converts to a 2D - columns - normal

• Pie of pie converts to a 2D - columns - normal

• Radar filled converts to 3D – columns deep

• Radar with markers – converts to 2D – net – normal but counter clockwise rather than
Excel's clockwise

Other charting issues include:

• Charts are slower to update in Calc than in Excel.

• There are fewer axis options such as no option for having an inverted y axis (negative
at top towards positive at bottom).

• The data must be contiguous with the labels in the first row or column.

• To change the range, click on the border of the chart, so that it is selected (green
selection points) > Right Click > Modify Data Range...

Right aligned text

In Excel if text is longer than the cell can hold and right aligned and there is nothing in the
cell to the left then the text “spills” into this cell. In Calc, the text will “spill” into the cell to
the right if it is empty.

Number formats

There is no “accounting” format (with the currency symbol at the left edge of the cell). A
workaround would be to have another column to the left that contains the currency symbol.
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Number formats

There is no predefined option for bracketing negative numbers. Use a custom format such as
“$#,##0.00_);[RED]($#,##0.00)”.

Grid lines

In Excel gridlines are a property of a Worksheet; in Calc it is an application-wide option:

Tools > Options > Spreadsheet > View

Keyboard shortcuts

Table 2: Excel v Calc default key shortcuts (incomplete)

Function Excel Shortcut Calc Shortcut
Rearranges the relative or absolute
references (for example, A1, $A$1,
$A1, A$1) in the input field

F4 Shift + F4

Edit cell comment (they are known as
'notes' in Calc)

Shift + F2 Control + F1

Fill right Control + R No equivalent

Go to specific cell F5 F5 (shows navigator)

Insert Function No standard equivalent Control + F2

Enter into all currently selected cells Control + Enter Alt + Enter
Alt + Shift + Enter (also
applies the cell format)

Mouse use

To select non-contiguous blocks of cells the first selection must be two or more cells, then
proceed as in Excel, holding down Control to select the next block(s) or 

1. Click once on the field "STD" (STanDard) in the status bar.

The field now shows "EXT" (EXTended selection).

2. Another click and it changes to "ADD" (ADD to selection).

Note: the ADD mode is the equivalent to Control + click and EXT is equivalent to Shift + click.

Double clicking the bottom right corner of the selection doesn't copy to the bottom of the
current region.
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Hidden rows

Hidden rows

There is no “select only visible rows” command. Selecting a block of cells with hidden rows
and deleting will delete the hidden rows as well. Workaround: select each visible row
manually before deleting. See IannzGotoSpecial.sxc available from
http://homepages.paradise.net.nz/hillview/OOo/  for a macro that can select only the visible
cells.

Navigator

The Navigator's main use would be for spreadsheet documents that have a lot of sheets.
Right-clicking on sheet selection controls doesn't display a dialog for selecting a sheet, so
using the Navigator is faster than scrolling through the sheets.

Stylist

Calc has two types of styles: cell and page. Right click in the Stylist to create, modify, or
delete styles.

Sheet area combo box

The sheet area combo box (left side of the Formula bar) shows the current range. It can be
used to jump to a named range, but can't be used to define a range (to define a range, use
Insert > Names > Define or Control + F3).

Function list

The Function list is a floating / dockable window that provides information about the
available functions. It is an alternative to AutoPilot:Functions. To view it: Insert > Function
List.

Error values

Some functions in Calc return esoteric error messages like Err:503. To get a message that is
more meaningful, select the cell with the error message then look at the right end of the
status bar. In this case it will show Error: Invalid floating point operation (e.g. division by
zero).

There is also a full description for each error message found within OpenOffice.org Help.
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Conditional formatting and styles

Conditional formatting and styles

Conditional formating requires styles to be defined – use the Stylist to do so.

To view a current list of styles for the sheet, press F3 or : Format > Stylist.

Working across spreadsheets, web pages,
and database data

Working across spreadsheets
Contrary to help and other references, using the Navigator with a “Drag Mode” of Link
doesn't work for accessing the contents of one spreadsheet in another.

To refer to the contents of cells in another spreadsheet document or workbook, the syntax is
'url of other workbook'#$sheetname!cellrange. For example, on a Linux system:

'file:///home/hillview/Documents/Tests/Address.xls'#$Sheet1.A1

or on a Windows system:

'file:///C:/Documents/Tests/Address.xls'#$Sheet1.A1

To input these links it is possible to:

1) Type in the formula up to the point where the link is required.

2) Window > [select desired document].

3) It isn't obvious that this is working but it is. Select the desired cell or range of cells.

4) Window > [select the original document].

5) Finish entering the formula.

What is disconcerting is that the value displayed is based on the value of the cell (or range of
cells) when the linked document was last saved.

So to check it, save the linked document and update the link in the document (Edit > Links)
that contains the link.

Note: To reiterate - these links do not update automatically! To get them to update, use Edit >
Links > [select the desired link] > Update. The update works from the saved file – so if both
files are open and the file that the link is based on is updated that file must be saved before
updating the link.

To have dynamic updating of data between two spreadsheets, use:

1) Select and copy the range of cells to be linked to.

2) Change to the spreadsheet that requires the link.

3) Edit > Paste Special > Link (checkbox down the bottom left).
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Working across spreadsheets, web pages, and database data

These cells will have dynamic access to the contents of the other sheet and the values
returned can then be used in other formulas.

Links to html data or other spreadsheets
To link to data on the net:

1) In a browser navigate to the desired page.

2) Copy the URL.

3) In Calc, Insert > External Data...

4) Paste in the URL.

5) This step is not obvious: press Enter, wait a moment and the bottom list box (called
Available tables / ranges) will show:

• HTML_all (the entire page)

• HTML_tables (all the tables on the page)

• HTML_1 (each table consecutively numbered on the page)

6) Select the desired option from the list box,

7) Optionally check the Update every checkbox and specify how often to update,

The same process can be used for linking to data in spreadsheets.

Note: The source file must be saved before the update can take place. (In OpenOffice.org
AutoSaves over write the original file, so with AutoSaves turned on this feature could be more
useful than it at first appears. The author hasn't experimented with this feature to test its limits.)

Links to database data
1) Display the Data source viewer (F4).

2) In the Data Explorer window, navigate to the desired table or query (if it isn't visible
click Explorer on / off - left button in data source toolbar).

3) Drag the table or query onto the sheet (see the Data Sources chapter for information
about working with data sources such as registering the data source).

Printing

Calc and Excel have the same printing functionality just the location of where to get to the
settings is slightly different.

Unlike Excel, a print range must be specified first.
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Printing

To define the print range (this is the equivalent of in Excel File > Page Setup > Sheet, first 3
fields):

1) Format > Print Ranges > Edit...

2) Select the desired range for each of the fields.

3) Note: it is possible to select noncontiguous areas for the print area with each area
being on a separate page. Each area is separated by a semicolon.

Like Excel, Calc provides a Page break view. The menu option is a toggle:

• View > Page break preview

The other settings such as whether to have grid-lines are done via the page style:

• Format > Page... > Sheet

Print Options for suppressing blank pages and printing only the selected sheet(s) can be set:

• Tools > Options... > Spreadsheet > Print

Note: Recommend having both these options set.

To print:

1) File > Print.

2) Optionally click Options to change the settings for suppressing blank pages and /or
only the selected sheet(s).

3) Other settings are the same as in Excel.
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