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Overview

Overview
This document describes some of the issues when importing and exporting Microsoft Office
(MSO) to and from OpenOffice.org (OOo).

Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License,
Version 1.0 (the "License"); you may only use this Documentation if you comply with the
terms of this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf
The Original Documentation is Sharing Files with Microsoft Office Users. The Initial Writer
(s) of the Original Documentation is/are Ian Laurenson © 2004. All Rights Reserved. (Initial
Writer contact(s): hillview@paradise.net.nz. The Initial Writer contact(s) is to report errors
in the documentation. For questions regarding how to use the software, subscribe to the Users
Mail List and post your question there: http://support.openoffice.org/index.html)
All trademarks within this guide belong to legitimate owners.

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org.

Acknowledgments
Thanks to the OOoAuthors team for proofreading this work, particularly Paul Miller and Jean
Hollis Weber.
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File formats

File formats
This section gives an overview of file format from an end-user’s perspective. For details
about XML formats, see http://books.evc-cit.info/book.php.
OpenOffice.org “natively” stores its files in a compressed (zipped) human readable (when
unzipped) XML format. This format is openly documented and is available under the GNU
General Public Library License (http://www.gnu.org).
Note: Some compression utilities only check the file extension and so may not recognize the file
as being compressed in the zip format. To open an OpenOffice.org file with such a compression
utility, rename the file to have the extension .zip.
By contrast, Microsoft Office files are stored in a proprietary format which is not human
readable. Microsoft have not publicly documented their file formats, which causes a lot of
problems for software developers to write filters for importing and exporting in Microsoft
Office formats.
Table 1. File extensions

Document
type

Application

Document
Extension

Template
Extension

Microsoft
Office eqv

Text

Writer

.sxw

.stw

.doc .dot

Spreadsheet

Calc

.sxc

.stc

.xls .xlt

Drawing

Draw

.sxd

.std

na

Presentation

Impress

.sxi

.sti

.ppt .pot .pps

Formula

Math

.sxm

na

Master document

Writer

.sxg

na

HTML document

Writer

.html

na

Note: OpenOffice.org can open Microsoft Office files. The reverse is NOT true: Microsoft Office
can not open OpenOffice.org formats. So if you need to deal with someone using Microsoft
Office, save your file first in the native OpenOffice.org format; then you can save it to one of the
many supported Microsoft Office formats. This way you ensure that even if the filter can’t
translate perfectly, you have your original in its native format.

Bulk conversion
To convert a lot of files:
File > AutoPilot > Document Converter...
Note: Converting a lot of files can take a long time. Recommend to set it going when the
computer is not going to be used for a while, but check for sufficient disk space.
Before doing a bulk conversion of files, think about whether it is really necessary. Read this
document right through to get an appreciation of the limitations of the conversion process.
Sharing Files with Microsoft Office Users
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Opening files
Opening text format files
OpenOffice.org Writer can import the standard Microsoft Office formats (as shown in the
right column of Table 1) as well as the .rtf, .txt, .csv and StarWriter formats.
When opening .HTM or .HTML files, OpenOffice.org customizes Writer for working with
these files.

Opening spreadsheets
In addition to the native formats, OpenOffice.org can open the following spreadsheet
formats:
Microsoft Excel 97/2000/XP (*.xls; *.xlw)
Microsoft Excel 97/2000/XP Template (*.xlt)
Microsoft Excel 95 (*.xls; *.xlw)
Data Interchange Format (*.def)
dBase (*.dbf)
Sylk

Rich Text Format
Text CSV (*.csv; *.txt)
Lotus 123 (*.wk1; *.wk1)
StarCalc formats
HTM and HTML files including Web page
queries

Opening presentations
In addition to the native formats, OpenOffice.org can open the following presentation
formats:
Microsoft PowerPoint 97/2000/XP (*.ppt; *.pps)
Microsoft PowerPoint 97/2000/XP Template (.pot)
StarDraw, StarImpress
CGM - Computer Graphics Metafile (*.cgm)

Opening graphics files
In addition to the native formats, OpenOffice.org can open the following graphic formats:
BMP
DXF
EMF
EPS
GIF
JPEG
MET

PBM
PCD
PCX
PGM
PLT
PNG
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PPM
PSD
RAS
SGF
SGV
Star Draw

SVM
TGA
TIFF
WMF
XBM
XPM
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Opening formula files
In addition to its native format, OpenOffice.org can open the following formula files:
StarMath and MathML (*.mml).
When opening a Word document that contains an embedded equation editor object, if the
option for it is checked in Tools > Options > Load/Save > Microsoft Office then the object
will be automatically converted to an OpenOffice.org Math object.

Saving files
Default file format
To set the default file format when
saving new files:
Tools > Options... > Load/Save >
General
Note: If the default is set to an
OpenOffice.org format and a Microsoft
Office file is being saved, then a warning
dialog will be displayed about potential
loss of formatting.

Figure 1. The first half of the writer Save As
pulldown menu

Export to PDF
In each application there is the ability to directly export to PDF. This industry-standard file
format for file viewing is ideal for sending the file to someone else to view using Acrobat
Reader or any other PDF display program like ggv or Xpdf.
You can export directly to PDF using a button on the toolbar (next to the Printer icon) for
export directly to PDF, or by choosing File > Export, which allows you to select some more
detailed options.

Saving files in other formats
To save files in different formats:
File > Save As > File Type:

Sharing Files with Microsoft Office Users
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Saving files

Writer can save to these file formats
In addition to its native formats, Writer can save in these formats:
OpenOffice.org Writer template (.stw)
Microsoft Word 97/2000/XP (.doc)
Microsoft Word 95 (.doc)
Microsoft Word 6.0 (.doc)
Rich Text Format (.rtf)
StarWriter 5.0 (.sdw)
StarWriter Template (.vor)

StarWriter 4.0 (.sdw)
StarWriter 4.0 Template (.vor)
StarWriter 3.0 (.sdw)
StarWriter Template 3.0 (.vor)
Text (.txt)
Text Encoded (.txt)
HTML (.html; .htm)

Note: The .rtf format is a common format for transferring text files between applications but be
aware of the lack of formating available in that format. It also seems that there is a bug
concerning files saved in the .rtf format that contain images when opened by Microsoft Office.
So the best way to pass a file in writer to a Microsoft Word user is to save it as Microsoft Word
97/2000/XP (.doc).

Calc can save to these file formats
In addition to its native formats, Calc can save in these formats:
Microsoft Excel 97/2000/XP (*.xls; *.xlw)
Microsoft Excel 97/2000/XP Template (*.xlt)
Microsoft Excel 95 (*.xls; *.xlw)
Data Interchange Format (*.dif)
dBase (*.dbf)

SYLK (*.slk)
Text CSV (*.csv; *.txt)
StarCalc formats (*.sdc, *.vor)
HTM and HTML files

Impress can save to these file formats
Microsoft PowerPoint 97/2000/XP (*.ppt; *.pps)
Microsoft PowerPoint 97/2000/XP Template (*.pot)
StarDraw, StarImpress (*.sda, *.sdd, *.vor)
Impress can also export to MacroMedia Flash (*.swf) and any of the graphics formats as
listed below for Draw.

Draw can save to these file formats
Draw can only save in its native format and StarDraw format, but can export to:
BMP
EMF
EPS
GIF
JPEG

MET
PBM
PCT
PGM
PNG
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Saving files

The HTML writer can save in these formats
HTML Document (*.html; *.htm)
OpenOffice.org 1.0 HTML Template (*.stw)
StarWriter/Web5.0 and 4.0 (*.vor)
Text (OpenOffice.org Writer/Web) (*.txt)
Text Encoded (OpenOffice.org Writer/Web) (*.txt)

AportisDoc and PocketWord files for transport to
your PDA
When installing OpenOffice.org, you can optionally choose to install DocBook and XLST
filters. They are then added to the Save As menu automatically. For more information, see the
chapter on installing OpenOffice.org.

Object Linking and Embedding (OLE)
To change the settings for Microsoft Office OLE objects:
Tools > Options > Load/Save > Microsoft Office
Having all of these options checked will allow embedded objects to be converted and thus be
editable in both office suites.
For other OLE objects, it will depend on the machine where the file is being edited just as it
does with Microsoft Office alone. Thus Windows application based OLE objects will not be
editable in OpenOffice.org on a Linux machine, although the object will still be displayed
correctly and is able to be resized.

Linked files
Cells copied from Excel and pasted special, linked and with RTF format, into Word are
imported into Writer as a normal table. This means that when the document is imported, the
link to the Excel file is lost.
Similarly when a chart is copied from Excel and pasted special, linked into Word, and then
the file imported into Writer, the chart is imported as an embedded OLE object but is not
converted into a Calc chart. On saving the file in Word format and then opening the file in
Word and trying to edit the chart by double-clicking, it displays an error message.
Warning: The links are lost!

Sharing Files with Microsoft Office Users
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WordArt / FontWork
The equivalent to Microsoft Office’s WordArt in OpenOffice.org is FontWork. WordArt
objects are imported as graphics so the ability to edit them is lost. Similarly, FontWork
objects are exported into Microsoft Office files as graphics only. See the chapter on
FontWork.

Vector graphics
The basic shapes (lines, arrows, rectangles, ovals) all import and export without any problem.
OpenOffice.org provides a greater degree of control over some properties than Microsoft
Office does, so sometimes there will be changes when going from OpenOffice.org to
Microsoft Office. Examples include the size of arrow heads, and line styles.
The Microsoft Office autoshapes, like the smiley face, lose their special characteristics. For
instance the ability to adjust the degree of the smile / frown on the smiley face is lost.
Microsoft Office provides more shadow options than OpenOffice.org, so sometimes there
will be a change in shadow appearance. Microsoft Office shadow styles 1, 2, 4, 6,14, 17 and
18 are supported in OpenOffice.org. Horizontal and tapered shadows do not get imported.
On exporting documents containing graphics, such as callouts, the locations frequently
change.

Frames / text boxes
When frames or text boxes from Microsoft Office are imported into OpenOffice.org with
linked text, the links do not remain.

Active content controls
These are the controls in Microsoft Office available on the Controls toolbar.
Checkboxes, radio buttons, text fields, labels, list boxes, combo boxes, and toggle buttons all
import without a problem. But as these controls typically require macros to be of use, they
will be functionally useless in the absence of macros custom built for use in OpenOffice.org.
Scrollbars and images import as OLE objects.

Macros
OpenOffice.org cannot run Microsoft Office macros. Although the macro language is very
similar, the underlying objects are quite different. To set whether OpenOffice.org keeps
attached macros for Word, Excel and PowerPoint files, use:
Sharing Files with Microsoft Office Users
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Macros

Tools > Options... > Load/Save > VBA properties
Note: Opening a Microsoft Office file infected with a virus is quite safe in OpenOffice.org.
OpenOffice.org has the ability to record macros. The recorder uses something called a
dispatcher. It is better practice to use the application program interface (API).

Import / export / sharing issues in text
documents
Good practice in text documents
Some issues can be avoided simply by using good word-processing practice:
•

Use character and paragraph styles rather than direct formatting.

•

Use paragraph formatting for space before and after rather than hard returns, particularly
in numbered or bulleted lists.

•

Use paragraph text flow properties (e.g. keep with next) rather than using manual page
breaks.

•

Do not use multiple tabs or spaces to align text – either set specific tab stops or better yet
use a table.

•

Use only commonly available fonts.

Compatibility settings in OpenOffice.org for the
current document
The following settings change the way OpenOffice.org works with the current document so
that it works more like Microsoft Office.
Use Tools > Options... > Text Document > General
Tops of pages

In Writer, if this setting isn’t checked, if a paragraph at the top of the page (or column) is
formatted with space above then the space above is ignored, whereas in Word the space
above is included it. Checking this option causes Writer to behave in the same way as Word.
Aligning tabs

This setting specifies whether centered and right-aligned paragraphs containing tabs are
formatted as a whole in the center or aligned to the right. If this checkbox is not marked, only
the text to the right of the last tab is aligned to the right, while the text to the left remains as
is. (From help.)
Spacing between paragraphs

Writer uses the greater of the two spacings for above and below paragraphs; Word sums the
two together. Check this box to have Writer behave in the same way as Word.
Sharing Files with Microsoft Office Users
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Font and font spacing
Text effect animations are not imported by Writer from Word files.
Hidden text in writer is a field, whereas in Word it is a font attribute.
Typically Word’s character spacing is tighter than Writer’s, so often Word will fit more
characters to a line. It is also possible that the spacing between lines could be slightly
different. The end result is that the page breaks may be in different places.

Tables
Writer doesn’t allow a row within a table to be split across pages. Word (by default) allows a
row to be split across pages.
Writer doesn’t support vertical text within a cell.
Warning: There is a vertical option for formatting text (Format > Character... > Rotation /
Scaling) for some reason that the authors haven’t figured out this is not recommended for using
in a table; see: http://www.openoffice.org/issues/show_bug.cgi?id=16944. If it is used in a table
in a document and that document gets exported to Word then Word goes into a loop perpetually
trying to re-paginate the document.
Text in a table with vertical alignment imported from Word: the vertical text simply becomes
horizontal.
Fields for calculations within tables are imported as the text of the saved result. In other
words, the field for performing the calculation is lost.
Summary: Documents containing tables can be imported and exported between
OpenOffice.org and Microsoft Office, but they cannot contain vertical text, nor should a row
span more than a page.

Mail merge documents
As OpenOffice.org and Writer have different approaches to data sources, on importing a
Word document that is the main document for a mail merge there is no connection with the
data source. It is not just a matter of making that connection, each field needs to be
reinserted. See the Mail Merge section in the Text Document differences chapter.
Also in Word you can have another Word document as a data source for a mail merge. There
is no way of specifying a Word (or Writer) document as a data source in OpenOffice.org.
Writer doesn’t have the option of suppressing blank lines when data fields are empty, so you
need to use conditional fields. See.
Writer merge fields export as text with the name of the field between angle brackets, e.g.
<Name>.
Summary: To work in a shared environment would require a separate file for each “main
document”: one in Word format, the other in OpenOffice.org format.
Sharing Files with Microsoft Office Users
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Forms
Issues with forms created in Microsoft Office:
A locked file in Microsoft Office imports unlocked into OpenOffice.org; that is, in design
mode.
Text form fields import into OpenOffice.org as Input fields and so lose their type. For
example, a text form field of type “number” or “date” will accept any text for input. In use a
text form field in OpenOffice.org displays a dialog for entering the text. Exporting back to
Microsoft Office, text form fields are changed into “Fillin” fields. The current date and time
and calculation fields import as simple text.
Check-boxes import/export ok.
Drop-down form fields import as Input List fields. Like text form fields in operation these
display a dialog from which the user can select an option. On export back to Microsoft Office
they return to drop-down form fields again.
Issues with forms created in OpenOffice.org:
The controls are exported as active controls when there is a Microsoft Office equivalent. As
Word doesn’t have the same database functionality of OpenOffice.org and as the macros
aren’t compatible, it would be very difficult to have one form that works in both
environments using standard form controls.
Summary: To work in a shared environment with forms is not easy but one workaround
would be to use other fields like Input field and Input List. To insert these fields use: Insert >
Fields > Other... > Functions.

Footnotes, end notes, tables of contents and
indexes
Footnotes, endnotes and indexes all import / export ok. Some issues found:
•

The location of the endnotes may change (in Word the endnotes were placed before
the index. In Writer they are always at the end of the document).

•

Writer bibliographic entries become text in Word.

•

A three column index exported from Writer to Word as three columns but on reimport it was one column.

•

On importing a Word file containing index entry fields, the index entry fields are
imported but as fields to the left of the text rather than the field containing the text.

Summary: Working in a shared environment is possible with some minor issues.
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Numbered paragraphs, outline numbering, crossreferences
Import / Export without a problem, except for references to numbered paragraphs:
•

Cross-references to the numbers of numbered paragraphs that aren’t numbered using
outline numbering don’t work as Writer doesn’t have this ability

•

Writer also doesn’t have the ability to use relative numbering in its cross-references to
numbers.

•

Cross-references to chapter numbers don’t have the same format as that displayed.

Page numbering
A quick and dirty approach in Word for having a different first page (like a cover page) and
then to have the numbering start on the second page but numbered as page 1 is to have a
layout of different first page and setting the starting page to be zero. Unfortunately, on
importing such a file into OpenOffice.org the page number on the second page is 2 instead of
1. To fix this problem in Writer, use:
1) Create a page style for how the pages after the first page should look. Name it (for
example) Convert1.
2) Have the cursor in the first paragraph of the second page.
3) Format > Paragraph > Text Flow.
4) In the Breaks portion of the dialog, select the checkbox Enable.
5) Check With Page Style.
6) Choose the page style created in step 1.
7) Leave the position as Before and set the page number to 1.
On exporting this document back to Word it will work, the only difference being that the
document will have a section break at the end of the first page. Documents created with
section breaks like this in Word will work fine importing and exporting with Writer. There is
one difference with Word: there will now be a blank page between the cover page and the
next page when printed (or print previewed).
Summary: For some documents a little work maybe required to fix up the page numbering on
importing to Writer. Once “fixed” the page numbering of the documents will import/export
without a problem.

Date and time fields
Word’s CreateDate and SaveDate fields don’t get imported with the same formats. For
example, if the fields in the Word document have a format that includes time, then this
information is not displayed by default. To include time in the format:

Sharing Files with Microsoft Office Users
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Right click on the field > Fields... > scroll to the bottom of the Formats listbox > Additional
formats... > in format code add HH:MM:SS
On export the SaveDate / DocInformation:Modified is exported as text.
Writer’s Time Fixed and Date Fixed fields get exported as text.

Importing Word fields
Table 2: Imported Word fields conversion

Word Field:

Writer converts to:

ASK

Input field

AUTHOR

DocInformation:Created

AUTONUM

Number Range AutoNr

AUTONUMLGL

Number range AutoNr

AUTONUMOUT

Number range AutoNr

COMMENTS

DocInfomation:Comments

CREATEDATE

DocInformation:Created

DATE

Date

EDITTIME

DocInformation:Modified

FILENAME

File name

FILLIN

Input field

HYPERLINK

(as a hyperlink)

INFO xxx

DocInformation:xxx

KEYWORDS

DocInformation:Keywords

LASTSAVEDBY

DocInformation:Modified

MACROBUTTON

(the name of the macro?)

MERGEFIELD

Mail merge fields (displayed as the name of the field)

MERGEREC

Record number

NEXT

Next record

NOTEREF

Show variable

NUMCHARS

Statistics (with select = Characters)

NUMPAGES

Statistics (with select = Pages)

PAGE

Page numbers

PAGEREF

Bookmarks (displayed as name of bookmark)

REVNUM

DocInformation:Document number

SAVEDATE

DocInformation:Modified

SEQ

Number range

SET

Set variable

Sharing Files with Microsoft Office Users
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Word Field:

Writer converts to:

SUBJECT

DocInformation:Subject

TEMPLATE

Templates

TIME

Date

TITLE

DocInformation:Title

TOC

(Displays the table of contents)

The following fields are not imported into OpenOffice.org (only the text that they displayed
when last saved): =, IF, DOCPROPERTY, FILESIZE, LINK, LISTNUM, QUOTE,
SECTION, SECTIONPAGES, STYLEREF, TOA, USERADDRESS, USERINITIALS,
USERNAME.
The following fields are ignored on import: AUTOTEXT, AUTOTEXTLIST, BARCODE,
BIDIOUTLINE, DOCVARIABLE, EQ, GOTOBUTTON, INCLUDETEXT, LISTNUM,
MERGESEQ, PRINT, RD, SKIPIF, SYMBOL, TA, TC.
The Word field EDITTIME is mapped to Writer field DocInformation:Modified on import
but the meaning has changed to the date and time last saved rather than how long the file has
been open for editing.

Import / export / sharing issues in
Spreadsheets
Password protected workbooks
Workbooks that have been password protected in Excel cannot be opened by Calc. The file
needs to be saved in Excel without password protection so that Calc can open it. If you don’t
have access to Excel, then to open the files you need another program. In Windows you can
use an Excel viewer (free to download from Microsoft) and in Linux you can use Gnumeric
1.2.6 and above. (As Gnumeric is open source it is probable that this limitation will soon be
removed from Calc.)

Number of rows
Calc only supports 32,000 rows (compared to Excel’s 65,536). When importing an Excel
workbook that contains a sheet with more than 32,000 rows, Calc creates a new sheet so the
data isn’t lost, but any formulas that refer to that data need to be manually changed.

Number of sheets
The maximum number of sheets in Calc is 256. When importing an Excel spreadsheet with
more than 256 sheets, a warning about data loss is displayed.

Sharing Files with Microsoft Office Users
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Form fields
Combo boxes, list boxes and checkboxes with links to spreadsheet cells all import and export
properly, although due to font handling the number of rows displayed in list boxes may be
slightly different. List boxes in Calc can either have multi-selection or not, whereas Excel has
two multi-selection modes: multi and extend. In Excel a multi-selection listbox’s link to a
cell is ignored (at least in Excel2000; the author hasn’t checked Excel XP). In Calc the link
works, but if more than one item is selected, the cell’s value is set to #N/A.
Option buttons import into Calc, but the link with cells works differently. In Calc each option
button has its own link to a cell, setting its value to true or false depending on whether the
option is selected. In Excel the cell link returns the number of the selected option button. On
exporting option buttons to Excel, the option buttons lose their radio operation – in other
words, they are not grouped so that selecting one “unselects” the others.
Scroll bars and spinners are not implemented in Calc.

Array formulas
Calc supports array formulas (formulas entered using Control+Shift+Enter) but there are two
things which Excel can do that Calc can’t do.
In Excel it is possible to have an array formula with two ranges in the formula and Excel
matches each cell in the ranges to get a result. For example, {=SUM(IF(A2:A5=1,B2:B5))}
would work like SUMIF and sum those cells in column B where in the same row column A
contained a 1. Calc returns “Err504”. Often this can be worked around by using SUMIF,
COUNTIF, or the database functions.
Array constants are not available in OpenOffice.org. The workaround is to have the constant
values in cells on a sheet and refer to them.

Optional parameters in formulas
Some formulas have more than one optional parameter at the end of the parameter list. In
Excel it is possible to leave an optional parameter blank and specify a later parameter, but
this is not possible in Calc. Formulas with optional parameters are not correctly imported into
Calc.

Functions
Statistical, engineering and financial functions

The statistical functions return slightly different results. They are the same up to at least 5
decimal places, but after that there is a discrepancy. Gnumeric (another open source
spreadsheet package) returns exactly the same results as Excel (based on the author’s simple
tests). The author hasn’t compared the results returned by a statistical package such as R or
SAS for the statistical functions.

Sharing Files with Microsoft Office Users
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In Excel some of the financial functions accept string parameters for dates; in OpenOffice.org
they require a serial number, and thus they are not correctly imported into Calc.
Analysis ToolPak Functions

The function EFFECT provided by the Analysis ToolPak for Excel is converted to
EFFECT_ADD in Calc and returns the same results.
Other functions not implemented / imported

Only three other functions are not imported: INFO, GETPIVOTDATA, and HYPERLINK.
Hyperlinks are supported but not as a function – use the Hyperlink button on the Function
bar.

DataPilot / Pivot Table
DataPilots are Calc’s equivalent to Excel’s Pivot Tables. However there are a number of
limitations. Pivot tables import from Excel into Calc but as soon as they are worked on these
limitations become apparent. The limitations are:
•

There is no PivotChart facility, but a DataPilot can be used as the data source for a
chart.

•

Page fields have not been implemented, but there is a filter option which gives similar
functionality.

•

Can have no more than 8 fields in the data, row or column areas.

•

There is no ability to group data (for example, a date field grouping by month can’t be
done). The workaround is to create a new column with a formula for calculating the
grouping, e.g. =Month().

•

You can’t define different formats for different fields.

•

There are no calculated fields.

•

There is no ability to show data fields as things like “Difference From” or “% of”

•

The Application Program Interface specification is incomplete for writing macros that
work with DataPilots—for example, the ability to control through another program,
such as OpenOffice.org’s own macro language, BASIC, whether the tables have grand
totals, or having access to DataPilots created from external data.

AutoFilter
AutoFilter imports and exports ok with the required rows being hidden. However, there are a
number of differences between Excel and Calc:
•

There is only one AutoFilter active for a spreadsheet document at a time. The rows
remain hidden but the drop downs in the first row disappear on applying AutoFilter
elsewhere.
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•

The remaining visible row numbers don’t change color to warn that there is a filter in
place.

•

Error values don’t show as an option in the drop down lists when cells in the column
have errors.

•

In the drop down lists, the equivalent to Excel’s “Custom” is called “Standard”.

Charts
Chart types that Excel provides that Calc doesn’t:
•

Bar of pie converts to a 2D - columns - normal

•

Pie of pie converts to a 2D - columns - normal

•

Radar filled converts to 3D – columns deep

•

Radar with markers – converts to 2D – net – normal but counter clockwise rather than
Excel’s clockwise

Other charting issues include:
•

There are fewer axis options, such as no option for having an inverted y axis (negative
at top towards positive at bottom).

•

The data must be contiguous, with the labels in the first row or column.

Right aligned text
In Excel if text is longer than the cell can hold and right aligned and there is nothing in the
cell to the left, then the text “spills” into this cell. In Calc, the text will “spill” into the cell to
the right if it is empty.

Number formats
There is no “accounting” format (with the currency symbol at the left edge of the cell). A
workaround would be to have another column to the left that contains the currency symbol.
There is no predefined option for bracketing negative numbers. Use a custom format such as
“$#,##0.00_);[RED]($#,##0.00)”.

Grid lines
In Excel gridlines are a property of a Worksheet; in Calc it is an application wide option:
Tools > Options > Spreadsheet > View
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Import / export / sharing issues in
presentations
Color gradients and borders
The author had not noticed the following changes, so this is a direct quote from “StarOffice 7
Migration Guide” by Sun.
Unlike Microsoft PowerPoint, StarOffice Impress does not support three color gradients,
double and triple borders, or round-dotted borders. To improve the results of the import, you
have to make the necessary adjusts before import. Change three-color presets to similar twocolor gradient fills and change double and triple border lines to a single border line with
appropriate width. Round-dotted border lines that are mapped to rectangle-border closely
resemble the original line style in PowerPoint so that manual editing should not be necessary.

Multimedia
Voice-over narration is not supported by Impress.
There appear to be no settings for multimedia custom animations, such as the ability to play a
sound for the next x slides.

Chart animations
There is no facility in Impress for “Chart Effects” as there is in PowerPoint, such as
presenting a series or category at a time. On import the charts simply appear. A workaround
is to have multiple copies of the chart with each one set up to display as desired.

Pack and Go
This feature in PowerPoint allowed a PowerPoint file to be split up over several floppy disks
and assured that all related files were included. This facility is not included in Impress, nor
can Impress open such files.

Fields
Date fields are exported as text, so they don’t automatically update.

Action Settings / Interaction
PowerPoint provides action settings for mouseover, but Impress doesn’t have this option,
only on mouse click, so mouseovers get mapped to mouse clicks. PowerPoint has an option
for highlighting the object on mouse click / mouse over; Impress doesn’t have this, so it gets
ignored on import.
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PowerPoint custom animations – Impress object
effects
Table 3 shows how the custom animations / object effects are imported into Impress and
exported to PowerPoint.
Table 3. Importing/exporting custom animations between PowerPoint and Impress

PowerPoint

Impress

Appear

Appear

Blinds

Fade Horizontally

Box

Fade To Center

Checkerboard

Checkerboard

Diamond

Appear

Crawl

Fly In From bottom

Dissolve

Dissolve

Flash once

Appear

Peek

Short Fly In from Bottom

Random Bars

Horizontal lines

Spiral

Spiral Outward Clockwise

Split

Close Vertical

Stretch

Stretch Vertical

Strips

Fade From Top Right

Swivel

Rotate Horizontally

Wipe

Cross-Fade From Top

Zoom

Fade From Center

Random effects

Vertical Lines

PowerPoint – Impress slide transitions
Table 4 shows how slide transitions are imported into Impress and exported to PowerPoint.
Table 4. Importing/exporting slide transitions between PowerPoint and Impress

PowerPoint

Impress

Blinds Horizontal

Fade Horizontally

Blind Vertical

Fade Vertically

Box In

Fade To Center

Box Out

Fade From Center

Checkerboard Across

Horizontal Checkerboard

Checkerboard Down

Vertical Checkerboard
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PowerPoint

Impress

Cover Down

Fly In From Top

Cover Left

Fly In From Right

Cover Right

Fly In From Left

Cover Up

Fly In From Bottom

Cover Left Down

Fly In From Upper Right

Cover Right Down

Fly In From Top Left

Cover Left Down

Fly In From Upper Right

Cover Right Up

Fly In From Lower Left

Cut

No effect

Cut through Black

No effect

Dissolve

Dissolve

Fade Through Black

No effect

Random Bars Horizontally

Horizontal Lines

Random Bars Vertically

Vertical Lines

Horizontal In

Close Vertically

Horizontal Out

Open Vertically

Split Vertical In

Close Horizontally

Split Vertical Out

Open Horizontally

Strips Left Down

Fade From Top Right

Strips Left Up

Fade From Bottom Right

Strips Right Down

Fade From Top Left

Strips Right Up

Fade From Bottom Left

Uncover Down

Uncover Downwards

Uncover Left

Uncover To Left

Uncover Right

Uncover To Right

Uncover Up

Uncover Upwards

Uncover Left Down

Uncover To Lower Left

Uncover Left Up

Uncover To Upper Left

Uncover Right Down

Uncover To Lower Right

Uncover Right Up

Uncover To Upper Right

Wipe Down

Cross-Fade From Top

Wipe Left

Cross-Fade From Right

Wipe Right

Cross-Fade From Left

Wipe Up

Cross Fade From Bottom

Random Transition

Automatic (random)
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