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Overview

Overview

The Options dialog controls many settings in OpenOffice.org (OOo). Some settings apply to
all the components of OOo; other settings apply to only one component.

This chapter covers some of the setup options, particularly those that are a bit obscure or hard
to find when you first start using the program. It does not cover all the options in detail. See
the online help for full details. This chapter also covers AutoCorrect/AutoFormat options.

Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License,
Version 1.0 (the “License”); you may only use this Documentation if you comply with the
terms of this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf.

The Original Documentation is Setting Up OpenOffice.org: Choosing options to suit the way
you work. The Initial Writers of the Original Documentation is Jean Hollis Weber © 2004.
All Rights Reserved. (Initial Writer contacts: jeanweber@openoffice.org. Contact the Initial
Writer only to report errors in the documentation. For questions regarding how to use the
software, subscribe to the Users Mail List and post your question there:
http://support.openoffice.org/index.html.)

All trademarks within this guide belong to legitimate owners.

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org.

Acknowledgments
Much of this material was first published in Taming OpenOffice.org Writer 1.1, by Jean
Hollis Weber, © 2003.

Modifications and updates

Version Date Description of Change

1.0 26 Dec 2004 First published version
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Choosing options that affect all of OOo

Choosing options that affect all of OOo

This section covers some of the settings that apply to all the components of OOo. For
information on settings not discussed here, see the online help.

1) Click Tools > Options.

2) Click the + sign to the left of OpenOffice.org in the left-hand section. A list of
subsections drops down.

User data
Because OOo’s revision features mark your changes and comments with the name or initials
stored in User Data, you’ll want to ensure that your name and initials appear there. To do
this:

1) In the Options dialog, click OpenOffice.org > User Data. 

2) If anything on the User Data page is incorrect, delete it and type the correct
information.

Figure 1. Filling in user data
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General options
1) In the Options dialog, click OpenOffice.org > General. 

2) On the Options – OpenOffice.org – General dialog (Figure 2), the options are as
described below.

Figure 2. Setting general options for OpenOffice.org 

Year (two digits)

Specifies how two-digit years are interpreted. For example, if the two-digit year is set to
1930, and you enter a date of 1/1/30 or later into your document, the date is interpreted as
1/1/1930 or later. An “earlier” date is interpreted as being in the following century; that is,
1/1/20 is interpreted as 1/1/2020.

Help Agent

To turn off the Help Agent (OpenOffice.org’s equivalent to Microsoft’s Office Assistant),
deselect Activate. If the Help Agent is active, you can specify how long it remains open
before it is automatically closed. To restore the default Help Agent behavior, click Reset.

OpenOffice.org Help formatting

To display Help in high contrast for accessibility, choose one of the high-contrast style sheets
from the list.
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Open/Save dialogs

To use the standard Open and Save dialogs for your operating system, deselect the Use
OpenOffice.org dialogs checkbox. When this checkbox is selected, the Open and Save
dialogs supplied with OpenOffice.org will be used. (See the “File Management” chapter for
more about the OOo Open and Save dialogs.)

Document status

Choose whether printing a document counts as changing the document. If this option is
selected, then the next time you close the document after printing, the print date is recorded
in the document properties as a change and you’ll be prompted to save the document again,
even if you didn’t make any other changes.

Back button (same behavior on all options dialogs)

Resets options to the values that were in place when you opened OpenOffice.org.

Memory options
1) In the Options dialog, click OpenOffice.org > Memory.

2) On the Options – OpenOffice.org – Memory dialog (Figure 3):

• Consider the trade-offs of convenience against speed or insufficient memory. For
example, more undo steps require more memory.

• To load the Quickstarter (an icon on the desktop or in the system tray – Windows
only) when you start your computer, select the checkbox near the bottom of the
dialog.

Figure 3. Choosing Memory options for the OpenOffice.org applications
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View options
The choices of View options affect the way the document window looks and behaves.

1) In the Options dialog, click OpenOffice.org > View.

2) On the Options – OpenOffice.org – View dialog (Figure 4), set the options to suit your
personal preferences. Some options are described below.

Figure 4. Choosing View options for the OpenOffice.org applications

Scale

If the text in the help files and on the menus of the OOo user interface is too small or too
large, change it by specifying a scaling factor. Sometimes a change here can have unexpected
results, depending on the screen fonts available on your system. It does not affect the actual
font size of your text.

Menu follows mouse pointer

When you select this option, the menus follow standard Windows behavior: after you have
clicked on any menu bar item, the highlighting moves when you move the cursor, and you
don’t need to click to activate submenus (just point to the menu item and the submenu pops
out).

Preview in fonts lists

When you select this option, the font list looks like Figure 5, left, with the font names shown
as an example of the font; with the checkbox deselected, the font list shows only the font
names, not their formatting (Figure 5, right). The fonts you will see listed are those that are
installed on your system.
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Figure 5. (Left) Font list showing preview; (Right) Font list without preview

Inactive menu items

Select this option if you want inactive menu items to be visible but grayed out. Deselect it to
prevent inactive menu items from appearing on the menu.

Font history

When you select this option, the last five fonts you have assigned to the current document are
displayed at the top of the font list.

Restore – Editing view

Select this option if you want to open documents at the place the cursor was located when
you previously closed the document. Deselect this option to always open documents at the
first page.

Restore – Open windows

Select this option if you want all documents and windows that are open when you close
OpenOffice.org to be restored when you restart it.

3D view

These options are for use with Draw and Impress. For more information, see the online help
or other documentation on these applications.

Mouse

Use these options to choose how the mouse is positioned in newly opened dialogs and to
select the function of the middle mouse button.
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Print options
Set the print options to suit your default printer and your most common printing method. You
can change these settings at any time, either through this dialog or during the printing process
(by clicking the Options button on the Print dialog).

1) In the Options dialog, click OpenOffice.org > Print.

2) On the Options – OpenOffice.org – Print dialog (Figure 6), look at the Printer
warnings section near the bottom. 

Here you can choose whether to be warned if the paper size or orientation specified in
your document does not match the paper size or orientation available for your printer.
Having these warnings turned on can be quite helpful, particularly if you work with
documents produced by people in other countries where the standard paper size is
different from yours.

Figure 6. Choosing general printing options to apply to all OOo components

Tip If your printouts are coming out incorrectly placed on the page or chopped off at the top,
bottom, or sides, or the printer is refusing to print, the most likely cause is page size
incompatibility.
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External programs
You can choose which program to use to send a document by e-mail using File > Send >
Document as E-mail or Document as PDF Attachment. In most cases, you will probably
want to use your default e-mail program. In that case, you don not need to make any changes
on this page.

On the Options – OpenOffice.org – External Programs dialog (Figure 7):

• To use your default e-mail program, leave the Program box showing Default e-mail
program.

• To specify a different program, choose its type in the Program list, and then in the
Path box, specify the location of the program on your computer.

Figure 7. Specifying an e-mail program to use with OpenOffice.org
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Paths
You can change the location of files associated with, or used by, OpenOffice.org to suit your
working situation. In a Windows system, for example, you might want to store documents by
default somewhere other than My Documents.

1) In the Options dialog, click OpenOffice.org > Paths.

2) To make changes, select an item in the list shown in Figure 8 and click Edit. On the
Select Paths dialog (not shown), add or delete folders as required, and then click OK
to return to the Options dialog. Note that many items have at least two paths listed:
one to a shared folder (which might be on a network) and one to a user-specific folder
(normally on the user’s personal computer).

Figure 8. Viewing the paths of files used by OpenOffice.org

Tip You can use the entries in the Options – OpenOffice.org – Paths dialog to compile a list of
files, such as those containing AutoText, that you need to back up or copy to another
computer.
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Colors
In the Options – OpenOffice.org – Colors dialog (Figure 9), you can specify colors to use in
OOo documents. You can select a color from a color table, edit an existing color, or define
new colors. These colors will then be available in color selection palettes in OOo.

Figure 9. Defining colors to use in color palettes in OOo
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Font options
You can define replacements for any fonts that might appear in your documents. If you
receive from someone else a document containing fonts that you don’t have on your system.
OpenOffice.org will substitute fonts for those it doesn’t find, but you might prefer to specify
a different font from the one the program chooses.

1) In the Options dialog, click OpenOffice.org > Fonts.

2) On the Options – OpenOffice.org – Fonts dialog (Figure 10):

• Select the Apply Replacement Table checkbox.

• Select or type the name of the font to be replaced in the Font box. (If you don’t
have this font on your system, it won’t appear in the drop-down list in this box,
so you need to type it in.)

• In the Replace with box, select a suitable font from the drop-down list of fonts
installed on your computer.

3) The checkmark to the right of the Replace with box turns green. Click on this
checkmark. A row of information now appears in the larger box below the input
boxes. Select the checkboxes under Always and Screen.

4) In the bottom section of the dialog, you can change the typeface and size of the font
used to display source code such as HTML and Basic (in macros).

Figure 10. Defining a font to be substituted for another font
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Appearance options
Writing, editing, and page layout are often easier to do when you can see as much as possible
of what’s going on in your document. You may wish to make visible such items as text, table,
and section boundaries (in Writer documents), page breaks in Calc, and grid lines in Draw or
Writer. In addition, you might prefer different colors for such items as note indicators or field
shadings.

On the Options – OpenOffice.org – Appearance dialog (Figure 11), you can specify which
items are visible and the colors used to display various items.

1) In the Options dialog, click OpenOffice.org > Appearance.

2) To show or hide items such as text boundaries, select or deselect the checkboxes next
to the names of the items.

To change the default colors for items, click the down-arrow in the Color Setting
column by the name of the item and select a color from the pop-up box.

3) To save your color changes as a color scheme, type a name in the Scheme box and
click Save.

Figure 11. Showing or hiding text, object, and table boundaries
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Accessibility options
Accessibility options include whether to allow animated graphics or text, how long help tips
remain showing, some options for high contrast display, and a way to change the font for the
user interface of the OpenOffice.org program (see Figure 12).

1) In the Options dialog, click OpenOffice.org > Accessibility.

2) Select or deselect the options as required.

Figure 12. Choosing accessibility options
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Choosing options for loading and saving
documents

You can set the Load/Save options to suit the way you work.

General load/save options
1) If the Options dialog is not already open, click Tools > Options. Click the + sign to

the left of Load/Save.

2) Choose Load/Save > General.

Most of the choices on the Options – Load/Save – General dialog (Figure 13) are familiar to
users of other office suites. Some items of interest are described below.

Figure 13. Choosing Load and Save options

Load user-specific settings with the document

When you save a document, certain settings are saved with the document. For example, your
choice on the Options – Text Document – General dialog of how to update links (Always, on
Request, Never) is a user-specific setting that is affected by this option. Some settings
(printer name, data source linked to the document) are always loaded with a document,
whether or not this checkbox is selected.

If you select this option, these document settings are overruled by the user-specific settings of
the person who opens it. If you deselect this option, users’ personal settings do not overrule
the settings in the document. 
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Choosing options for loading and saving documents

Edit document properties before saving

When you select this option, then the first time you save a new document (or whenever you
use Save As), the Document Properties dialog pops up to prompt you to enter relevant
information.

AutoSave

Note that AutoSave in OpenOffice.org overwrites the original file. If you have also chosen
Always save backup copy, the original file then overwrites the backup copy.

Size optimization for XML format (no pretty printing)

OpenOffice.org documents are XML files. When you select this option, OOo writes the XML
data without indents and line breaks. If you want to be able to read the XML files in a text
editor in a structured form, deselect this option.

Standard file format

If you routinely share documents with users of Microsoft Word, you might want to change
the Always save as attribute for text documents in the Standard file format section to one of
the Word document types.

VBA Properties Load/Save options
1) Choose Load/Save > VBA Properties. 

2) On the Options – Load/Save – VBA Properties dialog (Figure 14), you can choose
whether to keep any macros in MSOffice documents opened in OpenOffice.org. 

• If you choose Save original Basic code, the macros will not work in OOo but are
retained if you save the file into Microsoft Office format. 

• If you choose Load Basic code to edit, the changed code is saved in an OOo
document but is not retained if you save into an MSOffice format.

Figure 14. Choosing Load/Save VBA Properties
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Microsoft Office Load/Save options
1) Choose Load/Save > Microsoft Office.

2) On the Options – Load/Save – Microsoft Office dialog (Figure 15), you can choose
what to do when importing and exporting Microsoft Office OLE objects (linked or
embedded objects or documents such as spreadsheets or equations).

Select the [L] checkboxes to convert Microsoft OLE objects into the corresponding
OpenOffice.org OLE objects when a Microsoft document is loaded into OOo
(mnemonic: “L” for “load”).

Select the [S] checkboxes to convert OpenOffice.org OLE objects into the
correspnding Microsoft OLE objects when a document is saved in a Microsoft format
(mnemonic: “S” for “save”).

Figure 15. Choosing Load/Save Microsoft Office options
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Choosing language settings

You may need to do several things to set the language settings to what you want:

• Install the required dictionaries

• Choose the dictionaries and spelling options

• Change the default language for documents

• Set the version of English to be checked

Install the required dictionaries
OpenOffice.org 1.1.x automatically installs several dictionaries with the program. To add
other dictionaries, you can use the AutoPilot (not available in versions of OOo before 1.1.1)
or install them manually.

Using the AutoPilot

1) Be sure you have write permission on the folder <OOo>/share/dict/ooo and on the file
<OOo>/share/dict/ooo/dictionary.lst. 

2) Be sure you are connected to the Internet, unless you have already downloaded a
language pack or have one on a CD.

3) Click File > AutoPilot > Install new dictionaries. OOo opens a file (DicOOo.sxw)
containing instructions in several languages and macro buttons to start the download
and installation process. (The available dictionaries are for many more languages than
those used in the instructions.)

4) Click the macro button and follow the instructions in the wizard to download a list of
available dictionaries, select the ones you want, and download and install them. This
process proceeds automatically.

Installing a dictionary manually

1) Close all open OOo windows and the Quickstarter.

2) If necessary, download the dictionary zip file from
http://lingucomponent.openoffice.org/download_dictionary.html or another source.
The zip file will contain two files. The names of the files should be similar to
en_GB.aff and en_GB.dic. The filename corresponds to the language for the dictionary
(en is for English; GB is for Great Britain, for the U.K. English dictionary).

3) Extract the two files into the folder specified in the Dictionaries path in the Options –
OpenOffice.org – Paths dialog (Figure 8 on page 8). This would typically be the
<OOo>/share/dict/ooo  folder. 

4) Look in this folder for a file named dictionary.lst. If it does not exist, create it.

5) Open this file in a text editor such as Notepad. Add this line to the file:
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Choosing language settings

6) DICT en GB en_GB  (Change the filename to match the dictionary filename.)

7) Save the file as plain text.

Choose the dictionaries and spelling options
After installing the dictionaries, you need to register them with OOo:

1) Start OOo (if it’s not already running) and click Tools > Options.

2) Expand Language Settings and choose Writing Aids (Figure 16).

3) Make sure OpenOffice MySpell SpellChecker under Available language modules is
selected, then click the Edit button at the top right of the dialog.

Figure 16. Choosing languages, dictionaries, and options for checking spelling

4) In the Edit Modules dialog (Figure 17), select the language from the list at the top,
then select OpenOffice MySpell SpellChecker under Spelling. Click Close.
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Figure 17. Registering a new dictionary

5) Back on the Writing Aids dialog (Figure 16), choose the settings that are useful for
you. Some considerations:

• If you don’t want spelling checked while you type, select Do not mark errors and
deselect AutoCheck. (To find these items, scroll down in the Options list.)

• If you use a custom dictionary that includes words in all uppercase and words with
numbers (for example, AS/400), select Check uppercase words and Check words
with numbers.

• Check special regions includes headers, footers, frames, and tables when checking
spelling.

• Here you can also check which user-defined (custom) dictionaries are active by
default, and add or remove dictionaries, by clicking the New or Delete buttons. 

Change the default language for documents
1) Choose Languages under Language Settings on the left-hand side of the Options

dialog. 

2) On the right-hand side (as shown in Figure 18), change the Locale setting, Default
currency, and Default languages for documents. In the example, English (Australia)
has been chosen as the locale, and the Australian dollar (AUD) for the currency.
Although an English (Australia) dictionary exists, the English (UK) dictionary has
been selected as the default language.

3) If you want the language (dictionary) setting to apply to the current document only,
instead of being the default for all new documents, select the checkbox labelled For
the current document only.

4) If necessary, select the checkboxes to enable support for Asian languages (Chinese,
Japanese, Korean) and support for CTL (complex text layout) languages such as Hindi,
Thai, Hebrew, and Arabic. If you choose either of these checkboxes, the next time you
open this dialog, you will see some extra dialogs under Language Settings.

5) Click OK to save your changes and close the dialog.
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Figure 18. Choosing language options
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Controlling OOo’s AutoCorrect functions

You may find that some or all of the items in OOo’s AutoCorrect function are very annoying
because what you type will often change when you don’t want it to. Many people find some
of the AutoCorrect functions quite helpful; if you do, then select the relevant checkboxes. But
if you find unexplained changes appearing in your document, this is a good place to look to
find the cause. 

To open the AutoCorrect dialog, click Tools > AutoCorrect/AutoFormat. 

In Writer, this dialog has five tabs, as shown in Figure 19. In other components of OOo, this
dialog has only four tabs, and the contents of the Options tab is as shown in Figure 20.

Figure 19. The AutoCorrect dialog in Writer, showing the five tabs and some of the choices on the Options tab

Setting Up OpenOffice.org 20



Controlling OOo’s AutoCorrect functions

Figure 20. The AutoCorrect dialog in Calc, showing four tabs and the choices on the Options tab

Setting Up OpenOffice.org 21


	Contents
	Overview
	Copyright and trademark information
	Feedback
	Acknowledgments
	Modifications and updates

	Choosing options that affect all of OOo
	User data
	General options
	Year (two digits)
	Help Agent
	OpenOffice.org Help formatting
	Open/Save dialogs
	Document status
	Back button

	Memory options
	View options
	Scale
	Menu follows mouse pointer
	Preview in fonts lists
	Inactive menu items
	Font history
	Restore - Editing view
	Restore - Open windows
	3D view
	Mouse

	Print options
	External programs
	Paths
	Colors
	Font options
	Appearance options
	Accessibility options

	Choosing options for loading and saving documents
	General load/save options
	Load user-specific settings with the document
	Edit document properties before saving
	AutoSave
	Size optimization for XML format (no pretty printing)
	Standard file format

	VBA Properties Load/Save options
	Microsoft Office Load/Save options

	Choosing language settings
	Install the required dictionaries
	Using the AutoPilot
	Installing a dictionary manually

	Choose the dictionaries and spelling options
	Change the default language for documents

	Controlling OOo's AutoCorrect functions

