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Overview

Overview

This document is primarily for people or organizations who currently use or have used
Microsoft Office and are investigating or are actively changing to OpenOffice.org. It is aimed
at intermediate to advanced users of Microsoft Office; therefore, if the functionality in
OpenOffice.org is not significantly different, then typically that function is not mentioned.

Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License,
Version 1.0 (the "License"); you may only use this Documentation if you comply with the
terms of this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf

The Original Documentation is Migration Guide: A guide to ease your migration to
OpenOffice.org from other office suitesages. The Initial Writer(s) of the Original
Documentation is/are Ian Laurenson © 2004. All Rights Reserved. (Initial Writer contact(s):
hillview@paradise.net.nz. The Initial Writer contact(s) is to report errors in the
documentation. For questions regarding how to use the software, subscribe to the
OpenOffice.org Users Mail List and post your question there:
http://www.openoffice.org/mail_list.html#general)

All trademarks within this guide belong to legitimate owners.

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org

Acknowledgments
I would like to acknowledge all those who have posted requests and solutions to the forums.

I would also like to thank other documenters whose work I have based some of this material
on, particularly: Daniel Carrera, Jean Hollis Weber, Sophie Gautier, Scott Carr, Ralph
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this document are mine and do not reflect on them. Thanks to the other authors on the
OOoAuthors site, particularly Diane Mackay and Jean Hollis Weber.

My greatest thanks go to my partner, Warwick Anderson, without whom writing this guide
would not have been possible!
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Introduction

What is OpenOffice.org?

See the chapter titled “What is OpenOffice.org?” in the Introduction to the User Guide for an
overview about OpenOffice.org and its ability to work with text documents, spreadsheets,
presentations and drawings. OpenOffice.org is open source software; in this document you
will learn more about what this means.

How do I install OpenOffice.org?

See the chapter titled “Installing OpenOffice.org” in the Introduction to the User Guide for
instructions that show how to download and install OpenOffice.org.

How do I get support?

See the chapter titled “How to Get Help” in the Introduction to the User Guide to learn where
and how to ask questions to acquire the best support during your migration to
OpenOffice.org.

What’s involved in the initial migration?

Sharing files
See Sharing files with Microsoft Office users on page 4 for information about opening and
saving files of various formats.

How do I import other files used in Microsoft Office?
See Importing other Microsoft Office fileson page 23 for information about importing custom
dictionaries, auto-correct entries and Auto Text entries into OpenOffice.org.
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Introduction

What other resources are available to help with
migrating to OpenOffice.org?
See http://se.sun.com/edu/staroffice/so_migration_guide_0104.pdf for a document developed
by Sun that covers similar issues regarding migration to StarOffice, the cousin and
commercial version of the OpenOffice.org office package. 

What changes do I need to make in the way
that I work?

While the interfaces of OpenOffice.org and Microsoft Office are sufficiently similar to allow
immediate productivity, they are not identical. Some functions are based on different
underlying concepts. Documents linked herein are guides to help you with these differences.

In general what is different in use between
Microsoft Office and OpenOffice.org?
See General differences in use between OpenOffice.org and  Microsoft Office on page 26
first as it gives an overall view of differences; the other linked documents build on the
information presented in this section.

How can I change OpenOffice.org to make it work
even more like the way I have worked in Microsoft
Office?
See Customizing OpenOffice.org on page 43 for information about customizing
OpenOffice.org. This section includes links to macros that were written to help ease the
transition.

What are the specific differences in use between
Word and Writer?
See Differences in use between Writer and Word on page 47 for specific information related
to text documents.

What are the specific differences in use between
Excel and Calc?
See Differences in use between Calc and Excel on page 70 for specific information related to
spreadsheets.
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What are the specific differences in use between
PowerPoint and Impress?
See Differences in use between Impress and PowerPoint on page 80 for specific information
related to presentations.

How do I use the Math Object editor
(OpenOffice.org’s equivalent to Equation Editor)?
See the chapter titled “Editing Math Objects” in the Common Features Guide.

What about that database functionality?
See the chapter titled “Using Data Sources” in the Common Features Guide.

Is there an equivalent to WordArt?
See the chapter titled “FontWork” in the Common Features Guide.

What are the issues when migrating from
WordPerfect to Writer?

How do I install the WordPerfect filter?
The WordPerfect filter is not available in the standard OpenOffice.org installation. See
http://libwpd.sourceforge.net/ for more information about the WordPerfect filter.

What macros are available to make Writer work
more like WordPerfect?
Reveal codes

OpenOffice.org’s Writer doesn’t have underlying codes in the same way that WordPerfect
does. But a macro is being written that will allow you to work in a similar way to
WordPerfect’s reveal codes. See the reveal code document available at
http://homepages.paradise.net.nz/hillview/OOo/ for more information.

Hanging indents

The hanging indent concept in Writer is quite different from the concept used in
WordPerfect. The best approach in OpenOffice.org is to use styles, but to ease the transition,
see either AltKeyHandler.sxw or Indents.sxw available from
http://homepages.paradise.net.nz/hillview/OOo/ for a macro that approximates WordPerfect’s
way of implementing hanging indents.
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Sharing files with Microsoft
Office users

This chapter outlines the issues when importing Microsoft Office format files to
OpenOffice.org and exporting from OpenOffice.org in Microsoft Office file formats.

File formats

This section gives an overview of file format from an end-user’s perspective. For details
about XML formats, see http://books.evc-cit.info/book.php.

OpenOffice.org “natively” stores its files in a compressed (zipped) human readable (when
unzipped) XML format. This format is openly documented and is available under the GNU
General Public Library License (http://www.gnu.org).

Note: Some compression utilities only check the file extension and so may not recognize the file
as being compressed in the zip format. To open an OpenOffice.org file with such a compression
utility, rename the file to have the extension .zip.

By contrast, Microsoft Office files are stored in a proprietary format which is not human
readable. Microsoft have not publicly documented their file formats, which causes a lot of
problems for software developers to write filters for importing and exporting in Microsoft
Office formats.

Table 1. File extensions

Document
type

Application Document
Extension

Template
Extension

Microsoft
Office eqv

Text Writer .sxw .stw .doc .dot

Spreadsheet Calc .sxc .stc .xls .xlt

Drawing Draw .sxd .std na

Presentation Impress .sxi .sti .ppt .pot .pps

Formula Math .sxm na

Master document Writer .sxg na

HTML document Writer .html na
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Sharing files with Microsoft Office users

Note: OpenOffice.org can open Microsoft Office files. The reverse is NOT true: Microsoft Office
can not open OpenOffice.org formats. So if you need to deal with someone using Microsoft
Office, save your file first in the native OpenOffice.org format; then you can save it to one of the
many supported Microsoft Office formats. This way you ensure that even if the filter can’t
translate perfectly, you have your original in its native format.

Bulk conversion

To convert a lot of files:
File > AutoPilot > Document Converter...

Note: Converting a lot of files can take a long time. Recommend to set it going when the
computer is not going to be used for a while, but check for sufficient disk space.

Before doing a bulk conversion of files, think about whether it is really necessary. Read this
document right through to get an appreciation of the limitations of the conversion process.

Opening files

Opening text format files
OpenOffice.org Writer can import the standard Microsoft Office formats (as shown in the
right column of Table 1) as well as the .rtf, .txt, .csv and StarWriter formats.

When opening .HTM or .HTML files, OpenOffice.org customizes Writer for working with
these files.

Opening spreadsheets
In addition to the native formats, OpenOffice.org can open the following spreadsheet
formats:

Microsoft Excel 97/2000/XP (*.xls; *.xlw)
Microsoft Excel 97/2000/XP Template
(*.xlt)
Microsoft Excel 95 (*.xls; *.xlw)
Data Interchange Format (*.def)
dBase (*.dbf)
Sylk

Rich Text Format
Text CSV (*.csv; *.txt)
Lotus 123 (*.wk1; *.wk1)
StarCalc formats
HTM and HTML files including Web page
queries
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Sharing files with Microsoft Office users

Opening presentations
In addition to the native formats, OpenOffice.org can open the following presentation
formats:

Microsoft PowerPoint 97/2000/XP (*.ppt; *.pps)
Microsoft PowerPoint 97/2000/XP Template (.pot)
StarDraw, StarImpress
CGM - Computer Graphics Metafile (*.cgm)

Opening graphics files
In addition to the native formats, OpenOffice.org can open the following graphic formats:

BMP
DXF
EMF
EPS
GIF
JPEG
MET

PBM
PCD
PCX
PGM
PLT
PNG

PPM
PSD
RAS
SGF
SGV
Star Draw

SVM
TGA
TIFF
WMF
XBM
XPM

Opening formula files
In addition to its native format, OpenOffice.org can open the following formula files:

StarMath and MathML (*.mml).

When opening a Word document that contains an embedded equation editor object, if the
option for it is checked in Tools > Options > Load/Save > Microsoft Office then the object
will be automatically converted to an OpenOffice.org Math object.
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Sharing files with Microsoft Office users

Saving files

Default file format
To set the default file format when
saving new files:

Tools > Options... > Load/Save >
General

Note: If the default is set to an
OpenOffice.org format and a Microsoft
Office file is being saved, then a warning
dialog will be displayed about potential
loss of formatting.

Export to PDF
In each application there is the ability to directly export to PDF. This industry-standard file
format for file viewing is ideal for sending the file to someone else to view using Acrobat
Reader or any other PDF display program like ggv or Xpdf.

You can export directly to PDF using a button on the toolbar (next to the Printer icon) for
export directly to PDF, or by choosing File > Export, which allows you to select some more
detailed options.

Saving files in other formats
To save files in different formats:

File > Save As > File Type:

Writer can save to these file formats
In addition to its native formats, Writer can save in these formats:

OpenOffice.org Writer template (.stw)
Microsoft Word 97/2000/XP (.doc)
Microsoft Word 95 (.doc)
Microsoft Word 6.0 (.doc)
Rich Text Format (.rtf)
StarWriter 5.0 (.sdw)
StarWriter Template (.vor)

StarWriter 4.0 (.sdw)
StarWriter 4.0 Template (.vor)
StarWriter 3.0 (.sdw)
StarWriter Template 3.0 (.vor)
Text (.txt)
Text Encoded (.txt)
HTML (.html; .htm)
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Sharing files with Microsoft Office users

Note: The .rtf format is a common format for transferring text files between applications but be
aware of the lack of formating available in that format. It also seems that there is a bug
concerning files saved in the .rtf format that contain images when opened by Microsoft Office.
So the best way to pass a file in writer to a Microsoft Word user is to save it as Microsoft Word
97/2000/XP (.doc).

Calc can save to these file formats
In addition to its native formats, Calc can save in these formats:

Microsoft Excel 97/2000/XP (*.xls; *.xlw)
Microsoft Excel 97/2000/XP Template (*.xlt)
Microsoft Excel 95 (*.xls; *.xlw)
Data Interchange Format (*.dif)
dBase (*.dbf)

SYLK (*.slk)
Text CSV (*.csv; *.txt)
StarCalc formats (*.sdc, *.vor)
HTM and HTML files 

Impress can save to these file formats
Microsoft PowerPoint 97/2000/XP (*.ppt; *.pps)
Microsoft PowerPoint 97/2000/XP Template (*.pot)
StarDraw, StarImpress (*.sda, *.sdd, *.vor)

Impress can also export to MacroMedia Flash (*.swf) and any of the graphics formats as
listed below for Draw.

Draw can save to these file formats
Draw can only save in its native format and StarDraw format, but can export to:

BMP
EMF
EPS
GIF
JPEG

MET
PBM
PCT
PGM
PNG

PPM
RAS
SVG
SVM
TIFF

WMF
XPM

The HTML writer can save in these formats
HTML Document (*.html; *.htm)
OpenOffice.org 1.0 HTML Template (*.stw)
StarWriter/Web5.0 and 4.0 (*.vor)
Text (OpenOffice.org Writer/Web) (*.txt)
Text Encoded (OpenOffice.org Writer/Web) (*.txt)
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Sharing files with Microsoft Office users

AportisDoc and PocketWord files for transport to
your PDA
When installing OpenOffice.org, you can optionally choose to install DocBook and XLST
filters. They are then added to the Save As menu automatically. For more information, see the
chapter on installing OpenOffice.org.

Object Linking and Embedding (OLE)

To change the settings for Microsoft Office OLE objects:

Tools > Options > Load/Save > Microsoft Office

Having all of these options checked will allow embedded objects to be converted and thus be
editable in both office suites.

For other OLE objects, it will depend on the machine where the file is being edited just as it
does with Microsoft Office alone. Thus Windows application based OLE objects will not be
editable in OpenOffice.org on a Linux machine, although the object will still be displayed
correctly and is able to be resized.

Linked files

Cells copied from Excel and pasted special, linked and with RTF format, into Word are
imported into Writer as a normal table. This means that when the document is imported, the
link to the Excel file is lost.

Similarly when a chart is copied from Excel and pasted special, linked into Word, and then
the file imported into Writer, the chart is imported as an embedded OLE object but is not
converted into a Calc chart. On saving the file in Word format and then opening the file in
Word and trying to edit the chart by double-clicking, it displays an error message.

Warning: The links are lost!

WordArt / FontWork

The equivalent to Microsoft Office’s WordArt in OpenOffice.org is FontWork. WordArt
objects are imported as graphics so the ability to edit them is lost. Similarly, FontWork
objects are exported into Microsoft Office files as graphics only. See the chapter on
FontWork.
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Sharing files with Microsoft Office users

Vector graphics

The basic shapes (lines, arrows, rectangles, ovals) all import and export without any problem.
OpenOffice.org provides a greater degree of control over some properties than Microsoft
Office does, so sometimes there will be changes when going from OpenOffice.org to
Microsoft Office. Examples include the size of arrow heads, and line styles.

The Microsoft Office autoshapes, like the smiley face, lose their special characteristics. For
instance the ability to adjust the degree of the smile / frown on the smiley face is lost.

Microsoft Office provides more shadow options than OpenOffice.org, so sometimes there
will be a change in shadow appearance. Microsoft Office shadow styles 1, 2, 4, 6,14, 17 and
18 are supported in OpenOffice.org. Horizontal and tapered shadows do not get imported.

On exporting documents containing graphics, such as callouts, the locations frequently
change.

Frames / text boxes

When frames or text boxes from Microsoft Office are imported into OpenOffice.org with
linked text, the links do not remain.

Active content controls

These are the controls in Microsoft Office available on the Controls toolbar.

Checkboxes, radio buttons, text fields, labels, list boxes, combo boxes, and toggle buttons all
import without a problem. But as these controls typically require macros to be of use, they
will be functionally useless in the absence of macros custom built for use in OpenOffice.org.

Scrollbars and images import as OLE objects.

Macros

OpenOffice.org cannot run Microsoft Office macros. Although the macro language is very
similar, the underlying objects are quite different. To set whether OpenOffice.org keeps
attached macros for Word, Excel and PowerPoint files, use:

Tools > Options... > Load/Save > VBA properties

Note: Opening a Microsoft Office file infected with a virus is quite safe in OpenOffice.org.

OpenOffice.org has the ability to record macros. The recorder uses something called a
dispatcher. It is better practice to use the application program interface (API).
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Import / export / sharing issues in text
documents

Good practice in text documents
Some issues can be avoided simply by using good word-processing practice:

• Use character and paragraph styles rather than direct formatting.

• Use paragraph formatting for space before and after rather than hard returns, particularly
in numbered or bulleted lists.

• Use paragraph text flow properties (e.g. keep with next) rather than using manual page
breaks.

• Do not use multiple tabs or spaces to align text – either set specific tab stops or better yet
use a table.

• Use only commonly available fonts.

Compatibility settings in OpenOffice.org for the
current document
The following settings change the way OpenOffice.org works with the current document so
that it works more like Microsoft Office.

Use Tools > Options... > Text Document > General

Tops of pages

In Writer, if this setting isn’t checked, if a paragraph at the top of the page (or column) is
formatted with space above then the space above is ignored, whereas in Word the space
above is included it. Checking this option causes Writer to behave in the same way as Word.

Aligning tabs

This setting specifies whether centered and right-aligned paragraphs containing tabs are
formatted as a whole in the center or aligned to the right. If this checkbox is not marked, only
the text to the right of the last tab is aligned to the right, while the text to the left remains as
is. (From help.)

Spacing between paragraphs

Writer uses the greater of the two spacings for above and below paragraphs; Word sums the
two together. Check this box to have Writer behave in the same way as Word.
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Font and font spacing
Text effect animations are not imported by Writer from Word files.

Hidden text in Writer is a field, whereas in Word it is a font attribute.

Typically Word’s character spacing is tighter than Writer’s, so often Word will fit more
characters to a line. It is also possible that the spacing between lines could be slightly
different. The end result is that the page breaks may be in different places.

Tables
Writer doesn’t allow a row within a table to be split across pages. Word (by default) allows a
row to be split across pages.

Writer doesn’t support vertical text within a cell.

Warning: There is a vertical option for formatting text (Format > Character... > Rotation /
Scaling) for some reason that the authors haven’t figured out this is not recommended for using
in a table; see: http://www.openoffice.org/issues/show_bug.cgi?id=16944. If it is used in a table
in a document and that document gets exported to Word then Word goes into a loop perpetually
trying to re-paginate the document.

Text in a table with vertical alignment imported from Word: the vertical text simply becomes
horizontal.

Fields for calculations within tables are imported as the text of the saved result. In other
words, the field for performing the calculation is lost.

Summary: Documents containing tables can be imported and exported between
OpenOffice.org and Microsoft Office, but they cannot contain vertical text, nor should a row
span more than a page.

Mail merge documents
As OpenOffice.org and Writer have different approaches to data sources, on importing a
Word document that is the main document for a mail merge there is no connection with the
data source. It is not just a matter of making that connection, each field needs to be
reinserted.

See the Mail Merge section in the Text Document differences chapter.

Also in Word you can have another Word document as a data source for a mail merge. There
is no way of specifying a Word (or Writer) document as a data source in OpenOffice.org.

Writer doesn’t have the option of suppressing blank lines when data fields are empty, so you
need to use conditional fields.

See the Eliminating blank lines in the Text Document differences chapter.

Writer merge fields export as text with the name of the field between angle brackets, e.g.
<Name>.
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Summary: To work in a shared environment would require a separate file for each “main
document”: one in Word format, the other in OpenOffice.org format.

Forms
Issues with forms created in Microsoft Office:

A locked file in Microsoft Office imports unlocked into OpenOffice.org; that is, in design
mode.

Text form fields import into OpenOffice.org as Input fields and so lose their type. For
example, a text form field of type “number” or “date” will accept any text for input. In use a
text form field in OpenOffice.org displays a dialog for entering the text. Exporting back to
Microsoft Office, text form fields are changed into “Fillin” fields. The current date and time
and calculation fields import as simple text.

Check-boxes import/export ok.

Drop-down form fields import as Input List fields. Like text form fields in operation these
display a dialog from which the user can select an option. On export back to Microsoft Office
they return to drop-down form fields again.

Issues with forms created in OpenOffice.org:

The controls are exported as active controls when there is a Microsoft Office equivalent. As
Word doesn’t have the same database functionality of OpenOffice.org and as the macros
aren’t compatible, it would be very difficult to have one form that works in both
environments using standard form controls.

Summary: To work in a shared environment with forms is not easy but one workaround
would be to use other fields like Input field and Input List. To insert these fields use: Insert >
Fields > Other... > Functions.

Footnotes, end notes, tables of contents and
indexes
Footnotes, endnotes and indexes all import / export ok. Some issues found:

• The location of the endnotes may change (in Word the endnotes were placed before
the index. In Writer they are always at the end of the document).

• Writer bibliographic entries become text in Word.

• A three column index exported from Writer to Word as three columns but on re-
import it was one column.

• On importing a Word file containing index entry fields, the index entry fields are
imported but as fields to the left of the text rather than the field containing the text.

Summary: Working in a shared environment is possible with some minor issues.
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Numbered paragraphs, outline numbering, cross-
references
Import / Export without a problem, except for references to numbered paragraphs:

• Cross-references to the numbers of numbered paragraphs that aren’t numbered using
outline numbering don’t work as Writer doesn’t have this ability

• Writer also doesn’t have the ability to use relative numbering in its cross-references to
numbers.

• Cross-references to chapter numbers don’t have the same format as that displayed.

Page numbering
A quick and dirty approach in Word for having a different first page (like a cover page) and
then to have the numbering start on the second page but numbered as page 1 is to have a
layout of different first page and setting the starting page to be zero. Unfortunately, on
importing such a file into OpenOffice.org the page number on the second page is 2 instead of
1. To fix this problem in Writer, use:

1) Create a page style for how the pages after the first page should look. Name it (for
example) Convert1.

2) Have the cursor in the first paragraph of the second page.

3) Format > Paragraph > Text Flow.

4) In the Breaks portion of the dialog, select the checkbox Enable.

5) Check With Page Style.

6) Choose the page style created in step 1.

7) Leave the position as Before and set the page number to 1.

On exporting this document back to Word it will work, the only difference being that the
document will have a section break at the end of the first page. Documents created with
section breaks like this in Word will work fine importing and exporting with Writer. There is
one difference with Word: there will now be a blank page between the cover page and the
next page when printed (or print previewed).

Summary: For some documents a little work maybe required to fix up the page numbering on
importing to Writer. Once “fixed” the page numbering of the documents will import/export
without a problem.

Date and time fields
Word’s CreateDate and SaveDate fields don’t get imported with the same formats. For
example, if the fields in the Word document have a format that includes time, then this
information is not displayed by default. To include time in the format:
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Right click on the field > Fields... > scroll to the bottom of the Formats listbox > Additional
formats... > in format code add HH:MM:SS

On export the SaveDate / DocInformation:Modified is exported as text.

Writer’s Time Fixed and Date Fixed fields get exported as text.

Importing Word fields
Table 2: Imported Word fields conversion

Word Field: Writer converts to:
ASK Input field

AUTHOR DocInformation:Created

AUTONUM Number Range AutoNr

AUTONUMLGL Number range AutoNr

AUTONUMOUT Number range AutoNr

COMMENTS DocInfomation:Comments

CREATEDATE DocInformation:Created

DATE Date

EDITTIME DocInformation:Modified

FILENAME File name

FILLIN Input field

HYPERLINK (as a hyperlink)

INFO xxx DocInformation:xxx

KEYWORDS DocInformation:Keywords

LASTSAVEDBY DocInformation:Modified

MACROBUTTON (the name of the macro?)

MERGEFIELD Mail merge fields (displayed as the name of the field)

MERGEREC Record number

NEXT Next record

NOTEREF Show variable

NUMCHARS Statistics (with select = Characters)

NUMPAGES Statistics (with select = Pages)

PAGE Page numbers

PAGEREF Bookmarks (displayed as name of bookmark)

REVNUM DocInformation:Document number

SAVEDATE DocInformation:Modified

SEQ Number range

SET Set variable
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Word Field: Writer converts to:
SUBJECT DocInformation:Subject

TEMPLATE Templates

TIME Date

TITLE DocInformation:Title

TOC (Displays the table of contents)

The following fields are not imported into OpenOffice.org (only the text that they displayed
when last saved):  =, IF, DOCPROPERTY, FILESIZE, LINK, LISTNUM, QUOTE,
SECTION, SECTIONPAGES, STYLEREF, TOA, USERADDRESS, USERINITIALS,
USERNAME.

The following fields are ignored on import: AUTOTEXT, AUTOTEXTLIST, BARCODE,
BIDIOUTLINE, DOCVARIABLE, EQ, GOTOBUTTON, INCLUDETEXT, LISTNUM,
MERGESEQ, PRINT, RD, SKIPIF, SYMBOL, TA, TC.

The Word field EDITTIME is mapped to Writer field DocInformation:Modified on import
but the meaning has changed to the date and time last saved rather than how long the file has
been open for editing.

Import / export / sharing issues in
spreadsheets

Password protected workbooks
Workbooks that have been password protected in Excel cannot be opened by Calc. The file
needs to be saved in Excel without password protection so that Calc can open it. If you don’t
have access to Excel, then to open the files you need another program. In Windows you can
use an Excel viewer (free to download from Microsoft) and in Linux you can use Gnumeric
1.2.6 and above. (As Gnumeric is open source it is probable that this limitation will soon be
removed from Calc.)

Number of rows
Calc only supports 32,000 rows (compared to Excel’s 65,536). When importing an Excel
workbook that contains a sheet with more than 32,000 rows, Calc creates a new sheet so the
data isn’t lost, but any formulas that refer to that data need to be manually changed.

Number of sheets
The maximum number of sheets in Calc is 256. When importing an Excel spreadsheet with
more than 256 sheets, a warning about data loss is displayed.
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Form fields
Combo boxes, list boxes and checkboxes with links to spreadsheet cells all import and export
properly, although due to font handling the number of rows displayed in list boxes may be
slightly different. List boxes in Calc can either have multi-selection or not, whereas Excel has
two multi-selection modes: multi and extend. In Excel a multi-selection listbox’s link to a
cell is ignored (at least in Excel2000; the author hasn’t checked Excel XP). In Calc the link
works, but if more than one item is selected, the cell’s value is set to #N/A.

Option buttons import into Calc, but the link with cells works differently. In Calc each option
button has its own link to a cell, setting its value to true or false depending on whether the
option is selected. In Excel the cell link returns the number of the selected option button. On
exporting option buttons to Excel, the option buttons lose their radio operation – in other
words, they are not grouped so that selecting one does not “unselect” the others.

Scroll bars and spinners are not implemented in Calc.

Array formulas
Calc supports array formulas (formulas entered using Control+Shift+Enter) but there are two
things which Excel can do that Calc can’t do.

In Excel it is possible to have an array formula with two ranges in the formula and Excel
matches each cell in the ranges to get a result. For example, {=SUM(IF(A2:A5=1,B2:B5))}
would work like SUMIF and sum those cells in column B where in the same row column A
contained a 1. Calc returns “Err504”. Often this can be worked around by using SUMIF,
COUNTIF, or the database functions.

Array constants are not available in OpenOffice.org. The workaround is to have the constant
values in cells on a sheet and refer to them.

Optional parameters in formulas
Some formulas have more than one optional parameter at the end of the parameter list. In
Excel it is possible to leave an optional parameter blank and specify a later parameter, but
this is not possible in Calc. Formulas with optional parameters are not correctly imported into
Calc.

Functions
Statistical, engineering and financial functions

The statistical functions return slightly different results. They are the same up to at least 5
decimal places, but after that there is a discrepancy. Gnumeric (another open source
spreadsheet package) returns exactly the same results as Excel (based on the author’s simple
tests). The author hasn’t compared the results returned by a statistical package such as R or
SAS for the statistical functions.
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In Excel some of the financial functions accept string parameters for dates; in OpenOffice.org
they require a serial number, and thus they are not correctly imported into Calc.

Analysis ToolPak Functions

The function EFFECT provided by the Analysis ToolPak for Excel is converted to
EFFECT_ADD in Calc and returns the same results.

Other functions not implemented / imported

Only three other functions are not imported: INFO, GETPIVOTDATA, and HYPERLINK.
Hyperlinks are supported but not as a function – use the Hyperlink button on the Function
bar.

DataPilot / Pivot Table
DataPilots are Calc’s equivalent to Excel’s Pivot Tables. However there are a number of
limitations. Pivot tables import from Excel into Calc but as soon as they are worked on these
limitations become apparent. The limitations are:

• There is no PivotChart facility, but a DataPilot can be used as the data source for a
chart.

• Page fields have not been implemented, but there is a filter option which gives similar
functionality.

• Can have no more than 8 fields in the data, row or column areas.

• There is no ability to group data (for example, a date field grouping by month can’t be
done). The workaround is to create a new column with a formula for calculating the
grouping, e.g. =Month().

• You can’t define different formats for different fields.

• There are no calculated fields.

• There is no ability to show data fields as things like “Difference From” or “% of”

• The Application Program Interface specification is incomplete for writing macros that
work with DataPilots—for example, the ability to control through another program,
such as OpenOffice.org’s own macro language, BASIC, whether the tables have grand
totals, or having access to DataPilots created from external data.

AutoFilter
AutoFilter imports and exports ok with the required rows being hidden. However, there are a
number of differences between Excel and Calc:

• There is only one AutoFilter active for a spreadsheet document at a time. The rows
remain hidden but the drop downs in the first row disappear on applying AutoFilter
elsewhere.
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• The remaining visible row numbers don’t change color to warn that there is a filter in
place.

• Error values don’t show as an option in the drop down lists when cells in the column
have errors.

• In the drop down lists, the equivalent to Excel’s “Custom” is called “Standard”.

Charts
Chart types that Excel provides that Calc doesn’t:

• Bar of pie converts to a 2D - columns - normal

• Pie of pie converts to a 2D - columns - normal

• Radar filled converts to 3D – columns deep

• Radar with markers – converts to 2D – net – normal but counter clockwise rather than
Excel’s clockwise

Other charting issues include:

• There are fewer axis options, such as no option for having an inverted y axis (negative
at top towards positive at bottom).

• The data must be contiguous, with the labels in the first row or column.

Right aligned text
In Excel if text is longer than the cell can hold and right aligned and there is nothing in the
cell to the left, then the text “spills” into this cell. In Calc, the text will “spill” into the cell to
the right if it is empty.

Number formats
There is no “accounting” format (with the currency symbol at the left edge of the cell). A
workaround would be to have another column to the left that contains the currency symbol.

There is no predefined option for bracketing negative numbers. Use a custom format such as
“$#,##0.00_);[RED]($#,##0.00)”.

Grid lines
In Excel gridlines are a property of a Worksheet; in Calc it is an application wide option:

Tools > Options > Spreadsheet > View
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Import / export / sharing issues in
presentations

Color gradients and borders
The author had not noticed the following changes, so this is a direct quote from “StarOffice 7
Migration Guide” by Sun.

Unlike Microsoft PowerPoint, StarOffice Impress does not support three color gradients,
double and triple borders, or round-dotted borders. To improve the results of the import, you
have to make the necessary adjusts before import. Change three-color presets to similar two-
color gradient fills and change double and triple border lines to a single border line with
appropriate width. Round-dotted border lines that are mapped to rectangle-border closely
resemble the original line style in PowerPoint so that manual editing should not be necessary.

Multimedia
Voice-over narration is not supported by Impress.

There appear to be no settings for multimedia custom animations, such as the ability to play a
sound for the next x slides.

Chart animations
There is no facility in Impress for “Chart Effects” as there is in PowerPoint, such as
presenting a series or category at a time. On import the charts simply appear. A workaround
is to have multiple copies of the chart with each one set up to display as desired.

Pack and Go
This feature in PowerPoint allowed a PowerPoint file to be split up over several floppy disks
and assured that all related files were included. This facility is not included in Impress, nor
can Impress open such files.

Fields
Date fields are exported as text, so they don’t automatically update.

Action Settings / Interaction
PowerPoint provides action settings for mouseover, but Impress doesn’t have this option,
only on mouse click, so mouseovers get mapped to mouse clicks. PowerPoint has an option
for highlighting the object on mouse click / mouse over; Impress doesn’t have this, so it gets
ignored on import.
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PowerPoint custom animations – Impress object
effects
Table 3 shows how the custom animations / object effects are imported into Impress and
exported to PowerPoint.

Table 3. Importing/exporting custom animations between PowerPoint and Impress

PowerPoint Impress
Appear Appear

Blinds Fade Horizontally

Box Fade To Center

Checkerboard Checkerboard

Diamond Appear

Crawl Fly In From bottom

Dissolve Dissolve

Flash once Appear

Peek Short Fly In from Bottom

Random Bars Horizontal lines

Spiral Spiral Outward Clockwise

Split Close Vertical

Stretch Stretch Vertical

Strips Fade From Top Right

Swivel Rotate Horizontally

Wipe Cross-Fade From Top

Zoom Fade From Center

Random effects Vertical Lines

PowerPoint  – Impress slide transitions
Table 4 shows how slide transitions are imported into Impress and exported to PowerPoint.

Table 4. Importing/exporting slide transitions between PowerPoint and Impress

PowerPoint Impress
Blinds Horizontal Fade Horizontally

Blind Vertical Fade Vertically

Box In Fade To Center

Box Out Fade From Center

Checkerboard Across Horizontal Checkerboard

Checkerboard Down Vertical Checkerboard
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PowerPoint Impress
Cover Down Fly In From Top

Cover Left Fly In From Right

Cover Right Fly In From Left

Cover Up Fly In From Bottom

Cover Left Down Fly In From Upper Right

Cover Right Down Fly In From Top Left

Cover Left Down Fly In From Upper Right

Cover Right Up Fly In From Lower Left

Cut No effect

Cut through Black No effect

Dissolve Dissolve

Fade Through Black No effect

Random Bars Horizontally Horizontal Lines

Random Bars Vertically Vertical Lines

Horizontal In Close Vertically

Horizontal Out Open Vertically

Split Vertical In Close Horizontally

Split Vertical Out Open Horizontally

Strips Left Down Fade From Top Right

Strips Left Up Fade From Bottom Right

Strips Right Down Fade From Top Left

Strips Right Up Fade From Bottom Left

Uncover Down Uncover Downwards

Uncover Left Uncover To Left

Uncover Right Uncover To Right

Uncover Up Uncover Upwards

Uncover Left Down Uncover To Lower Left

Uncover Left Up Uncover To Upper Left

Uncover Right Down Uncover To Lower Right

Uncover Right Up Uncover To Upper Right

Wipe Down Cross-Fade From Top

Wipe Left Cross-Fade From Right

Wipe Right Cross-Fade From Left

Wipe Up Cross Fade From Bottom

Random Transition Automatic (random)
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This chapter describes how to import custom dictionaries and AutoText entries from
Microsoft Office to OpenOffice.org. Currently the author knows no easy way of importing
Microsoft Office auto-correct entries into OpenOffice.org.

Custom Dictionaries

Dictionaries are used when checking any document for spelling errors. Custom dictionaries
are enhanced dictionaries that may contain unique words or custom spelling of certain
entries.

OpenOffice.org does not provide a way of importing Microsoft Office custom dictionaries.
However, a macro has been developed for importing Microsoft Office custom dictionaries
into OpenOffice.org. A link for downloading the file can be found at
http://ooomacros.org/user.php#114694.

To import Microsoft Office custom dictionaries:

Create a new Dictionary:

1) Tools > Options... > Language Settings > Writing Aids > New.

2) Give the dictionary a name.

3) Optionally choose a language for the dictionary.

4) Click OK > OK.

Download the file that contains the macro:

1) In a web browser start at http://ooomacros.org/user.php#114694 and click on the link
for Download Import/Export Dictionary Words.

2) This should display a Source Forge page. Click on the latest link for this file. At the
time of writing, this is ImportExportDictionary1-1.zip.

3) Click on the icon  to the right of a mirror (typically choose one closest to you, but it
doesn’t really matter).

4) The browser should display a “save file” dialog, Fill the dialog in, remembering where
you saved the file.
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5) Unzip the file you saved in the previous step.

In Microsoft Word, locate where the custom dictionaries are stored:

1) Tools > Options... > Spelling & Grammar > Dictionaries
Typical location is:
C:\Windows\Application Data\Microsoft\Proof\CUSTOM.DIC

Import the dictionary:

1) In OpenOffice.org, open the file that contains the import/export macro (instructions for
downloading are above).

2) A confirmation dialog about running macros may be displayed. Click Run.

3) Click the Run Macro button (towards the top of the document).

4) Either type in the location of the custom dictionary to be imported or click on the
... button and navigate to it.

5) Choose the dictionary to import the words into (instructions for creating such a
dictionary are above).

6) Click Import. Two dialogs will be displayed. The first says how many words the
dictionary currently holds and the second how many words the dictionary holds after
the import.

7) Click Close.

8) Close the file and the job is done.

AutoText Entries

AutoText is a feature that stores formatted text, text with graphics, tables and fields and
provides the means to easily insert the saved material into documents.

OpenOffice.org stores AutoText entries in XML files in specified folders. Microsoft Word
stores AutoText entries in template files, typically Normal.dot. To import the AutoText
entries from these Microsoft Word templates, follow these steps:

1) Locate the template. Typically templates are found in:
C:\Windows\Application Data\Microsoft\Templates.

2) Edit > AutoText. (or Control + F3).

3) Optionally create a new category: Click Categories... > type in name for new category
> choose the location for the new category > click New > OK.

4) Select the category into which the AutoText entries are to be imported.

5) AutoText > Import.

6) Navigate to and select the desired Microsoft Word template > click Open.
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7) The AutoText entries should now be visible in the left list box of the dialog.

8) Click Close.

AutoCorrect Entries

AutoCorrect is a feature to automatically correct words as you type. You can add entries to
the AutoCorrect function to customize the way that OpenOffice.org operates.

The author has not been able to find a way of importing Microsoft Office AutoCorrect entries
to OpenOffice.org. A thread discussing this problem can be viewed at:
http://www.oooforum.org/forum/viewtopic.php?t=10248.

Information from that thread is copied below, because using this information it is reportedly
possible to import the “first hundred or so” entries.

There is a Word macro available from
http://word.mvps.org/FAQs/Customization/ExportAutocorrect.htm for creating a Word
document with the AutoCorrrect entries.

OOo AutoCorrect files are typically stored in ./user/autocorr/acorrXXXX.dat where XXXX
corresponds to the number for a given locale. These files are zipped and contain the file
DocumentList.xml, which looks like: 

<block-list:block-list> 
<block-list:block block-list:abbreviated-name="(C)" block-list:name="©"/> 
<block-list:block block-list:abbreviated-name="yuor" block-list:name="your"/> 
</block-list:block-list> 

So it would not be too difficult to create a text file to look like this and to zip it into a
acorrXXXX.dat file.
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between OpenOffice.org and

Microsoft Office

While the interfaces of OpenOffice.org and Microsoft Office are generally similar, there are
some differences. The purpose of this chapter is to outline those differences and how to work
with them. One of the underlying differences is the degree of integration of the applications.
For instance, it is possible to open a spreadsheet in Calc while working in Writer.

For information on how to customize the interface, see the chapter on Customizing
OpenOffice.org.

Help

Help in OpenOffice.org is very similar to its equivalent in Microsoft Office.

If you pause the mouse over a button, you will see a tooltip describing the button. (If you
don't see a tooltip, go to the Help menu and select Tips to turn them on.)

Shift + F1 changes the pointer to a question mark. When the question mark pointer is over a
button or control on a dialog, a more detailed description is displayed.

Pressing F1 displays contextual help (based on what is currently selected).

There is an equivalent to the Microsoft Office “Office Assistant”. This is
called the Help Agent. It “lights up,” alerting the user that help is available for
an event that has just happened. Examples are when a user first saves a file, or
when a word gets automatically corrected. The Help Agent can be turned off
and on from the Help menu.

See the Technical Support chapter for more information on getting help.

Zoom – the view percentage

To change the size at which the document is displayed on the monitor, use: View > Zoom or
right-click or double-click the number with a percentage sign next to it on the status bar.
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In Writer, the Optimal option zooms the display so that the document is displayed between
left and right margins. The zoom factor is automatically adjusted as the side panels are
displayed.

AutoCorrect / AutoFormat

Writer adds an auto-complete feature to words, so that when a user is typing, Writer tries to
predict what the completion of the word will be. Settings for this feature (including turning it
off) are here:

Tools > Auto Correct/Auto Format... > Word completion.

Menus

One of the differences in menu location is that page layout is considered to be a format, so it
is found under the Format menu (Format > Page...) rather than the File menu.

For customizing menus, see the Customizing OpenOffice.org chapter.

Personalized menus
There is no personalized menus option. This feature in Microsoft Office reorganizes the
menus so that the most frequently used options are displayed first. However, the degree of
context sensitivity, based on current cursor location, is much greater in OpenOffice.org than
in Microsoft Office. For instance, in Writer, the menu items for working with tables, found in
the Format menu, are only displayed when the cursor is in a table.

In OpenOffice.org there are some menu items that are relevant to the current cursor location,
but which are inactive for some reason. For example the sort option (Tools > Sort) is not
available when nothing is selected. By default these menu items are not displayed. To make
them visible use: Tools > Options > OpenOffice.org > View > Inactive Menu Items.

Toolbars

The top toolbar (default position) is called the Function Bar. The Function Bar is consistent
across the OpenOffice.org applications.

The second toolbar across the top (default location) is the Object Bar. The Object Bar is a
context-sensitive bar which shows the relevant toolbars in response to the cursor's current
position or selection. For example when the cursor is in a table, the object bar provides both a
Table Bar and a Text Bar. To toggle between these bars click the large triangle button at the
right end of the Object Bar.

The toolbar down the left side (default position) is the Main Toolbar. It has the buttons most
relevant to the current application.
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Buttons with a small green triangle will display one of the following with a long click,
depending on the button:

• Sub-menus (e.g. the New, Paste, Undo, Redo, AutoText buttons)

• Tear-off toolbars (e.g. Font Color, Highlighting, Insert buttons)

• A quick way of selecting things like number of cells or columns (e.g. Insert table,
Insert Frame, Insert Section)

Moving toolbars
To convert a docked toolbar to a floating toolbar and vice versa: Control + double click a
blank area of the toolbar. To dock a toolbar at a different edge, Control + drag a floating
toolbar to the desired edge.

Tear-off toolbars
Tear-off toolbars are accessed by giving a long click on a button with a small green triangle.
These toolbars are always floating (they cannot be docked at an edge), but they can float over
the top of other toolbars and docked / floating windows. To move a tear-off toolbar, drag it
by its title bar.

The Draw Functions toolbar
In Microsoft Office the Draw toolbar is, by default, across the bottom of the application
window. 

In Writer and Calc the Draw Functions toolbar is a tear-off toolbar from the Main Toolbar
(down the left by default). To display this toolbar click the Show Draw Functions button
(fourth button down by default).  In Draw and Impress, the tools found on Microsoft Office's
Draw toolbar are found directly on the Main Toolbar.

The Load URL drop-down on the Function bar
The drop-down on the left of the Function Bar is called “Load URL”. It lists up to the last
100 files that have been open in OpenOffice.org. Select a file from the list to open it.

Mouse use

Long click
Some toolbar buttons have a small green triangle in the top right corner of the button. This
green triangle symbolizes that clicking and holding the mouse button down will display a
submenu or tear-off toolbar (see “Tear-off toolbars“ on page 28). When you select a submenu
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or button, then the symbol on this button will change to the same symbol. Thus doing a
normal click on these buttons will act in the same way as long clicking and then clicking on
the submenu entry or button on the tear-off toolbar.

Drag and drop
While drag and drop does work, there is less feedback with pointer changing in
OpenOffice.org than in Microsoft Office. For example, when moving the pointer onto a
selected piece of text, the pointer remains the usual I bar rather than changing to an arrow.

Right click
Right clicking in OpenOffice.org does display a context menu but it doesn't select what has
just been right clicked on; the context menu is for what is currently selected.

Side panes – docked / floating windows

Microsoft Office XP introduced the concept of side panes. These are the closest equivalent to
OpenOffice.org's docked / floating windows. In OpenOffice.org these windows include:

• Navigator to help move around the document (the closest equivalent in Microsoft
Office would be the Outline view in Word)

• Stylist for managing styles

• Gallery (a clip art viewer)

• Function List (available only in Calc)

• Data Source View, sometimes called the beamer (available in Calc and Writer and can
only be docked at the top)

There is no equivalent of the Microsoft Office Clipboard for handling multiple copies.

Docking and undocking
Docking and undocking windows works the same as for the toolbars: Control + Double
click docks / undocks. Control + drag the title bar will shift the edge at which it docks.

It is possible to have two windows in the same area, for example having the Stylist and the
Navigator at the right edge with one above the other rather than side by side. Then the show /
hide and stick / floating buttons work for both docked windows.
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Resizing
The docked windows can be resized by moving to the border between its window and the
next window. When the mouse pointer changes to a double-ended arrow, click and drag to
the desired size.

Show / Hide
In addition to hiding/displaying windows, many have their own button that works like a
minimize to the edge button. It is a triangle pointing to the current docked edge to hide it, or
pointing out from the edge to show it.

Stick / Floating pin
With a window floating but docked at an edge, it overlaps the workspace window. Click the
pin to “stick” it so that the workspace window is resized to make the entire width of the
workspace window visible.

Navigator
The Navigator is activated and deactivated by F5, or the Navigator On/Off button in the
Function Bar or Edit > Navigator. This window shows the different objects in the current
document. For example in Writer it shows the list of headings and has controls similar to
Outline view in Word. The drop-down at the bottom of the Navigator is for selecting which
of the currently open documents has information displayed in the Navigator. (For more
information, see Navigator in each of the applications.)

Stylist
The Stylist can be activated and deactivated by F11, or the Stylist On/Off button in the
Function Bar or Format > Stylist.

To change the type of styles displayed, use the buttons across the top. For example, in Writer
the buttons are Paragraph Styles, Character Styles, Frame Styles, Page Styles and Numbering
Styles. The drop-down at the bottom of the Stylist determines which of these different types
get displayed. For example in Writer, for character styles the options are Hierarchical, All,
Applied and Custom. The style of the current selection is highlighted. See Help > Index >
type “Stylist” > creating new Styles from selections and updating from selections; and
Help > Find > type “Applying Styles” > Applying Styles in Fill Format Mode for how the
other buttons work.
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Gallery
The Gallery is activated and deactivated by the Gallery button in the Function Bar or Tools >
Gallery.

Note: There is no default key press.

This is OpenOffice.org's equivalent to Microsoft Office's Media Gallery, except it doesn't
have ties to the Web and there is no search facility. Very little clip-art comes with
OpenOffice.org. To download some public domain clip-art, see http://www.openclipart.org/.

Media in the Gallery is organized by themes. Themes are displayed down the left side of the
Gallery window.

Insert media into document

To place the media (such as clip art) into the current document:

Drag and drop the media into the document

or

Right click > Insert > Copy

Add pictures to the Gallery

It is possible to add pictures to existing themes when the icon for the theme is green1.

1) Right click on a theme > Properties... > Files > Find Files...

2) Navigate to (or type in) the top folder. Click Select. OOo will search this folder and all
subfolders for media files.

3) Select the files (by holding down Ctrl for individual files or Shift for blocks of files) that
you wish to be included in the Gallery.

4) Click Add.

Note: It is also possible to drag and drop a picture from the document into the Gallery.

Delete picture from Gallery

To delete a picture from the Gallery:

1) Select the picture.

2) Right Click > Delete.

3) Confirm the deletion.

Note: The link to the picture is removed from the Gallery but the file is not removed from the
disk.

Add a new theme

To add a new theme:

1) Display the Gallery.
1 An icon colored something other than green indicates that the folder that stores the theme is read-only for the

current user.
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2) In the top left of the window is a button New Theme... click it.

3) On the General tab, enter a name for the new theme.

4) On the Files tab, follow the instructions above to add pictures to the gallery.

Data source viewer
The Data source viewer is activated and deactivated by F4 and by the Data sources button in
the Main Toolbar.

The Data source viewer window behaves differently in that it can only be docked at the top.

It is possible to drag and drop fields from data sources to create fields in the current
document.

For working with the Data source viewer, see the chapter Data Sources in the Common
Features Guide.

Page preview

File > Page Preview in OpenOffice.org is the equivalent of Microsoft Office's Print preview.

The Zoom button in OpenOffice.org simply zooms the view; it doesn't provide a pointer with
which the user can select an area to zoom in on.

Keyboard shortcuts

The standard keyboard shortcuts for cut (Control + X), copy (Control+C), paste
(Control+V), undo (Control + Z), redo (Control + Y), save (Control + S), open (Control +
O) and new (Control + N) are the same.

Smart tags

Smart tags are not available in OpenOffice.org. In Microsoft Office XP they are like context
menus for things like pasting text so that the user could alter the way the paste worked.

Special characters / symbols

The equivalent of insert symbols is:

Insert > Special Characters

Note: The dialog displayed doesn't have a second tab for common special characters such as
em-dash. Workarounds are to use AutoFormat/AutoCorrect, AutoText or to record a macro.
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File management

Default locations
Use Tools > Options > OpenOffice.org > Paths to set the default locations for file storage.
The two path settings of interest (at this stage) are My Documents and Templates.

My Documents only allows one location. In other words., it is not possible to have a separate
folder for each of the applications. This folder is the default location for File > Save As, and
is the folder that gets displayed when the Default Directory button, , is clicked in the Open
and Save As dialogs.

For templates it is possible to have more than one folder specified. These are the folders that
are shown down the left side of the dialog that gets displayed for File > New > Templates
and Documents (see “Creating new files” on page 33).

Creating new files
As with Microsoft Office, in OpenOffice.org there are a number of different ways of creating
new files. What is different is that you can initiate the creation of any OpenOffice.org file
type from any application. For instance, it is possible to start creating a spreadsheet while
working in Writer.

Different ways of creating a new document:

• File > New.

• Use the New button on the Function Bar. This button has the long-click feature for
selecting the type of document to be created.

• From a “Quick start” program. For instance, the Microsoft Windows version of
OpenOffice.org has a Quickstart icon in the system tray.

• Control + N.

• Using AutoPilots (OpenOffice.org equivalent to Microsoft Office Wizards):
File > AutoPilot.

Default templates
Each component of OpenOffice.org (Writer, Calc, etc.) has a default template. To change the
default template for a component:

1) Save the template using File > Templates > Save... Category Default. The name of
the template is not important

2) File > Templates > Organize...

3) Double click Default folder.
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4) Select the template by clicking on it.

5) Either right click or Commands > Set as Default Template.

Note: The default template in Microsoft Word is always a file called Normal.dot. In
OpenOffice.org there is no special name for the default template files; they can be called
anything. If no template has been specified in OpenOffice.org then the properties for the default
template are those that are directly coded into OpenOffice.org code – an in-built template.

To reset back to the default (in-built) template:

File > Templates > Organize... > Commands > Reset Default Template > 
[xxx Document] where xxx is the type of document to be reset.

Template folder management
To make it easier to manage your templates such as creating and deleting folders (categories),
and importing templates into the folders, use:

File > Templates > Organize... > Double click the desired folder > Commands

Open and Save As dialogs
Running under Microsoft Windows there is the option of using either the OpenOffice.org
Open and Save As dialogs or the ones provided by Microsoft Windows. To view or change
which type of dialog OpenOffice.org is using:

Tools > Options... > OpenOffice.org > General > Use OpenOffice.org dialogs.

Note: The dialogs provided by Microsoft Windows are not the dialogs used by Microsoft Office!

What follows is for the OpenOffice.org Open and Save As dialogs.

The three buttons in the top right are, from left to right:

• Go up one level in the folder (directory) hierarchy. Note that this is a long-click button
if you want to go up higher than just one level.

• New folder.

• Default Directory (see “Default locations” on page 33).

For OpenOffice.org documents that have been saved with more than one version, use the
version drop-down to select which version you wish to open in read-only mode.

Note: For Microsoft Office documents only the current version can be opened.

The File type field has the same concept in OpenOffice.org as in Microsoft Office – the
ability to specify the type of file to be opened or the format of the file to be saved.

The Read only checkbox opens the file for reading and printing only. Consequently most of
the toolbars disappear and most menu options are disabled. An Edit File button is displayed
on the Function Toolbar to open the file for editing.
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It is possible to open files from the web using URLs. In theory it is possible to save files, but
the author hasn't been able to get this to work. Having a local copy and using an FTP program
to copy it to the server feels safer to the author anyway.

File management within an OpenOffice.org Open or Save As dialog

To rename a file:

1) Right click on a file name to display a context menu.

2) Click Rename and the file name will be selected.

3) Typing will replace the selected name or use a left or right arrow key to move the insertion
point to modify the existing name.

To delete a file:

1) Right click on a file name to display a context menu.

2) Click Delete and you will get a confirmation dialog.

Note: Instead of Right click > Delete you can simply press the Del key.

It is not possible to copy and paste files within the dialogs for moving files around.

Password protection
To protect an entire document from being viewable without a password, there is an option on
the Save As dialog to enter a password. This option is only available for files saved in
OpenOffice.org formats. OpenOffice.org's password-protection uses strong encryption to
protect your data.

Privacy options
To include or remove personal information (e.g. author’s name) with the document, go to
File > Properties... > General. The Delete button removes information such as editing time.
The Apply User data checkbox includes or removes information such as “Author”.

PDF (Adobe Reader) file creation
All of the applications have the ability to export documents as PDF files. Click on Export
Directly as PDF button on the Main toolbar, or use: File > Export as PDF...  The menu bar
option provides access to choices including the print quality and the range of pages to be
printed to PDF.

Creating web pages (HTML files) overview
This section is based upon an article by Ralph Krause, titled “HowTo: Creating web pages
with OpenOffice.org”. The original document is available at:
http://www.linuxjournal.com/article.php?sid=6289.
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All of the OpenOffice.org applications can be used to create web pages. This section
introduces their HTML capabilities.

Writer

Writer's HTML capabilities include saving existing documents in HTML format, creating
new documents as HTML and creating several different types of web pages using a wizard
(or AutoPilot in OpenOffice.org).

The easiest way to create HTML documents is to start with an existing Writer document. You
can view it as it will appear on a web page by using View > Online Layout.

Links can be inserted and modified using the hyperlink dialog. Display the dialog by clicking
the Hyperlink Dialog button on the Function Bar or Insert > Hyperlink. Writing or pasting
a URL will (depending on AutoCorrect/AutoFormat settings) automatically convert to
hyperlinks.

To edit an existing link, either move the cursor into the link using the keyboard or toggle the
“HYP” to “SEL” in the Status Bar and use the mouse, Edit > Hyperlink. From the
Hyperlink dialog, you can choose the type of link, as well as specify the link's address, text
and how it should be displayed (for example, in a new window).

To  turn existing text into a link, simply highlight it before opening the Hyperlink dialog.
You have to click Apply to insert the link into your document before closing the window.

Note: Cross references do not become hyperlinks in an HTML document.

To save in HTML format, select Save As from the File menu and specify HTML document
as the file type.

Note: One thing that Writer doesn't do is replace multiple spaces in the original document with
the HTML code for non-breaking spaces.

Writer can save a large document as a series of HTML files with a table of contents page. To
do this:

1) Decide which headings in the document should be on separate pages and make sure
that they have the same formatting style (for example, Heading 2).

2) File > Send and click on Create HTML Document.

3) In the dialog box that appears, enter the file name to save the pages under. Also
specify which style indicates a new page (as decided on in step 1).

4) Click Save to create the multi-page HTML document. (For those who may be
interested, the resulting HTML files conform to the HTML 3.2 standard.)

OpenOffice.org's wizard, called AutoPilot, allow you to create several types of standard web
pages. To use the AutoPilot:

1) File > AutoPilot > Web Page... .

2) In the dialog, select a template and layout to use. Templates define the structure of the
web page, while layouts determine font styles, colors and page background. Some
templates included with OpenOffice.org are:
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• A list with table of contents

• Contact form

• Photo album

• Single column with subheading

• Standard

The standard template provides a document with a page heading in large text, example links,
space for body text and a line indicating when the document was last changed.  Changes in
the template and layout selections are reflected in the document immediately, so that you can
preview them.

To create a template based on your selections, place a check in the Create template box.
This template will be available in the future through File > New > Templates and
Documents.

Click the Create button to close the dialog and edit the document. If you elect to create a
template, the Templates dialog appears, so that the template can be named.

To edit or view the document's underlying HTML code, View > HTML-Source or click
HTML Source on the Main toolbar.

Calc

Calc can save its files as HTML documents. If the file contains more than one sheet, the
additional sheets will follow one another in the HTML file. Links to each sheet will be placed
at the top of the document. Calc also allows the insertion of links directly into the spreadsheet
by using the Hyperlink dialog.

Draw

It is possible to export drawings as a Macromedia Flash file: File >Export and choose
Macromedia Flash for the file type.

The drawing program allows you to turn your drawings into a series of web pages. These web
pages are created by using:

1) File > Export > select Web Page as the file type, supply a name for the resulting
HTML file, and click Save.

2) In the HTML Export window, select whether to use an existing design for the web
pages or create a new one.

3) Click Next to select the type of web pages to create. The types available are Standard
HTML format, Standard HTML with frames, Automatic and WebCast. There is also
an option for creating a title page for the presentation.

• Standard HTML generates a series of pages, each page containing one slide.
Navigation links are available to move from slide to slide.

• Automatic generates a series of pages, each set with the Refresh meta tag that
causes a browser to automatically cycle through each web page.
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• WebCast generates an ASP or Perl application to display the slides.

4) After selecting the type of publication to create, select whether to convert the slides to
GIF or JPG files and what resolution should be used.

5) If Create a title page was chosen in step 3 above, supply the information for it on the
next page. The title contains an author name, e-mail address and home page, along
with any additional information specified

6) In the next page, choose between text or graphics for the links used to navigate
through the slides. For graphical navigation buttons, there are several styles to choose
from.

7) Next select the color scheme to use on the web pages. Available schemes include the
document's existing scheme, one based upon browser colors, and a completely user-
defined scheme.

8) Click the Create button to generate the HTML files.

Note: The HTML and image files are placed in the same directory, so it is advisable to create
unique directories for each drawing.

Impress

Exporting presentations from OpenOffice.org's Impress application is similar to exporting a
drawing from Draw. Use File > Export and select HTML document as the file type. The only
difference is that there is an option to display each slide's notes along with the slide.

Document properties
Some differences in document properties:

• Summary / Description: OpenOffice.org doesn't include fields for manager or
category.

• Statistics: For Writer this is where you find the word count.

• Custom / User defined: OpenOffice.org provides only four fields. To rename the fields
use Info fields...

• The Internet tab is for dynamic web pages – such as a page saying  “redirecting you
to ...”

Searching for files
There is no Find Files command built-in to OpenOffice.org for finding files that contain
specific text. However for those who are more technically able, a Python script that does this
is available from: http://www.danielnaber.de/loook/.
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Working with multiple files
The Window menu displays all of the currently open documents in OpenOffice.org.

Each open document has its own window, so depending on the operating system, use the task
bar or ALT + Tab to switch between the currently open documents. In Microsoft Office it is
possible to use Control + F6 to switch between currently open documents. In OpenOffice.org
F6 is used for accessibility to move to the menu and each of the toolbars. Control +F6 will
make the current document active.

For information on Object Linking and Embedding (OLE), see the chapter Sharing Files.

In the Windows version of OpenOffice.org, it is possible to copy and paste special cells from
a Calc spreadsheet into a Writer document as a Dynamic Data Exchange (DDE) link. It is
also possible in the Windows version to create a DDE field. Neither of these options is
available in the Linux version, yet opening a file created in the Windows version on a Linux
version works (some modification of the file location may be necessary). If you would like to
know more, see http://www.openoffice.org/issues/show_bug.cgi?id=5317.

In neither version is it possible to have a link to a chart.

Autosaves
To turn on/off autosaving and set the time period:

Tools > Options... > Load/Save > General > AutoSave every

Warning: Autosave will overwrite the current file!

Version control
With version control, you can save more than one version of a file under the one file name. In
Microsoft Office each version contains the changes that have occurred to the document (like
fast saves), in OpenOffice.org each version is complete. To use: File > Versions...

See “Open and Save As dialogs” on page 34 for more information.

Find and Replace

Find and replace are combined in OpenOffice.org.  There isn't a separate menu entry or key
shortcut for replace.

There is no “word forms” search.

Having performed a search and having closed the dialog box, the key shortcut to repeat the
search is: Control + Shift + F.

Searches are paragraph based so there is no way to search for text either side of a paragraph
marker. For example OpenOffice.org cannot search for two blank paragraphs. To get around
this problem and some other issues, an alternative macro has been developed. See
IannzFindReplace, available from http://homepages.paradise.net.nz/hillview/OOo/.
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Note: Manual page breaks are handled by changing the paragraph format of the first paragraph
on the new page.  When searching for formats this option is grayed out, as there is no way to
search for “manual” page breaks (except by using macros).

Some tips for find and replace
It is common to do several find and replace operations on the same selection. However
OpenOffice.org doesn't “remember” the original selection. So, before doing the find and
replace, bookmark the selection in Writer or define a range name for the selection in Calc, so
that by using the Navigator, the same range can be quickly reselected.

Doing a “find all” selects all the pieces of text that match the criteria. It is possible to
perform, on all of these selections, most operations that are possible on a single selection.

Attributes
The Attributes... button is only available in Writer's Find dialog. This button displays a
dialog with a series of checkboxes to find where a particular attribute has been changed from
the default for the underlying style. for example, the attribute “Font weight” would find
where text had been made bold where the underlying font was not bold (and vice versa).

Note: The attributes settings remain between uses of the Find dialog. This can be frustrating, so
always turn off all of the attribute settings after use.

Formats
This is the same concept as in Microsoft Office. Note that, if formats are used, there is an
option to include searching within styles. For example, searching for bold text would not find
bold text where the style is bold unless this option is checked.

Regular expressions
“Regular expressions” are significantly different in OpenOffice.org from Microsoft Office's
“Use wildcards”. See Help > Index tab > type in “regular expressions”. Some common
examples are in Table 1. To use regular expressions, make sure the Regular expressions
checkbox is checked. On reopening the Find / Replace dialog the Regular Expressions
checkbox is always unchecked.

Note: The asterisk “*” means any number of the preceding character so where in Microsoft
Office you might have just “*” the equivalent in OpenOffice.org is “.*” as “.” stands for any
single character (like Microsoft Office's “?”).

A macro that makes it easier to use regular expressions in Writer, and allows searching for
“page breaks” and for things like multiple blank paragraphs, is available in a document called
IannzFindReplace.sxw available from http://homepages.paradise.net.nz/hillview/OOo/.
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Similarity search
The Similarity search option broadens the search so that what is found doesn't have to be
exactly the same as what was specified in the “Search for” field. To specify how different it
can be, click on the ... button next to Similarity search.

Search for styles
Writer and Calc have an option, Search for styles (changes to Within Styles if Format or
Attribute search is used). Check this first if searching for a particular style. The Search for
combo box field changes to listing the used paragraph styles.

Table 5. Sample regular expressions

Problem Search Replace
Replace multiple tabs with just one tab \t* \t

Replace multiple spaces with just one space. “[:space]” finds both
non-breaking spaces and normal spaces but not tabs (help is
currently incorrect). Type a normal space in the Replace field.

[:space:]*  

Remove leading white space (space or tabs in any combination)
at the start of a paragraph.

^([:space:]|\t)*

Remove trailing white space (space or tabs in any combination at
end of paragraph).

([:space:]|\t)*$

Find paragraphs beginning with the character “a” (the rest of the
paragraph can vary) and replace the whole paragraph with a blank
line

^a.*

Remove a paragraph mark from the end of lines (e.g. when
having pasted text from an e-mail message).

$

Replace paragraph marks with a comma so that there is one long
line rather than many lines.

$ ,

Replace commas with a paragraph mark. , \n

Replace line breaks (Shift+Enter) with paragraph markers. (Note
that \n is used for both the Search and Replace fields. In search it
is interpreted as a newline and in replace as a paragraph mark.
There is not the ability to have a line break in the replace field.)

\n \n

Find the word “the” only (Don't find “then” or “bathe”). \<the\>

Find “ing” at the end of a word, e.g Reading, writing, but not
singer.

ing\>

Find whole word that ends with “ing”. Note there is a space
between the caret and the close square bracket character.

[^ ]*ing\>

Select all numbers at the start of a line where the numbers could
include a period, e.g. 1.1.

^[0-9.]* 
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Grammar checking

Currently there is no grammar checking function. To quote a proofreader of this document:
“But this is no great loss. I have reservations about the value of the one available in Microsoft
Word.”
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This chapter is about customizing the user interface in OpenOffice.org (OOo). The chapter
specifically covers the differences between customizing OOo and Microsoft Office (MSO).
The last section of this chapter describes how to store to a template any changes to menus,
keyboard shortcuts, status bar, and toolbars. It does not cover how to write macros; this is
covered in another chapter in the User Guide.

Toolbars

In the Windows version of OOo it is possible to customize toolbars by holding down the Alt
key while dragging a button – the same functionality as MSO. However, as OOo is available
on different platforms, the following method outlines the most generic approach to
customizing and adding toolbars.

Customizing toolbars
There are three ways to get to the toolbar customization menu:

• On a toolbar, right-click > Customize.  (Same as MSO).

• Tools > Configure... > Toolbars tab > Customize...

• View > Toolbars > Customize... (Same as MSO).

However, rather than dragging buttons onto the toolbar as is required in MSO, use:

1) Toolbars drop-down to select the toolbar.

2) The Add--> and <--Remove buttons to change which buttons are on the selected
toolbar.

3) The checkboxes to determine whether the button gets displayed or not.

4) The Move Up or Move Down buttons to change the order.

5) Icons... to change the icon displayed (e.g. for a macro).

Note: There is no in-built tool button editor. To use a custom icon, save it to the "{installpath}/
share/config/symbol" directory in *.BMP format. OOo automatically searches this directory for
new icons each time the Customize Buttons dialog is opened. Custom icons must be 16 x 16 or
26 x 26 pixels in size and cannot contain more than 256 colors (from OOo help).
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Creating a new toolbar
To create a new toolbar:

1. Tools > Configure... > Toolbars.

2. Click New. This will create a toolbar called “User-defined no.1”. It is not possible to
change the name of this toolbar. Based on pre-release versions of Ooo2.0, clicking New
will display a dialog allowing a name to be given to the new toolbar.

3. Customize the toolbar as above.

Menus

Customizing menus is not significantly different in OOo to what it is in MSO. The specific
steps are outlined below. It is even possible to set the menu font to be the font used by the
system.

Customizing menu content
To customize menu content:

Tools > Configure... > Menu

To add a function:

1) Select the location in the Menu entries list box.

2) Select the new menu item using the Category and Function list boxes.

3) Click New to insert that function into the menu.

Customizing the menu font
The font used in OOo for menus is different from that used in MSO. If you want to change
the font to the one used in MSO:

1) Tools > Options... > OpenOffice.org > Accessibility.

2) Check Use system font for user interface.

3) Click OK.

Customizing keyboard shortcuts

Customizing keyboard shortcuts requires a different procedure from that used in MSO. MSO
requires the user to use a key combination and then click Assign, whereas in OOo the
following steps are used:
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1. Tools > Configure... > Keyboard.

2. Select the desired shortcut in the top list box labeled Shortcut keys.

3. Select the Category for the command, and the actual Function in the bottom list boxes.

4. Select whether the key shortcut is to be OOo-wide or just for the current application in the
top right corner of the dialog.

5. Click Modify.

Note: Styles cannot automatically have keyboard shortcuts. A work-around is to record a macro.
A macro has been written to make it easier to assign Alt key combinations to things like styles.
See AltKeyHandler.sxw available from http://homepages.paradise.net.nz/hillview/OOo/.

Customizing word entry and editing

AutoCorrect/AutoFormat
A feature in OOo is the ability to have exceptions for AutoCorrect/AutoFormat rules. For
example, you can have “Correct TWo INitial Capitals” in operation but exclude situations
where two capitals are desired, like OOo. To set up exceptions:

1. Tools > AutoCorrect/AutoFormat...

2. Click on the Modifications menu tab.

Undo / Redo
To specify how many “undos” are available:

Tools > Options... > OpenOffice.org > Memory > Number of steps.

Spell checking
To set up the spell check options in OOo, use:

Tools > Options... > Language Settings > Writing Aids

The spell check options are consistent across all OOo applications.

Note: Custom dictionaries, unlike the default dictionaries, are not compressed. Using too many
custom dictionaries, or custom dictionaries that contain more than 1,000 entries, slows down
performance while proofing text.
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Security settings

To set up virus protection for macro and Java security settings, use:

Tools > Options > OpenOffice.org > Security

For other security-related issues, see Password Protection and Privacy Options in the chapter
on general use differences.

Personal settings

To find out where these customizations are stored, use:

Tools > Options > OpenOffice.org > Paths

The dialog shows that the information, by default, is stored below a folder called “user”.

Storing configurations in a template

This section describes how to store changes to menus, keyboard shortcuts, status bar and
toolbars in a template so that these customizations are automatically loaded when you work
on an OOo document based on that template.

1) Create and save the template that is to have the configurations saved into it. Having a
back-up of the template without the configuration changes is probably a good idea.

2) Make the desired changes to the configuration. (See Toolbars, Menus and Customizing
keyboard shortcuts above.) Note any changes that you don't want as standard, as these
will have to be undone.

3) Tools > Configure.

4) For each type of customization which is to be stored in the template, that is for each
tab of the dialog that you want to change, click Save and choose the desired template
(the one created and saved in step 1).

5) It is OK to overwrite the file – the warning message that is displayed is inappropriate
and can be ignored.

6) Undo the changes that are not wanted as standard (as were noted in step 2).
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Writer and Word

This chapter summarizes the differences in use between OpenOffice.org Writer 1.1.x and
Microsoft Word (various versions).

Views

Word has 4 views (depending on the version) called:

Normal: Recommended view (by Microsoft) for doing most of your typing and editing.
Writer has no real equivalent view.

Page or Print Layout: This shows the document (more or less) as it will print. This is the
closest equivalent to the main view in Writer.

Online Layout: In theory, this shows the document as if viewed on-line. Writer's equivalent is
a view option called Online Layout. To access this view, select View > Online Layout.

Outline View: For working with heading hierarchies. Writer has the Navigator, which is
detailed later in this chapter.

Writer also has an HTML source view that only shows when editing an HTML document. To
access this view, select View > HTML – Source.

When field codes are turned on, Writer displays less information about the field than does
Word. To get detailed information, right click the field > Fields... (or select field > Edit >
Fields...).

Status bar

The status bar is similar to Word's except it does not show the current location of the cursor
on the page (row number and number of characters across). It does however show the
position within a table in spreadsheet style format, e.g., Top left cell =A1.
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Navigator

Word doesn't have a similar concept to the Navigator and, in the author's opinion, it is such a
useful tool it is worth taking the time to learn more about it.

To launch the Navigator, press F5 or click the navigator icon on the Function Bar. To get a
detailed description of what each of the buttons do, press Shift + F1 and hover over the
buttons.

The Headings at the top of the list box in the Navigator are the closest equivalent to Word’s
Outline View.

With the List Box on there is a drop-down list box at the bottom of the navigator. With this
list box it is possible to select any of the open Writer documents so that their contents are
available for dragging and dropping. What happens when the selection is dropped is
determined by the drag mode specified by the Drag Mode button. Press and hold the Drag
Mode button to see the available options.

When viewing a master document the Navigator is quite different. For more details see the
chapter on Master Documents in the Writer Guide section.

Note: Graphics, indexes, OLE objects, and references cannot be dragged and dropped when in
the Insert as link or Insert as Copy modes.

Stylist

For a more detailed guide on using styles, see “Use templates and styles” on page 58.

Use Shift + F1 to check out the different buttons on the Stylist. Use the bottom list box to
change the style group that is displayed. For example, Applied Styles only shows those styles
that have been used in the document.

Keyboard

When some text has a character attribute at the end of a paragraph (say bold or a hyperlink)
but the new text doesn't require that attribute then press the right arrow key before typing.

Deleting paragraph marks: pressing Delete at the end of a paragraph effectively moves the
text of the following paragraph into the current paragraph, and the paragraph formating of the
top paragraph remains. Press Backspace at the start of a paragraph and the format of the
lower paragraph remains.

Hint: An aid to remember this is: the format of the paragraph that has the cursor will be the
format of the combined paragraph, unless the current paragraph is empty; in that case,
backspacing will leave the previous paragraph's formatting.
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Control + Home when in tables: In Word Control + Home always positions the cursor to the
top of the document, in Writer Control + Home first positions the cursor at the start of the
cell, then the start of the table and then the start of the document. Control + End has similar
behavior.

How to select multiple parts of the text
To copy, cut, format, or delete parts of the text in different areas of the document use:

• Control + selection with one click, double-click or sliding.

or

1) Click once on the field "STD" (STanDard) in the status bar
The field now shows "EXT" (EXTended selection).

2) Another click and it changes to "ADD" (ADD to selection).

Note: the ADD mode is the equivalent to Control + click and EXT is equivalent to Shift + click.

Multiple selections and tables
The following limitations apply when selections involve tables:

• It is possible to have multiple selections within a cell, but only one selection is
possible that involves more than one cell.

• A selection that starts in a table can not extend beyond the table.

• A selection that starts outside a table will include the entire table (that is, a selection
cannot start outside a table and also contain a portion of a table).

Comparison of key shortcuts
Table 6: Word vs Writer different default key shortcuts (incomplete)

Function Word standard
shortcut

Writer standard
shortcut

Underline words not spaces Control + Shift + W No equivalent

Change font size Control + Shift + P No standard equivalent

Thesaurus Shift + F7 Control + F7

Show/hide non-printing
characters

Control + Shift + * Control + F10

Hanging Indent Control + T No standard equivalent

“Unhang” Indent Control + Shift + T No standard equivalent

Indent Control + M No standard equivalent

“UnIndent” Control + Shift + M No standard equivalent
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Function Word standard
shortcut

Writer standard
shortcut

Superscript Control + Shift = Control+Shift+P

Subscript Control + = Control + Shift + B

Remove character formatting Control + Spacebar Right click > Default

Remove paragraph formatting Control + Q No equivalent

Jump to previous edit point Shift + F5 Need to use the reminders
on the Navigator

Shift paragraph up No equivalent Control + Up

Shift paragraph down No equivalent Control + Down

See AltKeyHandler.sxw (available from http://homepages.paradise.net.nz/hillview/OOo/) for
macros that extend Writer's key shortcut ability.

Mouse use

Some differences are:

• Right click displays a context menu, but for the current cursor position not the pointer
position.

• No quick selection of rows or columns in tables.

• Triple click selects current line or current cell when cursor is in a table.

• No quick selection of paragraphs or lines by clicking to the left of the paragraph.

• Control + Click doesn't select a sentence.

To select sentences easily, customize the keyboard:

1) Tools > Configure... > Keyboard.

2) For Category select Navigate.

3) Assign key shortcuts for Select to Next/Previous sentence.

4) Alternatively assign key shortcuts for To next/previous sentence and use F8 (extend
selection) and the assigned keys.

Tables

The menu option to insert a table is in the Insert menu. The other menu options for tables are
in the Format menu (rather than having their own menu). The menu options and Tables
object toolbar become visible when the cursor is in a table.
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Tables are like one special paragraph so when selecting text using the keyboard (Shift +
arrow) from, say, above the paragraph, the whole table is selected followed by the line below
it.

Tables without borders can be hard to spot – they don't have a thin gray line like tables in
Word. To display the thin gray line, use Tools > Options > OpenOffice.org > Appearance and
select the "Table boundaries" checkbox.

The page formatting of long skinny tables into newspaper style columns when the table
crosses a page break appears to be unreliable.

Header rows
By default new tables have a header row.

To have more than one row for a header row (copied from help):

1) Select the first row of the table.

2) Right-click and choose Cell – Split.

3) In the Split area, enter the number of rows that you want to include in the header.

4) In the Direction area, click in the Horizontally check box. If you want the rows to
have equal heights, select the Into equal proportions check box.

5) Click OK.

Turning off header rows
Simply delete the rows. To keep the contents of the header rows, insert the required number
of rows, copy and paste the heading rows into the new rows, then delete.

Adjusting column widths and row heights using the
keyboard
Use the 3 buttons on the Table object toolbar to set what happens to the overall width of the
table:

• Table: Fixed: Overall width of the table stays the same, but the adjoining column
shrinks or grows correspondingly.

• Table: Fixed Proportional: The current column and the end column change by
corresponding amounts, keeping the overall width the same.

• Table: Variable: Only the current column changes so the overall width of the table
changes.
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Use Alt and the arrow keys as follows to adjust the width of columns (or height of rows):

• Alt and arrow keys adjusts the right side (bottom for rows).

• Alt + Shift and arrow keys adjusts the left side (top for rows).

• Alt + Control + left or right arrow keys adjusts the current cell only.

Copying and pasting cells in a table
Writer never inserts new rows or columns when pasting data – it always overwrites the
contents of the cells. This makes it clear as to what will happen. To avoid overwriting cells,
first insert the required number of rows or columns.

Inserting and deleting rows or columns
Inserting is always below for rows and to the right for columns (opposite of Word).

Note: This is a surprising inconsistency as Calc inserts above and to the left.

To insert rows or columns using the keyboard: Alt + Insert, arrow key. To delete rows or
columns using the keyboard: Alt + Delete, arrow key. The insertion or deletion is in the
direction of the arrow key. For example, Alt + Insert, Up inserts a row above the current row.

Equal row heights and column widths
On the Tables object toolbar there is a long click button called Optimize. This presents a
tear-off menu for easily adjusting row heights and column widths to being the same.

Splits and merges
To merge cells – do this last, as you would in Word..

To split or merge cells: Select cells to be merged then Format > Cell.

To split a table (horizontally): Format > Split Table.

To join two tables they need to be one below the other, then Format > Merge Tables. If
there is a table above and below the current table the user will be prompted which one they
wish to join.

Preventing accidental change to cell contents
To prevent accidental change to cell contents: Select the cells, Format > Cells > Protect.

This is not a security feature as the cells aren't password protected but does prevent
accidentally changing a cell.
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Sorting
To sort a table:

1) Select the cells to be sorted; don't include the headings. The option to sort only
becomes available when there is something selected.

2) Tools > Sort.

Unlike Word, the sort dialog uses column number rather than the names of the column.

Entering numbers and formulas
Unlike Word, tables in Writer can work much more like spreadsheets. For example
calculated values change as the data is input (no more selecting and pressing F9 to update
calculated results).

With number recognition turned on, when entering a number Writer will automatically
format the number according to a specified number format. To change this behavior, right-
click when the cursor is in a table > Number Recognition.

To change the number format: Select the cells, Format > Number Format...

To enter a formula like SUM():

1) Select the cell where the result is to go.

2) Press F2 to display the Formula bar.

3) Click and hold Formula button to display formula menu.

4) Select desired function (list separator is for separating constants, e.g. =mean 5 | 12 |
20).

5) Click and drag on cells to input ranges.

6) Press Enter to finish.

To enter a formula like “this cell plus that cell minus that cell”:

1) Select the cell where the result is to go.

2) Press F2 to display the Formula bar.

3) Click on a cell.

4) Type or select the desired operator.

5) Click on the next cell.

6) Repeat steps 4 and 5 until done.

7) Press Enter to finish.
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Creating a table from a data source
To create a table from a data source:

1) Display the Data source viewer (F4).

2) In the Data explorer window navigate to the desired table or query.

3) Drag the name of the table or query into the document.

4) Select the desired fields and set other properties as required in the dialog.

Charts in Writer

Charts copied from a Calc spreadsheet and pasted into a Writer document are, by default,
embedded objects. Unlike doing this in Microsoft Office, only the relevant data for the chart
is embedded. In Microsoft Office copying and pasting a chart also embeds it, but if the Excel
workbook was 8 mb in size (not unrealistic for a spreadsheet) then each chart pasted into a
Word document would increase the Word document by 8 mb.

Linking of charts does not exist.

Customizing the user interface

Most functions are found in similar places in both programs, but a few are slightly different,
and the degree of control varies. This table summarizes where to find the setup choices.

Table 7: Customizing the user interface

To do this... In Word... In Writer...
Change measurement system Tools > Options... > General Tools > Options... > Text

Document > General
Turn off Autocompletion Not applicable Tools > AutoCorrect/AutoFormat.

In the “Word completion” tab, untick
Word Completion.

Turn on/off Help Agent Help > Microsoft Word Help
> Options

Help > Help Agent

Set up document window (rulers,
status bar, default toolbars, etc)

View > select required items View > select required items

Customize toolbars Tools > Customize Tools > Configure

Customize menus Tools > Customize Tools > Configure

Display font names in their font
(in toolbar drop-down font list)

Tools > Customize > Options Tools > Options > OpenOffice.org
> View, select Preview in fonts lists

Always show full menus (include
unavailable and little-used items)

Tools > Customize > Options Tools > Options > OpenOffice.org
> View, select Inactive menu items

Show/hide ScreenTips
(ToolTips) on toolbars

Tools > Customize > Options Help > Tips to uncheck
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To do this... In Word... In Writer...
Always create backup copy Tools > Options > Save Tools > Options > Load/Save >

General
Autosave every x minutes Tools > Options > Save Tools > Options > Load/Save >

General
Show paragraph marks, tabs, etc. Tools > Options > View Tools > Options > Text Document

> Formatting Aids

Change file locations Tools > Options > File
Locations

Tools > Options > OpenOffice.org
> Paths

Change user information Tools > Options > User
Information

Tools > Options > OpenOffice.org
> User Data

Set up AutoCorrect and
AutoFormat options

Tools > AutoCorrect Options Tools > AutoCorrect/AutoFormat
> Options

Write, edit, and review documents

Most writing, editing, and reviewing techniques in OOoWriter are similar to those in
Microsoft Word, but the details often vary.

Table 8: Write, edit and review documents

To do this... In Word... In Writer...
Jump quickly to other parts of a
document

Edit > Go to Edit > Navigator (or F11), double-
click on required heading, figure,
table, etc.

Choose language for spelling
checker

Tools > Language > Set
Language

Tools > Options > Language
Settings > Language. (Note:
OpenOffice.org has no grammar
checker.)

Ignore some text when checking
spelling

Select text; Tools >
Language > Set Language >
Do not check
(or) Format > Style >
Modify> Format > Language

Select text; right-click > Character
> Font > Language = [None] or the
real language of the selected text, if
that is foreign.

Recheck spelling Tools > Spelling & Grammar
> Recheck Document

Always rechecks

Find and replace text, formatting,
and styles

Edit > Replace > More;
choices as needed

Edit > Find & Replace; details are a
bit different

Use wildcards in find and replace Edit > Replace > More >
select Use Wildcards
checkbox

Edit > Find & Replace, select
Regular expressions; wildcards
themselves are different 
See the section on Regular
expressions in the  file General
differences in use between Microsoft
Office & OpenOffice.org.
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To do this... In Word... In Writer...
Choose, create, or edit a custom
dictionary

Tools > Options > Spelling
& Grammar > Custom
Dictionaries

Tools > Options > Language
Settings > Writing Aids

Create exception (exclude)
dictionary

File > New, type words, Save
As > text only, file
extension .EXC

As for custom dictionary, but select
Exception [-] checkbox

Track changes (choose options) Tools > Options > Track
Changes

Tools > Options > Text Document
> Changes

Protect document for editing Tools > Protect Document Edit > Changes > Protect Records
(Password needs to be at least 5
characters)

Mark and track changes (Word 2000) Tools > Track
Changes > Highlight
Changes

Edit > Changes > Record

Insert comments associated with
a change

Highlight text; Insert >
Comment

Edit > Changes >Comment

Insert notes (comments not
associated with a change)

Highlight text; Insert >
Comment

Insert > Note

Show changes as pop-up text Options > View > Screentips Help > Tips (and) Help > Extended
Tips

Merge documents Tools > Merge Documents Edit > Changes > Merge Document

Accept or reject changes View > Toolbars >
Reviewing

Edit > Changes > Accept or Reject

Change document properties File > Properties File > Properties

Get a word count Tools > Word Count (can get
word count for selection)

File > Properties > Statistics tab.2

Create AutoText entry Select text; Insert >
AutoText > New

Edit > AutoText (or) Control + F3

Insert AutoText Type shortcut and press F3 Type shortcut and press F3; or type
Name and press Enter. Writer
distinguishes between the “name”
and the “shortcut” of an autotext.
Word does not.

AutoText in Writer always ends with a paragraph mark. So for a short in-line shortcut, better
to use AutoCorrect.

2To get word count for selection, use the wordcount macro at:
http://www.darwinwars.com/lunatic/bugs/oo_macros.html. This does selections, and will do footnotes for
OOo1.1 and above. OOo 2.0 will have a Word Count feature for selections.
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Control page layout

This section covers such things as margins, headers, and footers.

Writer and Word have somewhat different notions of page layout.

Word notion of page layout
Page layout is a property of the document as a whole. If you change the page layout (for
instance, set the document to landscape), it changes for the entire document. You can then
arrange for specific sections to have a different layout.

Writer notion of page layout
Page layout is a property of the page style (for example, First Page, Index and Default). If you
change the page layout for one page style (for instance, set Default to have a header with page
numbers) only that style will be affected.

Using page styles gives Writer some very useful features. For instance, you can define the
First Page page style so that, after you have typed the first page, the style switches to Index
(or any other style you choose). You can then set Index so that it is followed by Default.

Comparison for page layout
Table 9: Control page layout

To do this... In Word... In Writer...
Define margins File > Page Setup > Margins Format > Page >Page

Specify different headers and
footers on first, odd, and
even pages

File > Page Setup > Layout >
Headers and Footers section

Define different page styles for
First, Left (even), and Right (odd)
pages, using Header and Footer
tabs

Edit headers and footers View > Headers and Footers, then
type or insert fields; can also double-
click in existing header or footer
regions

After you have specified Header
and Footer areas for a page, they
are always active. Single-click to
type or insert fields

Change from roman to arabic
page numbers in the footer of
a page

Insert a section break, deselect
“Same as Previous” in the second
section, define a new footer with
page numbers restarting at 1 in
arabic numerals

Insert a manual page break and
apply a different page style

Use paragraph styles for page
layout

Can define paragraph styles with
offset from left margin, with heading
styles aligned left or right

Can define paragraph styles with
offset from left margin, with
heading styles aligned left or right

Use columns for page layout Insert continuous sections to switch
from single to multiple columns on
one page

Format > Page > Columns (or)
Insert/Format > Section >
Columns (or) other methods
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To do this... In Word... In Writer...
Use frames or text boxes for
page layout

Frames are used in Word 97 but
mostly replaced by text boxes in
Word2000 and 2002; can be linked
to flow text from one to next, as in a
newsletter

Insert > Frame (can link frames
to flow text from one to next, as
in a newsletter); “text boxes” are
fields, not positioning devices

Use tables for page layout Table > Insert > Table (use dialog to
format)

Insert > Table (use dialog to
format)

Put portrait headers on
landscape pages

Use rotated text box linked to header Use rotated text in a frame

Set first page number to
greater than 1

Insert > Page Numbers > Format In first paragraph on first page,
Format > Paragraph > Text
Flow > Breaks, select Enable
and With Page Style, choose the
page style, specify the page
number

View and edit facing pages File > Print Preview; click Zoom
button to enable editing

File > Page Preview; cannot edit
when previewing; shows pages on
wrong sides of screen

Reduce page count by 1 File > PagePreview, Click
ShrinkToFit button.

See
http://homepages.paradise.net.nz/
hillview/OOo/ShrinkToFit.sxw.

Use templates and styles

Table 10: Use templates and styles.

To do this... In Word... In Writer...
Find which template is
associated with a document

Tools > Templates and Add-ins File > Document Properties >
General tab.

Specify default template "Normal" template is default File > Templates > Organize lets
you set any template as default

Create a new template File > Save As, set type to
Document Template (.DOT)

File > Templates > Save

Edit a template File > Open, choose template File > Templates > Edit

Copy styles between templates Tools > Templates and Add-ins
> Organizer

File > Templates > Organize.
There, you can copy styles with drag
and drop between templates and
documents.

Create a new document from a
template

File > New (opens a list of
templates)

File > New > Templates and
Documents

Apply a different template to a
document

Tools > Templates and Add-ins
> Attach, select template, Open

Start a new document based on the
different template; copy contents of
old document into new document.
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To do this... In Word... In Writer...
Apply a style to text (Word 2000) Select from Style

List or Style dialog
(XP) Can also use task pane.

Format > Styles (or press F11),
double-click style in list; after one
use, paragraph styles appear in
Apply Style list on Formatting
object bar.

Change a style definition (Word 2000) Format > Style >
Modify; (XP) can also select in
task pane and click Modify

Select style in Stylist, right-click,
choose Modify; or Format > Styles
> Catalog, select style, click
Modify.

Create a new style Format > Style > New Format > Styles > Catalog, click
New or Right click in Stylist New.

Use outline numbering Format > Style, select style >
Format > Numbering

Tools > Outline Numbering

Drop caps Format >Drop Cap...
One character only, can not be
part of a style.

Format > Paragraph > Drop Caps
Drop caps are able to be part of a
style. Can be >= 1 char or word.

Font size
When a style is based on another style, it is possible to set the font to being a percentage of
the font size of the original style. In the font size field simply type the number followed by a
percentage sign, e.g. 120%. This way, changes to the underlying style will be better reflected
in this style. To change it back to being an absolute font size type the number followed by the
characters “pt”, e.g. 12pt. It is also possible to specify how many points larger or smaller: e.g.
+2pt for 2 points larger, or -2pt for two points smaller.

Space between paragraphs and page breaks before
In Writer, some paragraph properties behave differently to the way they behave in Word.
Specifically:

• Space before if at the top of a page is ignored.

• Space between paragraphs: the greatest of space above and space below for the two
paragraphs is applied.

• Page break before: if at the top of a page, doesn't create a blank page.

This makes using styles possible without having to apply direct paragraph formating to fix
issues afterwards.
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Fields

For a comparison of fields between Writer and Word see the chapter on “Sharing Files with
Microsoft Office users.”

Table 11: Use of fields

To do this... In Word... In Writer...
Insert a field Insert > Field

(or) CTRL+F9 for blank
field

Insert > Fields

Define a number range field Insert > Field, use SEQ
(sequence)

Insert > Fields > Other > Variables
> Number range

Insert a bookmark Select text; Insert >
Bookmark

Select text; Insert > Bookmark

Insert a cross-reference to a
bookmark

Insert > Cross Reference,
choose Bookmark as type

Insert > Cross Reference >
Bookmark3

Insert a cross-reference to a
heading

Insert > Cross Reference,
choose Heading as type

Either bookmark the heading or use
Insert > Cross Reference > Set
Reference to mark the heading, then
Insert > Cross Reference > Insert
Reference.

Insert a cross-reference to a
figure or table

Insert > Cross Reference,
choose type

Insert > Cross Reference > Insert
Reference > Figure (or Table)

Use conditional content Use IF or other fields, or
styles (all workarounds)

Insert > Fields > Other > Variables
(among other ways)

3 For macros that aid in working with references see http://homepages.paradise.net.nz/hillview/OOo/. For a more
detailed discussion on references see the latest document available from
http://www.openoffice.org/issues/show_bug.cgi?id=28058.
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Work with large or complex documents

Major differences exist in the use of master documents. The table does not attempt to
summarize all these differences.

Table 12: Work with large or complex documents.

To do this... In Word... In Writer...
Create a table of contents, list of
figures, or an alphabetic index

Insert > Index and Tables Insert > Indexes and Tables >
Indexes and Tables

Insert index entries ALT+SHIFT+X Insert > Indexes and Tables >
Entry (or) click Insert Index
Marker icon

Create a bibliographic database Need to use other package Tools > Bibliography Database

Insert bibliographic references
into text

Link to field in database Insert > Indexes and Tables >
Bibliographic Entry

Insert footnotes and endnotes Insert > Footnote Insert > Footnote (or) click Insert
Endnote Directly icon

Insert other files Insert > File, choose Insert or
As Link

Insert > File

Cross-reference between
documents

Use Includetext fields Currently have to remember the
name of the set reference. Reference
will show correctly when in master
document.

Use master documents Some experts do not
recommend using Master
Documents in Word.

File > Send > Create Master
Document; use Navigator to insert
subdocuments
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Work with graphics

Most graphics work should be done outside Word or Writer, with the graphic files embedded
or linked to the Word or Writer file. However, you can do some simple graphics using the
drawing tools in Word or Writer. This table covers the basics.

Table 13: Work with graphics.

To do this... In Word... In Writer...
Create Drawing objects (Word 2000) View > Toolbars >

Drawing; (XP) Insert > Picture >
New Drawing

Click Show Draw Functions icon

Combine graphics objects and
drawing objects

(Word 2000) Edit > Picture >
Reset Picture Boundary; (XP) Use
drawing canvas

Place all objects in a frame

Insert graphics files into a text
document (embed or link)

Insert > Picture > From File,
choose Insert or As Link

Insert > Graphics > From File

Anchor graphics Format > Picture > Layout >
Advanced > Picture Position

Use icons on Graphics object bar,
or right-click and choose from
pop-up menu, or click Format >
Graphics

Wrap text around graphics Format > Picture (or Object) >
Layout

Use icons on Graphics object bar,
or right-click and choose from
pop-up menu, or click Format >
Graphics > Wrap

Crop graphics Format > Picture > Crop, (or) click
Crop tool on Picture toolbar

Format > Graphics > Crop
(No tool for dragging crop area)

Create captions for graphics Select graphic; Insert > Reference
> Caption

Select graphic; Insert > Caption

Annotate graphics Use drawing objects; group, or
place in frame or on drawing
canvas (XP)

Place all objects in a frame

Insert watermark Format > Background > Printed
Watermark > Picture (or Text)
Watermark

Format > Page Style >
Background
(or) create drawing object,
Arrange > To Background,
Anchor > To Page
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Mail Merge

A lot of this section is based on a “howto” written by Sophie Gautier, titled “How to do a
“mail merge” from a Calc spreadsheet”. The original is at:
http://documentation.openoffice.org/HOW_TO/word_processing/writer2_EN.html.

Creation of the Mail Template (main document)
1) In Writer create a document that is going to be the mail template.

2) Save the file but don't close it.

3) View > Data Sources (or press the F4 key). The registered data sources will be
displayed in the data source viewer.

4) Select the source of data for the mail merge. Click on the little cross next to the data
source name to display its content tree. Clicking on the name of a table to display the
fields and their records in the right side of the data source viewer. See the chapter on
Data Sources in the Common Features Guide section for information on registering a
data source.

To add the fields into your document

Click and drag the desired fields (one at a time) to the desired places in your document.

Selecting records for the merge
To select a record, click on the gray rectangle to its right. A small arrow will be displayed and
the record will be highlighted.

To select records that are not consecutive, hold the Control key down while making
selections.

Note: For selecting records based on a criteria see the chapter on Data Sources in the Common
Features Guide section.

Viewing merged data

To see your document as it will be when merged, click the Data to fields button 

To view different records, simply select the records in the data source viewer.

Eliminating blank lines
If a field might be blank, then the process to suppress the potentially blank line is:

1) In the mail template, place the cursor before the field.

2) Control+F2 (or Insert > Fields > Other... ) to open the Fields dialog.
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3) Switch to the Functions tab.

4) Select the field style Hidden Paragraph and type in the Condition area “not(field
name)”.

5) Click on the Insert button to insert the function into the document.

Merging

1) Click the mail merge button .

2) Choose whether to use all the records, the currently selected records (option becomes
available when records are selected; see Selecting records for the merge above).

3) Choose whether to send the merge to printer or file. When sending to file, a separate
file is created for each record; the files are named according to your options but with
an appended number to ensure that they are unique.

Mailing Labels
The easiest way to create mailing labels is:

1) File > New > Labels.

2) Select database from the list of registered databases (see the chapter on Data Sources
in the Common Features Guide section).

3) Select the table within the database.

4) Select each field and click the left facing arrow to move the field into the Label text
area.

5) Tidy the Label text area (press Enter between the address fields).

6) Select the brand and type of label for the labels to be printed on. If the correct brand
and type isn't listed use the Format tab to specify the layout.

7) Click the Options tab, ensure Entire page is chosen. The Synchronize contents
checkbox is so that changes made to the first label are propagated through the
remaining labels.

8) Click New Document.

9) Merge as above.

Merge to e-mail
There is no option for merging to e-mail.
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Envelopes

From the forums some people have had difficulty with envelopes. From brief
experimentation the author hasn't had any problems with OpenOffice.org 1.1.1 and above.

Adding an envelope
Insert > Envelope...

Removing an envelope
1) Place the cursor at the beginning of the envelope page.

2) If the Stylist is not open, press F11 or use Format > Stylist to display it.

3) Change to the Page Styles options.  It's the fourth icon from the left.

4) Double Click on Default.

5) Remove the remaining elements.

Page styles and page numbering

Modify a page style
In Writer all pages have a page style. To modify the page style of the page where the cursor is
positioned, use Format > Page.

Warning: As the page style is being changed, all pages with this style will be changed as well.

Create a style
To create a new page style:

1) If the Stylist isn't currently displayed, press F11 to display it.

2) Click Page Styles in the Stylist (fourth icon from left).

3) Right click in the Stylist > New.

The Page style dialog
Organizer tab

Name: Nothing tricky here, simply a name to help the user remember what the settings are
for.

Next style: This setting specifies what page style to use at the next page break (manual or

Migration Guide 65



Differences in use between Writer and Word

automatic) for any page that has this page style. Set it to a different page style when the page
style is only for one page (such as the first page of each chapter), otherwise this should be the
same as Name to keep the same page style for the following pages.

Page tab

Paper format settings: Format is the paper size, the other settings have the same names in
Word (on the paper size tab of page setup).

Margin settings: Same as for Word. Each setting represents the distance from the edge of the
page, but see Header/footer tabs below as the location of headers and footers relative to the
margins is different.

Layout settings: Page Layout is for specifying whether the page style is mirrored – used for
left and right pages. There are more options here than in Word, but there isn't a different first
page option – that's because it is handled by the Next style setting as mentioned above in
Organizer tab. Format refers to the format of page numbers. Register true is to make the text
line up better at the top of the page (see help for more details).

Background tab

For specifying a background color or graphic (watermark). (An alternative to this with more
flexibility is to create a drawing object, then use Arrange > To Background, Anchor > To
Page.)

Header/footer tabs

Headers and footers are printed between the margins of the page rather than in the top or
bottom margins as they are in Word. Another way of saying this is that for the top of a page
the area between the edge of the page and the top margin is always blank, next is the header,
and after the header, the main text area for the page.

Auto height allows the header or footer to grow and shrink depending on their contents.

Spacing specifies the distance between the header/footer and the main text area on the page.
Dynamic spacing allows the header/footer to expand into the area between the header/footer
and the main text area.

The left and right margins are indenting from the margins of the page and cannot have
negative values.

The More button is for specifying borders and backgrounds for the header/footer area. In
some versions of Word this approach was used to create a watermark. Since it is possible to
have graphics in the background of the main document, this is not the required way of having
a watermark in Writer.

Borders/columns footnote tabs

These tabs are for specifying the borders (lines around the outside), number and widths of
newspaper style columns and defining the area for footnotes (if any) for the page style.
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Page breaks and page numbering

Changing the style used for a page and changing
the numbering sequence
To insert a page break and change page style or page numbering method1:

1) Control + Enter.

2) Cursor will be in the first paragraph of the new page.

3) Format > Paragraph...

4) Breaks will be enabled.

5) Select With Page style, specify the page style to use and specify the page number to
start from.

To insert a page break and change page style or page numbering method2:

1) Insert > Manual break...

2) By default it will specify Page breaks.

3) Choose the Page style.

4) Select Change page number.

5) Enter the new starting page number.

To insert page numbering
1) Define a page style with header or footer turned on.

2) Position the cursor in the header or footer (use the mouse or key shortcut Control +
PageUp for Header or Control + PageDown for footer).

3) Optionally type: “Page” space.

4) Insert > Fields > Page Number.

5) Optionally type space “of” space “ Insert > Fields > Page Count.

To insert a field that calculates a different page count (for example, when you have a title
page but want to have the remaining pages say page 1 of 2 (instead of page 1 of3 ):

1) Press F2 to display the text formula bar.

2) Type =page – 1.

3) Press Enter.

Note: Unfortunately this field doesn't automatically update, so press F9 to update it before
printing.
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Page numbers on portrait and landscape pages in
the same place and orientation

1) Create a style for landscape pages. Set the margins for the landscape style such that
they correspond with the portrait style when rotated (top = left, bottom = right, left =
bottom and right = top). For page numbering on left, turn on headers; on right –
footers. Select Use dynamic spacing.

2) Create a style for the landscape header or footer based on the style for the portrait
header or footer. (In the Stylist, select the style that is used for the portrait header or
footer > right click > New.) Change the font position to 2700. If the page numbering is
on the bottom choose left alignment, for the top choose right.

3) Insert the page break and choose the page style just created (see above); don't change
the numbering.

4) In the relevant header/footer (as per step 1) insert the page number field.

Conditional text

In Word the only way to have conditional text is with the “if” field4. The equivalent in Writer
is the field “Conditional text”.

To insert a conditional field in Writer: Insert > Fields > Other > Functions > Conditional
text or Control + F2 > Functions >Conditional text.

There is also a field “Hidden text” that hides the text when the condition is true.

Working with the relevant fields for conditional text, both in Word and in Writer, means that
only small amounts of text can be conditional. However, there are times when having whole
paragraphs or sections of text be conditionally hidden is very convenient. Some examples:

• A test so that the same document can be used for the test itself and for the model
answers.

• Technical documents where the same document with variations can be used for similar
models of equipment.

Writer provides a field for conditionally hiding paragraphs and the ability to conditionally
hide sections. Here's an example to show how this could be done:

1) Ensure that hidden text is viewable: Tools > Options > Text Document >
Formatting Aids, tick both “Hidden text” and “Hidden paragraphs”.

Note: Conditionally hidden sections are not visible regardless of these settings if the condition
for hiding them is true.

2) At the top of the document: Insert > Fields > Other > Variables.

3) Name: DocType. Value: Model Answers.

4 To the best of the Author's knowledge.
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4) At the start of a one paragraph answer: Insert > Fields > Other > Functions >
Hidden Paragraph. For the condition type DocType == “Test” (To make this easier
to insert repeatedly, create an autocorrect entry).

5) For longer answers: Enter the model answer, select it, Insert > Section..., tick Hide,
and enter DocType == “Test” for the condition.

6) To print the document for a test, double click the field at the top of the document
created in steps 2 and 3, and change the value to Test. Print as usual.

Note 1: The field “Input list” has a name but this is not a variable so its value cannot be used in
the condition.

Note 2: It is easiest if the selection doesn't include the last paragraph to keep adding sections.
But if the last paragraph is selected simply move to the end of the document (Control + End)
then press Alt + Enter.

Master documents

Help covers using the basics of using master documents, or see “Work with large or complex
documents” on page 61, or for even more information see the chapter on Master Documents
in the User’s Guide.

It is possible to insert cross-references across sub-documents but the names of the references
must be typed in rather than selected from a list.

Use Insert > Fields > Other... > References.

A macro to help insert references to headings, including references across documents that
will be sub documents, in a master document, is available in a document called
OutlineCrossRef3.sxw available from http://homepages.paradise.net.nz/hillview/OOo/.

Note: There is no way to have a landscape page in a sub-document and that page remaining a
landscape page when included in the master document. The  workaround is to have the
landscape page be part of the master document rather than a sub-document, or the entire sub
document to be landscape.
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This chapter builds on the material covered in the chapter “General differences in use
between MSO and OOo”. It explores some of the differences is use specific to the difference
in use of the spreadsheet component in Microsoft Office (MSO) and OpenOffice.org (OOo).

Separating parameters in functions

The single biggest difference between Calc and Excel is that Calc uses semicolons to separate
parameters in a function and commas for separating non-contiguous ranges. This usage is the
reverse of Excel.

Interpreting cell contents

In Excel if a cell contains text that can be interpreted as a number, then Excel will in some
situations attempt to do so. In Calc if a cell is defined as text, even if the cell contains a
number then that cell is treated as it is defined as text, which typically means the numeric
value zero.

For example, if cell A1 is formatted as text and contains the character “1”, in Excel a formula
=A1+1 would return the value 2, but in Calc it would return the value 1.

Limitations

Calc only supports 32,000 rows compared to Excel's 65,536. OOo2.0 due out March 2005
supports 65,536 rows.

The maximum number of sheets in Calc is 256 (Excel is only limited by available PC
memory).
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Form fields

List boxes in Calc can either have multi-selection or not, whereas Excel has two multi-
selection modes: multi and extend. In Excel a multi-selection listbox's link to a cell is ignored
(at least in Excel2000; author hasn't checked Excel XP). In Calc the link works, but if more
than one item is selected the cell's value is set to #N/A.

In Calc each option button has its own link to a cell, setting its value to true or false
depending on whether the option is selected. In Excel the cell link returns the number of the
selected option button.

Scroll bars and spinners are not implemented in Calc, although numeric fields can optionally
have spin buttons.

Named ranges and “Natural Language”
formulas

It is possible in some versions of Excel to have the same range name on different sheets, but
this is not possible in Calc.

Calc does have “Natural Language.” This is where column and/or row labels are used
(without defining them as range names) in a formula. In Excel to refer to a cell a space is
used between the label names; in Calc an exclamation mark (sometimes called pling) “!” is
used. In Calc the names are enclosed in single quotes (done automatically by Calc if the label
starts with a letter and only has alphanumeric characters). To turn this feature on/off use:
Tools > Options... > Spreadsheet > Calculate >Automatically find column and row
labels.

Array formulas

Calc supports array formulas (formulas entered using Control+Shift+Enter), but there are
two things which Excel can do that Calc can't do.

In Excel it is possible to have an array formula with two ranges in the formula and Excel
matches each cell in the ranges to get a result. For example, {=SUM(IF(A2:A5=1;B2:B5))}
would work like SUMIF and sum those cells in column B where in the same row column A
contained a 1. Calc returns “Err504” which is an “error in parameter”. Often this can be
worked around by using SUMIF, COUNTIF, or the database functions.

Array constants are not available in OpenOffice.org. The workaround is to have the constant
values in cells on a sheet and refer to them.

Note: OpenOffice.org help refers to array functions as matrix functions.
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Optional parameters in formulas

Some formulas have more than one optional parameter at the end of the parameter list.  In
Excel it is possible to leave an optional parameter blank and specify a later parameter, but
this is not possible in Calc.

For example, to calculate an annuity, in Excel the formula =PV(0.05,10,100,,1) returns -
$810.78; in Calc =PV(0.05;10;100;;1) returns Err:511.

The workaround is to put values in for the missing parameters. For the above example
putting a zero in for the blank parameter returns the same result for the annuity.

Functions

Statistical, engineering, and financial functions
The statistical functions return slightly different results. They are the same up to at least 5
decimal places, but after that there is a discrepancy. Gnumeric (another open source
spreadsheet package) returns exactly the same results as Excel (based on the author's simple
tests). The author hasn't compared the results returned by a statistical package such as R or
SAS for the statistical functions.

In Excel some of the financial functions accept string parameters for dates; in OpenOffice.org
they require a serial number, although you can simply type in the dates in date format without
quotes.

Analysis ToolPak functions
The function EFFECT provided by the Analysis ToolPak for Excel is converted to
EFFECT_ADD in Calc and returns the same results.

Other functions not implemented / imported
Only three other functions are not imported: INFO, GETPIVOTDATA, and HYPERLINK.
Hyperlinks are supported but not as a function – use the Hyperlink button on the Function
bar.

DataPilot / Pivot Table

DataPilots are Calc's equivalent to Excel's Pivot Tables. However there are a number of
limitations. Pivot tables import from Excel into Calc, but as soon as they are worked on these
limitations become apparent. The limitations are:

● There is no PivotChart facility, but a DataPilot can be used as the data source for a
chart.
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● Page fields have not been implemented, but there is a filter option which gives similar
functionality.

● You can have no more than 8 fields in the data, row, or column areas.

● There is no ability to group data (e.g., for a date field, grouping by month can't be
done). The workaround is to create a new column with a formula for calculating the
grouping, e.g., =Month().

● You can't define different formats for different fields.

● There are no calculated fields.

● There is no ability to show data fields as things like “Difference From” or “% of.”

● The Application Program Interface specification is incomplete for writing macros that
work with DataPilots—for example, the ability to control via another program, such as
OpenOffice.org's own macro language, BASIC, whether the tables have grand totals;
or having access to DataPilots created from external data.

● There is a bug in OpenOffice.org that when a sheet containing a DataPilot is deleted
the DataPilot ends up on the preceding sheet but not visible.

● An alternative interface for working with DatPilots can be found in a document called
MyDataPilot.sxc available from http://homepages.paradise.net.nz/hillview/OOo/.

AutoFilter

There are a number of AutoFilter differences between Excel and Calc:

● There is only one AutoFilter active for a spreadsheet document at a time. The rows
remain hidden but the drop downs in the first row disappear on applying AutoFilter
elsewhere.

● The remaining visible row numbers don't change color to warn that there is a filter in
place.

● Error values don't show as an option in the drop down lists when cells in the column
have errors.

● In the drop down lists, the equivalent to Excel's “Custom” is called “Standard.”

● The top 10 in the drop down list is literal, but to get the same degree of control, use
Standard and specify “largest”, “largest%”, “smallest” or “smallest%” in the condition
field.

● Use regular expressions for specifying criteria to select rows based upon the text in the
cells. To do this: Choose “Standard” from the drop-down list, click More so that the
rest of the dialog is displayed, check Regular expressions. Table 1 has some examples
to help an Excel user to use regular expressions.
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Table 14: Example regular expressions for AutoFilter

Excel custom command Comparison Field Equivalent Regular
Expression

Begins with x = ^x.*

Does not begin with x <> ^x.*

Ends with x = .*x$

Does not end with x <> .*x$

Contains x = .*x.*

Does not contain x <> .*x.*

The user is not limited to these regular expressions; they are included here to show how to
achieve the same result for AutoFilter in Calc as can be achieved in Excel.

Text to columns

There is not an option to do this in Calc. See http://ooomacros.org/user.php#104183 for a
macro to do this.

Solver

There is no equivalent in Calc to the Solver add-in for Excel. But a working macro prototype
has been developed and is available from
http://www.openoffice.org/nonav/issues/showattachment.cgi/16029/SolverPrototype.sxc.

Charts

Chart types that Excel provides that Calc doesn't:

• Bar of pie converts to a 2D - columns - normal

• Pie of pie converts to a 2D - columns - normal

• Radar filled converts to 3D – columns deep

• Radar with markers – converts to 2D – net – normal but counter clockwise rather than
Excel's clockwise

Other charting issues include:

• Charts are slower to update in Calc than in Excel.

• There are fewer axis options such as no option for having an inverted y axis (negative
at top towards positive at bottom).
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• The data must be contiguous with the labels in the first row or column.

• To change the range, click on the border of the chart, so that it is selected (green
selection points) > Right Click > Modify Data Range...

Right aligned text

In Excel if text is longer than the cell can hold and right aligned and there is nothing in the
cell to the left, then the text “spills” into this cell. In Calc, the text will “spill” into the cell to
the right if it is empty.

Number formats

There is no “accounting” format (with the currency symbol at the left edge of the cell). A
workaround would be to have another column to the left that contains the currency symbol.

There is no predefined option for bracketing negative numbers. Use a custom format such as
“$#,##0.00_);[RED]($#,##0.00)”.

Grid lines

In Excel gridlines are a property of a Worksheet; in Calc it is an application-wide option:

Tools > Options > Spreadsheet > View

Keyboard shortcuts

Table 15: Excel and Calc default key shortcuts (incomplete)

Function Excel Shortcut Calc Shortcut
Rearranges the relative or absolute
references (for example, A1, $A$1,
$A1, A$1) in the input field

F4 Shift + F4

Edit cell comment (they are known as
'notes' in Calc)

Shift + F2 Control + F1

Fill right Control + R No equivalent

Go to specific cell F5 F5 (shows Navigator)

Insert Function No standard equivalent Control + F2

Enter into all currently selected cells Control + Enter Alt + Enter
Alt + Shift + Enter (also
applies the cell format)
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Mouse use

To select non-contiguous blocks of cells the first selection must be two or more cells, then
proceed as in Excel, holding down Control to select the next block(s) or 

1. Click once on the field "STD" (STanDard) in the status bar.

The field now shows "EXT" (EXTended selection).

2. Another click and it changes to "ADD" (ADD to selection).

Note: the ADD mode is the equivalent to Control + click and EXT is equivalent to Shift + click.

Double-clicking the bottom right corner of the selection doesn't copy to the bottom of the
current region.

Hidden rows

There is no “select only visible rows” command. Selecting a block of cells with hidden rows
and deleting will delete the hidden rows as well. Workaround: select each visible row
manually before deleting. See IannzGotoSpecial.sxc available from
http://homepages.paradise.net.nz/hillview/OOo/ for a macro that can select only the visible
cells.

Navigator

The Navigator's main use would be for spreadsheet documents that have a lot of sheets.
Right-clicking on sheet selection controls doesn't display a dialog for selecting a sheet, so
using the Navigator is faster than scrolling through the sheets.

Stylist

Calc has two types of styles: cell and page. Right-click in the Stylist to create, modify, or
delete styles.

Sheet area combo box

The sheet area combo box (left side of the Formula bar) shows the current range. It can be
used to jump to a named range, but can't be used to define a range (to define a range, use
Insert > Names > Define or Control + F3).
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Function list

The Function list is a floating / dockable window that provides information about the
available functions. It is an alternative to AutoPilot:Functions. To view it: Insert > Function
List.

Error values

Some functions in Calc return esoteric error messages like Err:503. To get a message that is
more meaningful, select the cell with the error message then look at the right end of the
status bar. In this case it will show Error: Invalid floating point operation (e.g. division by
zero).

There is also a full description for each error message found within OpenOffice.org Help.

Conditional formatting and styles

Conditional formatting requires styles to be defined – use the Stylist to do so.

To view a current list of styles for the sheet, press F3 or Format > Stylist.

Working across spreadsheets, web pages,
and database data

Working across spreadsheets
Contrary to help and other references, using the Navigator with a “Drag Mode” of Link
doesn't work for accessing the contents of one spreadsheet in another.

To refer to the contents of cells in another spreadsheet document or workbook, the syntax is
'url of other workbook'#$sheetname!cellrange. For example, on a Linux system:

'file:///home/hillview/Documents/Tests/Address.xls'#$Sheet1.A1

or on a Windows system:

'file:///C:/Documents/Tests/Address.xls'#$Sheet1.A1

To input these links it is possible to:

1) Type in the formula up to the point where the link is required.

2) Window > [select desired document].

3) It isn't obvious that this is working but it is. Select the desired cell or range of cells.

4) Window > [select the original document].
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5) Finish entering the formula.

What is disconcerting is that the value displayed is based on the value of the cell (or range of
cells) when the linked document was last saved.

So to check it, save the linked document and update the link in the document (Edit > Links)
that contains the link.

Note: To reiterate: these links do not update automatically! To get them to update, use Edit >
Links > [select the desired link] > Update. The update works from the saved file – so if both
files are open and the file that the link is based on is updated, that file must be saved before
updating the link.

To have dynamic updating of data between two spreadsheets, use:

1) Select and copy the range of cells to be linked to.

2) Change to the spreadsheet that requires the link.

3) Edit > Paste Special > Link (checkbox down the bottom left).

These cells will have dynamic access to the contents of the other sheet and the values
returned can then be used in other formulas.

Links to HTML data or other spreadsheets
To link to data on the Internet:

1) In a browser navigate to the desired page.

2) Copy the URL.

3) In Calc, Insert > External Data...

4) Paste in the URL.

5) This step is not obvious: press Enter, wait a moment and the bottom list box (called
Available tables / ranges) will show:

• HTML_all (the entire page)

• HTML_tables (all the tables on the page)

• HTML_1 (each table consecutively numbered on the page)

6) Select the desired option from the list box,

7) Optionally check the Update every checkbox and specify how often to update.

The same process can be used for linking to data in spreadsheets.

Note: The source file must be saved before the update can take place. (In OpenOffice.org
AutoSaves overwrite the original file, so with AutoSaves turned on this feature could be more
useful than it at first appears. The author hasn't experimented with this feature to test its limits.)
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Links to database data
1) Display the Data source viewer (F4).

2) In the Data Explorer window, navigate to the desired table or query (if it isn't visible
click Explorer on / off - left button in the Data source toolbar).

3) Drag the table or query onto the sheet (see the Data Sources chapter in the Common
Features Guide section for information about working with data sources such as
registering the data source).

Printing

Calc and Excel have the same printing functionality, but the location of where to get to the
settings is slightly different.

Unlike Excel, a print range must be specified first.

To define the print range (this is the equivalent of File > Page Setup > Sheet  in Excel, first
3 fields):

1) Format > Print Ranges > Edit...

2) Select the desired range for each of the fields.

3) Note: it is possible to select noncontiguous areas for the print area, with each area
being on a separate page. Each area is separated by a semicolon.

Like Excel, Calc provides a Page break view. The menu option is a toggle:

View > Page break preview

The other settings such as whether to have grid-lines are done via the page style:

Format > Page... > Sheet

Print Options for suppressing blank pages and printing only the selected sheet(s) can be set:

Tools > Options... > Spreadsheet > Print

Note: Recommend having both these options set.

To print:

1) File > Print.

2) Optionally click Options to change the settings for suppressing blank pages and /or
only the selected sheet(s).

3) Other settings are the same as in Excel.
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Impress and PowerPoint

This chapter builds on the information given in “General Differences in Use between
OpenOffice.org and Microsoft Office” by describing specific differences in use between
PowerPoint and Impress.

Accessing different views

Impress provides equivalent views to those provided by PowerPoint, and it has an additional
view for customizing the layout of handouts. The two main differences in views between the
two programs are: they have different names (see Table 16), and Impress gives you quick
access to all of its views from the main editing window.

In PowerPoint the buttons for quickly changing the view are in the the bottom left corner. In
Impress, the equivalent buttons are on the top right side, just above the vertical scroll bar.

In PowerPoint, the Notes view is only accessible from the View menu.

In Impress the buttons in the bottom left corner toggle between Slide view and Master view.
To quickly access the Master Slide view in PowerPoint, you need to hold down the Shift key
while clicking on the Normal View button.

Impress includes a button that allows access to objects in the background, and different
layers.

Impress also provides a Handout view for fine tuning how a handout will look. This is
equivalent to (but more flexible than) PowerPoint's print option for handouts.
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Table 16. Comparison of view names between PowerPoint and Impress.

PowerPoint
Name

Impress
Name

Main use

Normal Drawing Editing the contents of the slide

Slide Sorter Slide Rearranging the order of the slide show

Slide Show Start Slide Show The actual presentation (starts from current slide)

Outline Outline Editing the text

Notes Page (from
Edit menu)

Notes Appending notes to a slide

N/A Handout Changing the number and position of multiple slides to be
printed on a page

Master Master Placing and modifying those things which are consistent in
all slides in the presentation

Color gradients and borders

Impress does not support some of the formatting features that PowerPoint does. For example,
Impress does not support three-color gradients, double and triple borders, or round-dotted
borders. When import with PowerPoint slides, Impress will change three-color gradients to
two-color, double or triple borders to single, and round-dotted borders to square dots.

To improve the results of the import, make the necessary adjustments in PowerPoint before
importing to Impress. Change three-color to similar two-color gradient fills, and change
double and triple border lines to a single border line with appropriate width. Round-dotted
border lines that are mapped to rectangle-border closely resemble the original line style in
PowerPoint so that manual editing should not be necessary.

Multimedia

Narration
Voice-over narration is not supported by Impress.

There appear to be no settings for multimedia custom animations, such as the ability to play a
sound for the next x slides.

Sound
The author experienced some problems with sound in OOo 1.1.1 that are not present in
OOo 1.1.3.

Dragging and dropping a sound file from the Gallery places a control button on the slide,
which plays on being clicked when running the slide show.
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Video
Similarly with Insert > Object > Video... there were problems in Ooo1.1.1 that are not
present on OOo1.1.3.

Chart animations

There is no facility in Impress for Chart Effects as there is in PowerPoint, such as presenting
a series or category at a time. On import the charts simply appear. A workaround is to have
multiple copies of the chart with each one set up to display as desired.

Pack and Go

This feature in PowerPoint allowed a PowerPoint file to be split up over several floppy disks
and assured that all related files were included. This facility is not included in Impress, nor
can Impress open such files.

Fields

Date fields are exported as text, so they don't automatically update.

Fields are shown with gray background when editing so that they are recognizable as fields.

Action settings / Interaction

PowerPoint provides action settings for mouse over, but Impress doesn't have this option,
only on mouse click, so mouseovers get mapped to mouse clicks. PowerPoint has an option
for highlighting the object on mouse click / mouse over; Impress doesn't have this, so it gets
ignored on import.

Animating a slide show

Object effect animations
In OOo the object effects are the equivalent to MSO's custom animation. You can accomplish
most of the same functions, but the process is slightly different.

To access the object effects, go to Slideshow > Effects. This will display a docked/floating
window ().
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Figure 1. Animation Effects docked/floating window (shown as floating).

For more information on how to work with docked/floating windows, see the chapter
“General Differences in Use between OpenOffice.org and Microsoft Office.”

To begin, choose an effect category. These categories don't show whether the effect is an
entrance, exit, or emphasis like MSO does. In OOo, the effects are sorted first by the motion
the object takes, then by its direction.

Differences in animation effects
On export/import of Impress/PowerPoint files the names of the effects change. However, the
result and appearance are essentially the same. See Table 17.

In Impress you can only have one type of animation per text box. In PowerPoint it is possible
to assign each bullet in an outline to enter a different way.
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Table 17. Comparison of animation effects between PowerPoint and Impress.

PowerPoint Impress
Appear Appear

Blinds Fade Horizontally

Box Fade To Center

Checkerboard Checkerboard

Diamond Appear

Crawl Fly In From bottom

Dissolve Dissolve

Flash once Appear

Peek Short Fly In from Bottom

Random Bars Horizontal lines

Spiral Spiral Outward Clockwise

Split Close Vertical

Stretch Stretch Vertical

Strips Fade From Top Right

Swivel Rotate Horizontally

Wipe Cross-Fade From Top

Zoom Fade From Center

Random effects Vertical Lines

Slide transition effects
In the same way that object animations have a mapping between PowerPoint and Impress,
slide transitions also have different names between the programs, as summarized in Table 18.

Note: For both text effects and for slide transitions, if you choose one of the effects from the
Favorites menu it will, by default, have sound. The sound can be disabled by changing the effect
options (see ).
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Table 18. Comparison of slide transitions between PowerPoint and Impress.

PowerPoint Impress
Blinds Horizontal Fade Horizontally

Blind Vertical Fade Vertically

Box In Fade To Center

Box Out Fade From Center

Checkerboard Across Horizontal Checkerboard

Checkerboard Down Vertical Checkerboard

Cover Down Fly In From Top

Cover Left Fly In From Right

Cover Right Fly In From Left

Cover Up Fly In From Bottom

Cover Left Down Fly In From Upper Right

Cover Right Down Fly In From Top Left

Cover Left Down Fly In From Upper Right

Cover Right Up Fly In From Lower Left

Cut No effect

Cut through Black No effect

Dissolve Dissolve

Fade Through Black No effect

Random Bars Horizontally Horizontal Lines

Random Bars Vertically Vertical Lines

Horizontal In Close Vertically

Horizontal Out Open Vertically

Split Vertical In Close Horizontally

Split Vertical Out Open Horizontally

Strips Left Down Fade From Top Right

Strips Left Up Fade From Bottom Right

Strips Right Down Fade From Top Left

Strips Right Up Fade From Bottom Left

Uncover Down Uncover Downwards

Uncover Left Uncover To Left
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Fitting text to a frame

Fitting text to the frame, or text box, behaves differently between the two programs. In
PowerPoint, the program automatically resizes the font proportionally as the text exceeds the
size of the text box. In Impress, if the option Fit text to frame has been selected, the program
allows text to be typed outside of the text box. When you select another object, signifying
that typing has finished, Impress resizes the text as if it were resizing a picture. This often
leads to scrunched unattractive text.

The best way to avoid this is to avoid making a slide where the text goes beyond the size of
the text box. This is good work practice for making a presentation anyway.

To change the Fit to frame property in Impress:

1) Select the text box, by moving the mouse until the pointer is on the border of the text
box and the pointer changes into resize or move arrows; click.

2) Format > Text....

3) On the Text tab are the options for automatically adjusting frame size or font size:

• Fit width to text: Resizes the text to fit the width of the drawing or text object.

• Fit height to text: Resizes the text to fit the height of the drawing or text object.

• Fit to frame: Resizes the text to fit the entire area of the drawing or text object (to
be able to check this option the other two options must be unchecked).

This setting can also be changed in Graphics styles.
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