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Overview

Overview

This document describes how to create and use the Master Document feature in
OpenOffice.org Writer.
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Why use a master document?

Why use a master document?

Master documents are typically used for producing long documents such as a book, a thesis,
or a long report, especially when graphics, spreadsheets, or other included material causes the
file size to become quite large. Master documents are also used when different people are
writing different chapters or other parts of the full document, so you don’t need to share files.

Yes, master documents do work in OOoWriter. However, their use is full of traps for
inexperienced users. Until you become familiar with the traps and how to avoid (or work
around) them, you may think that master documents are unreliable or difficult to use.

You can use several methods to create master documents. Each method has its advantages
and disadvantages. Which method you choose depends on what you are trying to accomplish.
The different methods are described in this document, along with suggestions on when to use
each one.

Creating a master document

Depending on the state of your document when you decide to create a master document, here
are the three most common scenarios:

● You have one existing document (let’s call it a book) that you want to split into several
subdocuments (let’s call them chapters) that will be controlled by the master document.

● You have several existing documents (chapters) that you want to combine into one book
that will be controlled by the master document.

● You have no existing documents but intend to write a long book containing several
chapters.

We will look at each of these scenarios in turn.

Splitting one document into a master document and
subdocuments
When you have one existing document that you want to split into several subdocuments that
will be controlled by the master document, you can split the document automatically.

When to use this method: If the original document uses only the Default page style, is
numbered sequentially from the first page, and uses the Heading 1 style to identify the start of
each chapter, this method will work well.

Advantages: This method is quick and easy. Although cleanup work may be necessary, once
you have done the cleanup, the document will behave itself.

Disadvantages: If the original document was complex, you may have major cleanup work to
do because some formatting will be lost—for example, page styles, page breaks, restarted
page numbering.

Creating and Using Master Documents 1



Creating a master document

How to do it: Open the document and click File > Send > Create Master Document to split
the document. You’ll find that each of the subdocuments begins with a Heading 1 and the file
names are all “maindocnameX.sxw,” where X is 1, 2, 3, and so on. If you have a Preface or
other “chapter” starting with a Heading 1 before Chapter 1, the file names will not directly
correspond to the chapter numbers.

Combining several documents into a master
document
This method works best when all of the documents were created from the same template, but
you can also use it when the documents were created from different templates.

Use one of the techniques described in “Starting with no existing documents” to create a
blank master document and insert the other documents as subdocuments of the master
document.

Starting with no existing documents
The ideal situation is to start with no existing documents, because you can do everything
correctly right from the beginning. Writer provides three ways to create a master document:

● Method 1. Quick and easy, but not recommended

● Method 2. Not too complicated, but with restrictions

● Method 3. Complete control

In each case, you need to have a disciplined approach to make sure the master document
works correctly and reliably. Each method below describes the steps to take. Be sure to do
them in the order given.

Method 1. Quick and easy, but not recommended

Writer provides a quick and easy way to create a master document, but I do not recommend
using it, because the master document is not associated with a template, so changes to styles
and formatting are difficult to apply reliably.

How to do it: Click File > New > Master Document.

Method 2. Not too complicated, but with restrictions

This technique works well if you want to use sequential page numbering throughout the final
document (not restarting at 1 at any point), and each chapter starts with a Heading 1 on a new
page. If you want to restart page numbering anywhere in the document, use Method 3.

How to do it: Follow the instructions in the next section (Method 3. Complete control), but
don’t put in the text sections between the subdocuments or try to change the page numbering.

Method 3. Complete control

This method gives you complete control over complex documents with several page styles or
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restarted page numbering. It’s a bit more work to set up, but works reliably.

How to do it: Follow these steps, in the order given.

Step 1. Plan the project

Step 2. Create a template containing the required styles, fields, and other elements

Step 3. Create the master document and subdocuments from the same template

Step 4. Insert the subdocuments into the master document

Step 5. Add a table of contents, bibliography, or index

Step 1. Plan the project

Although you can make changes at most steps in this process, the more you can plan before
you start, the less work you'll have to do to correct any problems later. Here are some things
you need to plan:

● Parts of book or report required, and the page numbering to be used in different parts of
the book. I will use as an example a book with these parts:

Title (cover) page 1 page no page number
Copyright page 1 page (back of title page) no page number
Table of Contents unknown length start with i
Preface (Foreword) 2 pages continue from ToC
Chapters 1 to 8 unknown length start with 1
Appendixes A, B unknown length continue from Chapter 8
Index unknown length continue from Appendix B

● What pages will be in the master document and what will be in the subdocs. The ToC and
Index must be in the master document. A typical arrangement would be: 

Title (cover) page In master document
Copyright page In master document
Table of Contents In master document
Preface (Foreword) Subdocument
Chapters 1 to 8 Subdocuments
Appendixes A, B Subdocuments
Index In master document

● Page, paragraph, character, frame, and numbering styles. See the User Guide chapter on
Styles for instructions on how to create or modify styles. Some styles for my example book
are:

Page styles

Name Characteristics Next page style
Title page No header, footer or page numbers;

layout different from other pages
Copyright page

Copyright page No header, footer or page numbers;
layout different from other pages

Front matter first page
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Name Characteristics Next page style
Front matter first
page

No header; page number in footer,
Roman numbers (i, ii, iii); layout
different from following pages

Front matter left page

Front matter left
page

Header and footer, one containing
the page number (Roman)

Front matter right page

Front matter right
page

Margins mirrored from Front matter
left page; Roman page number

Front matter left page

First page No header; page number in footer,
Arabic numbers (1, 2, 3); layout
same as Front matter first page

Left page

Left page Layout as for Front matter left page,
but Arabic page numbers

Right page

Right page Layout as for Front matter right
page, but Arabic page numbers

Left page

Paragraph styles

Use Heading 1 for Chapter titles. If necessary, define a heading level to use for Appendix
titles. A handy style is Page Break, defined as 6 pt, no space before or after, page break
before. Use whatever other paragraph styles suit your requirements.

● Fields and AutoText entries as required. See other parts of the User Guide for ideas.

Step 2. Create a template containing the required styles, fields, and
other elements

You can create your template from an existing document or template that contains some or
all of the styles you want for this document, or you can create the template from a blank
document. For more about templates, see the Templates chapter in the Writer Guide.

If you use an existing document or template, I recommend that you delete all the text from it
except for fields in headers and footers before saving it as the template for this project. It will
still have all the styles you defined, even if the text is not there.

Be sure to use File > Templates > Save when creating the template. You can change the
styles in the template as your project develops. 

Step 3. Create the master document and subdocuments from the same
template

If you are starting a new project, you must ensure that you create the master document and all
the subdocuments from the same template. It doesn't matter what order you use to create the
master and subdocuments, and you don't have to create all the subdocuments at the same
time, when you're starting the project. You can add new subdocuments at any time, as you
need them—as long as you always create them from the same template.
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Create the master document
I recommend you follow this process to create the master document. You can use other
methods, but each method (including this one) has its drawbacks.

1. Open a new document from the template you created in Step 2. Be sure the first page of
this new document is set to the page style you want for the first page of the final
document; if it isn't, change it. In our example, the style for the first page is Title Page.

2. If any text or page breaks came into this document from the template, delete the text.
(Fields in headers and footers can stay.) 

3. Click File > Send > Create Master Document. Save the master document in the folder
for this project, not in the templates folder. We'll return to this master document later. For
now, you can either leave it open or close it, as you prefer.

Create subdocuments
A subdocument is no different from any other text document. It becomes a subdocument only
when it is inserted into a master document and opened from within the master document.
Some settings in the master document will override settings in a subdocument, but only when
the document is being printed or otherwise manipulated by the master document.

Create a subdocument in the same way as you create any ordinary document:

1. Open a blank document based on the project template (very important).

2. Delete any unwanted text, and set the first page to whatever page style you specified for
the first page of a chapter.

3. Click File > Save As. Give the document a suitable name and save it in the folder for this
project.

If you already have some of the chapters written, the files are probably not based on the
template you just created for this project. You will need to change the template attached to
the existing files. The only way to do this is:

1. Open a blank document based on the project template.

2. Copy the contents of the original document into this new document.

3. Click File > Save As and save the new document in the project folder under a suitable
name.

4. Rename the original chapter file so you don't use it by mistake.

Step 4. Insert the subdocuments into the master document

The instructions in this step use the page numbering requirements given in Step 1. If your
book has different requirements, change these instructions to suit.

These instructions are fairly tedious, but once you have the master document set up, you
shouldn't have to change it, and with a bit of practice setting it up goes quickly. 
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1. Open the master document and do the following.

● Make sure paragraph marks are showing (if necessary, set them in Tools > Options >

Text Document > Formatting Aids, or click the Nonprinting characters icon ).

●  Show text boundaries, table boundaries, and section boundaries (Tools > Options >
OpenOffice.org > Appearance). 

● Display the Navigator (click Edit > Navigator, or press F5, or click the Navigator
icon  ).

 2. Type the contents of the title page (or leave placeholders and fill in later). With the
insertion point in the last blank paragraph on the page, click Insert > Manual Break. On
the Insert Break dialog (Figure 1), select Page break and the page style for the second
page (Copyright page in our example), and leave the Change page number checkbox
deselected. Click OK.

Figure 1. Inserting a page break between the title page and the copyright page

3. Type the contents of the copyright page (or leave placeholders). Insert another manual
page break, this time setting the page style to Front matter first page. Select the Change
page number checkbox and choose 1 in the box below that, as shown in Figure 2. This
number 1 will show in your document as i, because the page style is defined to use
Roman numerals.

4. Let's assume the third page is for the Table of Contents. Leave a blank paragraph or two
on this page and insert another page break, with next page again set to the Front matter
first page style, which we want to use for the first page of the Preface. Because we want
the page numbering for the Preface to continue from the page numbers of the Table of
Contents, we do not select the Change page number checkbox this time. Notice that the
Navigator shows one item, labelled Text.
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Figure 2. Inserting a page break before the first page of the front matter

5. At last we're ready to add the first subdocument, which is the Preface. On the Navigator,
select Text, then long-click on the Insert icon and click File.

Figure 3. Inserting a subdocument into a master document using the Navigator

A standard File Open dialog will appear. Select the required file (which you created in
Step 3) and click OK. Wait while OOoWriter loads this document. 

You'll see that the inserted file is listed in the Navigator before the Text item, as shown in
Figure 4. You do not want it there; you want it after the text. Select Text and then click
the Move Up icon.

Figure 4. Moving text to before a subdocument

Check whether the first page of the master document has the correct page style. If not,
change it.

Scroll to the place where the subdocument begins. You'll see that it has a blank paragraph
at the top of the page; this was inserted as part of the manual page break. Set this
paragraph to the PageBreak style you created in Step 2. 
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Paragraph marker Section marker

Protected section 
containing 
subdocument

Figure 5. Page break before subdocument, which is in a protected section

You'll also notice that the document you just inserted is in a protected section. That
means you can't change any of the contents of this subdocument from within the master
document.

6. Save the master document file before you do anything else.

Now you want to add the next subdocument, which in our example is Chapter 1. In the
Navigator, select the Preface file you just inserted. Long-click on the Insert icon and
click File. Select the required file for the first chapter and click OK. Wait while OOo
loads the file.

You'll see that it comes into the master document before the Preface, which again is not
what you want. Select the new file and click the Move Down icon to move the new file to
be after the Preface.

7. Now place the cursor in the master document itself and scroll around until you find the
beginning of Chapter 1. You'll find that it is on the same page as the end of the Preface,
and you'll probably find there is no paragraph marker between the section markers for the
end of the preface and the beginning of the chapter, so you can't insert a page break.

Section marker at end 
of previous section

Section marker at 
start of next section

Figure 6. Two sections of a master document with no text area between them

To fix this, go back to the Navigator. Select the last file in the list (which should be
Chapter 1), then long-click on Insert and click Text. A blank paragraph appears in the
master document between the two section marks.
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Click on this blank paragraph and insert a page break, specifying the First Page style and
the page number to start at 1. Click OK.

Section marker at 
start of next section

Section marker at end 
of previous section

Text area in master document, between sections

Figure 7. A text area between two sections of a master document

8. Save the master document again.

Now go back to the first page of the Preface and check whether its page style is correct.
(It may go wrong when the chapter is inserted.) If the page style is wrong, change it to the
correct style (Front matter first page in our example).

9. To insert Chapter 2, go to the Navigator and select the last item on the list, which should
be Chapter 1. Insert the file for Chapter 2, move it to the end of the list, and insert a page
break as described earlier. Repeat until all the subdocuments have been added to the list. 

The Navigator will now look something like Figure 8.

Figure 8. The Navigator showing a series of files in a master document 
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Tip

You can define your Heading 1 paragraph style to start on a new page, and thus avoid
inserting manual page breaks between chapters, but this causes a page numbering problem if
you want to restart page numbering at the beginning of Chapter 1. To restart page numbering,
you must insert a manual page break; but because the Heading 1 style on the first page of
Chapter 1 forces yet another page break, you end up with one or more unwanted blank pages
before the first page of Chapter 1. The technique described in this chapter avoids this
problem.

Step 5. Add a table of contents, bibliography, or index

You can generate a table of contents, bibliography, or index for the book, using the master
document. You must insert these items into a text section in the master document.

Put the insertion point on the page in the first text section, where the table of contents is to
go. Create the table of contents as described elsewhere in the User Guide.

If you do not have a Text section at the end of the master document, insert one before the last
subdocument, then move it down so it is after the last subdocument. Now, if you have
included bibliographic entries in your subdocuments, you can put the insertion point on the
page in this last text section, where the bibliography is to go. Create the bibliography as
described elsewhere in the User Guide.

If you have included index entries in your subdocuments, put the insertion point on the page
in the last text section where the index is to go. Create the index as described elsewhere in the
User Guide.

Editing a master document

After creating a master document, you may want to change its appearance or contents.

Changing the appearance of the document
You can change the styles in the template as your project develops. Don’t make changes to
styles in the master document or in any of the subdocuments—do it in the template.

To update the master document (and all of the subdocuments) with changes to the template,
just open the master document. You'll get two messages: first, to ask if you want to update all
links; and second, if you want to apply the changed styles. Answer Yes to both of these
messages.

Editing subdocuments
You cannot edit a subdocument from within the master document. Instead, you must open the
subdocument, either by double-clicking on it in the master document's Navigator, or by
opening it from outside the master document. Then you can edit it just as you would edit any
other document. Just one rule: if you make any changes to the styles while editing a
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subdocument, you must copy those changed styles to the template so they are available to all
of the subdocuments and to the master document.

If you change the contents of any subdocument, you need to manually update the table of
contents, bibliography, and index from within the master document.

Advanced techniques

The methods described earlier in this chapter are all most writers will need when using
master documents. However, some master documents do need automatically-updating cross-
references between the subdocuments. This section describes how to make these work.

Cross-referencing between subdocuments
The process to create cross-references between subdocuments is tedious, but it works. (An
alternative is to use Ian Laurenson's CrossRefHeadings macro, available from
http://homepages.paradise.net.nz/hillview/OOo/.)

1. First set references in each subdocument, just as you would when you are cross-
referencing within a single document. When you do this, keep a list of what you've named
the reference fields, and be sure every name is unique. One way to keep track of this
information is by putting it in a separate text file or a spreadsheet. 

The field names are case-sensitive. You can check the field name by hovering the mouse
pointer over the referenced item. In our example (Figure 9), the heading has the field
name word count.

Figure 9. Finding the field name for a heading

2. Open the master document. In the Navigator (Figure 10), select a subdocument and click
the Edit icon (or right-click and choose Edit from the pop-up menu). The subdocument
opens for editing.
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Figure 10. Selecting a subdocument in the Navigator

3. In the subdocument, place the cursor where you want the cross-reference to appear. Click
Insert > Cross Reference.

4. In the Fields dialog, on the References page, select Insert Reference in the Type list on
the lefthand side (Figure 11). The Selection list in the middle column shows only the
reference field names for the subdocument you're using, so ignore that list and check the
list you created manually in step 1.

Figure 11. Fields dialog showing manual entry of field name
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5. In the Name field in the lower righthand column, type the name of the reference you set
in the subdocument you're referring to. In our example, the reference is in Chapter 3, and
its name is word count.

6. Click Insert. Nothing will appear in the subdocument except a tiny grey bar indicating a
field. If you hover the mouse pointer over this field, you should see the field name (Figure
12). 

Figure 12. Viewing the field name

(You can turn on the display of field codes by clicking Tools > Options > Text
Document > View and selecting the Field Codes checkbox. The two fields shown as
grey lines in Figure 12 now look like Figure 13.)

Figure 13. Displaying field codes

7. After you have inserted all the cross-references required in the subdocument, save and
close it and return to the master document window. 

Within the master document, navigate to the page of the subdocument on which you
inserted the cross-reference field. You should now see the text of the cross-reference
appear in the spot where you inserted it (Figure 14), because within the master document,
the subdocument can find the target of that field reference. 

Figure 14. Field contents showing where inserted in file

This technique also works if you open a subdocument directly in step 2 (that is, not from
within the master document) and insert a cross-reference field.
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