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Overview

Overview
Styles are one of OpenOffice.org Writer's most powerful features. They are necessary to use
OOo Writer to its full potential. This chapter introduces styles, assuming no previous
knowledge from the reader. After reading it, you will be confident using paragraph, page,
and character styles.
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Introduction

Introduction
What are styles?
Most users are used to writing documents according to physical attributes. For example, one
would specify the font family, font size and weight (say, Helvetica 12pt, bold).
Styles are logical attributes. We use styles every day. For example, there are two styles of
computers: desktop and laptop. Each has its own set of distinctive properties. You never say
“my computer is a low-weight, one-piece unit with an LCD screen attached to a rectangular
casing containing the computing components ad the keyboard. Instead, you say “I have a
laptop”.
OpenOffice.org styles are a way to do the same thing for your document. Using styles means
that you stop saying “font size 14pt, Times New Roman, bold, centered”, and you start saying
“title”. In other words, styles means that you shift the emphasis from what the text looks
like, to what the text is.

Why use styles?
OpenOffice.org (OOo) brings a powerful notion of styles. Styles help improve consistency in
a document. They also make major formatting changes easy. For example, you may decide
to change the indentation of all paragraphs, or change the font of all titles. For a long
document, this simple task can be prohibitive. Styles make the task easy.
The time is 9:50 A.M. and Jane is finishing the 30-page paper for school
that is due at 10:00 A.M. She looks over the assignment one more time, and
suddenly she realizes that:
•

The text must use Arial font instead of Times New Roman.

•

The headings must be dark blue and indented.

•

The title must appear at the top-right of every page except the first.

•

Even numbered pages must have a wider right margin, and odd
numbered pages must have a wider left margin.

Thankfully, Jane used OpenOffice.org and styles. She makes all the
changes in 2 minutes and hands in the paper on time.
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Types of styles
OpenOffice.org Writer has five types of styles:
•

Paragraph styles affect a an entire paragraph.

•

Character styles affect a block of text inside a paragraph.

•

Page styles affect page formatting (page size, margin and the like).

•

Frame styles affect frames and graphics.

•

Numbering styles affect numbered lists and bulleted lists.

The first three styles are the most used. Those are the styles covered in this chapter. Frame
styles and numbering styles are left for a later chapter.
These styles are available through a floating palette called the Stylist (press F11 to see it),
shown in Figure 1. The Stylist is discussed in the next section.
Frame Styles
Character Styles
Page Styles

Paragraph Styles

Numbering Styles

Figure 1 Stylist window; and the types of styles.
Note: The Stylist is a floating palette. You can drag it around the screen using the mouse.
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Using paragraph styles
First steps
OpenOffice.org uses a tool called the Stylist to manage styles. The concepts of styles and the
Stylist are best explained through an example.
1) Create a new document (go to File > New > Text Document or press Control+N).
2) Type “Heading 1” in it. Make sure that the cursor remains in that same line.
3) Press the Stylist icon
located on the Function Bar or press the F11 key. This
brings up a window called the Stylist (see Figure 2).
4) Make sure you are in the Paragraph Styles section (click on the top-left icon of the
Stylist ).
Stylist icon

Cursor

Paragraph Styles
Stylist
Figure 2 Click on the Stylist icon to bring up the Stylist.
Double-click on the Heading 1 entry of the Stylist. This will do two things:
•

Give the line you typed the Heading 1 style.

•

Add Heading 1 to the Apply Style menu.

The Apply Style menu is illustrated in Figure 3. It provides direct access to the styles that are
currently in use in the document.
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Using the Apply Style menu
The Apply Style menu lists the paragraph styles that are currently in use in the document.
One can select styles from this menu, just like the Stylist. As an exercise, press Enter, type
some text and select Heading 1 in the Apply Style menu. The text acquires the properties of
the Heading 1 style.
Heading 1 added to Apply Styles menu

Text with Heading 1 style
Style selected
Figure 3 Applying paragraph styles

Modifying paragraph styles
The power of styles lies in the ability to modify them to suit your needs. For the next
example, we will need three lines of text with the styles Heading 1, Heading 2 and Heading
3. Your document should resemble Figure 4. Heading 1 style should be applied to the word
“Title”, Heading 2 to “Subtitle 1” and so on.
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Figure 4 Headings 1-3 with default styles.
Suppose you decide to make some changes to these styles:
•

Heading 1 should be centered.

•

Heading 3 should be indented.

Center Heading 1

On the Stylist, right-click on Heading 1 and choose Modify.

Figure 5 Modifying a style.
When the Paragraph Style window pops up, choose the Alignment tab, select Center and
click OK.
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Alignment tab

Center text
Figure 6 Center Heading 1
Now everything marked as Heading 1 will be centered. If you make another Heading 1, it
will be centered as well.

Centered
Figure 7 Text is centered.
Indent Heading 3

On the Stylist, right-click on Heading 3 and choose Modify (as before). When the Paragraph
Style window pops up, follow the steps below:
1) Click on the Indents & Spacing tab.
2) Under the Indent section, set the indentation before the text to 1.5cm (0.6 in).
Indents & Spacing tab

Indentation

Figure 8 Set indentation
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The result should resemble Figure 9.

Figure 9 Text with the Heading 3 style is indented.

Linked styles
Some OpenOffice.org styles are linked together. This means that a change in one style
affects every style linked to to it. For example, every Heading style (such as Heading 1,
Heading 2) is linked with a style called Heading. This relationship is illustrated in Figure
10.
Heading
Heading 1
Heading 2
Heading 3
Heading 4
Figure 10 Linked styles.
As an example, suppose you want to change the font of not only Heading 1, or Heading 2, but
all headings. The easiest way to do that, is to take advantage of this linking. Open the stylist
(press F11) and select Heading.
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Figure 11 Select Heading style.
Open the paragraph styles window for the Heading style (right-click > Modify) and select
the Font tab. Select the Corsiva font and click OK (see Figure 12).
Select Corsiva font

Font tab

Figure 12 Select Corsiva font for Heading style.
Now the fonts of all the heading styles have been changed in a single operation. Your
document should now resemble Figure 13.

Introduction to Styles

8

Using paragraph styles

Figure 13 All Heading styles now have the Corsiva type font.

Creating custom styles
You have seen that the Stylist provides several pre-defined styles, such as Heading 1 and
Text body. But what if you need something different, like a poem style, that is not in the
Stylist? With OpenOffice.org you can make your own styles to suit your needs.
In this section, we will create a Poem style, and a Poem Header style, with the following
properties:
•

Poem: Centered, with font-size 10.

•

PoemHeading: Centered, bold, with font-size 12.

In addition, a Poem Heading is to be followed by a Poem. In other words, when you press
Enter, the style changes to Poem.
Note: The keen reader may have noticed this behaviour already. After you type a heading and
press Enter, the style switches back to Text body.

Creating the Poem style
Our first example is the Poem style. We use the Default style as a starting point.
1) Click on the Stylist icon

to bring up the Stylist (or press F11).

2) Right click on Default and choose New (see Figure 14).
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Figure 14 Create a new style.
This brings up the Paragraph Styles window, with the Organizer tab selected. To create a
custom style, you have to understand and configure the top three entries.
Name

This is the name of the style itself, like Heading 1 or Text body.

Next Style

Set the name to Poem.
This is the style that follows the Poem style by default. When you
press Enter, this style is used.

Linked With

Set this value to Poem. When you press Enter, the text will remain
in the Poem style.
If the Poem style is linked with another, say Default, then any change
in Default will affect Poem, just as you saw with Heading in the
previous section.
For our example, this is not the behavior we want. Set this entry to
– None – . This means that Poem is not linked with any other style.

After making all these changes, your screen should look like Figure 15.

Organizer tab

Edited entries

Figure 15 Initial configuration for the Poem style. Set the first three entries as shown.
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The next step is to configure the alignment and font properties of this style.
•

Under the Alignment tab, select centered text.

•

Under the Font tab, select 10pt font-size.

Click OK to save the new Poem style.
Congratulations! You just made your very own style.

Creating the PoemHeading style
Create a new PoemHeading style. Use the same procedure as before, with these changes:
•

Next style: Select Poem, not PoemHeading.

•

Linked with: Heading.

The window should look like Figure 16.

Edited entries

Figure 16 Settings for the PoemHeading style.
Now set the settings of the new style:
•

Under the Alignment tab, choose centered text.

•

Under the Font tab, choose bold and size 12pt.
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Sample poem
It is a good idea to test out your new styles and see if you are happy with them. Your poem
should look similar to the one in Figure 17.

Figure 17 Sample poem.
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Changing the formatting of your styles
One of the main advantages of styles is that they allow the document formatting to be
changed after the content has been written. For example, suppose you have written a 100
page book of poetry. Then you decide you don’t like the way the poems look after all. Or
perhaps your publisher doesn’t like it.
To learn about reconfiguring styles, we will make the following changes:
•

The Poem style will be indented instead of centered.

•

Add a PoemAuthor style based on Poem, except it is bold and has more indentation.

Indent Poem and Poem Header

First, set the Poem style to left alignment:
1) From the Stylist, select Poem, right-click and select Modify.
2) Go to the Alignment tab and select left alignment.
Set the indentation:
1) Go to the Indents & Spacing tab.
2) Under Indent, set the indentation before the text to 5cm (or about 2in).
Done! Click OK, and you should see the text change. Do the same thing for PoemHeading.
Create Poem Author style

You already know how to create a new style. Follow the same procedure as before (starting
from the Poem style). Use the following configuration:
•

Name: PoemAuthor.

•

Next style: Default.

•

Linked with: Poem.

Now, configure PoemAuthor just like you configured Poem, with the following changes:
•

Font: bold.

•

Indentation: 8cm (3.2 in).

•

Under the Indents & Spacing tab, under Spacing, set the spacing above the paragraph
to 0.5cm (0.2 in). This creates an extra space between the poem and the name of the
author.

These settings are shown in Figure 18.
The purpose of this style is to set apart the name of the author from the rest of the poem.
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Edited entries

Figure 18 Indentation and spacing for the PoemAuthor style.
This is how the Indents & Spacing tab should look at this point:Click OK to save this style.
Now set the author of the poem (in my case, “Robert Frost”) to the newly created Poem
Author style, as described in the Getting started section.
Final result

After all these changes, the poem should look similar to Figure 19.
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Figure 19 Final result, using three custom styles.

Tips and tricks
You can make the Stylist display only custom styles. Click on the menu at the bottom of the
Stylist window and select “Custom Styles”. As shown in Figure 20, the Stylist only displays
Poem, PoemAuthor and PoemHeading.

Custom styles view

Figure 20 Displaying custom styles only.
Introduction to Styles
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Using page styles and page numbering
Page styles are to pages what paragraph styles are to paragraphs. Just as paragraph styles can
define paragraph properties (font size, color and others), page styles can define page
properties (margins, page size and others).

Real life situation

Christian is a lawyer from California, USA. For his letters,
the first page has his letter head, and subsequent pages only
identify the recipient, the date and the page number.
Christian does this using page styles. He also uses page
styles to comply with the spacing requirements (such as
margins) for legal briefs in California State courts.

The page style for the current page is displayed on the status bar (Figure 21).

Current page style

Figure 21 The current page style is displayed on the status bar.
Open the Stylist and click on the Page Styles button

.

Page Styles
Figure 22 Selecting page styles.
Right-click on the currently active page style (see Figure 22) and select Modify. This
displays a window, shown in Figure 23.

Introduction to Styles

16

Using page styles and page numbering

Page properties

Figure 23 Page properties.

Page numbering
Many people first encounter page styles when they want to number pages. OpenOffice.org
(OOo) has a very powerful system for numbering pages, but to make full use of it you need to
learn something about page styles.
Preliminaries – fields

OpenOffice.org uses a feature called fields to manage page numbers. To insert a page
number field, select Insert > Fields > Page Number. You will see the page number on a
gray background. The gray background denotes a field.
Note: The gray background is purely for informational purposes. When you print the document,
the background will be the same as the rest of the document. Go to View > Field Shadings to
turn this feature off.
If you have seen lists in OOo, you will have noticed this gray background. OOo lists use
fields. The page number field always displays the page number for the current page. If you
see the words “Page number” instead of a number, press Ctrl+F9. This shortcut key toggles
OOo between displaying field contents (what the field is for) and field results (what the field
creates).
Note: A full introduction to fields is beyond the scope of this chapter.
Inserting a header

In OOo, headers are specified by page styles.
1) Open the Page Style dialog.
2) Select the Header tab.
3) Select Header on and click OK (see Figure 24).
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Turn on page header
Figure 24 Turn on page header.
At this point you should see the header on the current page, as in Figure 25.

Page header

Figure 25 A page with a page header.
What’s so special about headers? The text on the header appears on all pages with that page
style (try it!). This property of headers (or footers), along with fields, forms the basis of OOo
page numbering.
Tip: You can also add a header through the Insert menu: Insert > Header > [page style].
Likewise for footers: Insert > Footer > [page style].
Simple page numbering

The simplest case is to have the page number at the top of every page, and nothing more. To
do this, put the cursor on the header and select Insert > Fields > Page Number (Figure 26).

Page number

Figure 26 Page number inserted in the header.
Presto! Now the correct page number appears on every page.
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More complex variations

There are a lot of interesting variations that you can apply without further knowledge of page
styles. Here are some suggestions:
•

Right-align the header to make the page number appear on the top-right.

•

Add the word “page”, so the header reads “page 1”, “page 2”, and so on.

•

Add the document title, so the header reads “My Poem book, page 12”. Consider
using a tab to separate the title from the page number.

•

OOo also has a Page Count field (Insert > Fields > Page Count). Using it, you
could, for example, have a header that reads “page 2 of 12”.

These variations are all illustrated in Figure 27.

Additional contents

Page number

Page count

Figure 27 Variations on the simple page numbering method.
Many more variations are possible. For example, you can use a footer instead of a header to
make the page number appear at the bottom of the page.

The Next Style property
You have seen the Next Style property in the context of paragraph styles. This property is
especially powerful in page styles.
Make two page styles alternate

Perhaps the most common use of the Next Style property is to alternate between two page
styles. For example, if you are writing a book, you might want the following setup:
Odd pages

Even pages

Introduction to Styles

•

Page number on the top-right corner of the page.

•

Author name on the header.

•

Extra wide left margin.

•

Page number on the top-left corner of the page.

•

Book title on the header.

•

Extra wide right margin.
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Note: The margins are set this way to make binding easier after the book is printed double sided.
This can be accomplished using what you already know of page styles, plus a clever use of
the Next Style property. OOo provides two page styles called Right Page and Left Page.
First, set the page style Right Page to be followed by Left Page and vice versa.
1) On the Stylist, go to the configuration window for the Right Page style (Figure 28).

Figure 28 Right-click on Right Page and choose Modify.
2) Click on the Organizer tab, and set Next Style to Left Page (Figure 29). This means
that, after a Right Page, the page style will switch to Left Page.

Set Next Style to Left Page

Figure 29 Set Next Style to Left Page.
3) In a similar way, set Left Page to be followed by Right Page.
Set the first page of the document to Right Page. You will see that the page styles Right
Page and Left Page alternate. You can see the page style change in the status bar (Figure 21)
when you go to the next page. Now we can setup the properties of the Right Page and Left
Page styles.
Set up the page properties for Right Page.
•

Put the page number on the top-right of the page, and your name on the header.

•

The page margin settings are located under the Page tab. Set the left margin to 4cm
and leave the others unchanged. See Figure 30.
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Page margin

Figure 30 Set the page margins on the Page tab.
In a similar way, set up the page properties for Left Page.
•

Put the page number on the top-left of the page, and the title on the header (pick a title
for this exercise).

•

Set the right margin to 4cm and leave the others unchanged.

Figure 31 illustrates the transitions between Right Page and Left Page.

Right
Page

Left
Page

Right
Page

Left
Page

Figure 31 Right Page and Left Page styles alternate.
A title page

Consider a slightly more complex scenario. You want the document to have a title page. A
title page is different from the rest of the document:
•

It should not have a header or page number.

•

The left and right margins should be the same.

For the title page we can use the Front Page style that comes with OOo. Setting up the
header and margins is left as an exercise for the reader. The difficult part is how to reconcile
this front page with the alternating page styles (Right Page and Left Page). The trick is to set
the Next Page property to Right Page. In other words:
First Page
Right Page
Left Page

Introduction to Styles

Next Style: Right Page
Next Style: Left Page
Next Style: Right Page
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This works as illustrated in the following flowchart (Figure 32).

Front
Page

Left
Page

Right
Page

Figure 32 Flow of page styles.

Manual page breaks
The previous section discussed the Next Style property. This feature is enough for projects
with straightforward pagination requirements (for example, reports, letterheads, and small
books). But more complex projects require more control over page styles. Manual page
breaks provide this control.
The idea is simple: you break a sequence of page styles, and start a new sequence. To insert a
page break, go to Insert > Manual Break and choose page break. This section illustrates
three scenarios where page breaks are useful.
Example: Chapters

You are writing a book that is divided into chapters. Each chapter starts with a page style
called New Chapter. The following pages alternate between Right Page and Left Page. At
the end of the chapter, we return to New Chapter, for the next chapter.
OOo doesn’t have a New Chapter style, so you must create a custom style (see page 9). Let’s
suppose that you already have the page styles with the following properties:
New Chapter
Right Page
Left Page

Next Style: Right Page
Next Style: Left Page
Next Style: Right Page

This can be seen visually in the flowchart in Figure 33.

New
Chapter

Right
Page

Left
Page

Figure 33 Flow of page styles.
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At some point you will want to start a new chapter. Follow these steps:
1) Put the cursor at the end of the chapter, on a blank line of its own.
2) Go to Insert > Manual Break.
3) Select Page break, and under style, choose New Chapter.

Choose page break

Select style

Figure 34 Choose page break, and select the New Chapter page style.

Page break

Figure 35 illustrates the flow of page styles when using page breaks.

Chp
1

Right
Page

Left
Page

Chp
2

Right
Page

Left
Page

Figure 35 Page style flow using page breaks
Example: Inserting a page with special formatting

Some times you may need to insert a page with special formatting. For example, a landscape
page, or a page with more columns. This can also be done with page breaks. Suppose that
the current page has the Right Page style.
1) Insert > Manual Break.
2) Select the page style (say, Special Page). This page takes the place that would
normally be occupied by a Left Page.
3) Fill in the contents for this page. Then insert another page break.
4) Then select Right Page again. The pagination continues on as normal, except that one
Left Page has been replaced by a different page style.
This concept is illustrated in Figure 36.
Introduction to Styles
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Left
Page

Right
Page

ia
c
e
sp

l

Right
Page

Left
Page

Figure 36 Inserting a page with special formatting.
Example: Restart page numbering – a preface

Some times you want to reset the page number back to 1. A typical example is the preface
for a book. A standard preface has the following properties:
•

Page numbers are displayed in Roman numerals (i ii iii iv ...).

•

After the preface, the document starts on a Right Page.

•

The page number resets to one, and the format becomes Arabic (1 2 3 4 ...).

Resetting the page number requires page breaks.
Suppose the preface uses the Preface Page style (which has to be a custom style). After the
preface comes the Right Page style, and then the two page styles Right Page and Left Page
alternate.
First, let’s get the preliminary work done for the Preface Page style:
1) Create a new page style called Preface Page.
2) Set Next Style to Preface Page, since a preface could span multiple pages.
3) Add a header to Preface Page and insert a page number field.
Next make page numbers display as Roman numerals (i ii iii iv):
1) Open the page style dialog for Preface Page and click on the Page tab.
2) Under Layout settings, set the format to “i, ii, iii ...”. See Figure 37.
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Set page number format

Figure 37 Set page number format to Roman numerals.
After the preface is written, we are ready to restart page numbering. Follow these steps:
1) Put the cursor at the very end of the preface, on a blank line.
2) Insert > Manual Break. Select Page break and choose the Right Page style.
3) Put a check mark next to Change page number and set the new value to 1.
These settings are shown in Figure 38.

Set style to Right Page.

Change page number to 1
Figure 38 Set the new page number to 1 and the page style to Right Page.

Important Note: OpenOffice.org will not let you assign an odd page number to a Left Page, or
an even page number to a Right Page. OOo strongly adheres to the convention that odd page
numbers go on right-hand pages and even page numbers on left-hand pages.
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Using character styles
Character styles are a complement to paragraph styles. Like paragraph styles, they define text
properties (font, weight, size), but they are applied to smaller blocks of text than a paragraph.
For example, you can use the Emphasis character style to emphasize a word. A couple of
character styles used in this document include:
•

Key strokes use the KeyStroke style. For example, “to set OOo to full screen, press
Control+Shift+J”.

•

Menu paths use the MenuPath style. For example, “you can turn field shadings on and
off through View > Field Shadings”.

Why use character styles?
Beginning users often wonder, “why use character styles?”, “how is this different from
pressing the bold button?”. The following real life event illustrates the difference.

Real life situation

Jean is an technical writer from Australia. She learned the value
of character styles after her publisher told her to unbold menu
paths from her 200 page book. Jean had not used character
styles. She had to edit all 200 pages by hand, with some help
from Find and Replace.
This was the last time Jean failed to used character styles.

Character styles don’t have as many options as paragraph styles or page styles. Their benefits
are of a different nature:
•

Formatting changes.
As Jean’s story illustrates, the ability to make formatting changes throughout a
document can be important. Character styles provide this.

•

Consistency.
Character styles help ensure that typesetting guidelines are applied consistently.

•

Focus on content.
“Was I supposed to bold keystrokes? How about menus?”
A writer shouldn’t have to remember the answers to these questions. Typesetting
details distract you from the real content of your work. A properly named character
style (such as KeyStroke or MenuPath) will remove this burden from you.

Other ways of using character styles are described elsewhere in the Writer Guide. These uses
include making chapter numbers, page numbers, or list numbers larger than the surrounding
text and formatting hyperlinks.
Introduction to Styles
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Using character styles
Open the stylist (press F11) and click on the second button at the top bar . This displays
the list of available character styles. To apply a character style follow these steps:
1) Highlight the block of text where you wish to apply the style.
2) Double click on the appropriate character style.
Some examples include:
This example uses the Emphasis character style.
Definition: A statement describing the meaning of a word or phrase.
Note: One difference between character styles and paragraph styles is the need for highlighting.
Character styles require you to highlight the applicable text; paragraph styles do not.
Unset/undo character styles

Some times you will want to remove the formatting from a block of text. You must resist the
temptation to do this manually. This will only cause trouble down the road. There are two
easy ways to remove character formatting:
•

Select the block of text, right-click and choose Default.

•

If you have the Stylist open, click on the Default character style.

Note: Incidentally, the first method also works for removing manual formatting.
Migrating to character styles

For people used to formatting text manually, character styles can take some getting used to.
Here are some suggestions for making the transition easier:
•

Never mix character styles and manual formatting. Manual formatting supersedes
character styles. If you combine them, you may end up wasting hours in frustration
trying to figure out why your character styles don’t work.

•

Right-click > Default removes any text formatting (both manual and character styles).

•

Realize that clicking on the bold button is not easier than clicking on a character style.

•

Leave the Stylist open to make character styles easy to access.
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