Getting Started with Calc:
The spreadsheet component of OpenOffice.org
## Contents

Overview ................................................................................................................................. iii
Copyright and trademark information ................................................................................... iii
Feedback ................................................................................................................................. iii
Acknowledgments ..................................................................................................................... iii
Modifications and updates ....................................................................................................... iii
What is Calc? ............................................................................................................................. 1
Workbooks, worksheets and cells ............................................................................................... 1
Parts of the main Calc window..................................................................................................... 2
  Title bar and Menu bar .............................................................................................................. 2
  Toolbars ....................................................................................................................................... 2
  Formula bar ............................................................................................................................... 4
  Individual cells .......................................................................................................................... 5
  Sheet tabs ................................................................................................................................... 5
Starting new workbooks ............................................................................................................. 5
Opening existing workbooks ....................................................................................................... 6
Saving workbooks ....................................................................................................................... 7
Navigating within worksheets ...................................................................................................... 8
  Going to a particular cell .......................................................................................................... 8
  Moving from cell to cell .......................................................................................................... 9
  Moving from sheet to sheet ..................................................................................................... 9
  Navigation shortcuts ............................................................................................................. 10
Selecting items in a worksheet .................................................................................................. 11
  To select a cell ....................................................................................................................... 11
  To select a range of cells by dragging the mouse .................................................................. 11
  To select a range of cells without dragging the mouse ......................................................... 11
  To select cells which are not contiguous ............................................................................ 12
  To select an entire column, row or sheet ............................................................................ 12
  To select more than one worksheet .................................................................................... 12
Inserting and deleting columns and rows .............................................................................. 13
  To insert a single column or row ....................................................................................... 13

Getting Started with Calc
To delete a column or row .................................................................13
To insert multiple columns or rows ..................................................13
To delete multiple columns or rows ..................................................13
Inserting and deleting worksheets .....................................................14
To insert new worksheets .................................................................14
To delete worksheets ......................................................................14
Renaming worksheets ....................................................................14
Worksheet views ...........................................................................15
Using the zoom function ..................................................................15
Freezing rows and columns ...............................................................15
Splitting the window ......................................................................16
Entering data into a worksheet ........................................................18
Standard entry techniques ...............................................................18
More entry techniques ...................................................................19
Overview

This chapter introduces Calc, the spreadsheet component of OpenOffice.org 1.x.

Copyright and trademark information

The contents of this Documentation are subject to the Public Documentation License, Version 1.0 (the “License”); you may only use this Documentation if you comply with the terms of this License. A copy of the License is available at: http://www.openoffice.org/licenses/PDL.rtf

The Original Documentation is Calc: the spreadsheet component. The Initial Writers of the Original Documentation are Dave Le Huray and Jim Taylor © 2003. All Rights Reserved. (Initial Writer contacts: jttac@shaw.ca and dave@lehurst.org.uk. Contact the Initial Writers only to report errors in the documentation. For questions regarding how to use the software, subscribe to the Users Mail List and post your question there: http://support.openoffice.org/index.html.)

All trademarks within this guide belong to legitimate owners.

Feedback

Please direct any comments or suggestions about this document to: authors@user-faq.openoffice.org.

Acknowledgments

Ken Jones reformatted and revised the original document. Peter Kupfer added some new material.

Modifications and updates

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>16 Jan 2005</td>
<td>First published edition</td>
</tr>
</tbody>
</table>
What is Calc?

Calc is the spreadsheet component of OpenOffice.org (OOo). You can enter data, usually numerical data, in a spreadsheet and then manipulate this data to produce certain results.

Alternatively you can enter data and then use Calc in a ‘What If...’ manner by changing some of the data and observing the results without having to retype the entire workbook or sheet.

A major advantage of electronic spreadsheets is that the data is easier to alter. If the correct functions and formulas have been used, the program will apply these changes automatically.

Workbooks, worksheets and cells

Calc works with elements called workbooks. Workbooks consist of a number of individual worksheets, each containing a block of cells arranged in rows and columns.

These cells hold the individual elements; text, numbers, formulas etc., which make up the data to be displayed and manipulated.

Each workbook can have many worksheets and each worksheet can have many individual cells. In version 1.x of OOo, each worksheet can have a maximum of 32,000 rows (1 through 32000) and a maximum of 245 columns (A through IV). This gives 7,840,000 individual cells per worksheet.
Parts of the main Calc window

When Calc is started, the main window will look similar to Figure 1.

![Figure 1. Parts of the Calc window](image)

**Title bar and Menu bar**

The Title bar, at the top, shows the name of the current workbook and the version of OOo in use. If the workbook is new, then its name is Untitled X, with X being a number. When you save a new workbook for the first time, you will be prompted to enter a name.

Under the Title bar is the Menu bar. When you choose one of the menus, a submenu appears with other options. The Menu bar can be modified, as discussed in the chapter titled “Menus and Toolbars” in the Common Features Guide.

**Toolbars**

Under the Menu bar by default are three toolbars: the Object bar, the Function bar, and the Formula bar. The Main toolbar runs vertically down the left hand side of the screen.
The icons on these toolbars provide a wide range of common commands and functions. The toolbars can be modified, as discussed in the chapter titled “Menus and Toolbars” in the Common Features Guide.

Placing the mouse pointer over any of the icons displays a small yellow box, called a tool tip. It gives a brief explanation of the button’s function. Turning on Extended Tips under the Help menu, Help > Extended Tips, will provide a more detailed explanation of the buttons.

Some icons (buttons) have little green arrows attached to them, as in Figure 2. These arrows indicate that there are further commands or functions associated with this button. For some of these, the initial behavior of these icons depends on whether or not a default has been set for that button. Where there is no default, clicking the button will cause a small window to open from which a function can be selected. The Draw Functions window in Figure 2 is an example of this.

Other icons act a bit differently. For example, the first button in Figure 2, Insert, opens a dialog box from which you can select a graphic to be inserted. If you long-click (click and hold) on this button, a second menu pops up, like the draw functions in Figure 2, from which you can choose to insert a graphic or a special character.

The next button, Insert Cells, inserts cells. Before clicking it, highlight the location where the cells are to be inserted. A popup menu opens with options about how the surrounding cells should be shifted.

The next, Insert Object, inserts a chart. Any data that is highlighted when the Insert Object button is clicked becomes the data that makes up the chart. If this button is held down, a popup menu opens, with the following options: Insert Formula, Insert Floating Frame, Insert OLE Object, and Insert Applet.

The behavior of the Draw Functions button is shown in the illustration. From the popup menu any of the drawing tools can be selected. If a draw function is chosen, such as square, the popup menu disappears and that function becomes the default. However, if you click the popup menu’s title bar and move the menu, it will not disappear, but rather stay visible.

For some of the buttons, such as Draw Functions and Show Form Functions, after you have selected one of the functions, that will be the default until you select a different function. For others, the Insert Cells button for example, you can change the default function (the one you get by just clicking on the button) by double-clicking on the button and holding the last click. A window opens, where you can select a behavior. This behavior is set only after you actually apply the function to something in the chart.

In the Object bar and the Function bar there are rectangular areas on the left of these bars. They are the Load URL, Font Name, and Font Size menus. (See Figure 3.) If there is something already in the box, it tells what the current setting for the selected area is.
Click the little button with an inverted triangle to the right of the box to open a menu.

From the Load URL menu you can open a new document. From the Font Name and Font Size menus, you can change the font and its size in selected cells.

**Formula bar**

On the left of the Formula bar (see Figure 4) is a small text box, called the Sheet Area box, with a letter and number combination in it, such as D7. This is the column letter and row number, called the cell reference, of the current cell.

To the right of the Sheet Area box are the Function AutoPilot, the Sum button, and the Equals button.

Clicking the Function AutoPilot button opens a dialog box from which you can search through a list of available functions. This can be very useful, because it also shows how the functions are formatted.

The Sum button inserts a formula into the current cell that totals the numbers in the cells above, or to the left if there are no numbers above, the current cell.

The Equals button inserts an equals sign into the selected cell and the Input Line, thereby setting the cell ready to accept a formula.

When you enter new data into a cell that already contains something, the Sum and Equals buttons change to Cancel and Accept buttons.

The contents of the current cell (data, formula, or function) are displayed in the Input Line, the remainder of the Formula bar. You can edit the cell contents of the current cell here, or you can do that in the current cell. To edit inside the Input Line area, left-click the appropriate part of the Input Line area, then type your changes. To edit within the current cell, just double-click the current cell.
**Individual cells**

The main section of the screen displays the individual cells in the form of a grid, with each cell being at the intersection of a particular column and row.

At the top of the columns and at the left-hand end of the rows are a series of gray boxes containing letters and numbers. These are the column and row identifiers. The columns start at A and go on to the right and the rows start at 1 and go on downwards.

These column and row identifiers form the cell references that appear in the *Sheet Area* box on the Formula Bar (see Figure 4).

**Sheet tabs**

At the bottom of the grid of cells are the sheet tabs. These tabs enable access to each individual worksheet, with the visible, or active, sheet having a white tab.

Clicking on another sheet tab displays that sheet and its tab turns white.

![Figure 5. Sheet tabs](image)

**Starting new workbooks**

A new workbook can be opened regardless of which other part of OOo you are using at the time. For example, a new workbook can be opened from Writer or Draw.

**From the File menu**

Click on the **File** menu and then select **New > Spreadsheet**.

**From the toolbar**

Use the **Open Document** button on the Function bar. (This button is always a page of text from the current component with a green arrow in the top right corner.) A long-click (click and hold) on the Open Document button opens a sub menu from which you can choose Spreadsheet (or any other type of OOo document).

**From the keyboard**

If you already have a workbook open, you can press **Control+N** to open a new Calc workbook.
Opening existing workbooks

From the File menu
Click on the File menu and then select Open.

From the toolbar
Click the Open button on the Function bar.

From the keyboard
Use the key combination Control+O.

Each of these options displays the Open dialog box (Figure 6), where you can locate the workbook that you want to open.

![Open File dialog](image)

**Figure 6. Open File dialog**

*Tip:* You can also open a workbook that has been recently worked on using the Recently Opened Files list, located at the bottom of the File menu. This list displays the last four files that were opened in any of the OOo components. A recently used file can also be opened by clicking on the drop-down arrow next to the Load URL menu (Figure 4).
Saving workbooks

Workbooks can be saved in three ways:

**From the File menu**
Click on the File menu and then select Save.

**From the toolbar**
Click on the Save button on the Function bar. This button will be greyed-out and unselectable if the file has been saved and no subsequent changes have been made.

**From the keyboard**
Use the key combination Control+S.

If the workbook has not been saved previously, then each of these actions will open the Save As dialog box. Here you can specify the workbook name and the location in which to save the workbook.

![Save As dialog](Image)

**Figure 7. Save As dialog**

*Tip:* If the workbook has been previously saved, then these options will overwrite the existing copy without opening the Save As dialog box. If you want to save the workbook in a different location or with a different name, then go to the File menu and select Save As.
Navigating within worksheets

Going to a particular cell

**Using the mouse**
Place the mouse pointer over the cell and left-click.

**Using its cell reference**
Click on the little inverted black triangle just to the right of the Sheet Area (Figure 4) box, the existing cell reference will be highlighted. Type the cell reference of the cell you want to go to and press *Enter*. Or just click into the Sheet Area box, backspace over the existing cell reference and type in the cell you want.

**Using the Navigator**
Click on the Navigator button in the Function bar (or press *F5*) to display the Navigator. Type the cell reference into the top two fields, labeled Column and Row, and press *Enter*. In Figure 8 the Navigator would select cell F5.

![Figure 8. Calc Navigator](image)
**Moving from cell to cell**

In the workbook, one cell, or a group of cells, normally has a darker black border. This black border indicates the focus is.

![Figure 9. (Left) One selected cell and (right) a group of selected cells](image)

**Using the Tab and Enter keys**
- Pressing *Enter* or *Shift+Enter* moves the focus down or up, respectively.
- Pressing *Tab* or *Shift+Tab* moves the focus right or left, respectively.

**Using the cursor keys**
Pressing cursor keys on the keyboard moves the focus of in the direction of the arrows.

**Using Home, End, Page Up and Page Down**
- *Home* moves the focus to the start of a row.
- *End* moves the focus to the column furthest to the right that contains data.
- *Page Down* moves the display down one complete screen and *Page Up* moves the display up one complete screen.
- Combinations of *Control* and *Alt* with Home, End, Page Down, Page Up, and the cursor keys move the focus of the current cell in other ways Table 1 on page 10 describes all the keyboard shortcuts for moving about a spreadsheet.

**Tip:** *Holding down Alt+Cursor key will resize a cell.*

**Moving from sheet to sheet**

Clicking one of the Sheet Tabs (see Figure 5) at the bottom of the spreadsheet selects that sheet. Each sheet is independent of the others though they can be linked with references from one sheet to another.
Navigating within worksheets

If you need more sheets, an easy way to create them is to click into the little empty space at the right of the last sheet tab (as in Figure 10). Or you can select Insert > Sheet from the Menu bar, or right-click on one of the sheet tabs and select Insert Sheet.

If you have a lot of sheets, then some of the sheet tabs may be hidden behind the horizontal scroll bar at the bottom of the screen. If this is the case, then the four buttons at the left of the sheet tabs can move the tabs into view. Figure 11 shows how to do this.

Notice that the sheets here are not numbered in order. Sheet numbering is arbitrary – you can name a sheet as you wish.

Finally, you can move between sheets by using Control+PageUp (moves left one sheet) or Control+PageDown (moves right one sheet).

Navigation shortcuts

Table 1 lists the key combinations for navigating within Calc.

Table 1. Moving from cell to cell using the keyboard

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Movement</th>
</tr>
</thead>
<tbody>
<tr>
<td>→</td>
<td>Right one cell</td>
</tr>
<tr>
<td>←</td>
<td>Left one cell</td>
</tr>
<tr>
<td>↑</td>
<td>Up one cell</td>
</tr>
<tr>
<td>↓</td>
<td>Down one cell</td>
</tr>
<tr>
<td>Control+→</td>
<td>To last column containing data in that row or to Column IV</td>
</tr>
<tr>
<td>Control+←</td>
<td>To first column containing data in that row or to Column A</td>
</tr>
<tr>
<td>Control+↑</td>
<td>To first row containing data in that column or to Row 1</td>
</tr>
<tr>
<td>Control+↓</td>
<td>To last row containing data in that column or to Row 32000</td>
</tr>
<tr>
<td>Control+Home</td>
<td>To Cell A1</td>
</tr>
<tr>
<td>Control+End</td>
<td>To lower right hand corner of the square area containing data</td>
</tr>
<tr>
<td>Alt+PageDown</td>
<td>One screen to the right (if possible)</td>
</tr>
<tr>
<td>Alt+PageUp</td>
<td>One screen to the left (if possible)</td>
</tr>
</tbody>
</table>
Navigating within worksheets

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Movement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control+PageDown</td>
<td>One sheet to the right (in Sheet Tabs)</td>
</tr>
<tr>
<td>Control+PageUp</td>
<td>One sheet to the left (in Sheet Tabs)</td>
</tr>
<tr>
<td>Tab</td>
<td>To the cell on the right</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>To the cell on the left</td>
</tr>
<tr>
<td>Enter</td>
<td>Down one cells</td>
</tr>
<tr>
<td>Shift+Enter</td>
<td>Up one cell</td>
</tr>
</tbody>
</table>

### Selecting items in a worksheet

**To select a cell**

Left-click in the cell.

**To select a range of cells by dragging the mouse**

Click in a cell, press and hold down the left mouse button and then move the mouse around the screen. Once the desired block of cells is highlighted, release the left mouse button.

**To select a range of cells without dragging the mouse**

Using the mouse:

1) Click in the cell which is to be one corner of the range of cells.

2) Move the mouse pointer down to the cell which is to be the opposite corner of the range of cells.

3) Hold down the *Shift* key and click. The range of cells will be highlighted as above.

Using the keyboard:

1) Select the cell that will be one of the corners in the range of cells.

2) While holding down the *Shift* key, use the cursor arrows to select the rest of the range.
selecting items in a worksheet

**To select cells which are not contiguous**

1) Select the first range of more than one cell using one of the methods above.

2) Move the mouse pointer to the start of the next range or single cell (single cells work as subsequent items), hold down the Control key and click or click-and-drag to select a range. Repeat as necessary.

**Tip:** The first range must include at least two cells, otherwise this technique will not work.

**To select an entire column, row or sheet**

Click the column identifier letter to select the entire column, the row identifier number to select the entire row, or the small square located above the row identifiers and to the left of the column identifiers to select the entire sheet.

To select the entire sheet, you can also use the key combination Control+A.

**To select more than one worksheet**

**Contiguous Sheets**

Click on the sheet tab for the first sheet, move the mouse pointer over the last sheet tab, hold down the Shift key and click. All the tabs between these two sheets will turn white.

Any actions that you perform will now affect all highlighted sheets.

**Not Contiguous Sheets**

Click on the sheet tab for the first sheet, move the mouse pointer over the second sheet tab, hold down the Ctrl key and click. Repeat as necessary. The selected tabs will turn white.

Any actions that you perform will now affect all highlighted sheets.

**All Worksheets**

Right-click over any one of the sheet tabs and select Select All Sheets from the popup menu.
Inserting and deleting columns and rows

To insert a single column or row

Left-click on the column or row identifier to select the entire column or row and then:

• Go to the Insert menu and select Columns or Rows, or

• Hold down the left mouse button on the Insert Cells icon in the main bar and select Insert Columns or Insert Rows from within the extra toolbar that appears, or

• Right-click on the column or row identifier and select Insert Column or Insert Row from the popup menu.

Tip: When you insert a new column it is inserted to the left of the highlighted column and when you insert a new row it is inserted above the highlighted row.

To delete a column or row

Right-click on the column or row identifier and select Delete Column or Delete Row from the popup menu.

To insert multiple columns or rows

Highlight the required number of columns or rows by holding down the left mouse button on the first one and then dragging across the required number of identifiers. Proceed as for inserting a single column or row above.

To delete multiple columns or rows

Highlight the required number of columns or rows by holding down the left mouse button on the first one and then dragging across the required number of identifiers. Proceed as for deleting a single column or row above.
Inserting and deleting worksheets

To insert new worksheets

Left-click on the tab of the existing sheet that you want to place the new sheet next to, and then either:

- Click on the Insert menu and select Sheet, or
- Right-click on its tab and select Insert Sheet, or
- Click into an empty space at the end of the line of sheet tabs.

Each method will open the Insert Sheet dialog box. Here you can select whether the new sheet is to go before or after the selected sheet and how many sheets you want to insert.

To delete worksheets

1) Right-click on the tab of the sheet you want to delete and select Delete from the popup menu.

2) To delete multiple sheets select them as described earlier, right-click over one of the tabs and select Delete from the popup menu.

Renaming worksheets

The default name for the sheets is “SheetX”, where X is a number. While this works for a small workbook with only a few worksheets, it becomes awkward when there are many sheets. To give a sheet a more meaningful name, enter the name in the name box when you create the sheet or right-click on a sheet tab and select Rename Sheet from the popup menu and replace the existing name with a better one.

Tip: Sheet names must start with either a letter or a number; other characters including spaces are not allowed, although spaces can be used between words. Attempting to rename a sheet with an invalid name will produce an error message.
Worksheet views

Using the zoom function

The zoom function allows you to change the view in order to see more, or fewer, cells on the window.

The zoom function can be activated by either:

- Going to the View menu and selecting Zoom, or
- Double-clicking on the percentage figure in the status bar at the bottom of the window.

Both methods will open the Zoom dialog box. This dialog box has the following options listed on the left-hand side.

- **Entire Page** – this option changes the view so that an entire page fits within the height and width of the window. The page is defined by the page format that has been applied to the sheet. This can be modified through the Format menu, Page item, Page tab or through the Page Styles in the Style Catalog under the Format menu. In general, OOo will show at least one page within the window.

- **Page Width** – this option changes the view so that the width of the page fits within the width of the screen. The page is defined as above. Where Entire Page can make cells appear quite small, Page Width will show the width of the page while possibly sacrificing the view of the entire height of the page.

- **Optimal** – this option zooms the selected range to fit the screen and is normally greyed out to show that it is not available. To use this option, you must first highlight a range of cells. Now when you select the zoom function this option becomes available.

- **Percentages** – these options zoom the screen to a particular size, 100% being full size.

- **Variable** – this option allows you to set a zoom percentage of your choice. Either use the up and down arrows to the right of the entry field or click three times in the field to select the current amount and overtype with your desired zoom level, or click in the field and delete the amount there and replace it with your desired amount.

Freeze rows and columns

Freezing allows you to lock a number of rows at the top of a spreadsheet or a number of columns on the left of a spreadsheet or both. Then when scrolling around within the sheet any frozen columns and rows remain in view.

Figure 12 shows some frozen rows and columns. Note the heavier horizontal lines between rows 3 and 12 and the heavier vertical line between columns C and H. Rows 4 through 11 and columns D through I have been scrolled off the page. Because the first three rows and columns are frozen into place, they remained.
Freezing
Freezing is activated as follows:

1) Click into the cell that is immediately below the rows you want locked and immediately to the right of the columns you want locked.

2) Go to the Window menu and select Freeze.

3) You will see two lines appear on the screen, a horizontal line above this cell and a vertical line to the left of this cell. Now as you scroll around the screen everything above and to the left of these lines will remain in view.

Unfreezing
To unfreeze rows or columns, go to the Window menu. Note the checkmark by ‘Freeze.’ Click on Freeze again, deselecting it.

Splitting the window
Another way to change the view is by splitting the window – otherwise known as splitting the ‘screen.’ The screen can be split either horizontally or vertically or both. This allows you to have up to four portions of the spreadsheet in view at any one time.
Why would you want to do this? Imagine you have a large spreadsheet and one of the cells has a number in which is used by three formulas in other cells. Using the split screen technique, you can position the cell with the number in in one section and each of the cells with formulas in in the other sections. Then you can change the number in the cell and watch how it affects each of the formulas.

Figure 13. Split screen example

**Splitting the screen horizontally**

To split the screen horizontally:

1) Move the mouse pointer into the vertical scroll bar, on the right-hand side of the screen, and place it over the small button at the top with the black triangle.

2) Immediately above this button you will see a thick black line. Move the mouse pointer over this line and it will turn into a line with two arrows.

3) Hold down the left mouse button and a grey line will appear, running across the page. Drag the mouse downwards and this line will follow.

4) Release the mouse button and the screen will split into two views, each with its own vertical scroll bar.

Notice in Figure 13, the ‘Beta’ and the ‘A0’ values are in the upper part of the screen (window, actually) and other calculations are in the lower part. You may scroll the upper and lower parts independently. Thus you can make changes to calculations resulting in the
'Beta’ and ‘A0’ values and watch their affects on the calculations in the lower half of the window.

You can also split the window vertically as described below – with the same results, being able to scroll both parts of the window independently. With both horizontal and vertical splits, you have four independent windows to scroll.

**Splitting the screen vertically**

To split the screen vertically:

1) Move the mouse pointer into the horizontal scroll bar at the bottom of the screen and place it over the small button on the right with the black triangle.

2) Immediately to the right of this button you will see a thick black line. Move the mouse pointer over this line and it will turn into a line with two arrows.

3) Hold down the left mouse button and a grey line will appear, running up the page. Drag the mouse to the left and this line will follow.

4) Release the mouse button and the screen will be split into two views each with its own horizontal scroll bar.

Splitting the screen horizontally and vertically at the same time will give four views, each with its own vertical and horizontal scroll bars.

**Removing Split Views**

- Double click on each split line, or
- Click on and drag the split lines back to their places at the ends of the scroll bars, or
- Go to the **Window** menu and de-select **Split**. This will remove all split lines at the same time.

---

**Entering data into a worksheet**

---

**Standard entry techniques**

**Entering numbers**
Select the cell and type in the number using either the top row of the keyboard or the numeric keypad.

To enter a negative number, either type a minus (–) sign in front of it or enclose it in brackets (

). By default numbers are right-aligned and negative numbers have a leading minus symbol.

**Entering text**
Select the cell and type the text. Text is left-aligned by default.
Entering numbers as text
If a number is entered in the format 01481, Calc will drop the leading 0. To preserve this, in the case of telephone area codes for example, precede the number with an apostrophe – like so: ’01481. However, the data is now regarded as text by Calc. Arithmetic operations will not work on it. It will either be ignored or will produce an error of some kind.

Entering dates and times
Select the cell and type the date or time. You can separate the date elements with a slant (/) or – or type with text such as 10 Oct 03. Calc recognizes a variety of date formats. You can separate time elements with colons such as 10:43:45.

More entry techniques
In addition to the standard methods of entering data into cells, as mentioned above, Calc also has a number of additional entry techniques which include the following:

Entering data into a column or row
Entering data into a row or column, or part of a row or column, is called ‘filling.’

You can fill either with the same data or with data which changes in each cell.

To fill with the same data
1) In the first cell enter the data you want to fill the other cells. It can be text, a number or a formula.

2) Click in this cell, hold down the left mouse button and drag to select all the cells that you want this data to fill into.

3) Go to the Edit menu, select the Fill option and then choose the direction in which to fill.

You can also use the mouse:
1) Enter the data in the first cell that you want to fill into each of the other cells.

2) Click in this cell to select it. You will see a border appear around the cell and this border will have a small black square in the lower right corner.

3) Move the mouse pointer over this square and it will turn into a black cross.

4) When it does so, hold down Ctrl key, press the left mouse button and drag down the column, or across the row.

Tip: If you do not hold down the Ctrl key when dragging, then you will not fill the selected area with the same data. Instead you will create a series where the data alters by a predefined amount.

Another Tip: You’ll note that Fill works either on columns or rows but not both at the same time. However, when you want to fill an area, you can fill multiple columns or rows by first filling one column or row, then selecting an area with that column or row at one edge, and then filling the area as if you were filling a single row or column.
Entering data into a range of cells

1) Select a range of cells by clicking in one cell and then dragging downwards and across until a few columns and rows are selected. The cell under the mouse pointer, the Active Cell, will be highlighted a little differently than the others.

2) Press Enter to move the active cell up to the top left cell of the highlighted block.

3) Type in your first data item, which will appear in the Active Cell, and when complete press Enter. The Active Cell will move down to the cell below. Continue entering data and pressing Enter. The highlighted cell will move down one cell at a time.

When you reach the bottom of a column, the Active Cell will move to the top of the next column. When you reach the bottom right corner cell, the Active Cell will move back to the top left cell.

Entering the same data into a block of cells

1) Select the range of cells as in the procedure above.

2) In the Active Cell, enter the data that you want to appear in all the cells.

3) Press the key combination Control+Shift+Enter. This will copy the data into all the highlighted cells.

Autocomplete

Calc tries to guess the rest of a text entry you are typing. When you are typing several identical text entries, Autocomplete can speed up data entry quite a bit.

Here is how it works: Calc is aware of your previous text entries in a particular spreadsheet. When you enter some text in a column that starts in the same way as previous text in the same column, Calc will suggest the completion of the entry with the text previously entered – but with highlighted characters. To accept the suggested new characters, just press Enter or an arrow key. Otherwise, just keep typing or press Backspace if you have reached the end of your entry. If you keep typing, your characters will replace Calc’s suggested characters. If you press Backspace, the suggested highlighted characters will disappear.

Each column has a new context. If you enter something in one column that is similar to something in another, it will not try to complete the text entry according to what you have done in the other column. This, of course, applies as well to entries in other spreadsheets in the same workbook.

1) Enter “Now is the winter of our discontent” (but without the quote marks) in a cell.

2) Click into any empty cell within the same column and type “n” (again, without the quote marks). Autocomplete will insert the rest of the phrase for you.
3) If this is correct, press Enter or an arrow key to accept it.

4) If it is not correct, then continue typing the text you want to enter.

5) As you enter similar, but not identical, text, Calc will wait until you type something that is unique. For example, if you type, “Now is the time” in a new cell in the same column, Calc will continue to suggest “Now is the winter of our discontent” until you type the “t” in “time.” This is the first unique character.

Using the selection list
You can use the context that Calc has created from your textual entries in a column by selecting one of your entries from a list that Calc will offer you. Examples of the method are shown in Figures 14 and 15 below.

1) Create some text in some cells in a column. You will want several different entries.

2) Click in an empty cell in the column in which you have entered the text. Then right-click to activate a popup context menu.

3) Move the mouse pointer down the menu and left-click on Selection List.

4) A list will drop down below the active cell showing all the unique entries used in the column so far.

5) Click on the entry you want and it will be entered into the active cell.

6) Alternatively, after you click in an empty cell in the column, press Control+D and the selection list will pop up. You can now select a text entry from this list if you wish.