
OpenOffice.org User Guide
for Version 2.x

[OpenOffice.org User Guide for 2.x]
[0.2]
First edition: [20050411]
First English edition: [20050411]





Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License, Version 
1.0 (the "License"); you may only use this Documentation if you comply with the terms of 
this License. A copy of the License is available at: 
http://www.openoffice.org/licenses/PDL.rtf.

The Original Documentation is “OpenOffice.org User Guide for Version 2.x”. 

Contributor(s): G. Roderick Singleton. 

Portions created by G. Roderick Singleton are Copyright © 2005, 2006. All Rights Reserved. 

All trademarks within this guide belong to legitimate owners.
[Note: a copy of the PDL is included in this template and is also available at: 
http://www.openoffice.org/licenses/PDL.rtf.]

Feedback
Please direct any comments or suggestions about this document to: 
grsingleton@openoffice.org

Acknowledgements
I wish to recognize the Technical Writers of Sun Microsystems for the fine model they have 
provided for organizing this document. I also wish to thank Erwin Tenhumberg for his blog, 
Mary Ellen Dawley for her indexing effort, Ross Johnson for his editing/correctionsand 
manitoban for the docking text in chapter 2.

http://www.openoffice.org/licenses/PDL.rtf
mailto:manitoban@openoffice.org
mailto:manitoban@openoffice.org
mailto:manitoban@openoffice.org
mailto:grsingleton@openoffice.org?subject=Comment/suggestions for the User Guide
mailto:grsingleton@openoffice.org?subject=Comment/suggestions for the User Guide
mailto:grsingleton@openoffice.org?subject=Comment/suggestions for the User Guide
http://www.openoffice.org/licenses/PDL.rtf.
http://www.openoffice.org/licenses/PDL.rtf.
http://www.openoffice.org/licenses/PDL.rtf.
http://www.openoffice.org/licenses/PDL.rtf
http://www.openoffice.org/licenses/PDL.rtf




Modifications and updates

Version Date Description of Change
[0.9] [20051111] [grs: 9th draft issued for comment – switched to master doc, 

stewart's amendments and added a chapter on XML usage 
(flat file)]

[0.10] [20051111] [grs: 10th draft issued for comment – fix page numbering
[0.11] [20060131] [grs:11th draft issued for comment – updated index
[0.12a] [20060220] [rj: 12th draft issued for comment – corrections for 2.0 to 

replace 1.1.x references
[0.13] [20060221] [grs 13th draft issued for comment – integrated Ross Johnson's 

changes and edited for consistent grammar.
[0.14] [20060302] [grs:14th draft issued for comment – document layout to be 

more bookish
[0.15] [20060410] [grs:15th draft issued for comment – Added POSTNET section
[0.16] [20060619] [grs:16th draft issued for comment – Added file recovery info 

to Troubleshooting chapter
[0.17] [20060627] [grs:17th draft issued for comment – Corrected Overview
[0.18a] [20060719] [grs:18ath draft issued for comment – updated concordance 

file section and added JMF section to Chapter 14 and wps 
howto.

[0.19] [20060731] [grs:19th draft issued for comment – Added new export PDF 
feature

[0.20] [20060816] [grs:20th draft issued for comment – Fixed many legacy terms 
and added language/writing aids and comment on style 
painter

[0.21] [20061018] [grs:21st draft issued for comment – Integrated ztyx and 
walteram updates to chapters 3, 4 and 10

[0.22] 20070306 [grs:22nd draft issued for comment — added more info on 
keyboard shortcuts to Chapter 5 – Impress  and minor 
changes.

[0.23] [20070409] [grs:23rd draft issued for comment — Fixed pagnination errors





Contents
Overview................................................................................................... ........................1

Using the Guide...........................................................................................................................1

Important Features with 2.x.......................................................................... ..................3
Open Standards XML File Format (OASIS OpenDocument)....................................................3
New Multipane View.................................................................................................................3
New CustomShapes (compatible with Microsoft    AutoShapes)   ..................................................3
More Slide Transitions and Animation Effects...........................................................................3
Enhanced PDF Export.................................................................................................................3
New enhanced Database Features...............................................................................................5
Mail Merge Wizard.....................................................................................................................5
Enhanced    Word Count    Feature   ...................................................................................................5
Support for Nested Tables...........................................................................................................5
Digital Signatures    Support   ..........................................................................................................5
XForms Support..........................................................................................................................5
WordPerfect® Filters..................................................................................................................6
Calc now has 65,536 Rows.........................................................................................................6
Enhanced DataPilot Support.......................................................................................................6
Native Installers..........................................................................................................................6
Native Desktop Integration.........................................................................................................6
Floating Toolbars........................................................................................................................6
Style Paint Brush.........................................................................................................................6
Quickstarter for *NIX Operating Systems..................................................................................7
Multiple    Language Support   .........................................................................................................7
New Charting Module.................................................................................................................7

Chapter 1: Using OpenOffice.org Help.......................................... ................................9
OpenOffice.org StepbyStep Help.............................................................................................9
Tips............................................................................................................................................10

Turning tips on and off.........................................................................................................10
Extended Tips.......................................................................................................................10

Turning extended tips on and off.....................................................................................10

OpenOffice.org User Guide for 2.x i



Help Agent................................................................................................................................10
Turning the Help Agent on and off......................................................................................11

Chapter 2: Working With OpenOffice.org............................................................... ....13
The User Interface................................................................................................................13
Starting OpenOffice.org.......................................................................................................13
The OpenOffice.org Writer Window...................................................................................14
Toolbars in the OpenOffice.org Window.............................................................................14

The Title Bar....................................................................................................................14
The Menu Bar..................................................................................................................15
The Toolbars....................................................................................................................15
Examples of Floating Toolbars........................................................................................16
Using Floating Toolbars..................................................................................................17
The document window....................................................................................................17
Docking toolbars..............................................................................................................17
Docking windows............................................................................................................18
Changing the Visibility of Buttons on Toolbars..............................................................18

Opening and    Saving Documents   ...............................................................................................19
Opening Documents.............................................................................................................19

Saving Documents....................................................................................................................22
Changing the Work Directory..............................................................................................23
Saving Documents Automatically........................................................................................23

Backup a File Automatically...........................................................................................23
Saving Recovery Information Automatically Every 'n' Minutes.....................................23

OpenOffice.org File Formats....................................................................................................24
XML file format names........................................................................................................24
OpenOffice.org XML file structure......................................................................................25
Definition of the XML formats............................................................................................26
Setting Tabstops...................................................................................................................26

Sending    Documents as EMail   ..................................................................................................27
Single Messages...................................................................................................................27
MailMerge............................................................................................................................27

Printing Documents...................................................................................................................28

OpenOffice.org User Guide for 2.x ii



Displaying Print Previews....................................................................................................29
Reduced Printing of Documents...........................................................................................30

To print two pages beside one another on one sheet of paper.........................................30
Printing in    Black and White   .................................................................................................30

Printing text and graphics in    black and white   ..................................................................30
Printing all Draw and Impress documents in    black and white   ........................................30
Printing only text in    black and white   ...............................................................................31

Printing all Writer documents with    black and white text   ............................................31
Printing the current Writer document with    black and white text   ................................31

Printing Brochures................................................................................................................31
Spellcheck.................................................................................................................................32

Automatic    Spellcheck   ...........................................................................................................32
Checking Multilingual Texts................................................................................................33
Starting    Spellcheck   ...............................................................................................................34

Excluding Text From the    Spellcheck   ..............................................................................35
Adding Writing Aids for Other Languages...............................................................................35

Getting New Writing Aids....................................................................................................35
Using Automatic Functions.......................................................................................................40
Using    AutoCorrect and AutoFormat   .........................................................................................40

Turning off    URL Recognition by    AutoCorrect   ....................................................................42
Undo    URL recognition   ....................................................................................................42
Turn off    URL recognition   ................................................................................................42

Other    AutoCorrect functions   ................................................................................................42
Creating a Letter Template With the Wizard............................................................................44
Find & Replace.........................................................................................................................45

Finding a Word in Text........................................................................................................45
Searching for Whole Words Only........................................................................................46

Match Case......................................................................................................................46
Searching for Text With Wildcards.................................................................................46
Searching Backward........................................................................................................47
Current Selection Only....................................................................................................47
Searching for Styles.........................................................................................................47

OpenOffice.org User Guide for 2.x iii



Searching for Text Attributes..........................................................................................47
Searching for Special Formats ........................................................................................48
Similarity Search.............................................................................................................48

List of Regular Expressions..................................................................................................48
Digital Signatures    and Printing or Exporting Documents   .........................................................51

Only “open password”, no restriction..................................................................................53
“open password”, restricted..................................................................................................53
Permission restricted only....................................................................................................53
PDF without restriction (Default behaviour)........................................................................53

Permissions available................................................................................................................53
Printing.................................................................................................................................53
Changes................................................................................................................................53
Enable copy..........................................................................................................................54
Enable accessibility..............................................................................................................54
Programming PDF Security in Macros ...............................................................................54

Chapter 3: Managing Text Documents With Writer ....................................... ...........57
The OpenOffice.org Writer Functions......................................................................................57

Writing..................................................................................................................................57
Designing and Structuring....................................................................................................57
Desktop Publishing with OpenOffice.org Writer.................................................................58
Calculations..........................................................................................................................58
Creating Drawings................................................................................................................58
Inserting Graphics................................................................................................................58
Customizable Program Interface..........................................................................................58
Drag&Drop...........................................................................................................................58
Extensive Help Functions.....................................................................................................58

The OpenOffice.org Writer Window........................................................................................59
Windows® of OpenOffice.org Writer..................................................................................59

Entering and    Formatting Text   ...................................................................................................60
Entering New Text...............................................................................................................60

To enter new text:............................................................................................................60
Line breaks.......................................................................................................................60

OpenOffice.org User Guide for 2.x iv



Automatic correction.......................................................................................................60
Word completion.............................................................................................................60

Inserting Text........................................................................................................................60
Switching Between Insert Mode and Overwrite Mode........................................................61

Using the keyboard:.........................................................................................................61
Using the mouse:.............................................................................................................61

Entering Text Anywhere on a Page......................................................................................61
Selecting and    Deleting Text   .................................................................................................62

Deleting characters..........................................................................................................62
Deleting text.....................................................................................................................62

Selecting text to delete with the mouse.......................................................................62
Selecting text to delete with the keyboard..................................................................62
Deleting nonadjacent pieces of text...........................................................................62

Status bar uses..................................................................................................................63
Setting the Viewing Zoom Factor...............................................................................63
Editing or    Activating Hyperlinks   ................................................................................63

Applying Various Fonts ......................................................................................................63
Keyboard Navigating and Selection in Writer.....................................................................64
Inserting    Special Characters   .................................................................................................64
Inserting Protected Spaces, Hyphens and    Conditional Separators   .......................................65

Nonbreaking spaces........................................................................................................65
Nonbreaking hyphen......................................................................................................65
Hyphen, emdash and    endash   .........................................................................................65
Manual Hyphenation.......................................................................................................65

Emphasizing Text.................................................................................................................66
Changing the    colour of Text   .................................................................................................66
Rotating Text........................................................................................................................66
Defining Borders..................................................................................................................67

Choose Format from the menu bar, Borders tab page.....................................................67
Use the Borders floating    toolbar with Tables   ..................................................................69

Superscripts and Subscripts..................................................................................................71
Applying subscripts/superscripts retrospectively............................................................72

OpenOffice.org User Guide for 2.x v



Writing in    Uppercase or Lowercase   .....................................................................................72
Moving Text Sections in Documents...................................................................................72
Resetting Font Attributes While Typing..............................................................................73

Example procedure for    resetting Font Attributes   ............................................................73
Quick Formatting Using the Adjacent Paragraph Format....................................................73
Using Sections......................................................................................................................73
Sections and Columns..........................................................................................................75
Inserting Sections.................................................................................................................75
Editing Sections....................................................................................................................75

Formatting Text With and Without Styles................................................................................76
Direct Formatting or Formatting With Styles......................................................................76

The Style Concept in OpenOffice.org.......................................................................................77
The Styles in the Styles and Formatting Window................................................................77
Paragraph Styles...................................................................................................................77
Paragraph Style.....................................................................................................................78
Character Styles....................................................................................................................80
Hierarchical Styles................................................................................................................80
Numbering Styles ................................................................................................................81
Creating New Character Styles or Paragraph Styles............................................................81
Creating    Document Templates   .............................................................................................82
The Advantages of the Styles and Formatting Window.......................................................83
Formatting Multiple Paragraphs...........................................................................................83
Changing a Style the Easy Way...........................................................................................83
Page Styles and Page Numbers............................................................................................84

Create Page Styles...........................................................................................................84
Editing Page Styles..........................................................................................................88
Page Breaks as Paragraph Formats..................................................................................88
Changing the Format of Page Numbers...........................................................................89
Page Styles Summary......................................................................................................91

Defining default Templates.......................................................................................................92
Templates and Styles.................................................................................................................93

Copying Styles Between Templates and Documents...........................................................93

OpenOffice.org User Guide for 2.x vi



New Style from Selection.....................................................................................................94
Transferring Formats With    Fill Format Mode   ......................................................................94
Updating Styles From Selections.........................................................................................94

This is how to update a Style:..........................................................................................94
Style can also be updated by using drag and drop:..........................................................95

Entering and    Formatting Text Automatically   .......................................................................95
Disabling the    AutoCorrect Function   ................................................................................95
ASCII Quotation marks are replaced with    Custom Quotes   .............................................95
Sentences    always begin with a capital letter   ....................................................................95
Three identical characters will become a whole line.......................................................96

Automatic    Spellcheck   ...............................................................................................................96
To exclude words from    Spellcheck   ......................................................................................96

Using    AutoText   .........................................................................................................................97
Defining    AutoText   ................................................................................................................98
Using    AutoText    in Networks   ................................................................................................99
Printing AutoTexts...............................................................................................................99

AutoText    With    AutoComplete   ................................................................................................100
Exceptions in    AutoCorrect   .................................................................................................100

Example.........................................................................................................................100
Text Frames.............................................................................................................................101

Inserting, Editing and Linking Text Frames.......................................................................101
Inserting Text Frames....................................................................................................101
Editing Text Frames......................................................................................................102
Linking Text Frames......................................................................................................102

Using    Text Animation   .............................................................................................................104
Drawing Lines    in Text   ............................................................................................................107
Editing Text With    FontWork   ..................................................................................................108
Aligning Text With Lines.......................................................................................................110

Aligning text on a free form line........................................................................................110
Aligning text with straight lines..............................................................................................110
The Navigator..........................................................................................................................111

Jumping From One Object to Another in Text...................................................................111

OpenOffice.org User Guide for 2.x vii



Jumping to a Specific Page.................................................................................................112
Chapters in Navigator.........................................................................................................113

Indexes and Tables of Contents in Writer...............................................................................114
Defining Index/Table of Contents Entries..........................................................................114
Editing or Deleting Index and Table Entries......................................................................115
Creating a Table of Contents..............................................................................................116
Creating Alphabetical Indexes...........................................................................................117
Creating UserDefined Indexes..........................................................................................117
Using a    Concordance File   ..................................................................................................119

Preparation.....................................................................................................................119
Entering Data.................................................................................................................119
Example file...................................................................................................................120

Creating Bibliographies......................................................................................................122
Updating, Editing and    Deleting Indexes and Tables of Contents   ......................................123
Editing the Format of an Index/Table of Contents.............................................................123
Indexes Covering Multiple Documents..............................................................................124

Headings and Numbering........................................................................................................125
Numbering and Numbering Styles.....................................................................................125
Turning Bullets On and Off................................................................................................125
Turning Numbering On and Off.........................................................................................126

Example numbered list with sublevels:.........................................................................127
Outline Numbering.............................................................................................................127
Automatic Bullets and Numbering.....................................................................................128
Numbering Illustrations by Chapters..................................................................................129
Defining Number Ranges...................................................................................................129

Using Master Documents and Subdocuments.........................................................................131
Importing Lists From Other Text Programs............................................................................136

Changing Numbering via the Keyboard.............................................................................136
Interrupting and Continuing Numbering.................................................................................137

Delete the    automatic numbering   .........................................................................................137
Formatting the paragraph...................................................................................................137
Continuing numbering with a new starting value...............................................................137

OpenOffice.org User Guide for 2.x viii



Numbering Lines.....................................................................................................................138
Line Numbering for All Paragraphs...................................................................................138
Line Numbering for Particular Paragraphs.........................................................................138

Tables in Text..........................................................................................................................139
Inserting Tables..................................................................................................................139

Inserting an empty table using the mouse:....................................................................139
Inserting an empty table via the Insert menu or floating toolbar:..................................139
Inserting a single row table by typing ++... or ||............................................................139
Inserting from OpenOffice.org Calc with the clipboard................................................139
Inserting from OpenOffice.org Calc using draganddrop............................................140

Deleting Tables...................................................................................................................140
Inserting Paragraphs Before Tables at Start of Page..........................................................141

Resize columns, rows, and cells....................................................................................141
Table AutoFormat..........................................................................................................141
Table properties in general............................................................................................141

Calculating in Text Documents...............................................................................................143
Formulae in Text Documents.............................................................................................143

Formula Options............................................................................................................143
Basic Calculation Functions......................................................................................143
Basic Functions in the Submenu...............................................................................143
Operators...................................................................................................................143
Statistical Functions..................................................................................................144
Trigonometric Functions ..........................................................................................144
More Defined Values................................................................................................145

Calculating in Text.............................................................................................................145
Calculating With    formulae Located in Text   .......................................................................146
Conditional Text.................................................................................................................147

Defining and using    conditional text – by example   ........................................................147
Defining a    conditional variable   .................................................................................147

Type “Reminder” in the document, and then add space................................................147
Defining a condition and the    conditional text:   ..........................................................148

Displaying the    conditional text:   .....................................................................................149

OpenOffice.org User Guide for 2.x ix



Calculating in Text Document Tables................................................................................150
Calculating Across Multiple Tables...................................................................................151
Calculating    Cell Totals in Tables   .......................................................................................152
Merging and    Splitting Cells   ................................................................................................152

Merging Cells in OpenOffice.org Writer.......................................................................152
Splitting Cells in OpenOffice.org Writer.......................................................................152
Merging Cells in OpenOffice.org Calc OLE Objects....................................................152
Cancelling the merging of cells in OpenOffice.org Calc OLE Objects........................152

Inserting or    Deleting Rows/Columns Using the Keyboard   ................................................153
Repeating Multiple Heading Rows in a Table...................................................................153
Enlarging and Reducing Cells in Text Tables....................................................................153
Adapting Table Widths.......................................................................................................154

Images, Drawings, Clipart and    FontWork   ..............................................................................156
Positioning Objects.............................................................................................................156
Captions    and Number Ranges   ............................................................................................157

Defining    Captions   ..........................................................................................................157
Editing or    deleting    captions   ...........................................................................................157
Inserting an object in a number range............................................................................157

Numbering Illustrations by Chapters..................................................................................158
Inserting Graphics..............................................................................................................158

Inserting Graphics via dialogue.....................................................................................158
Inserting Graphics From OpenOffice.org Draw or Impress..........................................159
Inserting Graphics via Drag and Drop    From the Gallery   ..............................................159
Adding Graphics To the Gallery via Drag and Drop.....................................................160
Inserting Graphics With a Scanner................................................................................160

Inserting a Chart From OpenOffice.org Calc.....................................................................160
Dragging and Dropping the Chart with Move or Copy.................................................160
Charts with Linked Data................................................................................................161

Inserting Decorative Horizontal Lines...............................................................................161
Headers, Footers and Footnotes..............................................................................................162

Some Notes Concerning    Headers and Footers   ...................................................................162
Inserting Page Numbers in Footers....................................................................................162

OpenOffice.org User Guide for 2.x x



Formatting    Headers and Footers   ........................................................................................165
Defining Different    Headers   ................................................................................................165
Inserting Page Numbers of Continuation Pages.................................................................165
Inserting Lines Under    Headers   ...........................................................................................166
Footnotes and Endnotes......................................................................................................167
Inserting and Editing Footnotes..........................................................................................168

Inserting a footnote via an icon.....................................................................................168
Inserting a footnote via a dialogue.................................................................................168
Tips for Working with Footnotes..................................................................................169

Spacing Between Footnotes...............................................................................................169
Spellcheck   , Dictionaries, Hyphenation   ...................................................................................170

Controlling    Spellcheck    via the dialogue   .............................................................................170
Automatic    Spellcheck   .........................................................................................................171

To    exclude words from the    Spellcheck   :  ........................................................................172
Removing Words From    UserDefined Dictionaries   ...........................................................172
Hyphenation.......................................................................................................................172

Automatic hyphenation..................................................................................................172
Manual Hyphenation.....................................................................................................173

Thesaurus............................................................................................................................174
Form Letters, Business Cards and Labels...............................................................................176

Creating Form Letters.........................................................................................................176
Brief Instructions (For Quick Results)..........................................................................176
Fixed and Variable Fields..............................................................................................176

Creating and    Printing Labels    and Business Cards   ..............................................................178
Designing Business Cards via dialogue.........................................................................178
Designing Labels    and Business Cards   ...........................................................................179
Printing Labels    With Serial Numbers   ............................................................................179
Printing    Address Labels   .................................................................................................180

Avoiding Blank Paragraphs................................................................................................181
Newsletters..............................................................................................................................183

Creating a Newsletter From a Template.............................................................................184
Creating Page Styles......................................................................................................184

OpenOffice.org User Guide for 2.x xi



Editing    Headers   .............................................................................................................184
Editing Columns............................................................................................................184
Editing Paragraph Styles................................................................................................185
Working with Frames....................................................................................................186
Formatting a Frame .......................................................................................................186
Anchoring Frames.........................................................................................................186
Defining a Frame Wrap ................................................................................................186

Defining a Wrap Region ....................................................................................................187
Using coloured or    Graphic Backgrounds    ..........................................................................188
Creating a Table of Contents .............................................................................................188
Further Information............................................................................................................191

Using    Automatic Hyphenation   ......................................................................................191
Letters With Envelopes...........................................................................................................192

Using a ReadyMade Letter Template...............................................................................192
Creating a Letter Template Using the Wizard....................................................................192
Creating an Envelope Template.........................................................................................193

Inserting an Envelope into a Document.........................................................................194
Adjusting the Printer for the Printout ...........................................................................195

Creating and Printing a Letter With an Envelope..............................................................195
Creating an Single Envelope..............................................................................................195
Adding a POSTNET Bar Code to an Envelope..................................................................196

Get a POSTNET font.....................................................................................................196
Building a Complete POSTNET Bar Code for Printing................................................196

Adding More Languages to OpenOffice.org..........................................................................197
Setting Text    Language   ........................................................................................................197
Adding More Text Languages............................................................................................198
Setting UI    Language   ...........................................................................................................200

Adding Multiple    Language Support using    Language Packs   ...................................................200

Chapter 4: Spreadsheets in Calc..................................................... ............................203
Overview of the Functions in Calc..........................................................................................203

Calculating..........................................................................................................................203
Database Functions.............................................................................................................203

OpenOffice.org User Guide for 2.x xii



Arranging Data...................................................................................................................203
Examining and    Extrapolating    Data   ....................................................................................203
WhatIf Calculations..........................................................................................................203
Dynamic Charts..................................................................................................................204
Importing and Exporting Data............................................................................................204

Importing into Calc........................................................................................................204
Exporting from Calc......................................................................................................205

Referencing Data in Networks and the Internet.................................................................205
The Calc Window ..................................................................................................................206

Structure of a Spreadsheet..................................................................................................206
Rows and Columns.............................................................................................................207
Multiple Sheets in a Document..........................................................................................208

Inserting Sheets..............................................................................................................208
Renaming Sheets...........................................................................................................208

Values and Formulae as Cell Contents...................................................................................210
Calculating in Spreadsheets................................................................................................210
Using Builtin Functions....................................................................................................212
A Short Description of What Cells Can Contain................................................................213
Text.....................................................................................................................................213
Numbers.............................................................................................................................215

Calculating With formulae......................................................................................................218
Calculating With Dates and Times.........................................................................................219

Inserting and Editing Notes................................................................................................220
Handling Multiple Sheets........................................................................................................221

Displaying Multiple Sheets................................................................................................221
Working With Multiple Sheets...........................................................................................221
Printing Spreadsheets.........................................................................................................222

Formatting a Spreadsheet........................................................................................................223
Formating Numbers............................................................................................................223

Dates..............................................................................................................................223
Formatting Cells and Sheets...............................................................................................224
Using    AutoFormat for Tables   .............................................................................................224

OpenOffice.org User Guide for 2.x xiii



Layout of Spreadsheets...........................................................................................................225
Designing Spreadsheets Clearly.........................................................................................225
Formatting Text in a Spreadsheet.......................................................................................226
Formatting Numbers in a Spreadsheet...............................................................................226
Formatting Borders and    Backgrounds for Cells and Pages   ................................................226

Addressing Cells.....................................................................................................................227
Addresses and References, Absolute and Relative.............................................................227

Relative Addressing.......................................................................................................227
Absolute Addressing .....................................................................................................227
When to Use Relative and Absolute References...........................................................227

Addressing by Name..........................................................................................................229
Recognizing Names as Addressing....................................................................................229
Only    Copy Visible Cells   .....................................................................................................230
Referencing a Cell in Another Document..........................................................................231

Using References in formulae.................................................................................................232
References to Other Sheets.................................................................................................233

Using Charts............................................................................................................................235
Editing    Chart Titles   ............................................................................................................238
Editing Chart Legends........................................................................................................238
Adding    Texture to Chart Bars   ............................................................................................239
Editing Chart Axis..............................................................................................................239

Database Functions in Calc.....................................................................................................240
Defining Database Ranges.................................................................................................240
Creating Records in a Spreadsheet.....................................................................................240
Defining Database Ranges.................................................................................................242
Sorting Database Ranges....................................................................................................242
Filtering Database Ranges..................................................................................................243
Grouping Database Ranges and Calculating Subtotals......................................................245
Transferring Data From a    Data Source to a Spreadsheet   ...................................................246

Opening a    Database File in Calc   ...................................................................................246
Evaluating Data With Calc......................................................................................................249

DataPilot.............................................................................................................................249

OpenOffice.org User Guide for 2.x xiv



What use is the DataPilot?..................................................................................................250
Creating DataPilot Tables...................................................................................................250
Selecting DataPilot Output Ranges....................................................................................252
Editing DataPilot Tables.....................................................................................................252
Filtering DataPilot Tables...................................................................................................252
Updating DataPilot Tables.................................................................................................252
Deleting DataPilot Tables...................................................................................................252

Consolidating Data..................................................................................................................253
Applying Goal Seek................................................................................................................255

Naming Cells......................................................................................................................255
Start Goal Seek...................................................................................................................256
Applying Multiple Operations............................................................................................256

Multiple Operations in Columns or Rows.....................................................................256
Examples........................................................................................................................256
Calculating With One Formula and One Variable........................................................257
Calculating with Several formulae Simultaneously......................................................257

Multiple Operations Across Rows and Columns...............................................................257
Calculating with Two Variables....................................................................................258

Using Scenarios.......................................................................................................................259
Using ReadyMade Scenarios............................................................................................259
Creating Personal Scenarios...............................................................................................259

Validity of Cell Contents........................................................................................................261
Using Cell Contents Validity..............................................................................................261
Sample macro:....................................................................................................................263

Printing or Exporting Spreadsheets.........................................................................................264
Printing Sheet Details.........................................................................................................264
Defining Number of Pages for Printing..............................................................................264
Printing Sheets in Landscape Format.................................................................................265
Printing Rows or Columns on Every Page.........................................................................265

Saving and Opening Sheets in HTML....................................................................................267
Saving Sheets in HTML.....................................................................................................267
Opening Sheets in HTML..................................................................................................267

OpenOffice.org User Guide for 2.x xv



formulae and Values as CSV Files..........................................................................................268
Exporting formulae and Values as CSV Files....................................................................268
Importing a CSV File.........................................................................................................268

AutoFill...................................................................................................................................270
Applying Sort Lists.............................................................................................................270
Automatic Row Filling.......................................................................................................270
Protecting Sheets................................................................................................................271
Creating a Reference..........................................................................................................272
Further Information............................................................................................................272
Inserting a note ..................................................................................................................273
Inserting a sheet into another document ............................................................................273
Displaying formulae ..........................................................................................................273
Using print ranges ..............................................................................................................273
Freezing Columns...............................................................................................................273
Splitting a Calc Window....................................................................................................273
Conditional Formatting......................................................................................................273
Defining Validity................................................................................................................275
Creating Input Help............................................................................................................275
Linking Sheet Information.................................................................................................276

Chapter 5: Creating Presentations With Impress.............................................. ........277
OpenOffice.org Impress Toolbars and Windows®.................................................................278
How to Create a Basic Presentation........................................................................................279

Creating a Presentation With the Wizard...........................................................................279
Creating a Simple Presentation Without the Wizard..........................................................284
Switching Presentation Views............................................................................................285
Arranging Slides.................................................................................................................286
Incorporating Slide Show Effects.......................................................................................287

InSlide Effects..............................................................................................................287
Showing a Presentation......................................................................................................287

Editing Presentations...............................................................................................................288
Defining    Background colours   .............................................................................................288
Switching Page Styles........................................................................................................289

OpenOffice.org User Guide for 2.x xvi



Presentation Styles..............................................................................................................289
Using Outline View.................................................................................................................290
Slide Transitions, Effects and Animation...............................................................................291

Automatic Slide Transition.................................................................................................291
Effects for Objects..............................................................................................................291
Selecting Hidden Objects...................................................................................................292
Individual Presentations.....................................................................................................292

Exporting, Printing and Presenting.........................................................................................294
Printing a Presentation Slide..............................................................................................294
Exporting Presentations as Web Pages...............................................................................295
Exchanging Data via the Clipboard....................................................................................296

Creating a Business Report.....................................................................................................297
Creating a Business Report in Presentation Form..............................................................297
Entering Text in the Outline View.....................................................................................298
Changing the Slide Layout.................................................................................................298
Designing Slides.................................................................................................................298

Creating a Slide Show.............................................................................................................300
Defining or Changing Slide Order.....................................................................................300
Creating CrossFade Effects ..............................................................................................300
Starting Presentations ........................................................................................................300

Working with Connectors.......................................................................................................302
"Edge to Edge” Connectors................................................................................................302
"Middle to Middle” Connectors.........................................................................................303
Editing Connectors.............................................................................................................303
Using a Snap Grid .............................................................................................................303
Editing Glue Points ............................................................................................................304

Hints and Tips for a Successful Presentation..........................................................................305
Using the Mouse as a Pointer.............................................................................................305
Changing Bullet Symbols in Outline View........................................................................305
Inserting,    Deleting and Renaming Slides   ...........................................................................305
Creating and Printing Handouts.........................................................................................306
Organizing and Printing Notes...........................................................................................306

OpenOffice.org User Guide for 2.x xvii



Using the Navigator............................................................................................................307
Edit Jump Targets...............................................................................................................307
Modifying Object Size.......................................................................................................307
Creating Additional Objects ..............................................................................................307
Changing Font and Font Size ............................................................................................307
Modifying colours .............................................................................................................307
Keyboard Navigating and Selection in Impress.................................................................308

Chapter 6:    Creating Drawings with Draw   ................................................................ ..309
OpenOffice.org Draw Functions.............................................................................................309

Creating and Publishing    Vector Graphics   ..........................................................................309
Creating 3D Objects...........................................................................................................309
Manage    Organization Charts   ..............................................................................................309
Drawing..............................................................................................................................309
Export.................................................................................................................................310
Construct.............................................................................................................................310
Integrate..............................................................................................................................310

The OpenOffice.org Draw Window........................................................................................311
Toolbars and Windows® in OpenOffice.org Draw............................................................311
Drawing    Rectangles and Ellipses    and Entering Text   .........................................................312
Rotating and    Resizing Objects   ...........................................................................................314

Arranging and    Aligning Objects   .............................................................................................315
Arranging Objects..............................................................................................................315
Aligning Objects.................................................................................................................315
Drawing    Sectors and Segments   ..........................................................................................316
Entering Text......................................................................................................................317
Normal Text........................................................................................................................317
Fitting Text to Frames........................................................................................................317
Callouts...............................................................................................................................318
Converting Text Into 3D....................................................................................................318

Drawing, Editing and Converting...........................................................................................319
Curves and Objects.............................................................................................................319

Drawing Curves.............................................................................................................319

OpenOffice.org User Guide for 2.x xviii



Editing Curves....................................................................................................................320
Vectorizing Bitmaps...........................................................................................................321
Converting Text Characters to Curves...............................................................................322
Converting to Curves, Polygons, 3D..................................................................................323

Working With Objects............................................................................................................326
Duplicating Objects............................................................................................................326
CrossFading    Between Two Objects   ..................................................................................327

Grouping Objects ..........................................................................................................328
Entering Groups.............................................................................................................328
Exiting Groups...............................................................................................................328
Navigating Between Objects of a Group.......................................................................329

Combining Objects and Constructing Shapes.........................................................................330
Combining Objects.............................................................................................................330
Constructing Shapes...........................................................................................................330

Shapes  Merge..............................................................................................................331
Shapes  Subtract...........................................................................................................331

Graphic Objects in Drawings and Presentations.....................................................................332
Inserting Bitmaps................................................................................................................332
Editing Bitmaps..................................................................................................................332

Applying Text to Bitmaps.............................................................................................332
Saving Bitmaps...................................................................................................................333

Working With colours.............................................................................................................335
The    colour Bar   ....................................................................................................................335
Defining    Custom colours   ....................................................................................................336
Replacing colours using the Eyedropper............................................................................338

Gradients and Patterns    for Objects and    Background   ..............................................................340
Defining Gradients.............................................................................................................340
Defining a custom    colour Gradient   ....................................................................................340
Interactively Defining a    colour Gradient   ............................................................................341
Organizing the Attribute Tables.........................................................................................342

3D Globe.................................................................................................................................343
Creating Texture on a 3D Object........................................................................................343

OpenOffice.org User Guide for 2.x xix



Using Illumination..............................................................................................................345
More 3d Effects..................................................................................................................345

3D Effects: Favourites...................................................................................................345
3D Effects: Geometry....................................................................................................346
3D    Effects: Shading   .......................................................................................................346
3D Effects: Illumination................................................................................................347
3D Effects: Textures and Material ................................................................................347

Designing 3D Objects From Font Characters.........................................................................348
First Step:.......................................................................................................................348
Second Step:..................................................................................................................349
Third Step: ....................................................................................................................350
Fourth Step:...................................................................................................................352
Fifth Step:......................................................................................................................353

Using a Grid.......................................................................................................................355
Mechanical or Construction    Drawings   ....................................................................................356

Creating a Construction Plan..............................................................................................357
Using Snap Lines...........................................................................................................361

Using Dimension Lines......................................................................................................361
Working With Multiple Layers..........................................................................................362
Using One    colour per Layer   ...............................................................................................363

Chapter 7: Databases and    Data Sources   ........................................................... ..........364
Creating a    database file   ...........................................................................................................364
Creating a table.......................................................................................................................365
Creating a related table............................................................................................................366
Creating a relationship between tables....................................................................................367
Creating a data entry form.......................................................................................................367
Making data entry easier.........................................................................................................368

Modifying a    date field   ........................................................................................................368
Adding a list box to a form.................................................................................................369
Adding a    combo box    to a form   ...........................................................................................370
Changing the tab order of a form.......................................................................................371

Viewing Data..........................................................................................................................372

OpenOffice.org User Guide for 2.x xx



 Copying the form...............................................................................................................372
Changing the form's properties...........................................................................................372
Setting a sort order for a form............................................................................................372

Creating a query to find today's appointments........................................................................373
Add a sort order to the query..............................................................................................374
Changing the Join type in the query...................................................................................374

Creating a report......................................................................................................................375
Some tips for using the Calendar database.............................................................................376

Adding data to a related table.............................................................................................376
Open the form for the related table................................................................................376
Open the    Data Sources    window   .....................................................................................376
Refreshing the form.......................................................................................................377

Filtering Data......................................................................................................................377
Registering    a Data Source   .......................................................................................................378
Connecting to other types of databases...................................................................................378
Address Books........................................................................................................................379

Registering    an Address Book   .............................................................................................379
Using the Wizard to import an Address Book ...................................................................379
Manually    Registering    an Existing Address Book    .............................................................379
System Address Book as Data Source................................................................................380
Importing and Exporting    Data in Text Format   ...................................................................380
Exporting in CSV Text Format..........................................................................................381

Form Design............................................................................................................................382
Forms in OpenOffice.org....................................................................................................382

Available controls..........................................................................................................383
Customizing controls.....................................................................................................384
Creating a group of option buttons................................................................................385

Do any other controls have an wizard?..............................................................................385
Attaching a data source to a form..................................................................................385
Associating data with a field..........................................................................................386
Activating    form controls in a document   ........................................................................386
How to use the form......................................................................................................387

OpenOffice.org User Guide for 2.x xxi



Searching in Tables and Form Documents ............................................................................388
Searching With a    Form Filter    ............................................................................................389

Operators........................................................................................................................389
Commands ....................................................................................................................390

Chapter 8: Customizing OpenOffice.org.................................................. ..................392
Modifying and Customizing the User Interface of OpenOffice.org.......................................392

Configuring the Keyboard..................................................................................................392
Configuring Menus.............................................................................................................393
Changing Toolbars.............................................................................................................394
Inserting, Moving and    Deleting Icons on Toolbars   ............................................................394
Changing Icon Views.........................................................................................................395

Changing the Look of the User Interface................................................................................396
Selecting    Measurement Units   .............................................................................................396
Moving, Deleting or Copying Icons...................................................................................396

Sending Faxes and    Configuring OpenOffice.org for Faxing   ..................................................397
Creating a LAN Friendly Faxing Solution under Linux....................................................397
Creating a LAN Friendly Faxing Solution under Windows...............................................397
Sending a Fax via dialogue.................................................................................................398
Configuring OpenOffice.org for Faxing via Icon...............................................................398

Further Information.................................................................................................................398

Chapter 9: Advanced Techniques...................................................... .........................399
Copying and Moving    Data Using Drag and Drop   ..................................................................399

Dragging and Dropping Within a OpenOffice.org Document...........................................399
Inserting Objects    From the Gallery   ....................................................................................399

Inserting an object as a copy..........................................................................................399
Inserting an object as a link...........................................................................................400
Inserting an object as a    background graphic   ..................................................................400
Inserting an object as a texture (pattern) for another object..........................................400

Copying Graphics    From the Gallery   ..................................................................................400
Inserting Graphics From a Document in the Gallery.........................................................400
Copying Graphics Between Documents.............................................................................401
Copying Draw Objects into Other Documents...................................................................401

OpenOffice.org User Guide for 2.x xxii



Inserting a Draw object    in a text document   ........................................................................402
Inserting a Draw object    in a spreadsheet   ............................................................................403

Drag and    Drop With the    Data Source View   ............................................................................404
Using data in a text document............................................................................................404
Applying data to a table document.....................................................................................404
Inserting controls in a text form.........................................................................................404

Copying Sheet Areas to Text Documents...............................................................................405
Inserting Data From Spreadsheets......................................................................................405
Inserting Data From Text Documents................................................................................405
Copying    Text Using Drag and Drop   ..................................................................................406

Revision Marking Function.....................................................................................................407
Recording and Displaying Changes...................................................................................407
Accepting or Rejecting Changes........................................................................................408
Comparing Versions of a Document..................................................................................409
Merging Versions...............................................................................................................409
Recording Changes.............................................................................................................409

Version Management..............................................................................................................410
Protecting Contents in OpenOffice.org...................................................................................411

Protecting All Documents When Saving............................................................................411
Turning on protection ...................................................................................................411
Turning off protection ...................................................................................................411

Protecting Revision Marking..............................................................................................411
Turning on revision protection .....................................................................................411
Turning off revision protection .....................................................................................411

Protecting Cell Ranges in Calc...........................................................................................411
Protecting Sections in Writer..............................................................................................412

Turning on protection ...................................................................................................412
Turning off protection ...................................................................................................412

Protecting Cells in a OpenOffice.org Writer Table............................................................412
Automatic Protection of Indexes and Tables......................................................................413

Turning on protection ...................................................................................................413
Turning off protection ...................................................................................................413

OpenOffice.org User Guide for 2.x xxiii



Protecting frames, graphics and OLE objects....................................................................413
Protecting Drawing Objects and Form Objects..................................................................413

Turning on protection ...................................................................................................413
Turning off protection ...................................................................................................413

Protecting Records..............................................................................................................414
Digital Signatures    and Encryption   ..........................................................................................414

Overview............................................................................................................................414
Certificates..........................................................................................................................414

How to get a    Certificate?   ...............................................................................................414
Selfsigned certificates..............................................................................................415
Certificates from a    Certificate Authority   ..................................................................415

Integrating a    Certificate with OpenOffice.org   ....................................................................415
Changing Defaults and Other Configuration Items................................................................416

Saving Configuration With Document...............................................................................416
Inserting and Editing Tab Stops.........................................................................................416

Moving Tabs on the Ruler.............................................................................................417
Changing the Properties of Tabs....................................................................................417
Deleting Tabs.................................................................................................................417
Changing the Defaults...................................................................................................417

Changing the    colour of Text   ...................................................................................................418
Inserting Landscape pages into a Portraitoriented Document...........................................418

More on Templates.................................................................................................................419
Changing Default Templates..............................................................................................419
Modifying Default Templates............................................................................................419
Resetting Default Templates..............................................................................................419
Using    Custom Templates   ...................................................................................................419
Using OpenOffice.org over a Network..............................................................................420

Chapter 10: Introducing    OpenOffice.org Basic and Macros   ....................................421
Accessing the Sample Macros................................................................................................421

Calling the Sample Macros................................................................................................421
Editing the Sample Macros................................................................................................422

The Sample Macros.................................................................................................................423

OpenOffice.org User Guide for 2.x xxiv



AutoText.............................................................................................................................423
ChangeAllChars.................................................................................................................423
GetTexts.............................................................................................................................423
ReadDir...............................................................................................................................423
Userfields............................................................................................................................423

Chapter 11: Using OpenOffice.org Math.................................. .................................424
Formula Entry.........................................................................................................................424

Tool bar..............................................................................................................................424
Command Icon Box............................................................................................................425
Command dialogue Box.....................................................................................................425

Creating an Equation with dialogue Commands.....................................................................426
Special Formating...................................................................................................................427

Exponentiation:...................................................................................................................427
Subscripting:.......................................................................................................................427
Leading and trailing    superscript and subscript:   ..................................................................427
Centre subscript /    superscript:   ............................................................................................427
Under brace / Over brace:...................................................................................................428
Various types of Brackets...................................................................................................428

Special Characters...................................................................................................................429
Special Operators....................................................................................................................430

Integral Sign:......................................................................................................................430
Summation Character:........................................................................................................430
Product Character:..............................................................................................................430

Vectors and Matrices...............................................................................................................431
Vector.................................................................................................................................431
Matrix.................................................................................................................................431

Formatting...............................................................................................................................432
Size.....................................................................................................................................432
Colour.................................................................................................................................432
Layout.................................................................................................................................432
Alignment...........................................................................................................................433

Examples.................................................................................................................................434

OpenOffice.org User Guide for 2.x xxv



Chapter 12: Building Forms    with Xforms    ................................................. ................435
StepbyStep Procedure...........................................................................................................435

Chapter 13: Xml Enhancements................................................. ................................446
Flat XML filter........................................................................................................................446
Creating a new Docbook Filter...............................................................................................451

Chapter 14: Troubleshooting Common Problems.............................. .......................452
Error Message contains “Get Storage: "No Content"”............................................................452

Under Windows®...............................................................................................................452
Multiuser installations:.................................................................................................452
Singleuser installations:................................................................................................452

UNIX systems....................................................................................................................453
Outline numbering is not retained after a save........................................................................453
How get the    page count    to not count a title page?    
Or How do I offset the    page count   ?  ........................................................................................454
What to do when document prints or exports with blank pages ............................................454
What to to do with a General error General input/output error ..............................................455
How to recover content from a Openoffice.org file ...............................................................455

Steps for recovering a damaged Openoffice.org file:.........................................................455
How to get sounds under Linux? ...........................................................................................456

Overview............................................................................................................................456
Starting...............................................................................................................................456
Installing the JRE...............................................................................................................457
Activating the JRE in OpenOffice.org...............................................................................457
Installating the JMF............................................................................................................457
Integration of the JMF in OpenOffice.org .........................................................................458

Registration of the Plugins in the JMF..........................................................................459
Integration of the Plugins in OpenOffice.org................................................................459
Time for the second test.................................................................................................460
Integration of the Plugins in OpenOffice.org................................................................461
Time for the third test....................................................................................................461

What to do if it fails?..........................................................................................................462
How to open Microsoft Works Documents in OpenOffice.org 2.x........................................462

OpenOffice.org User Guide for 2.x xxvi



Index.................................................................................................................. ............464
Public Documentation License, Version 1.0............................... ................................472

OpenOffice.org User Guide for 2.x xxvii





Overview

Overview
The OpenOffice.org User's Guide attempts to provide answers to questions about working 
with OpenOffice.org. It is focused on OpenOffice.org 2.x releases, but it should also be 
useful with 1.9 and 1.1.x releases. Graphics are, for the most part, those using the older style 
icons rather than the newer Crystal graphics, which are currently only in the en_US and 
de_DE releases of 2.0.x. Some are also from the 1.1.x user guide where they are similar to 
existing ones. All these will change frequently as the 1.9/2.0 cycle progresses.

In addition, use of the OpenOffice.org Help facility is also covered. Through Help, users can 
get detailed answers to all questions at any time by pressing (F1), opening the Help menu or 
clicking the Help buttons. More information on using OpenOffice.org Help can be found in 
Chapter 1, “Working with OpenOffice.org”.
Other sources of support are available through the users@openoffice.org mailing list, the 
OpenOffice.org support newsgroups provided by gmane.org and the latest news about 
OpenOffice.org at www.openoffice.org.

Using the Guide
This User's Guide is designed for users who are already familiar with the basic functions of 
their computer. Where there are differences in certain functions between supported operating 
systems, these differences are explained. If functions described here are not available on a 
particular platform, this is a systemrelated limitation caused by the platform in use.
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Important Features with 2.x

Open Standards XML File Format (OASIS OpenDocument)
Beginning with version 2.0 OpenOffice.org uses the open standard OASIS OpenDocument 
XML format as the default file format. The OASIS OpenDocument format is a vendor and 
implementation independent file format, and thus guarantees freedom and independence.
In addition to OpenOffice.org itself, the open source office suite KOffice as well as 
OpenOffice.org derivatives like the StarOffice software support the OASIS OpenDocument 
file format. The OASIS OpenDocument file format is also one of the file formats 
recommended by the European Commission.

New Multipane View
The new Multipane view increases the productivity and usability of OpenOffice.org. The 
Multipane view provides all important tools and windows through one coherent, integrated, 
and simple user interface. Former Microsoft PowerPoint users should find OpenOffice.org 
2.0 easy to use.

New CustomShapes (compatible with Microsoft AutoShapes)
OpenOffice.org now supports CustomShapes which are very similar to Microsoft's 
AutoShapes. As a consequence, AutoShapes are imported and displayed correctly. 
CustomShapes are shapes that cannot only change their size but also their appearance.

More Slide Transitions and Animation Effects
OpenOffice.org now supports many more animation effects and slide transitions. Now users 
have more options to give their presentations a professional appearance. In addition, the 
extended support for effects improves the Microsoft PowerPoint compatibility.

Enhanced PDF Export
OpenOffice.org 1.1 introduced the PDF export feature. Version 2.x now extends the basic 
export feature. With the new version it is possible to define the compression levels of 
embedded images. In addition, the PDF support now correctly handles thumbnail images and 
hyperlinks.
In addition, with the release of 2.0.4, OpenOffice.org has added a number of security 
features, These are:

1. A new Security tab to the Export as PDF feature as shown below:
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2. Encryption is compatible with PDF v1.4, only ARCFOUR (RC4 compatible) 128bit 
encryption is provided.

3. Permissions settings are those supported by the Standard PDF security handler. PDF 
readers and viewers are expected to support these features; however, some may not.
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New enhanced Database Features
OpenOffice.org always had database frontend tools, but in past versions they were very 
hidden. OpenOffice.org 2.x starts to handle databases like any other application, i.e. a new 
database can be created via the "File > New" menu. For novice users OpenOffice.org 
provides a new Table Wizard that allows to create database tables without any knowledge of 
databases and SQL. The new embedded Java technology based HSQLDB database engine 
allows to create "database documents". These simple database files don't require a backend 
database server like MySQL or Adabas D. All information (table definitions, data, queries, 
forms, reports) is stored in one XML file.
QueryinQuery is available with OpenOffice.org 2.0.4 as database queries are an essential 
feature of any database management system. This feature provides the user with the 
possibility to customize the view to the data. A database query now assembles, filters, and 
sorts information spread over multiple tables of the relational database.

Mail Merge Wizard
The new Mail Merge Wizard will make it very easy to do mailings to hundreds of recipients. 
The wizard guides users step by step through the process. Different data sources can be used 
for the address information. There are differences though from 1.1.x.

Enhanced Word Count Feature
With 1.1.x, it was only possible to find document statistics under "File  Properties ..." or by 
installing a word count macro to count the number of words in a selection. OpenOffice.org 
2.0 eliminates this restriction. Now a new word count dialogue can be found in the "Tools" 
menu.

Support for Nested Tables
With OpenOffice.org 2.0 it is now possible to create tables within tables (nested tables). This 
increases the overall usability, but also improves the Microsoft Word compatibility.

Digital Signatures Support
Another new feature is the support of digital signatures. OpenOffice.org uses certificates 
stored in the regular repositories.

XForms Support
OpenOffice.org 2.0 now allows to create forms based on the open W3C XForms standard. 
With XForms it is very easy to implement simple logic without any programming.
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WordPerfect® Filters
OpenOffice.org 2.0 includes a WordPerfect® filter developed by the open source community. 
Developers are invited to contribute to this project.

Calc now has 65,536 Rows
OpenOffice.org 1.1.x supported only 32,768 rows in spreadsheet documents, which caused 
Microsoft Excel interoperability issues. The new version now takes OpenOffice.org to the 
same level as Microsoft Excel.

Enhanced DataPilot Support
With the DataPilot in OpenOffice.org 2.0 (similar to Microsoft Excel's PivotTable feature) it 
is now possible to create new groups, filter data based on values, show differences and 
percentages instead of absolute values, etc.
The new DataPilot features turn OpenOffice.org Calc into a very powerful tool for data 
analysis.

Native Installers
OpenOffice.org 2.0 supports the native installation mechanisms. For example, .MSI and 
.CAB files are provided on Microsoft Windows, RPM, and .deb files are available for Linux.
For users with more sophisticated management requirements, Sun provides configuration 
management tools as part of the StarOffice software. StarOffice 8 will also introduce Macro 
migration tools.

Native Desktop Integration
OpenOffice.org 2.0 integrates nicely into the desktop environment. Thus, OpenOffice.org 
looks and behaves like any other application on a given platform. On Windows XP it looks 
like a Windows application, and on Linux it uses the same UI widgets as GIMP or Evolution.

Floating Toolbars
Toolbars are much more flexible in OpenOffice.org 2.0. It is now very easy to attach and 
detach toolbars, move them around and customize them.

Style Paint Brush
An new icon  has been added to the Standard toolbar. This icon is a shortcut to the style 
painter in the  Style and Formatting Window.

OpenOffice.org User Guide for 2.x 6



Important Features with 2.x

Quickstarter for *NIX Operating Systems
The release of OpenOffice.org 2.0.4, now adds quickstart capability to the *NIX releases in 
the same manner as quickstart under Windows®.

Multiple Language Support
OpenOffice.org 2.x brings an easier way to have OpenOffice.org support multiple languages 
by means of the use of language packs. OpenOffice.org has in excess of 92 languages in 
process at the time of writing. Language packs are, fro the most part, created by their 
associated Native Language Community (NLC). Please check the NLC website that supports 
the language needed.

New Charting Module
The target for the new charting module is OpenOffice.org2.3. (For details, see 
http://graphics.openoffice.org/chart/chart.html ) The following is a summary of what one can 
expect with this new feature:

● New Chart Wizard that simplfies the creation of charts and provides a live preview. 

● Flexible Source Ranges that allow users to choose separate data ranges for single parts of 
single series now. For exampl, selection of different xvalues for different series.

● Settings for 3D charts mde easier via a single dialogue that now contains easier access to 
simple and realistic look and simplified perspective settings.

● Enhanced logarithmic scales that permit users to choose minimum, maximum and major 
intervals.

● Pie segment offset for 3D charts that allow users to drag out single 3D pie segments and 
donut segments.

● Enhanced automatic scaling so that automatic minimum and maximum values improve 
appearance of generated charts.

● Improved automatic axis label layout.
● Improved selection handling.

● Regression curves are now also available for 2D line charts, 2D bar and column charts and 
2D area charts

● Additional sub chart types: 2D Lines subtype 'points only', 2D net subtype 'points only', 
3D XY, 3D smooth lines, 3D donut
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Chapter 1: Using OpenOffice.org Help
Different kinds of help are available in OpenOffice.org.

● Stepbystep instructions with full references via the Contents and Index selections 
of OpenOffice.org Help

● Help Tips that pop up next to the mouse pointer

● Extended tips with more detailed explanations than provided with Tips

OpenOffice.org StepbyStep Help
To access Help, use the Help menu item or click the Help buttons in the individual dialogues.
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OpenOffice.org Help is contextsensitive. This means that, when Help is opened in Writer it 
is specific to Writer. Similarly, to get help about Calc, either first open a spreadsheet and only 
then look for help, or select Help for the specific module from the pulldown list at the top of 
the Help window. The pulldown list at the top of the Help window sets the selected module 
as the current section for searching.

Tips
Tips are on at installation by default and it is recommended that this feature should always be 
switched on. With Tips activated one can , for example, let the mouse pointer rest on an icon 
so that its name is displayed. Tips may also be seen in many other places in OpenOffice.org. 
For example, when scrolling through a table, the tip shows the row or column.

Turning tips on and off
Select Tools > Options > OpenOffice.org > General > Tips to enable or disable this 
feature.

Extended Tips
Switch on the Extended Tips during the first few weeks of OpenOffice.org usage. Enabling 
this option gives a brief description of each item on the screen when the mouse pointer is 
hovered over the item for a moment.

Turning extended tips on and off
Choose Tools > Options > OpenOffice.org > General > Extended Tips to turn extended 
tips on and off. The command is checked when the Extended Tips function is switched on.

Press Shift+F1 to turn Extended Tips on temporarily. The pointer turns into the 
Extended Tips pointer. Now see the Extended Tips for any element on the 

screen as the mouse pointer is moved. As soon as the mouse is clicked or a key pressed, the 
pointer returns to the normal mouse pointer.

Help Agent
When certain actions are performed in OpenOffice.org, the Help Agent 
automatically appears. This is a small window in a corner of the document.

The Help Agent normally remains visible for 30 seconds. When clicked, it is replaced by a 
help window providing some helpful advice about the current topic. If a Help Agent dealing 
with the same topic is repeatedly ignored or closed instead of being clicked, it does not 
appear again for this topic. Resetting the Help Agent restores it to the way it was when 
OpenOffice.org was first installed.
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Turning the Help Agent on and off
1. Choose Tools > Options > OpenOffice.org > General > Help Agent to have the Help 

Agent appear. If the command is checked, the Help Agent is automatically displayed when 
certain actions are performed in OpenOffice.org. Also, by accessing Tools > Options > 
OpenOffice.org > General from the main toolbar, users can reset the Help Agent.
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Chapter 2: Working With OpenOffice.org
OpenOffice.org is reasonably intuitive but is sufficiently different to other suites that a period 
of familiarization required before use is fluid and effective. This chapter starts with a general 
explanation of the most common control features in OpenOffice.org, such as toolbars, 
floating toolbars and dockable windows. This is followed by information on functions that 
can be used in most of the program modules of OpenOffice.org.

The User Interface
OpenOffice.org provides not only the usual control elements found in other applications, 
such as menus and icons, but a host of other special features besides. For example, many of 
the special OpenOffice.org features can be accessed via a context menu, opened by right
clicking on the selected objects. Other userfriendly functions are available by dragging and 
dropping with the mouse.

Starting OpenOffice.org
Under Windows® , once the program is installed (see the separate setup guide that is part of 
the download image and is on most CDs),the OpenOffice.org group should be on the 
Windows® Start menu under Programs. Under *NIX, its location depends upon where it is 
installed and which window manager is used; however, under Gnome and KDE, the 
OpenOffice.org group may be found in the Main menu. To create a blank text document in 
Writer, click Text Document. For a blank spreadsheet in Calc, click Spreadsheet, and so on. 

NOTE: Under Windows®, the OpenOffice.org Quickstarter should be in the Windows® task bar. The 
icon  may be doubleclicked or rightclicked to open its context menu. Rightclicking Quickstarter opens a submenu 
from which a new, blank document can be opened. Doubleclick Quickstarter to open the Templates and 
Documents dialogue.
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The OpenOffice.org Writer Window
A text document is displayed and edited in the Writer window. Spreadsheet, presentations or 
drawings are displayed in very similar windows, except the menus and icons change 
automatically depending on the context.

Toolbars in the OpenOffice.org Window

The Title Bar
The title bar shows the name of the program, OpenOffice.org, and usually the file name of 
the current document. If a document title is entered in File > Properties > Description , this 
title is displayed rather than the file name.
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The Menu Bar
At the top of the OpenOffice.org window, immediately under the title bar, is the menu bar. 
Point with the mouse to a command on the menu bar and press the left mouse button. The 
menu opens, allowing one to choose a command from the submenu by clicking it. The menu 
bar can also be accessed from the keyboard, by pressing the Alt key.

The menus are organized into basic functions. The Edit menu, for example, provides the 
functions needed to edit the current document (cut, copy, paste, undo changes and so on), 
while the View menu has functions that allow control of the view of the elements displayed 
on the screen. In other words, the commands used for editing, viewing, sequencing, 
formatting and printing a document can only be used when the document is open and active. 
Active, in this sense, means that the document is front of any others on the screen. If the 
commands should correspond to an object in the document, then that object has to be 
selected. In addition, the menus are context sensitive,. This means that only those menu 
commands that are relevant to the current work will be available . For example, if the cursor 
is located in a text document, then only the text editing menu commands are available. 
Likewise, if graphics are selected in a document, then only the menu commands that can be 
used to edit graphics will be available. The other inactive menu items are hidden. By 
choosing Tools > Options >OpenOffice.org > View, one can select the Show inactive menu 
items field and then see the inactive menu items as gray entries in menus.
OpenOffice.org lets the user change and customize the menu bar the way as desired. Many of 
the toolbars and the status bar may so be modified to suit personal requirements.

The Toolbars
Below the menu bar is the Standard toolbar. This toolbar contains icons for several 
important commands and functions that can be used in OpenOffice.org to open a document, 
export to PDF, undo and redo, access the navigator, or gallery or print the current document.

Immediately above the horizontal ruler is the Formatting toolbar. This offers features that 
are always appropriate to the current context such as alignment, font styles, lists and 
indenting. For example, if a piece of normal text is selected , one will see different icons from 
those within a text table. 

On the left edge of the document is the main toolbar. This varies depending on the 
document type (text, spreadsheet, presentation, drawing or formula). 
Other toolbars such as the option bar and colour bar will be described later. 
It is easy to change the position of the toolbars. For example, if the position of the main 
toolbar should be on the right edge of the document instead of on the left, simply drag the 
knurled handle at the far left in the toolbar to a new location around the edge of the main 
window.

Note: under Windows®, one only needs to use (Alt).
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Some icons have small triangles to indicate that there are more functions available. These are 
called floating toolbars. When a long click is applied to these icons, a new window opens 
giving access to all those features associated with that icon. Short clicks deliver different 
behaviour than a long click but give the same functionality.

Examples of Floating Toolbars
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Using Floating Toolbars
When editing a text document, the Insert icon is in the Tools toolbar. Do a long click on this 
icon. This opens a floating toolbar containing further icons. 

The user now has a few choices to make: either to click the icon to activate the feature, or to 
grab the window by its title bar and drag it away from the main toolbar while holding down 
the left mouse button (remember to first release the mouse button that was clicked to open the 
popup otherwise the title bar cannot be grabbed with the mouse). Notice that the icon, that 
was used previously, is still there. If one now clicks the From File icon, notice that this icon 
has replaced the original icon a the top of the main toolbar. Use a short click to open the 
directly visible function and a longer click to reopen the floating toolbar . 

The document window
At the top left hand edge of the document window are the toolbars that are needed for work, 
and that these vary depending on the document type and context. At the bottom edge is the 
status bar. The status bar contains different fields displaying information appropriate to the 
type of document. Some of these fields give access to special functions, either by double
clicking or by opening the relevant context menu. For more detailed explanations, refer to 
Help.

Docking toolbars
All toolbars may be positioned as either floating windows or dockable panes. These floating 
windows may be docked on any of the edges of the OpenOffice.org window. On each edge 
several toolbars may be docked alongside each other. To undock and redock, drag the handle 
at the left or top (if vertical) of the toolbar. 
In the floating state, the window floats above the workplace so that the windows below it are 
partially covered. Switch to the locked state to display the docked window next to the workplace. If 
the window is docked to the left of the workplace, the following buttons appear depending on 
the state: 

Unhide

A hidden window can be unhidden (shown) by clicking the arrow 
button.
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Unhide
Hide

Click the arrow button to hide a window.

Lock

Click this button to lock a floating window.

Floating

Click this button to change a locked window to a floating window. 

Docking windows
Some tools in OpenOffice.org open in popups that are dockable, such as the Styles and 
Formatting window, the Navigator and the Gallery. These floating windows may be docked at 
either the left or right edges of the main OpenOffice.org window.
To dock one of these windows, drag the title bar of the window  to the edge until  an outline 
appears. This outline indicates the size and position of the pane that will contain the tool 
when the mouse button is released. Another window may also be docked adjacent to one 
which is already docked. Users can choose to have one on top of the other or side by side. As 
a window is moved, note that an outline displays showing where the window will dock and 
how big it will be. 
To undock a tool and make it a floating window again, point to the grey area of the tools 
toolbar and drag the tool away from the edge until the outline indicates that it is no longer 
attached.

Changing the Visibility of Buttons on Toolbars
Tools and functions are initially grouped together on a default set of toolbars. Not all buttons 
are visible by default.
To quickly make a button visible or not on its toolbar:

1. Click on the small down arrow at the far right of the toolbar and select Visible Buttons.
2. Toggle the checked status of the button. Make sure to click the downarrow appropriate 

to the toolbar because toolbars may be placed sidebyside.

Note: While buttons may be moved or duplicated across toolbars, or new toolbars may be created or removed 
completely, we will start with just the OpenOffice.org provided toolbars.
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Opening and Saving Documents
There are multiple methods of loading or opening documents. For example, by using the File 
> Open dialogue, the Open icon on the Standard toolbar or the File > New menu.

NOTE: Under Windows®, a system dialogue is automatically displayed when opening and saving OpenOffice.org 
documents. Choose Tools > Options >OpenOffice.org > General and check Use OpenOffice.org dialogues. This 
enables a user to be presented with the OpenOffice.org dialogues shown in this guide.

Opening Documents
To open an existing document that was saved on the hard drive or on a removable disk, 

there are three possibilities. Either choose File > Open, click the Open File icon on the 
Standard toolbar, or use the Ctrl+O shortcut keys. 

Is each case, the Open dialogue is displayed. 

This dialogue is described in detail in the OpenOffice.org Help. However, here are a few tips: 

  Change the size of the dialogue by dragging the borders of the dialogue with 
the mouse. 
Click the Default Directory icon to go straight to one's work directory. To 
define a work directory, see the Changing the Work Directory section
Longclick or shortclick the Up One Level icon. A short click takes the user 
one directory higher. A long click opens a submenu with a choice of 
superordinate directories. 
To only see files containing a certain name, enter the name with wildcards in 
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the File name pulldown list and press Enter. If *.txt, for example, is 
used only the files having .txt at the end of their names will be displayed. 
If s* is used , all names beginning with the letter s will be displayed.
Documents may be opened with writeprotection enabled. To edit a readonly 
document, click the Edit File icon on the Standard toolbar.

The Templates and Documents dialogue

The Templates and Documents dialogue can be regarded as a kind of command centre for 
OpenOffice.org documents. It provides easy access to a user's work directory and to any 
supplied sample documents. Here find all document templates  both the supplied ones and 
any personally created ones. To open the dialogue, choose File > New > Templates and 
Documents or press Shift+Ctrl+N. In Windows®, doubleclick the OpenOffice.org 
Quickstarter icon on the task bar. 

The dialogue offers the following areas, which can be selected by clicking one of the 
offerings in the shortcut bar on the left:

• New Document  A way to create a new, empty document from a set of prepared 
templates.

• Templates  Choose from the many readytouse document templates.
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• My Documents  A quick route to the documents in a work directory. A work directory 
may be defined by selecting Tools > Options >OpenOffice.org > Paths and entering the 
path required for My Documents.

• Samples – This is an empty folder when installed; however, some examples may be 
downloaded from 
http://documentation.openoffice.org/Samples_Templates/User/template/   index.html.    (See 
New Document for example templates)
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Saving Documents
Saving the current document can be done in three ways, using File > Save command, the 
Save Document icon  on the Standard toolbar, or just press Ctrl+S.

For a first time save, use File > Save as. A dialogue box pops up to allow choosing where to 
store the file. 

With File > Save as, one assigns the document a name whereas the other two options save 
without asking for the file to be named. Therefore, using the Save as feature is especially 
important when saving files for the first time. For the most part, choose any name desired 
(limited only by the restrictions imposed by the operating system). When the document is to 
be opened later, find it under that name. 
Save documents regularly as work progresses. The simplest way is to save the current 
document by pressing CtrlS. This replaces the document on the data medium with the 
current document.

Note: An untitled document must be given a unique name for AutoSave to obey the settings in Tools > Options > 
Load and Save > General. Disabling AutoSave is not recommended.
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Changing the Work Directory
When the Open dialogue comes up, the work directory is displayed. The user can change this 
directory as follows:

1. Select Tools > Options >OpenOffice.org > Paths.

2. Doubleclick My Documents to open the edit dialogue.

3. In the Select Path dialogue, enter the work directory wanted and click Select. 
4. Close with OK.
Likewise, other directories can be selected using the same method. For example, to display a 
different default directory for inserting graphics, change the path for the entry Graphics.

Saving Documents Automatically

Backup a File Automatically
To create a backup copy of a document every time a document is saved:

1. Select Tools > Options > Load/Save > General.
2. Check Always create a backup copy.
If the current document is saved, using the same path and file name with which it was first 
opened, using File > Save or Ctrl+S, the old version will be overwritten by the new 
version. If the Always create backup copy is checked, the old version is first copied to the 
backup directory.
• The default backup directory is $HOME/OpenOffice.org<release>/user/backup. 

Change this, as described above, in Tools > Options >OpenOffice.org > Paths > 
Backups entry.

• The backup copy retains the same name as the document, but the extension is changed to 
.BAK. If the backup folder already contains such a file, it is overwritten without warning!

Saving Recovery Information Automatically Every 'n' Minutes
1. Select Tools > Options > Load/Save > General.
2. Check Save AutoRecovery information every and select the time interval in the list box.
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OpenOffice.org File Formats
OpenOffice.org uses an XML file format as the default for saving and opening documents.

XML file format names
In saving and opening OpenOffice.org documents if no other file type is 
selected,OpenOffice.org uses the following XML formats:

Application File extension
OpenOffice.org Writer *.odt
OpenOffice.org Writer templates *.ott
HTML Document *.html
HTML Document Template *.oth
OpenOffice.org Calc *.ods
OpenOffice.org Calc templates *.ots
OpenOffice.org Impress *.odp
OpenOffice.org Impress templates *.otp
OpenOffice.org Draw *.odg
OpenOffice.org Draw templates *.otg
OpenOffice.org Formula/Math *.odf
Master documents *.odm

These file name extensions permit reasonable differentiation when searching though a lot of 
files of different file types in a directory. Since these are compressed XML files , it should be 
evident that these must first be unpacked before being manipulated, for example, by a text 
editor.

Note: If a user wants to work permanently with another file format, define this as the default. Select Tools > 
Options > Load/Save > General for alternative file formats that can be selected for each OpenOffice.org document 
type.
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OpenOffice.org XML file structure
The OpenOffice.org XML file formats follow the OASIS OpenDocument standard and are 
compressed and packed using ZIP. Use an unpacking program, such as WinZip on 
Windows® or unzip on *NIX, to unpack the contents of an XML file. The structure is similar 
to the following illustration.

Archive: example.odt

Length Method Size Ratio Date Time CRC32 Name

        

30 Stored 30 0.00% 15/05/05 15:25 3931a5e1 mimetype

4260 Stored 4260 0.00% 15/05/05 15:25 a10af03b  Pictures/ 100010DA222DD884.gif

9022 Defl:N 2147 76.00% 15/05/05 15:25 cd8d5105 content.xml

2447 Defl:N 954 61.00% 15/05/05 15:25 08c57cab Basic/~wizard/Create.xml

1586 Defl:N 642 60.00% 15/05/05 15:25 55c931dc Basic/~wizard/Save.xml

389 Defl:N 223 43.00% 15/05/05 15:25 756d8953 Basic/~wizard/scriptlb.xml

287 Defl:N 193 33.00% 15/05/05 15:25 528021b8 Basic/Standard/scriptlb.xml

405 Defl:N 225 44.00% 15/05/05 15:25 95c3869e Basic/scriptlc.xml

59152 Defl:N 5041 92.00% 15/05/05 15:25 e86699c4 st yles.xml

13 81 Stored 13 81 0.00% 15/05/05 15:25 70e3c0fc meta.xml

6674 Defl:N 0 0.00% 15/05/05 15:25 af1ecee5 Thumbnails/thumbnail.png

6841 Defl:N 1230 82.00% 15/05/05 15:25 0d922df6 settings.xml

1602 Defl:N 349 78.00% 15/05/05 15:25 8e61970e METAINF/manifest.xml

    

87402 16 675 81.00% 12 files

Note: Under Windows®, output should be similar to the above.

• The text content of the document is located in content.xml. This file can be viewed with, 
for example, a pure text editor.
By default, content.xml is stored without indents or any other type of formatting so 
that the time needed for saving and opening is minimized. By unchecking Tools > 
Options > Load/Save > General > Size optimization for XML format this procedure 
can be changed so that the lines saved are structured in a more human readable format.

• meta.xml contains the meta information on the document, which is entered via File > 
Properties.
In documents saved with security, meta.xml remains unsecured.

• settings.xml contains further information on settings for this document, for example 
on the printer, on the recording of changes, the associated data sources and so on.

• st yles.xml retains the styles defined for the document. For example, these can be seen 
in the Styles and Formatting window.

metainf/manifest.xml file describes the structure of the XML file.
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Additional files can be contained in the packed file format. For example, Graphics can be 
found in the Pictures subdirectory, Basic code in the Basic subdirectory and linked Basic 
libraries are found in further subdirectories of Basic.

Definition of the XML formats
The DTD (Document Type Description) files can be found in 
$HOME/OpenOffice.org<release>/share/dtd.

Note that the formats are subject to certain licenses. Notes on the licenses are found at the start of the DTD files.  
More detailed information can be found on the OpenOffice.org website.

Setting Tabstops
OpenOffice.org offers multiple ways by which one can set and edit the tabstops used in a 
document. The procedures for setting and editing tabstops are described in Help > 
OpenOffice.org Help > Index > Search term > tab stops and are quite complete. 
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Sending Documents as EMail
Single Messages
Working in OpenOffice.org, one can send the current document as an email attachment 
providing that the default email program up is set up correctly. 

Note: To set up this feature, select Tools > Options >Internet > EMail and configure the program to use.

1. Choose File > Send > Document as Email.
2. When the email composer window appears, enter a recipient, subject and any text and 

send the email.

MailMerge
As of OpenOffice.org 2.0.1, providing that python is enabled at setup time (default), users 
have the opportunity to use email to send messages to multiple recipients. This feature also 
allows printing of these for delivery by post.

1. Choose Tools > Mail Merge Wizard
2. Follow the dialogues.
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Printing Documents
Upon creating a document, normally one will want to print it out on paper for distribution.
Print the current document either directly to a printer, or”to file”. When printing to a file, all 
the information that would otherwise be sent to the printer is initially written to a file. On 
another computer, the file can then be copied directly to the printer connected to it. 

Note: OpenOffice.org Writer always formats documents so that they are printed as well as possible with the 
selected printer. Therefore, always define a default printer, even if there is no available printer.

Click the Print File icon on the Standard toolbar to print the current document without 
the intervention of a dialogue.

To retain finer control of printing, either select File > Print, or use the keyboard shortcut 
Ctrl+P.

In the File > Print dialogue, select a specific printer (if there is more than one installed 
printer). Under Print range, determine how many pages to print (or only certain pages), and 
how many copies are wanted.

In addition to the general printing options already mentioned, one can choose special printer 
options for the different document types in OpenOffice.org using additional dialogues that 
allow the user to control the way the contents or the pages of the document are printed. 
Define these printer options for the current print job by clicking the Options button in the 
Print dialogue. Select Tools > Options > (name of document type) > Print to create a 
general definition for normal use. 
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Note: There are many different printers with widely varying properties. The printing functions differ according to 
the operating system, printer driver and printer model used. The selected printer defines the width and height of the 
characters, and hence also the line and page breaks. OpenOffice.org Writer and Calc always format the pages in 
the way they will appear when printed. 

Displaying Print Previews
Before printing out a document, reviewing how the printed document will appear on paper is 
often a good idea. OpenOffice.org offers a Print Preview feature for this purpose thereby 
allowing adjustment of margin widths, optimization of page breaks et cetera. 
1. Switch to the document for preview.

1. Select File > Page Preview.
2. Use the icons on the object bar to zoom in or out.

3. Use the arrow keys or object bar icons to scroll through the pages of 
the document and check how they will appear in print.
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Reduced Printing of Documents
To get a reduced printout of a text document, choose File > Page Preview. Here, decide 
whether to have two, four or any number of pages beside and on top of each other.

To print two pages beside one another on one sheet of paper
1. Choose File > Page Preview.
2. Locate the Page Preview icon  . If there are more or fewer pages than desired, long 

click the icon to the right of the grayed out Page Preview: Two Pages on the object bar 
and select the number of pages needed for previewing.

3.    Click on the Print page view icon. 

Clicking the Print options page view icon  opens a dialogue where one can enter 
settings for reduced printing.

4. Click OK to confirm.

Printing in Black and White
If there is a colour printer installed but printing should be restricted to black and white only, 
use one of the following options:

Printing text and graphics in black and white
1. Select File > Print. This opens the Print dialogue.

2. Click on Properties. This opens the properties dialogue for the printer.
3. Choose the option to print in black and white. For further information, refer to the help for 

the printer or read the printer manual.

4. Confirm the Properties dialogue and click OK in the Print dialogue.
5. The current document will be printed in black and white.

Printing all Draw and Impress documents in black and white
1. Choose Tools > Options > OpenOffice.org Impress or Tools > Options > 

OpenOffice.org Draw, as appropriate.

2. Then choose Print.
3. Under Quality select either Grayscale or Black & White and click OK. From now on, all 

presentations or drawings will be printed without colour.

Selecting the Default quality option allows documents to be printed in colour again later 
on.

Grayscale converts everything to a maximum of 256 gradations from black to white.

Black & White converts everything into the two values black and white.
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Printing only text in black and white
In Writer, the user can choose to print colourformatted text in black and white. This can be 
specified either for all text documents to be printed subsequently, or only for a printing 
process of the current text document.

Printing all Writer documents with black and white text
1. Choose Tools > Options > OpenOffice.org Writer or Tools > Options > 

OpenOffice.org Web/Writer.

2. Then choose Print.
3. Under Contents mark Print black and click OK.

All text documents or HTML documents will from now on be printed with black text.

Printing the current Writer document with black and white text
1. Choose File > Print. This opens the Print dialogue.

2. Click the Options button. This opens the Printer Options dialogue.

3. Under Contents mark Print black and click OK.
The text document or HTML document now being printed will be printed in black text.

Printing Brochures
OpenOffice.org text documents consisting of more than one page can be printed 
automatically as a brochure. Two pages of a text document will be reduced in size and 
printed next to each other on a page in landscape (horizontal) orientation. Both sides of the 
page will be printed (most printers require that users take out the paper after the first half of 
the printing process and feed it in again n such a way as to print on the blank side). 
OpenOffice.org will automatically print the pages so that they can be read as a brochure. 
OpenOffice.org automatically arranges the pages in such a way that the text can be read 
continuously by laying the pages together, fold them in the centre and stapling them in the 
fold. 

To make a brochure using the current document, select File > Print. In the dialogue that 
opens, do the following;

1. In Printer > Properties make sure Orientation is set to landscape
2. While still in this dialogue, set the Paper size of the *document* to A4 or US letter, as 

needed.
3. Click OK to close the dialogue.
4. Click the Options button in the lower left of the Print dialogue.
5. Next select whether to print right and left pages all at once, right pages or left pages. 

The following should provide sufficient information to make a decision:
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(a) If the printer is capable of duplex printing, choose Left and Right pages and 
brochure.

(b) With a single sided printer:
i.  choose Left or Right and brochure. 
ii. Click OK then go to step 6.
iii. When printing is complete, take the pages from the output tray and put them 

into the input tray in such a way as to print on the blank side and choose the 
opposite Page setting as in step 1. Repeat step (ii).

6. Click OK
7. Click OK

Spellcheck
OpenOffice.org has an automatic spellcheck which can be active while typing, or activated 
manually.

Automatic Spellcheck

The automatic spellcheck can be turned on and off by clicking the AutoSpellingCheck 
on/off icon on the Standard toolbar. With automatic checking enabled, words recognized as 
incorrect are highlighted with a wavy red underline. 
Incorrect words are recognized as incorrect if all the following conditions are met: 
• a spellcheck module is installed for the language of the word, 
• this module is enabled, 

• the word is not found in the installed dictionaries. 
• the word is not in any active user dictionary. 
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Users can create any number of custom/user dictionaries. 

Create a user dictionary by selecting Tools > Options > Language Settings > Writing Aids. 

As text is proofread, the wavy red underlines draw attention to possible spelling mistakes. Of 
course, Spellcheck will not catch spelling mistakes that form other recognizable words (such 
as “fun” instead of “run”). As long as the automatic spellcheck is activated, the red markings 
can be seen on the screen but are not printed. 
The easiest way to correct a redunderlined word is to rightclick it. This opens a context 
menu that offers suggested corrected spellings, and options to add the word to the dictionary 
or to ignore it. Simply click the correct suggested spelling to replace the redunderlined word. 
Spellcheck not only replaces the redunderlined word with the suggestion selected, it also 
remembers this replacement while the document is open. If the same typing error is made 
again, Spellcheck automatically replaces the mistyped word with the corrected spelling. 
If the word is spelled correctly, it may be added to a dictionary by clicking Add and 
specifying to which dictionary it is to be added. To ignore a correctly spelled, but 
infrequently used word, click Ignore All.

Checking Multilingual Texts
OpenOffice.org Writer can manage spellcheck(plus thesaurus and hyphenation) in multiple 
languages (33 at the time of writing). The OpenOffice.org setup program offers this via 
“Custom Installation” and, after installation via the “Modify” option in setup, 
where one can choose which language modules to install.
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Select the language of an entire text document with Tools > Options > Language Settings > 
Languages. If it applies to the user's needs, check For the current document only. For all 
paragraphs formatted with the same Paragraph Style, apply a language via the Paragraph 
Style. A language can be defined for individual words via Character Styles, or directly with 
Format > Character.

In Tools > Options > Language Settings > Writing Aids , check the option Check in All 
Languages. Now, Spellcheck will take all installed languages into account. Words that are 
correctly typed in any of the installed languages are regarded as correctly typed, irrespective 
of their language attribute. In multilingual texts, the automatic checking that was enabled by 
clicking the icon on the Standard toolbar, offers another facility as well. In the context menu 
of a redunderlined word that is recognized as incorrect, specify that the word or the whole 
paragraph is one of the other installed languages. The language of the underlined characters 
or all characters of the paragraph is automatically assigned as a character format.

Starting Spellcheck
To check the entire text for spelling mistakes in the “classic” way (i.e. letting Spellcheckgo 
through the whole document on its own), go to the Tools menu and choose Spellcheck. The 
Spellcheck dialogue will only appear if there are words in a text unknown to the Spellcheck. 
The various options to be seen in the Spellcheck dialogue are described in detail in the 
OpenOffice.org Help. In the Spellcheck dialogue, if an unrecognized word is included in a 
user dictionary, the user can also define the permitted hyphens for the automatic hyphenation. 
Enter the hyphens in the word as an equals sign (=). 

Note: placing an equals sign at the end of the word means that this word will not be automatically hyphenated. 
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Excluding Text From the Spellcheck
If certain areas, words or tables should not be spell checked because they are, say, in a 
foreign language for which there is no installed module, then specify "Unknown" as the 
language to be checked by Spellcheck. Do this by either using direct formatting by selecting 
the text and then choosing Format > Character > Font or by modifying the corresponding 
St yle for the text (e.g. open the context menu and choose Edit Paragraph Style...).

Adding Writing Aids for Other Languages
OpenOffice.org offers users the opportunity to change the language of the user interface as 
well as providing a wizard to install more dictionaries, hyphenation dictionaries and 
thesauruses.
This allows use of more than one language in a document as as attribute of the entire 
document or a group of words. 
As an adjunct to the addition of writing aids in various languages, users can change the 
default language used either generally or for a single document by means of selecting that 
language in Tools > Options > Language settings > Languages. Remember that the writing 
aids must be installed first.

Getting New Writing Aids
1. Select File  Wizards  Install new dictionaries ... to start the process to install more 

languages.
2. Click the language needed on this page for instructions in that language.
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3. Click the big button in the middle of the document page to start the installation 
process:
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4. The following dialogue opens to begin the selection of the needed components:

5. Click Next
6. Click “Retrieve the list” and select those needed:
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7. Click Next and select the Hyphenation dictionaries needed and click Next when done:

8. Click Next and select the Thesauruses needed and click Next when done
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9. Clicking Next, starts the download and installation of the items selected in the 
previous steps. 

OpenOffice.org User Guide for 2.x 39



Chapter 2: Working With OpenOffice.org

Using Automatic Functions
OpenOffice.org has all kinds of intelligent assistants to help, all of which have names 
beginning with “auto”.
The section introduces a few of these autofunctions. For detailed explanations, refer to the 
OpenOffice.org Help.

Using AutoCorrect and AutoFormat
In addition to catching typing errors, OpenOffice.org can format documents while typing or 
afterwards. AutoFormat and AutoCorrect permit the user to draft documents much more 
efficiently by automatically formatting and correcting common errors while the user types. 
Here are a couple of examples.
• AutoCorrect is useful if one often makes the same typing errors. For example, if one tends 

to capitalize not only the first letter of some words but also the second, simply select the 
AutoCorrect function that corrects mistakes of this sort while typing. 

• AutoFormat formats texts. One AutoFormat feature automatically will detect paragraphs 
beginning with a hyphen followed by a tab or space, and reformat the paragraph as a bullet 
point. The automatic bulleting is then applied to any paragraphs that follow as well. 
Automatic bulleting ends when the user enters a blank paragraph containing only a 
Return.

In text documents, toggle AutoFormat on or off by selecting Format >AutoFormat. A 
submenu with three selections appears. To automatically format while typing, check the 
While Typing  selection. To have Writer automatically format the entire document or the 
current selection at a later time, check the menu selection Apply. Selecting Apply and Edit 
Changes lets the user see all document changes made via AutoFormat. The user then may 
accept or reject all changes or may review each change separately.

One may also select and set the options in Tools > AutoCorrect. AutoCorrect offers many 
options that can be selectively turned on and off. Some of these offer different methods for 
formatting while typing and postprocessing. The Replace and Exceptions lists are language 
dependent. OpenOffice.org first searches in the list of the language of the text, then the list 
for the higher ranking language family, and finally in all installed languages (For example, 
first in "English (US)", then in "English", then in "All Languages"). 
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The following graphic shows the various functions available in this dialogue. A detailed 
explanation of each function is given in OpenOffice.org Help. 

In addition to the functions shown here, one can also select Custom Quotes. This means that 
all quotation marks entered as a simple computer character with Shift+2 are automatically 
turned into correct typographer's quotes. Users can choose the characters to be used for this 
purpose. 
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Turning off URL Recognition by AutoCorrect
When text is entered,OpenOffice.org automatically recognizes a word that may be a URL and 
replaces the word with a hyperlink. OpenOffice.org formats the hyperlink with direct font 
attributes (colour and underline) the properties of which are obtained from certain Character 
Styles.
If OpenOffice.org should not automatically recognize URLs while typing, turn off this 
feature using one of the following methods.

Undo URL recognition
1. Press Ctrl+Z to undo text that has been automatically converted into a hyperlink.

2. Select the hyperlink and choose Format > Default if this conversion is not noticed until 
later.

Turn off URL recognition
1. Load a document of the type in which URL recognition is to be modified. For example, if 

modifying URL recognition for text documents, open a text document.

2. In OpenOffice.org Writer select Tools > AutoCorrect ... .
3. In the AutoCorrect dialogue, choose the Options tab.

4. Deselect URL Recognition, so that words will no longer be automatically replaced with 
hyperlinks.

In Writer there are two checkboxes in front of URL Recognition. The field in the first 
column is for modifying in a postedit session while the field in the second column 
enables AutoCorrect to make the corrections while typing.

Other AutoCorrect functions
The Tools > AutoCorrect > Replace tab has a default list of items that will be automatically 
replaced provided that Use replacement table on the Tools > AutoCorrect > Options tab 
page is checked. One can add all of their most frequent typos to this list and have 
AutoCorrect replace them with the right text. Also use this feature to enter special 
characters or phrases that are keyboard intensive to do normally. For example,  (C)  is 
immediately turned into the copyright symbol. 

Note: The fonts supplied with OpenOffice.org include the Euro symbol. If working with other fonts, one can easily  
insert the Euro symbol from another font using AutoCorrect. When working in a text document, choose Insert > 
Special Character. Look for the Euro symbol and click OK.

Enter in the Abbreviation text box eu, for example. The Text only box should not be marked. Click New. Now close 
the dialogue. As soon as the eu is entered followed by a space or at the end of a sentence, a Euro symbol will be 
inserted.

On the Exceptions tab, enter any exceptions for the two types of automatic correction: 
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• Assuming the Replace option is enabled to automatically start each sentence with a 
capital (uppercase) letter, and“e.g.” is entered and is followed by a lowercase “d” then 
the “d” would be capitalized. So to compensate for this behaviour, enter “e.g.” into the 
Exception list to prevent this type of correction. 

• Again, assuming the Replace option is enabled to automatically convert the second of two 
capital letters at the beginning of a word to a lowercase letter, enter any exceptions that are 
correctly written with two capital letters, such as PC and CD. 

These exceptions can also be automatically included by selecting the Autoinclude 
checkboxes on the Exceptions tab. When this feature is enabled and one then uses an idiom 
in the text that is automatically corrected but which should not be corrected, immediately 
press Ctrl+Z. Doing this not only undoes the automatic “correction”, but also sees to it that 
this particular “correction” will not be made automatically again in the session.
AutoCorrect can also be used to replace one word or abbreviation with something more 
appropriate. For example, replace “ASAP” with the text “as soon as possible”; 
however, the OpenOffice.org AutoText function is a better choice for doing this.
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Creating a Letter Template With the Wizard
If one is writing a personal letter, the Wizard and standard AutoTexts are not essential, but in 
formal business correspondence these aids can save a lot of time and make work much easier. 

Note: To produce a standard letter, have a look at the supplied templates. Simply press the shortcut keys 
Shift+Ctr+N or choose File > New > Templates and Documents. 

Start the Wizard with the File > Wizards > Letter menu command. 

Treat this section as a tutorial on the OpenOffice.org template Wizard. Although the Wizard 
does produce a document that can immediately be filled in, printed, and sent, using the 
Wizard is really meant to help create customized templates. Customized templates for such 
things as business letters, faxes and other types of documents for which there is a Wizard 
ensures that correspondence has a consistent format. 

While one may, there is no need to go through all the steps of the Wizard each time one 
wants to write a letter. However, in order to get the most from the following, it is 
recommended that one accept all the defaults provided without changing them, and then print 
the result. Click Next on each dialogue page, so that every page is seen at least once during 
the learning process. Examine each of the Wizard pages while going through the process of 
creating a letter template. Enter data or modify options on each page as necessary. Each page 
allows modifications according to each user's preferences including sender and recipient 
addresses, both of which can also be entered manually. (For example, sender information is 
automatically taken from the personal details that each user enters at the time of installation. 
These details may be changed at any time by selecting Tools > Options >OpenOffice.org > 
User Data and entering new information or editing existing details.) Predefined elements will 
appear but users always have the final say on what to include in their letter. 
Thanks to the Wizard, one doesn't have to start from scratch but can use preexisting texts 
when creating custom templates, whether for business letters, faxes, memos, or other 
documents. 
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Find & Replace
When working with a computer it is often useful to be able to locate certain pieces of text 
quickly. The Find function in OpenOffice.org Writer, Calc, Impress and Draw is the tool to 
use for this purpose. Find can also locate variations in the given search term or limit the 
search to certain places in the document, such as the beginning of a word or the end of a 
paragraph. 
Text strings found in the text can be replaced by other strings with or without confirmation, 
although sometimes manual editing is still necessary where, for example, there are deviations 
in gender found in other languages. 

Finding a Word in Text
Let's say the word “Holland” appears somewhere in a long text and the user wishes to locate 
it.  Activate the Find function with Ctrl+F. Enter the string one wants to find in the Search for 
field and press Enter. OpenOffice.org starts searching from the current cursor position toward 
the end of the document. Upon reaching the end of the document, a new dialogue appears 
asking whether or not to continue the search at the beginning of the document. Tap the Enter 
key to confirm. If the text string is found, it is highlighted.

OpenOffice.org starts searching from the current cursor position toward the end of the 
document. Upon reaching the end of the document, a new dialogue appears asking whether 
or not to continue the search at the beginning of the document. Click the Enter key to 
confirm. If the text string is found, it is highlighted. 
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The Find & Replace dialogue can remain open without interfering with text entry and it 
can be moved to any place on the screen. However, when it is closed, it remembers the 
previously entered strings so they do not need to be reentered for the next search, but can be 
selected from the list box. 
One very useful feature is the multiselection facility Find All. For instance, using Find All, 
one could set every occurrence of the word “document” in the text to boldface. Enter the 
search term in the Search for field and then  click Find All. All occurrences are now 
selected. Place the cursor in the Replace field,  and click the Bold icon in the text object 
bar to boldface all occurrences of the search term.
The dialogue graphic above illustrates that there are several ways of expanding or restricting 
searches by combining selections from the Options group box and the buttons. Examples for 
each option are described below.

Searching for Whole Words Only
Select the Whole words only option to find whole words that match the searched for word. 
For instance, if the word “in” is entered as the search term in the Search for field, all 
instances of “in,” or “In,” as standalone words in the text will be found. Words like “bin” 
or “chin” will not be found if this checkbox is selected. If searching using regular 
expressions or for Styles, do not select this option. 

Match Case
When this checkbox is selected, the search is casesensitive to uppercase and lowercase 
letters. So if searching for “in,” it will be found, but not the word “In,” Combine a Match 
case search with the Whole words only option as needed. 

Searching for Text With Wildcards
1. Start Find by selecting Edit > Find & Replace dialogue or use Ctrl+F.

2. Check the More Options > Regular expressions box.

3. Enter the search term with the desired wildcards and click Find.
Regular expressions are entered using text combined with keyboard characters and symbols 
that have special meaning in this context:
• The wildcard for any number of a given character is the character itself followed by an 

asterisk (*).  Note that this is different to the way '*' is used in file names.
Example: Enter “Hawai*” in the Search for field. This means that any number of “i's”, 
including none at all, may follow “Hawa”. Thus the words “Hawa”, “Hawai” and 
“Hawaii” will be found.

• The wildcard for a single character is the period or dot (.). This is equivalent to the 
wildcard '?' in file names.

• Combining the above two rules, the wildcard for several unspecified characters in 
succession is '.*' (period and asterisk). This is equivalent to the wildcard '*' in file names.
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• A paragraph end can be found with the dollar sign ($), and the first character at the 
beginning of a paragraph with the string '^.' (caret and period).

• Regular expressions may only be searched within paragraphs.

There are many other wildcards that can be used that are listed in Help > OpenOffice.org 
Help with a search term of “Regular expression”. This complete List of Regular
Expressions is included in this document.
If you need more information of Regular Expressions, please see 
http://www.opengroup.org/onlinepubs/009695399/basedefs/xbd_chap09.html.

Searching Backward
When locating a frequently appearing word in a long text, the user might click find once too 
often by mistake. Check the Backward box and click again on Find to return to the 
location of the previously found item. 

Current Selection Only
Check the Current selection only box option to limit the search rather than causing the 
entire document to be searched. The search will be restricted to the lines that are highlighted 
in the document. If text is selected before activating the Find command, the search will 
automatically take place only within that selected range. 

Searching for Styles
Quickly reformat all or part of a text using this feature. For example, text formatted with the 
Style “Heading 2” can be replaced with the Style “Heading 3.” Select the Paragraph 
Style in the list box under Search for. Then select the new Paragraph Style in the Replace 
with field. Start the replacement process with the Replace button. All matching styles found 
in the text will be displayed in sequence. The user can decide each time whether or not to do 
the single replacement, replace all matching styles found in the text, or to cancel the process. 

Searching for Text Attributes
Select Attributes to open a dialogue from which to select those text attributes to be 
employed to search within a document. OpenOffice.org then finds all attributes that differ 
from the format of the Paragraph Style. For example. in this dialogue, if the Font Weight 
checkbox is selected, the program can find all words that have a heavier font than normal. 
These could be words that have has the Bold attribute applied, either through direct or 
indirect formatting, or that have been highlighted with a font previously defined as a bold 
font, such as ones containing the words "Bold" or "Black" in their name. By default, Find 
searches only for direct attributes. However, after searching for the attributes, one may enable 
the Including Styles checkbox in the groups section of the Find & Replace dialogue where 
Search for Styles was previously. Then, the search extends from the direct attributes we 
selected previously to include indirect attributes, such as. those set with styles. 
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Searching for Special Formats 
By clicking the Format button, one opens a dialogue from which to select the specific 
formats in the search. For example, if one has manually centered a few lines in the text, find 
them using the options of Format in the Find & Replace dialogue. Now let's say that the 
found attribute must be replaced with another, to do this take the following steps:

1. Position the cursor in the Replace with field. 

2. Click the Format button. 
3. Choose the replacement attribute. 

The chosen attributes are listed under the Search for and Replace with fields. If no 
replacement is indicated for the attribute found in the text, the default settings are 
automatically applied. 

Similarity Search
This function seeks not only for the search term, but also for similarly typed words. As 
needed, finetune the degree of similarity by clicking the button immediately to the right of 
the “Similarity search” checkbox. 

List of Regular Expressions
This list is also in Help but is included here as a convenience.

Character Result/Use
. Represents any single character. The search term "sh.rt" finds both "shirt" and "short".
^ Using ^Peter will find this search term only if it appears at the beginning of a paragraph. 

Special characters (for example, blank spaces and characteranchored frames) at the 
beginning of a paragraph are ignored.

$ This symbol represents the paragraph mark for use in a regular expression. For example, 
using $ will only find the search term if it appears at the end of a paragraph. So, if one 
searches for, say, Peter at the end of a paragraph, enter Peter$ in the Search for box. 
Special characters (for example, blank spaces and characteranchored frames) at the end 
of a paragraph are ignored.

^$ Enter ^$ in the Search box to find empty paragraphs. 
* Finds zero or more of the character immediately in front of the "*". For example, 

"Ab*c" finds "Ac", "Abc", "Abbc", "Abbbc", and so on.
+ The character before this symbol must appear at least once: "AX+4" finds "AX4", 

“AXX4”, but not "A4".
? Finds zero or one of the characters in front of the "?". For example, "Texts?" finds the 

words "Texts" and "Text".
\ Only finds the character (no digits) that is specified. Used to turn off any special 

interpretation of the character by OpenOffice. For example, if one searches for “\*+” , 
”*”, “**” and “***” will be found. That is, the regular expression interpretation of '*' is 
turned off only for that one instance.
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Character Result/Use
\n Finds a hard row break that was inserted with Shift+Enter. To change row breaks into 

paragraph breaks, enter \n in the Search for and Replace with boxes, and then click the 
Replace all button.

\t Finds a tab space. Users can also use this expression in the Replace with box.
\> Only finds the search term if it appears at the end of a word. For example, "book\>" 

finds "checkbook", but not "bookmark".
\< Only finds the search term if it appears at the beginning of a word. For example, 

"\>book" finds "bookmark", but not "checkbook".
^$ Searches for empty paragraphs.
^. Searches for the first character of a paragraph.
& Use this character in the Replace with box to add the characters that matched the search 

criteria when a replacement is made.
For example, if one enters "window" in the Search for box and "&frame" in the 
Replace with box, the word “window” is replaced with "window frame".
Users can also enter a “&” in the Replace with box to modify the Attributes or a 
different Format of the search criteria  entered in the Search for box.

[abc123] Finds the characters that are between the brackets.
[ae] Finds the characters that are between a and e.
[aehx] Finds the characters that are between ae and hx.
[^as] Finds all characters except for as
\xXXXX Finds a special character based on its fourdigit hexadecimal code (XXXX).

The code for the special character depends on the font used. Users can view the codes 
by choosing Insert  Special Character.

| Finds the search terms that occur before and after the "|". For example, "this|that" finds 
both "this" and "that" in the  search.

{2} Defines the number of times that the character in front of the opening bracket occurs. 
For example, "tre{2}" finds "tree".

{1,2} Defines the number of times that the character in front of the opening bracket can occur. 
For example, "tre{1,2}" finds both "tree" and "treated".

( ) Defines the characters inside the brackets as a reference. One can then refer to the first 
reference in the current expression with "\1", to the second reference with "\2", and so 
on.
For example, if the text contains the number 13487889 and one searches using the 
regular expression (8)7\1\1, "8788" is found.

[:digit:]? Finds a single digit number. To find a number with more than one digit, use [:digit:]*.
[:space:]? Finds white space such as spaces and tabs.
[:print:]? Finds printable characters.
[:cntrl:]? Finds nonprinting characters.
[:alnum:]? Finds alphanumeric characters (numbers and text characters).
[:alpha:]? Finds alphabetic characters.
[:lower:]? Finds lowercase characters if Match case is selected in the Options area.
[:upper:]? Finds uppercase characters if Match case is selected in the Options area.
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Note: The longest possible text within the paragraph is always found. If the paragraph contains the text “AX4 A4”, 
the search term “A.*4” finds the first A to the last 4, i.e. “AX4 A4”.

Note: The '()' and '\1..\9' reference RE combinations will be familiar to programmers who have used standard RE's, 
however the OpenOffice.org version is confined to the search term. The '\1..\9' cannot be used in the replace term as 
would normally be expected for standard REs. Use '&' to transfer the entire matching search term to the replace 
term
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Digital Signatures and Printing or Exporting Documents
There are many print options for putting documents on paper, including printing to file. Other 
ways of distributing documents are to publish in HTML format, XHTM, TeX, bib, docbook 
or as PDF files. These should be familiar to most users as they have been a part of 
OpenOffice.org for some time.
What is new is that, as of OpenOffice.org 2.0.4, export to PDF has some added security 
features beyond digital signing. These are encryption and some digital rights management 
(DRM) features such as copy, printing options, changes options and accessibility. For more 
information on PDF export, see the specification. 
The following graphic shows these options. 

With the new PDF Export security tab the user has the following possibilities:
● create a PDF document that can be opened only with the correct password, once 

passwordopened the user can do whatever it likes with it (see Only “open password”, 
no restriction);
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● create a PDF document that can be opened only with the correct password, but with 
restricted permissions; for example the document cannot be printed, or any of the 
selections from 6 to 9 in  ( see “open password”, restricted);

● create a PDF document that can be opened by anyone, but with restricted 
permissions; for example the document cannot be printed, or any of the selections.

● create a PDF document without restrictions, everything is allowed (see PDF without 
restriction).
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Only “open password”, no restriction
To create a PDF document that can be opened by users having the correct password and to 
enable those users to do anything they want with the PDF, do as follows:

1. Select “Encrypt the PDF document”
2. Click “Set Open Password” to set and confirm the password; the password can be 

empty or up to 32 characters long;
3. Deselect “Restrict permission” 

Note: An empty open password means that the PDF document can be opened by anyone. 

“open password”, restricted
1. Select “Encrypt the PDF document”
2. Click “Set Open Password” to set and confirm the password; the password can be 

empty or up to 32 characters long.
3. Select “Restrict permission” to set and confirm the password. As above, the password 

can be empty or up to 32 characters long.
4. Select the permissions as desired, see Permissions available. for a description of 

available permissions.

Permission restricted only
1. Deselect “Encrypt the PDF document”
2. Select “Restrict permission” to set and confirm the password. As above, the password 

can be empty or up to 32 characters long.
3. Select the permissions as desired, see Permissions available. for a description of 

available permissions.

PDF without restriction (Default behaviour)
1. Deselect “Encrypt the PDF document”
2. Deselect “Restrict permission”

Permissions available
The following is a description of the available permissions. These will only effect the PDF 
document wheref the chosen viewer respects the settings.

Printing
Point (6) in . The user can choose if the document can be printed or not. The “Not permitted” 
selection will disable the printing.

Changes
Point (7) in . The changes allowed to the PDF document can be selected here, they are self 
descriptive.
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The “Not permitted” selection will disable all the changes (but copy, see Enable copy).

Enable copy
Point (8) in . Enable copy (selection) of  text and images to be used in other documents 
(through paste). It can be selected independently from the other permissions.

Enable accessibility
Point (9) in . Enable the use of accessibility tools with the PDF document. It can be selected 
independently from the other permissions.

Programming PDF Security in Macros 
The following table lists the property values that can be used in programming. For more 
information on programming with macros, see Chapter 10.
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Name Type Default  
value

Notes

EncryptFile boolean false specifies that the PDF document should be 
encrypted while exporting it, meaniful only if 
the “DocumentOpenPassword” property is not 
empty.
It corresponds to item (1) in .

DocumentOpenPassword String empty the password that a user will need to read the 
exported PDF, should be in clear text. Must be 
used with the flag “EncryptFile” above.
It corresponds to item (2) in .

RestrictPermissions boolean false specify that PDF related permissions of this 
file must be restricted. It is meaningfull only if 
the “PermissionPassword” property below is 
not empty.
It corresponds to item (4) in .

PermissionPassword String Empty the password that a user will need to change 
the permissions of the exported PDF, should be 
in clear text. Must be used with the flag 
“RestrictPermissions” above.
It corresponds to item (5) in .

Printing int 2 specifies what printing is allowed:
• 0 meaning that the document cannot 

be printed
• 1 meaning the document can be 

printed at low resolution only,
• 2 meaning the document can be 

printed at maximum resolution.
It corresponds to item (6) in .

Changes int 4 specifies the changes allowed to the document.
• 0 meaning the document cannot be 

changed
• 1 meaning inserting, deleting and 

rotating pages is allowed
• 2 meaning filling of form field is 

allowed,
• 3 meaning filling of form field and 

commenting is allowed,
• 4 meaning all the changes of the 

previous selections are permitted, 
with the only exclusion of page 
extraction.

It corresponds to item (7) in .
EnableCopyingOfConte
nt

boolean true specifies that the pages and the document 
content can be extracted to be used in other 
documents (copy from the PDF document, 
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Name Type Default  
value

Notes

paste elsewhere).
It corresponds to item (8) in .

EnableTextAccessForA
ccessibilityTools

boolean true specifies that the document content can be 
extracted to be used in accessibility 
applications.
It corresponds to item (9) in .
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Chapter 3: Managing Text Documents With Writer 
In this chapter, the user will learn about the OpenOffice.org word processing module, called 
Writer. Starting with the basics, it will introduce the more sophisticated functions and, lastly 
provide an explanation of some of the templates and sample documents that are part of the 
distribution. 
Remember to examine other chapters in the guide for other important information on 
working in Writer: 
• Usage of menus, windows, floating toolbars et cetera is described in Chapter 1.

• Information about customizing the user interface of OpenOffice.org, working with data 
sources, e.g. for form letters, and about the revision marking function is contained in a 
separate chapter “Advanced Techniques”. 

The OpenOffice.org Writer Functions
This section contains a brief overview of the functionality and capabilities of OpenOffice.org 
Writer.

Writing
Writer helps users to create all sorts of written documents. One can produce personal letters, 
form letters, brochures, faxes, and even professional manuals. Documents that are used often 
can be saved as templates, for example, an invoice form. Spellcheck and thesaurus functions 
are at one's disposal. If desired, have the AutoCorrect and hyphenation functions active while 
typing. 
There is no restriction to the length of a text document in OpenOffice.org. Use the Navigator 
to move around easily and quickly within the document. OpenOffice.org Writer comes with a 
variety of templates for almost every purpose. Also users can create their own using the 
Wizard. 

Designing and Structuring
OpenOffice.org offers a wide variety of options to design documents. Use the Styles and 
Formatting window to create, assign and modify styles for paragraphs, individual characters, 
frames and pages. In addition, the Navigator can help create structured texts and also allows 
modification of the structure, for instance, by shifting paragraphs from one position to 
another. 
Additionally, various indexes and tables can be created in text documents. One can define the 
structure and appearance of the indexes and tables according to individual needs. Live 
hyperlinks and bookmarks allow jumping directly to the corresponding items in the text. 
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Desktop Publishing with OpenOffice.org Writer
OpenOffice.org Writer contains numerous functions to assist in creating perfectly styled 
documents. Text can be formatted multicolumnar, and have text frames, graphics, tables, etc. 
integrated into it. The text frames can be linked all over the place, even beyond page limits to 
create a newspaper format. Functions such as making lines registertrue, flow of contours 
through and around graphics, and defining of characters, paragraphs and tables in any colour 
complement the tools to lend documents a professional look. 

Calculations
Text documents in OpenOffice.org have an integrated calculation function that helps one to 
execute sophisticated calculations or logical links. Tables in a text document can easily be 
created in order to perform calculations. 

Creating Drawings
Draw, vector drawing tool, lets users create drawings, graphics, legends, et cetera directly in 
text documents.

Inserting Graphics
Pictures with different formats can be inserted into a text document, including graphics with 
a JPG or GIF format. The most common formats can be edited directly in a text document 
with the image editor. In addition, the Gallery provides a collection of clipart graphics 
organized by theme. 

Customizable Program Interface
The design of OpenOffice.org's program interface is such that each user can configure it 
according to individual preferences. The various windows (Styles and Formatting window, 
Navigator, et cetera) can be positioned as floating windows anywhere on the screen and some 
can be docked to an edge. Visible icons and menus can be customized as well. 

Drag&Drop
The draganddrop feature enables users to work even more quickly and efficiently with text 
documents in OpenOffice.org. For instance, one can drag graphics directly from the Gallery 
into an active document. 

Extensive Help Functions
The program provides an extensive Help function which serves as a reference guide to the 
program elements in OpenOffice.org as well as includes a variety of instructions for simple 
and complex tasks. 
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The OpenOffice.org Writer Window

Windows® of OpenOffice.org Writer
The above graphic shows the various windows and toolbars available for use in managing 
documents and where their associated icons are located. For clarity, the windows, listed 
counterclockwise, are Insert floating toolbar, Insert Fields “submenu, Insert Object 
floating toolbar, Form Functions floating toolbar, Draw Functions floating toolbar, 
Navigation Window, Navigator Window and Styles and Formatting window Window.
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Entering and Formatting Text
There is no prescribed sequence in which to work. One can enter text and, let us say, 
underline it or italicize it while typing or choose to do this later. Users can also decide 
whether or not to split a section of text into two columns immediately or to delay the action. 
Text never has to be deleted and retyped simply because formatting needs changing.
Basically, to edit text, first select it and then choose the relevant command, such as the one to 
format the text in italics. There are several ways of selecting text, for example, using the 
arrow keys whilst holding down the Shift key, or with the mouse whilst keeping the mouse 
button depressed. Often there are different ways of choosing a command, for example, with a 
menu command, with a toolbar icon or with shortcut keys. 

Entering New Text

To enter new text:
1. Open an existing text document or create a new one.
2. Enter text using the keyboard.

When special characters, such as the copyright symbol or accented characters that are not 
available on the keyboard are to be entered, select Insert > Special Character and chose 
what is needed from the table.

3. Press Enter to begin a new paragraph.

Line breaks
Users never need to worry about line breaks as the software inserts these automatically. Only 
press Enter at the point to start a new paragraph.

Automatic correction
OpenOffice.org Writer includes a configurable autocorrection tool that can make various 
corrections while typing. For example, automatically capitalizing the start of every sentence.

Word completion
The automatic word completion function helps when entering text. For example, let's say, 
there's an often used long word. In this case, Writer suggests a word it recognizes as 
matching what has been typed so far. If the suggestion is what is wanted, Press Enter (or 
define another key) to accept it.

Inserting Text
1. Open an existing document.
2. place the cursor at the point where text is to be added using either the mouse or the arrow 

keys, and enter the new text.
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Insert mode is enabled by default, thus any text, following the insertion point, is shifted as 
new text is entered. To overwrite the existing text at this point, select Overwrite mode by 
clicking the INSRT field in the status bar as shown below.

Switching Between Insert Mode and Overwrite Mode

Using the keyboard:
If the keyboard has an Ins key, press it to toggle between overwrite mode and insert mode. 
The current mode is displayed on the status bar.

Using the mouse:
On the status bar, click in the fourth field from the left, which indicates the current mode, to 
switch to the other mode:

• INSRT
Insert mode is enabled. The text cursor is a blinking vertical line. Click in the field to 
enable overwrite mode.

• OVER
Overwrite mode is enabled. The text cursor is a blinking block. Click in the field to enable 
insert mode.

default layout of the status bar:

Note: the area that is clicked to change from insert to overwrite

After clicking

Entering Text Anywhere on a Page
Writer enables one to enter text at any position within the type area in the text document. 
This is the direct cursor function:

1
.

Click the Direct Cursor on/off icon on the Tools toolbar. Clicking the icon 
turns the direct cursor on and off. When the icon appears pressed, the direct 
cursor is enabled.

2
.

Click on a free space in the text document. The shape of the mouse pointer 
shows how the text that is entered will be aligned.

Align Left
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Centre Align Right
3
.

Enter the text. OpenOffice.org automatically inserts the requisite number of 
blank lines, tabs and spaces.

Selecting and Deleting Text
Some basic steps to start.

Deleting characters
• To delete one character to the left of the cursor, press Backspace (above the Enter 

key). 
• To delete one character to the right of the cursor, press the Delete key (may be labelled 
Del).

Deleting text

Selecting text to delete with the mouse
1. Leftclick to set the cursor on the first character to be deleted.
2. Keeping the mouse button depressed, drag the pointer to the last character to be deleted. 

The characters will be highlighted.
3. Release the mouse button.
4. Press the Delete key to delete the selected text.

Selecting text to delete with the keyboard
1. Use the arrow keys to go to the first character to be deleted.
2. Hold down the Shift key.
3. Using the arrow keys, move the cursor to just after the last character to be deleted.
4. Release the Shift key. The text is highlighted.
5. Press the Delete key to delete the selected text.

Note: To put the selected text into the clipboard for use later or to put elsewhere in the document, press 
Ctrl+X rather than Delete. This “cuts” out the text and places it on the clipboard. To paste it back in,  
wherever and as often as desired, “press Ctrl+V when the cursor is set to the correct location.

Deleting nonadjacent pieces of text.
1. Press Ctrl and keep it pressed.
2. Leftclick “to set the cursor at the first character of the first piece of text to be deleted.
3. Press the left mouse button and drag the pointer to the last character of the text to be 

deleted.
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4. Release the mouse button and the Ctrl key.
5. Repeat steps 1 to 4 for each piece of text to be deleted.
6. Press the Delete key to delete the selected text.

Status bar uses

Setting the Viewing Zoom Factor

Note: the area that is Rightclicked to change the Zoom factor

By rightclicking in the area shown above, the user can select the display Zoom factor for the 
document. The optimal setting is particularly useful when the Styles and Formatting window 
or Navigator are docked and opened, off and on, during a session in that the full width page 
of text is always displayed.

Editing or Activating Hyperlinks

Clicking in this field on the status bar switches the text hyperlinks in the document from active (HYP) to edit 
(SEL).

Display Effect
HYP Click a Hyperlink to load the corresponding URL.
SEL Click a Hyperlink text and edit it as with normal text.

To edit the URL instead of the Hyperlink text, the status bar must have HYP displayed in this 
field. Point to the Hyperlink, then click and hold down the mouse button as the Hyperlink is 
dragged to the Hyperlink Bar. Both the text and URL can be edited from here. 
If the Hyperlink is inserted as a button rather than as text (see Link button), the Hyperlink 
can only be editeid if one changes the properties of the control field: Select the button, open 
its context menu and choose the Control command and then edit the text on the button and 
the URL from the Properties dialogue of the button.
Click a hyperlink in a document, brings up a dialogue asking to open the linked document.

Applying Various Fonts 
Modify the Paragraph Style to permanently change the font size and style for all paragraphs 
with that particular paragraph format. First, position the cursor in the text that to be modified 
and select the command Edit Paragraph Style in the context menu. 
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The Paragraph Style dialogue opens, with various tabs. Click on the Font tab and specify 
the type, size, and style of the font. 

Note: If one wants to emphasize a particular passage in a letter, simply select the text and click the Bold or Italic 
icon. To format only a single word, simply place the cursor anywhere in the word and click Bold or Italic. 

Make any other necessary changes, then click the Save Document icon and close the 
document template. 

Note: When creating a template, remember not to type a text for a particular letter. The main purpose of a 
template is to define the general layout of a document. Use the documents based on the template to add text for  
a letter. 

Keyboard Navigating and Selection in Writer
Navigating and selection using the keyboard is done using the arrow keys. One can also use 
Home, End, PgUp and PgDn. Certain keys have different functions depending on whether 
they are simply pressed or are used in combination with the Ctrl key. The following table 
provides an overview of the keys used for navigation.

Key Function +Ctrl key
Right/left arrow 
keys

Go one character to the left or right Go one word to the left or right

Up/down arrow 
keys

Go one line up or down Move the current paragraph up or 
down

Home Go to the beginning of the current line Go to the beginning of the 
document

Home In a table Go to the beginning of the current cell 1. Go to the beginning of the current 
cell 2. Go to the beginning of the 
table 3. Go to the beginning of the 
document

End Go to the end of the current row Go to the end of the document
End In a table Go to the end of the current cell 1. Go to the end of the current cell 

2. Go to the end of the table 3. Go to 
the end of the document

PgUp Scroll one page up the screen Switch to the header and back
PgDn Scroll one page down the screen Switch to the footer and back

Inserting Special Characters
This is how to insert special characters (such as check marks, boxes, telephone symbols etc.) 
in text:

• Select Insert > Special Characters to view the selection of characters available.
• In the large selection field select the desired character or more than one by clicking with 

the mouse or by navigating by keyboard in succession. The characters are displayed at the 
bottom of the dialogue box. Upon closing the dialogue with OK, all displayed characters in 
the selected font are inserted in the current document at the cursor.
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• If a special character is required in any text input field (such as in the URL field of the 
Standard toolbar or in the input fields in the Find&Replace dialogue), press 
Shift+Ctrl+S to pop up the Special Characters dialogue. 

Inserting Protected Spaces, Hyphens and Conditional Separators

Nonbreaking spaces
To prevent two words from being separated at the end of a line, press the Ctrl key while 
“typing the space between the words. This is important, for example, between a title and the 
person's name.

Nonbreaking hyphen
An example of a nonbreaking hyphen would be in a company name such as AZ. Obviously 
having A appear at the end of a line and Z at the beginning of the next line is not usually 
desired. To solve this problem, press Shift+Ctrl+ minus sign. In other words, hold 
down the Shift and Ctrl keys and press the minus key.

Hyphen, emdash and endash
To enter longer dashes, add the character sequences and replacement under Tools > 
AutoCorrect > Replace. 

NOTE: There is a Replace dashes under the Options tab but be aware that this selection is for creating paragraph 
borders when a sequence of three hyphens or three equals signs are entered these are replaced by a single line 
border and a double line border respectively.

Here is a method to use:
1. Open a text document and place the cursor in a convenient location.
2. Use the Special Character dialogue to find the long (em) dash to use and insert it in the 

document.
3. Copy the character.

4. Open Tools > AutoCorrect > Replace.
5. Paste the dash character into the With field
6. Enter the desired character sequence into the Replace field. For example, two hyphens 

( ) to trigger the replacement.
Now there is a shortcut that defined that automatically replaces the userdefined input 
sequence with the optional dash selected. This dash can also be in another font.

Manual Hyphenation
Although OpenOffice.org offers automatic hyphenation by entering a separator inside a word, 
users can override this feature by entering Ctrl+ minus. Thus the word can be 
hyphenated at the end of the line regardless of the state automatic hyphenation for this 
paragraph.
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Emphasizing Text
There are many ways of emphasizing text in a special way. Here are some of them:

• Use the icons in the Object bar for regular Formatting needs. For example, change the 
text to bold or to another font style, change the text colour and background, or centre the 
text.

• Whole paragraph can be emphasized using borders. Place the cursor in the paragraph that 
is to be emphasized, rightclick to its context menu and select Paragraph, then click on, 
for example, the Borders tab. At this point,a border may be selected to frame the 
paragraph, and also with shadow shading, if desired. If necessary the distance between the 
border and the paragraph text can be adjusted under Spacing to contents.

• Using a Text Frame, provides the following possibilities: 

a) Text can receive a border
b) Text can be placed outside of the text margin on the side of the page.
c) Text frames can be linked when text should flow from one frame to another.

• Choose Format > Paragraph > Background to apply a background colour to the 
paragraph.

• Use the Draw Text “function: Open the Draw function toolbar (on the Standard 
toolbar), select the Text icon , drag open a frame and enter the text. This text can be 

positioned as desired, which includes rotating at various angles, or curving and slanting 
the text with the help of Format > Object > FontWork.

Changing the colour of Text
Click the little down arrow of the Font colour icon in Writer and other modules to obtain a 
floating toolbar from which to choose a colour from the range of colours. Alternatively, long
click the icon itself.

Font colour icon. Note the colour name is shown in the bar at the bottom.
When using a shortclick with no text selected, the mouse pointer changes its appearance to a 
tilted paint can pouring paint. Drag the hot spot of the mouse pointer across the target text 
area. This text area now takes on the selected colour. The function remains active for as long 
as the icon is active (looks depressed), or until simply clicking without dragging, or until the 
(Esc) key is pressed.

Rotating Text
Text can be rotated by entering it into a text frame as follows:

OpenOffice.org User Guide for 2.x 66



Chapter 3: Managing Text Documents With Writer 

Open the Show Draw Functions floating toolbar on the Standard toolbar.

On the Draw Functions toolbar, click on the Text icon. The mouse pointer 
changes to a '+' which indicates that a text frame may defined and opened.
Open up a text frame, release the mouse button and type in any text.
Click on the edge of the text frame. Now see the Draw Object Bar, which 
contains the Object Rotation Mode icon. appears. Click on it. 
Now, if one clicks on one of the handles in the corners of the text frame and 
drag the mouse, the whole text frame turns with the text.

From the context menu of the Text Frame, a user can start the Position and Size dialogue by 
selecting the Rotation tab. This allows the precise angle of rotation to be defined 
numerically.

Defining Borders
Borders of pages, paragraphs, tables and other objects can be defined in two places:

• Choose Format > (object name) > Borders where <object name> is page or 
paragraph.

• In tables, use the Borders floating toolbar on the object bar.

Choose Format from the menu bar, Borders tab page
To set a border, select Format > Page > Borders or Format > Paragraph > Borders which 
opens the following dialogue:
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On the left of the dialogue panel is the Line arrangement group. Notice that the four outer 
edges of the Userdefined area are marked with small angles. To edit an outer margin, click in 
the appropriate position between the small angles. Above this area are four predefined 
Default borders which may also be used. 
In both cases, the selected border elements will be indicated by black triangles. Now now 
choose a line style or a colour, it will be applied to the selected part of the border.

Note: If an empty line is selected in the preview, that is to say, if, one of the three conditions “Line”, “Gray Line” 
and “No Line”, The condition “No Line” appears, This means that the relevant part of the border will be deleted.

Clicking repeatedly on an element in the Borders dialogue switches between three 
alternative modes:

The element is displayed as a line Clicking OK will apply the format to the element.

The element is displayed as a thick 
black line

If OK is clicked, the object remains unchanged.

The element is not displayed Clicking OK deletes the element.
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Use the Borders floating toolbar with Tables
Suppose the following table border is required for a document:

Berlin New York  London
Country Germany USA Great Britain
River Spree Hudson Thames

Population > 3 Million Citizens  > 7 Million Citizens  > 6 Million Citizens

1. Place the cursor at the position in the document where the table is to be inserted.

2. Choose Insert > Table to open the Insert Table dialogue, and insert a table of the 
required size, e.g. 4 columns and 3 rows.

3. Select the whole table by pressing CtrlA twice, then click the Borders icon on the 
object bar. On the floating toolbar click the icon at top left, which means “No Border”.
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4. Now, with the mouse, select the whole of the first row, open the context menu and choose 
Table to open the Table Format dialogue.

5. Open the Borders tab page.

6. In the line field select the required line thickness, e.g. 2.50 pt.
7.  First select full bordering from the Defaults

8. In the large Line arrangement field, click once in the area between the two top angles 
(see illustration) to remove the top line and then on OK.

8. Now select the second row of the table and again open the Table Format dialogue by 
choosing Table in the context menu.

9. Under Line arrangement , click the areas between the two bottom angles (see 
illustration) to remove the bottom line between the rows and then on OK.

9. Now select the third row of the table and again open the Table Format dialogue by 
choosing Table in the context menu.

10.Under Line arrangement , click the areas between the two top angles (see illustration) to 
remove the top line between the rows and then on OK.

10.In the Style field select the required line thickness and click OK.
11.Now the table is finished.
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Superscripts and Subscripts
Users have the following options for superscripting or subscripting text:
1. Use the keyboard shortcuts Ctrl+Shift+P and Ctrl+Shift+B.

2. Choose Format > Character > Position.
3. Use the Text Object toolbar Superscript/Subscript buttons. If these buttons are not visible 

in the toolbar, expose them using the method described under Changing the Visibility of
Buttons on Toolbars.

1. Making text superscript/subscript while typing
Suppose one wants to type 1 m² (superscript 2):
1. Type the character “m”.
2. Press Ctrl+Shift+ P.  Ctrl+Shift+P is the keyboard shortcut for superscript text.
3. Type the 2.
4. Press the keyboard shortcut, Ctrl+Shift+P, again to disable superscripting.

Note: At the end of a paragraph, an easier way to disable superscripting is to press the 
right arrow key once.

5. Continue entering the text.
Suppose that entering H2O with a subscript 2 is wanted:
1. Type the H.
2. Press Ctrl+Shift+B. Ctrl+Shift+B is the keyboard shortcut for subscript text, 
Ctrl+Shift+P for superscript text.

3. Type the 2.
4. Press the keyboard shortcut again.

There is an even easier way when the cursor is at the end of a paragraph: Press the right 
arrow key once.

5. Type the O.
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Applying subscripts/superscripts retrospectively
Let's say that while proofing text, the text H2O needs to altered to include a subscripted “2” 
giving (H2O). To do so, use either the key shortcut method, described above, or use this 
method method via the menu command:
1. Highlight the character that should be in subscript/superscript. For example, select the 2.

2. Choose Format > Character. This opens the Character dialogue.
3. Click the Position tab.

4. Select Subscript and click OK.
The 2 now appears in subscript.

Writing in Uppercase or Lowercase
Writer has the following methods for reformatting text in uppercase or lowercase.

• To display in uppercase: Highlight the text and choose Format > Character > Font 
Effects tab, and under Effects select Capitals.

• Displaying in lowercase: Highlight the text and choose Format > Character > Font 
Effects tab, and under Effects select Lowercase.

• Converting to uppercase: Highlight text, then choose Format > Case/Characters > 
Uppercase or rightclick and make the same selection form the popup menu.

• Converting to lowercase: Highlight text, then choose Format > Case/Characters > 
Lowercase or rightclick and make the same selection from the popup menu.

Moving Text Sections in Documents
1. Select the text that to be moved.
2. Place the mouse pointer in the selected text, then press the mouse button and keep it 

pressed.
3. Drag the mouse until a symbol appears next to the pointer, indicating that the selected area 

will be moved. In addition, a gray text cursor moves with the mouse pointer, indicating 
where the selection is to be inserted.

Mouse Pointer Shape  Meaning
Moving

Copying

Creating a link
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To copy the text, rather than move, it, press Ctrl while performing the actions described 
above. As shown, the action is indicated by a plus sign next to the mouse pointer. One can 
press and release the Ctrl key as often as needed   the action applies to the condition 
prevailing at the time the mouse button was released.

Resetting Font Attributes While Typing
Users may apply direct formatting while typing text and later decide to reset all formatting 
and continue entering text using the default format. Text is entered using direct character 
formatting, to reset the formatting to default, press the right arrow key once which causes the 
prior text to revert to the default Paragraph Style. Now, continue entering text at the end of 
the current paragraph. 

Example procedure for resetting Font Attributes
Suppose one wants to type the words “bold italic”, and set the last two words to 
bold italic while typing. First type Enter this in, then click on the Bold and 
Italic icons on the Object Bar followed by entering bold italic. To continue 
with normal setting,, simply press the right arrow key once and finish the paragraph. 
This is simpler than clicking on the two icons again. 

Quick Formatting Using the Adjacent Paragraph Format
When there are two consecutive paragraphs with different paragraph formats that should be 
formatted the same way, do it quickly with the following method: 
a) Delete the paragraph mark between two paragraphs.
b) Press Enter.
Both paragraphs now have the same format with the same Style.

Note: to see paragraph marks, enable View > Non printing Characters
Delete paragraph marks in the following two ways:

1. Go the end of the first paragraph and press the Delete (Del) key. This action merges the second paragraph 
into the first (known as ”deleting to the right”). To turn the text back into two paragraphs, Press the Enter key 
twice and the second paragraph has the same format as the first. 

2. Go to the beginning of the second paragraph and press Backspace (usually above the Enter key). the 
second paragraph merges with the first paragraph but keeps its format (known as “deleting to the left”).  
Pressing Enter creates two paragraphs but both have the format of the second paragraph. 

Using Sections
Sections in OpenOffice.org Writer text documents isolate blocks of text for special purposes. 
One example of their use in Writer is in preparing complete documents using Master 
documents. Another is in preparing contracts from a set of fixed codicils. 
The following are the ways that sections can be incorporated in a Writer document:
• Sections of text that have a different number of columns than the master text.
• Sections protected from further editing.

• Sections that are only to be shown under certain circumstances or hidden.
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• Sections that are to be inserted into a document as files or parts of files.

• Sections that can be incorporated into other text documents via DDE

A section must consist of at least one paragraph. When selected text is defined as a section, it 
automatically ends with a paragraph break.
Another text document may be inserted as a section within a text document. A section from 
another text document can also be inserted as a section. Sections can be linked, within a 
single document, to other locations. To insert a new paragraph immediately before or after a 
section, place the cursor at the very beginning or end of the section and press Alt+Enter.
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Sections and Columns
• Multicolumn section: A section can contain other sections. This feature allows the user, 

for example, to create a twocolumn section on a page of text, and then create a three
column section within that section. 

Multicolumn page: The page format (Format > Page > Columns), which always applies to 
all pages with the current Page Style, is independent of the sections.

Multicolumn frame: Frames containing columns of text may be inserted. These can be 
moved freely around the page (from Tools toolbar, longclick to open Insert floating toolbar, 
click Insert frame icon). For these frames, for example, one can select that the text in the 
frame be positioned a certain distance from the edge of the frame (Choose Format > Frame 
> Wrap). 

Inserting Sections
1. Place the cursor at the point to insert the new section, or select the text that is to form a 

new section.

2. Choose Insert > Section. In the dialogue, define other settings for the section.

3. Click Insert.
Other documents or sections from other documents can be inserted. In this case, Links must 
be checked. Enter a file name in the text box, or click “...” to search for a file. Select a 
named section of the document in the Section pulldown list. 
When opening a document that contains linked sections, a popup asks the user to update 
these sections. If the answer is yes, the current versions of the linked sections will be 
updated. 
Under Windows®, the DDE method can be used to keep inserted sections up to date with the 
current status of the original files. Sections can also be used as files in HTML documents. 
The inserted sections are automatically updated when OpenOffice.org loads the relevant 
HTML document again. Web browsers show the content of the sections as at the time the 
content was saved as an HTML document. 

Editing Sections
Edit the sections in the text document by choosing Format > Sections. This dialogue allows 
the user to protect sections, unprotect sections, reveal hidden sections, change the conditions 
and remove sections; that is turn them back into normal text. 
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Formatting Text With and Without Styles
Plain text can be too bland unless one applies visual effects to it, such as giving overall 
structure to the text, emphasizing individual words, quotations or references or breaking up 
solid areas of text. Thus the user should consider giving special formatting to sections of text. 

Direct Formatting or Formatting With Styles
When working with Writer, choose between direct formatting and formatting with Styles. to 
apply text attributes such as bold, italics, font type and font size.
Apply direct format by directly setting a certain attribute(s) to the selected text area. For 
example, clicking the Bold icon on the text object bar directly applies the bold format to a 
selected text area or to subsequent characters at the cursor while typing. Direct formatting is 
more appropriate for one time use. If, for example, to make a word bold, just position the 
cursor in the word and click the Bold icon. This works quickly and intuitively. 

Styles,on the other hand, apply attributes to text in an indirect manner. A Style is a labelled 
collection of default settings that format text. Indirect formatting, with the help of Styles, is 
much preferable when formatting lengthy documents in a uniform fashion. Styles do require 
some advance preparation. First create the Style, then apply the Style to the text. Both tasks 
are best done using the Styles and Formatting window. 
By way of example, let's assume that each of the headings is formatted with a 24 point 
Helvetica font but this now needs to be changed in all the headings to a 20 point Times 
font and in bold. Doing this manually requires time and patience; however, had the format 
been defined as a Style, say with the name “Head1”, that was applied to the headings in the 
document, one could simply modify the “Head1” Style, and all headings would be 
automatically changed to match the new settings. 
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The Style Concept in OpenOffice.org
Styles for characters, paragraphs, frames, numbered lists and pages (or cells in tables ) are 
always saved with the document. If wanted, one can copy the Styles of one document to 
another document and choose whether ore not to overwrite (replace) Styles of the same 
name. 
One nice feature of OpenOffice.org is that one can turn any document, including the 
Character, Paragraph, Frame, Numbering and Page Styles it contains, into a template . When 
a new document based on this template is opened, all those Styles are available to the user. 
OpenOffice.org come with predefined Styles for all document types. Thus, when a new text 
document is opened using File > New > Text Document, a new, blank document is opened 
with these fixed settings. One may add or modify the styles used with a document as work 
progresses and, if desired, this document can be turned into a default template “by saving it 
via File “> Templates > Save. Any Styles that are custom defined and are contained in the 
default template will then apply to all new documents created with this template. 

The Styles in the Styles and Formatting Window
Open the Styles and Formatting window by selecting Format > Styles and Formatting  or 
by pressing F11 or by clicking the Styles and Formatting icon on the Formatting toolbar. 
All the Styles and Formatting window functions are explained in OpenOffice.org Help. 
At the top of the Styles and Formatting window are icons for selecting the Style type to 
display. These are, from left to right: Paragraph, Character, Frame, Page, Numbering Styles, 
Fill Format Mode, New Style from Selection and Update Style.

The scrolling frame of the Styles and Formatting window lists those available styles in the 
active Style category that is specified in the list box at the bottom of the Styles and 
Formatting window. 
For example, in the graphic below, the word “Automatic” is selected in the list box. Writer 
offers the Styles that make sense in that context. To see all the Styles of a Style type, select 
“All St yles” from the list box. 

Paragraph Styles
Select Paragraph Styles, if it is not already selected, by clicking the Paragraph Styles icon in 
the Styles and Formatting window. The list of Paragraph Styles appears.
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Doubleclick an entry in the list of Paragraph Styles. The paragraph in which the cursor is 
positioned will now be formatted with that Paragraph Style. Doubleclick in the Styles and 
Formatting window on another Paragraph Style, and the formatting of the current paragraph 
changes accordingly. 
To format a paragraph as a heading, follow this procedure:
1. Type the line to be formatted as a heading and press the Enter key.
2. Set the cursor in that line.
3. Open the Styles and Formatting window. For example, by pressing the F11 key.
4. Doubleclick the Paragraph Style “Heading 1”.
This one paragraph now has the paragraph format “Heading 1”. If one wants to know 
which attributes are included in this paragraph format, click “Heading 1” in the Styles and 
Formatting window, then rightclick to open the context menu. Then choose Modify to open 
the Paragraph Style: Heading 1 dialogue, which tells everything about the properties of this 
Paragraph Style. 
When one decides not to modify this Paragraph Style, simply close the dialogue by clicking 
the Cancel button. But, this Paragraph Style should define the corresponding modifications 
then close the dialogue with the OK button. These modified settings will now apply to all 
paragraphs (old and new) having the “Heading 1” 

Paragraph Style.
Changes can also be applied the to all Paragraph Styles that are derived from the Paragraph 
Style “Heading 1”. The Paragraph Styles “Heading 1” to “Heading 10 ” are all 
hierarchically derived from the Paragraph Style “Heading”. By selecting 
“Hierarchical” from the list box at the bottom, one can immediately see where a 
selected Style fits in the hierarchy of styles. Simply put, the style immediately higher up is 
the one from which the style is derived and the following one, which is derived from the 
custom style. 

OpenOffice.org User Guide for 2.x 78



Chapter 3: Managing Text Documents With Writer 

By way of example, if one changes the left indent to 2.54 cm (1 inch) in the Paragraph Style 
“Heading”, for example, that this will change the left indent for all Paragraph Styles 
“Heading 1” to ”Heading 10 ” to 2.54 cm. Changes that users make directly in one of 
the Style dialogues have priority over the properties “inherited” from higherranking Styles. 
Right click on a style and open it with Modify to get the Paragraph Styles dialogue “and 
then choose the Organize tab. If the Linked with list box is checked, one will see from 
which Style the selected Style is derived. 
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Character Styles
In the following illustration, the Styles and Formatting window displays a list of available 
Character Styles. These Styles do not modify the whole paragraph, but only the single word 
in which the cursor is currently positioned or a selected text range. 

Use or modify the supplied Styles, or define custom Styles and use those. The best way is to 
start by selecting a Style from the Styles and Formatting window (with a single click), which 
may then be used as the starting point for creating a custom Style. One, then, merely has to 
enter the properties that are different from the selected Style since the other properties are 
“inherited” from the parent Style. 
The following table describes the base Styles and the various attributes available .

Style Type Attribute Selection
Paragraph Styles Indents and Spacing, Alignment, Hyphenation, 

Tabs, Font, Language, Initials
Character Styles Font, Font Size, Language
Frame Styles Position, Anchoring, Borders
Page Styles Header, Footer, Margins, Columns
Numbering Styles Numbering Type, Outline, Bullets, Assigning Numbering 

Styles

Hierarchical Styles
Styles can be hierarchically linked to each other. Thus, one defined Style can be derived from 
another with the result that the new Style contains only the differences from the “basic” 
Style. This is convenient, if later one changes the “basic” Style, to have all text with the 
derived Style also updated accordingly. 
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For example, start with the Paragraph Style “default”. It uses the font “Times New 
Roman” in “12” point to create a Style called “indented text” where the only addition 
is a a left indent with no other changes. Later, the user decides to change the font in “text 
body” and then the font is automatically changed in the “indented text” Style as well. 
Sticking with this example, if one redefined the left indentation in the “default”, it would 
have no effect on the paragraphs formatted with “indented text” because, in the 
hierarchy, the more closely associated format always has priority. 

Numbering Styles 
Simple bulleting and numbering in a document can be easily set using the icons on the Writer 
object bar. Likewise, the icons for bold, italic et cetera. can be used to assign direct 
formatting that is not already part of the Style. The Styles and Formatting window, too, offers 
various Numbering Styles that may be applied by doubleclicking the name of the Style. 

For more control of numbering in a document, use Format > Bullets and Numbering which 
offers several other options that may be more suitable and which can be used to create 
custom styles. 

Creating New Character Styles or Paragraph Styles
Creating a new Style on the basis of an existing Style is a straight forward process. The 
following is a stepbystep procedure with which to start: 
a) First of all, apply new, direct formatting to any characters or any paragraph, which will 

become the Style. To do this, either use the text object bar or open the Format menu and 
choose Character or Paragraph. 

b) Select the text or paragraph containing the new formatting. For words or paragraphs, 
simply position the cursor in the respective word or paragraph. 

c) At the top of the Styles and Formatting window, click the Paragraph Styles icon to create 
a new Paragraph Style. Likewise, click the Character Styles icon to create a new 
Character Style. 

d) At the top of the Styles and Formatting window, click New Style from Selection. This 
opens the Create Style dialogue. 

e) Enter a name for the new Style and click OK. 
As can be seen in the Styles and Formatting window, a new Style has been created in the 
“Custom St yles” group making it available for use for indirect formatting in documents. 
A user may also create a new Style without using an existing Style as the starting point. Here 
is a method by which to create a new paragraph style. 
a) In the Styles and Formatting window, choose Paragraph Style by clicking its icon. (the 

one farthest to the left in the Styles and Formatting windows toolbar.)
b) Call the context menu of the Styles and Formatting window (click right mouse button).
c) Choose New...
d) Enter the data for the desired Style 
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e) close the dialogue with OK.
Yet another example shows how to define a Paragraph Style for a subtitle and assumes there 
are several subtitles in the text that are candidates for formatting with a custom Paragraph 
Style.
1. Position the cursor in a paragraph in the text that to format with the new Paragraph Style. 
2. Apply a Paragraph Style to the paragraph as an initial format. This way one does not need 

to define all of the attributes oneself. For example, doubleclick on the “Heading 1” 
Paragraph Style in the Styles and Formatting window.

3. The paragraph is now formatted as “Heading 1. ” 
4. Highlight the entire paragraph. It will appear highlighted.

5. Modify the type of characters by selecting an italic font in the Character dialogue 
(Choose Format > Character > Font) or by clicking the Italics icon on the text object 
bar. 

6. In the Styles and Formatting window, click on the New Style by Example icon and enter 
a name for the new Style in the dialogue box, for example, “Head1” 

7. Click OK. 
8. Now apply the new “Head1” Paragraph Style by placing the cursor in the paragraph and 

doubleclicking the “Head1”Style name in the Styles and Formatting window. 

Where the desired Style already exists in a document, select and apply it from the Apply 
Style pulldown list on the object bar.

Creating Document Templates
For any userdefined Paragraph or Character Styles to be available in other documents, first 
create a template. It is best if one uses a current document so that the template will contain all 
the Styles wanted and needed. The following steps will help create a new template:
1. Have the documents open. If desired, delete all text from the current document, leaving 

only the Styles.

2. Call the menu command File > Templates > Save.

3. In the dialogue Document Templates, select the category into which to save the template. 
In the New Template text field, enter the name for the template.

4. click OK to complete the process of creating a template.

With the template saved, the next time when File > New > Templates and Documents is 
used to select a template for creating a document, this template will selectable from those 
available. All the userdefined Text and Paragraph Styles will then be available for the new 
document. 
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The Advantages of the Styles and Formatting Window
From the preceding instructions users should now know how to apply the styles in the Styles 
and Formatting window to text, how to apply custom Styles and how to create a template that 
uses these custom styles. This gives an advantage in that Styles do not have to be redefined 
every time. Plus one can apply Styles from one text document to another text document by 
either selecting “Format > Styles and Formatting  or by opening the Style and Formatting 
window and using Load Styles from the New Style from  Selection dropdown 
menu. In this way, the desired formatting can be applied to the  document quickly and 
easily. But the Styles and Formatting window offers still more possibilities. 

Formatting Multiple Paragraphs
In the work described above, the same Paragraph Style “Heading 1” was applied to each 
of several paragraphs. The Styles and Formatting window can save a lot of time on this task:
1. In the Styles and Formatting window, select the Style that should be applied on multiple 
paragraphs by clicking the Style once.

2. At the top of the Styles and Formatting window, click on the  Fill Format Mode 
icon. The mouse pointer changes to a symbol indicating this mode as soon as it moves back 
into the document.
3. Click once on every paragraph in the text to which to apply the selected Style.

4. Finally, to switch off this mode, click the Fill Format Mode icon again or press the 
Escape key.

Changing a Style the Easy Way
The section provides a scenario for making a style change quick and easy. To start one has 
used the custom Style made in the previous sections to format a document with the new 
“Head1” Style. However, later, the user may decide that it would look better if the headings 
were spaced with slightly wider gaps between the letters. The following gives the steps to 
making this change: 
1. Locate the longest heading formatted with the “Head1” Style “in the document and click 

three times in that heading to select the entire line.
2. Make the desired changes. To lock the character spacing, use this method: 

a) choose Format > Character, or choose Character from the context menu for 
the selected line. 

b) In the Character dialogue, click the Position tab and in the Spacing list box 
select “Expanded”. In the spin button, increase the spacing to make the heading 
wider. 

c) Close the dialogue with OK. 
3. Now additional direct formatting has been on one of the headings formatted with the Style 

“Head1”. All direct and Style formatting should now be added to the “Head1” Paragraph 
Style. This style is still selected in the Styles and Formatting window. 
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4. At the top of the Styles and Formatting window, click  the Update Style icon. All 
headings formatted with “Head1” will be  automatically reformatted with 
the modified Style. 

Styles can also be configured to adapt to any changes automatically. In the properties 
dialogue for the Style, click the Organizer tab and mark Auto Update. This allows users to 
change the formatting of, say, a paragraph formatted with this Style “and have the formatting 
of all other paragraphs with the same Style “be automatically changed as well. 

Page Styles and Page Numbers
Often text documents are created without a page number on the title page but with lowercase 
or uppercase roman numerals on the pages of the Table of Contents (one does not know how 
many yet), and to start numbering the rest of the pages with Arabic numerals. 

Note: Different Page Styles are the OpenOffice.org Writer equivalent of “section changes” in other text programs.

Page numbers are better located in footers or headers rather than in the running text, 
to“ensure that they do not change their position when text is inserted or deleted. The steps 
below show how to do this: 
1. Create a new Page Style
2. Apply the new Page Style
3. Edit the Page Style
4. Use the footer Paragraph Style to format page numbers.

Note: Do not use the Offset box under Insert > Fields > Other > Document tab to change the page number of a 
page. The offset is only used, for example, at the end of a page to display the number of the next page, i.e. to offset  
the display; it does not change the page number itself. 

The manually entered page number (in contrast to the automatically numbered page numbers) is an attribute of that  
particular page. This property is set as direct formatting in the first paragraph of that page. 

Create Page Styles
1. Open the document in which to enter or change the page numbers or begin with a new text 

document, although users will need to first enter some text and page breaks to be able to 
follow the steps described here.

2. Open the Styles  and Formatting window.
3. Select the Page Styles view in the Styles and Formatting window.
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4. Call up the context menu of one of the Page Styles and select the New... command.

One will now see the Page Style dialogue with the Organizer tab page. The cursor will be 
blinking in the Name text box in which to enter the name of the first new Page Style.

5. Enter Title Page and press the Enter key. The properties of the new Page Styles can be 
changed later.
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6. In the context menu of the Styles and Formatting window click the New... command again 
and define the Page Style with the name “Table of contents”.

7. Repeat the whole procedure again for the new Main text Page Style. Of course, the names 
used here are only meant as examples. In a real situation, one would naturally enter the 
names of choice.

With the completion of the above steps, there should now be three new Styles that have been 
created.

1. Place the cursor on the first page of the document. Doubleclick the Title page entry in 
the Styles and Formatting window.
So, now the first page is assigned this Page Style. To confirm this, one will see the name 
Title page in the Page Style field on the status bar below. By the way, users can also edit 
(doubleclick) and assign existing Page Styles via the context menu of the Page Style field 
on the status bar. 
If, however, one now scrolls through the pages of the document, it may be noticed that the 
Title page Page Style has been applied to every page. If all the pages had been defined by 
the Standard Page Style, they are now all defined by the new Style. Page Styles always 
apply to all preceding as well as following pages, unless a page break occurs with a 
change of Page Style. 

On the Organizer tab page, if a Next Style for a Page Style is entered, this means that 
after a page break (whether it is entered manually or occurs automatically) the Next Style 
will be taken as the Page Style. In the example described here, for the Page Style Title 
page one can select the Next Style Table of Contents. The Table of Contents Page Style 
is then always applied to the next page after the title page. This saves a user from having 
to go through the procedure described below involving the Manual Break dialogue. 

Note: Always choose the Table of Contents Page Style as the Next Style to follow the Table of Contents, since 
no one can be sure the number of pages that the Table of Contents will require. 

2. Now place the cursor at the beginning of the page where the Table of Contents should 
begin. Go ahead and enter a manual page break with a change of Page Styles.

3. Select Insert > Manual Break. The Insert Break dialogue appears.
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4. Select as Type the Page break option. In the list box select the Table of Contents Page 
Style which will then begin at this point in the document.

5. Click OK.
6. Place the cursor at the beginning of the first line in the main text.

7. Choose Insert > Manual Break. The Insert Break dialogue appears.

8. Select as Type the Page break option. In the pulldown list, select the Main text Page 
Style, which should be applied after this point. Mark the Change page number check box 
and select the new page number 1.

9. Now click OK.

Note: For headers or footers to contain different contents on the right and left sides, just uncheck the Same content 
left/right check box under Format > Page > Footer. 
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Under Format > Page > Page, one can select the page layout “mirrored”. This lets the user 
define an inner and an outer margin for the text. The left and right pages of the main text 
often have different Page Styles so that, for example, the left pages have a header, but the 
right ones do not. There are already Left page and Right page Page Styles provided for use; 
so use these instead of Main text. The first page of the main text is page 1 and contains the 
Right page Style; assign the Left page Style as the Next Style and vice versa. These Styles 
can be assigned to the corresponding pages in the Styles and Formatting window context 
menu with the Modify command. On the Organizer tab page, choose the Next Style.

Caution: There is an active issue that inserts blank pages where one 
least expects them. If this is a problem, please use the workaround at 
page 454

Editing Page Styles
The new Main text Page Style can have a page number in the middle of the footer. To make 
it so, do the following:

1. Select Main Text in the Styles and Formatting window, right click to open the context 
menu and select Modify. 

2. The paragraph Style dialogue window opens to display the definitions for Main Text.
3. Click the Footer tab. 

4. Check the Footer on box. 
5. Click OK which places an empty footer on the document page. 
6. Click the mouse cursor in the footer area of the page to enter data.

7. Choose Insert > Fields > Page Number. If View > Field Shadings is enabled, the page 
number appears in a gray field otherwise with no shading. 

8. To have “Page” precede the page number, place the cursor in front of the field and enter 
“Page”.

9. Click the Centred icon on the object bar to centre the current paragraph.
10.The appearance of the footer and its contents are now defined.

Page Breaks as Paragraph Formats
In the first paragraph of the main text, direct paragraph formatting was automatically applied, 
determining that the text automatically begins on the new Page 1. This will also apply if no 
text exists after the manual break on the new page. To check this for the first paragraph after 
the manual break, choose Paragraph... from the context menu (not Edit Paragraph Style, 
since this is a direct formatting attribute for a paragraph). 
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If a particular paragraph should be on a new page with a new Page Style, then that would be a 
property of that particular paragraph. Assign this property under Format > Paragraph > 
Text Flow.

Changing the Format of Page Numbers
Page numbers may be specified as either direct or as a property of the Page Style just like 
other text attributes. Using direct formatting, however, should only be employed in a few 
instances. When direct formatting, one edits the the field directly as follows:

1. Doubleclick the field with the page number. The Edit Fields: Document dialogue opens.
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2. Select the desired field format.
3. Click OK.
Better than the direct formatting method, just described, is to make the page number format a 
property of the Page Style as explained below:

1. Open the context menu on the page and select Page. Then the user will see, for example, 
the Page Style: default dialogue. Instead of “default”, the title bar of the dialogue 
contains the name of the current Page Style.

2. Go to the Page tab.

3. In the Numbering pulldown list, determine how the numbering should appear on all 
pages with this Style. 

4. Close the dialogue with OK.

5. Now select the As Page Style format for the field which shows the page number (see the 
description of direct formats above ). 

Users may change other properties in the footer, such as the font, by editing the Footer 
Paragraph Style so that the changes will apply to all footers.

• Place the cursor in the footer. Call the context menu and choose Edit Paragraph Style.

Increasing the spacing of the footer from the text above is also a format attribute of the Page 
Style:
1. Select the page style in the Styles and Formatting window.

2. Right click and select the Modify... command in the the context menu. 
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3. In the Page Style dialogue set the desired width and height of the footer.

Page Styles Summary
Unlike assigning a character style or paragraph style, where one first selects the text then 
doubleclicks in the Styles and Formatting window on the name of the style to apply the 
chosen style, applying page styles is different. 
A page style is always a property of the first paragraph of a page whether or not this the first 
paragraph of the current page or the first paragraph of a previous page. However, not every 
first paragraph has the Page Style attribute. Since this is the case, OpenOffice.org Writer 
searches for the page style attribute of the current page by starting at the current cursor 
position and continues to search toward the beginning of the document, checking each first 
paragraph of a page to locate a page style as attribute. 
To change from one page style to another, use the context menu of the field in the Status bar 
which displays the current page style . 

Upon right clicking on this field, one gets a popup containing a list of page styles, select the 
page style wanted for this page and Writer searches backwards until the first paragraph at the 
beginning of a page has been found. This paragraph is now be given the newly selected page 
style and this style will be applied from this point up to the end of the document or until a 
new first paragraph containing another page style is found.
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Defining default Templates
Whenever users finds that they are forever changing the formatting of new documents to suit 
“requirements, it is time to use a separate template. In Writer, this is known as the default 
template. If the user chooses, this default template can be set so that every time a new text 
document is opened and this is the template that is employed upon selecting File > New > 
Text Document. The following demonstrates one way that this can be done:
1. Create or open a document that contains the user's favourite styles and formatting.
2. Delete the text of the document, as desired, so that only the styles and other settings 

remain.

3. Save the document as template by choosing File > Templates > Save. Doing so saves the 
document as a template in $HOME/OpenOffice.org<release>/user/template under *NIX 
and , under Windows®, %HOME%\OpenOffice.org<release>\user\template. This is the 
user's default template directory.

4. Select File > Templates > Organize.
5. In the left list box of templates, doubleclick “My Templates”. The expanded list view 

will include the name of the default template that was saved. Click the name.

6. Open the context menu and choose Set as default Template. Close the dialogue. This 
template will now be used as the default template.
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Templates and Styles
OpenOffice.org templates are files that one can use as base for creating personal, custom 
documents, in the manner of a road map. Templates can contain text, logos, other graphic 
objects and other constructs. Also, every template contains a set of styles that are viewable in 
the Styles and Formatting window. For each document type (text, table, drawing, 
presentation etc.), a single template file is defined, called a default template (file). This 
template is always used as the default when, for example, create a new (usually empty) 
document with File > New. 
Nearly every document type has its own template. Lists of the different templates for text 
documents can be found in the OpenOffice.org Help about text documents as can those that 
that apply to drawings, presentations and spreadsheets. 

Copying Styles Between Templates and Documents
By selecting File > Templates > Organizer, the following dialogue appears.

Use this dialogue to copy the Styles contained in a particular template or in a particular 
document individually to another document. Doubleclicking the name of a folder in the left 
window expands to list all the templates contained in that folder. Doubleclicking one of 

these files causes the category Styles to appear. Once again, doubleclick to expand the list of 
the styles contained in the template document. But in the case of a document one only sees 
the Styles that are actually used in that document. 
When dragging and dropping elements from one template or document to the another, the 
mouse pointer shows the location to which the content may be dragged. Either the mouse 
pointer is a circle with a line through it, in which case the content cannot be move d to that 
place, or the mouse pointer has an insert line that marks the place where the content will be 
moved to when the mouse button is released. 
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Creating New Styles From Selections
Create a new style by copying an existing style, as follows:
1. Open the Styles and Formatting window.
2. In the document, select formatted text or a paragraph that has the format from which to 

create the new style.
3. Click the icon  on the Styles and Formatting window Standard toolbar.

New Style from Selection
New styles can also be created from a selection by dragging and dropping it:
1. Select the type of style to be made by clicking the corresponding icon at the top of the 

Styles and Formatting window (e.g. Paragraph, Character , Frame, Page or Numbering).
2. Select that part of the paragraph, text or object form which to form the new style.
3. Drag this to the main Styles and Formatting window area and release the mouse button 

over a free area when the insertion line is no longer visible.

Transferring Formats With Fill Format Mode
Applying a new Style in Fill Format Mode:
1. Open the Styles and Formatting window.
2. In the Styles and Formatting window, select the style to copy.

3. Click the Fill Format Mode icon.
4. Position the paint can pouring cursor on the object to which to apply the style selected.
5. Press the mouse button.

Note: There is an exception to this procedure: when applying a Character Style in the Fill Format Mode, select the 
character with the mouse (paint can pouring) while holding down the mouse button instead of only clicking.

To quit the fill format mode, click the icon again or press Esc.

Warning: If the watering can icon is activated, a rightclick anywhere in the 
document undoes the last paint can pouring action. Be careful not to accidentally 
rightclick and thus undo actions that should be kept.

Updating Styles From Selections

This is how to update a Style:
1. Open the Styles and Formatting window.
2. In the document, select a formatted text or paragraph with the format to adopt as a style.
3. In the Styles and Formatting window, select the style to update (singleclick, do not 

doubleclick!)

4. In the Styles and Formatting window, click on  the Update Style icon: 
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Style can also be updated by using drag and drop:
1. Select the style to be updated in the Styles and Formatting window.
2. Select the section of paragraph text, the format of which is to be used to update the style 

selected in the Styles and Formatting window.
3. Drag the text into the main Styles and Formatting window area and release the mouse 

button when the insertion line is seen above an entry.
With this procedure, the paragraph style directly above the insertion line is given the new 
format.

Entering and Formatting Text Automatically
This section deals with certain automatic functions that involve entering and formatting text.

Disabling the AutoCorrect Function
Writer has functions that are turned on by default to correct many common typing errors as 
one works. However, this behaviour may not always be desirable. Any automatic correction 
can be reversed immediately after it is made by pressing (CtrlZ).
Below is a description of the places in OpenOffice.org where one can disable automatic 
corrections (and reenable them):

ASCII Quotation marks are replaced with Custom Quotes
1. Open a text document.

2. Choose Tools > AutoCorrect.
3. Click on the Custom Quotes tab. Uncheck Replace.

Sentences always begin with a capital letter
1. Open a text document.

2. Choose Tools > AutoCorrect.
3. Click on the Options tab. Unmark Capitalize first letter of every sentence.
A word is replaced with another word
1. Open a text document.

2. Choose Tools > AutoCorrect.
3. Click on the Replace tab. Look for the word pair and delete it.
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Three identical characters will become a whole line
When three of the following characters (  _ = * ~ #) are entered at the start of a new 
paragraph and Enter is pressed, a pagewide line of various thickness results. The line is a 
border of the previous paragraph. Choose Format > Paragraph > Borders to edit or delete 
it.
To turn this feature off:
1. Open a text document.

2. Choose Tools > AutoCorrect.
3. Go to the Options tab. Uncheck the Apply border check box if this automatic 

conversion should no longer occur.

Automatic Spellcheck
• From within a text document, click the AutoSpellcheck on/off icon on the Standard 

toolbar. All words marked as incorrect by the spelling checker will then be underlined in 
red.

• Click on words underlined in this way with the right mouse button. A context menu then 
appears.

• The context menu often provides a list of suggested words, one of which one may click to 
select it. The suggested word then replaces the word underlined in red.

If the wrongly typed word is replaced using the AutoCorrect function in the context menu, 
the word pair will be entered in the AutoCorrect replacement table. To call up this table, 
choose Tools > AutoCorrect > Replace tab.

If the word underlined in red is correct, it can be stored in a custom dictionary using the Add 
command.

To exclude words from Spellcheck
For words marked as incorrect, users can exclude them from spell checking as follows.

1. Right click on the word to open the context menu.

2. Choose Ignore All.
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Using AutoText
Writer contains an AutoText function which helps users to use shortcuts and 
abbreviations to add expanded words to letters, faxes or any other OpenOffice.org 

documents.
To insert AutoText do the following:
• Enter the shortcut for an AutoText item and press the F3 key.

There is a set of predefined AutoText blocks already in existence. For example, enter DT 
and press the F3 key to insert a dummy text which can be used to check the look of a page 
filled with text (and other objects). Likewise entering FN and pressing F3 will insert an 
OpenOffice.org Math formula that is sequentially numbered at the right page margin.

• Choose Edit > AutoText.

• The AutoText dialogue contains a number of AutoTexts. As can be seen, AutoTexts can 
even contain graphics and tables.

Longclick on the Edit AutoText icon on the Insert toolbar and select an AutoText category 
as shown below:
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Use the left mouse button to select the AutoText for insertion. Upon releasing the mouse 
button, the text is inserted in the text at the cursor position. .

Note: Use the AutoComplete function in a similar manner. Directions for doing this function are found in Help.

Defining AutoText
Write the desired text. It may contain formatting and embedded graphics. Select the text. 
Now select Edit > AutoText. In the large list box, select the category (e.g. 'default'), assign a 
name for the new text component in the text box and correct the abbreviation if necessary. 
Now save the text component via AutoText > New and close the dialogue.
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Using AutoText in Networks
Multiple AutoText lists can be used. An example would be in a typical OpenOffice.org 
network installation:
A readonly company wide AutoText list might be located on the server and a userdefined 
AutoText list located in a user's individual work area. Both can be read and used while 
typing.

• Choose Tools > Options OpenOffice.org > Paths.

• Doubleclick AutoText. Two paths are entered here. The first path will take the selected 
AutoText list from the server installation while the second path takes the AutoText list 
from the user work area. When two AutoText lists from the different locations have the 
same name, OpenOffice.org uses the one from the user location.

Printing AutoTexts
To print a list of all AutoTexts, run the AutoText macro from the OpenOffice.org Basic 
Gimmicks library . This macro lists all AutoText names and shortcuts in a new text 
document.

1. Select Tools > Macros > Run Macro.

2. Doubleclick OpenOffice.org Macros and then doubleclick Gimmicks in the expanded 
left hand list.

3. Select AutoText in the newly expanded list.

4. Click Run.
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AutoText With AutoComplete
To enable AutoCompletion of selections in the AutoText dialogue, check Display remainder 
of name as suggestion while typing.

So while typing, enter a word in the text that exists as an AutoText name, this sequence is 
recognized after the third matching letter is typed and a Help tip appears containing the 
whole name of the AutoText entry. If the offering is acceptable, press Enter to insert the 
AutoText.

Note: Help tip sometime contain several AutoText names that begin the same way, use Ctrl Tab to scroll  
forwards and ShiftCtrl Tab to scroll backwards through the list to select the text wanted.

Exceptions in AutoCorrect
Should AutoCorrect correct a word that is entered but this correction is not wanted, restore 
the original word by using the Undo function. This action will also add the word to the list of 
exceptions in AutoCorrect proving that AutoInclude is checked in the AutoCorrect 
dialogue. (By default it is checked.)

Example
By default, AutoCorrect automatically corrects two capitals at the start of a word. However, 
in the case of product names and other similar texts, two initial capitals may exactly what is 
needed.
Suppose there's a new product called “ESt”. Under normal settings, AutoCorrect 
automatically changes this to “Est”; however, by pressing the CtrlZ key sequence the 
automatic replacement is reversed (Undo) and the word “ESt” is automatically added to the 
list of exceptions in the AutoCorrect dialogue.

Note: See also the functions for automatic numbering of headings in Help.
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Text Frames
Making text look as good as it as reads is likely something desired. To achieve this, users can 
customize its appearance for maximum impact.

Inserting, Editing and Linking Text Frames
A text frame is a bounded area that can contain text, graphics and other objects and be placed 
anywhere on a page; for example, to make columns for a newsletter.
Linking the content of a frame to another, let's the text flow backward and forward between 
them.
Click the edge of any text frame to select it and eight handles appear, four of which are 
located in the corners and one in the middle of each side.

Inserting Text Frames
Existing text into a may be put into a frame or an empty frame opened into which text can be 
added later. Following these steps to create a frame. If using existing text, highlight the text 
for the frame then proceed as shown below:

1. Longclick the Insert icon on the Tools toolbar and open its floating toolbar. 

2. On the Insert floating toolbar, press the mouse button on the Insert frame manually icon 
to open the column preview.

3. In the preview move the mouse point to select the desired number of columns.
4. With the crosshair cursor, create a selection frame to define the new location and area for 

the paragraph. Press the Escape key to cancel frame formation.
Any text that was highlighted is now automatically deleted from the normal, continuous text 
and inserted into the text frame.
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Editing Text Frames
Select a text frame by clicking on one of its edges. Once selected, a user can drag and drop to 
change its position by grabbing an edge and thus move the whole frame. If one does the same 
action using one of the handles, the size of the frame changes. So, dragging a handle on one 
of the sides enlarges or compresses the text frame in one direction only, whereas dragging a 
corner handle enlarges or reduces it in two dimensions. 
Right clicking within a selected frame popups the context menu. Th options in this menu 
allow one to make further adjustments. 

As seen in the above graphic, a number of selections can be made. For example, choose 
Alignment which positions the frame relative to other frames, drawing objects, graphics et 
cetera. Use the Wrap submenu to choose if normal text should wrap around the frame, wrap 
on one of the sides or not wrap at all. Selecting Frame in the context menu is the same as 
choosing Format > Frame from the menu bar and opens a dialogue that gives access to 
managing all properties of the frame. 
The contents and functions available fro use in text frames are the same as in text documents 
and can contain pictures, multiple columns, tables, drawings et cetera. 

Linking Text Frames
Several text frames may be linked to each other “over different pages of a document. The text 
“automatically flows from one to the next.
1. In order to create a link, click the edge of the frame to be linked. Eight handles appear 
around the edges.

2. Click the Link icon on the object bar.
3. Click the frame that is to be linked.
When a linked frame is selected, any existing links are indicated by a connecting line. 
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Note: The height of a frame that is linked with a subsequent frame is automatically fixed. The height is no longer 
automatically adapted to the content of the frame. Only the height of the last frame of a chain can be adapted to the 
text content. 

Click the Link of the object bar when a frame is selected and the cursor changes. The cursor 
can display as on of two icons: a chain with an arrow when two frames can be linked by 
clicking, or a chain with a stop sign when linking is not possible where the cursor is 
positioned. A note is displayed in the status bar in each case, for example, why linking is 
possible or not possible. 

Note: Linking is only possible from one frame to the next. That means that a frame that is already 
linked to a frame cannot be linked to another frame which follows. Therefore, the link icon cannot be 

activated if a frame already has a next link. Also, two frames can only be unlinked with the Unlink Frames icon 
from the first frame. 

Linking of frames cannot happen under the following conditions:
• The target is not empty. Automatically captioned frames are not considered empty and, 

thus, can not be the target of a link.
• The target already has a previous link.
• Source and target are in different sections. For example, one frame is in a header and the 

other frame is in a footer.
• The source already has a next link.

• Source and target are the same.
• Closed chains or chains from the inside out or from the outside in are also not permissible. 

The latter is the case if a frame is inserted into another frame and these must be linked 
with each other.
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Using Text Animation
Writer's Text Animation feature enables composition of applications with coloured, animated 
text. For example, for a simple web site. The following stepbystep procedure shows how to 
do it:
1. Open a new, blank OpenOffice.org Writer document.

2. Select Format > Page to select a background for the whole page.

3. Open the Draw Functions toolbar using the Show Draw Functions icon in the Standard 
toolbar

4. Click the Rectangle icon. 
5. Create a rectangle in the centre of the page.

6. Open the context menu for the rectangle object by right clicking somewhere within it.

7. Choose Area to open the Area dialogue and then select the Area tab.

8. In the Fill section list box choose either Colour or Gradient if the one  wanted isn't 
currently selected.

9. Select a colour or a gradient.
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10.Close the dialogue with OK.
11.Open the context menu once more.

12.Select the Line... command to define the border properties of the rectangle and choose a 
colour and a width.

13.Close the dialogue with OK.
14.Doubleclick in the middle of the rectangle and enter any text regardless whether the text 

extends beyond the width of the rectangle or not.
15.Click again on the border of the rectangle in order to select it.

16.Open the context menu and select Text.
17.In the Text dialogue, click the Text Animation tab.

18.Under Text Animation, select Effects 
19.Select the pulldown list the option “Scroll Through”.

20.On the Text tab page, set the distance from the left and right borders. (The border of a 
frame goes half inside and half outside.) 

21.Click OK.
22.The text animation will start to run immediately.
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23.To alter the size of the animated text, select the rectangle again and doubleclick in the 
centre. Now select the text and apply a larger font size.

24.A suitable text colour can also be chosen by opening the context menu and choosing 
Character.

Note: Enlarge or reduce the page view either by choosing View > Zoom or via the context menu of the scale field 
on the status bar. If the screen display is to be refreshed, press Shift+Ctrl+R. 
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Drawing Lines in Text
There are a number of ways to add lines to a page of text and any lines that are incorporated 
in a document can have attributes defined, such as the angle, width, colour, et cetera, however 
the user chooses. 
Here are some ways to add lines.
• Use the shortcuts described under Three identical characters will become a whole line on 

page 96.

• Apply the preset paragraph style Horizontal Line by placing the cursor on a blank line 
and doubleclicking the Horizontal Line style in the Styles and Formatting window.
If the entry for horizontal lines is not visible in the list of Paragraph Styles, switch the 
view in the Styles and Formatting window from “Automatic” to “All Styles”. 

• Draw a line above, beside or below a paragraph by choosing Format  Paragraph > 
Borders. This function is explained in detail in the OpenOffice.org Help. 

• To personally define the line attributes and direction, use the Line drawing object as 
follows: 

1. On the Standard toolbar, click the Show Draw Functions icon to open the Draw 
Functions toolbar. 

2. Click the Line icon. The mouse pointer changes to a crosshair symbol with a line 
beside it. 

3. In a document, locate where the line should begin, click, hold down the mouse button 
and drag to the point where to end the line. Holding down the Shift key, restricts 
drawing to horizontal, vertical, and diagonal lines only. 

4. Release the mouse button once the line has the desired direction and length. 
5. To draw more lines, repeat steps 2 and 3.

6. End this function by pressing the Esc key or by clicking the Selection icon from the 
Draw Functions floating toolbar. 

7. Once all lines are complete, select all of the lines at the same time by clicking each 
line while holding down the Shift key. By using this multiple selection method, one 
can assign all of them a common colour, width or any other attribute as needed. 

Note: If these lines or other draw objects are exported in a text document to HTML, Be aware that such objects 
“are not defined as part of the Internet page description language HTML and are therefore not exported directly 
into HTML format but “are exported as graphics.
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Editing Text With FontWork
The FontWork program module is used for graphical text effects in a similar manner to the 
WordArt® function available with Microsoft Office. If this functionality is needed, here is 
the procedure to follow:

1. Open the Drawing Functions floating toolbar from the Main toolbar. 

2. Select the Text icon. 
3. Draw a text frame on the page.

4. Enter the text, for example “FontWork”.

5. Choose Format > Object > FontWork. This opens the FontWork window, from which 
to select the desired effects:

6. Click the upperleft icon with the semicircle to display the text as a curve.
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7. Click Vertical in the Shadow options. Specify 0.10 inches for the xaxis shadow distance. 
The text should now appear similar to the illustration.

8. Since the first and last letters may not be easy to see, insert two blank spaces before and 
after the text. doubleclick the text, edit it, and then click outside the object.

9. Selecting the FontWork object causes eight handles appear which can be used to change 
the size and shape of an object. For example, drag one of the handles in the desired 
direction. 

10.Finished FontWork objects can be copied to the clipboard and so pasted into other 
documents for modification, sizing or other attributes.
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Aligning Text With Lines
Aligning text on a free form line
1. Draw a free form line using the free form line function on the Draw Functions floating 
toolbar .
2. Doubleclick on the line.
3. Enter the desired text or copy it from the clipboard.

4. Choose Format > Object > FontWork.

5. Click for example on the Rotate icon.

Aligning text with straight lines
Slanting text so that it follows an angle from one point on the text page to another point uses 
a similar procedure to aligning text on a free form line. Here's how: 
1. Using the draw functions, draw a straight line from one point to another.

2. In the list box on the object bar, select the line style “Invisible”.
3. Doubleclick on the line, which is now invisible (but the two ends may still be seen). 
4. Doubleclick exactly between them.
5. Enter the text.
6. Click outside the line object.
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The Navigator
The Navigator is another important feature of OpenOffice.org that, along with the Styles and 
Formatting window, that helps manage formatted documents. 

Activate the Navigator by clicking the corresponding item in the Edit menu.
In particular, the Navigator helps one to navigate, or move accurately, to the parts of a 
document required and provides detailed information about the content of the document in an 
understandable manner.
In text documents, the Navigator provides complete lists of all heading, graphics, “tables et 
cetera in a document. Simple navigation, such as going straight to a specific place in a 
document, only requires doubleclicking the desired entry in the Header list. Besides simple 
navigation, the Navigator can do much more in assisting users to manage documents. For 
example, a document is structured using headings, through the Navigator, a user can change 
the sequence and hierarchical levels of whole chapters and subchapters quite easily by 
clicking the appropriate icons in the Navigator. 
 

The Navigator can be docked to the edge of a window using the procedure described under 
Docking windows on page 18.

Jumping From One Object to Another in Text
Clicking the Navigation icon in the Navigator window toolbar opens the Navigation 
window.

This Navigation window has functions to allow movement in a document from one object 
(graphic, table, et cetera) to the next or previous one of the same type.
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For example, click the Navigation icon in the Navigator window and in the Navigation 
window click the Graphics icon. The graphic object type will be selected and the Navigation 
window will disappear immediately so that the user can access the Previous and Next icons 
in the Navigator window toolbar. Press either the Previous or Next icons to search for the 
next nearest graphic in that direction.

In the Navigation window, the doublearrows at the righthand end of the toolbar may also be 
used to search. 

Note: To have the Navigation window stay open, first grab it's blue title bar and drag it away from it's initial  
position.Any distance will do. Now it will stay on top until closed.

  Another way to access the Navigation window can be found in the vertical scroll 
bar at the bottom righthand side of the document window.

  When the Navigation double arrows in the vertical scroll bar appear black, a 
user can move through the document pagebypage. Likewise, if the arrows 
appear blue, one can search to each object of the same category that has been last 
selected in the Navigation window . 

Jumping From One Reminder to Another
Use the Navigator to set temporary reminders that stay in effect until the document is closed. 
This is handy when looking up or adding something later as it makes it easy to move between 
particular locations in the document. For example:
1. Position the cursor where the reminder is to be set .

2. Click the Set Reminder icon in the Navigator. The reminder will not be visible in the 
document.

3. When jumping to a reminder, select the Reminder entry in the Navigation window and 
one can now move through the reminders by clicking the Previous and Next arrows.

Jumping to a Specific Page
Moving quickly to particular pages in long documents is easy even if the Navigator is not 
opened or docked.
Doubleclick the current page number on the Status bar, and the Navigator window switches 
between open and closed. 
Enter the number of the target page number into the spin button at the top of the Navigator 
panel. After a short delay the page is automatically displayed. Press Enter and the cursor is 
automatically placed at the top of that page. 
A keyboard shortcut, Ctrl+Shift+F5, places the cursor in the Navigator page spin button. 
If the Navigator is inactive it is opened first.
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Chapters in Navigator
In long documents, use the Navigator to obtain an overview and change the sequence of 
chapters or their level in the hierarchy of chapters and subchapters. The only condition is 
that “Heading” Paragraph Styles must be applied to the chapter headings (or choose the 
Paragraph Styles which will be recognised as headings under Tools > Outline Numbering). 
Drag and drop to change the sequence of chapters. Users can also do this by clicking on the 
Promote Chapter and Demote chapter icons. The content of the chapters and of the 
relevant subsections is of course also moved. 
To move the chapter headings without moving their contents, drag and drop while holding 
down the Ctrl key. (The Drag Mode icon only affects drag and drop behaviour between 
Navigator and document). When using this function, switch on Heading Levels Shown by 
clicking on the relevant icon in the Navigator, to see what is happening in the document. 

Other Navigator Features

When one wants to know about the objects in a document, the Navigator can be very helpful, 
particularly in longer documents,. For example, there is an HTML page open, the Navigator 
tells at a glance which hyperlinks the page contains including any hidden hyperlinks. 
However, hidden hyperlinks will be without reference text. 
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Indexes and Tables of Contents in Writer
Writer documents can contain any number of predefined or userdefined indexes. For 
example, users can have a table of contents, alphabetical index, illustration index and/or 
bibliography. 

Defining Index/Table of Contents Entries
The first step in preparing indexes, such as a table of contents or other index, is to determine 
which entries in the document should be included. 

First define entries for the index(es) as entries in the document in the following manner:
1. Select the word or words in the document which are to be listed in the index. Several 

words can be selected by holding down the Shift key if they are listed one after the 
other, or by holding down the Ctrl key if they are spaced apart. When selecting a single 
word, simply position the cursor in the word  – it does not need to be highlighted.For a 
Table of Contents, using Headings is easiest.

2. Enter the selected words in an index by choosing Insert > Indexes and Tables > Entries. 
If a different term to appear in the index, enter it in the Entry field. For example, one 
could enter “dictionary, defining”, whereas only the word ”dictionary” appears in the text. 

To define all similar words in a text as entries, select Insert > Indexes and Tables > 
Entry and check Apply to all similar texts. 
To include the words in a separate index with a name of one's choice, click on the 
New Userdefined Index icon in the Insert Index Entry dialogue. This opens a 
dialogue in which to enter a name for the index. This name later appears as the title of the 
index. The title of an index can be changed without the content of the index changing. 
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Editing or Deleting Index and Table Entries
All defined index entries are shaded gray in the document for easy recognition but, which, is 
never be printed. If display of the shaded entries onscreen is unwanted, switch the 
highlighting on or off using View > Field Shadings.

1. To edit an entry, place the cursor immediately before or inside it.

2. Then choose Edit > Index Entry.

3. Alter the text in the Entry text box as needed.

4. Click on the Delete button to delete this entry from the list.
If the displayed text of the entry is modified, the altered text is inserted into the generated 
index. Only a thin gray mark in the document remains where the entry was. To edit an entry 
such as this, place the cursor directly after the thin mark and choose Edit > Index Entry. 

Use the arrow buttons in the Edit > Index Entry dialogue to switch to the next or previous 
entry of the same index type. 
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Creating a Table of Contents
1. Place the cursor at the location at which to create the table of contents.

2. Choose Insert > Indexes and Tables > Indexes and Tables. The Insert Index/Table 
dialogue appears. Click the Index/Table tab and select “Table of Contents” as 
Type (the first time this dialogue is started, this tab page and type are already selected).

3. Click on OK to create the table of contents from the headings and entries already defined.
4. To insert additional paragraphs of another paragraph style into the table of contents, check 

Additional Styles 
5. Click the icon next to the box to open the dialogue 
6. Define the paragraph styles that are also to appear in the table of contents and the level 

they are to be shown. Click the   icon near Outline to open the Assign Styles 
dialogue. This dialogue sets paragraph styles for each level of the index, starting at the top 
level.

 i. Select one of the existing document paragraph styles  from which to generate 
each entry at this level of the index.

When changing headings, rearranging their sequence or inserting new chapters, remember 
“to update the table of contents as follows:
• Place the cursor in the Table of Contents. 

• Right click to active the context menu 

• Select Update Index/Table.

• Select Tools > Update > All Indexes and Tables to update all the indexes and tables of 
contents in a document.
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Creating Alphabetical Indexes
1. Place the cursor in which to create the index.

2. Select Insert > Indexes and Tables > Indexes and Tables.
The Insert Index/Table dialogue appears.

3. On the Index/Table tab, select “Alphabetical Index” in Type.
4. Click OK to generate the alphabetical key word index using the default settings.
The are several options that can enhance the usability of any index. For example, to highlight 
letters under which entries exist as subtitles (”alphabetical delimiter” in the Entries tab), or 
to allow casesensitivity to be taken into account when sorting, and much more.
Editing the paragraph styles in the Styles and Formatting window is the best method for 
changing the formatting of the individual lines in the index as all direct formatting is 
overwritten at the next update.

Creating UserDefined Indexes
Users can create as many userdefined indexes as needed. 
Step 2… Create a named index entry collection:

a) Open Insert > Indexes and Tables > Entry 
b) Select UserDefined from the Index list box

c) Click the New UserDefined Index icon in the dialogue 
 i. Name the new index.

 ii. Click OK.
d) Add entries for this new index. At least one entry must be inserted into the new 

index before closing the Index Entry dialogue or the index won't be created:
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 i. In the document, find a candidate location or text for the new index.
 ii. Position the text cursor at that position, or select a word or phrase that will go 

into the index.

 iii. In the Index Entry floating window click the Insert.
 iv. Repeat this process from step 1.d.i. or continue with step 1.e.

e) In the Index Entry floating dialogue click the Close.
Step 3… Finally, create the index in the document:

1. Position the cursor on the place where the userdefined index is to be created.

a) Choose Insert > Indexes and Tables > Indexes and Tables.... to open the 
dialogue Insert Index/Table.

b) In the Type list box, select the entry matching the name that was given to the 
index collection in step 1.c.i.

c) Give the index a title by editing the Title box.

d) Check the Styles box 

e) Click the   icon to open the Assign Styles dialogue. This dialogue sets 
paragraph styles for each level of the index, starting at the top level.
 i. Select one of the existing document paragraph styles  from which to generate 

each entry at this level of the index.

 ii. Click the >> button to record that style and move to the next index level.
 iii. For each index level, repeat this process from step 2.f.i, or continue with step 

2.g.
f) Click OK.
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g) Mark the other check boxes under Create from to create the index from all the 
objects of a certain type.

h) Assign names to the objects in the Options tab of the corresponding property 
dialogue. 

i) Click OK to generate the index from marked entries.

Using a Concordance File
A concordance file is a variation of an index in that it provides exact references to words in 
the document and permits crossreferencing and subindexing. Thus a concordance file 
contains a number of key words and information as to how these words are to be seen in an 
index.
One way to create an alphabetical index is to use a concordance file. Users will need to know 
what terms are wanted in the index, and how these should be displayed. OpenOffice.org 
allows an index to have up to three levels: parent, subparent, indexed item.

Preparation
Place the cursor in the document where the index is to be inserted then select Insert > 
Indexes and Tables > Indexes and Tables. On the Index/Table tab, enter into the Title box 
the name that will bet displayed at the beginning of the index. In the Type box, choose 
Alphabetical Index. Under Options check Concordance file and after clicking on File, choose 
New. A Save As dialog box pops up and a name must be assigned to the index and Saved. 
The extension automatically given to the concordance file is .sdi. The other fields and tabs 
in the Insert Index/Table screen are used to design the layout of the index.

Entering Data
The 'Edit Concordance File' screen is now displayed with seven columns: Search term, 
Alternative entry, 1st key, 2nd key, Comment, Match case, and Word only. 
'Search term' is the actual term to be searched for in the document. The search term can be 
more than one word. 
'Alternative entry' is the term that will be shown in the index. If the Search and Alternative 
terms are the same, Alternative can be left blank. 
'1st key' is the parent term that the current term should be listed under in a multilevel index 
and is left blank if the term is to stand on its own. 
'2nd key' is the subparent term that the current term should be listed under in a multilevel 
index and is left blank if the term is to stand on its own or if it only has one parent. 
The information in the Comment field does not get printed in the index and can be used for 
any additional information. 
'Match case' means that uppercase and lowercase letters are considered when searching for a 
term and is 'No' by default. 

OpenOffice.org User Guide for 2.x 119



Chapter 3: Managing Text Documents With Writer 

'Word only' means terms will only be picked up if the full search term word(s) are found in 
the correct order.  For example, if the search term is 'in present'  every instance of the word 
'in' followed by the word 'present' will be indexed but  'in presentation' or 'in a present' will 
not be indexed. 'Word only' is 'No' by default.
After entering the terms press 'OK' to save the concordance file.

To review or change entries, right click anywhere in the the document and choose Edit > 
Index/Table to bring up the Insert Index/Table dialogue. Then choose 'Edit' under the 
'File' button.
A concordance file can also be created or modified manually. Follow the above steps to 
create a concordance file, though it is only necessary to enter one line of data. Save the file to 
create the .sdi file. This file can now be opened in Writer and additional entries can be 
made or existing entries can be modified. When saving the modified document there may be 
a warning message about formatting, answer 'Yes' to save in the Text file format. This will 
keep the .sdi extension.
The text document displays each entry of the concordance file  as a separate line and the 
items are separated by semicolons. The fields are: Search term;Alternative entry;1st Key or 
Parent 1;2nd Key or Parent 2;Match Case;Word only
If there is no information for a specific field, that spot should be left empty.
Commented lines begin with # and are ignored by the indexing system.
'Match case' and 'Word only' are interpreted as 'No' or 'False' if they are 
empty or contain a zero. All other contents are interpreted as 'Yes' or True.
If the search term and alternative entry are the same, leave the alternative entry blank. If the 
user wants to make sure the term is displayed a particular way, enter it in the Alternative 
entry field exactly as it should be displayed. For example, searching for the word 'e-mail' 
in the document, it should be indexed regardless of whether it is upper or lower case; 
however,  display of  the index entry must be upper case. Thus, the concordance file entry 
should be e-mail;E-mail;;;0;1 OR E-mail,E-mail;;;0;1. Without the 
alternative entry, the index will display the first instance of 'email' found in the document so 
it may or may not be capitalized.
If the search term has no parent, leave Parent 1 and Parent 2 blank. Parent 1 is the 
highest parent, Parent 2 is a subparent of Parent 1. 

Example file
In a document on animals the index could have a listing for cat breeds. Parent 1 would be 
'cats', Parent 2 would be 'longhaired', 'shorthaired' or 'semi longhaired'
Examples of entries (the commented lines are given for explanation and are not required) :

#American Shorthair is the search term and the #alternative 
entry so only needs to be listed #once

#Cats is the highest level parent with #shorthaired as a 
subparent.
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#Match case is 0 which means false, so all upper #and lower 
case instances will be selected

#Word only is 1 which means true, so only #instances of the 
full words will be selected. 

#It would not #include American shorthaired.

American Shorthair;;cats;shorthaired;0;1

Himalayan;;cats;longhaired;0;1

Maine Coon;;cats;semi longhaired;0;1

Norwegian Forest;;cats;semi longhaired;0;1

Persian;;cats;longhaired;0;1

Abyssinian;;cats;shorthaired;0;1

Bengal;;cats;shorthaired;0;1

#feed cats and cat treats are both search terms #that will 
be included in the following index #entry:

#cats

#    care

#        feeding

feed cats;feeding;cats;care;0;1

cat treats;feeding;cats;care;0;1

Once entries are made in the concordance file, it may be necessary to make sure only the 
desired text is indexed. Users can either look at the index results or use 'Find and 
Replace' in the document and enter each search term to see what text will be indexed. If 
something is being indexed that is not wanted, one will need to modify the search term to 
eliminate the unwanted text. 
For example,a document on nature could include information about trees and animals. An 
index entry for bark would pick up tree bark and text about animals barking. To insure that 
only the tree bark text is indexed, a user might have to change the entry from: 
bark;;tree;;0;1 
to: 

tree bark;bark;tree;;0;1 
and: 

bark of the tree;bark;tree;;0;1

The order of entries in a concordance file does not effect the display order which is 
alphabetical. However, keeping like items together makes it easier to track down any errors 
or to find an entry that needs to be changed.

Turning on View > Field Shadings allows users to see which terms are indexed and might 
help determine what index items have been forgotten.
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Creating Bibliographies
Bibliography entries are often in the form of: “Smith [Smith 1995] has also carried 
out research on this matter” or similar so that the reader knows that more detailed 
information can be found in the bibliography under “Smith 1995” with the full name of the 
author, title of the book, publisher, date of publication and a myriad of other possible terms.

Decide what details should appear in the bibliography and then use Insert > Indexes and 
Tables > Indexes and Tables with a Type of Bibliography to define how the entries will 
look when displayed. 

Select Tools > Bibliography Database to open the bibliography database. Examine the 
columns and find one labelled Type then use different entries for magazine articles than for 
entries concerning books. For this reason the bibliography database is divided into different 
types of sources of literature. A new record can be inserted in the Insert Bibliography Entry 
(by clicking the New button), but these “ad hoc” records will be saved only in the current 
document, not in the Bibliography Database, and then only if the relevant new entry is 
actually inserted. 

Note: When saving a document with bibliography entries, all information belonging to the entries will  
automatically be saved in a hidden field. In this way, all data will be included when the document is distributed, for  
example, on a disk. It does not matter whether the bibliography was created in the document or not. 

1. To insert the bibliography entries into the text, position the cursor in the text where the 
entry is to appear and then choose Insert > Indexes and Tables > Bibliography Entry. 
The following dialogue will appear:
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2. First decide whether to select the entry from the records contained in the bibliography 
database or from the entries that are contained in the current document (and which can 
differ from entries of the same name in the bibliography database). An entry in the 
document content can be identical to an entry in the Bibliography Database. The entry in 
the document has precedence.

3. If the required entry already exists as a data record select it in the list box Short name and 
click Insert. If the desired entry does not yet exist, create a new entry. If the New button is 
used to do this, one can define a new record, but this will only be recognized in the current 
document. 

If the record should be included in the bibliography database, choose Tools > 
Bibliography Database, enter the new record and then insert the bibliography database 
entry in the document. 

Updating, Editing and Deleting Indexes and Tables of Contents
Indices and Table of Contents are snapshots of what is present at the time they are created. 
Obviously there are occasions when these need updating, editing or deleting. The following 
instructions give the steps needed to accomplish any of the above tasks.
1. Place the cursor in the index/table and right click to open the context menu.
2. Select the desired command:

a) Update Index/Table
b) Delete Index/Table
c) Edit Index/Table 
d) Edit Paragraph Style

Note: (d) Edit Index/Table is only available if Insert > Indexes and Tables >Indexes and Tables > Index/Table > 
Protected from manual changes is selected. This is because, by default, indices and tables of contents are 
protected from changes. 

Editing the Format of an Index/Table of Contents
The Entries tab on the Insert > Indexes and Tables >Indexes and Tables dialogue permits 
editing the format of an index. In this tab, alter the way in which entries, tab stops and page 
numbers are arranged et cetera. Using the Styles tab, assign other Paragraph Styles . For 
detailed instructions, refer to the OpenOffice.org Help. 
Hyperlinks can be automatically assigned to the entries in the table of contents using the 
following method:

1. Go to the Entries tab page, 
2. Place the cursor in the structure row before the entry <E#>

3. Click the Hyperlink button, then place the cursor after <E> and click Hyperlink again. 
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Where the list is a table of contents for the document, click a hyperlink to go straight to the 
first occurrence; however, for this to work the table of contents must be generated from 
headings. 

Indexes Covering Multiple Documents
There are several ways of creating an index covering multiple documents:
• Create an index in each individual document, then copy the indexes into a document and 

postedit them.

• A more elegant solution is to select each individual index as a section (Insert > Section) 
and insert these sections in a common index document as a link.

• If one is working with a master document, common indexes are possible across all sub
documents.

More information about master documents can be found later in this manual.
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Headings and Numbering
Most text documents benefit from use of headings and numbering. Writer provides automatic 
functions that help the user manage the structure and formatting of documents via headings 
and numbering.

Numbering and Numbering Styles
Numbering in a document may be applied either as direct formatting or by using a Style, in 
the same manner as is done with other paragraph attributes such as “Justified” or “Line 
Spacing”. The icons on the numbering object bar and the options in the Format > Bullets 
and Numbering dialogue apply direct formatting. Direct formatting is also applied when 
automatic numbering is used via the AutoFormat/AutoCorrect function. 

Note:The AutoNumbering of AutoCorrect is not applied to the Styles listed in the Styles and Formatting window 
under “Special St yles”.

A Numbering Style can be applied as part of certain Paragraph Styles or applied directly to 
the paragraphs. With the former case, one can take advantage of the paragraph formatting 
system for numbering as well. Changing a Numbering Style ensures that all numbering 
created with this Style will be automatically reformatted. Numbering Styles are described in 
the OpenOffice.org Help. 

Turning Bullets On and Off
Bullets may be turned on an off in a document. The following is one method to turn a 
bulleted list on and off:
1. Place the cursor in a paragraph to be marked with a bullet symbol, or select a number of 

paragraphs. 

2. Click on the Bullets on/off icon on the Text   Object Bar. The paragraph or paragraphs 
will be formatted as a bulleted list. 

3. In an existing bulleted list, if one clicks the Bullets on/off icon, the paragraphs will turn 
back into normal text. 

4. In a bulleted list, clicking on the icon at the far right of the object bar changes the Text 
Object Bar to the Numbering Object Bar which contains icons for moving and rearranging 
numbered paragraphs. By opening the context menu on the object bar, users can also 
select which bar to display. 
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One can select further settings for the bulleted list in which the cursor is positioned with the 
Format > Bullets and Numbering dialogue.

• Choose different bullet symbols under Format > Bullets and Numbering > Options by 
clicking on the button with three dots. This opens the Special Characters dialogue but 
only if “Bullet” was selected in the Numbering pulldown list.

Turning Numbering On and Off
Turning numbering on and off can be accomplished as follows:
1. Highlight the paragraphs to be numbered or returned to normal text.

2. Click on the Numbering on/off icon on the Text   Object Bar. The paragraphs are 
formatted as a numbered list or, with an existing numbered list, the paragraphs will turn 
back into normal text.

Numbered lists are best controlled in the same manner as bulleted lists, i.e. with the icons on 
the Numbering Object Bar. When a numbered list is moved down a level, the subordinate 
numbered list at this level starts from one again. Using the Show sublevels box in Format > 
Bullets and Numbering > Options, select which previous levels should be included in the 
numbered list.
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Example numbered list with sublevels:
1  Line one
2  and line two. If one enters a return the next the new paragraph will automatically be 

numbered 3. Pressing a Tab at this point increments the list sublevel, indents and changes 
the number to 1 at which point one can add text.
1. and now there is a sub level of line 2.  To decrement the sublevel of  a list paragraph, 

put the cursor at the beginning of the paragraph text and press Shift Tab.
The above list is not numbered as fully as it might be but serves as an example. Normally the 
full number of the last line should indicate the sublevel as 2.1 as well. To do this apply 
Format > Bullets and Numbering > Outline to that level. This will be reflected in Format 
> Bullets and Numbering > Options.

Outline Numbering
Choose Tools > Outline Numbering to number headings automatically. By default, the 
Paragraph Style “Heading 1” is assigned to the highest level of Outline Numbering.
For custom paragraph styles that should be used, apply these styles in this dialogue on each 
individual level.

Note: If a Numbering Style is selected from the Number pulldown list, then all paragraphs in a document that 
have the “Heading 1” format will have consecutive numbers placed in front of them.
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With respect to custom style s where there is, currently, a Paragraph Style “Head1” that is 
used for headings at level 1. 

1. In the Level list box select 1 

2. In the Paragraph Style pulldown list select Head1.
3. Click OK.
Now, all paragraphs to which Head1 is applied will be listed in the Navigator under 
“Headings”.
Remember that chapters can be rearranged the in the Navigator (see the section on the 
Navigator) when changing their order or their placing in the hierarchy. Using this feature also 
updates the numbering. 

• Click on one of the icons Promote Chapter, Demote Chapter, Promote Level and 
Demote Level, or 

Move the chapter heading in the Navigator using the mouse. 
The result is that numbering of all affected chapters is adjusted automatically. 

Automatic Bullets and Numbering
Writer also automatically recognizes bullets and numbering during entry if Format > 
AutoFormat > While Typing was previously chosen. Numbering that uses Roman numerals 
is also recognized and continued. 

Note: A list can start with any value: e.g., it does not have to begin with I. 

A stepbystep example with Roman numerals:

1. Enter I. (with a period after it), also followed by a space and text. A right parenthesis may 
also be used as a substitute for a period.

2. Press the Enter key to create a new paragraph.

3. The new paragraph will begin with II., i.e., the Roman numeral for two. 
4. Enter some text, press the Enter key and the next paragraph will begin with III. 
5. Repeat as needed.

Roman numbering can begin with any numeral desired, For example, with ci (corresponds 
to 101), which will be followed by cii (102) et cetera.
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Numbering Illustrations by Chapters
Numbering illustrations by chapter, so that illustrations are labelled “Illustration 
1.1 ”, “Illustration 1.2”, and so on in the first chapter and “Illustration 
2 .1”, “Illustration 2.2”, et cetera. in the second, is easily done. Use the following 
procedure to do this:
1. Organize a document in chapters. 

Choose Tools > Outline Numbering to number the chapter headings that are formatted. For 
example, where there is the Paragraph Style “Heading 1”, select the ”Heading 1” Style 
from the Paragraph Style list box and the option “1,  2, 3,..” from the Number list 
box below it. 
2. Select the first illustration for numbering. 

3. Choose Insert > Caption.... 
4. In the dialogue that appears, select Illustration as the category and Arabic (1 2 3) as the 

numbering. Caption text can also be entered in this dialogue. 

5. Click Options. 
6. Specify the chapter numbering in the Number Range Options dialogue. For example, 

select option “1” under Level and specify the separator wanted for chapter numbering. 
7. Click OK. 

8. In the Caption dialogue, click OK. The illustrations are now numbered by chapters. 
9. Repeat 17 for all other illustrations in the document. 
Numbering now occurs automatically: All illustrations within one chapter level are 
numbered,appropriately and the chapter level numbering wanted can be changed in the 
Number Range Options dialogue.

NOTE: Choose Tools > Options > OpenOffice.org Writer > General, and under Caption mark the Automatic  
check box. When the button next to Object selection is clicked, the Caption dialogue appears. Here one can, for  
example, determine that all illustrations in text documents from now on receive captions automatically. 

Defining Number Ranges
Define separate number ranges, or sequences to number each group of elements in a 
document that belong together. For example, notes, warning messages, quotations, et cetera. 
The following procedure shows how to do this:
1. For example, type “Note Number” in front of the first note.

2. Choose Insert > Fields > Other....
3. On the Variables tab page, select the “Number Range” field. 

4. For the Name, enter “Note.”

5. Click Insert
6. Close the dialogue.
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This “Note” number range enables users to automatically number all the notes in a 
document. In the field Value, select a new initial value for the entire number range. This is 
useful when dealing with a document in a series of connected documents. 

Number ranges and captions can be restarted with each chapter. In the Caption and Fields 
dialogues users can choose the chapter level at which to begin renumbering. 
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Using Master Documents and Subdocuments
A new empty master document is created by choosing File > New > Master Document, or 
creating a master document from an existing document by choosing File > Send > Create 
Master Document.

Note: Existing master documents have the extension .odm, thus distinguishing a master document from “normal” 
Writer documents in the Open File dialogue. 

Open a master document by choosing File > New > Master Document and the new master 
document is opened as an empty text document. Providing that the Navigator is not docked 
and collapsed, the Navigator opens immediately in global mode.
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The Navigator provides the functions needed for navigating and editing a master document. 

Doubleclick a document in the Navigator to load it for editing. Now the user can either 
enter text, such as headings, or insert subdocuments, by clicking the Insert   icon and 
choosing the desired entry Text or File. A new document “can also be inserted a by a long 
click on the icon to get the context list and selecting New document whereupon one “first 
enters the name and path for the document and then continues on to write the new document 
and save it.

Paragraph Styles that the user defines and uses in the subdocuments are automatically 
adopted in the master document. If the master document is saved afterwards, these Styles will 
be available everywhere in the master document. The Styles defined in the master 
document have priority over Styles with the same name in subdocuments. 
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Note: When using master documents, use the same template as a base for all subdocuments and the master 
document itself. As a new Style is needed in the document, simply add it to the document template and reload the 
master document so that the new Style can be applied to all documents automatically. 

Use Page Styles to ensure that all subdocuments always start on a new page (i.e. always on a 
new right page). There is a builtin Page Style called “Right page” that could, for 
example, be linked to the Paragraph Style “Header 1”. For example, by assigning a page 
break to the Paragraph Style “Header 1”, every “Header 1” will always be at the top of 
a right page. If the Next Style is assigned to the Page Style “Right page” select “Left 
page” instead and vice versa. 

If the cursor is positioned in a text in the master document, the entry Text is shaded gray 
because consecutive texts are always combined to one single text. New text can be inserted 
between individual inserted documents. The new documents or texts are always inserted 
above the current entry. However, one can easily change their order with Drag&Drop or with 
the icons Move down and Move up. 
Documents are inserted in the master document as protected areas. That means these 
documents cannot normally be edited within the master document bu it is possible to 
navigate through the document with the cursor and read them. 

All indexes are created directly in the master document and, automatically, include all 
subdocuments. 
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When one or more subdocuments are changed after creating an index, the 
indexes in the master document should also be updated. To do this, click the icon 
Update (as shown to the left) on the Navigator for master documents and select 
the entries to be updated from the submenu. Likewise, references work in a 
Master Document and its subdocuments, in the same manner a in subdocuments 
themselves “when these are defined in the documents involved. For example, if 
figures in a subdocument are numbered from “Figure 1” to “Figure 10 ”, 
figures in the next subdocument can numbered starting at “Figure 11 ). 

A Master document, together with all its parts, can be saved as a combined OpenOffice.org 
Writer document. To do so, do the following:

1. In the Navigator, click the Toggle icon.
2. In the Navigator list, doubleclick "Sections".

3. Rightclick a section name and choose Edit.
4. Select all of the sections in the Section list, and then click Remove.
5. Click OK.

6. Choose the command File > Export. and select the normal OpenOffice.org Writer text 
format in the list box File type. 

Printing a master document with all subdocuments, texts, and indexes is the same as printing 
any other OpenOffice.org document. Simply use the print direct icon on the Standard toolbar 
or via File > Print dialogue. 
To check if a link exists for a single subdocument or all subdocuments, position the mouse 
pointer in the Navigator on the corresponding entry. The path information for the original 
document appears in a small popup window. Should the file is no longer be found at the 
original path, a warning File not found is shown along with the original path and the entry is 
displayed in red in the Navigator. 

Warning: Graphics inserted in a subdocument and anchored "to page" will not 
be displayed in the master document even though the graphic always appears 
correctly in the subdocument. According to the closing entry on issue 50669, this 
is expected behaviour. To quote:
“It's a limitation of the OpenOffice.org master document concept. It is not 
possible to use reference to a certain "page" defined in a subdocument because 
the master document reorganizes the page flow, page number and references to 
collate all documents together. This way, the absolute reference to a page X in a 
sub doc is lost in the master doc. The graphic loses its anchor reference and 
simply disappears.” 
WORKAROUND To avoid this problem do the following:

a) Set the anchor to "To Character" or "To Paragraph" and 
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b) Choose suitable horizontal and vertical references to the page in the 
properties dialogue, under "Type > Position". 
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Importing Lists From Other Text Programs
Word processors internally organize bulleted and numbered lists in a unique manner, such as 
using special fonts or graphics that may not be available in OpenOffice.org. So, should 
OpenOffice.org import foreign text and present this information incorrectly, use the following 
steps to overcome these import problems: 

1. Import the document from the other application (File > Open and then the Files of type 
list box). Where bullets are not applied correctly, use the other application to try saving the 
document another export format, such as in RTF format, and then import this new 
document. 

2. Use the Find & Replace dialogue.
a) Select the string of characters which now appears at the start of each list and copy 

to the clipboard. This could be, for example, an asterisk (*) followed by a tab. 

b) Start Find & Replace.

c) Insert the contents of the clipboard in the Search for field (Ctrl+v). 

Note: To ensure that the search text is only found at the start of the paragraph by inserting a caret (^) before 
the search text and checking the Regular expressions box.

d) Click on Find All. To select all imported lists but do not close the Find & 
Replace dialogue at this time. 

e) Click on the Bullets on/off icon on the Object Bar to convert all the imported lists 
to OpenOffice.org lists. 

f) Back in the Find & Replace dialogue, click on Replace All. Since the Replace 
with field is empty, all selected strings will be deleted. For example, the asterisk * 
and tab, used above, will disappear. 

g) In the Bullets and Numbering dialogue define the type of bullets for bulleted 
lists.

Changing Numbering via the Keyboard
• To move the numbering down a level in the hierarchy (or further to the right), place the 

cursor at the beginning of the numbered paragraph and press the Tab key.
• Press Shift and Tab together to move an indented bulleted or numbered list up one 

level (to the left).
• To insert a tab stop at the beginning of a numbered line, press (Ctrl+Tab).
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Interrupting and Continuing Numbering
Sometimes, with a series of automatically numbered paragraphs, there is one paragraph that 
must not have a number as the following example demonstrates:
1. First paragraph.
2. Paragraph two.

An unnumbered paragraph.
3. Paragraph number three.
To do this, choose from the following methods:

Delete the automatic numbering
1. Select all paragraphs 1 to 4 and click on the Numbering on/off icon.
2. Place the cursor before the first character of the third paragraph.
3. Press the Backspace key to delete one character to the left.

Note: The paragraph remains indented but loses its number. The fourth character now has the 
number 3. This method also produces the desired result after saving in HTML format.

Formatting the paragraph
1. Select all paragraphs 1 to 4 and click on the Numbering on/off icon.
2. Place the cursor in the third paragraph.

3. Click again on the Numbering on/off icon.
This is how the unnumbered paragraph was produced in the example above. However, with 
HTML format, the interruption creates two separately numbered lists.

Continuing numbering with a new starting value
1. Number paragraphs 1 and 2 with the Numbering on/off icon.
2. Place the cursor in the fourth paragraph.

3. Choose Format > Bullets and Numbering and go to the Options tab.

4. In the Numbering pulldown list select “1, 2, 3 ...”. 

5. In the Start at spin box select the starting value – in this case 3.
6. Click OK.
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Numbering Lines
When lines are to be numbered within a document, select the line numbering properties that 
are wanted via the Tools > Line Numbering. The user can decide, for the whole of the 
document, whether blank lines should be counted as well, and whether lines in text frames 
should likewise be counted. Decide the intervals at which lines are numbered and insert 
separators between these intervals to identify a particular line number. The line numbering 
appears on the screen and is printed. 

Other line numbering properties can be applied to the paragraph (Format > Paragraph > 
Numbering) or to the Paragraph Style. Doing it this way ensures greater flexibility, as one 
can exclude a paragraph from the line numbering or restart the numbering at a paragraph 
with any value. 

Line Numbering for All Paragraphs
1. Select Tools > Line Numbering.

2. Check the Show numbering check box.
This numbers all the paragraphs in the document.

Line Numbering for Particular Paragraphs
1. Enable the line numbering for all paragraphs as described above.

2. Open the Styles and Formatting window and click the Default paragraph style.
3. Rightclick to open the context menu.

4. Click Modify to open the Paragraph Style: Default dialogue.

5. Select the Numbering tab.

6. Uncheck Include this paragraph in line numbering. As all paragraph styles are derived 
from the Default style, no paragraph will be numbered unless a subordinate paragraph 
style exists and was modified accordingly.

7. Now, in the document, highlight all the paragraphs that are to be numbered.

8. Select Format > Paragraph > Numbering, check the Include this paragraph in line 
numbering check box.

9. Click OK when done.
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Tables in Text
Tables and spreadsheets can be included in text documents.

Inserting Tables
There are a number of ways to insert tables in text documents:

Inserting an empty table using the mouse:
1. Place the cursor at the position in the text where to insert the table.

2. Point with the mouse to the Insert table icon on the Insert floating toolbar.
3. Press the mouse button and move the mouse down and to the right until the required 

numbers of rows and columns appear in the preview area under the icon.
4. Release the mouse button. (To abort the process, before releasing the button move the 

mouse up or to the left until the word Cancel appears in the preview area.)

Inserting an empty table via the Insert menu or floating toolbar:
1. Place the cursor at the position in the text where to insert the table.

2. Select Insert > Table from the Function toolbar or click briefly on the Insert Table icon 
on the Insert floating toolbar. Either opens the Insert Table dialogue.

Inserting a single row table by typing ++... or ||...
Type a sequence of two or more '+' or '|' characters at the start of a new paragraph and end it 
by pressing the Enter key. The paragraph is automatically converted to a table with a single 
row and the number of columns equal to one less than the number of '+' or '|' characters.
Separate the '+' or '|' characters by one or more of any of (, <tab>, <space>, =, _) in order to 
determine the initial column widths.

This feature can be turned off/on via the Tools > AutoCorrect > Options dialogue by 
toggling the Create Table check box.

Inserting from OpenOffice.org Calc with the clipboard
1. Open the text document and the Calc document from which to insert a range of cells.
2. Select a range of cells from the spreadsheet. Copy it to the clipboard, for example with 
Ctrl+c.

3. Switch to the text document. There are now various options for inserting the range of 
cells:

• Use the “normal” command Edit > Paste or Ctrl+V to insert the range of cells as an 
OLE object. Doubleclick on the OLE object in order to edit it with Calc tools and 
commands. Click outside the object to quit edit mode.
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Choose Edit > Paste Special to open the Paste Special dialogue which has several 
options from which to choose. The same options can also be found on the submenu of 
the Paste icon on the Standard toolbar:

Options Is inserted as...
“Calc” OLE object — as with Ctrl(V) or draganddrop
GDI metaFile Graphic
Bitmap Graphic
HTML (HyperText 
Markup Language)

A HTML table.

Formatted text [RTF] A standard OpenOffice.org Writer table object
DDE link (only under 
Windows®)

Table structure and contents, without formatting. With 
updating.

Unformatted text Plain text with Tab delimiters

Inserting from OpenOffice.org Calc using draganddrop
Open the text document and the Calc document from which to insert a range of cells.
1. Highlight the range of cells from the spreadsheet that should be in the document. 
2. Click in this selected range of cells and hold down the mouse button. Wait a moment until 

the cursor changes.
1. Without releasing the mouse button, drag the selected range of cells into the text 

document. Should the text document not be visible, first move the mouse pointer to the 
text document icon on the task bar and wait a moment until the text document opens. In 
the text document, a gray insertion cursor follows the mouse pointer to the location of 
where the table is to be placed.

3. Release the mouse button when the gray insertion cursor is at the location where the table 
is to be inserted.

Deleting Tables
When deleting a whole table from a text document, the user has the following options:
1. By paragraph:

a) Select from the end of the paragraph before the table to the start of the paragraph after 
the table. 

b) Press (Del) or Backspace.
2. By table:

a) Place the cursor in the table.
b) select all cells, for example by pressing (Ctrl+a)
c) open the context menu.

d) select Row > Delete. 

Note: Method 2 (by table) also works at the beginning or end of a document.

OpenOffice.org User Guide for 2.x 140



Chapter 3: Managing Text Documents With Writer 

Inserting Paragraphs Before Tables at Start of Page
Occasionally a table will get inserted at the very beginning of a text document or 
immediately after a fixed page break, and now text must be inserted before this table. This is 
not difficult but how to do it can be puzzling. Here's how:
1. Place the cursor in the first cell of the table, right at the start of any content in that cell.
2. Press Enter, which adds a paragraph before the table and moves the cursor to it.
1. Formatting Tables in Text Documents
A new table inserted into a text document can have the default format which means that the 
first row has the Paragraph Style “Table Heading”, and all other rows will have the 
“Table Contents” Style. Text entered in the first row will automatically be bolded and 
centered. This section describes various formatting options that can be used to determine the 
overall appearance of a table.

Resize columns, rows, and cells
Table columns and rows can easily be resized just by moving their borders. One can also 
easily merge ranges of cells into a single cell, or split individual cells horizontally or 
vertically. For this there are icons on the Table toolbar, called Merge Cells and Split Cells, 
which can be used, or use the corresponding entries in the Table menu. This gives great 
flexibility in formatting any table. 

Table AutoFormat
To quickly set up existing tables, a number of predefined table styles are available via the 
Table > AutoFormat dialogue.
Auto formatting cannot be applied, however, if the table has already had it's cell structure 
modified (cells merged or split, even if cells were merged and then restored to their original 
split state, et cetera).

Table properties in general
With the cursor in the table, open the Table Format dialogue either with the menu command 
Table > Properties or the Table command in the context menu.
To change the table background, for example, proceed as follows:
1. Select the cells to which to assign a background colour.

2. Now, either choose Table > Properties or click Table in the context menu of the selected 
cells.

3. In the Table Format dialogue, click the Background tab.
Notice the two list boxes at the top of the dialogue. In the left box, choose a colour or 
graphics as the background. In the right box, define whether to apply the background to 
the selected cells, the whole row, or the entire table. Cell formatting takes priority over 
row formatting. 
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4. Click OK upon making a choice.
5. Tables can be designed with even greater impact using thematically appropriate 

backgrounds. While background colours and graphics are always inserted behind text and 
values in a table, graphics and other objects can also be inserted into the table. 
a. Set the cursor in the cell where the object is to appear.

b. To insert graphics, choose Insert > Picture > From File.

c. In the Insert Picture dialogue, select the desired graphics file. 

d. Click Open.

e. Click on the inserted graphic object and select the Picture command from the context 
menu (or doubleclick on the graphic object). In the Picture dialogue, various settings 
can be defined for the graphic and its function in the document. 
For example, define how text is to wrap around, which will determine if the text 
should flow around, through or beside the graphic object. Users can also set a 
hyperlink which can be loaded whenever the graphic object in the text document is 
clicked. Furthermore, a graphic object can be linked to a macro and in so doing, 
assign various events to it. One could, for example, use this capability to program 
certain functions, such as having a sound played when the mouse pointer touches the 
graphic object. 
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Calculating in Text Documents
Formulae in Text Documents
Pressing F2 opens the Formula bar. Clicking the formula icon   in the formula bar opens 
a submenu from which one can insert a formula.
The formula appears in the input line at the current cursor position. To specify a range of 
cells in a table, select the desired cells with the mouse. The corresponding cell references 
also appear in the input line. Enter additional parameters, as necessary, and click Apply to 
confirm the entry. A formula can also be entered directly, if the appropriate syntax is known. 
This is necessary, for example, in the Insert Fields and Edit Fields dialogues.

Note: The SUM function is only valid in formulae within a table cell.

Formula Options

Basic Calculation Functions
Addition + Calculates the total.

Example: <A1> + 8
Subtraction  Calculates the difference

Example: 10  <B5>
Multiplication MUL or * Calculates the product.

Example: 7 MUL 9
Division DIV or / Calculates the quotient

Example: 100 DIV 15

Basic Functions in the Submenu
Sum SUM Calculates the sum of the selected cells.

Example: SUM <A2:C2> displays the sum of the values 
in cells A2 to C2

Round ROUND Rounds a number to the specified decimal places.
Example: 15.678 ROUND 2 displays 15.68

Percent PHD Calculates a percentage
Example: 10 + 15 PHD displays 10.15

Square Root SQRT Calculates the square root.
Example: SQRT 25 displays 5.00

Power POW Calculates the power of a number.
Example: 2 POW 8 displays 256.00

Operators
Various operators may be inserted in a formula. Choose from the following functions:
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List 
Separator

| Separates the elements in a list.
Example of using a list:
MIN 10|20|50|<C6>|<A2:B6>|20

Equal EQ or 
==

Checks if selected values are equal. If they are unequal, the 
result is zero, otherwise 1 (true) appears.
Example: <A1> EQ 2 displays 1, if the content of A1 
equals 2.

Not Equal NEQ 
or !=

Tests for inequality between selected values.
Example: <A1> NEQ 2 displays 0 (wrong), if the content 
of A1 equals 2.

Less than or 
Equal

LEQ Tests for values less than or equal to a specified value.
Example: <A1> LEQ 2 displays 1 (true), if the content of 
A1 is less than or equal to 2.

Greater than 
or Equal

GEQ Tests for values greater than or equal to a specified value
Example: <A1> GEQ 2 displays 1 (true), if the content of 
A1 is greater than or equal to 2.

Less L Tests for values less than a specified value
Example: <A1> L 2 displays 1 (true), if the content of A1 
is less than 2.

Greater G Tests for values greater than a specified value
Example: <A1> G 2 displays 1 (true), if the content of A1 
is greater than 2.

Boolean Or OR Tests for values matching the Boolean OR
Example: 0 OR 0 displays 0 (false), anything else results 
in 1 (true)

Boolean X 
Or

XOR Tests for values matching the Boolean exclusive OR
Example: 1 XOR 0 displays 1 (true)

Boolean And AND Tests for values matching the Boolean AND
Example: 1 AND 2 displays 1 (true)

Boolean Not NOT Tests for values matching the Boolean NOT
Example: NOT 1 (true) displays 0 (false)

Statistical Functions
Choose from the following statistical functions:

Mean MEAN Calculates the arithmetic mean of the values in an area or a 
list.
Example: MEAN 10|30|20 displays 20

Minimum 
Value

MIN Calculates the minimum value in an area or a list.
Example: MIN 10|30|20 displays 10

Maximum 
Value

MAX Calculates the maximum value in an area or a list.
Example: MAX 10|30|20 displays 30.00

Trigonometric Functions 
Choose from the following trigonometric functions:
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Sine SIN Calculates the sine in radians
Example: SIN (PI/2)

Cosine COS Calculates the cosine in radians.
Example: COS 1

Tangent TAN Calculates the tangent in radians.
Example: TAN <A1>

Arc Sine ASIN Calculates the arc sine in radians.
Example: ASIN 1

Arc Cosine ACOS Calculates the arc cosine in radians.
Example: ACOS 1

Arc 
Tangent

ATAN Calculates the arc tangent in radians.
Example :ATAN 1

More Defined Values
PI PI 3.1415...
Euler's 
constant

E 2.7182...

True TRUE not equal to 0
False FALSE =sum<C4>

Calculating in Text
1. Place the cursor at the position in the text where the calculation result should appear.
2. Press (F2) to display the Formula bar at the top of the main edit window (above the 
horizontal ruler if rulers are shown).
3. Enter the desired formula, for example (4+6)* 100.

4. Press Enter or click on Apply to insert the result.

Use the Formula icon to perform more complex calculations. Clicking on this icon opens a 
branched submenu from which to select a formula. The formulae are placed on the formula 
bar at the cursor position, and users are free to switch between inputting formulae and values 
from the keyboard and via the Formula icon. 
As an example of a more complex calculation to be performed in a text, suppose we want to 
calculate the mean value of three figures. 
1. Display the Formula bar with (F2).

2. Open the submenu of the Formula icon.
3. Choose “Mean” from the statistical functions. The input field will display ”=mean.”
4. Enter the first number and then a vertical bar (|) as the list separator.
5. Enter the second number, another separator and then the third number. The input field may 

now show, for example, “ =mean 12|22|34.”
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6. Press Enter, to inset the result as a field in the text.
7. Doubleclick on the field to edit it.

Calculating With formulae Located in Text
If the text already has a formula, the result can be entered into the text without using the 
Formula bar as follows:
1. Select the calculation formula in the text. This text must not contain anything other than 

figures, arithmetic operators and any currency symbols.
Example: 12 + 24 * 2

2. Hold the Ctrl key down and press the numberpad plus (+) key, or choose Tools > 
Calculate. The calculation result will be stored on the clipboard.

3. Set the cursor at the point where the result of the calculation is to be inserted.

4. Press Ctrl+V, or choose Edit > Paste.
In this example, the result, 60, is inserted. If the formula is still selected at the time of 
insertion, the result replaces the formula.
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Conditional Text
Fields can be used in a document to display text when a condition is met. For example, one 
can define the conditional text that is displayed in a series of reminder letters.
Setting up conditional text is a twopart process:

1. Create a variable, then
2. Create the condition.

Defining and using conditional text – by example

Defining a conditional variable
The first step in the process is defining a variable for the condition statement. 

Type “Reminder” in the document, and then add space.
1. Select Insert > Fields > Other.
2. Click the Variables tab.

3. Click “Set variable” in the Type list.

4. Type a name for the variable in the Name box, for example “Reminder”.
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5. Click “Text” in the Format list.

6. Enter “1” in the Value box,

7. Click Insert.
To display integers, click the “1234” format.

Defining a condition and the conditional text:
The second step in the process is to define the condition that must be met, the text to be 
displayed when the condition is met or not met, and to insert the place holder for displaying 
the conditional text in the document.
1. Place the cursor where the conditional text is to be inserted in the text.

2. Choose Insert . Fields > Other.
3. Click the Functions tab.

4. Click “Conditional text” in the Type list.

5. Type Reminder EQ "3" in the Condition box. In other words, the conditional text 
will be displayed when the variable in the field that was defined in the first part of this 
example is equal to three. 
The quotation marks enclosing the number 3 indicate that the variable, defined in the first 
part of this example is a text string. See above for a list of operators that can be used when 
defining a condition. 
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6. Type the text to display when the condition is met in the Then box. There is no limit to 
the length of the text that  can be entered. One can even copy and paste a paragraph into 
this box.

7. Click Insert, and then click Close.

Displaying the conditional text:
In this example, the conditional text is displayed when the value of the conditional variable is 
equal to 3.

1. Place the cursor in front of the field that was defined in the first part of this example.

2. Choose Edit > Fields.

3. Replace the number in the Value box with "3".

4. Click Close.
1. If the field does not automatically update, press F9.
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Calculating in Text Document Tables
OpenOffice.org Writer tables can also include calculations, and these can extend between 
tables.
For example, there are two tables, labelled Table1 and Table2 in which the first cell of 
Table1 must be multiplied by the first cell of Table2 and the product returned in cell A2 
of the current table.  In this case, the table names serve as table identifiers. 
Here's how:
1. Enter numbers into cells A1 of Table1 and A1 of Table2.
2. Position the cursor in cell A2 of Table2.
3. Press F2 to bring up the Formula bar. It already starts with an '=' ready for the user to type 

a formula.
4. Click on cell A1 of Table1. OpenOffice.org will insert the cell reference 
<Table1.A1> into the formula bar.

5. The formula bar is still waiting for the user to continue entering the formula, so now type 
* (the multiply operator).

6. Click on cell A1 in Table2. OpenOffice.org will insert the cell reference <A1> into the 
formula bar with no user action. Note that this time the reference does not need the table 
identifier.

7. Press Enter now to complete the formula and the product is presented in Table2 cell A2.

1. Note: With the help of the Navigation Bar one can navigate quickly and easily between 
the table formulae in the document. 

If a table formula refers to an invalid table cell, a “**Faulty expression**” is displayed in the cell. Invalid table 
cells are either deleted cells or those which are themselves faulty. 

It is only possible to refer to table cell values from within tables. One trick to inserting a table 
calculation result within text is demonstrated by this next example.
To add cells B1:B 10  from Table1 and present the sum in a line of text, :
Create the text and Table1. 
1. Place the cursor in the text where the sum is to appear. 

2. Insert a frame (Insert > Frame menu command). In the Frame dialogue select the 
Anchor as As Character.
a) Deselect the border.
b) Click OK to close the dialogue.

1. Deselect the frame by clicking outside it. 

Note: when entering text in the frame, click in the very centre of the frame. The frame should not be selected, but 
the text cursor should be inside the frame. 
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c) Insert a singlecell table inside the frame using Insert > Table. 
d) Set a row and a column value of 1, uncheck Heading, and uncheck Border.
e) Click OK. 
f) The cursor is positioned in Table2. 

b) Define the formula by either pressing F2 or typing an equal sign (=) into the cell (this is a 
shortcut), at which point the Formula bar will be displayed. 
The formula for calculating the total of cells B1 to B10 is: “ = <Table1.B1:B10> ”. 
But don't type this yet because there is a simpler way.

5. Highlight the cells in Table1 to be summed. Do this by keeping the mouse button 
pressed as the pointer is dragged from the first to the last cell being summed. 

6. Close the mathematical formula by clicking the Accept icon on the Calculation Bar. The 
result of the calculation will be seen in Table2. 

7. If there are changes in the cells being summed, update the result by pressing function key 
(F9). 

Note: Instead of first inserting the border and then inserting a table inside the border, start by inserting a single
cell table, then select the whole of this cell  the only way to do this is with the shortcut keys (Ctrl+a) and then 
click on the Insert > Frame icon. The border automatically surrounds the table (incidentally, this also works with 
any section of text). Now set the anchor to character, cut the whole table to the clipboard and paste it where it 
should go, remove the borders from the frame and table and apply further settings. 

Calculating Across Multiple Tables
Calculations in any text document, where there are more than one table which contains data 
required for calculation, can be done in OpenOffice.org Writer. For example:
• Insert two tables each with several rows and columns.
1. Enter a few figures in the tables, but leave at least one cell empty.
The tables should be automatically named “Table1” and “Table2”. If one chooses, each 
table can be given a different name (Table > Properties, Table tab, text box Name) using 
only letters and numbers for naming.
1. Position the cursor in an empty cell.
2. Press F2 to display the Formula bar.
3. As an example, enter SUM.
4. Individually click the cells containing figures in both tables that are part of the calculation. 

After each click, enter a plus sign (+) from the keyboard, and continue to the next cell 
containing a figure.

5. Finally, click the Apply icon on the Formula Bar. For example, if adding up the first two 
rows of each table and showing the total in Table2, the formula is 
=sum<Table 1.A1>+<A1>.
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Calculating Cell Totals in Tables
1. Insert a table with multiple rows (Insert > Table) into a new text document. 
2. Enter a series of numbers into a column, one number per row, leaving the last cell of the 

column empty. 
3. Place the cursor in the last empty cell of the column.

4. Click the Sum icon in the Table object bar. 
5. The Formula bar appears, and a formula indicates the cells of the column to be added. The 

cells are separated by a vertical bar (|). 

6. Press the Enter key to confirm, or click Apply in the Formula bar. The sum will appear 
in the last cell. 

When numbers are changed in the table, the sum is automatically be updated. If, for example, 
formatting the numbers as currency, select the cells and choose Number Format from the 
context menu. The Number Format dialogue appears, where the user can choose a new 
format. 

Merging and Splitting Cells
One can select adjacent cells together, then merge them into a single cell. Conversely, a large 
cell that has been created by merging single cells can be divided back into individual cells. 
The commands are different in OpenOffice.org Writer and Calc. 

Merging Cells in OpenOffice.org Writer
1. Highlight all the cells to be included in the merged cell.

2. Select Table > Merge Cells.

Splitting Cells in OpenOffice.org Writer
1. Set the cursor in the cell to be split.

2. Select Table > Split Cells.
A dialogue allows splitting the cell into two or more cells, horizontally or vertically.

Merging Cells in OpenOffice.org Calc OLE Objects
1. Highlight all the cells to be included in the merged cell.

2. Select Format > Merge Cells. The state of this menu item is toggled on. Note that this 
menu item reflects the state of the current selected cell.

Cancelling the merging of cells in OpenOffice.org Calc OLE Objects
1. Set the cursor in the cell to be split.

2. Select Format > Merge Cells. The state of this menu item is toggled off.
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Inserting or Deleting Rows/Columns Using the Keyboard
The following methods describe how to insert and delete rows and columns using the 
keyboard: 

● To insert a new column or row:
1. Put the table in insert mode by pressing Alt+Ins. OpenOffice.org will wait up 

to three seconds for teh user to press one of the following key commands:
i. Press the relevant arrow key to insert a new row or column to the right or left, 

above or below the current row or column.
ii. Hold down the Ctrl key as well as the relevant arrow key to add a cell in that 

direction, (by splitting either the current or an adjacent cell).
1. To delete a column or row:

2. Put the table in delete mode by pressing Alt+Del. OpenOffice.org will wait up to 
three seconds for the user to press one of the following key commands:
i. Press the relevant arrow key to delete a row or column to the right or left, 

above or below the current row or column. 
ii. Hold down the Ctrl key as well as the arrow key, to merge the current cell 

with the adjacent cell. 

Repeating Multiple Heading Rows in a Table
1. If automatically repeating more than one row within a table following a page break, 

this is how to do it: 
1. Select the first table row.

2. Open the context menu and choose Cell > Split.
a) In the Split Cells dialogue, select the “horizontal” direction. 
b) Enter the number of rows that are to be repeated 
c) confirm with “OK”. 

All rows at the beginning of a table that is created in this manner will now be repeated after a 
page break. 

Enlarging and Reducing Cells in Text Tables
The width and height of rows and columns are changeable using the keyboard, by dragging 
and dropping with the mouse or by commands in the context menu. Column widths can also 
be changed numerically via a dialogue. 

Rows and columns can also be evenly distributed with the icons on the Optimize 
floating toolbar on the Table Object Bar. 
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Rows and columns can also be modified either in the table directly, or with the aid of the 
rulers. If the mouse pointer is rested on a vertical dividing line in the table, the pointer 
appears as a separator symbol, and one can simply drag the dividing line to the desired 
position. (The user may need to click once outside the table before this procedure will work.) 
The dividing lines on the ruler can be moved in the same way. 
When the keyboard is used to enlarge and reduce a table, always hold down the Alt key 
while pressing one of the four arrow keys. The current column or row is enlarged or reduced 
by whatever amount is set under Tools  Options > OpenOffice.org Writer > Table > 
Keyboard handling. Rows and columns are handled separately. 
The current row or column is enlarged or reduced at its righthand or lower edge. If ones 
presses the Shift key as well as Alt, the lefthand or upper edge will be moved. Here are 
two examples that expect that the cursor is set somewhere in the middle of a medium to large 
text table:
1. Hold down the Alt key, and press the right arrow key. The current column is 

expanded by the amount specified Tools > Options > OpenOffice.org Writer > Table. 
The left edge of the column remains fixed while the right edge moves.

2. Now, hold down the Alt key together with the Shift key and press the right arrow 
key. The right edge will remain fixed while the left edge will move to the right, thereby 
reducing the column.

The height of the rows can be adjusted in the same way. However, since the rows are preset to 
a minimum height, one must first increase their size before the result is obvious. 
 By pressing the Ctrl key during the process, the enlargement or reduction will apply only 
to the active cell rather than to the entire row or column. The proportions of the table remain 
fixed. 

Adapting Table Widths
The display attributes of a table are defined by the settings under Tools > Options > 
OpenOffice.org Writer > Table. 

• Behavior of rows/columns — Fixed means, for example, that if one cell is made wider 
the adjacent cell will become narrower. Other cells will not be affected, and the overall 
width of the table stays the same.

• Behavior of rows/columns — Fixed and Proportional means that all adjacent cells 
become proportionally narrower. In other words, wide cells will shrink more than narrow 
ones. Again, table width remains constant.

• Behavior of rows/columns — Variable means that the width of the entire table is 
variable. Whenever an individual cell is made wider, the entire width of the table expands 
as well.

When inserting or deleting (cells, rows or columns), the table mode decides how the 
neighbouring cells, rows or columns should behave. In the table mode, new rows and 
columns are only inserted in a fixed way if there is sufficient space.
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Images, Drawings, Clipart and FontWork
Images, drawings, clipart, and special FontWork objects can be inserted in the text 
document.

Positioning Objects
There are various ways of anchoring the objects on a text page, such as graphics and text 
frames. The following describes the various options, based on the example of a frame:

Anchoring Effect
as a Character Frames are placed in the document like any other character, 

hence, they have an impact on the line size of the line and the line 
break.

to Character Frame is with its X and Y coordinates associated to a character, 
for example, in the X direction always to the margin and in the Y 
direction always to the height of the character (marginal frame). 
The frame should be set at “Flow”.

to Paragraph Frame is associated to a paragraph, changes its position with the 
paragraph.

on the Page Frame has always the same position in relation to the page 
margins.

on Frame Frame is inside the superior frame in a fixed position.

The anchor determines what specific text feature the object is bound to as the document's 
content and formatting is altered. For example, it is possible to set the frame on a fixed 
position in relation to a page margin, to a paragraph margin, to a text area, etc. 
The frame position on even pages can be automatically mirrored, so that a fixed position in 
relation to the right side of the page produces a corresponding position on the left side of the 
page. For example, a graphic can always be positioned inside the outer edge of pages. Where 
the graphic is, say, an arrow pointing to the text, it is a good idea to mirror this automatically 
on even pages too. To do this, use the Mirror on even pages option on the Type tab of the 
Graphics dialogue (choose Picture in the context menu of the graphic). 
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Captions and Number Ranges
In text documents one can create separate, continuously numbered captions for figures, tables 
and drawing objects. 
Users can also define as many separate number ranges as desired. The captions are linked to 
the figures, tables or drawing objects in a frame. Select the frame when the object is moved. 

Defining Captions
1. Select the figure or the object or place the cursor in the table that requires a caption.

2. Open the Caption dialogue with the command Insert > Caption.
3. The dialogue shows a preview of how the caption will look. Further text can be inserted in 

the Caption field. 
4. Click OK.

Note: If one would like to place a tab stop between the automatic captions (e.g., “Figure 1”) and the additional 
text, can be inserted it in the document later. Press Ctrl+Tab to insert a tab stop at the beginning of a paragraph. 

The paragraph format of an automatically applied caption is obtained from the Paragraph 
Style “Illustration”, “Table”, “Drawing” or “Text”. All of these paragraph styles 
are derived from the “Caption” Paragraph Style. So if all captions always are to appear in 
green, for example, simply modify the “Caption” Paragraph Style accordingly in the Styles 
and Formatting window. To examine this, switch the Styles and Formatting window to the 
“All St yles” view or to the hierarchical view. 

Editing or deleting captions
A caption is normal text which is placed together with an object in a common frame.
1. Edit the caption text just like normal text.
2. Delete the caption text just like normal text.

Inserting an object in a number range
Suppose the document contains illustrations as linked graphics, and these are labelled in a 
number range called “Illustration”. Now the user wants to add a drawing obtained 
with the drawing tools as a further illustration. Extend the automatic number range 
“Illustration” as follows: 
1. Below the additional illustration, insert a new line and apply the Paragraph Style 

“Illustration.” 

2. Open the Insert > Fields > Other dialogue. Pressing Ctrl+F2 is another way to open 
this dialogue. 

3. On the Variables tab, select the Type “Number range”. Under Selection select 
”Illustration”. 

4. Click Insert 
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5. Close the dialogue box. 
If illustrations are moved with their captions by hand so that the sequence changes, it may be 
necessary to update the numbers by pressing F9. 

Numbering Illustrations by Chapters
Numbering illustrations by chapter, so that illustrations are labelled “Illustration 
1.1 ”, “Illustration 1.2”, etc. in the first chapter and “Illustration 2 .1”, 
“Illustration 2.2”, et cetera in the second is often useful. Here's how to proceed:

1. Organize the document by chapters if this is not already done. Select Tools > Outline 
Numbering to number the chapter headings that are formatted, for example, with the 
Paragraph Style “Heading 1”. Select the ”Heading 1” Style from the Paragraph 
Style list box and the option “1, 2, 3,..” from the Number list box below it.

2. Select the first illustration to number.

3. Select Insert > Caption....
4. In the dialogue that appears, select Illustration as the category and Arabic (1 2 3) 

as the numbering. Caption text can also be entered in this dialogue.

5. Click Options. Specify the chapter numbering in the Number Range Options dialogue. 
For this example, select option “1” under Level and specify the separator wanted for 
chapterwise numbering.

6. Click OK.

7. In the Caption dialogue, click OK. The illustrations are now numbered by chapters.
Do the same for all other illustrations in the document. The numbering occurs automatically: 
All illustrations within one chapter level are numbered, and the user can enter at which 
chapter level to switch the numbering in the Number Range Options dialogue. 

NOTE: Choose Tools > Options > OpenOffice.org Writer > General, and under Caption mark the Automatic 
check box. When the button next to Object selection is clicked, the Caption dialogue appears. This is where one 
can, for example, determine that from now on all illustrations in text documents receive a caption automatically. 

Inserting Graphics
Graphic objects can be inserted in a text document in several ways. The following sections 
describe the most useful.

Inserting Graphics via dialogue
1. Set the cursor at the position in the document where to insert the graphic.

2. Choose Insert > Picture > From File. The dialogue Insert Picture will appear.

3. Select the desired graphic and click on Open.
By default, graphics are inserted with its alignment centered above the current paragraph.
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Inserting Graphics From OpenOffice.org Draw or Impress
Graphic objects can be copied and inserted from one document to another by dragging and 
dropping the object.
1. Open the document in which to insert the graphic object.
2. Open the document from which to copy the graphic object.
3. If the graphic has a hyperlink connected to it then the mouse pointer will change to a 

Grabbing Hand when the mouse is over the graphic. In this case switch from HYP mode (in 
the Status bar) to SEL (select) mode by clicking in the box where it appears.

4. Select the graphic by clicking on it.

Note: On some systems, pressing the Alt key and clicking the graphic object selects the object while in HYP mode 
without activating a hyperlink that may be connected to it. On other systems the Alt key is used to shift the focus 
to the Menu bar.

5. While holding down the Ctrl key, keep the mouse button pressed and drag the graphic 
object into the other document. 

Note: When the documents are not visible next to each other, first drag the mouse pointer to the destination 
document button in the Desktop Task bar. Continue to hold the mouse button down and the document, addressed 
in this fashion, is displayed, and the [still pressed] mouse pointer may be moved within the document and 
released. 

1. Release the mouse button as soon as the gray text cursor is at the position to insert the 
copy of the graphic object.

If the object is connected to a hyperlink and the method, outlined in the note above, is not 
used, the hyperlink will be inserted instead of the graphic object. Graphics inserted from a 
webpage are generally linked to the remote web site. Use Edit > Hyperlink  to embed the 
graphic in the document.

Inserting Graphics via Drag and Drop From the Gallery
A user can Drag and drop a graphic object from the gallery into a text document, spreadsheet 
or presentation to insert the graphic object. 

1. When dragging and dropping, without pressing a key or while pressing the Ctrl key, 
a plus sign appears next to the mouse pointer and the graphic object is inserted as an 
object. 

2. When dragging and dropping while pressing the Shift and Ctrl keys together, a 
linking arrow is seen next to the mouse pointer and the object is inserted as a linked 
object. A linked object is not copied into the document but refers to an object 
elsewhere. If the object elsewhere is modified, then all linked instances of it are also 
changed. The size of the object in the document does not change, so OpenOffice.org 
will automatically scale the view of the object if necessary.

When a graphic object is released directly on a drawing object, the following rules apply: 
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1. When dragging and dropping, without pressing a key or while pressing the Ctrl key, 
a plus sign appears next to the mouse pointer and the graphic object is inserted as an 
object on top of the existing object. 

2. When dragging and dropping while pressing the Shift and Ctrl keys together, a 
linking arrow is seen next to the mouse pointer and the existing drawing object is 
replaced by the object from the Gallery. The position and size of the object that is 
replaced remains valid for the new graphic. 

Adding Graphics To the Gallery via Drag and Drop
Graphic objects can be added to the Gallery and, thus,  have them conveniently available for 
use in any document.

1. Select My Theme in the Gallery themes box, or add a new via the New Theme 
button and select it.

2. Press and hold the Ctrl key while  dragging and drop a graphic object from the 
document to the Gallery images box.

3. Open the context menu of the new gallery image and select Title. Enter a name for 
the image and press OK.

Add  any themes to organize personal, readyuse images.

Inserting Graphics With a Scanner
To carry out scanning in Writer, a scanner with appropriate driver software must be installed 
on the local system. (Under Windows®,OpenOffice.org supports the TWAIN standard while , 
under Unix, OpenOffice.org supports the SANE standard.)
1. Set the cursor at the position in the document where the graphic is to be inserted.

2. Select Insert > Picture > Scan.
The submenu contains a command to open a dialogue for selecting the scanning source.

3. From the submenu, select the command to request scanning.
The scanner driver opens a window in which to follow the scanner manufacturer's 
instructions. 

4. Once the scanning process is completed, the image is inserted in the document.

Inserting a Chart From OpenOffice.org Calc

Dragging and Dropping the Chart with Move or Copy
1. Open the OpenOffice.org Writer document into which the chart will be inserted.
2. Open the OpenOffice.org Calc document containing the chart.
3. Click and hold the mouse button on the chart. Wait until the mouse pointer changes to the 

ArrowwithFrame pointer.
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Drag the chart into the OpenOffice.org Writer document.
This will move the chart. To copy the chart, press and hold the Ctrl key while  dragging.

Note: If the Writer document is not visible, first arrange the windows appropriately. If the operating system or 
windows manager provides a task bar, drag the chart to the Writer button on the task bar, hold that position for  
a moment while the Writer window opens in the foreground and then drop it in the now visible document.

4. In the Writer document, position the chart or modify the scale as one would any object.
5. To later modify the chart data, doubleclick and edit it.

Charts with Linked Data
If a chart depends on data in a Calc document and this data changes, a chart inserted by the 
above method is not automatically updated. To keep the chart and the data uptodate, do as 
follows: 
1. In the Calc document, copy the cell range from which the chart is created.

2. In the Writer document, longclick the Insert Object icon on the Standard toolbar to open 
the submenu.

3. Select Insert OLE Object. 
The data is now in a table in the Writer document and is always linked via OLE to the 
source data in the Calc document. (Note DDE is related to OLE and is handled as part of 
the implementation.)

4. Position the cursor in the table. 

5. Longclick the Insert Objects icon on the Standard toolbar to open the floating toolbar 

6. Click the Insert Chart icon. 

Inserting Decorative Horizontal Lines
Choose Insert > Horizontal Ruler to open a dialogue for selecting decorative lines.
The lines are graphics anchored to the current paragraph and centered between the margins. 
These lines may also be found in a Gallery theme. If one wants to continue using a line from 
the Internet, add it to the relevant theme in the Gallery. The line can then be selected from 
this dialogue. 
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Headers, Footers and Footnotes
Some Notes Concerning Headers and Footers
Headers and footers are always linked to the Page Style. All pages with the same Page Style 
automatically have the same headers and footers. By using Fields in the headers and footers, 
one can insert variable content in a text document, such as page numbers and chapter 
headings. 
Headers and footers are also available for HTML Writer documents. However, because 
headers and footers are not provided in the HTML definition, they are exported as special 
tags and are correctly interpreted again upon loading an Writer HTML page. Thus, web 
browsers show the content of the header or footer as the text which was there at the time of 
the HTML export while Writer inserts the fields again and updates these as and when 
necessary. (Author and sender, on the other hand, are only inserted as fields if the user, is the 
author or was the last one to modify the document.) Headers and footers are exported in 
HTML documents if they are enabled in Web Layout mode. 
If the content of headers and footers needs to change at different points within a document, it 
is best to create different Page Styles and apply these to the pages. 

Choose Insert > Header or Insert > Footer to toggle headers or footers on/off for a 
particular  Page Style. These operations don't affect the current page, unless the current page 
has that Page Style.

Format > Page may also be chosen to start a dialogue that allows selecting headers or 
footers for the current Page Style. Here find a check box Same content left/right. If this is 
not marked, format different headers and footers on the left sides than on the right sides. 

Note: If one only wants to assign a single page a different header, the user could also insert a text box to cover the 
header text. Anchor the frame to the page, and assign the ”Wrap Through” option and the background colour 
“White.” 

Inserting Page Numbers in Footers
Suppose that the cursor is  on a page that has a page style  that now requires  a footer be 
inserted. By doing so, all pages that  also use this style will also  display this footer.

Note: This is the only way to edit the content of a header or footer, that is, by finding or creating a page with the 
target page style first.

1. Choose Insert > Footer and select, from the submenu, the page style corresponding 
to the style being used for current page.  This will toggle the footer on for this page 
style (assuming it was not on already). The cursor now appears in the footer. 

2. Choose Insert > Fields > Page Number. The page number appears as a field in the 
footer. 
That's it. If the user now wants to format this field, for example by centering it across 
the page and adding some text so that it appears as  “Page 9 of 12”, this is how 
it's done:
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i. Place the cursor anywhere in the footer and click on the Centered icon on the 
Formatting toolbar. 

ii. Type the text “Page ” before the field and “ of ” after the field.

iii. Now choose Insert > Fields > Page Count.
1. Inserting Chapter Information in Headers
Fields containing the file name, date, time, chapter headings, et cetera can be inserted into a 
header.
1. Enter text in a document and apply the style “Heading 1” to chapter headings.

2. Activate the header for the page style used by the current page (Format > Page > Header 
or Insert > Header).

3. Click within the header to position the cursor in it.
4. Type “Chapte r: ”
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5. Select the Insert > Fields > Other “command.

a) In the Fields dialogue:

b) Select the Document tab

c) Choose Chapter in the Type box, 

d) Format Chapter name. Where the header to contain paragraphs formatted with 
Heading2 instead of Heading1, enter a 2 under Layer.

e) Click Insert to add the desired information to the header, and then close the dialogue 
box.

f) Now every page of the document using this page style will automatically display the 
chosen chapter heading in the header. 

Other information can be inserted into a header in the same manner. Find other menu 
commands under Insert > Fields. Choose from Date, Time, Page Number, Page Count, 
Subject, Title and Author. Additional field commands can be selected or defined under 
Other. 
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Formatting Headers and Footers
Headers and footers can be formatted with multiple objects where an object could be text, a 
field or whatever. The footer used in this document uses a table to contain the Title field and 
the page number field. 
Tabstops can also be used effectively for this purpose. The procedure for setting and editing 
tabstops can be found via Help > Contents > Index > Search term > tab stops. 

Defining Different Headers
A defined header and footer will appear in all pages that have the same Page Style. However, 
different headers for the first page or for even and oddnumbered pages are often needed. For 
example, one may want the name of the chapter to appear on the left (even) pages and the 
name of the first subchapter to appear on the right (odd) pages. Since headers are a property 
of the Page Styles, users need to define two different Page Styles and apply them to the 
respective pages. There are preset Styles for First page, Left page and Right page, which 
can be adapted to one's specific needs. 
Take the Page Style for left pages, this style might have different inner and outer margins, 
while the style for right pages has a mirror image of those margins. If different headers and 
footers are not needed, simply choose a mirrored page layout (under Page Layout in the 
tab Page). 

Switching between odd and even Page Styles and between First Page and Left Pages can be 
done automatically by defining the Next St yle. If one defines the Page Style with Next 
St yle and apply the new Page Style to the first page, then OpenOffice.org will 
automatically apply the correct Page Styles to the continuation pages. Here is a method:
1. Open a new text document.

2. Click the Page Styles icon in the Styles and Formatting window (Format > Styles and 
Formatting).

3. Choose the Style First Page to use as the basis for a custom Page Style.

4. Open the context menu and choose New.

5. In the Page Styles dialogue, go to the tab Organizer. 
a) Give the Page Style a name, such as “Page1,” and 
b) define “Left Page” as the Next Style.

6. For the “Left Page” define “Right Page” as the Next Style, and for the “Right 
Page,” choose “Left Page.”

Inserting Page Numbers of Continuation Pages
Footers are inserted using Insert > Footer. 

1. After creating the footer, set the cursor in it and select Insert > Fields > Other.... 
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2. Choose the Document tab and under “Type” select ”Page”, under “Select” select 
“Next page” and under “Format”, select “As Page St yle”. 

3. Finally click Insert to insert the field command in the footer of the current document.
The document will display the page number of the next page, with the exception of the last 
page. 
If the words “Continue on page” should also appear in front of the page number but should 
not appear if there is no next page, do this:

1. Set the cursor in front of the field that just inserted in the document

2. Open the Fields dialogue.

3. Select a field of the “Page” type, under Select, select “Next page” and under 
“Format”, select “Text”. 

4. In the Value text box, enter the text to be displayed if a next page exists in the 
document. Enter “Continue on page ” (note the space at the end!).

5. Click Insert. 
Of course, one can also enter instead of “Continue on page” , something else. For 
example, “.../”, to indicate the number of the next page. 

Inserting Lines Under Headers
Adjust the appearance of the header directly in the header itself. For example, by clicking on 
an existing header, users can format the text individually or as a whole paragraph. Additional 
attributes are available in the Format > Page dialogue in the tab Header. 

Selecting the Header tab permits defining a document header for the first time. Mark 
Header on. When the dialogue is closed by clicking on OK, a header is created which can 
then be filled out in the document. 

Click the More button on the Header tab to choose additional settings for the border and 
background of a header. 
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Draw a line under the header by going to the Borders tab. Under Line arrangement click 
between the two lower angle marks at the bottom of the rectangle. This tab page can also be 
used to define the style of the line and the distance between the header text and the line.

Footnotes and Endnotes
Footnotes in a text document can be displayed at the bottom of a page (or column where 
there is more than one column) or at the end of a document. The settings are defined by 
choosing Tools > Footnotes. The following information is also valid for endnotes. Endnotes 
are footnotes that appear collectively at the end of a document instead of at the foot of each 
page. 
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One can jump from a footnote anchor in the document to the footnote text quite easily by 
clicking on the footnote anchor. Press PgUp to return from the footnote to the text. 
• The footnote format can be changed by modifying the Paragraph Style “Footnote,” 

which is automatically applied to all footnotes in a document.
• To delete a footnote, simply delete the footnote mark in the text and the footnote text is 

automatically deleted as well.

Inserting and Editing Footnotes
Footnotes can be inserted in two ways: via an icon or via a dialogue.

Inserting a footnote via an icon
1. Set the cursor at the point where the footnote anchor should appear.

2. Open the Insert floating toolbar  on the Tools toolbar.

3. Click on the Insert Footnote Directly icon.

Inserting a footnote via a dialogue
1. Set the cursor in the document at the point where the footnote anchor should appear.

2. Select Insert > Footnote to open the Insert Footnote dialogue.
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When inserting a footnote using the icon, footnote numbering is automatic. The Insert 
Footnote dialogue on the other hand allows individual settings for the footnote.

Tips for Working with Footnotes
1. Click in the text of a footnote to allow editing or modification.
2. Press PgUp to jump from the footnote area to the footnote anchor in the text.
Place the cursor in a document immediately before the footnote character of a previously 
inserted footnote to edit its properties and choose Edit > Footnote or doubleclick 
immediately before the footnote character.
When defining general settings applied automatically to footnotes in the document, select 
Tools > Footnotes to open the Footnote Settings dialogue.

1. Format footnotes with Page Setup by choosing Format > Page... > Footnote.
In multicolumn pages, the footnote is inserted in the column where the footnote anchor is 
located.
Users can also use the mouse to jump from the footnote anchor to the footnote. The mouse 
pointer changes its appearance as soon as it is over the footnote anchor.

Spacing Between Footnotes
If a bigger distance between the different footnotes or endnotes is wanted, one can add an 
invisible (white) line as the lower border to the corresponding paragraph format:
1. Set the cursor in a footnote.

2. Open the Styles and Formatting window.
3. Click on the footnote Paragraph Style to be modified.
4. Open the context menu

5. Select Modify.

6. On the Borders tab page, select a top and a bottom line and give them both the colour 
white.

7. In the Spacing to contents area, uncheck Synchronize .
8. Increase/decrease the value of the upper or lower spacing.
9. Click OK.
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Spellcheck, Dictionaries, Hyphenation
Controlling Spellcheck via the dialogue
Choose Tools > Spellcheck or press F 7.

In a document where there are no unknown words Spellcheck will complete and display a 
message box to say as much.  Clicking the Ok button there will close the Spellcheck 
dialogue, so one  needs to deliberately spell a word incorrectly to see how Spellcheck works.

Normally the Spellcheck dialogue appears when called manually via the menu or by 
pressing F7. Selecting text before calling the dialogue and then checking the spelling 

only in the text that is selected can be an advantage. The Spellcheck dialogue is described in 
detail in Help. A manually initiated Spellcheck always begins at the cursor position, unless 
the text was selected (in which case it begins at the beginning of the selected text and ends at 
its end). When the spell checking does not begin at the beginning of the document or if the 
end of the document is reached during the checking process, a dialogue appears asking 
confirmation that checking continue checking at the beginning of the document. 
The system always searches first through the selected userdefined dictionaries and, if the 
word is not found there, it searches through the main dictionary. Should the word not be there 
either, the dialogue, shown above, is displayed and which allows the user to replace the 
“word. Type it correctly in the Word field or select a word from the list of Suggestions, and 
click on Replace. 

The word in the Word text box can be permanently added to the userdefined dictionary. 
First, select the Dictionary pulldown list. Then, click Add. 
When replacing a word in the Word field with another word, one can check this other word 
by clicking on the Check Word button. 
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If needed, all unknown words in a text can be automatically entered in the active userdefined 
dictionary. For instructions, refer to OpenOffice.org Help. 

Automatic Spellcheck
• From within a text document, click the AutoSpellingCheck on/off  icon on the 

Standard toolbar. All words marked as incorrect by the spelling checker will then be 
underlined in red.

• Right click on words underlined in this way and a context menu appears.

• The context menu often provides a list of suggested words, one of which may be clicked 
“to select it. The suggested word then replaces the word underlined in red.

If a wrongly typed word using the AutoCorrect function is replaced in the context menu, the 
word pair is entered in the AutoCorrect replacement table. To call up this table, choose Tools 
> AutoCorrect > Replace tab. 

If the word underlined in red is correct, one can place it in a custom dictionary using the Add 
command. 

To exclude words from the Spellcheck:
1. Select the words.
2. Open the context menu of one of the words.

3. Select Character.

4. Select the Format > Character > Font tab.

5. Select the language [None].
Removing Words From UserDefined Dictionaries
1. Choose Tools > Options > Language Settings > Writing Aids tab.

2. Select the userdefined dictionary and click Edit.
3. Now the Edit UserDefined Dictionary dialogue appears allowing the user to search 

through an alphabetic list.
4. Select the word

5. Click Delete.

Hyphenation
Hyphenation in text documents either can either be done automatically or manually.
• Automatic hyphenation is an attribute of paragraphs and Paragraph Styles. This means 

that one can switch the hyphenation on or off for a paragraph or for a paragraph format 
and select its properties.

• Manual hyphenation gives individual control, but can be tedious.
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Automatic hyphenation
In OpenOffice.org, automatic hyphenation is turned off by default. The following steps are 
useful for enabling hyphenation on an “as needed” basis:

1. For one or more selected paragraphs, open the context menu and select paragraph.
2. For all paragraphs formatted with a certain Paragraph Style, open the context menu in one 

of the paragraphs and select Edit Paragraph Style.

a) In the next dialogue, click on the Text Flow tab.

b) Under Hyphenation, checkoff Automatically.

3. To enable hyphenation in all paragraphs, edit the parent paragraph style of all derived 
paragraph styles.

a) In the next dialogue, click on the Text Flow tab.

b) Under Hyphenation, checkoff Automatically.

To enable automatic hyphenation without queries, select Tools > Options > Language 
Settings > Writing Aids > Options and select Hyphenate without inquiry. 

Manual Hyphenation
• For manual hyphenation, place the cursor at the point where the word should be separated 

and press Ctrl and .
The word will be separated if it is possible, even if automatic hyphenation is turned off for 
the paragraph.

If a hyphen is entered directly, Writer will not apply the automatic hyphenation for that word. 
Let's assume the word “Antarctica” would be hyphenated: Antarctica, but this 
should be: Antarctica. Enter all three hyphens manually (directly), including the one 
between “i” and “ca” as is used in automatic hyphenation.

There is a quick way to prevent a particular word from being affected by the hyphenation (or Spellcheck) 
functionality: 

• Select the word and choose Format > Character. On the Font tab select Language None. 

If a word should be permanently set to prevent automatic hyphenation such that it will never be separated, place it  
in an active userdefined dictionary with an equals sign after it: 

1. Choose Tools > Options > Language Settings > Writing Aids.
2. Select a Userdefined dictionary. 

3. Click the Edit button. Where there is no userdefined dictionary, as yet, create one by clicking the New button. 

4. In the Edit Custom Dictionary dialogue, enter the word. e.g., ”Companyname=” (without quotation marks) 

5. Click Close to close the dialogue. 

6. Click OK. 

Now, the word “Companyname” will never be hyphenated. 
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Selecting Tools > Language > Hyphenation avoids searching manually through the text in 
order to find words to hyphenate. This starts the following dialogue which shows all words 
that could be hyphenated with the current line break, one after the other.

The syllable at which the word could best be hyphenated at the current line break is 
highlighted. In the case where the word to be hyphenated should have the hyphen at an 
earlier place in the word, use the left arrow button to move the highlighting to the left. Click 
on Hyphenate to hyphenate the word at the highlighted place and the next word that could 
be hyphenated is displayed.
When Spellcheck recognizes the word, the default hyphens are displayed as well.

Thesaurus
The OpenOffice.org thesaurus provides a means to look up words that may be used instead of 
the highlighted word. 

1. Highlight the word in the text for which an alternative is desired from the thesaurus. For 
example, the word, clean.

2. Select Tools > Language > Thesaurus or press Ctrl+F7.
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3. In the dialogue which then appears, scroll down the two lower list boxes until a suitable 
word is found. If the dialogue is closed by clicking on OK, the selected word is replaced 
by the word in the Replace field.

Note: Not all languages have a thesaurus to accompany an installed dictionary.

When looking for alternatives for a word in another language for which a thesaurus is 
installed, for example an English word, 
1. Select the word in the text 
2. Call up the thesaurus. 

3. Click on the Language button to switch to “English (UK)” or “English (US)”, in 
order to select British or North American spelling. 

4. Then click on Search. 

If English language attributes are applied to the English words in the text (Format > 
Character, Font tab, Language list box), then Spellcheck, thesaurus and hyphenation will 
automatically be in this language. One can assign a language to paragraph styles in the same 
way. 
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Form Letters, Business Cards and Labels
Write form letters, design business cards and produce labels   all from data obtained from―  
a data source or that is sequentially numbered.

Creating Form Letters
To aid in creating form letters, the following section first gives some brief instructions and 
then detailed instructions.

Brief Instructions (For Quick Results)
1. Register an address data source in OpenOffice.org, if not done previously.

Instructions may be found with the search term “address book” in Help.

2. File > Wizards > Letter to open the dialogue.
3. Setup the template.
4. Select the addresses for the form letter, or enter them manually.
Click Create. Writer can now create the form letter.

Fixed and Variable Fields
Fixed fields are fields which are filled out only once, i.e., when the field is inserted into the 
document. For example, if writing an invoice based on an invoice template, use a fixed date. 
By doing so when setting up the invoice document, the field position will contain the current 
date and will not change later on. That is, the date of the invoice is determined only once. 
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On the other hand, a variable date is updated every time the document is opened and printed. 
A manual update of the fields (i.e. with the F9 key) sets the actual date in the field entered as 
Variable date.
If, for example, when inserting a date as a field in a form letter, the user must decide if it is to 
be inserted as a fixed or as variable date: 
• Where the date should never change; that is, as if the date is typed in directly (without a 

field), select a fixed date format. The advantage to using a fixed date field means that the 
form letter “can be saved as a template. Using this templates to a create a new form letter 
based on that template will have the date will automatically updated to today's date.

• By selecting a variable date, the date will be updated every time the document is opened 
or printed.

Apart from the date, there are various other fields which can also be used in a form letter. The 
most important fields are the ones which determine where the different elements of the 
recipient's address are to be placed. These fields have a direct connection to the database 
table which contains the address list. A field will be inserted in the form letter for each data 
field, such as name, street, city, et cetera. When printing, Writer inserts the desired data fields 
in the fields from each record. In most cases, create the form letter template.

1. File > Wizards > Letter to open the dialogue.
2. Setup the template.
3. Select the database containing the addresses for the form letter.
4. Set the fields as directed by the Wizard
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5. With each dialogue, select the features needed.
6. Click Create to add this document to the templates and to open a Writer session to 

complete the body. 

7. If the body text will be used in the future, use File > Template > Save and overwrite the 
initial instance of the template.

Having done this, this template may be used for other form letters:

1. Select Tools > Mail Merge Wizard to start the process of creating a form document 
based on the template just created. The letter based on this template will be displayed and 
already contain the fields for the address, date, sender, et cetera. 

2. Choose From a template in the Mail Merge dialogue. 
3. Press F4 to open the data source for the current document. 
4. Select the records necessary for use in the form letter by clicking the row headers at the 

left in the data source view. Press the Shift key and/or the Ctrl key to make a 
selection. To print a form letter for all the records in the table, click the empty field above 
the row headers to select all records. 

5. Edit to suit personal requirements.
6. Save the document.

7. Now click the Mail Merge icon on the Table Data toolbar at the top of the data source 
view. The Form Letter dialogue appears, where two choices are offered, to save as file(s) 
or print. One can also choose to print selected records, all records or a particular range. If 
printing a range, for example, records 1 to 5, ensure that the numbers follow the order 
displayed in the data source view. 

To sort or filter records in the data source view, by click the respective icons on the database 
bar. For example, to sort all records according to postal code, place the cursor in the POSTAL 
CODE (ZIP) field of any record and click Sort Ascending. Now the form letter is all ready to 
go! 

Note: If a completely new document containing the necessary form letter fields is being created, use drag and drop 
to do so: Open the text document and press F4 to show the desired database table. Point to a column header and, 
holding down the mouse button, drag it into the document. The field for inserting this item from this database table 
is automatically placed in the document. 

Creating and Printing Labels and Business Cards

Designing Business Cards via dialogue
Choose File > New > Business Cards to open a dialogue with several tabs that help design 
the look of business cards. These are generally fairly simple, which may or may not be what 
is wanted.
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Designing Labels and Business Cards
Using File > New > Labels for designing business cards, as business cards may be regarded 
as a simplified, special kind of label, is often the best method. Like labels, all business cards 
are the same and, as labels, can be filled with different contents, graphics, data obtained from 
a database, or they can be marked with serial numbers. 

1. Select File > New > Labels to open the Labels dialogue.

2. On the Labels tab, under Format, define the label format.
Writer contains many formats of commercially available sheets for labels, badges, 
business cards etc. Userdefined formats can also be added.

3. On the Labels tab, under Inscription, choose what to write on the labels.
This often involves database fields, so that the labels can be printed with varying content, 
when sending “Form Letters” for example. But it is equally possible to have the same 
text printed on every label.
Use the pulldown lists to select the database and table from which the data fields are 
obtained. Click on the big arrow to transfer the selected data field into the inscription area. 
Press Enter to insert a line break. Entering spaces and any other fixed text is also 
possible.

Using the Format tab, define custom label formats, not covered by the predefined 
formats. To be able to do this, the label type on the Labels tab must be set to “Use r
defined”. On the Options tab, specify whether all labels or only certain ones are to be 
created.

4. Enable Synchronize contents check box on the Options tab. If this is checked , only one 
(the top left label) has to be entered and edited while the remainder will be repeated 
identically 

5. Upon clicking New Document, a small window opens with the Synchronize Labels 
button. Enter the first label. When the Synchronize Labels button is clicked, the current 
individual label is copied to all the other labels on the sheet.

6. Click on New Document to create a new document with the settings that have been 
entered.

7. Print the new document.

Printing Labels With Serial Numbers
Printing lottery tickets or entry tickets with serial numbers on them is quite easy. This is how 
to do it:

1. Select File > New > Labels. This opens the Labels dialogue. 

2. On the Labels tab, under Format, select the format in which to print. 
3. Tickets, label tags or rolls are available from specialist suppliers and are often made from 

stiff paper with tearoff perforations, or as selfadhesive labels on a backing material. 
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4. To define a custom format, select the Format tab. 

5. Check Synchronize contents. 

6. Click on New Document. 
7. A new document is now created, divided up as wanted. only the top left label needs to be 

edited and, when satisfied, “press Synchronize labels to make all labels appear the same. 
This button is only visible if Synchronize contents is checked on the Options tab. 

8. Enter the desired text in the top left label and format the contents. 
9. Serial numbering can be applied by inserting a field. 
10.Place the cursor at the point where the number should appear. 

11.Press Ctrl+F2 or choose Insert > Fields > Other. 

a) In the Fields dialogue, go to the Variables tab. 

b) Select the type Set variable, if it is not already marked. 

c) In the Name box, enter a name for the counting variable, for example Number. 
d) To increment the variable from one label to the next by 1, enter the following formula 

in the Value text box: Number+1. 

e) Click Insert, then close the Fields dialogue. 

12.Click Synchronize Labels. 
13.Now save and print the finished document. 

Printing Address Labels
When printing address stickers for form letters that do not fit in window envelopes, do the 
following:

1. Select File > New > Labels to open the Labels dialogue.
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2. Select the format of the label sheets that will be printed from the dropdown menu. 
Remember to check Synchronize contents on the Options tab.

3. Click on New Document to close the dialogue.
4. When the label document open, invoke the data source view by pressing the F4 key. 

5. Click the Tack icon at the edge of the data source view to avoid having it cover the first 
label. 

6. In the data source view, select the address data source table. 
7. Drag the data fields needed for the Address individually into the top left label. For 

example, click on the column header NAME and, keeping the mouse button depressed, 
drag it into the label. This inserts a field. 

8. Put the fields in order to complete the address in the first label at top left. 
9. Place the cursor at the last text position (after the last field) in the first label. 

10.Open the Fields dialogue by pressing the shortcut keys Ctrl+F2.

11.Choose the Database tab. 

a) Select the type Next record, 

b) Click on Insert 
c) Click Close. 

12.Now synchronize the labels by clicking the Synchronize button in the small window. 
13.In the data source view, select the records that will printed on the labels, by clicking on 

the row headers to the left. Use the Shift or Ctrl key in the usual way to select several 
records at the same time. 

14.On the Table Data toolbar, click    the Data in Fields icon. 

15.Now save and/or print the label document. 

After the last label on the page, the command Next Record is effected automatically. Therefore, do not insert the 
command manually after the last label on a page. 

Avoiding Blank Paragraphs
Sometime fields in a form letter can be empty and a blank line is printed. For example, there 
is a field named COMPANY that should appear in the recipient field, but for some records 
this field is empty. To prevent these empty fields from being included do the following:

1. Place the cursor in the text document before the form letter field COMPANY. 

2. Choose Insert > Fields > Other to open the Fields dialogue. 

3. On the Functions tab select the type Hidden Paragraph.
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4. In the Condition field, enter the following text (without quotation marks): 
not(Company)

Now the COMPANY line will not be printed, and the rest of the lines will be moved upward 
if the COMPANY database field is empty.
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Newsletters
In this section, learn how to create a newsletter/newspaper as a text document. This is useful 
for creating newsletters for a company or club, or in celebration of a special event. Currently 
OpenOffice.org does not have a resident newsletter template but there is a nice one that 
works available from http://   ooextras.sourceforge.net   /   and this is one used in this section. 
To install the template after downloading, do the following:
1. Open the template in OpenOffice.org Writer.

2. Select File > Templates > Save
3. Choose where to save the template. Default is probably best as no special permissions are 

needed.
4. Name the template
5. Click OK
Voila, there is now newsletter template ready for use.
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Creating a Newsletter From a Template
In the File menu choose New > Templates and Documents. Locate and doubleclick to open 
the Newspaper Template.
The document contains several useful elements that could be of good use of in a newsletter. It 
contains, for example, an automatic page numbering system and a field with the fixed date. 
One can now enter text and position graphic objects.
Modify the existing heading as needed and insert any graphics.
A few other texts highlighted in gray are variables, which modifiable.
When the document is completed, save and print it.

Edit the template (File > Templates > Edit) for any personalization and layout changes.

Creating Page Styles
Where a page must include not only text but also several larger graphics, create a separate 
Page Style for this purpose.

1. Open the Styles and Formatting window and click the Page Styles icon.

2. From the context menu, select the command New to open the Page Styles dialogue. 

3. In the tab Organize, assign a descriptive Name for the Style.

4. Next, click the Page tab and define the page format and margins. 

5. Check Registertrue and choose the reference Paragraph Style Text Body.

Note: If the registertrue option is activate, the baselines of all paragraphs with the Text Body Style will be exactly 
aligned so that they are at the same position in each column and on each page in relation to the page. With double
side printing, the baselines of the registertrue paragraph will have the same position. Normally use the Paragraph 
Style used to create the actual text. To define another Paragraph Style as registertrue, call up the properties 
dialogue of that Paragraph Style. Call it up, for example, in the Styles and Formatting window via the context menu 
of that particular Paragraph Style, select the Modify command. On the Indents and Spacing tab, in the field under 
Registertrue, select Activate. 

Editing Headers
To edit a header, click in the header field in the document. With the context menu (Page), 
activate the Page Styles dialogue. Select the Headers tab and click Options. In the Borders/
Background dialogue, choose a background colour and click OK, then confirm the following 
dialogue as well. 

Editing Columns
To change the number of columns or create a dividing line between columns, activate the 
Page Styles dialogue via the Page context menu. 

Click on the Columns tab. Change the number of columns in the spin box Amount, and 
modify the distance between the columns in the spin box Spacing. Make sure that the 
Automatic Width field is selected. 
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To create a dividing line, select a narrow line from the Line list box under Separator, set the 
Height to 75%, and define the position as Centered. Finally, click OK to close the dialogue. 

To place headings or subheadings that are more than a column wide into a multicolumn text, 
try putting them in a text frame. The text frame can the be freely scaled and positioned on the 
page. Insert a frame using the Insert Frame icon on the Insert floating toolbar. Text frames 
can may also have borders, but this is not always necessary. 

Editing Paragraph Styles
1. Click the Paragraph Styles icon in the Styles and Formatting window and select the 

paragraph style to be modified. 

2. Select the Modify command from the context menu, call up the Paragraph Styles 
dialogue. In this dialogue, there are several tabs with various settings and options. 

Experiment with font effects, for example drop caps. Click the respective tab and select 
Show Drop Caps. Drop caps may even be assigned a Style in the Character Styles list box 
under Contents. 
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Note: Newsletters or newspapers require a variety of main headings, subheadings, and text wraps to make it easier 
to read. In the Paragraph Styles dialogue of the Styles and Formatting window context menu, it would thus be a 
good idea to create several appropriate paragraph styles ( go to the Styles and Formatting window > context menu 
> click New...). 

Working with Frames
A frame positioned over one or more columns can give the newspaper a less crowded, more 
interesting appearance. Such a frame can contain text, graphics, or even a chart. 

Click the Insert icon on the Tools toolbar and from the floating toolbar, select the Insert 
frame manually icon. The mouse pointer changes to a small cross that is dragged to open a 
frame and position it over one or more columns in the document. 

Formatting a Frame 
Put the cursor in the frame (deselect the frame first, then click inside it) and enter any text or 
graphics. The appearance and properties of the frame can, of course, be modified at any time. 
Select the frame by clicking it, call up the context menu and click Frame.... A dialogue with 
several tabs will appear which allows, for example, one to apply a coloured shadow to the 
frame via the Borders tab. 

Anchoring Frames
In the Frame dialogue, click the Type tab and select the type of anchor under the heading 
Anchor to. If the frame is to always remain on the same page — which is important for a 
table of contents, for example, — select Page. For the frame to flow with the text, e.g., for 
small symbols which always appear in the margin accompanying a certain word in the text, 
select To Character. Or, in flowing text, the frame should move with the text as a character, 
select As Character. Select Paragraph to anchor a frame to a specific paragraph,. 
The type of anchor can also be specified from the context menu. Alternatively, click the 
Change Anchor icon in the Object bar to quickly change the anchor. 

Defining a Frame Wrap 
Open the Frame dialogue (context menu > Frame) to define the frame wrap and click the 
Wrap tab. Select the desired wrap style, and under Spacing, define the spacing between the 
frame and text. Finally, select the option First Paragraph. 
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The First Paragraph field (or the menu command in the context menu) ensures that when a 
graphic is positioned between two paragraphs, only the first paragraph wraps around the 
picture. 

Defining a Wrap Region 
Note: As one follows this procedure, ibut cannot find an icon in a toolbar to which the description refers,  check 
the  Visible Buttons menu for the toolbar.

Making a newsletter more attractive with objects or graphics is done easily by having the text 
flow around an object. Simply draw a polygon using the Polygon icon in the Draw 
Functions toolbar. Place the polygon over the text and assign the text the Wrap > Contour 
with its context menu. 
A wrap contour to 3D objects can also be defined. Create a 3D object with OpenOffice.org 
Draw, copy it to the clipboard and paste it into the text document. Open the context menu of 
the inserted object and choose Wrap > Contour. In the context menu of an object with a 
wrap contour is the Wrap > Edit Contour command. This command calls the Contour 
Editor from which manually reediting the automatic contour is possible. Refer to the 
instructions in Help. 
Linking Frames and Facilitating Text Flow 
If the text should be continued in the same manner as in a newspaper, i.e. from a frame on 
page 1 to, say, a frame on page 4, and where the text flow from frame to frame must be 
done automatically, use linked frames. 

1. Create two (or more) frames by opening the Insert floating toolbar, clicking Insert 
Frame.

2. Select the first frame (click the border of the frame). 

3. Click the Link Frames   icon on the Frame toolbar. 

4. Now, click the second frame. 
5. To enter text in the linked frames, position the cursor in the first frame and type in 

text or insert it from the clipboard. 

Note: If certain text from a document is to flow in linked frames, first put the text cursor in the first frame 
(first click the normal text to cancel the frame selection and then click the frame). 

6. Now decide if the text should be a copy in the frame or if it should keep a link to the 
original document (in this case it would always return to the actual stand of the 
original document). If the text is only to be copied, choose the command menu Insert 
> File. 
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7. If the text is a section linked to another file choose Insert > Section. In the Insert 
Sections dialogue that appears, click Link and select the file wanted with the ... 
button. 

8. Finally, click the Insert button. 

Using coloured or Graphic Backgrounds 
To assign a coloured background to a paragraph, place the cursor in that paragraph and click 
the Background colour icon in the Object bar. A floating colour palette appears from which 
the desired colour is selected by clicking it once. 

Note: When frequent use of a background colour for certain paragraphs is used, it is best to create a Paragraph 
Style for this purpose. 

A background can be a graphic image rather than a colour. The background graphic image is 
assigned to a paragraph either via the Paragraph Style (in that case, all paragraphs based on 
this Style will have the same graphic background), or use Format > Paragraph.... to edit it. 
Click the Background tab and in the list box As select “graphics” in order to pick out an 
appropriate graphic image. 

Creating a Table of Contents 
Tables of contents can be created manually; however, if the contents are altered, the table of 
contents must be manually updated, as well. It is much more convenient (and timesaving) to 
have the program create a table of contents automatically. 
1. With the text entered, creating a table of contents on the front page of the newspaper or 

newsletter may be in order. To do so, follow these steps: 
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a) Draw a frame manually on the front page, 

b) Select To Page as anchor. 
c) Press the Escape key to set the cursor in the frame. 

2. Open the Insert Index/Table dialogue (choose Insert > Indexes and Tables > Indexes 
and Tables). 

3. On the Index/Table tab page.

4. Select “Table of Contents” as Type,
5. Enter an appropriate heading, e.g., “In this issue...” in the Title field. 

Ensure that one of heading Paragraph Styles is assigned so that chapter numbering may be 
determined for the headings. These are determined by the Styles under Tools > Outline 
Numbering. The predefined Paragraph Styles are “Heading1” through “Heading 10”. 
If the table of contents should use the headings in the document, specify the desired outline 
structure using the Evaluate up to level spin box. 
If other, customized Paragraph Styles for the headings have been defined, these can also be 
incorporated “into the table of contents. To do so, go to the Insert Index/Table dialogue, 
click the Index/table tab and in the Create from area, mark the Additional Styles check 
box. Click the button to the right of the check box. The Assign Styles dialogue will appear. 
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This is where the level of the Style is assigned, in the table of contents, for each Style used in 
the document. 

Choose more settings on the Entries and Styles tab pages and Click OK to create the table of 
contents. 
Once the newsletter or newspaper is finished, save and print it. 
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Further Information

Using Automatic Hyphenation
When working with columns, it makes sense to activate automatic hyphenation for every 
Paragraph Style (do so by calling up the context menu of the Styles and Formatting window 
and clicking Modify... to access the Paragraph Style dialogue > click the Text Flow tab). 
Enter a “3” for Characters at line end and Characters at line begin to ensure that 
hyphenated words have at least three characters at the beginning or end of a line. For text 
alignment in columns, choose Justify on the Alignment tab. 

OpenOffice.org User Guide for 2.x 190



Chapter 3: Managing Text Documents With Writer 

Letters With Envelopes
With OpenOffice.org Writer, a letter can be written in no time. These instructions show how 
easy it is.
There are two really easy ways to get a result:
● Use a letter template, 
or
● Use the Wizard to create a custom tailored letter template.

Using a ReadyMade Letter Template
1. Press Shift+Ctrl+N to open the Templates and Documents dialogue:

2. Select a template.
3. Enter the details required for the various wildcards, such as the salutation.
4. Type in the remaining text.

Templates include the user data that was entered in Tools > Options >OpenOffice.org > 
User Data and which may be modified at any time. 

Creating a Letter Template Using the Wizard
1. Start the Wizard by selecting File > Wizards. 
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2. Click Letter in the submenu to see the first page of the Wizard for Letters. 

3. Select Personal Letter.
4. click Next to bring up a second page with additional options appears. 

5. Choose the option No Logo.
6. click Next. A dialogue will appear in which one can enter the sender details. 

7. The sender address is displayed at this point. Thus, under Show sender? select Yes. 

8. Click the symbol top right in the Position and size area.

9. Click Next. 
Note: If the input field does not contain a sender, the program will lack the necessary details. In this case, click 
Cancel, open the User Data tab (in Tools > Options > OpenOffice.org) and enter the necessary data. After 
that, reopen the Wizard and carry on as described up to this point. Sender details may also be entered directly 
in the input field of the Wizard; however, these details are not currently entered in Tools > Options > 
OpenOffice.org > User Data, this process for every must be repeated with new template created with the 
Wizard. 

10.Continue to click Next until reaching the page with the footer options. 

11.Deactivate the check box Footer on 
12.Click Next twice. 

13.Enter the name of the template in the Name field. If necessary, enter any additional 
information in the Info field. (The template will be stored in the template folder under the 
name chosen.) 

14.Click Next. 
15.Enter the printer trays if different paper trays are “to be used for the first and subsequent 

pages. This is especially practical when the only the first page is to be on letterhead paper. 

16.The last step is to click Create. 

After clicking the Create button, OpenOffice.org creates a document template and places it 
in the template folder. At the same time, a new, unnamed document appears on the screen, 
that has been generated as a copy from this template. 
Now start entering text and then save and print the document. However, if one would like to 
keep on working on the layout of the document template or create an envelope for it, close 
the new document without saving it. 

Creating an Envelope Template
This section contains a description of how to create a template for an envelope after 
completing a letter template plus some tips on how to continue polishing template design.
As the envelope should be saved together with its template, open the letter template.

1. Select File > Templates > Edit. 
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2.  Locate the letter template wanted and open it. The templates are found in the 
OpenOffice.org directory user/template in the user's home directory. (Path names may 
vary with different releases.)

3. Go to the Insert menu

4. Select Envelope. A dialogue of the same name appears. 

5. On the tab pages Envelope and Format, specify the envelope format and the position of 
the addresses of the sender and addressee on the envelope. Use the Printer tab page to 
define appropriate print options. 

Inserting an Envelope into a Document
Click on the Insert button in the Envelope dialogue. The envelope will be inserted above the 
first page of the active document. (In this case, before the first page of the personal letter 
template) 

To continue editing the envelope (for instance, to change the format again), open the Page 
Style: Envelope dialogue (in the context menu of the envelope click Page... and select the 
Page tab). 
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Adjusting the Printer for the Printout 
Printing envelopes depends very much on the type of printer used. Some printers require a 
special cassette, while others have a multipurpose tray that can feed envelopes. If in doubt, 
consult the manual for the printer. 

Specify any print options in the Page Style: Envelope dialogue. To open this dialogue, click 
an empty spot on the envelope, open the context menu, and select Page.... Then select the 
Page tab. Define the desired settings under Paper Format. 
Check File > Print ... > Properties to ensure that the printer knows the size of the envelope 
being used. When this step is skipped, printing of an envelope becomes unpredictable.

Creating and Printing a Letter With an Envelope
With the creation of a customized template for personal letters, write and print a letter.

1. Select File > New > Templates and Documents.
2. In the dialogue select the template.
3. Click OK. OpenOffice.org creates a document based on the template without changing the 

template itself no matter of the modifications to the document.
4. Enter the text of the letter in the document.
5. Check if the addressee information on the envelope is correct.
6. If this document is to be printed or edited later on, save it and enter a name.
7. Place an envelope in the printer. 

8. Select the command File > Print and print page 1, which is the envelope.

9. Place normal letter paper in the printer, select the command File > Print again.
10.Print the second page. If the letter has more than one page of text, specify which pages to 

print under Pages.

Creating an Single Envelope
1. Open OpenOffice.org Writer
2. Insert Envelope
3. On the Envelope tab, enter the address info.
4. On the Format tab, set Size > Format to DL. Adjust layout to suit.
5. On the Printer tab, Select the layout that reflects how to feed. 
6. On the same tab, click on Setup. This opens a new dialogue.
7. On the Setup dialogue, select the printer and click Properties.
8. On the Properties dialogue, select the envelope size in the Paper size dropdown list. 

In this case, Envelope DL.
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9. Same dialogue, select Orientation. This depends on how the  envelope feeds (see step 
5) In any case, landscape means that  the text is rotated 90 degrees so that it is parallel 
to the long axis of the envelope and vice versa for portrait.

10. If there is a manual feed tray, select this under Device.
11. Click OK
12. Click OK
13. Select New Doc if one only wants the envelope or insert to add it to the existing 

document. 
14. In the new window, check that all is okay and click the print icon.Creating an 

Envelope Template

Adding a POSTNET Bar Code to an Envelope

Get a POSTNET font
First thing to do is get a suitable POSTNET font. Do not be duped by the shareware notion of 
'free', which must be interpreted as 'free download' of a demo or crippled version of a 
commercial product for whichusersmust pay to use but, thanks to the the tenacity of Ross 
Johnson, there is one available that works. Please see 
http://www.adams1.com/pub/russadam/fonts.html and in the POSTNET group select 
http://www.adams1.com/pub/russadam/shareware/uspsbarcode.ttf. This is listed as “A 
POSTNET TTF” author unknown and which is unconditionally free.
On Windows, simply install this font set by following the instructions for installing fonts that 
come with Windows. This TrueType font can also be successfully installed into 
OpenOffice.org on Linux in a similar manner using standard utilities. Once you've done that, 
shutdown all OpenOffice.org windows and restart them, the font will be listed in the font list.
Now, one can type some numbers, select them, then change the font and, Voila!, POSTNET 
bar code that is almost correct. In other words, this bar code is incomplete and will be 
unacceptable if printed on the envelope as it is. 

Note: Disable the default font preview mode so that one can see the font name listed. Failure to do so will cause 
this font set to appear as a blank entry in the list.

a) In OpenOffice.org2x, Use Tools > Options > OpenOffice.org > View > Font Lists and uncheck
    Show preview of fonts.
b) In OpenOffice.org1.1.x, Use Tools > Options > General > View > Font Lists and uncheck Show
    preview of fonts.

Building a Complete POSTNET Bar Code for Printing
While numbers can be represented by the bar code, a correct POSTNET bar code for most 
postal services requires additional information.
The first piece of additional information is a check digit, which is calculated from the postal 
code as follows :

1. Start with the Postal code, say '12345', and sum the digits: 
1+2+3+4+5 = 15
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2. Calculate the number that is needed to add to this number to make the last digit of the 
sum a zero (0).That is, 15 + ? = ?0 The answer in this case is: '5'. 
e.g.. 15 + 5 = 20

3. Add this number to the postal code as the last digit. In this example, the POSTNET 
sequence is now: 123455

4. Finally, wrap the digit sequence in square brackets. The final text for the POSTNET 
bar code should now be [123455]

When one formats this text using the POSTNET bar code font, a POSTNET bar code. For 
example, enter [123455] into Writer, select the whole [123455] text and change the font 
to the POSTNET bar code font that has been installed. 

Note: Calculating this sequence, and putting it on an envelope easily may prove problematic. Perhaps others can 
help out with automating the process; however,by using a database or spreadsheet to store an address list, then 
one could simply add a POSTNET sequence column with the postal code precomputed in POSTNET format or 
perhaps as format the bar code as part of a database query. Using OpenOffice.org macros is yet another way to 
obtain results .

With respect to using 9 digit postal codes, where there is a 5 digit zip plus 4 digit suffix, the 
rules are the same. Add all 9 digits, find the check digit (sum + check = ?0), append 
that digit to make 10 digits and, finally wrap the sequence in square brackets. e.g. 
[1234567895]

There is apparently another two digit code that can be added if it is wanted, and the same rule 
applies for the 11 digit version to make a 12 digit code wrapped in [].
All three forms are valid.

Adding More Languages to OpenOffice.org
Setting Text Language
One can change the language of the user interface and invoke a wizard to install more 
dictionaries. Help offers some instructions:

1. Open the Online Help using the F1 key or from Help > OpenOffice.org Help menu.
2. Select the Index tab page.
3. Enter “languages” in the Search term box 
4. Read the help page.

Note: The language for spellcheck, hyphenation, and thesaurus is an attribute for a whole document or for a 
selection of words.

1. Choose Tools > Options > Language Settings > Writing Aids for a list of available 
language modules.

2. Click the top Edit button to see which dictionaries are installed for the current 
language. Use the dropdown listbox to see which languages are installed.
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3. If the listbox doesn't list the language that you want, see "Adding More Text 
Languages".

Adding More Text Languages
1. Choose File > Wizards > Install new dictionaries to open a Writer document that 

helps users to install additional languages.
2. The document contains pages in many different languages. Click your own language 

on the first page to see the following instructions in your own language as shown 
below:\

3. Click the big button in the middle of the document page. This starts a macro to 
display more info and download the dictionary files (see image).
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4. Choose whether to install the new files for the current user only or for all users 
depending permissions. 

5. Click Next.
6. Click Retrieve the list button. A list of available dictionaries in various 

languages will be displayed after some short delay.
7. Select the dictionaries in the languages needed for Spelling by using Ctrl-Right 
Click if more than one are required.

8. click Next.
9. Click Retrieve the list and select the Hyphenation dictionaries for the 

needed languages using the method in step 7.
10.Click Next to proceed to selecting Thesauruses to accompany previously selected 

dictionaries and hyphenation dictionaries.
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11.Click Retrieve the list and select desired thesaruses using the method in step 
7.

12.The macro downloads the files to the appropriate folder. 
13.Click Finish.
14.Close OpenOffice.org (including the Quickstarter).
15.Restart OpenOffice.org.

Setting UI Language
A standard installation of OpenOffice.org will provide a user interface (UI) of the chosen 
language. Most users download the US English version, which gives english menu 
commands and english Online Help. If you want another language for the menus (and for 
Online Help, if available in that language), change the UI language as follows.

1. Choose Tools  Options  Language Settings  Languages.
2. Select another UI language in the "User interface" listbox.
3. Click OK and restart the OpenOffice.org software.
4. If the listbox doesn't list the language that wanted, see Adding Multiple Language

Support using Language Packs.

Adding Multiple Language Support using Language Packs
Using languages packs is another way to have OpenOffice.org in mulitple languages, 
complete with the user interface in that language. 

1. Open your Web browser and check the NLC website that supports the language 
needed. If you cannot find one there, then enter 
http://   OpenOffice.org   translation.services.openoffice.org/pub/OpenOffice.org/    intthe 
browser.

2. Select and download the correct language pack for the version of OpenOffice.org.
3. Close OpenOffice.org and the Quickstarter, if it is enabled).
4. Install the language pack. 

a) With Windows ®, doubleclick the exe file. 
b) Under any UNIX, use tar command or archive tool of choice, to open the 

.tar.gz file that was downloaded in preparation for installation. 
c) In most cases, use the procedures described in the Setup Guide  (in various 

languages) for completing installation according to standard practice for the 
target platform/OS.
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Chapter 4: Spreadsheets in Calc
Calc is the powerful spreadsheet program of the OpenOffice.org program. It provides the 
functions necessary for professional use with financial and statistical functions as well as 
database functions and much more.

Overview of the Functions in Calc
This section contains a short overview of some important functions and capabilities of Calc.

Calculating
Calc works primarily as a spreadsheet program. i.e. it provides a spreadsheet containing cells 
into which text, digits and formulae can be entered and, from these, calculate simple and 
complex results. Calc, like the other components of OpenOffice.org, has numerous automatic 
functions to ease usage. 
While Calc provides all the basic calculation types, it also has numerous calculation methods 
that can be entered interactively via the Wizard: Functions. In addition, it allows 
entering text and flexibly arranging cells, so forms can be comfortably styled, filled in, 
calculated and printed. 

Database Functions
Data that can be summarized into records, such as addresses, inventory levels, customer 
orders or similar, can also be managed by Calc. Even if there are no calculations, Calc can 
quickly sort a database range and search the data for specific characteristics, such as 
maximum or minimum values. 
In addition, a sheet in Calc can serve as a data source for creating form letters and reports 
with OpenOffice.org Writer. 

Arranging Data
Data can be organized in easytoread lists. With just a few mouseclicks, the view can be 
reorganized to show or hide certain data ranges, format ranges according to special 
conditions, or calculate subtotals and totals.

Examining and Extrapolating Data
The data in Calc tables can be examined in detail in many different ways. Calc is useful for 
creating term papers because it supports many statistical functions such as regression 
analysis. And for daily calculations at work, the integrated financial functions are helpful, 
because they can be used to print detailed tables of current credits and loans and other data. 

WhatIf Calculations
Results of changes made to one factor of calculations composed of several factors can be 
views immediately. For example, see how changing the period in a loan calculation affects 
the interest rates or repayment amounts. Furthermore, larger tables are made manageable by 
using different predefined scenarios. 
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Dynamic Charts
Calc has a charting function that can display spreadsheet data graphically by selecting the 
data to be displayed and clicking the Insert Chart icon. Drag open a frame at the required 
position, define specific chart settings in the dialogue that appears. The chart is inserted at the 
selected position and, when the source data is modified, is be dynamically updated. 

Importing and Exporting Data
Data from other spreadsheets programs can be imported, edited in Calc and, output in 
different export formats.
Users are presented with a dialogue similar to the following when they select Text CSV as 
the file type when the input file uses a character to separate the fields (tab in this example):

Importing into Calc
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Where the input file is in fixed width fields, check the Fixed width box and set the 
column widths in the measurement bar as shown below:

Exporting from Calc
Usually, one would simply use the Save as dialogue. Other export options, such as PDF are 
also available in the same manner as for Writer or the other OpenOffice.org modules.\

Referencing Data in Networks and the Internet
Rather than being restricted to having only a fixed value or formula that refers to other cells 
in the sheet, each Calc cell can also contain a reference to contents in other documents. The 
documents referred to do not have to exist on the local computer, they can also be stored on a 
network or anywhere in the Internet. 
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The Calc Window 

Structure of a Spreadsheet
A spreadsheet is made up of individual sheets. Each sheet contains various cells, arranged in 
rows and columns. Each cell can contain either an arithmetic formula, text or value (of 
virtually any length). 
A calculation can be entered directly as a mathematical formula. For example., =4 + 5. 
But the main reason for using a spreadsheet is that its formulae can refer to other cells. An 
example of such a mathematical formula might be =SUM(A1:A8). This calculates the sum 
of the values in cells A1 through A8 and enters the result in the cell containing the formula. 
Additional formulae may also be entered in cells A1 through A8, each referring to other cells 
and their contents, and so on. As one can see, this allows calculation of extremely complex 
relationships. 
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A new spreadsheets is opened with the command File > New > Spreadsheet. Initially it is 
named “Untitled1” and remains with that name until saved under a different name. Look 
at the new, still empty document for the several typical elements, that are discussed in the 
following sections. 

Rows and Columns
On a spreadsheet, rows are numbered from 1 to 32000 and the columns are designated with 
the letters A through Z, AA through AZ, and so on; the last column is labelled with the letters 
IV. Each cell on the sheet can be uniquely referenced by row and column. For example, cell 
A1 is the first cell in the upper left corner of the sheet. 
These numbers and letters appear along the edge of the window. The row header contains the 
row numbers, and the column header names the columns. Clicking on one of these areas, 
selects the entire row or column. To select the entire sheet, click on the unlabelled button at 
the intersection of the row and column headers at the top left. 
Enter some text in cell A1. As text is typed, notice that the text appears both in the cell and in 
the input line of the formula bar. Continue typing to see that more text can be added than 
appears to fit in the cell. 
In fact, any cell can accommodate text longer than a cell. The whole length of the text is 
displayed and printed, provided the adjacent cells to the right are empty. If the cell to the 
right is not empty, a small triangle on the right hand edge of the first cell appears, indicating 
that the cell contains more text than can be displayed. 

Note: Turn off these triangles by choosing Tools > Options > OpenOffice.org Calc > View and unchecking the Text 
overflow box.

When a number cannot be displayed in a cell because it is too long, or due to the formatting, 
e.g., currency format,###” is displayed. In this case, increase the column width. Set the 
width to optimal” by simply doubleclicking the right divider in the column header. 

Use all the usual functions to edit text. Notice, however, that the right and left arrow keys will 
replace the cell cursor if Entry mode (by clicking in a cell and entering characters) is 
enabled. Doubleclicking or pressing the F2 key or clicking in the entry row, enters the Edit 
mode. The left and right arrow keys now replace the text cursor. Upon pressing the Enter 
key, the text in cell A1 is finished and the cursor automatically moves to cell A2. The active 
cell is always the one with the cell cursor and that is where entries and changes are made. 
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Multiple Sheets in a Document
At the lower edge of the spreadsheet document there are tabs for switching among the 
various sheets of a document. A new, empty spreadsheet initially contains three sheets, each 
titled SheetX” where X stands for the numbers 1 through 3).

Inserting Sheets
1. Using the mouse, put the pointer in one of the sheet tabs at the bottom of the window.
2. Right click to open the Context menu for the commands governing editing sheets.

3. Choosing the Insert command, opens the Insert sheet dialogue .
4. Select the position and quantity of sheets to be inserted
5. Click OK.

Renaming Sheets
1. Right click the tab of the sheet for renaming, e.g. Sheet1”.

2. Open the context menu and choose the Rename command. 
3. A dialogue box appears in which to enter a new name.
4. Enter a new name for the sheet 
5. click OK.
6. Alternatively hold down the Altkey and click on any sheet name and enter the new name 

directly. As an alternative, this feature may or not work with the installed window 
manager.

Note: The name of a sheet may consist only of letters and numbers. Spaces are also permitted.

The name of a sheet is independent of the name of the spreadsheet. Enter the spreadsheet 
name when saving it for the first time as a file. The document can contain up to 256 
individual sheets, each of which, can have different names.
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Values and Formulae as Cell Contents
Individual cells can contain text, numbers, dates or formulae. Cell contents are very easily 
specified or modified and these may be updated at any time by recalculating the formulae 
with current data.
Values in spreadsheets mean numbers, dates, times and results of formulae. Emphasize 
values by marking Value Highlighting in the View menu.

If desired, check this option in Tools > Options > OpenOffice.org Calc > View, in which 
case this function will apply permanently for the current document and all documents created 
in the future (other, already existing documents retain their settings). If this function is 
enabled, numbers and dates are automatically shown in blue, and values in cells containing 
formulae in light green. Text remains in black. If Value Highlighting is not marked, users are 
free to choose the colours and other formatting of the content of their spreadsheets.
Text can be entered in a cell even if it appears to be too long for the cell. Now try entering a 
very long whole number. If the number is too long to fit in the cell, the overflow indicator 
### . By double clicking the right hand edge of the heading of this column, the column is 
automatically set to the optimal width.
The box at the bottom right in the status bar always displays helpful information. In a 
spreadsheet, this box can be used to permanently display the sum of all selected cells. Other 
values may also be displayed, such as the maximum value of all selected cells. Use the 
context menu to change the value displayed in this field. In case of an error in the 
spreadsheet, this field will also display an error message.

Calculating in Spreadsheets
The following demonstrates a simple percentage calculation that can be done in a 
spreadsheet:
1. Position the cursor in cell A3.
2. Enter the number 150 and
3. press the Enter key. The cursor then moves down to cell A4.
4. Enter the number 16  in cell A4. 
5. Press the Tab key this time rather than the Enter key and the cursor moves to the right 

to cell B4.
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6. Enter the following in cell B4:
=A3 * A4 / 100

When input is started with an equals sign, this indicates that a formula is being entered 
and the formula will be seen in the input line of the formula bar.

7. Press Enter to finish the formula. 
8. The result of the calculation is (16 percent of 150) in cell B4.
9. Click on cell A3, enter 200.
10.Press the Enter key, at which time, the calculation result is automatically adjusted.
11.Click on cell B4.
12.Click at the end of the formula in the input line of the Formula bar.
13.The blinking text cursor indicates a new entry can be made.
14.Add “+ A3” (without the quotation marks) to the formula.
15.Press the Enter key. 
16.The newly calculated value of the formula appears in cell B4: the previous 16  percent of 
A3 plus the contents of A3.

These steps introduce the most important steps in working with spreadsheets: creating and 
entering formulae, entering data (text and numbers), obtaining results, modifying source data 
or formulae, and how to view results of new data or formulae.
Besides the four basic arithmetic operations, there are other operators, nested brackets 
and many other functions. The Wizard: Functions button is a useful aid when 
inputting functions.
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Using Builtin Functions
Calc has many builtin functions, one of which convert Euros to another currency, such as the 
US dollar. The following provides an example of using functions to achieve a goal. 

Note: A list of functions is available from Help > Contents > Index > Search term > function list; Calc. 

1. Enter a formula (e.g. =4+5 or =A3*A4/100) in a cell.
2. Press the “Enter” key.
3. The result of the calculation appears in the cell. 
However, functions can also be entered in a formula. An example could be =SIN(1), which 
will give a result of sine of one (rounded to two decimal places).
1. Calc has several other functions, too, and additional functions can be added using 
StarBasic or AddIns. Help has a section outlining how to do this. In most cases 
though, the standard functions provided in the program are sufficient for most 
requirements. The function with the Syntax CONVERT(arguments) is shown here as 
an example that will convert a sum of 100 German Marks into Euros by entering the 
following formula in a cell: 

=CONVERT( 100;"DEM";"EUR")

The result will be the number of Euros per 100 German Marks. The value for conversion is 
always stated first within the parentheses. It can be entered directly, as shown, or by 
reference. If the amount is, for example, in cell D2, enter D2 in the formula as the first part of 
the function. The remaining parameters of the function name the unit of the amount and the 
unit into which it is to be converted. All three parts of the function are separated from each 
other by semicolons. 
Thus, using the formula =CONVERT(50;"EUR";"DEM"), displays the number of German Mark 
that is the equivalent of 50 Euros. To try this, proceed as follows:

In an new spreadsheet, enter in column D, from D2 to D20 a number of USD sums 
1. Designate column E from E2 to E20 as the cells in which the same sums in Euros must 

appear.
2. Click in cell E2.
3. Enter =CONVERT(

4. Click in cell D2. D2 is now defined as the first part of the function. The cursor remains at 
D2 in the formula.

5. Enter "DEM";"EUR". i.e. enter the text with both semicolons and the quotation marks.
6. Press the Enter key.
7. This completes the entire formula which now reads 

=CONVERT(D2;"DEM";"EUR"). 
8. Cell E2 will contain the result of the calculation.
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9. Click cell E2, then the small filled square in the bottom right hand corner of cell E2 and, 
pressing the left mouse button, drag down to cell E20.

10.Release the mouse button there.
11.The formula is now copied from E2 to E20. And all references have been automatically 

adapted so that they always refer to the neighbouring cell on the left.

A Short Description of What Cells Can Contain
The previous examples show that cells can accommodate different elements. These are 
described below.

Text
Text in a cell can be formatted and edited with most of the functions available in a text 
document. For example, to select a word, doubleclick the word either in the input line or in a 
cell. If a different font or other attribute from the text object bar is needed, the modifications 
apply only to the selected word.

• Pressing the Ctrl+Enter keys inserts a manual line break. This shortcut only works 
directly in the cell, not in the input line.

When text must break automatically at the right border of the cell, proceed as follows:
1. Select all cells in which the text should break at the right border:

2. In Format > Cell > Alignment 
3. Check the Line break field
4. Click OK.
Calculations are possible even in text. For example, enter text in cell A1 and more text in A2. 
In cell A3, insert the formula =CONCATENATE(A1;A2) which will concatenate the two 
texts, in other words, to string them together.
Numbers may also be entered in the Text format. Format the desired cells as Text (open the 
context menu of the cell, by right clicking, and choose Format Cells > Category > 
Numbers > Text), and enter numbers in the cells. These will be interpreted as text. The 
display of these numbers is leftjustified just like normal text; however, calculations with 
numbers in text format are not possible.
If normal numbers have first been entered in cells and the format of the cells has been later 
changed to Text, these numbers remain normal numbers and will not be converted. Only 
numbers entered later or numbers which are then edited become text numbers.
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To enter a number directly as text, enter an apostrophe (') first, for example for years in 
column headings '1999, '2000 and '2001 . The apostrophe will be not visible in the cell, 
as it only signals that the entry is text. This can be useful when entering numbers , such as a 
telephone number or ZIP code, that begins with a zero (0) since a zero (0) at the start of a 
sequence of digits is removed in normal number formats.
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Numbers
While numbers are displayed in various ways, internally these always remain numeric. For 
example, '1' and '1.0 ' are the same.

Enter the number 12345.6789, for example, and the number will appear in the sheet with 
only two decimal places, i.e. 12345.68. Nonetheless, the exact number with all four decimal 
places is kept by the program.
Fractional numbers can also be entered in a cell and used for calculation:
1. Enter 0 1/5 in a cell.
2. Press the Enter key and, in the input line, will be the value 0.2. This will be used for the 

calculation providing that the cell format is number. Calc does recognize fractions and 
will automatically use 1/5 and display this.

However, if 0 1/2 is entered, AutoCorrect replaces the three characters 1,  / and 2 with a 
single character. Likewise with 1/4 and 3/4. This replacement is defined in the Tools > 
AutoCorrect > Replace tab.
If multi digit fractions such as1/ 10  are needed, change the cell format to the fraction view (
Context menu of the Cell, choose Format cells). Fractions such as 12/31  or 12/32 may be 
entered; however, the fractions are automatically scaled down so that, in the last example, 
3/8 is displayed.

Select other display options by choosing Format > Cells. All the defined formats are lists on 
the Numbers tab. A preview shows how the result will look. In this dialogue, define personal 
formats, that can then be applied to numbers or other content of a spreadsheets.
There are various ways to enter integers starting with a zero:
• Enter the number as text. The easiest way is to enter the number starting with an 

apostrophe (for example, '0987). The apostrophe will not be entered in the cell and the 
number will be formatted as text. Because it is in text format, no calculations are possible.

• Format a cell with a number format such as \0000. This format can be assigned in the 
Format code box under Format > Cells... > Numbers tab and defines the cell display as 
always put a zero first and then the integer, having at least three places, and filled with 
zeros at the left if less than three digits.

Entire columns, (with numbers in text format i.e. in the form of 000123) can be turned into 
real numbers again (without zeros in front of them, i.e. in the form of 123) as follows:
1. Select the column in which the digits are found in text format. Set the cell format in that 

column as Number.

2. Call up Edit > Find & Replace
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3. In the Search for box, enter ^[09]

4. In the Replace with box enter: &

5. Check Regular expressions
6. Check Current selection only
7. Click Replace All

Cells in the Currency Format

In Calc numbers can have any currency format. Clicking the Currency icon in 
the object list formats the number and the cell is given the default currency 
format as set in OpenOffice.org under Tools > Options  Language Settings 
> Languages.

Without currency formats, the international exchange of Calc documents could lead to 
misunderstandings. For example, an Calc document is loaded by a user who uses a different 
default currency format.
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In Calc, users can define a number, formatted as “1,234.50 €”, to remain in Euros in 
another country and does not changed to the local currency. Use the Cell Attributes dialogue 
to influence the currency format (Choose Format > Cells > Numbers tab) by two country 
settings. In the Language list box select the basic setting for currency symbol, decimal and 
thousands separators. In the Format list box select any deviations from the currency symbol 
of the format defined by the language.
• If, for example, the language is set to Default and the locale is set as German, the 

currency format will be 1.234,00 € and, per the locale definition, a point is used 
before the thousand digits and a comma before the decimal places. Now select the 
subordinate currency format $ English (US) from in the Format list box, to get the 
following format:$ 1.234,00. Note that the separators remain the same and that only 
the currency symbol is changed and converted. The underlying Format of the notation 
remains the same as it is set in the locale setting.
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Calculating With formulae
All formulae begin with an equals sign. formulae may contain numbers or text, and other 
data is also possible such as format details, that specify how the numbers are to be formatted. 
Naturally the formulae will also contain arithmetic operators, logic operators or function 
starts.

When using the basic arithmetic signs (+, , *, /) in formulae, remember that using the Multiplication and 
Division before Addition and Subtraction rule. Instead of writing =SUM(A1:B1) it's better to write =A1+B1.

Parentheses are also useful for grouping. For example, the result of the formula =1+2*3 means something different 
than =(1+2)*3.

Here are some typical Calc formulae:

=A1+10 Displays the contents of cell A1 plus 10 .
=A1* 16% Displays 16%  of the contents of A1.
=A1 * A2 Displays the result of the multiplication of A1 and A2.
=ROUND(A1;1) Rounds the contents in cell A1 to one decimal place.
=EFFECTIVE(5%;12) Calculates the effective interest at 5% annually with 12 

payments.
=B8SUM(B10:B 14) Calculates the sum of the cells B10  to B 14  minus the value of 

B8.
=SUM(B8;SUM(B10:B 14)) Calculates the sum of cells B10  to B 14  and adds the value to 

B8.

It is also possible to nest functions in formulae, as shown in the example. Functions may also 
be nested within functions. For example, instead of simply =ROUND(A1;1), calculate and 
round a sine function using =ROUND(SIN(A1);2). Use the Function Wizard to help form 
nested functions.
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Calculating With Dates and Times
In spreadsheets users can do more than just display dates and times (both taken from the 
internal clock of the computer). Calculations can also be made with dates and times. For 
instance, to find out exactly one's age in seconds or hours, follow these steps: 

1. Open a new spreadsheet. 
2. Enter a date in cell A1. e.g. a birthday, such as.,1/3/48. 
3. Enter the following formula in cell A3: =NOW()A1 
4. Press Enter or click the Accept icon on the formula bar(  ). The result appears in 

date format. 
5. Rightclick this cell (i.e. bring up its context menu) since the exercise is to see the 

difference between two dates as a number of days, the format of cell A3 should be set as a 
number.

6. Select Format Cells.... 
7. The Cell Attributes dialogue appears. 

1. On the Numbers tab, the Number category will appear highlighted. The format is set 
to General which causes, among other things, the result of calculations containing 
date entries to also be displayed as a date. 

2. Set the number format to 1,234,for example.
3. Press OK to close the dialogue. 

8. Cell A3 will now contain the number of days between today's date and the specified date. 
9. Experiment with some additional formulae: 

1. in A4 enter =A3* 24  to calculate the hours.
2. in A5 enter =A4*60 for the minutes.
3. in A6 enter =A5*60 for seconds.
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4. Press the Enter key after each formula. 
The time since the birthday will be calculated and displayed in the various units. The values 
are calculated as of the exact moment when the last formula was entered and confirmed by 
pressing the Enter key. This value is not automatically updated, although NOW continuously 
changes, of course. In the Tools menu, the menu item Cell Contents > AutoCalculate is 
normally active; however, automatic calculation does not apply to the function NOW. Consider 
that, if it were, the computer would use all its resources updating the sheet. 
When spreadsheets contain a very large amount of data or very complicated formulae that 
may be modified before viewing the calculation results, it may be prudent to cancel or 
disable the automatic calculation function. Calculation time naturally becomes longer as the 
complexity and size of a spreadsheet increases. 

Inserting and Editing Notes
A note may be assigned to each cell by choosing Insert > Note. All notes are indicated by a 
small red square, the note indicator, in the cell. Notes made visible whenever the mouse 
pointer is over the cell, provided Help > Tips or Extended Tips is active. 

• For a selected cell, choose Show Note from the context menu of the cell. Doing so keeps 
the note visible until the Show Note command is deactivated from the context menu. 

• To edit a permanently visible note, just click in it. When the entire text of the note is 
deleted, then the note itself is deleted. 

• Another way to delete a note is by choosing Edit > Delete Contents, or calling the same 
dialogue with the Delete key. 

• Select Tools > Options > OpenOffice.org Calc  View to show or hide the note indicator 
by checking or unchecking the Note indicator box. 
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Handling Multiple Sheets
Spreadsheet are not limited to just one sheet. In fact, several sheets laid on top of each other. 
Each sheet has its own unique name displayed on the sheet tab at the bottom of the window. 

Additional sheets can be appended to a document or inserted in front of the current sheet. 
Activate the context menu of a sheet tab and choose the corresponding command. Choose 
Rename in the context menu to modify the name of a sheet. 

Displaying Multiple Sheets
Use these navigation buttons to display the sheet tabs of all the available 
sheets. Click the button on the far right of this group to move to the the last 

sheet tab to see its name. To display the sheet itself, click on the name. 
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When there is insufficient space to display the sheet tabs on the lower window border, 
increase it by moving the separator bar between the tab bar and the horizontal scrolling bar 
with the mouse button. Keep the mouse button pressed and drag to the right. Remember this 
shares the available space between the sheet tabs and horizontal scroll bar. 

Working With Multiple Sheets
Each sheet of a spreadsheet is completely independent of the other sheets in a spreadsheet 
document. However the same data can be incorporated into several sheets. For example, the 
same data should be inserted at the same location in the first three sheets. To do so, select all 
three sheets together and enter the data in only one of the sheets. 
Selecting several sheets together, is simply a matter of clicking the sheet tabs of the sheets in 
question while pressing the Ctrl key. All selected sheets will now have white sheet tabs, 
instead of the gray sheet tabs of the unselected sheets. To undo the selection of a sheet, click 
its sheet tab again whilst pressing the Ctrl key. Clicking the sheet tab of the current sheet 
while pressing the Shift key, ensures that only this one is selected. 
Calc includes the name of the sheet in the reference when assigning sheet references. Thus, 
instead of referring to $A$1, Calc refers to $Sheet 1.$A$1 which makes multisheet 
referencing easy and straight forward as shown in the examples below:.
• To address the first cell from both Sheet1 and Sheet2 in a single reference, for 

example, summarize, the 3D formula will read =SUM(Sheet 1.A1:Sheet2.A1). The 
sum function has one addend here, namely, the range from Sheet 1.A1 to Sheet 
2.A1. In this range there are two cells (as long as no more cells are included between 
Sheet 1 and Sheet 2). The simple formula (not a 3D formula) would only list two 
addends: =SUM(Sheet 1.A1;Sheet2.A1). 

• To include any subsequently inserted sheets found between Sheet 1 and Sheet 2, the 
formula would then be =SUM(Sheet 1.A1:Sheet2.B2). 

The full address of a cell also contains the complete path and file name of the spreadsheet 
document. So, in its full form, the reference to cell A1 in Sheet1 of the document 
name.sxc could be ='file:///home/username/name.sxc'#$sheet 1.A1 
under *UNIX where /home is a mounted filesystem and username specifies the directory 
where the file is stored. Under Windows®, the specification is similar and could be 
='file:///c:/name.sxc'#$sheet 1.A1 where the drive is “C:”. 

Note: the single quotes surrounding the file name, and the # character that describes the location within the file, in 
accordance with URL convention. 

Printing Spreadsheets
C licking the Print File Directly icon in the Standard toolbar sends all the sheets in the document to the 
printer. However, if there's a print range selected, then only selection is printed. To set the print range, select the 
cells to be printed, then use the Format > Print Ranges > Define command. There is further information on this  
topic in the OpenOffice.org Help. 
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To print the only current sheet, go to menu File > Print.... In the Print dialogue, select the 
Selection option and click OK. If, however, there is selected a certain range of cells, only 
those cells are printed and in the column width as shown in the sheet. 
If various sheets are to print simultaneously, for example, Sheet 1 and Sheet 2, select 
them before hand (hold down the Ctrl key and click the sheet tabs). The white tabs are the 
selected ones. Next, go to the Print dialogue, enable the Selection option and only the 
selected sheets will be printed. After having printed the desired sheets, remember to click the 
sheet that is being worked on while holding down the Shift key so that only that sheet is 
selected. Failure to do this will result in all modifications being applied on all sheets. 
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Formatting a Spreadsheet
A spreadsheet is hardly ever used without formatting. Cell contents, such as texts and 
numbers, are given certain formats, and the cells themselves are formatted with different 
colours, borders and other attributes. 
Either create the numbers format or use one of the many predefined formats. For cells, a wide 
selection of cell Styles is provided and personal cell Styles can be defined in the same way as 
one does text Styles. 
Certain values in spreadsheets are often given particular emphasis, e.g. in a table of turnovers 
to show all the values above the average in green and all those below the average in red. This 
is possible using the Conditional Formatting for spreadsheet documents (covered in a later 
chapter.) 

Formating Numbers
Enter a number into the sheet, for example, 1234.5678 . This number will be displayed in 
the default number format, with two decimal places. One will see 1234.57  when the the 
entry is confirmed. Only the display in the document will be rounded off; internally, the 
number retains all four decimal places after the decimal point. 

1. Set the cursor at the number and choose Format > Cells to start the Cell Attributes 
dialogue. 

2. On the Numbers tab there is a selection of predefined number formats. A preview box, n 
the bottom right of the dialogue, shows how the current number will appear with a 
particular format. 

3. This dialogue also allows defining other attributes (in addition to number formats) which 
apply to the selected cells or cell contents. For example, font, size, and colour can be 
defined on the Font tab page.

Modifying the number of the decimal places displayed in a cell is sometimes 
required. The easiest method is to use the Number Format: Add Decimal Place or 
Number Format: Delete Decimal Place icons on the object bar. 

Dates
1. Likewise, from the list of options, the date and time can be formatted as desired. 
The year in the date details is often stated as two digits. Internally the year is managed by 
OpenOffice.org as four digits, so that in the calculation of difference from 1/1/99 to 
1/1/01  the result will correctly be two years. 

• Tools > Options > OpenOffice.org > General defines up to which year a twodigit year 
“xx” should be displayed as “20xx”. 

This means that if a date of 1/1/30 or higher is entered, it will be treated internally as 
1/1/1930 or higher. All lower years apply to the next century. So, for example, 1/1/20 is 
converted into 1/1/2020. 
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Formatting Cells and Sheets
The distinction between direct and Style formatting holds true for cells as well as for text 
documents, e.g. A choice between applying a particular font size directly as direct formatting 
to a cell or defining a Style to apply the desired font size. Styles make particular sense for 
documents that are used extensively or are to be templates. It does not make sense to use 
Styles for documents that are only printed and discarded. 

Using AutoFormat for Tables
A quick way to format a table or a cell range is offered by the Format  AutoFormat 
function. In a spreadsheet, first select the cells to which to apply AutoFormatting, including 
the column and row headers and any sum rows or columns. At least 3x3 cells must be 
highlighted before this menu item is activated. Then start the AutoFormat dialogue. 

The preview shows an example of how each selected format in the Format panel will look. 
Click OK to apply the format to the selected range in the spreadsheet.

Note: If there is no change in colour of the cell contents, then under Tools > Options > OpenOffice.org Calc > 
View > Show or in the View menu, Highlight values may be checked. In this case, the specified colours will be 
used.

A userformat can also be set as an AutoFormat:
1. Format a spreadsheet to as desired.
2. Select the whole sheet, e.g. by clicking the empty button in the top left corner (above the 

first row header).

3. Call up the AutoFormat dialogue and click Add.... A dialogue will appear in which to 
give the new format a name.

The format defined in this way can then be used in the future on other spreadsheets. By 
choosing an appropriate background colour and a pattern for the cells in the sheet, an 
eyeappealing spreadsheet is created. 
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Use the More button to display additional options in the dialogue. In the additional section 
that is then displayed, select which properties of the chosen format are to be excluded from 
the automatic formatting. For example, removing the check mark in front of Font, the font 
will not be taken into account by the AutoFormat. 

Layout of Spreadsheets
Sheets do not have to have the look of any of the predefined formats. There are many ways to 
apply a different layout for spreadsheets, as well as tables in text documents.

Designing Spreadsheets Clearly
Calc assists in designing a sheet in a variety of ways. For example, here are three different 
views of the same sheet, varying only in layout:

This is a sample sheet without any special formatting, as it appears by default.

The above graphic shows the sheet formatted using one of the AutoFormats, it will look 
appealing without requiring any further editing.
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In this example, the sheet has been formatted with certain cell attributes in the Format > 
Cells dialogue. In addition the view of the grid lines and sheet headers has been deactivated 
in Tools > Options > OpenOffice.org Calc > View and a graphics file loaded as background 
in Format > Page > Background.

Note: An image loaded via Format > Page > Background, is only visible in print or via File > Page View.

For a background image to appear on screen as well, insert the graphic image by choosing Insert > Picture > 
From File and put the image behind the cells by way of the context menu command Arrangement > To the 
Background.

To later select the background image, use the Navigator.

Formatting Text in a Spreadsheet
1. Select the text for formatting.
2. Choose the desired text attributes from the spreadsheet object bar. 

Note: Format > Cells is another choice. The Cell Attributes dialogue allows choosing various text attributes on the 
Font tab page.

Formatting Numbers in a Spreadsheet
1. Select the cells containing the numbers to be formatted.
2. To format numbers in the default currency format or as percentages, use the icons on the 

spreadsheet object bar. For other formats, choose Format > Cells.... Choose from the 
preset formats or define a personal format on the Numbers tab page.

Formatting Borders and Backgrounds for Cells and Pages
• Basically, a format can be assigned to any group of cells by first selecting the cells (for 

multiple selection, hold down the Ctrl key when clicking), and then activating the Cell 
Attributes dialogue via Format > Cell. In this dialogue, select attributes such as shadows 
and backgrounds. 

• To apply formatting attributes to an entire sheet, choose Format > Page. This permits 
defining headers and footers, for example, to appear on each printed page. 
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Addressing Cells
Cells can be addressed directly by means of their coordinates in the rowandcolumn matrix. 
Use absolute or relative referencing, or give cell ranges their own names.

Addresses and References, Absolute and Relative

Relative Addressing
The cell in column A, row 1 is addressed as A1. Address a range of adjacent cells by first 
entering the coordinates of the upper left cell of the area, then a colon followed by the 
coordinates of the lower right cell. For example, the square formed by the first four cells in 
the upper left corner is addressed as A1:B2. By addressing an area in this way, one is 
making a relative reference to A1:B2. Relative here means that the reference to this area will 
be adjusted automatically when the formulae are copied. 

Absolute Addressing 
Absolute references are the opposite of relative addressing. A dollar sign is placed before 
each letter and number in an absolute reference, e.g., $A$1:$B$2. 
Calc can convert the current reference, in which the cursor is positioned in the input line, 
from relative to absolute and vice versa by pressing Shift +F4. When starting with a 
relative address such as A1, the first time this key combination is pressed, both row and 
column are set to absolute references ($A$1). The second time, only the row (A$1), and the 
third time, only the column ($A1). Pressing the key combination once more, both column 
and row references are switched back to relative (A1) 
Calc shows the references to a formula. If, for example the formula 
=SUM(A1:C5;D15:D 24) is clicked in a cell, the two referenced areas in the sheet will be 
highlighted in colour. For example, the formula component A1:C5 may be in blue and the 
cell range in question bordered in the same shade of blue. The next formula component 
D15:D 24  can be marked in red in the same way. 

When to Use Relative and Absolute References
First examine what happens without a relative reference. Assume a calculation in cell E1 that 
sums the cells in range A1:B2. The formula to enter into E1 would be: =SUM(A1:B2). If, 
later, a new column must be in front of column A, the elements to be added would then be in 
B1:C2 and the formula would be in F1, not in E1. After inserting the new column, all 
formulae would therefore have to be checked and corrected in the current sheet, and possibly 
in other sheets. 
Fortunately, Calc does this work automatically. After inserting a new column A, the formula 
=SUM(A1:B2) is updated to =SUM(B1:C2). Row numbers are also automatically adjusted 
when a new row 1 is inserted. Absolute and relative references are always adjusted in Calc 
whenever the referenced area is moved. But be careful when copying a formula since in that 
case only the relative references will be adjusted but not any absolute references. 
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Absolute references are used when a calculation refers to one specific cell in the sheet. For 
example, if a formula that refers to exactly this cell is copied relatively to a cell below the 
original cell, the reference will also be moved down if the cell coordinates are not defined as 
absolute. Aside from when new rows and columns are inserted, references can also change 
when an existing formula referring to particular cells is copied to another area of the sheet. 
Assume, for example, the formula =SUM(A1:A9) is entered in row 10  but the calculated 
sum must be in the adjacent column to the right. In this case, simply copy this formula to the 
cell to the right. The copy of the formula in column B will be automatically adjusted to 
=SUM(B1:B9). 
There are many methods to copy a formula, one of which is:
1. Select the cell containing the formula.

2. Choose Edit > Copy, or press Ctrl+ C to copy it.
3. Select the cell into which the formula is to be copied.

4. Choose Edit > Paste, or press Ctrl+V. The formula will be positioned in the new cell, 
and all nonabsolute references will be updated.

Copying a formula into multiple cells can be quick and easy. One way to copy into adjacent 
cell areas is as follows:
1. Select the cell containing the formula.
2. Position the mouse on the bottom right of the highlighted border of the cell, and continue 

holding down the mouse button until the pointer changes to a crosshair symbol.
3. With the mouse button pressed, drag it down or to the right over all the cells into which 

the formula will be copied.
4. Upon releasing the mouse button, the formula will be copied into the cells and 

automatically adjusted.

Where values and texts must not be automatically adjusted, then hold down the Ctrl key 
when dragging. formulae, however, are always adjusted accordingly when dragging.
Now look at what happened when rows and columns are added. Assume a calculation in cell 
E1 that sums the cells in range A1:B2. The formula to enter into E1 would be: 
=SUM(A1:B2). If, later, a new column must be in front of column A, the elements to be 
added would then be in B1:C2 and the formula would be in F1, not in E1. After inserting 
the new column, all formulae would therefore have to be checked and corrected in the current 
sheet, and possibly in other sheets. 
Fortunately, Calc does this work automatically. After inserting a new column A, the formula 
=SUM(A1:B2) is updated to =SUM(B1:C2). Row numbers are also automatically adjusted 
when a new row is inserted. Absolute and relative references are always adjusted in Calc.
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Addressing by Name
A neat way of making the references to cells and cell ranges in formulae legible is to give the 
ranges names. For example, name the range A1:B2 as Start then in the formula simply enter 
=SUM(Start). Following the insertion or deletion of rows and columns OpenOffice.org 
also correctly assigns the ranges identified by name. Remember, range names cannot contain 
any spaces. 
For example, it is much easier to read a formula for sales tax if written as = Amount * 
Tax_rate instead of = A5 * B2. In this case, cell A5 would be named as Amount and 
cell B2 as Tax_rate. 

In order to specify range names, follows these steps:
1. First highlight the area to be named.

2. Select Insert > Names > Define, or use the Ctrl + F3 key combination. 
3. Enter the name for the first area. 

4. Click Add. 
Other cell ranges can also be named in this dialogue by entering the desired name in the 
field and then selecting the respective cells. Use the Define Names dialogue to define 
names for formulae or parts of formulae needed more often. 

5. Close the dialogue with OK. 

Recognizing Names as Addressing
OpenOffice.org can correlate names with areas for the most part automatically, as long as the 
row and column coordinates are entered. Refer to the following graphic.
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The automatic formula recognition allows entering, for example, the formula =SUM(Ju ly) 
in cell B8. This formula can then be copied to the right. Cell C8 automatically shows the 
formula =SUM(August), cell D8 =SUM(September), and so on. This feature also works 
for horizontal calculations. Try it out by entering the formula =SUM(London) in cell E4. 
The New York entry must be treated as a special case because this name contains a space. 
Thus, it must be enclosed in single quotation marks: =SUM('New York'). 
Automatic recognition does not work with formulae. One cannot enter the formula 
=SUM(sum) in cell E8. Instead, enter =SUM(B8:D8) or =SUM(E3:E6). The latter 
formula will also be inserted automatically if the cursor is placed in cell E8 and the Sum icon 
in the Formula bar is clicked. 

This function is active by default. To turn it off, select Tools  Options... > Spreadsheet 
Document > Calculate and uncheck the box in front of Automatically find column and 
row labels. 

Use Insert > Names > Labels.... to define any names required as shown in the previous 
section.

Note: To have names automatically recognized, names must consist of alphanumeric characters and the first  
character must be a letter. To use non alphanumeric characters (including spaces), enclose the names in single 
quotation marks ('). Where a single quotation mark appears in a name, e.g., Jan '97, enter a backslash in front of  
the quotation mark (Jan \'97). This type of referencing is not compatible with earlier versions of OpenOffice.org. 

Calc automatically recognizes an area, called a range, of cells that belong together. To 
determine which cells make up a particular range, place the cell cursor in the desired range 
and press Ctrl + * but remember to use only the * from the numerical key pad as 
Ctrl+ Shift +8 (the asterisk over the 8) does not work. The range will be highlighted. 

Only Copy Visible Cells
Assume the user has hidden are a few rows or columns in a cell range and now only the 
visible cells are to be copied.
Calc behaves differently depending on the method used to hide the invisible cells and what is 
the intended action to be performed upon them.

Method Result
Cells were filtered out by way of AutoFilters, default 
filters or special filters.

Only the visible cells are copied.
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Method Result
Copy the visible cells, for example, with copy and 
paste via the clipboard,with the middle mouse button 
or drag and drop while pressing the Ctrl key.

Cells were filtered out by way of AutoFilters, default 
filters or special filters.
Move the visible cells, for example, by way of cut 
and paste via the clipboard or drag and drop without 
pressing an additional key.

All cells, including the hidden ones, are 
moved.

Cells were hidden manually by way of the Hide 
command in the context menu of the row or column 
headers, or through an outline.
Copy or move the visible cells.

All cells, including the hidden ones, are 
copied or moved.

Referencing a Cell in Another Document
Cells can also be referenced in other spreadsheets:
1. For the following example, the source document is named 'C:\test\test.sxc'; and 

it contains a sheet named Sheet1.
2. Open a different or new spreadsheet document.
3. Place the cursor in cell A1 and enter the following formula: 
='C:\test\test.sxc'#Sheet 1.A1

4. Alternatively, enter the file name as a URL designation: 
='file:///C/test/test.sxc'#Sheet 1.A1. Similarly access a file on the 
Internet by using: ='http://ww w.sun.com/test/test.sxc'#Sheet 1.A1.

5. Drag the box in the lower right corner of the active cell to select a range of cells. 
OpenOffice.org automatically inserts the corresponding references in the adjacent cells. 
As a result, the sheet name is preceded with a "$" sign to designate it as an absolute 
reference.
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Using References in formulae
So far users have been introduced to formulae containing absolute values, absolute and 
relative references and references to named ranges. Occasionally we have also mentioned the 
Wizard: Functions. Here is an example of references used in formulae, with the help of the 
Wizard: Functions. 
Consider the example from the previous topic. Now, use the functions Wizard to calculate the 
average of monthly sales for each location. 

1. Position the cursor in cell B8, where the average will be displayed. Activate the Wizard: 
Functions by clicking its icon on the formula bar. 

2. Select the AVERAGE function. Where the category that contains this function is unknown, 
simply leave the default set to all categories and repeatedly press the letter A until the 
AVERAGE function is selected. 

3. Click Next in the Wizard: Functions. On the right half of the Wizard, another input area 
will appear where one can enter the arguments of the function. 

4. Click in the input field into which values are to be entered, in this case starting with field 
number 1. Enter either B3:B6 or January or use the mouse to select that range in the 
sheet. To do so, simply click on the first cell, B3, hold down the mouse button and drag to 
B6. 
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While dragging the mouse to highlight the desired range, the Wizard dialogue will be 
automatically minimized so that only the active input field is visible. The field indicates 
the area being selected with the mouse. The dialogue can be reduced or enlarged manually 
by clicking the Shrink / Maximize button to the right of the input field. 

5. Finally, click OK to close the Wizard. 
The formula is calculated according to the given arguments, and the final result appears in 
cell B8. 

References to Other Sheets
In any sheet cell, users can show a reference to a cell in another sheet.
1. Open a new, empty spreadsheet.
2. For example, enter in cell A1 of Sheet1 the following formula and complete the input 

with the Enter key:
=Sheet2.A1

3. Now click the sheet tab labelled Sheet2 on the bottom window border to go to Sheet2 
of the current document. Set the cursor in cell A1 there and enter text or a number.

4. Upon switching back to Sheet1, see the same content in cell A1 as was entered on 
Sheet2. If the contents of Sheet2.A1 change, then the contents of Sheet1.A1 also 
change.

In a corresponding way a reference can also be made to a cell of another document. Open 
another spreadsheet in addition to the new spreadsheet, which is already saved as a file (this 
does not work unless a document has previously been saved).
1. If the samples from http://   www.pathtech.org   /  OpenOffice.org/templates   /   are installed, 

choose File > Open and open the Movie1 document from the spreadsheet samples.
2. Change back to the new, still almost empty spreadsheet. Set the cursor in a free cell and 

enter an equals sign to begin a formula.
3. Now switch to the document that has Movie1 loaded. Click cell C3.
4. Switch back to the new spreadsheet. In the calculation row notice that Calc has added the 

reference to the formula. By way of example, the following will now be located there:
In *NIX:
='file:////OpenOffice.org/share/samples/english/spreadsheets/Movie 1.sdc'#$movievisits.C3

In Windows®:
='file:///C:/ 
OpenOffice.org/share/samples/english/spreadsheets/Movie 1.sdc'#$movievisits.C3

5. Confirm the formula by clicking the green check mark.
The reference to a cell of another document thus contains the name of the other document in 
single inverted commas, then a hash #, then the name of the sheet in the other document 
followed by a point and the name of the cell there C3.
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The name of the sheet automatically receives a leading dollar sign, since the sheet has 
absolute addressing.
Examine the name of the other document in this formula and notice that it is written as a 
URL. This means that a URL from the Internet can be entered too. For example, supposing 
there is an Internet page containing current stock exchange information in spreadsheet cells, 
just follow these steps to load this page in Calc: 
1. In a Calc document, position the cursor in the cell in which to start inserting the external 

data.

2. Select Insert > External Data. The External Data dialogue appears.
3. In the dialogue, enter the URL of the document or Web page. Write the URL in the 

following way: (fictional example) http://www.mybroker.com/table.html. Enter a file 
name from the local or network file system in the usual way, i.e., via the File > Open 
dialogue.
OpenOffice.org loads the Web page or file in the background, that is, without displaying it. 
In the large list box of the External Data dialogue are the names of all the sheets or areas 
from which to choose.

4. Select one or more sheets or areas, optionally activate the automatic update function to 
every n minutes and click OK.
The contents are inserted as a link in the Calc document.

5. Save the spreadsheet. Upon reopening, Calc updates the linked cells.

6. Under Tools > Options > OpenOffice.org Calc > General, choose to have the update, on 
opening, execute always, upon request or never. The update can be started manually in the 
dialogue under Edit > Links.
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Using Charts
Data from spreadsheets can be represented graphically in a chart. A wide variety of charts 
and diagrams suited for illustrating the structure of the data can be selected and created from 
a spreadsheet.
1. Open an existing spreadsheet or enter data in a new sheet with row and column headings. 
2. Select the data together with the headings.

3. Longclick the Insert Object icon found in the Main toolbar to display the floating 
toolbar. Then click the Insert Chart icon and the cursor will change to a crosshair 

symbol with a small chart symbol. 
4. In the spreadsheet document, open a selection rectangle defining the location and size of 

the chart. Both can be modified subsequently. 
5. As soon as the mouse button is released, a dialogue appears that makes further entries 

possible. Simply clicking the Create button creates a chart with the default settings. 

This example, using Movie1.sxc from the sample archive mentioned above, shows the 
number of times people of different age groups in various cities go to the movie theatre 
annually. 
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If the age groups, rather than the towns, should appear on the horizontal axis, tilt the chart. 
As long as the chart remains selected, the main toolbar contains a Data in Columns icon. 
Click and rotate it with the mouse. 
Other changes to the individual elements of the chart are also possible. Either doubleclick on 
the individual parts of the chart or, with the chart selected, choose the individual functions 
from the Format menu. For example, doubleclicking on the colour preview in the legend 
automatically reformats all relevant data points. On the other hand, clicking on the 
background in the box of the legend, formats the background to the legend. 
If the chart was created from the data of a Calc spreadsheet, clicking on the data series in the 
chart becomes highlighted. 

Suppose there's an Calc spreadsheet in the background, and now it needs to be 
selected for further editing. Open the Show Draw Functions floating toolbar 
and select the first tool, the Select arrow. This allows the chart to be selected 
by clicking. 

In a Calc chart, a data series can be forwards or backwards. A series can be arranged in such 
a way that the lowest 3D representations are as far forward as possible and the higher ones 
further back. To change the arrangement in the chart, use the appropriate command from the 
context menu of a data series or choose Format > Order. The output data in the Calc 
spreadsheet will not be rearranged. 

Note: When a chart is inserted in a presentation or drawing document with the Insert > Insert Chart floating 
toolbar, it is displayed with a set of sample data. To insert a chart in a spreadsheet, highlight the cells in the 
spreadsheet whose values should be displayed in the chart. 

In Writer documents too, charts can be inserted that are obtained from the data of a Writer table. Where no data 
are selected in a OpenOffice.org Writer table, selecting Insert > Object > Chart also inserts a chart containing 
sample data in OpenOffice.org Writer. 

Values in a chart containing sample data can be changed by doubleclicking on the chart and then choosing Edit > 
Chart Data. When the values of a chart obtained from selected data are changed, the values in the cells of the table 
must be changed. If the chart is in a text document, press (F9) to update the chart. 

Modification of chart data is also possible if, for example, a chart is copied a chart from a Calc document into a 
Writer document and is now doubleclicked in the Writer document. Remember, however, only this copy is being 
edited and not the original document. 
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The type of chart can also be changed, after the fact. Doubleclick on the chart and choose 
Format > Chart Type, a dialogue appears offering various types from which to choose.

Experiment with the different options in the Chart Type dialogue. Try switching between 2D 
and 3D representations. With the Columns chart type, a Combination Chart of lines and 
columns can be created. 
• The threedimensional representations make special effects possible. In 3D charts, one can 

even adjust the illumination settings, such as light source, ambient light and the colour 
filter. 

• 3D charts can be rotated and flipped with the mouse for optimal design. 

• By choosing Insert > Statistics, users can apply statistical indicators to XY charts, such as 
standard deviations, with regression curves and more besides. A single or double 
logarithmic representation of the axes can also be set here. 

• In line charts there are various icons that can be applied automatically via OpenOffice.org 
Chart, as desired. Manual application is also possible using graphic files or graphics from 
the Gallery such as Bullets. 
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In a chart, individual data series or data points can be selected by clicking on them and then 
opening the context menu to choose one of the numerous options to format the view. 

Editing Chart Titles
Suppose the user has inserted a chart in a Calc document and wants to change the title.
1. Doubleclick on the chart.

A gray border appears around the chart and the menu bar now contains commands for 
editing the objects in the chart.

2. Doubleclick on the default title text. A gray border appears around the text which can 
now be changed. 

3. Press Return to create a new line.
4. A singleclick on the title, instead of doubleclicking, allows moving it with the mouse.

5. Select Format > Title > Main Title to edit the formatting of the main title. This opens the 
Title dialogue.

6. Select the Characters tab to change the font or other similar attributes.
7. Click OK. 
8. In the document, click outside the chart to exit chart editing mode.

Editing Chart Legends
Suppose there is a chart in a Calc document that requires application of a colour gradient to 
the legend.
1. Doubleclick on the chart.

A gray border appears around the chart and the menu bar now contains commands for 
editing the objects in the chart.

2. Select Format > Legend or doubleclick on the legend. This opens the Legend dialogue.

3. Select the appropriate tab, for example, the Area tab for modifying the background of the 
legend. 

4. From the pulldown list select Gradient. 
5. Select a gradient from the list.
6. Click OK.
7. In the document, click outside the chart to exit chart editing mode.

Note: Users can define custom gradients, hatching, bitmaps and colours in OpenOffice.org Draw.

To select the legend, first doubleclick on the chart (see step 1), then click on the legend. Now e the legend may be 
moved within the chart using the mouse. 
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If the legend is moved over another object of the chart, its Properties dialogue can no longer be opened by double
clicking on it,as Calc won't know which object is meant. To open the Properties dialogue either use the Format 
menu or click once on the legend, then open the context menu and select Object Properties. The same applies to all  
other objects of the chart. 

Adding Texture to Chart Bars
Assign a bar type to a bitmap rather than, say, using full colour.
1. Switch to edit mode by doubleclicking on the chart.
2. Doubleclick on the corresponding bar (all bars of this colour are now selected).

3. From the context menu, select the Object Properties entry

4. Choose the Area tab page.

5. Click on Bitmap. Now select a bitmap from the list box as texture for this bar. 

6. Clicking OK to accept the setting.

Editing Chart Axis
When the scale of the vertical Y axis requires changing, do the following:
1. Doubleclick on the chart.

A gray border appears around the chart and the menu bar now contains commands for 
editing the objects in the chart.

2. Select Format > Axis > Y axis to edit the Y axis, or doubleclick on the Y axis. This 
opens the Y axis dialogue. Modify as needed.

To modify the scale of the xaxis, 

1. Select the Scale tab and make any adjustments.
2. Click OK. 
3. In the document, click outside the chart to exit chart editing mode.
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Database Functions in Calc
Spreadsheets in Calc are also able to manage records consisting of several fields, as in a 
database. Think of each row of the Calc spreadsheet as a record, whose fields are arranged in 
the individual columns. Then, for example, sort or group the Calc database by rows, look for 
key words and calculate totals. 

Note: The database ranges in Calc spreadsheets have nothing to do with the databases and spreadsheets that are 
addressed in Tools > Data Sources and edited in the data source browser (F4). 

In Calc, a spreadsheet can contain several sheets which are manipulated. Combining several adjacent rows of a 
spreadsheet into a database area is a way, for example, to sort them together. Furthermore, external files can be 
imported into a Calc spreadsheet, for example files in dBase format, The records from the dBase file would then 
become rows and the data fields would become columns in a Calc spreadsheet. 

In the data source browser, on the other hand, the dBase file (or other data source) is edited directly, and SQL 
queries, for example, may be performed. 

Defining Database Ranges
For example, if a user would like to manage the household budget with Calc, enter the 
records in an empty Calc spreadsheet and select the area as a database range.

Creating Records in a Spreadsheet
1. Open a new spreadsheet.
2. Enter the column titles in the first row, e.g. “Date” in cell A1, “Item” in cell 
B1,“Amount” in C1. Then enter some information.

To format the sheet in the same manner as in the illustration above, proceed as follows:
1. Select row 1 by clicking on the row header.

2. Click the Bold icon.
3. Select the entire column A by clicking on the column header. 
4. Open the context menu 

5. Choose Format Cells. 

6. In the Cell Attributes dialogue, click the Numbers tab 

OpenOffice.org User Guide for 2.x 240



Chapter 4: Spreadsheets in Calc

7. Choose a date format for Column A.
8. Select column C by clicking on the column header, 

9. Apply a currency format. Clicking the Number Format: Currency icon on the object bar 
is sufficient.
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Defining Database Ranges
1. Select the three column area and define the selected area as a database range by choosing 

Data > Define Range.

2. The selected range already appears in the Define Database Range dialogue. Be sure to 
mark the check box Contains column headers so that the first row is correctly taken into 
account. This box becomes visible when the More button is clicked.

3. Enter a name for the range 
4. Close the dialogue with OK.

The selected range is now defined as a database range, which among other things, means that 
the rows (records) can be conveniently sorted. Any sort lists and filters that have been defined 
for the database range will also be updated.

Sorting Database Ranges
Select a range of cells and define these as a database range by choosing Data > Define 
Range.
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Set the cursor in the database range and choose Data > Sort. In the dialogue that appears, 
select the column to be sorted, fro example, Amount, as the sort criterion and click OK.

Up to two additional criteria can be specified, one to follow the other, for the sort function. 
For instance, sort the expenditures first by date, then by item if they have the same date, and 
then by amount if they have the same date and item.

Filtering Database Ranges
To filter out only certain records so that they can be modified, use the spreadsheet filtering 
function. Choose between using a dialogue to specify the criteria exactly (in that case range 
definitions are also possible), or creating an AutoFilter that will help filter according to 
specific values or text. 
Imagine that the output list is already 8000 records long. With this number of records it is no 
longer possible to get an overview. Now, only those records that occurred after 1/2/2000 and 
which apart from this involve an amount in excess of 100 currency units must be shown. 
Here is one way:
1. Set the cursor in the database range

2. Choose Data > Filter > Standard Filter to open the dialogue. 
3. Enter the following: 
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a) Date > 1/2/2000 AND Amount > 100. 
In the dialogue, the existing contents of the data fields in the pulldown lists can be selected, 
or an amount, say100, can be entered directly. 

If OK is clicked at this time, only those records that meet all criteria are shown. Select Data > 
Filter > Remove Filter to reset the view. 
Displaying only records with a specific content is easily done with the aid of the AutoFilter: 
1. Place the cursor in the database range. 

2. Click on the AutoFilter icon on the main toolbar. The column headers of the database 
range have now been given small buttons. 

3. Click on the button next to the Date field and select for example, 1/2/00. Only records that 
contain this date will be shown. 

On the main toolbar, reset the view with the AutoFilter icon. 

OpenOffice.org User Guide for 2.x 244



Chapter 4: Spreadsheets in Calc

Grouping Database Ranges and Calculating Subtotals
Assuming there is sample data that can be expanded and actually used for a budget, the date 
should be summarized and printed in totals and subtotals. This can be done in just a few 
steps.
1. Place the cursor in the database range.

2. Choose Data > Subtotals. The Subtotals dialogue appears.
3. Specify the desired options for calculating the subtotals.
4. Group subtotals according to Date (i.e. calculates a new subtotal for each date), and 
5. Use the function Sum (adds the subtotals) to calculate Amount.
6.

When the Enter key is pressed or OK is clicked, the sheet will be grouped according to the 
subtotals. For every group of entries with an identical date, a subtotal is calculated.
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The grand total is displayed at the bottom.

Notice the controls to the left of the row headers. These enable the user to view which 
records (rows) have been summarized. Clicking on a minus sign shows only the row with the 
results. The easiest way to control the display is with the small digits above the group area. 
When 1is clicked, only the grand total is displayed. Clicking 2 reveals the subtotals, while 
selecting 3 shows all elements. 

Transferring Data From a Data Source to a Spreadsheet
Individual tables of data from the data source browser are transferable into a Calc 
spreadsheet document. 
There is a choice of two different methods for transferring the data. One, the desired database 
file, in dBase or text format,t can be loaded directly via the File > Open dialogue, in which 
case, the whole database table is imported into a Calc spreadsheet document. Or, two, by 
dragging and dropping what is selected.

Opening a Database File in Calc
Open a dBase or text format document as one opens any OpenOffice.org file.

1. Choose File > Open.
2. In the dialogue, go to the folder where the database file is located. 

3. Enter the name of the file or go to the File type list box, select dBase, for example.
4. Select the name.

5. Click Open. 
To open a text document, select the file type Text CSV.
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When making a dBase import, a dialogue open from which to choose the character set of 
the file. For example, in some languages, databases created under DOS use different 
characters than those used in databases created under Windows®. The dBase IV format 
uses Codepage 437 (US).

4. After confirming this dialogue with OK, the database file is loaded in the Calc spreadsheet 
document.

The first row provides information on the type and length of the individual data fields. This 
information is contained as dBase header in the file. (When saving a Calc sheet with the file 
type dBase, the first row of data is used to create the header information.) 
Before working on the data in the spreadsheet, we would like to introduce the second method 
for transferring selected records from the data source view to the Calc spreadsheet. 

Dragging and Dropping Copies into Spreadsheets
This method works with all formats, and users have the choice of transferring all or only 
selected records into the spreadsheet document. To use this method, log into the data source 
in Calc.

1. Choose Tools > Data Sources.

2. The Data Source Administration dialogue opens. 

3. Click New Data Source.

4. In the Database type field, select dBase to log into a dBase database.

5. Click the “...” button
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6. Select the folder containing the database file(s) in *.dbf format.
7. Click OK.

8. In the Name field, enter a name to be displayed for the data source.

9. Click Apply. 

10.Click the Tables tab. Put a check mark next to the names of the table(s) needed in the data 
source view. 

11.Click OK.
12.Open the data source browser (F4).
13.Click on the plus (+) sign next to Tables to view the existing tables in the database.
14.In a dBase database, each *.dbf file in the directory is a table of its own.
15.Click the name of the table. The records are displayed in the data source browser.

Select the records and insert them into the spreadsheet.
1. To manually select a record(s) for transfer into the spreadsheet, click the row header of the 

record (the gray field without text at top left). Click the first and last record row headers of 
a continuous range of records while pressing the Shift key to select the range, or hold 
down the Ctrl key and click the desired records individually. 

2. Drag the selected records to the row headers in the sheet where the records are to be 
inserted. Then release the mouse button. 

To automatically transfer only specific records from a large database into the spreadsheet, use 
the filters in the data source browser: 
1. Set the cursor in the data field which contains the data (should be the same in all filtered 

records). For example, to filter only records that have Main Street in their address, 
place the cursor in a field containing Main Street. 

2. Click the AutoFilter icon. 
3. Now only the records containing the precise text, Main Street, are visible. 
4. Select the Main Street records. For example, using the Shift key as described 

above, drag the selected records into the spreadsheet document and release the mouse 
button at the point where the first field should be inserted. 
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Evaluating Data With Calc
Calc provides several powerful tools for evaluating data. The DataPilot helps produce any 
kind of subevaluation of the data as a separate spreadsheet. With the DataPilot, analyzing the 
data thoroughly is made easy via consolidation, Goal Seek and multiple operations. 

DataPilot
The DataPilot helps to analyze and assess data that has already been entered.
It allows the user, from one and the same value, to generate reports as a function of the point 
of view that is most prominent.
Imagine a data analysis table containing a company's sales figures, not only for specific 
product groups, but also for branches and years. Use the DataPilot to quickly find the data 
which is interesting and pertinent to current requirements.
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What use is the DataPilot?
A table that has been created with the DataPilot is an interactive table, i.e. data can be 
arranged, rearranged or summarized according to different points of view. This functionality 
is especially useful for Sales Control. On the one hand it may be important to view the 
turnover figures at regular intervals while, on the other ,it may be relevant to analyze sales 
figures on a regional basis.

Creating DataPilot Tables
1. Select the data range of a table together with the row and column headings.

2. Choose Data > DataPilot > Start. The dialogue Select Source appears.

3. Select the option Current selection.
4. confirm with OK..

5. The column headings of the table will be shown as buttons in the DataPilot dialogue, 
which can then be positioned via drag and drop as required in the layout areas Column, 
Row and Data.

6. Drag the required fields into one of the three areas. The field will be dropped accordingly.

If the button is dropped in the Data area it will be given a caption that also shows the formula 
that will be used in the data range to create the data.

• Doubleclicking on one of the fields in the Data area calls up the Data Field dialogue.
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Use this dialogue to select the functions to be used for displaying the data in the data area. To 
make a multiple selection, press the Ctrl key while clicking the functions.

• The order of the buttons can be changed at any time by simply moving them to a different 
position in the area with the mouse. 

• Replace a button by dragging it to the other buttons. 

• When doubleclicking one of the buttons in the Row or Column area, the Data Field 
dialogue appears. Here, select if and to what extent Calc should calculate and display 
subtotals. 

Exit the DataPilot by pressing OK. A Filter button will now be inserted into the table — the 
default position is under the selected area and two lines further down the DataPilot table 
is inserted with a bold outline. 
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Selecting DataPilot Output Ranges
Click the button More in the DataPilot dialogue. The dialogue will be extended. Select a 
named area from the list box Results to into which to create the DataPilot table. If the 
required output area does not have a name, enter the coordinates of the upper left cell of the 
area into the field to the right of the list box Results to. Clicking on the appropriate cell with 
the mouse also enters the coordinates.

By activating the check box Ignore empty rows, these will, then, not be taken into account 
when the DataPilot table is created.

If the check box Identify categories is activated, the categories will be recognized by means 
of their headings and assigned accordingly when the DataPilot table is created.

Editing DataPilot Tables
Click one of the buttons in the table that the DataPilot has created and hold the mouse button 
down. A special symbol appears next to the mouse pointer. 
Dragging the button to a different position in the row alters the order of the columns. If a 
button from the row to the left edge of the table is dragged into the line headings area, a 
column can be changed into a row. The mouse pointer alters its appearance from the icon for 
a column heading to that of a line heading. 
To remove a button from the table, just drag it out of the table. Release the mouse button 
when the mouse pointer becomes a not allowed icon. The button is, thus, deleted. 

Note: Doubleclicking on the name of a table element hides or shows the merged elements below it. 

Filtering DataPilot Tables
Although the DataPilot tables are usually created according to user requirements, there may 
be occasions when not all of the data provided by the tables is of interest. If this should be the 
case, filters should be used that apply conditions to the data such that if the conditions are not 
met the excess data is removed from the tables. 

Click the Filter button in the sheet to call up the entry mask for the filter conditions. The 
Filter dialogue will appear. This dialogue provides different criteria which can be used for 
selecting data. 

Updating DataPilot Tables
If the data of the base table has changed, Calc recalculates the tables to bring the analysis up
todate. Here are the steps to accomplish to recalculate the tables:
1. Click with the right mouse button on one of the button fields

2. Choose the Refresh entry or choose Data > DataPilot > Refresh.

Deleting DataPilot Tables
To delete a DataPilot table, select any cell in the analysis table, then choose Data > 
DataPilot > Delete.
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Consolidating Data
During consolidation, the contents of the cells from several sheets will be combined in one 
place. Choose a function so that , for example, displays the sum, the standard deviation or the 
variance of the data.
1. Open the document that contains the areas to be consolidated.

2. Choose Data > Consolidate to open the Consolidate dialogue.

3. From the Source Data Area list box, select an area as a starting point to consolidate with 
other areas.

4. If the area is not named, click in the field next to the Source Data Area. A blinking text 
cursor appears. Type a reference for the first source data area or select the area in the sheet 
with the mouse.

5. Click Add to insert the selected area as a Consolidation Area.

6. Select additional areas and click Add after each selection.

7. Specify where to display the result by selecting a target area from the Copy results to list 
box.

8. If the target area is not named, click in the field next to Copy results to and enter the 
reference of the target area (or the top left cell in the target area). Alternatively, select the 
area using the mouse or simply position the cursor in the top left cell of the target area.

9. Select a calculation rule for determining how the values of the consolidation areas should 
be linked. The sum function is the default setting.

10.Click OK to consolidate the area.
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If a new sheet, independent from the source areas, should not be created , but retaining links 
to the source areas or consolidating areas in which the order of rows or columns varies is 
preferred,, click the More button in the Consolidate dialogue.

1. Select Link to Source Data to insert only the formulae that generate the results in the 
target area, rather than the actual results. With linked data, any values modified in the 
source area are automatically updated in the target area. The corresponding cell references 
in the target area are inserted in consecutive rows, which are automatically ordered and 
then hidden from view. Only the final result, based on the selected calculation rule, is 
displayed. 

2. Under Consolidate by do the following:

a) Select either Row Labels or Column Headers if the cells of the source area are to be 
consolidated according to a matching row label or column header rather than to the 
identical position of the cell in the area.
To consolidate by row or column headers, the text must be contained in the selected 
source areas, or included in the selection with the mouse. 

The data from the consolidation and target areas is saved when the document is saved. 
Opening a document later, in which consolidation has been defined, this data will again be 
available. 

Note: The text in the headers or labels must be identical, so that rows or columns can be accurately matched. If the 
row or column label does not match any that exist in the target area, it will be appended as a new row or column. 
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Applying Goal Seek
With the help of Goal Seek one can calculate a value that, as part of a formula, leads to the 
result specified for the formula. Thus the formula is defined with several fixed values and one 
variable value and the result of the formula.
Goal Seek is best illustrated by means of an example.
To calculate annual interest, create a table with the values for the capital (C), number of 
years (n), and interest rate (i). The formula is: I = C * n* i / 100

Note: Formula can also be entered using the variable names:  Interest = Capital * Year * 
Interest rate / 100.

In this example, the investment capital of $150,000 and an interest rate of 7.5%  is 
calculated to result in annual interest income of $11,250. (The cells are formatted after 
calculation: A5 and E5 as currency, and C5 as percent. The cell width is adjusted 
automatically.)
For ease of use, assign names to cells so that they can be used in the formula.

Naming Cells
Using the example graphic above:
1. Select cell A5 in the example

2. Select Insert > Names > Define. The Define Names dialogue appears.
3. Enter the name C in the text field. At the bottom of the dialogue, the reference: 
$Sheet 1.$A$5 is displayed. 

4. Doublecheck for accuracy.

5. Click Add.
6. In the next field, enter an i, set the cursor in cell B5.

7. Click Add.
8. Next, enter ann in the empty field, set the cursor in cell C5, 

9. Click Add. 
10.Close the dialogue with OK.
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11.Now enter the formula in E5 using the variables = C*n*i instead of =A5*B5*C5.

Start Goal Seek
Assume an interest rate of 7.5%  and that the number of years (1) will remain constant. 
However, the user may want to know how much more or less investment would be needed to 
attain a particular annual return. For example, calculate how much capital would be required 
for an annual return of $15,000 by performing the following steps:
1. Place the cursor in cell E5.

2. Select Tools > Goal Seek and the Goal Seek dialogue appears.

3. The correct cell, (E5), should already be entered in the field Formula Cell.
4. Place the cursor in the field Variable Cell.
5. In the sheet, click in the cell (A5) that contains the value to be changed.

6. Enter the expected result of the formula (i.e., the desired value) under Target Value. In 
this example, the value is 15,000.

7. Click OK.

8. A dialogue appears with the result of the Goal Seek. The result is provided for use as 
desired. If the result should be used, click Yes to enter the result in cell A5.

Applying Multiple Operations

Multiple Operations in Columns or Rows
If the data of a data range is one above the other (for columns) or next to each other (for 
rows), select the data range together with the cell or cell range next to or below it as the target 
range. In the Column/Row field, enter the cell reference to the first cell in the data range. In 
the Formula field, enter the cell reference to the cell with the formula that applies to the data 
range.

Examples
The company produces toys which sell for $10 each. Each toy costs $2 to make, in addition 
to which there are fixed costs of $10,000 per annum. How much profit will be made in a year 
if a particular number of toys are sold?
Consider the following table:
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Calculating With One Formula and One Variable
1. Open a new spreadsheet for this tutorial.
2. To calculate the profit, first enter any number as the quantity (items sold) > in this 

example 2000. The profit is found from the formula Profit=Quantity * (Selling 
price  Direct costs)  Fixed costs. Enter this formula in B5.

3. In column D enter certain annual sales one under the other, e.g. in steps of 500 from 500 
to 5000.

4. Highlight the range D2:E11, and thus the values in column D and the empty cells 
alongside in column E.

5. Choose Data > Multiple operations.

6. With the cursor in the formulae field, click cell B5.

7. Set the cursor in the Column field and click cell B4. This means that the quantity in B4 
is the variable in the formula which is replaced by the highlighted column values.

8. Close the dialogue with OK. 
9. Profit will be displayed in column E.

Calculating with Several formulae Simultaneously
1. Use the spreadsheet created above/
2. Delete column E.
3. Enter = B5 / B4 in C5:. This calculates the annual profit per item sold.
4. Select the range D2;F11. i.e all three columns.

5. Select Data > Multiple Operations.

6. With the cursor in the formulae field, mark cells B5 through C5.

7. Set the cursor in the Columns field and click cell B4.
8. Close the dialogue with OK.
9. Profit will be displayed in column E and the annual profit per item in column F.

Multiple Operations Across Rows and Columns
Calc allows joint multiple operations for columns and rows in, socalled, crosstables. The 
formula cell has to refer to both the data range arranged in rows and the one arranged in 
columns. Select the range defined by both data ranges and call the multiple operation 
dialogue. Enter the reference to the formula in the Formula field. The Row field is used to 
enter the reference to the first cell of the range arranged in rows and the Column field the 
first cell of the range arranged in columns.
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Calculating with Two Variables
Consider columns A and B of the sample table above. Now try varying not only the quantity 
produced annually, but also the selling price, and calculate the profit in each case.
Expand the table shown above so that D2 through D11 contain the numbers 500, 1000 and 
so on, up to 5000. In E1 through H1 enter the numbers 8, 10 , 15  and 20.

  A B C D E
1 Selling price 10 8 10
2 Direct costs 2 500 7000 6000
3 Fixed costs 10000 1000 4000 2000
4 Quantity 2000 1500 1000 2000
5 Profit = B4*(B1 > B2) > B3 2000 2000 6000

1. Highlight the range D1:H11.

2. Select Data > Multiple Operations.

3. With the cursor in the formulae field, click cell B5.

4. Set the cursor in the Rows field and click cell B1. This means that B1, the selling price, is 
the horizontally entered variable (with the values 8, 10, 15 and 20).

5. Set the cursor in the Column field and click in A1. This means that B4, the quantity, is the 
vertically entered variable.

6. Close the dialogue with OK. 
7. See profits in the range E2:H11. In some cases, pressing (F9) is needed to update the 

table.
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Using Scenarios
Scenarios are important aids for making numbers that are dependent on each other and their 
resulting calculations visible.
Modify specific basic requirements in the table and see the new result. Name a scenario, 
created in this manner, and compare it with other scenarios.

Using ReadyMade Scenarios
If the samples from http://www.pathtech.org/OpenOffice.org/templates/ are installed, choose 
one of the readymade example scenarios with which to work.

1. Choose File > New > Templates and Documents and from the dialogue open the 
Samples.

2. Open the spreadsheet examples to see the spreadsheet documents available.

3. Doubleclick the document with Recar in the name.
This is a sample spreadsheet in which several scenarios have been created.
Areas in which the scenarios that differ by initial values are located are surrounded by 
frames. Select the appropriate scenario in the list box appearing at the top of every frame.
Scenarios can also be selected in the Navigator:

1. Open the Navigator with the F5 key or the Navigator icon on the Standard toolbar.

2. Click the Scenarios icon in the Navigator (the icon with the question and exclamation 
marks).

In the Navigator, see the defined scenarios with the comments that were entered when the 
scenarios were created.

Creating Personal Scenarios
Assuming that the spreadsheet used in the previous section is available, create a scenario by 
selecting all the cells that provide the data for the scenario. For example, create an additional 
scenario called High Dollar Rate using the following steps:
1. Select the cells that are already highlighted by the frame of the existing scenario. 
Remember, multipleselect cells that are not contiguous, i.e. that are distributed across the 
table, may also be selected. To select multiple cells, hold down the Ctrl key as each cell is 
clicked. However, In this case, simply select the range F18:F23.

2. Choose Tools > Scenarios.... The Create Scenario dialogue appears.
3. Enter High Dollar Rate as the name of the scenario and leave the other fields at 

their default values.
4. Close the dialogue with OK. The new scenario is automatically activated.
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4. Change any values in the frames to the values that are to apply to the new scenario. In this 
case, modify the dollar rate and all other values that could be affected by it, i.e. economic 
growth and sales prices. As changes are made, moments later the results from these operating 
figures are displayed.

To discover which values in the scenario affect other values, choose Tools > Detective > 
Track to Dependents. Arrows appear that point to the cells that are directly dependent on the 
current cell.
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Validity of Cell Contents
For each cell the user can define, in advance, what type of contents will be valid for this cell. 
This will make it easier for other users to employ these sheets correctly. 
The validity rule is activated when a new value is entered. If an invalid value has already 
been inserted into the cell, or if a value is inserted in the cell either with drag and drop or by 
copying and pasting, the validity rule will not take effect. To determine and display which 
cells contain invalid values, choose Tools > Detective at any time and select the command 
Mark Invalid Data.

Additional details about Data Validity can be found in the OpenOffice.org Help. 

Using Cell Contents Validity
1. Select the cells upon which to define a new validity rule. Where needed, select multiple 

cells by clicking on all respective cells while holding down the Ctrl key.
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The validity rule is a component of the cell format. To copy the validity rule to other cells, 
choose Edit > Copy and Edit > Paste Special, and select Format.

2. Select Data > Validation.... The Data Validation dialogue appears.

3. On the Values tab page, enter the conditions for new values entered into cells. Values 
already entered will not be affected.

4. In the field Allow, All Values is selected by default. This means that there are no 
restrictions. As needed, choose one of the other options: Whole Number, Decimal, 
Date, Time, and Text Length.

5. This choice sets the first condition. By choosing, for example, Whole Numbers, values 
such as 12.5 are not allowed, even if they satisfy the other conditions.
Choosing Date allows date information both in the form1/1/97 as well as in the form 
of a serial date. Similarly, the Time condition permits time values as 12:00 or serial 
time numbers. Text Length stipulates that cells are allowed to contain text only.

6. After setting the first condition under Allow, select the next condition under Data. 
According to what is chosen, additional text fields (Value, Minimum and Maximum) 
may appear to further specify the condition.

7. A few possible conditions resulting from this register could be as follows:
Integer greater than 1, Decimal between 10 and 12.5, Date earlier than or equal to 
1/1/2000 ,Time not equal to 00:00, Text with a length of more than 2 characters.

After the conditions for cell validity have been determined, if any values are subsequently 
entered which do not meet the conditions, Calc displays a warning message. Fill out the other 
two tabs in the dialogue to specify more detailed messages to aid a user working with a 
spreadsheet.

• On the Input Help tab page, enter the title and the text of the tip, which will then be 
displayed if the cell is selected.

• On the Error Alert tab page, select the action to be carried out in the event of an error.
• If Stop is selected as the action, invalid inputs are not accepted, and the previous cell 

contents will be retained.
• Select Warning or Information to display a dialogue in which the entry can either be 

cancelled (the cell value will be retained) or accepted (even if the new value violates the 
validity rule).

• If Macro is selected, then specify the macro to be carried out in the event of an error via 
the Browse button.
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Sample macro:
Function Example Validity(CellValue as String, TableCell as String)

Dim msg as string

msg =Invalid value: &'” & CellValue &'"

msg = msg & in table: &'” & TableCell &'"

MsgBox msg ,16,"Error message"

End Function

Note: After changing the action for a cell on the Error Alert tab page and closing the dialogue with OK, another 
cell must be selected before the change takes effect.
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Printing or Exporting Spreadsheets
There are many print options for putting spreadsheets on paper. Another way of distributing 
data is to publish it on the Internet in HTML format or as PDF files.

Printing Sheet Details
When printing a sheet one can select which details are to be printed:
• Row and column headers

• Sheet grid
• Notes

• Objects and graphics
• Charts

• Drawing objects
• formulae

To choose the details proceed as follows.
1. Select the sheet for printing.

2. Choose Format > Page.
This command is not visible or available if the sheet was opened with write protection on. 
In that case, click the Edit File icon on the Standard toolbar.

3. Select the Table tab. In the Print area mark the details to be printed
4. Click OK.
5. Print the document.

Defining Number of Pages for Printing
If a sheet is too large for a single printed page, Calc prints the current sheet evenly divided 
over several pages. Since the automatic page break does not always take place in the optimal 
position, users may define the page distribution themselves.
1. Go to the sheet to be printed.

2. Choose View > Page Break Preview.
3. This displays the automatic distribution of the sheet across the print pages. The 

automatically created print ranges are indicated by dark blue lines, and userdefined ones 
by light blue lines. The page breaks (line breaks and column breaks) are marked as black 
lines.

4. The blue page break lines can be moved using the mouse. Look for further options in the 
Context menu, including adding an additional print range, removing the scaling and 
inserting additional manual line and column breaks.
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Printing Sheets in Landscape Format
In order to print a sheet use one of the number of interactive options available under View > 
Page Break Preview. To make a hard copy in landscape format, proceed as follows:
1. Go to the sheet for printing.

2. Select Format > Page.
This command is not visible if the sheet has been opened with write protection on. In that 
case, click the Edit file icon on the Standard toolbar.

3. Select the Page tab. 

4. Select the Landscape paper format
5. Click OK.

6. Choose File > Print to open the Print dialogue .
Depending on the printer driver and the operating system, it may be necessary to click the 
Properties button and to change the printer to landscape there.

In the Print dialogue under Print range, select the pages to be printed: 

• All > All sheets will be printed.

• Pages > Enter the pages to be printed. The pages will also be numbered from the first 
sheet onwards. If one sees, in the Page Break Preview, that sheet1will be printed 
on 4 pages and only the first two pages of sheet2, enter 56 here.

• Selection > Only the selection will be printed. If cells are selected, these are printed. If 
no cells are selected, all those sheets whose names (at the bottom on the sheet tabs) are 
selected will be printed. By pressing Ctrl while clicking a sheet name this selection 
may be changed.

If under Format > Print range the user has defined one or more print ranges, only the 
contents of these print ranges will be printed.

Printing Rows or Columns on Every Page
Suppose a sheet is so large that it must be printed on four pages. The pages will be arranged 
as follows:

Page 1 Page 3

Page 2 Page 4

The top two rows of the sheet should not be printed on pages 1 and 3, but should be the 
topmost rows on print pages 2 and 4. The first column A should not be printed on pages 1 
and 2, but should be on pages 3 and 4.

1. Select Format > Print ranges > Edit and the Edit print ranges dialogue opens.

2. Click the icon at the far right of the Rows to repeat area.
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The dialogue shrinks so that more of the sheet can be displayed.
3. Select the first two rows and, for example, click cell A1 and drag to A2.

In the shrunken dialogue the user will see $1:$2. Rows 1 and 2 are now rows to repeat.

4. Click the icon at the far right of the Rows to repeat area. The dialogue is restored again.
5. If one also wants column A as a column to repeat, click the icon at the far right of the 

Columns to repeat area.
6. Click column A (not in the column header).

7. Click the icon again at the far right of the Columns to repeat area.

Note: Rows to repeat are rows from the sheet. 

8. Define headers and footers, to be printed on each print page, independently of this via 
Format > Page.
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Saving and Opening Sheets in HTML
Saving Sheets in HTML
Calc saves all the sheets of a spreadsheet together as one HTML document. At the start of the 
HTML document a heading and a list of hyperlinks are automatically added which lead to the 
individual sheets within the document.
Numbers are shown as written. In addition, in the <SDVAL> HTML tag the exact internal 
number value is written so that the exact values are available when opening the HTML 
document with Writer.

1. To save the current Calc document as HTML, choose File > Save As.

2. In the area with the other Calc filters, choose the File type HTML Document. 

3. Enter a File name and click Save.

Opening Sheets in HTML
HTML documents may be opened with writeprotection enabled. To edit a readonly HTML 
document, click the Edit File icon on the Standard toolbar.
OpenOffice.org offers various filters for opening HTML files, which may be selected via the 
File > Open dialogue in the File type field (pay particular attention to the area, as the name 
Web pages is always the same):
• Open in Writer/Web filter Web pages or as default which does not require selecting a 

filter.

All the options of OpenOffice.org Writer/Web are now available, such as Show HTML 
source.

• In the OpenOffice.org Writer filter open Web pages.

All the options of Writer are now available. However, please note that not all editing 
options that Writer offers can be saved in HTML format.

• In the Calc filter open Web pages.
All the options of Calc are now available to the user. Again, note that not all options that 
Calc offers for editing can be saved in HTML format.
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formulae and Values as CSV Files
CSV is an acronym for “Comma Separated Values.” CSVfiles are pure text files, which 
contain the contents of the cells of a table/area of a spreadsheet. Commas, tabs, spaces, 
colons or semicolons can be used as the field delimiters between the cells. Text is 
automatically put between either quotation marks or single quotes, as selected, while 
numbers are written directly.

Exporting formulae and Values as CSV Files
1. Select the area/table that is to be written as a csv file.
2. Where formulae are to be exported as formulae, e.g. in the form =SUM(A1:B5), proceed 

as follows:

a) Choose Tools > Options > OpenOffice.org Calc > View.

b) Under Display, check the formulae field. 
c) Click OK.

To export the calculation results instead of the formulae, do not mark formulae.

3. Choose File > Save as to open the Save as dialogue .

4. In the File type field select the format Text CSV.

5. Enter a name and click Save.

a) From the Export Text dialogue that appears, select the records and the field and text 
delimiters for the data to be exported.

b) Confirm with OK.

Caution: If the numbers contain commas as the decimal separator or 
thousands separator, do not select the comma as the field delimiter. If the text 
contains double quotation marks, select the single quotation mark as 
separator and vice versa.

6. If necessary, after saving the document, uncheck formulae in order to see the calculated 
results in the table again.

Importing a CSV File
1. Choose File > Open to bring up the dialogue .

2. In the File type field, select the format Text CS V.  
3. Select the file from the list.

4. Click Open.
When a file has the .csv extension, the file type is automatically recognized.

5. The Import text files dialogue opens. 
6. Click OK.
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7. If the CSV file contains formulae as formulae, uncheck formulae (in Tools > Options > 
OpenOffice.org Calc > View), so that the calculated results are visible in the table.
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AutoFill
Copying text, values and other cell contents to a spreadsheet is very easily using the mouse. 
Here the user needs to consider a few special features. When several values are copied at 
once, Calc forms a logical series out of the initial values, such that, if certain texts are entered 
that are in sort lists, the list will be continued accordingly.

Applying Sort Lists
By way of experiment, enter the text Jan or January in an empty cell. Select the cell and 
click the mouse on the box in the lower right corner of the cell border. Drag over several cells 
to the right or downwards. Upon releasing the mouse button, the highlighted cells will be 
filled with the names of the months. 

This predefined series can be found under Tools > Options > OpenOffice.org Calc/pen
 > Sort Lists. Custom lists can also be tailored to local needs, such as a list of a 

company's branch offices. These lists are handy for expanding as headings and other 
repetitive tasks by simply entering the name in the list with which to start and then expanding 
this entry by dragging as described above. 

Automatic Row Filling
1. Enter a number in a cell.
2. With the mouse drag the bottom right corner of the cell downwards.
3. When the mouse button is released, the cells selected in this manner are filled with 

numbers. The starting number is increased by 1 in each case.
If two or more adjacent cells have been selected, that contain different numbers, and these are 
dragged together, any recognizable arithmetic pattern of the numbers is continued. For 
example, if A1 contains the number 1 and A2 the number 3, then joint copying of the two 
cells by dragging downwards causes the progression to continue with 5, 7, 9, 11  and so on.
1. First select the range in the table to completely fill.

2. Select Edit > Fill > Row to open the dialogue
3. Select the type of progression. e.g.

1. Select 2 as the starting value, 2 as the increment and geometric progression as the 
progression type. 

In this way a list of the powers of 2 is produced.
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The dialogue also allows series of dates and times to be automatically filled in. For example, 
to insert the first date of each month of the year as row headers, proceed as follows:
1. Enter a date, e.g., 1/1/99 into a cell (without quotation marks).
2. Highlight this cell and the 11 cells below it.

3. Select Edit > Fill > Series.

4. In the dialogue, select Date and Month. 
5. Click OK.
The first date of each month automatically appears in the selected cells.

Protecting Sheets
To prevent the values entered in a sheet from being modified by another person, protect the 
sheet. To do this, follow these steps:

1. Display the Protect Sheet dialogue (Tools > Protect Document > Sheet). 
2. Enter a password,
3. Click OK. 
Likewise the entire document can be protected so that it is only possible to open it by 
entering the password.
• All cells in a newly created spreadsheet document have the protected attribute. This 

attribute can be turned on and off via the Cell Protection tab page of the Cell Attributes 
dialogue, which is opened by choosing Format > Cells or via the Format Cells... context 
menu command.

• The Protected” attribute can be set or removed for each cell individually. In any case, it 
does not take effect until the entire sheet and/or the entire document is protected. Apply 
this protection using Tools > Protect Document > Sheet... or Tools > Protect Document 
> Document....
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• While a password can be applied for protecting the sheet and the document, this is not 
required. However, if a password is set, then protection can only be removed later by 
entering the correct password. If no password is set, there is still effective protection 
against a document being accidentally modified.

• Sheet protection prevents modification of the contents of this specific sheet. Document 
protection prevents the sheets from being inserted, deleted, resorted or renamed.

• If a user has a document with confidential data that should be protected from being 
opened by unauthorized persons, protect it with a password. The password makes this 
protection of the entire document dependent on the protection mechanism of cells, sheets 
and documents described above. To save a document with a password, select File > Save 
As... and check the Save with Password check box.

Creating a Reference
If a user wants to insert a value, say the result of a profit calculation, into another sheet or 
into another spreadsheet document, a reference must be created. 
1. Select the cell where to insert the result
2. Enter =. 
3. Next select the cell that contains the original result
4. Press Enter. 
This cell can also be included in another spreadsheet or in another file. The result is 
automatically inserted into the reference cell and is also updated when changes are made 
later.
The content of a cell can be dragged to a cell in another document. With this action, either 
choose to transfer a copy of the cell, as it now stands, into the other document or create a link 
so that the other document always reflects the current content of the cell.
After setting all the necessary preferences and changes, save the document and print it.

Further Information
The document based on this template is protected. In order to make modifications in the 
protected cells, first disable the protection via Tools > Protect Document > Spreadsheet. 
This must be done individually for every protected sheet, including the hidden sheets. 
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Inserting a note 
To keep a note, perhaps reminding one to sell a certain share later on, select the relevant cell 
and choose Insert > Note. A shadowed area in the document appears in which to enter text. 
To make this note visible all the time, click in the relevant cell (cells with notes have a small 
red dot in the corner, provided "Note Indicator” in Tools > Options > OpenOffice.org Calc 
> View is marked), open the context menu and choose Show Note. Otherwise, one only sees 
the note when the mouse pointer is moved on to the cell. 

Inserting a sheet into another document 
Select the cell range and copy it to the clipboard (Copy icon on the Standard toolbar). Open 
the document into which to insert the sheet (generally a text document) and insert the sheet 
(Insert command). 

Displaying formulae 
To display the references in the spreadsheets, choose Tools > Options > OpenOffice.org 
Calc > View and mark formulae. The best way to examine an individual formula is to click 
the cell containing the formula and then click the Wizard: Functions icon on the formula 
bar. 

Using print ranges 
Print ranges have been used in the sample document to print specifically targeted cells. 

Freezing Columns
Select the column to the right of the column to be frozen, say a list of names, by clicking on 
the column header, and click Freeze in the Window menu. This makes is possible to scroll 
horizontally, while the area to the left of the freeze line remains fixed. This fixes the display 
so that the column containing the names is always in view. This function is especially useful 
for large sheets.

Splitting a Calc Window
Sometimes a user may need to work with a spreadsheet in which the active data is in different 
rows. Scrolling up and down can be inconvenient. In this case splitting the display can be an 
advantage. Select the cell tat which to split the display,and click Split in the Window menu. 
This make is possible to scroll vertically in each of the split sections. This function can be 
especially useful for large sheets.

Conditional Formatting
With this function, information can be displayed simply by entering a letter. For example, if 
this is an employee list, use this feature to instantly find out if a particular employee is 
present, sick, or on vacation.
To do so, use the following steps:
1. Open the Styles and Formatting window (click the icon in the Standard toolbar)
2. create three Cell Styles. 
3. For the Cell Styles, choose names that correspond to the information to be represented. In 

the case of the employee list , choose: Sick, Vacation and Present.
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4. Click in the Styles and Formatting window, and open the context menu and click the New 
command to activate the Cell Style dialogue. 

5. On the Organize... tab, enter the word Sick and assign a background colour to the Cell 
Style by way of the Background tab page. 

6. Click OK 
7. Repeat this process for the two remaining Cell Styles.
8. Now, using the mouse, select the range to which to apply the conditional formatting. 

Choose Format > Conditional Formatting to open the Conditional Formatting 
dialogue.

9. For Condition 1 define: Cell value > equals “s” (s=sick). In the Cell Style list box, 
select the Style Sick.

10.For Condition 2 define: Cell value > equals “v” (v=vacation). In the Cell Style list box, 
select the Style Vacation.

11.For Condition 3 define: Cell value > equal “p” (p=present). In the Cell Style list box, 
select the Style Present.

Note: The use of quotation marks is absolutely necessary to define conditions!

Upon entering a “v” (without quotation marks) in a cell in the previously selected area and 
pressing the Enter or Arrow key, the cell will be displayed in the defined colour.

Note: A maximum of three conditions is possible.
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Defining Validity
To avoid invalid entries in a spreadsheet, define a validity condition. Select the cells to which 
the validity condition is to apply, and open the Validity dialogue (in the Data menu). On the 
Criteria tab, define the acceptable entry criteria (in this example: Text length, equal and 1) 
in the appropriate lists and fields.

Next, click on the Error Alert tab. Select the option Show error message when invalid 
values are entered and click Stop in the Action list box. Under Error message, enter an 
appropriate text (e.g. On ly  v (vacation), p (present), or s (sick) are 
valid entries.) .
If a user were to now enter more than one letter in the corresponding cell in the sheet, the 
message defined above appears.

Creating Input Help
Using the Validity dialogue, custom help functions can be created for a previously selected 
area. Select the Input Help tab and check the box Show input help when cell is selected. 
Enter a title in the respective field, and enter the help text in the field below. This text is then 
displayed as a Help tip for the user.

OpenOffice.org User Guide for 2.x 275



Chapter 4: Spreadsheets in Calc

Linking Sheet Information
The information contained in a schedule can also be used by linking it to the vacation 
accounts and automatically subtracting used vacation days, for example.
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Chapter 5: Creating Presentations With Impress
Presentations have more than just drawings and graphics to offer. Use presentations to link 
several slides to form a slide show, to animate the elements on the slides and to assign special 
transition effects between slides. Slides often contain text which, in the outline view mode, is 
displayed and entered in a hierarchical structure. Change the text or rearrange the order of the 
slides at any time. 
There are several ways to create a presentation: 

Use Wizard Presentation.
• Use the templates and sample documents supplied, which are modified as necessary.
• Start with an empty document.

OpenOffice.org Impress provides many graphics features for creating presentations, all of 
which are found in OpenOffice.org Draw, too. Please take the time to read chapter 6 on 
OpenOffice.org Draw to discover the complete capabilities of Impress. 
The sample documents referenced in this section may be found, at the time of writing, at 
http://www.pathtech.org/OpenOffice.org/templates/Samples/.
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How to Create a Basic Presentation
The following brief stepbystep example demonstrates different methods of how to create a 
presentation document.
As with text documents, there are various ways to start creating a presentation:

• Open the Wizard Presentation by choosing File > Wizards > Presentation. The Wizard 
starts automatically each time a new presentation is created. If desired, switch off the 
automatic mode on the first page of the Wizard. The Wizard is described in detail in the 
Help.

• By turning off the Wizard in Tools > Options > OpenOffice.org Impress > General, a 
new, empty document (for example, by choosing File > New> Presentation) is opened.

• Alternatively open an existing presentation document that is modified and saved under a 
different name. 

• Or use one of the many templates available in the Templates and Documents dialogue. 
Pressing Shift+Ctrl+N opens this dialogue or use File > New > Templates and 
Documents.

For more information on the various dialogues used here, refer to Help. 

Creating a Presentation With the Wizard
1. Choose File > New > Presentation. 
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The Wizard Presentation opens automatically. The first page allows starting with an empty 
presentation, a template or the last presentation opened. By clicking the From template 
option,OpenOffice.org Impress collects all existing presentation templates and displays 
them in the list box. 

2. For the purposes of this example, select the template “new_product_intro” and click 
Next. On page two of the Wizard dialogue choose another Page St yle if needed. The 
selection of presentation layouts available to choose from are from the predefined 
template directories. As on the first page of the Wizard, all templates are displayed as 
Page St yles. 

On this page, however, the default is “Presentation Backgrounds”. From this 
page, select the presentation medium for the presentation: Slide, Overhead, Screen 
or Paper. The dimensions, margins, and orientation of the presentation will depend on 
these selections. 

3. To continue following this example, do not change the background or medium of the 
presentation. Click Next. 
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4. Page three of the Wizard deals with the slide transition. 
a) In the first list box select the slide effect “CrossFade From Left”. 
b) Select the default “Medium” for the speed of change. 

5. Select Automatically as the presentation type (i.e. repeatedly runs through presentation, 
with fixed time lapses, until the Escape key is pressed). 

6. Now one can determine further parameters: 

a) Use the Duration of page spin box to determine how long each slide is shown before 
the next one appears. Once the presentation is completed, a different duration for each 
slide can be set individually. 

b) Use the Duration of pause spin box to determine how long the pause will be at end of 
the presentation before it starts again. If the Show Logo check box is marked, the 
“Created with OpenOffice.org” logo will be displayed on the pause page. 
The Default presentation type runs the presentation from beginning to end with manual 
slide transition, e.g. by mouse click. 
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7. Click Next. 

8. Enter additional text which that should appear in the presentation on page four. 
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9. Click Next. 
The fifth and final page of the Wizard determines the number of the slides needed in the 
presentation. A list of names of all the slides in the presentation is also presented. If there 
are some slides to be removed from the presentation, click the Page icon with the green 
check mark next to the name. The check mark will disappear, which indicates that that 
slide will not be included in the presentation. To reverse this action, click the page icon 
again. 

10.Click the plus sign in front of a slide, the headings from the first outline level will be 
shown. 

11.By checking the Create summary check box, the Auto Pilot creates an additional last 
slide with a summary of all the titles of the previous slides in the presentation. Normally 
this is not necessary, since most templates already include such a page. 

12.Click Create to create the presentation.

• Clicking Create on any of the Wizard pages creates the document and eliminates the 
need to go through all the pages of the Auto Pilot. 

• Once created, edit, save, and print or run the presentation, et cetera. 

To start a presentation on a computer screen, simply press Ctrl+F2 key or 
click the Presentation icon on the main toolbar. 
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Creating a Simple Presentation Without the Wizard
This section explains, with the help of a simple example, how to create a presentation based 
on one of the existing templates. 
• Open a new presentation document based on one of the supplied templates by choosing 

File > New > Templates and Documents, or with Shift+Ctrl+N. 

• In the Templates and Documents dialogue that appears, click the Templates icon on the 
left and then doubleclick “Presentation Backgrounds”. Doubleclick one of the 
templates, such as “Note Pad”. 

• Now there is a slide in which any predefined text can be replace with the text of choice. 

Note: If the document is in the Master view mode when opened, switch to the Slide view mode using the 
respective icon in the lower left corner of the document window. A document will always be opened in the view 
in which it was last saved.  If Tips and/or Extended tips is enables, hovering the mouse pointer 
over one of these will popup which is which.

To create a second slide, click the Insert Slide... command in the small Presentation 
window. (If the small presentation window is not visible, click the Presentation Box On/Off 
icon  on the Object bar). In the next dialogue, select a page layout and confirm with 
OK. 

Alternatively one can also click in the area right of the “Slide 1” tab to create a new slide, 
without any selection dialogue. The new slide has the same layout as the current slide. 
1. The user will then see “Slide 2”. 
2. Press OK.
3. Click once on the lower text frame and delete it, say, with the Delete key. 
4. Click in the text frame at the top and enter a title. 

5. Next insert a 3D object by longclicking the 3D Objects icon  to open its floating 
toolbar. 

6. Select the Sphere icon. 

7. Click on the slide below the Live in 3D text, drag open a 3D rectangle, and then release 
the mouse button. Voila, a 3D sphere. 

8. Drag the sphere into the centre of the slide and enlarge it by dragging one of the handles in 
one of the corners. When dragging, hold down the Shift key so that the sphere remains a 
sphere. 
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9. Assign an interesting colour or colour gradient to the sphere by way of the list boxes on 
the object bar. Placing a bitmap as a pattern on a 3D object, for example, a world map 
from the Gallery is covered in another chapter. 

Save the presentation by either pressing the Ctrl+S shortcut keys and specifying the name 
and location for the file or use File > Save as and again specify the location for storage. 

Switching Presentation Views
To the right, above the vertical scroll bar, there are some icons for switching views and for 
starting the presentation.

Drawing View
Outline View
Slide View
Notes View
Handout View
Start Slide Show
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To the left of the horizontal scroll bar in the drawing view, notes view and handout view, see 
the following icons:

Slide View Master View Layer View Navigation

Arranging Slides
Switch to the Slide View by clicking the respective icon above the vertical scroll bar located 
at the right of the screen. Now the position of individual slides can be rearranged and effects 
defined for the transition between slides. 

In the slide view, change the sequence of the slides by dragging them to any other position in 
the presentation. 
Longclick a slide in the slide view to copy the slide using drag and drop while pressing the 
Ctrl key. The mouse pointer will have a small plus sign next to it when dragging to indicate 
a copy. Drag and drop is also possible between the slide views of OpenOffice.org Impress 
documents. 
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If the context menu of a selected slide is called up, the Show/Hide Slide command will be 
seen. One can use this command to temporarily remove the current slide from the 
presentation, without deleting it from the actual document. A slide that is not shown in the 
presentation receives a name highlighted in gray. 

Incorporating Slide Show Effects
In the Slide View mode, define transition effects to precede the display of each slide:
1. Click on the second slide once to select it.
2. On the object bar under Transition, select “Automatic” and enter the desired display 

time for the first slide, for example 00:01:00. That means that the second slide will be 
displayed for one minute.

3. Select a desired effect from the Effects list on the object bar.
4. Click the small button to the left underneath the second slide to preview the selected 

effects.

5. Save the presentation again using Ctrl+S or from File > Save menu item.

InSlide Effects
OpenOffice.org 2.x offers inslide effects such as fadein et cetera. To add effects within a 
slide use Custom Animations.

Showing a Presentation
By following the previous steps there is now a finished presentation ready for display.

To run it, click the Slide Show icon on the main toolbar, and the presentation will 
start automatically in default mode, that is to say, in fullscreen mode.
Click once with the mouse and the second slide will be displayed (preceded by the defined 
transition effect). After the last slide, a black slide is displayed, which means that the 
presentation is over. End the presentation by pressing the Escape key. The Escape key 
may also be used to stop the presentation before the end, as necessary.
At this point, more slides may be added to the presentation or some of the other effects 
attempted.
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Editing Presentations
This section shows how to use the versatile features of Impress to fine tune a presentation. 
Many of the methods available in Draw can also be used in Impress, such as entering text and 
converting it into 3D, turning objects into curves and polygons, editing connectors and glue 
points and so on. For details, please refer to the chapter on Draw. 

Defining Background colours
The background of a slide in a presentation or drawing document can be handled either in the 
master view or by assigning another Page Style to the slides or by modifying the current Page 
Style.
• Switch to the master view by using the icon in the lower lefthand 

corner of the work area.
The master view permits editing the background for all slides. All objects that are entered 
in this view, whether company logos, lines or text, are displayed in the background on all 
slides that use the current Page Style (the master page). This allows headers and footers on 
to be reproduced on all presentation slides. Objects inserted in the Master View cannot be 
modified in the normal Slide View. 

• Change only the background used in the presentation using the following steps:
a) Right click in any slide

b) Choose Slide > Page Setup
c) Select the Background tab
d) Choose a colour, gradient, hatching or bitmap for the background. 
e) Click OK 
f) The next dialogue asks if the settings should apply to all slides or just to the current 

slide. By answering “Yes” to the question “Background settings for all 
slides?", the Background Presentation Style will be modified for the current master 
page and all slides with this Page Style will have the modified background. Answering 
“No”, means that only the background of the current slide is modified. 

• Modify the Presentation Styles in the Styles and Formatting window by following these 
steps: 
1. Open the Styles and Formatting window, 

2. Click the Presentation Styles icon,  if it is not already selected, to see all existing 
Styles of this type in the Styles and  Formatting window. 

3. Select the Background Style. 

4. Rightclick to open the context menu for this Style and choose Modify. 
5. Choose the background for all slides with the current Page Style. 
6. Click OK. 
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Note that this modification is only valid for the current presentation document. 

Switching Page Styles
The subordinate designs which make up the slide design determine the way an object looks, 
including its background. The slide design can also be called a “Master Slide”. In Impress, 
assign a different slide design to each slide as desired.
1. Go to the slide that is to have a different Master page.

2. Select Format > Styles > Slide Design... to open the dialogue

3. Click Load.... to see the Load Slide Design dialogue.
4. Select a new slide design from the dialogue, e.g. from the area “Presentation 
Backgrounds”

5. Confirm this with OK.

6. If the Exchange background page check box is checked, the new slide design applies to 
all pages of the current document. If there is no check mark in it, then this action only 
applies to the current slide. This provides the flexibility to define a different slide design, 
and thus a different background, for example, for one single slide. Assuming, that 
Exchange background page is not checked, the background selected will now be assigned 
to the slide currently in use. 

Presentation Styles
As part of slide design there are a whole set of Presentation 
Styles that may be assigned to the slides. Open the Styles 
and Formatting window to see a list of the predefined 
Styles. Existing Styles may be modified but any 
modifications are valid only for those slides in the current 
document that uses this slide design or new Styles created.
The builtin Styles, Outline 1 through Outline 9, enable the 
user to give the outlined headings and topics on the slides a 
uniform look.
Open a new, empty presentation with a slide layout that 
allows greater structural depth. The slide layout called 
“Title, Text” is suitable for this purpose.

1. Activate the outline view mode by clicking View > Master View > Outline View (starting 
in the Menu bar) or by pressing the F12 key.

Note: The slide layout chosen determines the number of levels of outline. If a slide layout which does not permit 
any outline is chosen, notice that the outline functions are not available.
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Using Outline View
One way to create a completely new presentation is in the Outline View mode. All slide titles 
appear in a list along with the headings and subtopics. The hierarchy of the headings as well 
as the sequence of the slides can be easily modified.

1. The preview window should have opened; if not, it can be shown by choosing View > 
Preview. The Preview window enables the user to view the slide layout, including text, 
background, and background objects. The Preview window can be at the window border 
by pressing the Ctrl key and dragging the window to the position of choice. 

2. Now open the Styles and Formatting window either by choosing Format > Styles and 
Formatting or with the F11 key or opening it if it is docked. 

3. The cursor should now be blinking next to the small icon for slide 1. 
4. Enter the desired text, for example First Page. This will be the title for slide 1. 
5. Press the Enter key. This displays a small icon for slide 2 in the next line of the 

Outline view. 

6. Enter a title for the second slide, for example, Second Page. 
7. Press the Enter key again to get the small icon for slide 3. 
8. Now press the Tab key before entering any text. This action ensures that the text entered 

here will be a subtitle on slide 2. 
9. Continue to enter more subtitles of the first level on page two. 
10.Pressing Shift + Tab moves one level up. Thus enabling the user to make a new slide 

out of a first level subtopic. 
The levels created by following these steps automatically contain the Presentation Styles title, 
outline 1, outline 2, et cetera. These Styles can be modified by having a new slide 
design assigned to them, for example, a new font, font size and font colour. These designs 
can, of course, be edited (for example, via the Styles and Formatting window's context 
menu). 
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Slide Transitions, Effects and Animation
With Impress, grabbing an audience's attention using animated objects and interesting slide 
transitions is easy.

Automatic Slide Transition
When showing a series of slides, use the slide transition effects to present them in an 
interesting way. For example, the current slide can roll out of the window while the new 
slides rolls in. This effect is called “roll from left”. 
The best thing to do is to assign this effect in the Slide View. Simply click on the third icon 
from the top in the scroll bar on the right of the presentation window or choose View > 
Master View > Slide View. 

In the slide view, all slides which have a slide transition effect, have a small button. Click this 
button to preview the selected effect.

The Slide Transition window is described in detail in OpenOffice.org Help.

Effects for Objects
The objects in a slide can have various effects, for example, they can roll into the 
presentation from the left side, the text can be slowly drawn on screen, et cetera.

1. All these effects can be assigned using the Drawing View (View > 
Master > Drawing).

2. Access the Effects window, i.e. with the Effects icon in the Main toolbar.
3. Select the object to which to apply the effect.

4. Open the Effects window 
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5. Select the desired effect. 

6. Click the Assign icon in the Effects window, or doubleclick the effect to assign it.

7. An object can also be faded in (Effects button) and, additionally, faded out (in the Effects 
window, on the Extras tab click the Object Invisible icon) per mouseclick.

The Effects window is described in detail in OpenOffice.org Help.

Selecting Hidden Objects
• To select an object that is completely covered by another object, click on its position while 

holding down the Alt key. 
• If several objects are lying on top of one another, every Alt+click selects a different 

object lying in this position. Hold down Shift as well to click through the objects in the 
reverse order. 

• Press the Tab key to select an object. Press Tab again to select the next object. Press 
Shift+Tab to go through the objects in the reverse order. 

Individual Presentations
A slide show presents the slides in sequence, from beginning to end. To start presenting the 
slides in the presentation, either click the Slide Show icon on the main toolbar, or use the 
keyboard shortcut Ctrl+F2.
Presentations usually start with the first slide; however, to begin with the currently selected 
slide, proceed as follows:

1. Choose Tools > Options > OpenOffice.org Impress > General.
2. In the area Starting the presentation, check the Always with current slide box.

Note: that this setting has priority over the Individual Presentation described below.

Other options permit the user to show only or to never show certain slides:

1. To prevent display of a slide, go to the Slide View (for example by choosing View > 
Master View > Slides View), select the slide and select Slide Show > Show/Hide Slide .
The name of the selected slide will now appear highlighted in gray, meaning that the slide 
will not be shown.

2. Choose Presentation > Show/Hide Slide again when the slide should be included again.
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A more elegant way to keep individual slides hidden in certain presentations can be found 
under Presentation > Custom Slide Shows.

1. Open the Slide Show > Custom Slide Shows dialogue,

2. Click the New button. The Define Custom Slide Show dialogue appears.
3. In this dialogue, enter a name for the presentation. On the left, there is a list of the existing 

slides. Select a slide to show in the custom presentation and click the button with the 
arrows pointing to the right.

4. The slide will be inserted in the right field. Any slide listed on the right will be shown in 
the custom slide show.

5. Rearrange the order of the slides in the right field via Drag&Drop.

OpenOffice.org User Guide for 2.x 293



Chapter 5: Creating Presentations With Impress

Exporting, Printing and Presenting
There are many possible ways of outputting finished presentation documents. For example, 
electronically display finished presentations, print the pages in colour on paper or print high 
resolution transparencies, or transfer them wholly or partially to other applications and then 
use them within those applications. Printing offers a choice between outputting the document 
directly to a printer, or printing it to a file that may then be copied to a printer. 

Printing a Presentation Slide
In Impress, the current document is easily printed by clicking the Print File Directly icon in 
the Standard toolbar. Printing is immediate, according to the printer default settings, and no 
dialogue appears. There is an exception in text documents where a certain area of text is 
selected and, in this instance, a dialogue appears upon clicking the Print icon. This dialogue 
asks for confirmation of printing the whole text or only the selected area. 

When printing via the Print dialogue, Impress offers choices of whether to print only a 
selected range of pages, only certain pages identified by their page numbers or all pages of 
the document. Take a look at the print dialogue, which is opened via File > Print or by 
pressing Ctrl+P. 

The appearance of the Print dialogue may vary according to the selected printer. However, in 
most cases, there are options to specify whether to print the entire presentation, certain slides, 
or only the current selection. Other options specify how many copies to print and how these 
should be collated. 

Click the Options... button in the Print dialogue to display additional options. When printing 
text, drawing and presentation documents, the Brochure option is available for twotoapage 
text on a single sheet. The size of the pages is reduced and printed in two columns per page 
and doublesided, so that the pages need only be folded and fastened in the middle to create a 
complete brochure. 
Since presentation objects are usually in the form of vector graphics, they can be printed out 
in any resolution supported by the local printer or film recorder. Where the slides are to be 
sent to a film recording service or to be printed on a highresolution colour printer in a print 
shop, mark the Print to file check box in the Print dialogue. It will then be printed to a file 
that can be sent to the film recording service or commercial printer. 

Note: first install and select the printer driver for the printer or film recorder that will be used by the printing or 
film recording service. Most printing and film recording services require files created for a PostScript printer. If  
there is no PostScript printer available, OpenOffice.org permits installation of a PostScript printer driver that can 
be used to print to a file. On UNIXbased systems, use spadmin to active this driver.
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Exporting Presentations as Web Pages
When the Web Page export file format is chosen, Impress automatically starts an Wizard to 
help produce an attractive HTML presentation. A number of HTML pages are created that 
are connected to one another by hyperlinks and in which the graphics are saved as GIF or 
JPEG images. One can work on these HTML pages in Writer to give them headings and 
additional hyperlinks, for example.

1. Select File > Export...
2. Choose the file format HTML.
3. Enter a file name

4. Click Save.

This opens the HTML Export Wizard. This Wizard is described, in detail, in OpenOffice.org 
Help.

In the HTML Export Wizard, choose whether the created Internet presentation should 
contain frames, be navigates using graphic buttons or with text links and whether a link 
should be offered on the home page allowing the user to download the original Impress 
presentation.
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In addition to the export of default HTML documents and HTML documents with frames, 
Impress documents can be exported as WebCast or in the automatic mode.
• WebCast export automatically produces scripts for web servers with Perl or ASP support. 

This format allows a presenter (e.g. during a telephone press conference with 
accompanying slide show over the Internet) to change the slides on the viewers' browsers. 

Note: Examples can be found in <instdir>/OpenOffice.org<release>/share/config/webcast 
where <instdir> is the directory in which the network or standalone installation is located.

• Automatic export takes over the settings for the viewing time of each page in the 
presentation. A default HTML presentation is the result, in which the pages are “turned” 
automatically.

Sound reminders for turning the pages can also be exported, if desired. The sound files would 
then be copied in the target directory and played back when a HTML page is loaded.

Exchanging Data via the Clipboard
Objects in a drawing or presentation document can also be copied to the clipboard and then 
inserted elsewhere. The objects are stored as vector graphics on the clipboard using the 
following procedure:
1. Select an object in the current document
2. Copy it to the clipboard with Ctrl+C.
3. Switch to the application into which to insert the object.
4. Insert the contents of the clipboard at the desired location with Ctrl+V.
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Creating a Business Report
This section explains how to create a business report for a presentation. In the following 
example, it is assumed that the presentation will be shown via a computer.

Creating a Business Report in Presentation Form
Since OpenOffice.org Impress has no business report template, this section will start with a 
completely new document. To start, follow these steps:

1. Create an empty presentation document (File > New > Presentation). Using Wizard 
Presentation is described quite well in OpenOffice.org Help.

2. Select Empty presentation
3. Click Create. This brings up the Modify Slide dialogue where the appearance of the first 

slide can be defined.

4. Enter a name and select the desired layout, e.g. Title slide.

5. On the “Title slide” click on the existing text and overwrite it with appropriate text, 
for example “Elegy Software” and “Annual Report 2003”.
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6. To insert another slide, click the area next to the tab at the bottom of the screen. Assign a 
name for the new slide and choose a layout (in the context menu of the slide tab, click 
Modify Slide).

Note: Do not assign a name like “Slide2.” If the order of the slides needs to be changed later, the label might not 
describe the content of this slide. Clear, descriptive names like “Overview” or “Introduction” are more 
useful.

Insert additional slides, as necessary, from the insert menu on the main toolbar (a long 
click may be needed). The corresponding tabs appear at the bottom of the screen. Click 

the tab of the slide to edit, e.g. Overview, and then click the Outline View icon above the 
vertical scroll bar.

Entering Text in the Outline View
To establish an outline, use the Outline View mode. Using the icons in the object bar, 
promote or demote an outline point one level, or move it up or down in the hierarchy. The 
icons in the main toolbar can also be used to determine which outline levels are to be 
displayed. 
In the Outline view, all slides in the presentation document are listed hierarchically, and the 
title of each slide is preceded by a slide icon. 
Enter the desired text and use the icons in the Main toolbar to structure the outline. Create a 
subsection to a slide by placing the cursor at the start of the respective line and pressing the 
Tab key. Use the Shift+Tab key combination to move the line up one level in the 
hierarchy. After completing the edit of the presentation outline, click the Drawing View icon 
(directly above the Outline View icon) to return to the normal view. 

Changing the Slide Layout
Changing the slide layout can only be done while in the Drawing View (the first icon in the 
vertical scroll bar). Doubleclick the tab of the slide to modify and select the desired layout 
from the predefined layouts.

Designing Slides
Designing a slide can only be done in the Drawing View, and the Select tool  must be 
activated.
To change the font size and style of the title, for example, select it and assign new attributes 
from the Font and Font Size fields in the Object bar.
Borders may be defined by clicking the paragraph to which to apply the border and defining 
the attributes in the list boxes Line Width and Line Style.
To apply a uniform background and recurring elements (company name, subject) to all slides, 
click the Master View icon to the left of the horizontal scroll bar. The default texts in the 
master view may be safely ignored as these are not visible on the slides. The only text visible 
on the slides is that which is entered by the user. Using the Text floating toolbar on the main 
toolbar, a frame can be opened for background text. 
Using the Styles and Formatting window is an excellent method for managing the appearance 
the slides. Here is a stepbystep procedure:
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1. Open the Styles and Formatting window by clicking the Styles and Formatting icon in 
the Formatting toolbar. 

2. Click the Presentation Styles icon. 
3. Select a background style, and 

4. Open the Modify dialogue via the context menu. 
5. Click the corresponding slide tab and make any changes. 

By modifying the Background Style, all slides can be assigned the same background. 

Note: Since the Master View can be activated at any time, it is always possible to make changes at a later time. 

OpenOffice.org User Guide for 2.x 299



Chapter 5: Creating Presentations With Impress

Creating a Slide Show
In completing a slide show, it is necessary to take a few additional steps to ensure a 
successful presentation.

Defining or Changing Slide Order
To change the slide order, click the Slide View  icon above the vertical scroll bar. In this 
mode, all slides in the presentation document are displayed in reduced size. Click the slide to 
be moved and drag it with the mouse to the desired position. The position where the slide 
will be inserted is indicated by a vertical black bar. 

Creating CrossFade Effects 
To apply crossfade effects, one must have Impress in the Slide View or Drawing View. 

Click on the slide when in the Slide View mode. Set the effect and transition period that is to 
apply to the slide Transition using the two left list boxes. 

In Drawing View, choose Slide Show > Slide Transition to bring up the dialogue in which 
slide transition effects are defined. In the Slide Transition dialogue, select the option 
Manual Transition which will switch from one slide to the next in the presentation on 
clicking the mouse or pressing the right arrow key. 

Starting Presentations 
The easiest way to start a presentation is by clicking the Slide Show icon  on the 
main toolbar or choose Slide Show > Slide Show. The onscreen presentation starts 
immediately. Presentation settings can be adjusted under Slide Show > Slide Show Settings.
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This dialogue also lets the user determine which slides to include in the presentation. Select 
any other desired options, and click OK. 
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Working with Connectors
In addition to the individual frames, connectors are important components of an organization 
chart because they help represent the relationships within the organization. Impress provides 
a variety of connector types. Click on the Connectors icon in the Main toolbar, and a floating 
window with the available types appears. 

Frames and connectors can be linked either from “edge to edge” or from “middle to 
middle,” or a combination of both. These possibilities are described below. 

"Edge to Edge” Connectors
Select the desired connector by clicking it, and then drag it to the first frame. A small symbol 
is displayed on every edge of the frame. Put the mouse pointer on one of the symbols (the 
symbol will be given a dashedline border). Press the mouse button and drag the connector to 
the desired frame. As soon as the mouse touches the frame, symbols appear on each edge 
here as well. Continue dragging the connector to the desired symbol(that symbol also 
receives a small, black border) and release the mouse button. 
When a frame that is connected to another frame is moved, notice that the connector also 
changes position. The actual connection line between the two frames remains the same, so 
that for minor shifting of the frames, the connector usually does not have to be edited. With 
major frame movements, however, it is often necessary to reedit, because the connector may 
shift to a different position. 
To change the position of a connector, simply click on it. Small points appear, at both the 
beginning and end of the connector. If the cursor is rested on one of the points, a small square 
appears next to the mouse pointer. Press the mouse button and drag the beginning or end 
point to the desired frame. 
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"Middle to Middle” Connectors
If a connector is selected from the Connectors floating toolbar and click in the middle of one 
of the frames, a black, dashedline border appears around the entire frame. Press the mouse 
button and drag the connector into the middle of another frame, which also receives a black 
border, and release the mouse button. 
The advantage of this method is that when the frames are moved later, the connector fits 
perfectly, so that the beginning and end of the connectors lie in the middle of each frame. 
This function comes in handy in switching the position of two frames because the connectors 
need not be edited manually. 

Editing Connectors
To change the properties of a connector, select it and click Connector... in the context menu 
to open the Connector dialogue.

Choose the desired connector type from the list box. The Standard Connector is the default. 
The user can also modify the line skew and the line spacing in this dialogue. All changes will 
be shown in the small Preview window. To apply a different colour to the connector, open the 
Line dialogue with the context menu. Hints and Tips for a Successful Presentation

Using a Snap Grid 
To work with greater precision, use the grid function. To display a grid, click the option Use 
Snap Grid under Tools > Options > OpenOffice.org Impress > Grid. In addition, one can 
also select Visible Grid to help position the objects more easily. 
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Editing Glue Points 
By default, the connectors dock to the handles in the centre of the object pages. However, 
using the glue points, the user can make the connectors dock to any point of an object. For 
detailed instructions, refer to the Help > Contents > Index > Search term > glue points; 
using.
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Hints and Tips for a Successful Presentation
Using the Mouse as a Pointer
There are occasions when using the mouse as a pointer is preferable to other methods, such a 
a laser pointer. To use the mouse, select the option Mouse pointer as pen in the Slide Show 
dialogue. This allows highlighting charts or pointing to important aspects during a 
presentation. To change slides manually, doubleclick the mouse.

Changing Bullet Symbols in Outline View
To change a bullet symbol whilst in the Outline view, place the cursor in the desired 
line/paragraph and click the Bullets and Numbering icon (only visible in the Object bar of 
the Outline view). A dialogue appears from which to choose a different symbol.

Inserting, Deleting and Renaming Slides
1. To insert an additional slide, do the following:

a) Select the slide that precedes where the new slide will be put. 
b) Now click the empty space between that tab and the horizontal scroll bar and a new 

slide appears with the page layout of the previous slide. 

Alternatively, choose Insert Slide from the context menu of the slide tab area. In the 
Insert Slide dialogue, assign a name to the new slide and define a layout.

2. Deleting a slide is easy. 
a) Click the tab at the bottom of the work area to activate it and 
b) Open the context menu. 

c) Choose Delete Slide and 

d) Confirm the subsequent warning with Yes to delete the slide.
3. Likewise renaming a slide is simple. To rename:

a) Select the respective slide by clicking the name on the tab, 
b) Press the Alt key and 
c) Click the slide name again. The old name will be selected and can then be overwritten.
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Creating and Printing Handouts
Providing handouts, to help the audience follow a presentation, is often useful. To prepare 
handouts, use the Handout View mode. Since the handouts contain both the individual 
slides and space for notes, they can be a very helpful presentation aid.

In the vertical scroll bar, click the Handout View icon. Open the Modify Slide dialogue via 
the context menu (Slide  Modify Slide...) to specify how many slides are printed on a single 
sheet of paper.

Click OK to create the handouts. To print them, choose File > Print and click Options to 
open a dialogue in which the user chooses how the handout should be printed.

Organizing and Printing Notes
Enter notes for individual slides in the Notes view. Access the Notes view using the Notes 
icon located at the right of the document window scroll bar.

• Once notes are entered, print them by selecting File > Print... then click Options.... The 
Printer Options dialogue appears.

• In the Printer Options dialogue, in the Contents area, select Notes. Click OK. In the Print 
dialogue, select the slides for printing (all or specific ones) and click OK. Be sure to go 
back and deselect Notes in the Printer Options dialogue, otherwise the document will 
always be printed with notes.
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Note: The settings in Printer Tools apply only to the current document. For specific settings for all presentations,  
choose Tools > Options > OpenOffice.org Impress... and select the Print tab.

Using the Navigator
Move quickly from slide to slide by opening the Navigator (function key F5). All the slides 
of the presentation are listed here. Simply doubleclick the relevant slide title to jump to that 
slide.

Edit Jump Targets
In the bottom corners are areas for which one can define an interaction. To edit or view the 
interaction, click (again in background mode) on the area while pressing the Alt key and 
open the context menu and choose the Interaction command. 

Modifying Object Size
To change the object size, drag a selection frame around the respective objects. 

After selecting the frames, open the Position and Size dialogue from the context menu. In 
the tab Size, apply the same size to all selected frames under the group box Size. 

Note: Alternatively, rather than using a selection frame, click on the individual objects and press the Shift key at  
the same time to make a multiple selection. 

Creating Additional Objects 
For additional objects, copy one and simply insert it as often as necessary. Then, position the 
rectangles in the document and align them using the snap lines. 

Note: To display vertical and horizontal snap lines, click on the respective ruler and drag a snap line from the ruler 
to the desired position. 

Changing Font and Font Size 
Change fonts and font sizes using a Style, so that these changes once only have to be made 
once. Click in one of the frames and open the Styles and Formatting window. The Graphics 
Style Object with shadow is selected. In the context menu, choose Modify to open the 
Graphics Style: Object with shadow dialogue, and click on the Font tab to define the 
desired font type and size. Upon clicking OK, the text in all of the frames will be displayed 
according to the selected settings. 

Modifying colours 
To assign a different colour to a frame, use the mouse to drag a selection frame 
around the respective frame. Select Area in the context menu to open the dialogue 

of the same name. 

Select a colour on the Object Fill tab. Further design options are available with the various 
colour schemes in the Gradients tab. Choose one of the existing colour gradients, all of 
which can also be edited and modified. 
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Keyboard Navigating and Selection in Impress
Navigating and selection using the keyboard is done using the arrow keys. One can also use 
Home, End, PgUp and PgDn. Certain keys have different functions depending on whether 
they are simply pressed or are used in combination with the Ctrl key. The following table 
provides an overview of the keys used for navigation.

Key Function +Ctrl key
Right/left arrow 
keys

Go one character to the left or right. Go one word to the left or right.

Up/down arrow 
keys

Go one line up or down. No Action.

Home Go to the beginning of the current line Go to the first slide.
End Go to the end of the current row Go to the last slide.
PgUp Scroll to previous slide. No action.
PgDn Scroll next slide. No action.
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Chapter 6: Creating Drawings with Draw
OpenOffice.org Draw can be used to create drawings with different degrees of complexity. 
This ranges from a simple drawing to an interactive multipage document. To create drawings 
or graphics, open an empty document and design all the elements by hand, or work with the 
templates and sample graphics that can be reached by selecting File > New > Templates and 
Documents or directly from from the Gallery, inc the case of graphics. 
Draw enables creation and saving vector graphics. These graphics can also be exported as 
pixel graphics. Furthermore, it is also possible to insert pixel graphics (bitmaps) into draw 
pages at any time. 

OpenOffice.org Draw Functions
This section contains an overview of some of the OpenOffice.org Draw capabilities.

Creating and Publishing Vector Graphics
OpenOffice.org Draw is an objectoriented vector graphic drawing program. The objects can 
be lines, rectangles, 3D cylinders or other polygons. All objects already have set properties, 
such as size, colour of the surfaces, colour of contours, linked files, associated actions when 
clicked and much more. Any or all of the properties can be modified at any time. 
Because of the vector technology objects can be rotated in any direction and have their size 
altered, without unsightly step effects occurring on the edges. Furthermore, as all of the 
objects can be controlled individually, they can be moved and overlapped as required. 

Creating 3D Objects
Draw does not restrict graphics to two dimensions. Cubes, spheres, cylinders and other 3D 
objects, can be created, rotated at will and each object can be illuminated individually by 
means of various light sources. These features together with default or freely defined colour 
gradients, allow quick and easy creation of eye catching company and Internet presentations.

Manage Organization Charts
OpenOffice.org Draw is objectoriented. The objects could be rectangles, for example, 
containing text and linked to each other. If rectangles are moved, connectors will 
automatically follow. This makes drawing and maintaining a company or departmental 
organizational chart much easier. The connectors can also be freely placed at glue points, 
which makes the creation of technical drawings with explanatory texts easier.

Drawing
Make straight lines, free lines, bezier curves and other types of rectangles and geometrical 
figures in the usual ways. The 3D functions can be used to create 3D objects such as cubes, 
spheres, cylinders, tori and more. Rotate two dimensional contours in the third dimension. 
Choose colouring, colouring with bitmap textures, perspectives and/or illumination to create 
impressive 3D objects for invitation cards, brochures, business cards and other stationery.
To insert additional elements into a drawing use clipart available in the gallery. It doesn't 
matter if they are vector or pixel graphics.
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Export
Use Draw to quickly and easily create buttons and icons for Web pages et cetera and export 
them as GIF, JPG, PNG or other formats.

Construct
There are many tools that Help create exact drawings. For example, define a grid to which an 
object can be snapped during construction and moving, or temporarily snap new objects to 
the edges and points of existing objects. The size of the object can be altered at any time by 
entering the required measurements in the Properties dialogue. It is also simple to insert 
dimension lines which can be used in a variety of ways. 

Integrate
And, in case it is not obvious, Draw allows the user to add texts, tables, charts and formulae 
from the other program modules of OpenOffice.org into any drawing.
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The OpenOffice.org Draw Window

Toolbars and Windows® in OpenOffice.org Draw
The above graphic shows the various floating windows that enable OpenOffice.org Draw. 
Each window has a corresponding icon on one of the toolbars. Most are icons are located on 
the Main toolbar that is on the left of OpenOffice.org main window. Please ensure that at 
least Help > Tips is enabled so that hovering the cursor over an icon provides a meaningful 
explanation of what each does. Enabling Extended Tips gives even more information.

Note: that the user can also access functions through the context menu instead of using menu commands, which 
makes for less work with the mouse.
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Drawing Rectangles and Ellipses and Entering Text
The drawing module in OpenOffice.org (Draw) has many functions for creating and editing 
vector graphics. In this section introduces the most commonly used functions.

More detailed information can be found in OpenOffice.org Help.

Open a new drawing document by choosing File > New> Drawing. In addition to the blank 
drawing page, notice the main toolbar on the left and the object bar for drawings at the top of 
the work area. With the View > Toolbars command, adding the option bar and/or the colour 
bar at the bottom edge of the window is easy and useful as shown in the following 
illustration: 

If these instructions are used to create a presentation document instead of a new drawing 
document then notice one of the visible differences between Impress and Draw: The buttons 
at the top right above the scroll bar (only in Impress) indicate drawing view while the buttons 
at the bottom left indicate the slide view.
Draw and edit vector graphics in the drawing view. The other views, which are only available 
in Impress by clicking the buttons at top right, Help create presentations. They are introduced 
in the chapter on Impress and are also described in Help.
In the slides view,the user works on the individual slides of the presentation, whereas the 
master view allows defining a uniform background for all slides. In addition, the layer view 
can be turned on and off as desired. For example, the layer view is where objects that are not 
always supposed to be visible can be managed. 
The main toolbar contains several floating toolbars. When opened, these toolbars provide 
additional related icons. The floating toolbars are indicated by small triangles on icons and 
are opened by longclicking the corresponding icon on the main toolbar until the floating 
toolbar appears. When a toolbar is “floating”, it can be moved from its original position 
and placed anywhere else in the work area. 

Longclick the Rectangle icon to  open the floating toolbar and click on the Rectangle 
icon. The pointer changes to a crosshair symbol with a small square.
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1. Draw a rectangle on the slide. It has preset attributes, including a blue fill and a thin black 
line as a border. There are eight handles with which can be dragged to change the size of 
the object.

2. Draw further rectangles. These can be overlaid with the existing rectangles. 

3. Click the Ellipse icon  and draw a few ellipses. Also try drawing a few 3D objects, as 
shown in the illustration. Several examples are available. in the 3D (threedimension) 
theme in the Gallery.

4. Click each of the objects and modify the fill colour, line colour, and the line width using 
the list boxes and icons on the object bar.

Note: Clicking once on any tool, makes the tool available for only one single task. Doubleclick the icon to allow it  
to remain active until another tool is chosen.

Defaults, such as blue as the filling colour, can be changed. Make sure that no object is selected and choose a 
different colour on the object bar as the new default.
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Rotating and Resizing Objects
When clicking an object for the first time, eight handles appear with which the size ma be 
changed. The whole object can also be dragged to move it to another position on the slide.

Click the Rotate icon on the main toolbar under Effects and directly on the main toolbar in 
Impress.

When the mouse pointer is positioned over a handle, the 
pointer indicates that the object can be rotated by 
dragging the mouse. In the middle of the object, a small 
circle indicates the pivot point. It can be moved to any 
other position with the mouse. When the corners of the 
object are dragged with the mouse, the object rotates 
around the pivot point. Dragging the middle points on the 
sides slants the object in relation to the opposite edge. 
Click on the object once again to display the eight 

handles. By doubleclicking within the object, the handles change and the text cursor appears 
positioned in the middle of the object. Text can now be entered which is automatically 
connected to the object. Some interference may appear on screen. Press Ctrl+Shift+R to 
refresh the screen. 
To resize an object, simply click on one of the handles and drag until the object is the size 
needed.
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Arranging and Aligning Objects
Arranging Objects

Where objects are overlapping and the position of the individual 
objects in the foreground or background must be changed, use 
either the context menu commands, or use the icons on the 
Arrange floating toolbar.

• Click on the object which is to move either in front of or behind other objects. Then click 
on one of the icons in the upper row of the Arrange floating toolbar, for example, to move 
the object completely to the back. To position it directly behind another object, click the 
Behind Object icon. Then click on the object behind which the current object is to be 
positioned. This effect will only be seen if the objects are presently overlapping or are 
moved to do so later.

• Select two objects at the same time by holding down the Shift key and clicking the 
objects, one after the other, and then clicking Reverse. This switches the order of the two 
objects.

Aligning Objects
Position objects anywhere using the mouse. However, to 
position an object at exactly the upper margin of a slide, 
for instance, or centre two objects vertically above each 
other, use the icons on the Alignment floating toolbar.

• If an individual object is selected and then one of the icons on the Alignment floating 
toolbar is clicked, the object is aligned at the page margins. Two or more objects selected 
together, will be aligned to each other.

• A special type of alignment is the Distribution of objects. When, at least, three objects are 
selected at once, use the Distribution command. In Impress, this command can be found 
in the context menu, while in Draw it is found as an option in the Modify menu. 

The selected objects are distributed so that their borders or midpoints are the same distance 
apart. The two objects that are the horizontally or vertically farthest apart from each other are 
fixed points, i.e. immovable. The other objects between the outermost objects can be moved 
using this function. 

Note: Remember that everywhere in OpenOffice.org a multilevel undo function is available. Activate this function 
by clicking the Undo icon on the Standard toolbar or by pressing Ctrl+Z. Each time this command is used, it  
reverses a previous action. 
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Drawing Sectors and Segments
The Ellipse floating toolbar contains several icons for drawing sectors and segments. Sectors 
look like “perfectly cut pieces of pie”. Segments look like halves of a pie.
Drawing sectors of an ellipse or circle requires multiple steps, though the process functions 
intuitively:

1. Open the Ellipse floating toolbar and click on the Circle Pie icon.  The pointer 
changes to a crosshair symbol accompanied by a small sector symbol. 

2. Use the mouse to drag open the shape of a circle. The outline of a circle follows the 
movement of the mouse. 

Note: The first click defines the first corner of the delimiting rectangle which surrounds the circle. The delimiting 
rectangle will later be obvious from the eight handles that appear when selecting the circle. To draw the circle such 
that the first click defines the centre, press the Alt key while dragging the mouse. 

3. Release the mouse button when the circle has reached the desired size. Now notice that a 
radius which follows the movement of the mouse is drawn in the circle. 

4. Position the radius at the point where it is wanted so as to place one boundary of the sector 
and click once. 

5. Now when moving the mouse, notice that the first radius is set and a second radius follows 
the movement of the mouse. Click again to complete the circle pie. 

Drawing ellipses is done in a similar fashion. The 
dimensions of the delimiting rectangle, formed when first 
drawing the shape, determines the dimensions of the ellipse. 
When drawing a segment, proceed in exactly the same 
manner as described above for sectors. The only difference 
is that in the last step no second radius follows the 
movement of the mouse, but rather a secant (straight line) 
cuts through the circle. 

The other icons in the Ellipse floating toolbar can be used to draw ellipses and arcs. This 
process also functions as described above although, only the perimeter of the ellipse or the 
circle is drawn. 
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Entering Text
To enter a text in a drawing, decide if the text should have a “normal” format as in a text 
document or if the text should be handled as a graphic object that can be rotated, expanded, 
minimized, et cetera. “Normal” text can also appear in the form of a legend (in a frame with 
an arrow).

Open the Text floating toolbar from the main toolbar.

Note: Where Asian language support is enabled under Tools > Options >Language Settings 
> Languages, there will be additional icons for entering vertical text.)

Normal Text
1. Enter “normal” text by clicking the Text icon. 
2. Drag open a delimiting frame in the document which sets the position and maximum 

width the text area should have. If the text is long, extend the frame in order to incorporate 
the whole text. Position and the size of the frame can later be changed using the mouse; 
but the frame cannot be made smaller than the text itself. 

3. Enter the text. Select the text by holding down the Shift key while using the arrow keys or 
use the mouse. The font and font size can now be modified as in regular text documents. 

When the mouse is clicked anywhere on the document other than the text, text edit mode is 
no longer in effect. Clicking the text once again, the text will be selected as an object. Now, it 
can, for example, be rotated or the entire text moved. By doubleclicking the text it can be 
edited it again, for example, delete characters or set additional font attributes. 

Fitting Text to Frames
1. With the Fit Text to Frame icon, draw a delimiting frame which predetermines the 

position and size of the text.
2. Enter any text in the frame.
3. Click in any free area of the document.
Notice that the entered text is scaled so that it exactly fits into the frame.
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Callouts
1. Using the Callouts icon,  drag the mouse from where the callout arrow should point, 

to the point where the callout text should appear. 
2. Release the mouse button.
3. Edit the size of the frame of the callout.
4. To start entering text into the callout, just doubleclick the line. The callout frame appears 

with a wide gray border, indicating text edit mode.
5. Enter the callout text.
6. Change the line properties by clicking on the line, opening the context menu and clicking 

on the Line command. Select arrowheads for the lines in the Style pulldown list on the 
Line tab page.

Converting Text Into 3D
Selected text can be transformed into a 3D body by choosing Convert > To 3D from the 
context menu. The 3D body will fill the area created for the text frame. 

3D text can be rotated using the Rotate icon  from the Effects floating toolbar on 
the Main toolbar. 
By clicking inside the delimiting frame and dragging with the mouse button pressed, the 
object will rotate on all the axes at the same time. However, by clicking one of the eight 
handles and dragging it with a pressed mouse button, the object rotates on only one axis. 
The pivot point, which first appears as a small circle in the middle, can be moved. Thus, 
while rotating the object, it rotates around the new pivot point. Open the 3D Effects window 
by clicking the 3D Controller icon from which another, different illumination can be applied 
to the 3D object. The 3D Effects window is described in more detail in Help. 
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Drawing, Editing and Converting
Curves and Objects
With vector graphics in drawing and presentation documents, design not only ellipses and 
rectangles, but also irregularly shaped curves forming open or closed figures. Both Impress 
and Draw make it very easy to draw and edit even quite unusual figures.

Drawing Curves
1. The tools for drawing special shapes are found in the Curves floating toolbar indicated by 

this icon  on the Mail toolbar. Drag the floating toolbar away from the Main toolbar 
into an empty drawing or presentation document. 

2. Select the Curve  icon. The cursor appears as a crosshair symbol with an 
accompanying symbol that indicates the new function. 

3. Create a curve using the mouse. 
a) The point where the mouse button is first clicked determines the starting point. 
b) Move the mouse in the direction the curve should take from the starting point. The 

point where the mouse button is released, defines this direction 
c) Moving the mouse without holding the button down and the curve will follow the 

movement of the mouse
d) Click where the second point of the curve should be. 
By holding down the mouse button, the direction of the curve from the second point can 
be defined to the next point (in the same manner as was done at the starting point), release 
the mouse and move to the third point, click again and keep the mouse button pressed, and 
so on. 
But when the mouse button is released after clicking on the second point of the curve, and 
another point in the slide is clicked, the second point will be defined as a corner point. At a 
corner point, the curve abruptly changes direction, thus forming a corner. If there is a 
point three defined as a corner point in this way, a straight section between points two and 
three will appear. 
When the Shift key is held down, directions are limited to multiples of 45 degrees. By 
holding down the Alt key, the curve will be closed, and an additional curve can be drawn. 
These can be combined with the first one to form a single object. 

4. To end curve drawing, doubleclick the last point to be set then continue working with 
other tools. 
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The curves, that have been drawn using the above steps, are Bézier curves. The points on a 
Bézier curve are called data points. 
• Each data point on the Bézier curve can be “symmetric”. The curve then has the same 

curvature either side of the point. 
• Or the data point is “smooth”. The curve then has different curvatures either side of the 

point. 
• If the curve is not steadily continued at the data point, but instead forms a corner or tip, it 

is a corner point. Any type of data point can be converted into any other, thus giving good 
control over the shape of the curve. 

Note: When precisely linking two existing points in a drawing using lines, click the Line icon on the main toolbar 
and also activate the option bar via View > Toolbars > Option Bar. Select the Snap to Object Points icon on this  
toolbar. 

Editing Curves
Data points can be edited if they are displayed as small rectangles. To work on a curve later, 
when it is no longer selected, click the Edit Points icon on the object bar and select the 
curve. If the object bar is not visible, click briefly on Select on the main toolbar: 

1. Now click Edit Points on the far left of the object bar or on the option bar. 
2. Click once on the point for editing. It will appear as a filled square, and there should be 

two Bézier lines with control points at the ends. (Please note that sometimes one of the 
control points is directly on top of the Bézier point and thus hard to see.) In the case of 
corner points, which define right angles, the control points lie directly on the Bézier point. 
Now move the Bézier point and the control points as needed. Note how the curve changes 
accordingly. The change in form of the cursor indicates in each case the function that can 
be executed. 
The object bar contains several icons with which can, among other options, change the 
type of the selected point. A detailed explanation of the various options can be found in 
Help. 

3. To convert the type of data point, select the point. The object bar shows the type of point: 
corner point, smooth transition or symmetric transition. 

4. Click one of the icons to change the type of point. 
Of course, curves can also be edited in the “conventional” manner, i.e., changing width, 
colour, and (in the case of a filled curve) the object fill. The options for changing these 
attributes are found in the Object bar. If the Edit points icon is not pressed, use the context 
menu or the Format and Modify menus. 

Also try out the other icons on the Curves floating toolbar. When a filled curve is finished by 
doubleclicking, it is automatically closed and all “internal areas” are filled. 
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Vectorizing Bitmaps
With Draw or Impress, transform pixel images, so called bitmaps, into vector drawings. 
One of the advantages of vector graphics is that they look good in any scale when printed. 
This is different when printing scaled bitmaps, since unattractive effects may appear, such as 
missing or zigzag lines, et cetera.
1. Select the bitmap to vectorize, for example by clicking once on the object.

2. Select Convert > To Polygon from the Modify menu in Draw  . For Impress, select 
from the context menu of the selected object.

The Convert to Polygon dialogue enables setting some parameters for the conversion and 
previewing the result. 

3. Clicking on OK and the selected bitmap is now a vector graphic.
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Converting Text Characters to Curves
Sometimes one needs to fancy up some text, say for a logo or sign, such that the text is non
linear. The following procedure shows one way to accomplish this task.

1. Use the Text icon  from the Text floating toolbar on the main toolbar and then type the 
text, letters or special characters in a Draw document. Remember to use a reasonable font 
size and font type to avoid unnecessary editing later. 

2. With the text object still selected, choose the command Modify > Convert to Curve. The 
text is converted to a vector object that can be edited. 

3. If the text consists of more than one character, the characters will be displayed as a 
grouped object. To edit a single character, enter the group. To do this, use the Enter 
Group command in the context  menu of the group or press F3. Then click the 
character to be edited. 

4. Now, click the Edit Points icon  on the option bar (top left in the graphic below). 
Click the object to see all the Bézier points of the object. The object bar, provides various 
icons for editing, inserting and deleting points. 
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5. Use the Zoom floating toolbar to enlarge the view. If the black filling of the characters is a 
distraction during the editing process, temporarily change it to, say, 10% gray by choosing 
Format > Area. 

Converting to Curves, Polygons, 3D
Many objects quite effectively edited by converting them. The following examples illustrate 
this concept:
• Open a rectangle. This has the default settings for colour, line thickness etc. and should 

now be selected. 

• Choose Modify > Convert (in Impress the corresponding command can be on the context 
menu of the rectangle). The menu subcommands are: To Curve, To Po lygon, To 
3D, To 3D Rotation Object. 

• Choose Modify > Convert > To Curve to convert the rectangle into a Bézier curve. Now 
edit the existing points. As shown in the following graphic, move the points, convert them 
from corner points into rounded points, delete them, insert new points et cetera as the 
rectangle is converted into a heart shape. All these options are described in detail in Help 
under the search words Edit points and Bézier object bar. 

Choose Modify > Convert > To Polygon to convert the original rectangle into a “Po lygon 
with 4 points”, as will then be stated on the status bar. Now, for example, a polygon 
down can be broken down into its basic parts by choosing Break from the Modify menu. The 
status bar will then read “4 Lines selected”. Each of the lines can be shifted 
separately. 

With a polygon selected, click the Edit Points icon to modify points, insert new ones and 
anything else needed in this mode. 
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Select Modify > Convert > To 3D  to generate a threedimensional 
object from the twodimensional  object in (g) above. This 
conversion uses an extrusion method such that the polygon is “pulled” 
perpendicular to its plane by a certain amount into the third dimension. 

3D object can be rotated and edited via the 3D Effects window that is called up from the 
context menu. 

To create a 3D object by means of a rotation extrusion, choose Modify > Convert > To 
3D Rotation Object. A polygon will be rotated 360 degrees around an axis into the third 
dimension. 

By rotating a rectangle a little bit before converting it into a 3D rotation object, a more 
striking object will be created. 
While these examples showed conversion of only basic objects, such as simple rectangles, 
imagine how much can be done when converting complex objects. 
For example, drag a drawing from the Gallery to the page and convert it into a 3D object. 
Draw positions the objects contained in the drawing in various 3D levels corresponding to 
their arrangement in 2D levels. For example, in 3D the stars from the European flag stand out 
vividly from the blue background of the flag. 

Most objects can be converted to 3D: 
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• Groups can be converted as long as they contain convertible objects. 
• Bitmaps will be laid as a texture over a rectangular object of adequate size. 

• Metafiles will be broken down into a group of polygons and then converted. 
• Draw objects with text on them display the text in raised form on their surface (e.g. a 

rectangle which was doubleclicked and on which text was placed). 
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Working With Objects
Individual objects in an impress or draw document can be selected, copied, cut and pasted in 
much the same way as words in text. Other actions are also possible that are only available 
for graphic objects. For example, objects may be duplicated, crossfaded or grouped. Figures 
placed in the drawing area, such as rectangles, circles, lines et cetera, are treated as objects.

Duplicating Objects
Objects, in Draw, are easily duplicated. This feature allows the user to make a set number of 
copies of an object which differ in consistent degrees from one copy to the next in position, 
orientation, size, and colour.
For example, to create a stack of coins, use the duplicate function.
First create the bottom coin by doing the following as shown in the graphic below:
1. 1. Draw an ellipse or circle at the bottom of the slide.

2. 2. Choose the Edit > Duplicate... command to open the Duplicate dialogue.
3. 3. Enter the following values:

Follow these steps to create a stack of coins as shown on the right of the above graphic:
1. Select 30 as the number of copies. The xaxis is the horizontal axis from left to right. 

Entering positive values in the field for the xaxis placement causes a shift to the right. 
If the stack of coins should increase from the bottom up, enter a negative value in the y 
direction (vertical). 

2. To make the coins to become smaller the higher they get, enter a negative value for the 
width and height. 

OpenOffice.org User Guide for 2.x 326



Chapter 6: Creating Drawings with Draw

3. Finally, define a colour scheme from bottom to top. Select, for example, a darker yellow 
for the beginning colour (bottom) and a lighter yellow colour for the end colour (top). 

4. Click OK to create the duplicates. 

CrossFading Between Two Objects
The crossfading function is only available for drawings in Draw and not in Impress 
documents. To insert into a presentation an object that was created by crossfading two 
objects, copy it from the drawing into the presentation document by way of the clipboard. 
In the process of crossfading a transition between two objects is calculated and the 
increments will be positioned on the page. In the increments, the form, orientation, and 
colour of the objects, as well as other attributes, are adjusted uniformly. 
1. For example, in an empty drawing document, draw an object at the bottom left and 

another one at the upper right (use two different colours). 
2. Select both objects. 

3. Select the command Edit > Crossfading. A dialogue appears where further settings can 
be defined. 

4. Click OK. 
Draw calculates the increments and displays the results. 
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This new object is a group which consists of the specified 
number of individual objects. Enter the group by pressing F3 
and then edit the individual objects. The Modify menu in Draw 
contains all the necessary commands for working with groups 
and these functions can be also found in Impress under the 
Format > Group menu command or in the context menu. 
Further information can be found in Help. 
1. Working With a Group of Objects
Several objects at one time can be selected, grouped, combined, merged, subtracted and 
intersected. 
• Selecting several objects at the same time has a temporary effect; i.e. whenever the mouse 

is clicked elsewhere on the page or slide, the grouped area is deselected. 
• Grouping and combining are valid until the group or the combination is deselected using 

the command from the context menu or the Modify menu. 
These commands can also be used to group together several groups, add a combination and 
combine the results as a group or combination. 

Grouping Objects 
Several objects can be combined into a group. To do this, select them together, rightclick to 
bring up the context menu and choose Group. Any and all changes made to a group have an 
effect on all objects in the group. In particular, groups can be moved, rotated, etc. as a single 
object. 
For example, in drawing a bicycle, first construct a wheel, composed of a tire, rim, spokes, 
and hub, and then group these objects together. This makes it easy to rotate the wheel, 
duplicate it, and move the second wheel to the appropriate position. Finally, draw the frame 
and the rest of the bicycle, and form a new group. 
To edit an object that is part of a group, there is no need to redefine the group. Use the 
Enter group command which allows editing any object in the group. When edits are 
completed,

Entering Groups
Enter a group by first selecting it, either by clicking it or by using the keyboard. Once 
selected, the user can decide whether to employ the context menu command, the F3 key or 
doubleclicking the group to enter it.

Exiting Groups
Exiting a group may be accomplished in these three ways: using a menu command, the key 
combination
Ctrl+F3, or doubleclicking outside all of the objects in the group. The group remains 
selected upon exit; thus making it possible to quickly enter and exit a group using the 
keyboard.
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Navigating Between Objects of a Group
Using the Tab and Shift+Tab keys the user can move forward and backward along the 
row of objects in a group edited with F3 or on a page. If the keys are pressed again on a final 
object while going in one direction, the first object selected will appear next.
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Combining Objects and Constructing Shapes
In Draw and Impress graphic objects may be combined in different ways. Several single 
objects can be brought together to create new objects by using Boolean set operators on the 
original geometry.

Combining Objects
1. Select several objects.

2. Choose Combine from the context menu. 
In contrast to groups, which consist of single objects, a combination fuses the component 
objects into one single new geometric object with its own new properties. The combination 
may be undone again later, but the individual objects may not be recoverable.
The user should recognize the property that stands out the most in a combination when the 
individual objects overlap. In this case, the combination is the result of the Boolean/logical 
operator XOR, and shapes, discussed later, are other logical combinations. The areas of 
overlap are the ones which stand out the most in a combination, as they will be converted into 
“holes”.

In the illustration, several objects are shown to the left as they are before being combined, 
and at the right after being combined. The combination is given the attributes of the object 
farthest to the back (i.e. undermost object).

Constructing Shapes
The commands Shapes > Merge, Subtract and Intersect also form a new geometric object 
out of the original objects. The new object comes into being through the use of logical 
amount operators (boolean O) on the source geometries. 
1. Select several objects.

2. Choose Shapes from the context menu. In the submenu, choose Merge, Subtract or 
Intersect.

In the following illustrations the original shapes are shown on the left and the result on the 
right.
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Shapes  Merge
The selected polygons are merged so that they make one object, the 
surface of which is the sum of all the parts (Boolean OR). 

Shapes  Subtract
All other polygons selected are subtracted from 
the undermost polygon. This entails the other 
polygons first being merged and then subtracted 
from the polygon positioned under/behind all the 
others. Holes are taken into account. Logically 
this operation corresponds to the following 
formula: A > (B1 | ... | Bn) 

Shapes  Intersect
The selected polygons are joined into one single polygon 
that corresponds to the intersection area (Boolean AND).

  Only the area where all polygons overlap remains. 

Choosing Shapes > Subtract and Shapes > Intersect also permits cutting parts out of a 
bitmap. The illustration below shows examples. 
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Graphic Objects in Drawings and Presentations
Both Draw and Impress use a vector graphic format. However, pixel graphics or bitmap 
graphics may also be inserted into presentations or drawings and documents or certain 
sections of a document can be exported in a pixel graphic format.

Inserting Bitmaps
Bitmap images can be inserted in any Writer, Calc, Draw or Impress document.

1. Choose Insert > Picture.

2. Select the file. With the File type field users can limit the selection to certain file types.

3. Check the Link box to hyperlink to the original file where embedding is not needed.

If the Link box is checked, whenever the document is updated and loaded the bitmap 
image is reloaded, and any editing steps, that have been applied to the local copy of the 
image in the document, are reapplied and the image is displayed.

If the Link box is not checked, the copy created with the first insertion is embedded and 
used.

4. Click Open to insert the image.

Editing Bitmaps
When a bitmap image is selected, the object bar offers the tools for editing the image. Only a 
local copy is edited in the document, even if an image  is inserted as a link. 
The object bar may look slightly different depending to the module being used. The 
illustration shows the object bar in Draw: 

A number of filters are located on the Filter floating toolbar, that the 
user can open with the icon on the far left of the object bar. 
Some of the filters open another dialogue when started, and the user can 
use these options, for example, to select the intensity of the filter. 
Text and graphics can be added to the bitmap image by selecting these objects together and 
exporting the selection as a new bitmap image. 

Applying Text to Bitmaps
To apply text to a pixel image and save it in JPEG format, for example, follow these steps:
1. Open a new drawing document.

2. Insert the pixel image by choosing Insert > Picture.
3. Unselect the image by clicking somewhere else in the document.
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4. Open the Text floating toolbar from the Main toolbar and select an option; for example, 
the Fit Text to Frame icon.

5. Draw a frame around the pixel image and enter some text inside this frame.
6. If desired, select this text and assign another colour to it. The background of the text is 

automatically transparent.
7. Select the pixel image and the text by drawing a frame around both. The Status bar will 

read “2 draw objects selected”.

8. Choose File > Export and, in the Export dialogue, 
9. select the file type “JPEG  Joint Photographic Experts Group” 
10.Enter a name. 

11.Check the Selection check box to export only the selected objects.

12.Click Save. 
Another dialogue permits setting options to define the quality of the JPEG image. Remember 
that the higher the quality, the larger will the file be.
When a graphic object (for example, an inserted Pixel image) is selected in Impress or Draw, 
the graphic object bar will be automatically be displayed. This bar enables modification of 
the colour tone, brightness and contrast of the graphic object.
Changing the transparency value of graphic objects is also possible. At a higher transparency 
values a graphic object becomes seethrough, and objects lying behind it will be visible. 
When the work is saved as an OpenOffice.org document, the transparency is saved too.

NOTE: When exported as a graphic format, transparency is only saved where the graphic format supports the 
transparency and this function is enabled at the time of export. 

Saving Bitmaps
Saving changes to a bitmap image as an image file, for example in one of the GIF, JPEG or 
TIFF file formats, is only possible in Draw or Impress by selecting and exporting the bitmap 
image. The following provides a stepbystep procedure:
1. Select the bitmap image. 

Also select any additional objects as necessary. Pressing the Shift key for each selection 
or by open a frame around all objects, to include, say, text with the bitmap image.

2. Choose File > Export to open the dialogue.

3. In the File type field select the file format desired. For example GIF, JPEG et cetera.

4. To only export the selected objects, check the Selection box.

If Selection is not checked, the entire page of the document is exported.
5. Enter a name for the file.

6. Click Save.
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Working With colours
The object bar has a list box from which to choose the colour for a selected object from a 
number of predefined colours. The colour of the border line can be chosen independently of 
the colour of the filling.

The colour Bar
If wanted or needed, the colour bar can be displayed on the edge of a drawing or 
presentation. The colour bar offers a choice of colours. Selected objects can be coloured by 
simply clicking on a colour. To display the colour bar, select View > Toolbars > colour Bar. 
The colour bar displays all predefined colours with their respective names in the same order 
as in the list box of the Object bar. Userdefined colours appear at the end of the colour bar 
and the bottom of the list box. 

The field at top left of the colour bar is for the colour “Invisible”. 
Change the size of the colour bar using the mouse. Alternatively, hold down the Ctrl key 
and doubleclick in the gray part of the colour bar to obtain a movable, variablesize window 
that can be manipulated in the same way as most other windows. For example, it can be 
moved by dragging the title bar and its size changed by dragging the edges or corners of the 
window. To dock the window again, hold down Ctrl and doubleclick on a gray area of the 
floating colour bar. 
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Defining Custom colours
Any number of colours can be defined by the user, have names assigned and be saved in 
colour palette files.

1. In a drawing document, choose Format > Area... to open the Area dialogue.

2. In the dialogue, click the colours tab.

This provides everything needed to modify the colour of a selected object. Here, the user can 
also define and organize new colours.
To apply a colour that is not yet in the colour palette, first define the new colour and assign a 
name to it.

Note: Modifications to the standard colour palette are permanent. These are saved automatically, and are 
irreversible. This should not present problems if only adding a new colour to the palette, but it can create 
difficulties if the standard colours are changed. 

1. To define a new colour, the best thing to do is choose a colour from the colour palette 
which resembles the new colour. It will be displayed in the upper of the two preview 
boxes.

2. The list box provides two settings, RGB and CMYK,for defining the colour. Select the 
colour model in the list box that corresponds to what is needed for this colour.
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The colour models RGB and CMYK are just two of the models most used to define colours. 
RGB stands for redgreenblue and this model is particularly useful for colours being 
displayed on a computer monitor as it combines the three basic colours used. CMYK stands 
for CyanMagenta Yellowblack or Cyan Magenta YellowKey and is 
the colour model that best describes the subtractive colours used in printing. Select the 
colour model that corresponds to the desired output medium (monitor or a printer). When 
exporting image files, it is best to ask the photoexposure service in which colour model 
and format the image is expected.

3. Define the colours by modifying the values in the spin boxes. Enter values directly, or 
click the buttons to change the existing values. The result is shown immediately in the 
lower preview box.
If selecting colours from a colour spectrum is preferable to specifying the values with the 
spin buttons, click Edit. This opens the colour dialogue. In this dialogue it is also possible 
to specify the colour in the HSV or HSB (HueSaturation Value/Brightness) 
model. Select the colour and click OK.

4. Once a new colour is chosen, specify whether it should replace the original colour or be 
defined independently. 

Note: It is recommended that only customdefined colours be replaced.

1. To replace the colour displayed in the upper preview box, click Modify. 

2. To set the new userdefined colour, assign a name to the colour in the Name field, and 
click Add and OK.

The new colour will immediately be added to the palette of existing colours; however, if the 
dialogue is exited by using the Cancel button, the colour of the current object does not 
change.
Nonetheless, the modifications in the colour palette do remain in effect.
Further instructions on saving and loading the colour palette and other palette files are found 
in Help.
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Replacing colours using the Eyedropper
In Draw and Impress, images inserted in a bitmap format such as, GIF, JPEG and metafile 
images like WMF can have their colours edited using the Eyedropper. To open the 
Eyedropper window,choose Tools > Eyedropper.

The Eyedropper can replace selected colours and, to a point, similar colours, with other 
colours, up to four colours at one time. If the replacement is not what is desired or needed, 
reverse it with one click on Undo on the Standard toolbar. Use the Eyedropper to match the 
colours of different bitmaps or to redo a bitmap with, say, the colours of a company logo.

The Transparency attribute also serves as a colour. Transparency, in an image with a colour, 
can be replaced for example, with white. This is Helpful when, for example, the printer 
driver has problems with printing transparent graphics. 
If the user wants to produce an image on HTML pages to publish in the Internet, like the 
illustration of a product, for example, it usually looks better when one does not see a 
rectangular picture, but rather sees only the illustration of the product against the uniform 
background of the web page. If there is a white background in the picture behind the product, 
use the Eyedropper to replace the colour white with “Transparent” (i.e. no colour) and save 
and/or export the image in a format that supports the transparency attribute (such as GIF). 
When using this method, be sure that the illustration of the product itself does not contain 
any white parts, since these would also become transparent just like the background. 
To replace colours with the Eyedropper

1. Insert an image in a Bitmap format (e.g., BMP, GIF, JPG, TIG) or in a metafile format like 
WMF. To do this, choose Insert > Picture in Draw and Impress. 

2. Open the Eyedropper window by choosing Tools > Eyedropper. 
3. In the Eyedropper window, click the Eyedropper icon in the upper lefthand corner. The 

mouse pointer will turn into a special pointer with which one can indicate the colour to be 
replaced in the current document. The colour box next to the eyedropper icon in the 
Eyedropper window displays the colour the mouse pointer is resting on. 
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4. Click the left mouse button when the colour is found which is to be replaced. This colour 
will automatically be registered in the first of the four rows in the Eyedropper window. 

5. Now, in the list box to the right in the same row, select the new colour which should 
replace the selected colour in the whole bitmap image. 

6. If in the same editing step one wants to replace another colour, click the check box in 
front of the next row. Now select the eyedropper icon in the upper left hand corner again 
and choose a new colour. Up to four colours can be replaced in one editing step. 

7. Select the bitmap image or the metafile image in which the colours are to be changed, by 
clicking in it. 

8. In the Eyedropper window click Replace. If too many similar colours were replaced, 
undo the step using Ctrl+Z and decrease the colour tolerance in the spin button. Then 
click Replace. 
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Gradients and Patterns for Objects and Background
The objects in drawings and presentations do not have to have uniform colours. They can also 
have colour gradients, transparency gradients, patterns and hatching effects. Users can also 
define a colour, a gradient or a pattern for a background that is visible in all slides of a 
presentation.

Defining Gradients
To assign a predefined gradient to an object, proceed as follows:
1. Select the object.

2. From the context menu or under Format on the menu bar, choose Area....
3. Select the Gradient option, then make a selection from the gradient list.

Defining a custom colour Gradient
Before defining a new, custom colour gradient, save the current colour gradient list as a file 
to ensure there is a backup [say why?] or load a different list from another file.
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If the user has selected an object and then defined a new gradient, the new gradient is 
immediately assigned to the selected object. If one does not want immediate assignment, 
undo the selection before opening the dialogue for defining gradients. To do this, click with 
the selection tool on a position where there are no objects.

1. In the Area dialogue, click the Gradients tab. This tab enables definition of all of the 
options for new colour gradients.

2. From the list of existing colour gradients, click the gradient to use as a basis for creating 
the new colour gradient.

3. Click the Add... button. 
a) In the dialogue, assign a name for the new gradient. For example, enter the name 

“UFO”.
b) click OK. The name will appear as a new entry at the end of the list and is selected for 

editing.

4. Click Modify to save the changes in the new gradient. The preview shows how the 
gradient looks.

5. Close the Area dialogue with OK.
The new colour gradient may be used immediately.

Interactively Defining a colour Gradient
Colour gradients can be modified by clicking and dragging them with the mouse. However, 
in order to be defined interactively, the object must already have a colour gradient.
1. Select an object which has a colour gradient.

2. In Draw, open the Effects floating toolbar  from the Main toolbar.

3. On the Effects floating toolbar, click the Gradient icon.
Two objects in colour which are linked by a vector should now be visible.
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Depending on the type of gradient, one or both of the objects can be moved with the mouse 
and thus determine the origin, end and angle of the colour gradient. When the colour bar is 
displayed, assign colours by dragging and dropping the selection to each object to determine 
the start and end colours.

In a similar manner, the transparency of an object can be set using the  Transparency 
icon. With this tool, defining a grayscale gradient which spans from black (0% transparency, 
i.e. opaque) to white (100% transparent) is possible.

Organizing the Attribute Tables
The icons Load Gradients List and Save Gradients List open dialogues for opening and 
saving gradients. The current gradient list, for instance, might consist of all gradients which 
are custom defined for a certain project. Save the list, then reload the standard list. This way 
the list (and the memory space) can be kept free from resources that are not needed. To 
continue working on this project later, simply reload the custom gradient list. The same 
procedure applies for loading and saving lists of hatchings and bitmaps.
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3D Globe
This section describes how to create a threedimensional globe with Draw in just a few steps. 
When finished, rotate the finished Globe using the mouse.

Creating Texture on a 3D Object
Note: If only the globe shown here is needed, and creating a similar one is not on needed, use the finished globe 
from the Gallery in the 3D Effects theme. Drag the globe into the document.

To create a custom 3D globe, first open an empty draw document, insert a globe and then 
apply a world map as a texture to the globe (worldmap2.wmf from the StarOffice collection 
is a good choice but there are others available via the Internet). Then adjust the illumination.

1. Open an empty drawing document by choosing File > New> Drawing.

2. Open the 3D Objects floating toolbar  on the left of the Main toolbar.

3. Select Sphere from the toolbar, 
4. Drag open a area to create the globe. All 3D objects can be opened in this way. If creating 

an oblong shape is preferable, press the Shift key while dragging. This behaviour for 3D 
objects is opposite to the way other objects such as ellipses and rectangles behave.

5. Open the Gallery.  The Gallery themes appear as subdirectories.
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6. Locate the map to be used. If there is a Maps theme, click the it and the Gallery shows the 
maps.

7. Click any rectangular world map, say, worldmap2.wmf.
8. Hold down the Shift and Ctrl keys and drag the map of the world onto the sphere. 

This lays the map of the world on the sphere as a texture.
9. If the Gallery hides the globe, users can fix the Gallery window so that it no longer 

overlaps with the document. At the edge of the Gallery window click the Stick/Floating 
icon (looks like a thumb tack).

The texture is laid onto the sphere in its original size in the default setting. Since the map of 
the world is much larger than the sphere, only a small segment is seen as a green area on the 
sphere. This will soon be changed.
1. Click the sphere to select it.

2. Display the context menu for the sphere and choose Area. The Area dialogue appears 
with the Area tab page.

3. Select the Bitmap field, removing the mark in the Tile field.

4. Close the dialogue with OK.
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Now the world map can be seen as texture on the sphere. OpenOffice.org has automatically 
selected the most appropriate projection method. To see this, doubleclick on the sphere and 
then rotate it.

In Tools > Options >OpenOffice.org > View tab, check the appropriate box for 3D objects 
to refresh during interaction.

Using Illumination
Now one needs to provide illumination for the world globe. Select an overall blue 
illumination, for example, so that the oceans will have a blue colour, and a yellow highlight 
that will shine on the side of the earth facing the sun.
1. Select the world globe since the illumination preferences being set always refer to the 

currently selected object.

2. Open the 3D Effects window by clicking the 3D Controller icon  at the bottom of 
the main toolbar.

3. In the 3D Effects window, click the Illumination button.
a) Use this feature to change the default setting of the light source to “blue” and move it 

down and to the left. 

b) Click Assign. 
4. Repeat step 3 to apply a second light source in “yellow” to shine on the earth from the 

above right.

More 3d Effects
Take a look at the 3D Effects window. The individual tabs and icons are described in detail in 
Help. What follows is just a brief overview:

3D Effects: Favourites
This dialogue window offers a few special effects 
that can be used on the 3D object. To save 
interesting effects so that they are available for 
selection on this tab, file the appropriate 3D 
object in the Gallery, more specifically in the 3D 
theme folder.
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3D Effects: Geometry
By using this feature, the user can control the 
manner and quality of how the object surface is 
geometrically calculated and displayed. For 
example, interesting effects can be produced by 
deliberately reducing the number of segments of 
a sphere. Properties of the 3D font, such as the 
slant of the edge (bevel), depth, et cetera are 
determined here. 

3D Effects: Shading
This feature permits specifying the setting 
of the shader (flat, phong or 
Gouraud) to be used to display the 3D 
object. Gouraud provides the best 
shading, but requires the most computing 
time. Also use this feature to specify a 
shadow for the 3D object and to select the 
camera distance and focal length. 
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3D Effects: Illumination
Control of illumination of a selected 3D 
object is easily done in a variety of ways. 
In addition to the general ambient light, 
eight additional light sources are 
available, all of which can be aligned, 
adjusted for colour, or turned on and off 
individually. 

3D Effects: Textures and Material 
With these two sections, control the appearance of the surface of 3D objects. See Help for an 
explanation of the numerous possibilities. 
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Designing 3D Objects From Font Characters
The stepbystep methodology described below is particularly useful in preparing objects that 
could be used for logos and other identifiers. What follows is presented in tutorial form.

First Step:

1. Open an empty drawing document either using File > New> Drawing or the New icon on 
the Function toolbar.

2. Create a text box containing a single capital letter. In this procedure, the letter “P” is used.
3. Choose a character set for formatting. 
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4. Set the font size to about 400 pt. 
This font size is to provide a usably sized object that, when converted to 3D, the text takes 
up exactly the space that is drawn for the text, independent of the font size selected. 

5. Draw the text box using the Text icon on the floating toolbar. 

6. Select the letter and then manually enter 400 in the Size field on the text object bar. At this 
point, other attributes, such as another typeface or emphasis attribute, like bold, may be 
selected. 

Second Step:
Select the text field with the letter and choose Convert > To 3D on the Modify menu. 
Modify the colour of the object by selecting Area on the Format menu. Of course it is also 
possible to assign a gradient or a bitmap graphic to the object.
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Third Step: 
Select the letter “P” again so that it can then be modified in a different way. Click the 
Format/ 3D Effects menu item. The options available include options for setting the depth of 
the object and the focal length of the camera. In addition, the user can set the individual 
illumination and the texture model.
• The sample object was given its special shape by adjusting the camera to an extremely 

short focal length.
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Fourth Step:
Now add some text to the logo. Start by inserting a text box and populate it with name of the 
company and in a format that is suitable. To put a border around the text, convert the text to a 
polygon by choosing Modify > Convert > To Polygon. Of course, the surface of the newly 
created object can also be modified.
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• For a border around the company name, convert it into polygons. Then select a line width 
greater than 0.00 and a line style not equal to “transparent” on the object bar to make the 
borders of each letter visible.

Fifth Step:
Create a simple drawing object as a background for the logo, for example an ellipse. Choose 
Modify > Position to place the object all the way to the back.
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Now there is a perfect 3D logo created with OpenOffice.org in only five steps!

Note: that the user can also access the functions through the context menu instead of using menu commands, which 
makes for less work with the mouse.
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Using a Grid
To work with great precision, for example to place rectangles one on top of the other, use the 
grid function. To turn on the grid, choose Tools > Options > OpenOffice.org Draw > Grid 
and select the Snap to Grid option. As an additional aid, selecting Visible Grid makes it 
easy to place documents exactly on top of each other in the document.
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Mechanical or Construction Drawings
This section explains how to produce a mechanical drawing with OpenOffice.org. The same 
method can be used to create other similar drawings, such as, construction blueprint, garden 
layout et cetera.

OpenOffice.org User Guide for 2.x 356



Chapter 6: Creating Drawings with Draw

Creating a Construction Plan
To create a drawing like the preceding illustration, click the Rectangle icon and drag the 
floating toolbar into the work area. Then, select Curves and Lines and Arrows and drag 
these floating toolbars into the work area as well. Choose a tool with which to begin, such as 
the Rectangle, and use it to drag open an area to represent the first surface. Finally, draw in 
the details with the Line tool. 
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Add some more details.
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Complete the drawing.
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Using Snap Lines
It is advisable to use snap lines to position lines and objects more precisely. 
To display a snap line, click on a ruler and hold down the mouse button to drag it into the 
document. To move the snap line, rest the mouse pointer on it until a double arrow appears. 
Shift the line by holding down the mouse button and dragging the line to the desired position. 
To delete a snap line, simply drag it back onto the ruler. In Draw, snap lines can also be 
positioned in a numerically exact way using the Edit Snap Line... command from the 
context menu of the snap line.

Note: Snap lines are lines which are visible only on the screen and are used for the sole purpose of precise 
positioning and alignment. An unlimited number of horizontal and vertical snap lines can be created. 

Using Dimension Lines
With Draw, dimension lines can be directly inserted into a drawing. Drag the snap lines from 
the ruler into a document and positioned so that there is a snap line over every major line in 
the drawing. To do this, click the Dimension Line icon  on the Lines floating toolbar. 
The mouse pointer will turn into a cross and a dimension line may be dragged directly from 
one side to the other, or, even better, from one snap line to another. 
To edit the look of dimension lines, select them, open the context menu and click 
Dimensions.... The dialogue that appears, permits determination of the appearance and 
position of the dimension lines. 

To increase the space between a dimension line and the measured object, move the mouse 
pointer to one of the points on the dimension line. The mouse pointer will turn into another 
icon, enabling either expansion or reduction of the space. Note: To obtain an absolutely 
horizontal or vertical dimension line or one at a 45° angle, press the Shift key while 
dragging the dimension line. 
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Working With Multiple Layers
The next step is to position the details in the motor drawing. It is a good idea to use the layer 
function if testing several different variations. 

To get a better overview, turn on the Layer view, by pressing the symbol on the bottom 
left border of the work area. Alternatively, choose View > Layer (a check mark will appear 
in front of the command). To insert a new layer, open the dialogue Insert Layer. It can also 
be opened through the context menu of the tabs Layout, Controls and Dimension Lines 
arranged at the bottom of the screen. Enter a unique name, e.g. “Sketch1”. Repeat this 
procedure for another level and enter the name as “Sketch2”. 

Now click the Suggestion1 tab and place the details of this level; for example, by dragging 
the desired clipart from the Gallery into the document. 

After the details are positioned on Layer1, do the following:

1. click the Sketch2 tab and arrange elements there as well. Notice that the elements from 
Sketch1 are visible. 

2. To change this, click the Sketch1 tab and call up the context menu and select Modify 
Layer. 

3. In the Modify Layer dialogue, remove the check from the Visible check box

4. Click OK to view only the Layout level and the Sketch2 level. 

As a rule all layers will be displayed. To view a particular layer, deactivate the Visible field 
on all the other layers. 
After completing the drawing, save and/or print the document as needed. 

Note: Visualize layers as transparent sheets, one on top of the other, which together form a complete picture. It is  
also possible to view individual “transparencies”, i.e. Layers. 

Using One colour per Layer
If more than one layer at a time is displayed, apply an identical colour to all elements on the 
same layer for a better overview.
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Chapter 7: Databases and Data Sources
Versions of OpenOffice.org Base prior to 2.x required a connection to an external data 
source. While 2.x retains this functionality, it also introduces the ability to create an 
HSQLDB database as an internal data source. Now all the data tables, forms, queries and 
reports for a database can reside in one .ODB file.
This chapter introduces builtin HSQLDB databases and touches on some of the functionality 
still retained from earlier versions of Base. The examples found in this chapter are some of 
the steps used to create the Calendar example database.
The large amount of preparatory work done when one is actually designing a database is 
beyond the scope of this chapter. Briefly, the preparatory work for creating the Calendar 
database involved sketching out what the user wanted to see as the end result and working 
from there to design tables that would follow good database design theory or, failing that, at 
least be easy to implement and maintain.

Creating a database file
After the preparatory work, a file or container must be created to hold all the parts of the 
database.

If OpenOffice.org is already open, you can choose  File > New > Database. You can 
also open OpenOffice.org Base itself selecting the  program icon from the menu or by 
running sbase  from the commandline.

The Database Wizard opens to Step 1, Select database.

1. Make sure the option is set to Create New Database and click Next.
2. In Step 2, Save and proceed, you will want the option regarding registering the 

database (Do you want the wizard to register the database is OpenOffice.org?) set 
to Yes, register the database for me.

When you register a database, OpenOffice.org now knows where the data is 
located and how it is organized. In spreadsheets and text documents, you can use 
View > Data Source to connect to the data.

3. Under After the database file has been saved, what do you want to do? Make sure 
Open the database for editing is checked.

The Create tables using the table wizard check box opens the Table Wizard. 
The Table Wizard offers a set of sample tables from which fields, with 
corresponding types and formats, can be chosen to create a new table. Fields can 
be chosen from multiple tables to create the particular table. 

4. Click Finish.

5. In the Save As window that opens, name the database and select a location in which 
to store it. Leave the Save as type set to OpenDocument Database.
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6. Click Save.
An OpenOffice.org Base window will open for the new database. At this point, we have 
created an empty database file.

Creating a table
An empty database file is not much use. The next step is to create a table in which to store the 
data. In previous versions of OpenOffice.org Base, we would connect to an external data 
source such as Adabas, JDBC, ODBC, dBase, ADO, Text, Spreadsheet, or Address Book. We 
can still do this (as discussed below) but, as mentioned above, we can also create HSQL 
tables that will reside in the database file itself.
Each field in a table is represented in the design of that table by a row. Each row has fields 
for Field Name, Field Type and Description. Description is an optional field that can be 
used to provide a description of what the field is used for.

Additionally, each of the table fields have Field Properties. These vary based on the type of 
field.
The main table in our Calendar database is the Appointments table and the 
following steps explain how that table was created.

1. In the database window, click the Tables icon in the lefthand column. 

2. In the Tasks pane at the top of the window, click the Create Table in Design view 
icon. A Table Design window opens.

3. In the first row in the Table Design window, in the Field Name box, type ID and hit 
the Tab key on the keyboard.

4. In the Field Type box that the cursor jumps to, choose Integer [INTEGER].
5. In the Field Properties section at the bottom of the window, change the value for 

AutoValue to Yes.
6. Create the fields listed below by repeating steps 3 through 5 using the information in 

the table. Obviously, do not go back to the first row in the design window and do not 
set the AutoValue option on any other fields to Yes.

Field 
Name

Field Type Field Properties

Subject Text [VARCHAR] Entry Required = Yes; Length = 50 

Location Text [VARCHAR_ 
IGNORECASE]

Entry Required = No; Length = 50

Start date Date [DATE] Entry Required = Yes
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Start time Time [TIME] Entry Required = No

End date Date [DATE] Entry Required = No

End time Time [TIME] Entry Required = No

Note Memo 
[LONGVARCHAR]

Entry Required = No

Type Integer [INTEGER] AutoValue = No; Entry Required = No

7. Rightclick the field selector for the ID field (this is the area to the left of the field 
name) and choose Primary Key.

8. Click File > Save.

9. Enter Appointments for the Table Name and click OK.

10. Close the table design window by clicking File > Close.

11. In the database window, click File > Save to save the work done so far on the 
database.

Note: The type VARCHAR_IGNORECASE is a special type of VARCHAR specific to HSQLDB. It is caseinsensitive 
which means entries such as Home and HOME are the same. 

Note: Each field can only accept data corresponding to the specified field type. It is not possible to enter text, for  
example, in a number field. Memo fields in dBase III format are references to internallymanaged text files which 
can hold up to 64KB text. 

Creating a related table
The last field of the Appointments table is the Type field. Since we are trying to follow good 
database design procedures here, we want to put our appointment types in another table and 
link the tables using an ID field. The basic reason for this is because so many of our 
appointments are going to have the same type, we want to cut down on data entry errors and 
make it easier to update all the records if we decide to change the name of a type.
To create the Types table:

1. In the database window, click Create Table in Design View.
2. Create the table using steps 3 through 5 in the previous example and the information 

below.

Field 
Name

Field Type Field Properties

ID Integer [INTEGER] AutoValue = Yes
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TypeName Text [VARCHAR] Entry Required = Yes; Length = 50

3. Rightclick the field selector for the ID field and choose Primary Key.

4. Click File > Save As.

5. Enter Types for the table name and click OK.

6. Close the table design window by clicking File > Close.

7. Click File > Save in the database window to save your work.

Creating a relationship between tables
Now, to make the Types table more useful to us, we need to create a relationship between the 
two tables. A relationship means that two or more tables share information. They link a 
primary key to a foreign key. A primary key is unique. In the Calendar database, the primary 
key for the relationship we set up in the follow steps is the ID field in the Types table. The 
foreign key is the Type field in the Appointments table.

1. Click Tools > Relationships. The Relation design window is displayed with the Add 
Tables dialog in front of it.

2. Click the Appointments table in the list and click Add.

3. Click the Types table and click Add. Both tables should appear in the Relation 
design window.

4. Click Close in the Add Tables dialog.

5. In the Relation design window, click the lower edge of the Appointments table and 
drag down to make the window for the table larger.

6. Click the Type entry in the Appointments table and drag it over the ID entry in the 
Types table. A line will connect the two entries.

7. Click File > Save to save your work.

8. Close the Relation design window.
9. Save the database.

At this point in the creation of the sample database, a form was created to simplify data entry 
into the Types table. For the sake of brevity, these steps are skipped. Data may be directly 
entered into a table, though it is not recommended.

Creating a data entry form
However, the following are steps for creating the data entry form for new appointments are 
presented here.
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1. In the database window, click the Forms icon on the left side. 

2. Click the Use Wizard to Create Form button.

3. The Form Wizard opens to Step 1, Field Selection. Click the Tables or queries 
dropdown and choose Table: Appointments.

4. Move all the fields except ID to the Fields in the form list by clicking the > button 
for each desired field.. Click Next.

5. Step 2, Set up a subform, is not needed for this form since we will not be including a 
subform. Simply click Next.

Note: A subform allows the user of a database to access related data. For example, if multiple types were allowed 
per appointment, they might be displayed in a subform.

6. The wizard automatically skips steps 3 and 4 since they are related to subforms.

7. Step 5, Arrange controls, allows the designer to choose a rough, basic layout for the 
form controls. This choice is open to preference but in creating the sample database, 
we chose In Blocks – Labels Above, the fourth option. Click Next.

8. Step 6, Set data entry, is where the designer of the database can narrow the use of a 
form. In this example, this is a new appointment form so we only want user to be able 
to enter data. Set the option here to The form is to be used for entering new data 
only. Existing data will not be displayed. Click Next.

9. Step 7, Apply styles, is also open to personal preference. The Flat field border style 
does have some nice builtin visual effects and was chosen for the example database. 
We also chose Ice Blue as the style. Click Next after selecting the options.

10. Step 8, Set name, allows us to name the form. Enter New Appointment for the 
name.

11. Set the option to Modify the form and click Finish.
12. The form opens to edit mode, as opposed to data entry mode. Now the form can be 

modified.

Making data entry easier
The easiest thing to do to simplify data entry is to move the fields around. This can be done 
by clicking and dragging the fields while the form is in edit mode. The following sections 
detail other ways to simplify data entry. These example steps assume that the New 
Appointment form is open in edit mode.

Modifying a date field
A text box that is related to a date field can very easily be turned in to a date picker control.

1. Click once on the Start Date field.

2. Rightclick the field and choose Group > Edit Group.
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3. If the text box itself is not selected, click away from the text box.

4. Doubleclick the text box for the Start Date field, not the label.

5. The Properties: Date Field dialog box opens. 

6. On the General tab, make sure the following options are set:

○ Dropdown should be set to Yes.

○ Repeat should be set to Yes.
7. Repeat steps 1 through 6 for the following:

○ End Date Dropdown: Yes; Repeat: Yes
○ Start Time Default Time: 9:00:00; Spin Button: Yes; Repeat: Yes.

○ End Time Default Time: 9:30:00; Spin Button: Yes; Repeat: Yes.

8. Close the Properties dialog box.

9. Click File > Save to save our modifications to the form.
For the time fields, we made them easier to use by giving them a default time other than 
midnight. Additionally, the spin button may be used instead of keyboard entry.

Adding a list box to a form
If the database has a related field, such as the Calendar database's Type field, that will have a 
finite, usually fairly short, list of entries, it may simplify data entry to create a list box to 
replace the text box on a form. With a list box, we choose one value and actually add a 
related value to the table.

1. In the Form Controls toolbar, usually at the bottom of the screen, click the List 
Box button.

2. Click and drag in an empty area of the form to create a box about the size of the Type 
field that is already on the form.

3. The List Box wizard opens.

4. On the first screen, Table Selection, click Types. This is the table that contains the 
data for the list box.

5. Click Next.
6. On the second screen, Field Selection, click TypeName. This is the field containing 

the display text for the list box entries.

7. Click Next.
8. On the third screen, Field Link, in the Field from the Value Table list click Type 

and in the Field from the List Table list click ID.  This creates the link between the 
key value that underlies the displayed value and the field that the value is written to.

9. Click Finish.
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The new form control might have a different look than the other controls on the form. In the 
Calendar database, we had to do the following:

1. Doubleclick the list box to bring up the Properties dialog box.

2. Set the Border color property to Black.

3. Click the ellipsis (three dots (...)) button that is to the right of the Background color 
property field.

4. In the Color dialog box, set the Red, Green and Blue values each to 221. Click OK. 

5. Close the Properties dialog.
Field background colors may be matched by checking the background color values of the 
other fields on the form.

Now, however, the form seems to have two Type fields and one Type label.

1. Click the Type field that was created by the wizard.

2. Rightclick the field and choose Group > Edit Group.
3. If the text box itself is not selected, click away from the textbox then back on it to 

select just the field, not the label.

4. Delete the field by pressing the Delete key on the keyboard.

5. Move the Type list box to where the text field was so that the list box replaces it.
6. Select both the list box and the label (click one, hold down the shift key and click the 

other).

7. Rightclick the selection and choose Group > Group.

Adding a combo box to a form
Another way to make data entry easier is to add a combo box to a form. The combo box, 
unlike the list box, can only display the value it is adding to the field. That is, when choosing 
from a list box, an identifier (such as a number) is put into the related field whereas with a 
combo box the actual value of the combo box is put into the field.

The Location field is a good candidate for a combo box. While editing the New Appointment 
form:

1. On the Form Controls toolbar, usually at the bottom of the screen, click the 
Combo Box button.

2. Click and drag a combo box in an empty area of the form. The Combo Box wizard 
will open.

3. On the first screen, Table Selection, click Appointments.

4. Click Next.
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5. On the second screen, Database Field, set the option to Yes, I want to save it in the 
following database field: and choose Location from the dropdown list.

6. Click Finish.
The look of this field should also be made consistent.

1. Doubleclick the combo box to bring up the Properties dialog box.

2. Set the Border color property to Black.

3. Click the ellipsis button (to the right of the Background color property).

4. In the Color dialog box, set the Red, Green and Blue values to 221 (assuming that 
the same color scheme is being used).

5. Close the Properties dialog.

6. Move the combo box so that it matches up with the Location label.

Changing the tab order of a form
The tab order of the form we have been creating and modifying through these steps probably 
does not make sense because we added some form controls and may have moved others. To 
change the tab order of a form:

1. Click on any control on the form.

2. Click the Activation Order button on the Form Design toolbar.
3. Set the order as follows:

1. txtSubject
2. ComboBox
3. datStart date
4. timStart time
5. datEnd date
6. timEnd time
7. ListBox
8. txtNote

This can be accomplished by clicking a control name in the list and using the Move Up and 
Move Down buttons to change the order of the controls.

ComboBox is the default name provided for the Location combo box and ListBox is the 
name provided for the Type list box.
Obviously this order assumes the form is set up similarly to the form in the Calendar 
database. If it is not, use a different order for the fields.
Remember to save the form and, after it is closed, save the database container.
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Viewing Data
The database still does not have a convenient way to view the appointments it stores. We 
could look at the table itself but this is neither attractive presentation nor good database 
design. Additionally, because the New Appointment form is a data entry form, we cannot use 
it to view previously entered records.
Since a lot of time and effort was put in to creating the New Appointment form and its format 
is also good for viewing data, the following sections will discuss copying a form and 
changing some of the properties of the new form.

 Copying the form
1. In the Forms section of the database, rightclick the New Appointment form.

2. Click Copy.

3. Rightclick in the database window and choose Paste.

4. In the dialog box that appears, enter All Appointments for the form name and click 
OK.

5. Save the database.

Changing the form's properties
Obviously, since the New Appointment form was a dataentry only form, we will need to 
change the related form property.

1. Rightclick the All  Appointments form and choose Edit.
2. Click the Form Navigator  button on the Form Design toolbar. This toolbar is 

generally found at the bottom of the OpenOffice.org Writer window. (Writer is the 
application used to edit forms in OpenOffice.org.)

3. In the Form Navigator dialog, rightclick the Main Form item and choose 
Properties.

4. On the Data tab of the Properties dialog, set the Add data only property to No.

5. Close the Properties dialog.

6. Close the Form Navigator.
7. Save the form.

8. Click the Design Mode On/Off button on the Form Design toolbar.
You can now use the Form Navigation toolbar to navigate through the records in the 
database.

Setting a sort order for a form
The records are currently in the order in which they were added to the database. This, in the 
long run, is not very useful. Adding a sort order to the form will make it more useful for 
viewing all the appointments in the database.
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1. Reenter form design mode by clicking the Design Mode On/Off button again.
2. Click any control on the form.

3. Click the Form button on the Form Controls toolbar.

4. In the Form Properties dialog, on the Data tab, click the ellipsis button to the right 
of the Sort property.

5. For the first field name, choose Start Date and leave the Order as ascending.

6. For the second field name, choose Start Time. Leave the Order as ascending.

7. The third field name should be set to End Date. Leave the Order as ascending.

8. Click OK in the Sort dialog box.

9. Close the Form Properties dialog, save the form and close it.
10. Save the database.

Creating a query to find today's appointments
Queries extract information from a database. A list of today's appointments would be a useful 
query.
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1. Click the Queries icon on the left side of the database window.

2. Click Create Query in Design View.

3. The Add Tables window opens in front of the Query Design window. Add both 
tables to the query.

4. Click Close in the Add Tables window.

5. Add the following fields from the Appointments table: Subject, Location, Start 
date, Start time, End date, End time, Notes.

6. Add the TypeName field from the Types table.

7. In the Start date column, on the Criterion  row, enter any date such as 
3/9/1972 .

8. Click the Switch Design View On/Off button. The SQL statement that underlies the 
query is now visible. Toward the end of the statement something like the following 
appears: AND (("Appointments"."Start date" = {D '197203
09'})). This statement finds records where the Start date equals the date 3/9/1972.

9. Replace {D '19720309'} with the text CURRENT_DATE and click the Switch 
Design View On/Off button again.

10. Click the Run Query  button. The query results appear at the top of the resulting 
window.

11. Save the query as Appointments for Today and close the query.
If the database does not contain appointments for today, add an appointment for today and 
rerun the query by doubleclicking on it.

Add a sort order to the query
There will be days with more than one appointment. In that case, it would be useful to sort 
the results of the query.

1. Open the query for editing by rightclicking the icon for the query and choosing Edit.
2. To add a sort order to a column, click in the Sort row in that column. The Sort row is 

just below the Table row. Click the Sort row in the Start time column.

3. Click the dropdown for Sort and choose Ascending.

4. Set the Sort to Ascending for the End date and End time fields as well.
5. Save the query.

If the database contains appointments for the current day, try running the query.

Changing the Join type in the query
When the query is run, as it exists currently, some appointments won't appear.
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The default type of join is an Inner join, which only returns records where the joined fields 
are equal. If the Type field for an appointment does not contain data, the join field for that 
appointment's record would not match any entries in the join field in the Types table.
We can fix this by changing the join type in the query.

1. Rightclick the join line between the tables in the top portion fo the query design.

2. Choose Edit.
3. In the Join Properties dialog, in the Options section, click the Type dropdown and 

choose Left join.

4. Click OK.
5. Save the query.
6. Close the query.
7. Save the database.

Creating a report
A query can, of course, be viewed and used by doubleclicking to execute the query. It can 
also be used as the underlying data for a form. The form wizard has already been discussed. 
Copying a form and changing the underlying data has also been discussed.
A query or a table can also be used to generate a report. The following section uses the 
Appointments for Today query created in the steps above as the basis for a  report.

1. Click the Reports icon on the left side of the database window.

2. Click Use Wizard to Create Report. 
3. The Report Wizard opens to Step 1, Field Selection. Change the Tables or queries 

dropdown to Query: Appointments for Today.

4. Click the >> button to move all the fields from the Available fields list to the Fields 
in the report list.

5. Click Next.
6. In Step 2, Labeling fields, click Next to use the default labels.

7. Step 3, Grouping, can also be skipped since this report does not really need 
grouping. Click Next without moving any fields.

Note: Grouping is a way of collecting records that share certain data. For example, we could create another report  
grouped by Type. This report would list all of the appointments of each type together. Grouping creates the first  
levels of sorting in any report with grouping.

8. Step 4, Sort options, is automatically skipped because a query is selected. This may 
be changed in later versions.
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9. In Step 5, Choose layout, Align Left – Modern was chosen for the Layout of data 
and Generic for Layout of headers and footers. Click Next when this step is 
complete.

10. In Step 6, Create report, leave Title of Report as Appointments for Today. This 
report is a Dynamic report so leave that option set. The option to Create report now 
should also be set.

11. Click Finish.
The report is generated and will appear after a few moments. The report will need to be 
modified to be more attractive and useful. Since the report is simply a Writer document and 
the data itself resides in a table, modifying the report is not covered here.
However, to open a report for modification:

● In the Reports section of the database, rightclick the report and choose Edit.

Some tips for using the Calendar database
The following tips, while specific to the Calendar sample database, can be generalized to 
other Base databases.

Adding data to a related table
Occasionally a user of the Calendar database may wish to add an appointment type while 
working in an appointment form. While the types appear on the form, the actual type names 
reside in a separate table and the new type must be added to that table. There are at least two 
ways to accomplish this, by opening the form for the related table (assuming there is one) or 
by opening the Data Sources window.

Open the form for the related table
If the related table has its own form, as it does in the case of the Calendar database:

1. Switch to the database window.
2. Open the form, in this case the Types form.
3. Add the data to the form.

4. Be sure to click the Save Record button. 
5. Close the form.

Open the Data Sources window
The following steps may be used if the related table does not have a form. On an 
appointment form:

1. Choose View > Data Sources or press the F4 key on the keyboard.

2. This opens the Data Sources pane at the top of the form window. Make sure 
Calendar, the database, is expanded.
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3. Expand the Tables icon by clicking the plus sign next to it.

4. Click the icon for the Types table.

5. Enter a TypeName.

6. Click the Save Current Record button at the top left of the Data Sources pane. 

7. Close the Data Sources pane by choosing View > Data Sources or pressing the F4 
key.

Refreshing the form
Once a new type is added, the Types list box must be updated by clicking the Refresh button 
at the bottom of the form. 
The dropdown should contain the new type.

Filtering Data
If one wishes to see only a certain day's appointments it is possible to create a query that only 
returns that particular day. However, it is also possible (and easier) to use the All 
Appointments form and filter for a particular day.
One way to filter data is as follows:

1. Go to a record for the particular day.

2. Click in the Start Date field.

3. Click the AutoFilter  button on the Form Navigation toolbar (usually at the 
bottom of the screen).

The form is filtered based on the record chosen in step 1.
A second way to filter data:

1. Click the FormBased Filters  button, also on the Form Navigation toolbar.
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2. The Form Filter toolbar opens, as does a blank copy of the form. Enter a date in the 
Start Date field.

3. Click the Apply FormBased Filter button. 
The form is now filtered based on the data entered.

A filter can be removed by clicking the Remove Filter/Sort button. 
Please see the section “Searching With a Form Filter” below for further information.

Note: The rest of this chapter, though originally written for versions prior to OpenOffice.org 2.x, has been verified 
and updated.

Registering a Data Source
When creating a database, OpenOffice.org allows the creator to register the database with the 
currently running copy of OpenOffice.org To register a data source for viewing and/or editing 
in OpenOffice.org at a later time (or after copying the database to a new computer):

1. Select Tools > Options. This command opens the Options dialog. 

2. In the category list at the left of the dialog, expand OpenOffice.org Base then click 
Databases. 

3. Click New. The Create Database Link dialog opens.

4. Click Browse. The Open dialog is displayed.

5. Navigate to the location of the database, select the database and click Open.

6. If desired, change the Registered name of the database.

7. Click OK. The Create Database Link dialog closes.

8. Click OK. The Options dialog closes.

Connecting to other types of databases
The Database Wizard also allows one to link to other types of data sources rather than 
creating a new database. 

NOTE for 2.0 dBase users: To open a connection to a dBase database, one must select the "Connect to an existing 
database" radio button and choose "dBase" from the dropdown list box. This should work even if one  never had 
any dBase installed on the computer, because a basic dBase functionality is built in to %PRODUCTNAME. 
However, the controls should be renamed to give a better understanding. I would suggest "Connect to or open 
another data source", and rename the first control to "Create a new HSQLDB database". Changed this issue to be 
an enhancement request for an UI change in the dialog. 

To create a database that links to external data source:

1. In any OpenOffice.org window, click File > New > Database.

2. Set the What do you want to do? option to Connect to an existing database.
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3. Select the appropriate type from the dropdown. The various types are briefly 
discussed in the table below.

4. Refer to Help > OpenOffice.org Help for information on registering particular 
database types. Check the Index for Database Wizard.

Select from the following database types (depending on the operating system):

Database type Meaning
Adabas A slightly scaleddown version of the wellknown relational database 

system. Adabas is installed with its own setup program. (See 
http://www.softwareag.com/adabasd/)

JDBC Link to databases contacted via a JDBC driver.
ODBC Link to databases contacted via an ODBC driver.
dBase Files can be edited directly with the driver for direct access in the file 

system.
ADO Link to databases contacted via the ADO driver.
Text Register text files, such as commaseparated CSV files (readonly).
Spreadsheet One can register OpenOffice.org Calc and MS Excel spreadsheets (read

only).
Address Book This address book driver allows the user to register the system address 

book or another address book source (readonly). It also ensures that data 
fields are correctly assigned to the templates provided with 
OpenOffice.org, in form letters, for example.

Address Books
Registering an Address Book
As seen in the table above, an OpenOffice.org database can connect to an external address 
book. Available address books include Mozilla, Thunderbird, LDAP and certain operating 
system address books.
OpenOffice.org templates and Wizards, such as the letter and mail merge wizards, use fields 
that can represent the contents of an address book. When the document is connected to the 
data source, the general fields used in the templates are replaced by the actual fields from the 
data source.
While an actual Base database allows more flexibility, the data is still read only. Because of 
this, OpenOffice.org allows one to register address books as data sources.

Using the Wizard to import an Address Book 
Select File > Wizards > Address Data Source. This Wizard is described in Help. 

Manually Registering an Existing Address Book 
1. Choose File > Templates > Address Book Source. The Templates: Address Book 

Assignment dialog appears. 

OpenOffice.org User Guide for 2.x 379



Chapter 7: Databases and Data Sources

2. In the Data source box, select the system address book or the data source to use as the 
address book. 
If the system address book is not yet registered in OpenOffice.org as a data source, click 
the Administrate button. This opens the Address Book Data Source Wizard, in which 
the address book can be registered as a new OpenOffice.org data source. Read further how 
to do this in the next section, System address book as data source. 

3. In the Table box, select the database table to use as the address book. 

4. Under Field assignment, set the fields for company, department, first name, et cetera to 
the actual field names used in the address book. 

5. Click OK. After this point, the address book is recognized as an OpenOffice.org address 
book data source. 

System Address Book as Data Source
1. Select File > Templates > Address Book Source.
2. Click the Administrate button to call the Address Book Data Source Wizard (see also 

instructions above). 

3. Select the type of external address book and click Next. 
4. Data sources vary at this point. Additional settings may need to be chosen. Some address 

books have multiple tables, only one of which can be used per data source. Click Next 
after completing this step.

5. In the Data Source Name step, choose a location in which to save the database and a 
name for OpenOffice.org to use as the name for the data source.

6. Click Finish.

Importing Data Into OpenOffice.org
If one is exchanging data with a database that does not have an ODBC link and which does 
not allow dBase import and export, it is often possible to exchange the data via a common 
text format.

Importing and Exporting Data in Text Format
To exchange data in a text format use the Calc import/export filter. 

1. Export the desired data from the source database in a text format. The CSV text 
format is highly recommended since it separates data fields by using commas and 
records by inserting line breaks. 

2. Open the data with the Text CSV file filter. Select this file filter in the Open dialog 
in the Files of type list box. Select the file and click Open. 

3.  This displays the Text Import dialog. Here users can decide which data to include 
from the text document. 
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Once the data is in a Calc spreadsheet, it can be edited as desired. Users have two ways of 
saving the data as an OpenOffice.org data source: 
• Save the current OpenOffice.org Calc spreadsheet in dBase format in the folder of a dBase 

database. To do this, choose File > Save As, then select the File Type dBase and the 
folder of the dBase database. 

• Check the data range in the OpenOffice.org Calc spreadsheet and drag the area into a table 
container in the data source view. The table container is the area on the left of the database 
explorer that is designated Tables (see diagram). A wizard is started automatically. 

Exporting in CSV Text Format
The current Calc spreadsheet can be exported in a text format which can be read by many 
other applications.

1. Choose File > Save as.

2. In Save as type select the filter Text CSV. 
3. Enter a file name.

4. Click Save.
5. A dialog warning the document may contain formatting or content that is incompatible 

with the CSV format is displayed. Click Yes to save the file in CSV format.

6. This opens the Export of text files dialog, in which to select the character set, field 
delimiter and text delimiter. 

7. Click OK. A warning informs users that only the active sheet was saved.
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Form Design

Forms in OpenOffice.org
In some situations, a user may want to create a document that contains some fixed text, but 
allows others to enter some items and perhaps take some actions on those items. Such a 
document is called a form, analogous to the preprinted forms everyone has filled out dozens 
of times. One can create custom forms in most of the OpenOffice.org applications; forms that 
one creates without using the Form Wizard do not have to connect to a data source (though 
they can  see below). If the form isn't connected to a data source, any information the user 
enters is simply saved with the form. (This method is handy when sending a form to a group 
of people for them to fill out and return.) Writer, Calc, Impress, and Draw all support forms.

To create a form, start with a document in the appropriate application. Click View > 
Toolbars > Form Controls. (In some cases, one may have to add the button to the toolbar 
first.) The Form Controls toolbar (Figure 1.) appears. The toolbar includes an assortment of 
controls that can be put on  forms, as well as buttons for managing the form as a whole.

As with the other toolbars , docking it is an option. When designing a form involving a 
number of controls, this can be a very handy feature.
Most items on the Form Controls toolbar are controls. Others are a variety of options for 
working with forms and controls. Most of them are discussed later in this article.
To add a control to a form, click it on the Form Controls toolbar. The cursor changes to 
crosshairs. Click and drag the new control to the location desired.
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Once a control is chosen from the Form Controls toolbar, continue dropping that type of 
control. To turn off that control type, either click another control to select it, click the form 
itself without dragging, click the same control on the Form Controls toolbar, or click the 
Select button on the Form Controls toolbar.

Available controls
OpenOffice.org offers a wide variety of controls from the general to the specific. Table 1 lists 
them.

Control Use
Check Box Used for on/off or yes/no choices.
Text Box Used to enter freeform text.
Formatted Field Used to enter text applying formatting codes as in Calc.
Push Button Used to execute commands.
Option Button Used, with one or more other option buttons, to allow choice among 

mutually exclusive options. See Group Box.
List Box Offers a list of choices. User can choose one or, in some cases, several.
Combo Box Offers a list of choices. User can choose one or enter a new value.
Label Field Used to provide labels for other controls. Doesn't accept input.
Spin Button Used to increment and decrement the displayed numeric value by clicking 

with the mouse.
Scroll Bar Provides navigation through the content by scrolling horizontally or 

vertically.
Image Button Used to execute commands; has a picture rather than a text caption.
Image Control Displays a picture on the form.
Date Field Used to enter a date. Supports up arrow and down arrow to change portions 

of the date.
Time Field Used to enter a time. Supports up arrow and down arrow to change portions 

of the time.
File Selection Allows user to point to a file.
Numerical Field Used to enter numbers. Optionally has spinner arrows to change value with 

the mouse.
Currency Field Used to enter monetary values. Supports up arrow and down arrow to change 

value. Optionally has spinner arrows to change value with the mouse.
Pattern Field Used to enter text, applying a specific formatting pattern.
Group Box Used to visually combine several controls, as well as create groups of option 

buttons.
Table Control Used to display data from a table or query in a grid format.
Navigation Bar Reproduces most of the Form Navigation toolbar on the form itself

Table 1. The selection of controls available for use in forms is extensive. Controls are shown here in the order in 
which they appear on the Form Controls and More Controls toolbars. 
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Customizing controls
With some controls, one can simply drop them on a form and use them as is. That works for 
things like a Text Box, Date Field, or Time Field. With others, though, once the control is 
added, one may  need to provide additional information. Even for those that work 
immediately, a user may  customize their appearance or behavior.
To set up a control, click it to select it (sizing handles appear around the edges), and then 
choose Control from the shortcut menu, Format > Control from the menu, or Control 
from the Form Controls toolbar. The Properties dialog for the control appears. The 
contents of the Properties dialog vary, depending on the type of control.

Just as the contents of the Properties dialog vary with the type of control, so does what one 
needs to do to get it working. Table 2 lists some of the items common to a number of 
controls.

Table 2. The Properties dialogs for the various controls lets one set them up as  wanted. The properties shown 
here are common to a number of the controls.

Property Meaning
Name Identifies the control. In some cases, including option buttons, assigning the 

same name to several controls turns them into a group.
Label The caption that appears on the control.
Label field Links the control to a Label Field control. Used for controls (like Text Boxes) 

that don't have their own label.
Enabled Determines whether the control is available to the user.
Tabstop Determines whether the control is part of the tab order, that is, whether the user 

can reach it by tabbing from one control to the next.
Order Determines the position of the control in the tab order.
Character set Specifies the font characteristics for the control.
Default value Specifies the initial value displayed in the control.
Background 
color

Specifies the background color for the control.

Help text Specifies the tooltip for the control.

Individual controls have additional properties related to their purpose. For example, a Check 
Box has a Default Status property that determines whether it's initially checked and a Text 
Box has a MultiLine input property that determines whether one can put multiple lines of text 
into the control.
Some controls need certain properties specified in order to be useful. In some cases, wizards 
are available to help the user specify the necessary information. The next few sections 
consider some of those controls.
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Creating a group of option buttons
Option buttons (also known as radio buttons) let users choose one item from among a 
mutually exclusive group.
The easiest way to set up a group of option buttons is:

1. Make sure the Wizards On/Off button on the Form Controls toolbar is on. 
(When it's on, it has a thin border around it.)

2. Put a group box on the form by click the Group Box button on the More 
Controls toolbar and then clicking and dragging in the form. The Group 
Element Wizard – Data appears to guide creation of an option group.

3. On the first page, specify the options to appear in the group. For each, type it in, and 
then press Enter or click the >> button. When all the items have been entered, click 
Next.

4. On the second page, indicate which item in the list should be initially selected. Users 
can also specify no item be selected. Click Next. 

5. On the third page one can associate a value with each item. Specifying a value is 
particularly significant when data on the form is tied to a data source. (See 
"Activating form controls in a document" below.) To specify the value for an item, 
click that item in the list, and then type the appropriate value in the text box. By 
default, character items are associated with numbers starting from 1. Click Next to 
move to the Database Field page.

6. The Database Field page lets one automatically save the user's choice to a field in a 
table. If  preferred, users can specify that the value is available only in the form. Click 
Next to reach the final page of the wizard. 

7. On this page, one specifies a name for the option groupthe name appears as a caption 
on the surrounding box. Click Finish to exit the wizard and create the option group.

Do any other controls have an wizard?
Most of the remaining controls are simple enough to configure that no wizard is needed or 
provided. However, the Table control is fairly complex. It provides a grid type display of the 
data in a table, along with navigation controls. The Table Element wizard lets one choose 
which fields display and in what order.

Attaching a data source to a form
Using the wizards for some kinds of controls requires the user to specify a data source for the 
form. However, sometimes, one may want to do so even if one is not creating a combo box 
or list box.
To link a data source to a form:

1. In the database window, rightclick the form and choose Edit to enter Design mode.

2. Click the Form Navigator button on the Form Design toolbar.

OpenOffice.org User Guide for 2.x 385



Chapter 7: Databases and Data Sources

3. In the Form Navigator dialog, rightclick the Main Form item and choose 
Properties.

4. Click the Data tab.

5. Make sure the Content Type is set correctly (Table, Query, SQL command).

6. Choose appropriate table or query from the Content dropdown or click the builder 
button (the ellipsis button) to create an SQL command. 

Associating data with a field
Once the form has a data source, one can link fields to controls. To do so:

1. Add the control to the form or click once to activate an existing control.

2. Ungroup the control by rightclicking and choosing Group > Edit Group.
3. Deselect the ungrouped controls.

4. Rightclick the data control, not the label, and choose Properties.

5. Click the Data tab.

6. Choose a field from the Data Field dropdown.

7. Close the Properties dialog box.
8. Regroup the control by selecting the control and the label then rightclicking and 

choosing Group > Group.
Be aware that when  linking a field to a control in this way, every time  that control is used, 
changes that are made are stored in the actual data source.

Activating form controls in a document
While editing a data source is one use for forms, users may want to use a form for other 
things. For example, to add a button to a spreadsheet that performs a calculation or to a 
presentation that runs a video clip.
Each control has a number of events associated with it. An event is something that occurs 
due to user action. For example, when the mouse is moved, an event fires each time it enters 
the area of a control and each time it leaves that control's area. Typing a character also fires 
an event. So does clicking the mouse.

The Events tab of the Properties dialog for each control lists the events available for that 
control. For each event, one can specify what happens when that event fires. Do so by 
clicking the ellipsis button next to the event, and then pointing to the OpenOffice.org macro 
that performs the desired action.
The form itself has events, as well. To access these:

1. When editing the form, click the Form Navigator button on the Form Design 
toolbar.
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2. In the Form Navigator dialog, rightclick the Main Form item and choose 
Properties.

3. Click the Events tab.
As with control events, a user can assign a macro to any form event.

How to use the form
Once one finishes laying out a form, it can be "run"  by clicking the Design Mode On/Off 
button on the Form Design toolbar. When design mode is off, the controls operate as 
expected – the user can select and clear check boxes, open combo boxes and dropdown lists, 
and so forth.
Ordinarily, when one opens a saved form, design mode is automatically turned off. So, a user 
opening a form the designer supplies, sees it as they would expect. (Be aware, however, that 
a user can turn design mode on and change the form.) 

When a form linked to a data source has design mode turned off, the Form Navigation 
toolbar appears at the bottom of the form.
OpenOffice.org doesn't have a mechanism to prevent users from changing forms to Design 
mode. In Microsoft Office, you can protect a form document and give it a password to 
prevent users from seeing inside.
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Searching in Tables and Form Documents 
In  spreadsheets and documents in which form functions are used, one can click 
the Find  Record icon to open a dialog to find any text and values. Use the icon on 
the Form  Navigation toolbar, not the similar looking icon on OpenOffice.org's 
Standard toolbar. 
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There are various search options, including searching in one field rather than all fields, 
position of the value with in the field, which direction to search in the database, etc.

The ? and * wildcards can also be used, as in the Find and Replace dialog. Additional 
information about the database search function can be found in Help. 

Searching With a Form Filter 
To search with a form filter:

1. Open a form. 

2. Click the FormBased Filters button, on the Form Navigation toolbar.

3. The Form Filter toolbar opens. Enter a value in the appropriate field.

4. Click the Apply FormBased Filter button.
5. The form is now filtered based on the data entered.

A filter can be removed by clicking the Remove Filter/Sort button.
When formulating filter conditions, various operators and commands are available. Apart 
from the relational operators there are SQLspecific commands that query the content of 
database fields. If these commands are used, in the OpenOffice.org syntax, OpenOffice.org 
automatically converts these into the corresponding SQL syntax. SQL commands can also be 
entered directly. The following tables give an overview of the operators and commands: 

Operators

Operator Meaning Condition is satisfied if...
= equal to ... the content of the field is identical to the indicated 

expression. The operator = will not be displayed in the 
query fields. If a value without any operator is entered, 
the operator = will be automatically adopted.

<> not equal to ... the content of the field does not correspond to the 
specified expression.

> greater than ... the content of the field is greater than the specified 
expression.

< less than ... the content of the field is less than the specified 
expression.

>= greater than or 
equal to

... the content of the field is greater than or equal to the 
specified expression.

<= less than or 
equal to

... the content of the field is less than or equal to the 
specified expression.
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Commands 

OpenOffice.org 
command

SQL 
command

Meaning Condition is satisfied if...

IS EMPTY IS NULL is null ... The field is empty. For Yes/No 
fields with three states, this command 
automatically queries the 
undetermined state (neither Yes nor 
No).

IS NOT EMPTY IS NOT NULL is not empty ... the field is not empty.
LIKE (placeholder * 
for any number of 
characters 
placeholder ? for 
exactly one character)

LIKE (% 
placeholder for 
any number of 
characters 
Placeholder _ for 
exactly one 
character)

is an element of ... the data field contains the indicated 
expression. The (*) placeholder 
indicates whether the expression x 
occurs at the beginning of (x*), at the 
end of (*x) or inside the field content 
(*x*).Either the SQL % character or 
the familiar (*) file system 
placeholder can be entered as a 
placeholder in SQL queries in the 
$[officename] interface. The * or % 
placeholder stands for any number of 
characters. The question mark (?) in 
the $[officename] interface or the 
underscore (_) in SQL queries is used 
to represent exactly one character.

NOT LIKE NOT LIKE Is not an element 
of

... the field does not contain the 
specified expression.

BETWEEN x AND y BETWEEN x 
AND y

falls within the 
interval [x,y]

... the field contains a value that lies 
between the two values x and y.

NOT BETWEEN x 
AND y

NOT BETWEEN 
x AND y

Does not fall 
within the 
interval [x,y]

... the field contains a value that does 
not lie between the two values x and y.

IN (a; b; c...) Note that 
the semicolons are used 
as separators in all 
value lists!

IN (a, b, c...)  contains a, b, c... ... the field contains one of the 
specified expressions a, b, c,... Any 
number of expressions can be 
specified, and the result of the query is 
determined by an Or link. The 
expressions a, b, c... can be either 
numbers or characters

NOT IN (a; b; c...) NOT IN (a, b, c...) does not contain 
a, b, c...

... the field does not contain one of the 
specified expressions a, b, c,...

= TRUE = TRUE has the value 
True

... the field has the value True.

= FALSE = FALSE has the value 
false

... the field has the value false.

Examples of Usage
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Command/Operator Result
='Ms.' returns records with the field content “Ms.”
LIKE 'g?ve' returns records with field contents such as “give” and “gave”
LIKE 'S*' returns records with field contents such as “Sun” or “Stop”.
BETWEEN 10 AND 20 returns records with field contents between the values 10 and 20. 

(The fields can be either text fields or number fields).
IN(1; 3; 5; 7) returns records with the values 1, 3, 5, 7. 
NOT IN ('Smith') returns records that do not contain “Smith”.

In the form view, click the Apply Filter icon to change to the filtered view. 

The filters that have been set can be removed by clicking on the icon 
Remove Filter/Sort. 

If several filter conditions are to be connected with OR, click the Filter 
Navigation icon on the Form Filter toolbar. The Filter Navigator window 
appears. 

The filter conditions that are set appear in the Filter Navigator. As soon as a filter is set, at 
the bottom of the Filter Navigator notice a blank filter level in which Or can be selected by 
clicking on it. Once the blank filter level is selected, enter other filter conditions in the form. 
These conditions are linked by Boolean OR to the previously defined conditions. 
The context menu can be called for every entry in the Filter Navigator. Edit the filter 
conditions in this area directly as text. In addition users can also select the filter conditions (
SQL: “Is Null” or (SQL: “Is not Null”) to check if a field has content or not. It is 
also possible to delete the entry by using the context menu. 
Filter conditions can also be moved within a form in the Filter Navigator by Drag&Drop or 
copy them by holding down the Ctrl Key. 

While designing a form, set the Filter proposal property for each text box in the Data tab of 
the corresponding Properties dialog. These fields allow subsequent searches in the filter 
mode, selections via a pulldown list all the summarized information contained in such fields. 
The field contents can also be easily selected using the AutoComplete function. Please note 
however, that this function requires a lot of memory space especially when used in large 
databases and should, therefore, be used sparingly. 
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Chapter 8: Customizing OpenOffice.org
Use this section as a guide on customizing the user interface of OpenOffice.org. This should 
be mainly of interest to advanced users of OpenOffice.org.

Modifying and Customizing the User Interface of OpenOffice.org
There is much freedom in configuring menus, toolbars and keys to suit personal preferences.
One is free to change:
• Items on the menu bar. These can be deleted, new ones added, copied from one menu to 

another, renamed, and so on.
• Toolbar configuration. These may be freely configured to suit. Under Windows®, icons 

may even be dragged and dropped while holding down the Alt key to change toolbar 
appearance.

• Shortcut keys as desired.

To make configuration changes, select Tools > Configure to open the Configuration 
dialogue. Help also provides much useful guidance for configuring OpenOffice.org.

Configuring the Keyboard
In most instances, one configures new keyboard shortcuts to enable a macro to perform a 
certain action on a document. Other actions can also be given a shortcut; for example, adding 
all unknown words in a text document to the active user dictionary with a single command to 
shortcut keys or to a separate icon. The following procedure is a simple example which 
illustrates how to enable a keyboard shortcut that gives this capability to OpenOffice.org:
1. First ensure that the following conditions exist:

• A userdefined dictionary is active.

• The language of the dictionary has to be set up on “All”.
• The dictionary file is not a readonly file.

2. Open a text document.

3. Choose Tools > Configure. The Configuration dialogue appears.

4. Select the Keyboard tab to specify a key combination.

5. Search for an available key combination in the Keyboard list box such as F4.

6. Click Modify
7. Select Category > Options area at the lower left of the Keyboard tab, 

8. select the Adding unknown words function next to it.
9. close the dialogue with OK.
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Now, by pressing the F4 key or whatever shortcut keys were selected, one can start a spelling 
check of the current text document, automatically placing all unknown words in an active 
userdefined dictionary.

Configuring Menus
Configuring a menu item is similar to configuring a keyboard shortcut as shown above. The 
stepbystep procedure that follows should help in setting up a new menu item, in this case, 
the extendedPDF macro from ooomacros.org. While OpenOffice.org modules include pdf 
export commands, these do not allow HTML links; thus it may be convenient to add this 
feature. 
This procedure will work only if there is an installed extendedPDF macro. The following 
explains how to integrate extendedPDF commands into the File menu.

Note: Installing the extendedPDF macro is covered by the macro document itself.

1. Open a document.

2. Choose Tools > Configure to open the Configuration dialogue.

3. Click the Menu tab.
4. In the large list box, scroll to find the command in which to integrate the new 

extendedPDF command (e.g. “Export”) and select it.
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5. Locate in the Functions menu, the category and function to add. In this case this would be 
found in the category, OpenOffice.org Basic Macros > extendedPDF and the Function 
would be extendedPDF.

6. Click New. The new menu command is inserted in the large list box.
7. The order of the items by moving the names to the large list box using Drag&Drop.

8. Click OK to close the Configure dialogue. OpenOffice.org automatically saves the 
changes.

The new menu items should now be available.

Changing Toolbars
• To copy an icon, say from an object bar to the Standard toolbar, so that it is always visible, 

simply hold down the Alt key and drag the icon to its new location. OpenOffice.org 
automatically remembers the configuration of the toolbars.

• To delete an icon, hold down the Alt key while dragging it out of its toolbar and drop it 
outside of the toolbars.

• To have a separating dash on the toolbar, drag an icon slightly to the right while holding 
down the Alt key. 

• To delete a separating dash, drag the icon to the right of the separating dash slightly to the 
left while holding down the Alt key.

The context menu of a toolbars contains a Visible Buttons command. This opens a submenu 
with a list of predefined icons. Icons with check marks beside them are visible on the 
selected toolbar. Click on an item to switch the icon from visible to hidden and vice versa.

The Visible buttons command in the context menu of the toolbars may also be used to have a 
quick overview of the icon names and their functions.

Inserting, Moving and Deleting Icons on Toolbars
1. Open a document of the type which has the toolbar to modify. For example, to modify the 

text object bar for all text documents, open a text document, and then do the same for the 
other document types. 

2. Open the context menu of the toolbar and select the Edit command. 
3. At the bottom of the dialogue select the desired function category and the function. 

4. If no suitable icon is displayed for this function, click Icon... and select an appropriate 
icon. Confirm with OK. 

5. Now drag the selected icon out of the dialogue while keeping the mouse button pressed 
and drop it on the toolbar. Release the mouse where the new icon is to be located. 

6. Close the dialogue. 
7. On a Windows® system only, to move this icon to a new position, drag it to the new 

position while keeping the Alt key pressed.
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8. Again for Windows® only, to remove an icon from a toolbar, drag it out of the toolbar 
while keeping the Alt key pressed. 

If the toolbar is to be docked with another border, proceed as follows: 
1. Hold the Ctrl key down and doubleclick a gray area of the toolbar to open the toolbar 

as a floating window. 
2. Drag the toolbar to its new position. If the mouse key is released while holding down the 
Ctrl key, and if the toolbar is also over a window border, the toolbar will dock with the 
window border. 

Changing Icon Views
Icon views can be changed between two choices, flat icons and 3D icons.

1. Choose Tools > Options > OpenOffice.org.

2. In the View register uncheck Flat buttons.
3. Click OK to confirm the new settings and close the dialogue.

The Flat buttons check box switches between flat and 3D view. The Large buttons check 
box switches between large and small icons.
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Changing the Look of the User Interface
OpenOffice.org has different ways of display that reflect different operating systems. Thus, 
the user can change the windows and dialogues to suit personal taste:

Choose Tools > Options > OpenOffice.org > View. In the Look & Feel combo box, choose 
an appearance reminiscent of Macintosh, XWindows® or OS/2. The “Standard” setting 
has the familiar look of a Microsoft Windows® application.

Selecting Measurement Units
One can select separate measurement units for Writer, Writer/Web, Calc, Impress and Draw 
documents.

1. Select Tools > Options.
2. Click on the document type that is to have its measurement unit changed. For example, 

click on Text Document to select the measurement unit for Writer.

3. Click on General.
4. On the General tab page, under Settings, is a combo box for selecting the measurement 

unit. 
5. Close the dialogue with OK.

Moving, Deleting or Copying Icons
• To move an icon keep the Alt key pressed and drag the icon to its new position. It will be 

moved within the same toolbar and copied between toolbars.
• To delete an icon from a toolbar, keep the Alt key pressed and drag the icon to a place 

where there is no toolbar.
• To insert or delete a dash, drag the icon in the same way to the side.
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Sending Faxes and Configuring OpenOffice.org for Faxing
To send a fax directly from OpenOffice.org, both a fax modem and a fax driver that allows 
applications to communicate with the fax modem must be installed as they would with a 
printer.

Creating a LAN Friendly Faxing Solution under Linux
1. Install   fax software such as mgetty or sendfax. Don't forget to run faxrunq as a 
cron job.

2. Test by sending a postscript file to someone.
3. Install fax4CUPS (assuming CUPS is the printer control software. If not, consider it.)
4. Make a printer in CUPS following the fax4CUPS instructions which points to mgetty.
5. Test by sending a postscript file to someone as a nonroot user with 

lpr P printername o "phone=faxnumber" filename 
(if it doesn't work, try it as root. If that works, try changing the permissions on the cups 
spool directory)

6. test the same lpr command from another machine on the LAN. This should work if 
CUPS browsing is enabled

7. find and run spadmin as root. 
a) Create a new fax type printer. Current versions of OpenOffice.org may not allow 

reconfiguring the printer properties as a OpenOffice.org fax device, in that case just use 
a different printer name. 

b) Use the command lpr P printername o "phone=(PHONE)"
c) do the test page in spadmin. A fax number prompt should pop up.

8. try printing to the fax printer in Writer .. should work
9. info about making a fax toolbar button appear is in the Writer help file
10.info about inserting the fax number in the Writer document is in the Writer Help file
Done. A fax out solution for OpenOffice.org that doesn't require anything on the Linux 
workstation except for CUPS which should be available in any case.
Go and vote for the OpenOffice.org feature request for doing the spadmin steps 
automagically at http://qa.openoffice.org/issues/show_bug.cgi?id=49980 (if they do that then 
the workstation requires no configuration at all. It'll all be done through CUPS auto
browsing)

Creating a LAN Friendly Faxing Solution under Windows
While Windows ® does not use CUPS, printer management is similar and the steps outlined 
for Linux should enable one to configure a Fax printer in a similar manner. Remember to test 
at each stage.
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Sending a Fax via dialogue
Print the current document with the fax machine as a printer:

1. Open the Print dialogue by choosing File > Print and select the fax driver in the Name 
pulldown list.

2. Clicking OK opens the dialogue of the fax driver where one enters the fax recipient.

Configuring OpenOffice.org for Faxing via Icon
OpenOffice.org can be configured for faxing such a way that a single click on an icon is 
sufficient to send a fax:

1. Choose Tools > Options > OpenOffice.org Writer > Print.
2. Select the installed fax driver from the Fax pulldown list.
3. Click OK.

4. Open the context menu on the Standard toolbar and click Visible Buttons to see a list of 
immediately configurable buttons for this toolbar. All buttons that are currently visible 
have a check mark.

5. In the context menu, click to mark the Send Standard Fax button . The button is now 
visible on the Standard toolbar. By clicking on it, the fax driver entered in step 2, is 
activated to send the current document.

Further Information
OpenOffice.org can be configured in other ways. However these require programming skills 
that are beyond the scope of this document. For information on this type of configuration, 
See http://documentation.openoffice.org. 
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Chapter 9: Advanced Techniques
This contains topics of interest to advanced users of OpenOffice.org including information on 
revision marking function (redlining) in Writer and Calc.

Copying and Moving Data Using Drag and Drop
The easiest and often most intuitive way to copy and move data in OpenOffice.org is by 
dragging and dropping with the mouse.

Dragging and Dropping Within a OpenOffice.org Document
There are many options for moving or copying objects using drag and drop. Selected text, 
text areas, draw objects, graphics, buttons and other form functions, hyperlinks, table areas 
and many more can be moved with the mouse. 
Pay attention when dragging using the mouse pointer. The mouse pointer shows a plus sign 
when copying and an arrow when making a link or hyperlink. 

Mouse Pointer Shape Description
Moving

Copying

Creating a link

Pressing Ctrl or Shift+Ctrl when releasing the mouse button, usually influences 
whether the item is copied, moved, or a link is created. Drag objects out of the Navigator; in 
the submenu of the Drag Mode icon, specify whether to copy the object, insert it as a link or 
insert it as a hyperlink. Drag and drop operations in OpenOffice.org can be cancelled at any 
time by pressing the Esc key before releasing the mouse button. 

Inserting Objects From the Gallery
Objects can be inserted in a document as either a copy or as a link. A copy of an object is 
independent of the original object. Changes to the original object have no effect on the copy. 
Links, on the other hand, remain dependent on the original object; thus, changes to the 
original object are also reflected in the link.

Inserting an object as a copy
• Open the Gallery.

• Choose a theme from the left area.
• Select the object by a single click.
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• Drag the object into the document or rightclick to open the context menu and select 
Insert and Copy.

Inserting an object as a link
• Open the Gallery.
• Choose a theme from the left area.

• Select the object by a single click.
• Drag the object into the document while pressing the Shift and Ctrl keys, or right

click to open the context menu and select Insert and Link.

Inserting an object as a background graphic
10.Open the Gallery.
11.Choose a theme from the left area.
12.Select the object by a single click.

13.Open the context menu and choose Insert > Background > Page or Paragraph.

Inserting an object as a texture (pattern) for another object
• Open the Gallery.

• Choose a theme from the left area.
• Select the object by a single click.

• Drag the object on to the other object in the document while pressing Ctrl.

Copying Graphics From the Gallery
Graphics, dragged from the Gallery, are inserted into a text, spreadsheet or presentation 
document where they are dropped.
If the graphic is released directly on a draw object, please note the following:
9. If it is moved, by dragging without pressing any key (no additional symbol appears next to 

the mouse pointer), only the font attributes are copied from the graphic and applied to the 
draw object where the mouse button is released.

10.If it is copied by dragging while holding down the Ctrl key (a plus sign appears next to 
the mouse pointer), the graphic is inserted as an object.

11.If a hyperlink is created, by dragging while holding down Shift+Ctrl (a linking arrow 
appears next to the mouse pointer), the drawing object is replaced by the graphic from the 
Gallery; however, the position and size of the replaced draw object are retained.

Inserting Graphics From a Document in the Gallery
Graphics, from HTML pages and other similar sources, can be placed in the Gallery by
draganddrop.
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•  Display the Gallery theme to which to add the graphic.

• Position the mouse pointer above the graphic, without clicking.
•  If the mouse pointer changes to a hand symbol, the graphic refers to a hyperlink. In this 

case, click the graphic while pressing the Alt key to select it without executing the 
respective link.
However, if the mouse pointer does not change to a hand symbol, simply click the graphic 
to select it.

• Once the graphic is selected, release the mouse button. 
• Click again on the graphic image, keeping the mouse button pressed for more than two 

seconds, to copy the graphic image to memory.
• Without releasing the mouse button, drag the graphic into the Gallery.

Note:Draw objects that are created using the Draw functions floating toolbar, cannot be incorporated in the 
gallery.

Copying Graphics Between Documents
Graphics can be copied from one document to another. 

Note: If the document is to be published, please observe copyright laws and, for safety, obtain the consent of the 
authors of the original.

9. Open the document in which to insert the graphic object.
10.Open the document from to copy the graphic.
11.Click the graphic to select it.
12.Rightclick to open the context menu or use Ctrl+C
13.Select Copy to place the graphic into the clipboard.
14.Bring the target document into focus.
15.Select the location for the graphic. 
16.Rightclick to open the context menu and select Paste at the position where to insert a 

copy of the picture or use Ctrl+V.
17.If the graphic is connected with a hyperlink, the hyperlink and not the graphic is inserted.

Copying Draw Objects into Other Documents
In OpenOffice.org it is possible to directly copy draw objects between text, spreadsheets and 
presentation documents.
3. Select the draw object or objects.
4. Copy the draw object to the clipboard by using Ctrl+C or by rightclicking to open the 

context menu and selecting Copy.
5. Switch to the other document and place the cursor at which to insert the draw object.
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6. Insert the draw object at the target position by using Ctrl+V or use the Paste command 
from the context menu.

Inserting a Draw object in a text document
An inserted draw object is anchored in a text 
document at the current paragraph. Anchors can 
be changes by selecting the object and clicking on 
the Change Anchor icon on the object bar. This 
opens a popup menu that permits changing the 
possible types of anchor.
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Inserting a Draw object in a spreadsheet
An inserted draw object is anchored to a spreadsheet in the current cell. Change the 
anchor between cell and page and back by selecting the object and clicking on the 

Change Anchor on the object bar.
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Drag and Drop With the Data Source View
The simplest and quickest way of transferring data from a data source into a text or 
spreadsheet document, or creating forms based on a data source, is the draganddrop 
method.

Copying with Drag&Drop

To reverse a mistake made during a drag and drop operation, position the cursor in the 
document and choose the Undo command from the Edit menu (or via the keyboard).

Note: Copying by drag and drop is possible in the both directions:

6. A text table or a selected range of a spreadsheet can be dragged using drag and drop to a table container in the 
data source explorer or vice versa.

7. Likewise, simpler text can be copied using drag and drop from one document to a data field in the data source 
view. Read up on how this happens in Help.

Using data in a text document
A database field can be inserted in a text document by dragging a field name from the 
column header of the data source view into the document. This inserts a field for this 
database field in the document. This is especially useful when designing form letters. Simply 
drag the desired fields, such as, home address, form of address et cetera, into the document. 
The best way to insert a complete record is to select the corresponding header and drag it into 
the document. When the mouse button is released, the Insert database columns dialogue 
appears, where one can decide whether to use all database fields, and whether to copy the 
data into the document as text, a table or fields. All currently selected records will be 
inserted. 

Applying data to a table document
One or more records can be inserted into the current sheet of a spreadsheet by selecting the 
rows in the data source view and dragging and dropping them into the spreadsheet. The data 
is inserted in the place where the mouse button is released.

Inserting controls in a text form
When a text form, linked to a database, is created, one can generate controls by dragand
drop from the data source view: When a database column is dragged into the text document, 
a field is inserted. By holding down Shift+Ctrl while dragging, a text field is inserted, 
grouped with an appropriate label field. The text field already contains all the database 
information that is needed for the form. 
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Copying Sheet Areas to Text Documents
• Open both the text document and the spreadsheet. 

• Select the sheet area to copy. 
• Point to the selected area and press the mouse button. Keep the mouse button pressed for a 

moment, then drag the area into the text document. 
If the documents are not visible next to each other, first drag the mouse pointer to the 
destination document button. Continue to hold down the mouse button. The document 
addressed in this way is displayed, and the mouse pointer can be moved within the 
document. 

• Once the cursor is located in the place where to insert the sheet area, release the mouse 
button. The sheet area is inserted as an OLE object. 

Select and edit this OLE object at any time. 
11.To edit the OLE object, simply doubleclick on it. 

Alternatively, select the object and choose Edit > Object > Edit or choose Edit from the 
context menu. The object can be edited in its own frame within the text document, but the 
icons and menu commands needed for spreadsheets are visible. 

12.Choose Open to open the source document of the OLE object. 

Inserting Data From Spreadsheets
• When copying the contents of a cell (text or numbers), using the clipboard is best. 

Copying formulae that are in the cells into the clipboard, such as from the input lines of 
the formula bar, is also possible; thus. they can now be inserted into the text.

• To copy a simple, rectangular area of cells into a text document as a sheet, select the cells 
in the sheet and then use either the clipboard or drag & drop to insert them into the text 
document. This will be an OLE object in the text document that can edited.

• If cells are dragged to the character view of a presentation document, they will also re
appear there as OLE objects. Once dragged into the outline view, each cell will form a line 
of the outline view. Dragging using draganddrop will move the cells. Press the Shift 
key, when dragging, create a copy.

Inserting Data From Text Documents
Text can be transferred into other document types such as spreadsheets and presentations but, 
there is a distinction made that depends on whether the text should be set in its own text 
frame, transferred into a spreadsheet cell or transferred into the structure of a presentation.
• If text is transferred via the clipboard, one can paste it to the destination with or without 

text attributes. Use the shortcut keys Ctrl+C to copy and Ctrl+V to paste.
To select the format in which the clipboard contents will be pasted, do a long click on the 
Paste icon on the Standard toolbar. Select the format from the submenu.

• To obtain a selection of formats, choose Edit > Paste Special.
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• In a text document use File > Send > Outline to presentation to create an new 
presentation document that contains the headings from the text document as the outline. 
The headings must be formatted with a corresponding Paragraph Style before the user can 
see this command.

• To transfer the same headings to the first superordinate paragraph (or several paragraphs) 
of the text, select the AutoAbstract to presentation command. Again, the headings must 
be formatted with a corresponding Paragraph Style before the user can see this command.

Copying Text Using Drag and Drop
• If one selects a text section and drags it into a spreadsheet with drag & drop, it will be 

then be inserted as text into the cell where the mouse is released.
• When a text section is dragged to the character view of a presentation, an OLE object is 

inserted as a OpenOffice.org plugin.
• If text is dragged to the outline view of a presentation, it is inserted at the point where the 

cursor is positioned.
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Revision Marking Function
The revision marking function in Writer and Calc highlights changes to documents so that 
whomever is editing the file can see who changed what and when.

Recording and Displaying Changes
When several authors are working on the same text or spreadsheet, the review function 
(marking changes, redlining) makes it possible to document who made which changes, so 
that this is clear to everyone. On the final edit of the document, it is then possible to look at 
each individual change and decide whether it should be accepted or rejected.
For purposes of illustration, imagine having to deliver a report. Now, before publication, the 
report must be read by the senior editor and the proofreader, and both will add their changes. 
Perhaps the senior editor writes clarify after one paragraph and crosses out another entirely. 
The proofreader checks the spelling of the document and notes two cases where explicit 
references to the gender of an imaginary person could be reworded to avoid gender entirely. 
The edited document comes back whereupon one can choose to incorporate or ignore the 
suggestions of the two reviewers. Plus, you also emailed a copy of the report to a good 
friend and colleague who has done research on a similar topic in the past, asking for a few 
suggestions, and the document is now returned by email with  suggestions. It is now a 
simple matter to produce a final version of the document from the results that are returned.
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Accepting or Rejecting Changes
When bringing a document in which others have noted their changes back together again, the 
user can accept or reject the changes individually or all together.
• If one has put multiple copies of the document in circulation, first of all. merge these into 

one document (see Merging Versions).

• Open the document and choose Edit > Changes > Accept or Reject. The Accept or 
Reject Changes dialogue appears.

• Select a change on the List tab. The change is selected and displayed in the document and 
now the users makes a decision with one of the dialogue buttons.

If one author has changed another author's change, one will see the changes hierarchically 
arranged with a plus sign for opening up the hierarchy.

When the list of changes is too long or confusing, switch to the Filter tab in the dialogue and 
specify only the changes of certain authors, or only the changes of the last day, or that the list 
should be restricted in some other way.
Changes can also be filtered by the descriptions. Wildcards (as with regular expressions in 
the Find & Replace dialogue) are permitted when entering the filter.
Text document changes that have not yet been accepted are displayed in the list. Changes that 
have been accepted are removed from the list and appear in the text without any further 
marking.
Spreadsheet changes that have been accepted are combined in the list in a single entry, so that 
one can continue to see which changes have already been accepted.
colourcoded entries inform the user about the result of the filter that is set. Entries in black 
can be accepted or rejected and match the filter criteria. Entries in blue do not, themselves, 
match the filter criteria but have subentries that are included by the filter. Grayed entries 
cannot be accepted or rejected and do not match the filter criterion. Green entries do match 
the filter but in spite of this cannot be accepted or rejected.
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Comparing Versions of a Document
Perhaps one of the authors who received a copy of the document made changes but did not 
record them by choosing Edit > Changes > Record. Nonetheless, the delivered copy of the 
document can be compared with the original document.

1. Open the edited document and then choose Edit > Compare Document.
2. From the file selection dialogue, select the original copy of the document. 
3. Confirm the dialogue.
Now OpenOffice.org combines both documents in the original document. All text passages 
that occur in the document but not in the original are identified as having been inserted, and 
all text passages that are missing in the copy document are identified as deletions.
Now start the revision process by accepting the “insertions”, in which case the relevant texts 
stay in their original form, or accepting the “deletions”, in which case the marked text 
contained in the copy are not inserted in the document.

Merging Versions
It is not always one and the same document that is edited by different authors and passed 
from one to the next author. It often makes more sense to give a separate copy of the 
document to each author. For example, three copies are returned in addition to the original 
document, with different changes in each copy.
It is easy to merge these documents into the original. The only requirement is that the 
documents differ only and exclusively in the recorded changes. In other words, all “normal” 
text must be identical.
1. Open the original document into which to merge all the copies.

2. Select Edit > Changes > Merge Document.... This opens a typical file selection dialogue 
from which to choose a copy of the document.

3. After merging the documents, the designated changes from the copy in the original 
document will be visible.

Recording Changes
The review function is available in OpenOffice.org for both text documents and spreadsheet 
documents. Not all changes are recorded (for example, the changing of a tab stop from align 
left to align right is not recorded). However, all usual changes made by a proofreader are 
recorded, such as additions, deletions, text alterations, usual formatting et cetera.

1. To start Revision Marking, open the document to be edited and choose Edit > Changes 
and click Record which display a check mark when enabled.
2. Now start making any changes. Note that all new text passages entered are underlined in 
colour, while all deleted text remains visible but is crossed out and shown in colour.
3. If a marked change is moved with the mouse pointer, one will see a reference to the type of 
change, the author, date and time of day for the change in Help Tips. If Extended Tips is also 
enabled (on the Help menu), any available comments on this change will be displayed.
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Changes in a spreadsheet document are highlighted by a border around the cells; when a cell 
is pointed to more detailed information on this change is seen in Help Tips when Extended 
Tips is also enabled (on the Help menu).
Comments on each marked change may be entered by placing the cursor in the area of the 
change and then choosing Edit > Changes > Comment.... In addition to Extended Tips, the 
comment is also displayed in the list in the Accept or Reject Changes dialogue.

To stop recording changes, choose Edit > Changes > Record again to disable the 
function(The check mark is removed). Now the document can be saved and returned to the 
person who asked for the changes.
In a text document, highlight all lines that have changed with an additional marking. This can 
be in the form of a red line in the margin, for example.

Select the type of additional selection under Tools > Options... > Text Document on the 
Changes tab or under Tools > Options > OpenOffice.org Calc on the Changes tab. In these 
dialogues, determine how and in what colour the changes should be flagged, where on the 
page the dash should be and so forth.

Version Management
The File menu contains a Versions command. The Versions function allows the user to save 
multiple versions of the same document in the same file. One can choose to view individual 
versions of a document, or display the differences between versions with colour markings. In 
the dialogue to open a document, choose which version of the document is wanted for editing 
from a list box. 
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Protecting Contents in OpenOffice.org
The following is an overview of the different ways of protecting contents in OpenOffice.org 
from being modified, deleted or viewed.

Protecting All Documents When Saving
All documents that are saved in XML format ( OpenOffice.org Format) can be provided with 
a password. These documents can no longer be opened without the password. The content is 
secured, so that it cannot be read with an external editor either. This applies to content, 
graphics and OLE objects.

Turning on protection 
1. Select File > Save As 
2. check Save with password.
3. Save the document.

Turning off protection 
1. Open the document and enter the correct password.

2. Choose File > Save As and uncheck Save with password.

Information that is entered under File > Properties, such as the name of the author, date 
created, word and character counts et cetera, are not encrypted.

Protecting Revision Marking
With every change made in Calc and Writer, the review function records who made the 
change. This function can be turned on with protection, so that it can only be turned off when 
the correct password is entered. Until then, all changes continue to be recorded and 
acceptance or rejection is not possible.

Turning on revision protection 
1. Choose Edit > Changes > Protect Records. 
2. Enter and confirm a password of at least 5 characters.

Turning off revision protection 
1. Choose Edit > Changes > Protect Records. 
2. Enter the correct password.

Protecting Cell Ranges in Calc
In Calc, protection can be applied to spreadsheets and the whole document. As part of the 
process, choose whether the cells are protected against accidental changes, whether the 
formulae can be viewed, whether the cells are visible and/or whether the cells can be printed.
Protection may be password protected, but this is not always necessary. Once a password is 
assigned a password, protection can only be removed by entering the correct password.
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Note: Cell protection for cells , setting the Protected attribute, is only effective when the whole table is protected. 
The default condition is that every cell receives the Protected attribute. Thus, in cells where the user may make 
changes, the attribute must be removed selectively for those cells. Once this is done then protect the whole table 
and save the document. 

Turning on protection For cells: Select cell range. Choose Format > Cells > Cell Protection tab.
For spreadsheets: Choose Tools > Protect Document > Sheet. 
For documents: Choose Tools > Protect Document > Document. 
Enter and confirm a password of at least 5 characters.

Turning off protection For spreadsheets: Choose Tools > Protect Document > Sheet. 
For documents: Choose Tools > Protect Document – Document. 
Where a password has been assigned, enter the correct password.

Protecting Sections in Writer
Any section of a OpenOffice.org Writer text document can be protected against changes with 
a password.

Turning on protection 
1. Select the section. 

2. Choose Insert > Section > Section, 

3. Under Write protection mark the Protect and With password check boxes. (If the 
section already exists: Format > Sections.) 

4. Enter and confirm a password of at least 5 characters.

Turning off protection 
1. Choose Format > Sections > Section
2. Under Write protection, uncheck Protect. 
3. Enter the correct password.

Protecting Cells in a OpenOffice.org Writer Table
The contents of individual cells of a Writer text table can also be protected from changes.

Turning on protection Place the cursor in a cell or select cells. Choose Format > Cell > 
Protect.

Turning off protection First, ensure that Tools > Options > OpenOffice.org Writer > 
Formatting Aids > Cursor in protected areas has Enable checked. 
Place the cursor in the cell or select the cells. Then choose Format > 
Cell > Unprotect. 
Select the table in the Navigator, open the context menu and select 
Table > Unprotect. 
Use Shift+Ctrl+T to remove protection for the entire current table 
or all selected tables.
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Automatic Protection of Indexes and Tables
Tables of contents, alphabetical indexes and so on that are created automatically in Writer, 
are automatically protected against accidental changes.

Turning on protection 
1. Place the cursor in the index/table of contents.

2. From the context menu choose Edit Index/Table. 

3. On the Index/Table tab page, check Protected against manual changes.

Turning off protection 
1. Ensure that Tools > Options > OpenOffice.org Writer > Formatting Aids > Cursor in 

protected areas has Enable checked. 
2. Place the cursor in the index. 

3. From the context menu choose Edit Index/Table. 

4. On the Index/Table tab page, uncheck Protected against manual changes or, in the 
Navigator, select the index, open the context menu and select Index > Readonly .

Protecting frames, graphics and OLE objects
Many objects can be inserted in OpenOffice.org documents. Users can protect the content, 
position and/or size of inserted graphics. The same applies to frames (in Writer) and OLE 
objects.

Turning on protection For graphics inserted in in a document: Choose Format > Graphics > 
Options tab. Under Protect, mark Contents, Position and/or Size.

Turning off protection For graphics inserted in a document: Choose Format > Graphics > 
Options tab. Under Protect, uncheck as appropriate.

Protecting Drawing Objects and Form Objects
Draw objects, that are inserted in a document using the Draw Functions floating toolbar, can 
be protected from being accidentally moved or changed in size. Likewise, the user can do the 
same with form objects inserted using the Form Functions floating toolbar.

Turning on protection 
1. Select Format > Position and Size > Position or Size tab. 

2. Check the Protect check box.

Turning off protection 
1. Choose Format > Position and Size > Position or Size tab. 

2. Uncheck the Protect check box.
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Protecting Records
Changes made in a document can be recorded by choosing either Edit > Changes > Record 
or Edit > Changes > Protect Records. If Protect Records is selected, one must enter the 
correct password in order to turn off the function or accept or reject changes.

1. Select Protect Records. This opens the Password dialogue.
2. Enter a password consisting of at least 5 characters and confirm it.
3. Click OK.

Digital Signatures and Encryption1

Overview
Use of Digital signatures in OpenOffice.org is new to with OpenOffice.org 2.0 and is 
relatively new in other office applications. Nonetheless,, the requirement to protect data from 
being modified has existed for a long time. 
While OpenOffice.org 1.1.x offered protection for documents with encryption and 
passwords, digital signatures offer enhanced secure protection of document content, both 
inside OpenOffice.org 2.0 and externally.
Another aspect of using digital signatures, is for ensuring Macro security. This can be a very 
important topic because when user accesses a document containing macros or receives them 
via email, the user cannot know if these can be trusted or whether they may harm the system. 
Being that there is no easy way to determine whether a macro is harmful; the decision 
whether to trust a macro or not to trust must be based on the trustworthiness of the macro 
author. Unfortunately, one cannot know that the macro really comes from the author or that it 
has not been modified by somebody else. Digital certificates and signatures are the solution. 
Authors can sign the macro with a private key and user can then verify the signature with the 
author's public keys. An added benefit of using digital signatures is the assurance that the 
content has not been modified.

Certificates

How to get a Certificate?
There are really only two ways to get a certificate. One, to create one for oneself or, 
secondly, to obtain one from a trusted signing authority. 

1 Specification  http://specs.openoffice.org/appwide/security/Electronic_Signatures_and_Security.sxw
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Selfsigned certificates
These are user created using certificate creation tools. The following list provides some that 
are know at the time of writing this section. In this case, users are expected to know and 
understand the basics of the procedure.

Product OS Vendor
SelfCert.exe Windows Microsoft – part of Office
abylon SELFCERT Windows http://www.abylonsoft.com/frame.htm
Certificate 
Assistant

Mac OS X Builtin.

CA.pl Linux, BSD, Solaris10 Comes with OpenSSL.
keytool JDK or JRE Part of Java (Solaris)

Please see the instructions in the Operating System documentation for your system.

Certificates from a Certificate Authority
Depending on user needs, getting a certificate from a Certificate Authority may be free or 
have a cost attached. Some Certificate Authorities offering certificates are listed below:

Vendor Cost Type Contact
Thawte Free Email http://www.thawte.com/

Comodo Free 30 day trial Server and email http://www.instantssl.com/

Verisign Cost All types http://www.verisign.com/

CAcert Free All types http://www.cacert.org/

Integrating a Certificate with OpenOffice.org
See Help > Contents > Index > Search term > digital signatures for instructions on 
enabling Digital Signatures in OpenOffice.org for instructions.
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Changing Defaults and Other Configuration Items
Saving Configuration With Document
Users can set a global configuration (so that it applies to all documents of this type), or can 
connect the configuration to a specific document, which must exist as a file.
1. Load the document to which to connect the configuration or open any document of the 

same type.
2. Set the configuration. For example, select the toolbars that should be visible or define 

what is on the toolbars, menus or status bar and so on. All such configuration options are 
found under Tools > Configure.

3. Click Save... in the dialogue under Tools > Configure. Another dialogue appears from 
which to save the configuration.

4. In the File Type list box, select <All>.
5. In the large list box of the Save dialogue, select the file that is to be connected to the 

configuration.

6. Click Save. A prompt appears, asking whether to replace the file or not. This query 
concerns only the configuration connected to the document, not the “actual” contents of 
the document.

7. Confirm overwrite.
The configuration is now connected to the active document. Check this by loading the 
document and choosing File > Document Template > Organizer then doubleclicking the 
document.
As soon as one loads or opens this document, the configuration, that was saved with it, 
becomes active. The global default configuration is restored when another document is 
loaded or opened that does not contain custom configuration information. Select manual 
settings at any time by choosing Tools > Configure and clicking the Reset button.

Inserting and Editing Tab Stops
Set a tab stop by clicking on the ruler. Alternatively, a user can set tab stops by choosing 
Format > Paragraph. Both methods affect the current paragraph or all selected paragraphs.
Click the ruler once to set a leftjustified tab. Rightclick a tab icon on the ruler to see the 
context menu in which the tab type can be changed.
To set several decimal tabs one after the other, keep clicking the icon to the left of the ruler 
until the desired tab type is shown, then click on the ruler.

Selection Description:
Setting left tabs
Setting right tabs
Setting decimal tabs
Setting c entered tabs
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Doubleclick the ruler to open the Paragraph dialogue.

Doubleclick the white area of the ruler to set one tab. The Paragraph dialogue appears with 
the Tabs tab page.

Note: To assign tabs directly to a current Paragraph Style, open the context menu of that paragraph and choose 
Edit Paragraph Style to call the Paragraph Style dialogue where tabs are then entered.

Moving Tabs on the Ruler
There are three ways to set tabs:
1. Move individual tab stops on the ruler using the mouse.
2. To move several tab stops on the ruler, press the Shift key before clicking a tab. Drag 

one tab while continuing to press Shift to move that tab as well as all the tabs to the 
right of it. The spacing between those tabs remains the same.

3. Press Ctrl instead of Shift when dragging a tab on the ruler to move that tab and all 
the tabs to the right of it. This results in the spacing between those tabs changing 
proportionally to their distance from the margin.

Changing the Properties of Tabs
To change tab type, click the tab to be changed on the ruler, then open the context menu.

Deleting Tabs
Deleting a tab with the mouse is easy. Simply hold down the mouse button while dragging 
the tab outside the ruler.

Changing the Defaults
To change the settings of the default tab stops, see the settings in Tools > Options > 
(Document Type) > General. The Context Menu of the ruler toolbar allows changes to the 
displayed units to centimetres, inches, point, pica et cetera. These changes are only valid until 
exiting OpenOffice.org, and they only apply to the ruler from which context menu the 
changes were made. To change the ruler measurement units permanently, choose Tools > 
Options > OpenOffice.org Writer > General and change the measurement unit there. 
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Changing the colour of Text
Click the Font colour icon in Writer and other modules, and keep the mouse button pressed 
to obtain a floating toolbar from which to choose from the range of colours.

Font colour (Writer)
Font colour (other modules)

The following applies to all modules (Writer, Calc, Draw, Impress): Select the text that is to 
take another colour, then click the colour wanted on the floating toolbar. 

Note: Only in Writer: If one confirms the symbol with a shortclick while no text is selected, then the mouse pointer 
changes its appearance and is displayed as a paint can pouring. Use this paint can pouring symbol with the mouse 
key pressed to drag across a text area. This text area takes the selected colour. The function remains active for as 
long as the symbol is “pressed”, or until clicked without dragging, or until the Esc key is pressed. 

Inserting Landscape pages into a Portraitoriented Document
1. Open the Styles and Formatting window (Format > Styles and Formatting or F11)

2. In the Styles and Formatting window, click on the Page Styles icon (fourth icon from left)
3. The type "Standard" should already be highlighted, hold the right menu button down to 

see the context menu and choose "New..." 
4. In the dialogue that appears, give the new page style a descriptive name; for example, 
Landscape

5. Click on the Page tab and change the page orientation to Landscape by clicking on the 
corresponding radio button. At the same time, make other changes to the page style, as 
needed (such as adjusting the margin sizes).

6. Click on OK. The new style will appear as one of the style choices.
7. Place the text cursor in the document at the location at which to insert the Landscape page

8. Select Insert > Manual Break
9. In the dialogue that appears, select Page Break and in the Style list, select the new page 

style, e.g. "Landscape";
10.Click OK
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More on Templates
Changing Default Templates
When a new document is opened using File > New, a blank document appears based on the 
default OpenOffice.org template for that document type. Users can edit or modify this 
document or replace it with an existing document so that the new document contains 
personalized custom format attributes or other contents.

Modifying Default Templates
If there is an existing OpenOffice.org document which is satisfactory, use it. However, this 
step is not necessary. However, if one is not what is needed, one can do the following to 
create a new template:
1. Open a new, empty document
2. Edit it until it makes a good template. For example, edit the styles in the Styles and 

Formatting window. 
3. By way of example, the following describes how to proceed for text documents and these 

steps can be applied for other types of OpenOffice.org documents. Templates, of course, 
can be defined for each OpenOffice.org module. 

1. Now save the document, created in step 2, by choosing File > Templates > Save and 
saving the document in, say, the Default category.

2. Select File > Templates > Organize.

3. Doubleclick Default in the list on the left. This will display the userdefined templates 
in the user/template directory. 

4. Select the template was just saved and open the context menu or open the submenu of 
the Commands button.

5. Choose Set as default template. 
That is all that is needed. The next time a new text document is opened, the new document 
will correspond to the template defined as default in step 5 above.

Resetting Default Templates
To reset the modified text template to the original default template, proceed as follows:

1. Select File > Templates > Organize.

2. Open the context menu and choose Reset default template. In the submenu, select the 
document type to restore. Thereafter, when a user opens an empty text document, it will 
again correspond to the OpenOffice.org default template for text documents.

Using Custom Templates
There are several ways to make work easier by using custom templates. One of the most 
important is quick access to the templates. Templates can be stored in different locations in 
OpenOffice.org. Opening a new document using a custom template will then differ 
accordingly.
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New templates saved using File > Templates > Save or by selecting the “Template” file type 
in the “normal” Save dialogue. User templates are usually stored in the 
<path_to>/.openoffice.org2/user/template directory. The template is made 
available, anytime, by selecting it in the New dialogue (File > New > From Templates and 
Documents). When the template is opened, a new document will be created based on that 
template. 
Remember to update the view of the templates in the dialogue to ensure that newly created 
templates are visible. In this case, select File > Templates > Organize and in the submenu of 
the Commands button, choose Update. To modify the template oneself, call this file via File 
> Templates > Edit and then edit it. 

Using OpenOffice.org over a Network
Where users home directories are remotely mounted via Samba, NFS or other similar file 
storage method under *NIX , it is sometimes necessary to make changes to modify the shell 
script that starts Openoffice.org. The following provides a possible solution:

1. Locate the startup script. Usually in 
/<install_dir>/OpenOffice.org2.app/Contents/openofficeorg2.0/program.

2. Edit this file with a suitable text editor such as vi and change the following lines as 
indicated:

SAL_ENABLE_FILE_LOCKING=1

export SAL_ENABLE_FILE_LOCKING

3. to either 
SAL_ENABLE_FILE_LOCKING=0

export SAL_ENABLE_FILE_LOCKING

4. or comment them out as shown below:
#SAL_ENABLE_FILE_LOCKING=1

#export SAL_ENABLE_FILE_LOCKING

5. Restart OpenOffice.org.

NOTE: This may or may not work depending on whether or not the network filesystem is set up correctly. Please 
see the System Administration Guide for the Operating System that is in use.
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Chapter 10: Introducing OpenOffice.org Basic and 
Macros

OpenOffice.org provides a number of sample macros to help guide the user in programming 
macros but also to serve as useful aids that can be used immediately. Use these to get an 
overview of how to write a macro.
These macros are only available in English regardless of the installation language.

Accessing the Sample Macros
Calling the Sample Macros
1. Select Tools > Macros > Run Macro. The Macro Selector dialogue appears.

2. In the Library field, doubleclick OpenOffice.org Macros. 

3. The list will expand, doubleclick Gimmicks. The Gimmicks modules appear.

4. Choose one of the modules, the AutoText module, for example, by clicking the entry.

5. Click Main in the Macro name field.

6. Click the Run button to run the module.
7. A new document is created, listing the AutoText entries available to this installation of 

OpenOffice.org.

Since the object of this exercise was to run a macro, Run Macro was selected. Below an 
alternative, Organize Macros, is used to uncover other features.

OpenOffice.org User Guide for 2.x 421



Chapter 10: Introducing OpenOffice.org Basic and Macros

Editing the Sample Macros
1. Select Tools > Macros > Organize Macros > OpenOffice.org Basic. The 

OpenOffice.org Basic Macros dialogue appears.

2. In the Macro from field, doubleclick OpenOffice.org Macros. 

3. The list will expand, doubleclick Gimmicks. The Gimmicks modules appear.

4. Choose one of the modules, the AutoText module, for example, by clicking the entry.

5. Click Main in the Existing Macros in: field if it is not already selected.

6. Click the Edit button.
The Basic IDE appears. This is where one can view and edit the program code.
The following illustration shows some of the code one would see by following these 
instructions.

Instructions on how to use the Basic IDE can be opening OpenOffice.org help (Help > 
OpenOffice.org Help) and choosing the Contents tab. From there: Macros and 
Programming > General Information and User Interface Usage > OpenOffice.org Basic 
IDE.

Note: Tools > Macros > Organize Macros also contains entries for Python, BeanShell, and JavaScript. These are 
other languages that can be used to write OpenOffice.org macros. Each language has samples for review.
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The Sample Macros
The following sample macros are in the Gimmicks module.

AutoText
Use the Main macro.
This macro opens an empty Writer document and inserts a table in which the names of all the 
AutoTexts are listed.
One can print the document to have a handy list of the available AutoTexts.

ChangeAllChars
Use the ChangeAllChars macro.
Use this macro in a text document to replace all text and numbers with the characters "x" and 
"X". This can be helpful, for example, if the document is to be used as a template but the 
original text is not to be legible.
If one edits this macro, other replacement characters can be defined in the program code.

GetTexts
Use the Main macro.
This macro carries out a search in the active document (text document, spreadsheet, or 
drawing) and compiles a list of the contents.
This sample will help the user learn how to reference objects in the documents.

ReadDir
Use the Main macro.
Use this macro to see how a OpenOffice.org Draw document can be filled with content and 
how the contents of directories are read.
A dialogue asks for a directory and then the macro creates a graphic list (tree view) of all the 
files and subdirectories.

Userfields
Use the StartChangesUserfields macro.
This macro helps users manage several sets of user data and allows switching back and forth 
between them. This can be quite helpful when more than one person uses the same copy of 
OpenOffice.org and each person wants to see his or her own user data in the fields.
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Formula Entry
Main View of OpenOffice Formula.

Tool bar
The tool bar is divided into two parts. 
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The upper part is for adjusting the on screen size of the image. The lower part contains an 
icon for an interactive cursor, and an icon for inserting special characters.

Command Icon Box
The command icon box provides a method of writing an equation using GUI similar to other 
word processors.

The upper two rows in the icon box are menus that call the actual command buttons into the 
lower portion of the command box. The command buttons are used to insert the appropriate 
command at the cursor position in the command field.

Command dialogue Box
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The command dialogue box displays the commands that create the equation. The dialogue 
box can be edited directly.

Creating an Equation with dialogue Commands
To create an equation with equation editor, enter the programming commands in logical 
sequence into the dialogue box. The commands entered are similar to the commands used to 
generate equations in TeX ( a scientific publishing format).
Maintaining logical consistency of the commands entered into the dialogue box is important. 
The brackets used in the dialogue box must be matched, for example all "(" must have a 
corresponding ")".
Here are some examples. As can be seen, it is really simple to type formulae in the dialogue 
box.

Command Input Field Formula
1+1=2 11=2

The next example shows how round brackets ( ) and braces { } are used. The parenthesis are 
used when it is desired to display grouping in the equation, the brace is used to group the 
commands, but to not display. If braces are needed in an equation, then the lbrace and rbrace 
commands are used.

Command Input Field Formula
(1+2) over (2+3) 12

 23
{ 1+2 } over { 2+3 } 12

23
lbrace 1+2 rbrace over lbrace 2+3 rbrace {12 }

{2 3 }

Here is a more complicated example.

Command Input Field Formula
{{1 over 5} +4} over {5+{4+1}over{3+3+1}} 1

5
 4

5 41
331
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Special Formating
Of course there are many other types of groupings that can be created with Open Office. 

Exponentiation:
Command Input Field Formula
2^3 23

5^(1+3+3^2) 5 1332 

Subscripting:
Command Input Field Formula
2_3 23

(1 over 2)_%alpha +4_3


1
2


 43

Leading and trailing superscript and subscript:
Command Input Field Formula
2 lsub ( 123 ) 2123
2 rsub ( 123 ) 2 123
2 lsup ( 123 ) 2123

2 rsup ( 123 ) 2 123

Bi lsup{209}+fe lsup{58} toward Mt 
lsup{266}lsub{109} +n lsup {1}

Bi209  fe58  Mt109
266  n1

In the last example, the 'Mt' has both leading superscript and subscript applied. This requires 
only typing both commands after 'Mt'.

Centre subscript / superscript:
Command Input Field Formula
{24*3} csub ( 123 ) 2− 4∗3

123 
+18 csup ( plus )  (1+2+3+4) csub {minus}

 18
 plus 

−123 4
minus

OpenOffice.org User Guide for 2.x 427



Chapter 11: Using OpenOffice.org Math

Under brace / Over brace:
Command Input Field Formula
+ 18 underbrace plus  ( 1 + 2 + 3 + 4) underbrace 
minus

18
plus

−123 4
minus

+ 18 overbrace plus  ( 1 + 2 + 3 + 4) overbrace 
minus 18

plus

−123 4
minus

Various types of Brackets
In almost all equations various types of brackets are required. OpenOffice formula allows the 
use of several kinds of brackets.

{ } structural braces: used to group parts of an equation for programming purposes.

( ) Parenthesis: used to group parts of an equation. Parenthesis are displayed in the final 
equation.

[ ] square brackets: usage is the same as parenthesis ( ).

{ } braces: as the keyboard characters { } are used for program commands and are not 
displayed in the resulting formula, braces must be typed as lbrace for '{' and rbrace for '}'
The size of brackets can be controlled with the commands 'left' and 'right'

Command Input Field Formula
(1+2  2 cdot (2 over (2  1 ))) 

12−2⋅
2

2−1


left (1+22 cdot left (2 over {21} right ) right ) 12−2⋅ 2
2−1 

left lbrace a^2+b^2=c^2 right rbrace {a2b2= c2 }
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Special Characters
Many equations use special characters in addition to the usual characters of the alphabet. 
Open office provides an easy method to use Greek characters, while any other character in 
the available fonts can be used.
The Sigma appears in the tool bar when Open Office Formula is active. This activates the 
dialogue for special characters.
The Greek letters and other symbols can be entered directly into the command dialogue box 
by entering the name of the special character preceded by %, for example %SIGMA produces 
and %mu gives  .
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Special Operators
The following examples show the use of some special operators

Integral Sign:
Command Input Field Formula
int from {0} to {infinity}{a^2 over 3} = "?"

∫
0

∞
a2

3
=?

Summation Character:
Command Input Field Formula
sgn (%sigma) cdot sum from {%SIGMA in 
%PHI}{1 over {1  aleph_%sigma^2}}  sgn ⋅∑

∈

1

1−ℵ
2

Product Character:
Command Input Field Formula
prod from {i=1} to {i=100}{{ (x_i+1) cdot 
x_i^3} over { x_i^2 1 } } = "?" ∏

i=1

i=100 x i1⋅x i
3

x i
2−1

=?

5^(1+3+3^2) 5 1332 
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Vectors and Matrices
Vectors and Matrices are created by the 'stack' and 'matrix' commands respectively. These 
commands are used with the octothorp # to indicate elements, and double octothorp ## to 
indicate new line. An empty element is indicated by structural braces {}.

Vector
Vectors are composed using the 'stack' command as follows:

Command Input Field Formula
left (stack {A # B # a+b=c } right )  A

B
ab= c

 left( stack {alignr 1 # 2 } right) + left( stack { 2 # 
3 } right) + left( stack { 3 # 1 } right)   1

22
3  3

1
Matrix
Matrices are composed using the matrix command as follows:

Command Input Field Formula
left( matrix { 1 # 2 ## 2 # 3 } right) = x 1 2

2 3= x

abs matrix { a # b ## c # {} } = y ∣a b
c ∣= y

abs matrix { {1 over 2} # b ## c # d } = z

∣1
2

b

c d∣= z
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Formatting
There are some additional formating commands that are available in Open Office Formula. 
These allow adjustment of the size, colour, and layout of the equation.

Size
The instruction size changes the size of text in the equation.

Command Input Field Formula
size 2 { a+b} = size +10 {C}

ab=C

Colour
The instruction colour changes the colour of the text in the equation.
colours available are red, blue, green, yellow, white, and black (default), 

Command Input Field Formula
colour blue A A
left( matrix { { colour red 1} # { colour blue 2} 
## {colour green 3} # 4 } right) = colour black 
{x} 1 2

3 4= x

Layout
Various text formating commands are available to change the layout.

Command Input Field Formula
bold {"bold"} newline "newline"  bold

newline
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Alignment
The alignment commands are available to change the position of the elements of an equation 
with respect to each other.

Command Input Field Formula
stack{ alignr a ={} # alignr b+c+d ={}}
 stack{ alignl 12 # alignl b^22 } 

a=
b cd=

12
b2−2

5^(1+3+3^2) 5 1332 
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Examples
Now for the complicated examples:

Command Input Field Formula
nroot{4}{nroot {3} {1 over 3+x^2} } 

4 3 1
3
x 2

ldline R_ %alpha rdline =left ldline matrix {sin 
%alpha # cos %alpha ## cos %alpha # sin 
%alpha} right rdline 

∥R ∥=∥sin  −cos 
cos  sin  ∥

{partial over {partial t} x(t)}+a(x)=%lambda cdot 
F(x,t)

∂
∂ t

x  t a x =⋅F x , t 

matrix{
 a_11 # a_12 # dotsaxis #a_{"1m"} ##
 a_21 # a_22 # dotsaxis # a_{"2m"} ##
 dotsvert #dotsvert #dotsdown #dotsvert ##
 a_{"n1"} # a_{"n2"} # dotsaxis #a_{"nm"}
 } 

a11 a12 ⋯ a1m

a21 a22 ⋯ a2m

⋮ ⋮ ⋱ ⋮
an1 an2 ⋯ anm

 sqrt{1x} = 1  x over 2  1 over 2 x^2 over 4  
dotslow 1− x=1−

x
2
−

1
2

x 2

4
−

 t= size +6 int from {r_0} to {r_t} size 8 {dr over 
sqrt {2 over %my [E_cm  V(r)]  l^2 over {
%my^2 r^2} } } t=∫

r 0

rt

dr

 2
my

[E cm−V  r ]− l2

my2 r 2

left ( stack{n # k} right ) = fact n over {fact k cdot 
fact (nk)} n

k = n!
k !⋅ n− k !

f(x) = left lbrace matrix {1# x in setZ ## 1 over x 
# x in setQ ##0 # x in setR } right none

f  x = { 1 x∈ℤ
1
x

x∈ℚ

0 x∈ℝ
[a;a_0,a_1,a_2,dotslow ] = a+{1 over {a_0+1 over 
{a_1+{1 over {a_2+1 over dotslow}}}}} [ a ; a0, a1, a2,]=a

1

a0
1

a1
1

a2
1
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OpenOffice.org 2.0 now allows to create forms based on the open W3C XForms standard. 
With XForms it is very easy to implement simple logic without any programming.
This simple example describes creation of a forms document which can be used to create and 
collect datasets of a predefined structure in order to exchange this data with other parties.

1. User creates a new document as shown above.
2. User adds form controls and lays out of the document. 
3. When layout is completed,, the user can start to work on the properties of the individual 

form controls. The first step is binding the controls to their respective counterparts in 
the instance data.

4. A submission control is added by the user. Normally the instance data is saved together 
with the document or to a linked instance. By using a submit button, the instance data 
can be sent to a server, to an email recipient or be saved to a file.

5. The user can now switch off designmode for use. Where the finished form is to be 
shared with others, the user should also set the form to open in usage mode by default.

StepbyStep Procedure
1. Start with File > New > XML Form Document as shown below:
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2. Then Use View > Toolbars and ensure that the Form Control and Form Design bars 
are checked.

Users may dock any that are floating.

OpenOffice.org User Guide for 2.x 436



Chapter 12: Building Forms with Xforms 

3. Ensure that Data Navigator is enabled as shown below.

4. Edit the form and add text boxes for those fields that are needed.
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5. Select one of the text boxes and rightclick to bring up the context menu. Select 
Control.
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6. Adf fix
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7. Use the Data Navigator that was mentioned earlier. Under the "Bindings" tab the 
defined bindings should be visible and the default model should be listed in the 
combo box on the left side of the "Models" button. In the Data Navigator pick a 
binding, do a rightclick and select edit: 
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8. In this dialogue, select the settings needed. For this example, these are Decimal as 
the Data Type and that data entry is mandatory.
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9. Now deselect Design mode so that the form may be tested in Run mode.

10. Enter data in the fields. Note in the graphic below, the red frame and the error 
message indicate that the fAMount fields is mandatory and must filled in:
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11. Because one usually wants to do something with the data from the form, it is 
important to add a "Submission". Therefore toggle back to the design mode, go to 
the Data Navigator again then click on the "Submission" tab and click the Add 
icon: 

12. Next, fill out the "Add Submission" dialogue as shown below. In this example 
data is simply saved to a file. Users may employ more complicated methods as suits 
requirements.
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13. Toggle Design On/Off to Off and test.

14. This graphic shows the content of the submit as stored in the files specified above.
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Using Xforms and further xml processing can thus produce very usable reports et cetera.
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Chapter 13: Xml Enhancements
This section contains hints and tips for using Tools > XML Filter Settings to create new 
filters. 

Flat XML filter
There are two different ways to get OpenOffice.org to output Flat Xml files:

1. Using the method from the SDK (See http://api.openoffice.org/ )

2. Using  Tools > XML Filter Settings
Outputting Flat XML files and importing them is fairly straight forward with the builtin tool. 
The following is a stepbystep procedure that will let one save and open flat XML files:

1. Click on  Tools > XML Filter Settings
2. Click on New 

3. Enter any settings as shown in the following illustrations:

OpenOffice.org User Guide for 2.x 446

http://api.openoffice.org/


Chapter 13: Xml Enhancements

4.
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5. Test the filter using the current document. BA display will open that provides  output 
similar to the following:

<?xml version="1.0" encoding="UTF8"?><office:document 
xmlns:office="urn:oasis:names:tc:opendocument:xmlns:offic
e:1.0" 
xmlns:style="urn:oasis:names:tc:opendocument:xmlns:style:
1.0" 
xmlns:text="urn:oasis:names:tc:opendocument:xmlns:text:1.
0" 
xmlns:table="urn:oasis:names:tc:opendocument:xmlns:table:
1.0" 
xmlns:draw="urn:oasis:names:tc:opendocument:xmlns:drawing
:1.0" 
xmlns:fo="urn:oasis:names:tc:opendocument:xmlns:xslfo
compatible:1.0" 
xmlns:xlink="http://www.w3.org/1999/xlink" 
xmlns:dc="http://purl.org/dc/elements/1.1/" 
xmlns:meta="urn:oasis:names:tc:opendocument:xmlns:meta:1.
0" 
xmlns:number="urn:oasis:names:tc:opendocument:xmlns:datas
tyle:1.0" 
xmlns:svg="urn:oasis:names:tc:opendocument:xmlns:svg
compatible:1.0" 
xmlns:chart="urn:oasis:names:tc:opendocument:xmlns:chart:
1.0" 
xmlns:dr3d="urn:oasis:names:tc:opendocument:xmlns:dr3d:1.
0" xmlns:math="http://www.w3.org/1998/Math/MathML" 
xmlns:form="urn:oasis:names:tc:opendocument:xmlns:form:1.
0" 
xmlns:script="urn:oasis:names:tc:opendocument:xmlns:scrip
t:1.0" 
xmlns:config="urn:oasis:names:tc:opendocument:xmlns:confi
g:1.0" xmlns:ooo="http://openoffice.org/2004/office" 
xmlns:ooow="http://openoffice.org/2004/writer" 
xmlns:oooc="http://openoffice.org/2004/calc" 
xmlns:dom="http://www.w3.org/2001/xmlevents" 
xmlns:xforms="http://www.w3.org/2002/xforms" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchemainstance" 
office:version="1.0" office:mimetype="application/x
vnd.oasis.openoffice.text">

 <office:meta>

  <meta:generator>OpenOffice.org/2.0$Linux 
OpenOffice.org_project/680m3$Build8968

  </meta:generator>

  <dc:title>Using Data Sources</dc:title>

  <meta:initialcreator>Ian 
Laurenson</meta:initialcreator>

...

6. Use Save As and select the Flat filter from the list.
Of course one needs to supply an XSLT file to provide the instructions needed to do the 
conversion. Here is a simple example  that  can be used and it is the the content of the file 
simple .xsl that was used above.:

<xsl:stylesheet version="1.0"

xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
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<xsl:stripspace elements="*"/>

<xsl:template match="/">

  <xsl:copyof select="."/>

</xsl:template>

<xsl:output method="xml" indent="yes"/>

</xsl:stylesheet>
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Creating a new Docbook Filter
• Go to Tools > XML Filter Settings...

• Set Filter Name and Name of File Type to DocBook (Chapter)
• Go to the Transformation tab

• Set DocType to <chapter>
• For XSLT for Export browse to the chapter export stylesheet 

(sofftodocbookheadings_chapter.xsl).
• For XSLT for Import browse to the chapter import stylesheet 

(docbooktosoffheadings.xsl).
• For Template for Import browse to the style template (DocBookTemplate.stw).

• Click OK and close the XSLT Filter Setting dialog

In the above list, the export and import stylesheets are swapped as follows:
• For XSLT for Export browse to the chapter stylesheet 

(sofftodocbookheadings_chapter.xsl).
• For XSLT for Import browse to the chapter stylesheet (docbooktosoffheadings.xsl).
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Error Message contains “Get Storage: "No Content"”
The full error message reads:
OpenOffice can not be started due to an error in accessing the 
OpenOffice.org configuration data.

Please contact your system administrato r. 

The following internal error has occurred: Get Storage:  "No Content" 

The reason this message often occurs is because there is a file called Common.xcu that 
sometimes gets corrupted. In most cases, it seems that this file sometimes ends up being 
filled with 0s and the problem seems to occur more often under Windows®, possibly as a 
result of a crash or improper exit while OpenOffice.org was open. 

Under Windows®
To locate this file under Windows®, it is easiest to use Windows® Explorer's Find function 
(sometimes called Search). 

Multiuser installations:
Where OpenOffice.org is installed as multiuser under Windows® NT/W2k/XP, this file is 
likely to be in a special system user directory. Therefore, having administrator rights and 
enabling the option to view system directories in Explorer is essential before using the Find 
function. This particular file should be found in 
C:\Documents and Settings\user\Application Data\OpenOffice.org<release>\<user>\regi
stry\data\org\openoffice\Office\Common.xcu where <user> is an actual user name and 
<release> is the release of OpenOffice.org. 
Once the file is located, simply rename the file (for example to something like 
Common.xcu.old). Now restart OpenOffice.org, a new Common.xcu is created and the 
problem should have disappeared. 

Singleuser installations:
Where OpenOffice.org is installed for a single user, this file is likely to be in 
C:\Program Files\OpenOffice.org<release>\<user>\registry\data\org\openoffice\Office
\Common.xcu where <user> is an actual user name and <release> is the release of 
OpenOffice.org.. However , if the OS is NT/W2k/XP,.this file could still be in a special 
system user directory. Therefore, having administrator rights and enabling the option to view 
system directories in Explorer is essential before using the Find function. For Windows® 
95/98/ME, the location should be as mentioned above.
Again, once the file is located, simply rename the file (for example to something like 
Common.xcu.old). Now restart OpenOffice.org, a new Common.xcu is created and the 
problem should have disappeared. 
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Note: that there may be files called Common.xcu under paths such as C:\<some 
path>\.OpenOffice.org<release>\share\registry\...... et cetera where <release> 
is the release of OpenOffice.org.. Do NOT delete these files!

UNIX systems
The default location of this file under a UNIX installation (single or multiuser) is $HOME/ 
.openoffice.org<release>/user/registry/data/org/openoffice/Office/Common.xc
u where $HOME is the user's home directory. As above, simply rename the file (for example 
to something like Common.xcu.old) and restart OpenOffice.org. A new Common.xcu is 
created and the problem should have disappeared. 

Outline numbering is not retained after a save.
This is issue 27534 which is fixed in release 1.1.4. However, in documents generated by 
OpenOffice.org1.1.0 up to 1.1.3, one must employ a workaround to achieve expected 
behaviour. The problem is that a line in “settings.xml.” is being set incorrectly when a 
document is saved. Unfortunately the only way to fix this is to manually edit the .sxw file.
The following provides a procedure to follow:
1. Make a temporary directory in which to unzip the .sxw file. For example, my_text.
2. Change into this directory.
3. Use unzip or similar zipfile utility to unpack the document file that is not retaining its 

numbering.
4. Edit settings.xml and locate the line in it that looks like the following:

<config:configitem config:name="UseOldNumbering" 
config:type="boolean">false</config:configitem>

5. Set the value from 'false' to 'true'.
6. Now using zip or similar utility, repack the files in the temporary directory under a new 

name and give it the .sxw extension. Under Linux the command could be:
zip r my_new_fixed_document.sxw *

7. Open the fixed document in OpenOffice.org and check that numbering is what is wanted.
If a copy of StarOffice 6.0 is available, one can get the same effect by opening and saving the 
document in StarOffice6.0. By doing so, this line will be removed totally. Likewise 
OpenOffice.org1.0 might also work. 
In either case , when the document is opened using OpenOffice1.1.x, the line, described 
above, is added with value 'true'; so that will be no further problems with outline 
“numbering.”
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How get the page count to not count a title page? 
Or How do I offset the page count?
If one has a title page or cover page in the document, Writer's "page count" field still counts 
those pages and will be too high. 
Unfortunately, there is no way tooffset the "page count" field. Thususing a formula, instead, 
will insert the proper page count. Here's the procedure: 

1. Place the cursor whereto insert the offset page count (perhaps in teh header). 
2. Press the F2 key to bring up the formula bar. Type in the formula "=page  1" (the 

"=" will already be in there). The "page" variable is the number of pages in the 
document, not the page currently selected. Subtract the number of pages that should 
not be counted in the page count (in this example, 1, for a title page). 

3. Press the Enter key to insert the formula. 
4. Choose Tools > Update > Fields from the menu (or press F9) to force the formula to 

refresh. (Otherwise, the page count formula will just be 0.) 
5. To edit this formula again later, place te cursor immediately before the formula, and 

press F2. 

Note: Every time the page count changes, refresh the formula again.

What to do when document prints or exports with blank pages 
This is issue is affected by the bookcentric paradigm of left/right, even/odd pages that is so 
deeply ingrained into OpenOffice.org that it applies even when using nothing but the 
Default page style.
1. Create a Title page style from Defaultor First Page.
2. Lay out the Title page however it needs to look .

3. Next, select Insert > Manual Break.. and specify Next Style as "First Page", 
numbered 1. This results in the phantom page which the following steps will correct. 

4. Select the Styles and Formatting window and modify the First page style layout to be 
"Left Only". 

5. The status bar will now show "Page 1 2/2", which is what is wanted. The page style 
following First Page is default and the page numbering will proceed without surprises 
from there.
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What to to do with a General error General input/output error 
This error message indicates that the files script.xlc and dialog.xlc, could 
bemissing or corrupted. Look for them in the directory 

$HOME/.openoffice.org2/user/basicunder *NIX 
or, under Windows ®

C:\Document and Settings\<username>\Application Data\OpenOffice.org<release>\user\basic.

To fix the problem, try exiting OpenOffice.org (including the Quickstarter, if any) and copy 
these from the directory <where_OOo_is_installed>/presets/basic/ under 
*NIX,
or, under 
Windows, from 

C:\Program Files\OpenOffice.org <release>\presets\basic 
to 

C:\Documents and Settings\<user name>\Application Data\OpenOffice.org 
<release>\user\basic 

Note: To be absolutely safe, one could also delete the local settings directory; however,. the penalty for doing this  
is that it is possible tolose all personal settings and customizations. 

How to recover content from a Openoffice.org file 
The following set of instructions may or may not work, depending on how bably damaged 
the file has become. The steps outlined assume the user has some basic technical skills as 
these are needed in this instance. Prerequisites for using this method are:

a) A zip utility such as Zip for most platforms or WinZip for Windows and similar tools
b) Sufficient disk space to allow multiple copies
c) Patience

Steps for recovering a damaged Openoffice.org file:
1. Make a backup of the file
2. Create a directory in which to work
3. Use the zip utility of your choice to open the damaged Openoffice.org file and unpack 

it into the directory created in step 2. 

NOTE: sometimes changing the extension of the Openoffice.org file to zip is required.

4. Use Openoffice.org to create a new empty file of the same type as the damaged one 
and save it.

5. Repeat Steps 2 and 3 with the new empty file.
6. Replace the contents.xml file in the directory created in Step 5 with the 

contents.xml from the damaged file unpacked in Step 3.
7. Use the zip utility to repackage the files and directories in the directory created in 

Step 6.
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8. Rename the new zipfile with the extension used with the original file.
9. Open the new file in Openoffice.org and fix any formatting problems including 

inserting graphics, Users can get these from the appropriate subdirectory of the 
directory created in Step 3.

10. If the contents is recovered using this method, cleanup.
11. Openoffice.org has a good recovery mechanism and users should ensure it is enabled 

by going to Tools > Options > Openoffice.org > Load/Save and enabling the 
following: 
a) Always create a backup
b) Save AutoRecovery information everyand select the interval from 

the spin box.

How to get sounds under Linux? 
NOTE: This section is under construction. Please use with caution.

Overview
OpenOffice.org 2.x, under Linux and possibly other *NIX variants, requires the Java Media 
Framework (JMF) to render media such as film and sound under Linux.
This section of the troubleshooting chapter will outline

● Installing the Java Media Framework (JMF) 

● Configuring the JMF under OpenOffice.org and making it usable 
● Installation of additional JMF Plugins that support further media types 

Windows® users employ Windows the “DirectShow” part of DirectX.

Starting
Get the following components:
Java run time Environment (JRE) 

The JRE is the basis for Media support in OpenOffice.org as well as Base. It is not 
necessary to use Sun's JRE as other JREs can employ the builtin “hook”,However non
Sun JREs may not implement the full Java API so should be tested..
Four different download formats are available. Choose the one that suites your OS and 
environment. All formats willunpack files. For example, if the system uses a RPMbased 
distribution, take the RPM package. Otherwise, take one of the other packages that is 
most suitable.

Java Media Framework (JMF) 
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The JMF provides the framework for rendering media in OpenOffice.org. Outofthebox, 
it supports only a limited set of media formats. Media types which are missing in the 
actual JMF can be added via Plugins.

JMF MP3 Plugin (optional) 
The MP3Plugin allows playing audio in MP3Format via JMF and, thus, with 
OpenOffice.org.

Jffmpeg  a codec pack for the JMF (optional) 
Jffmpeg is a codec pack, which extends the JMF to include many more  medium types. 
With Jffmpeg all of the FFmpeg project (libavcodec) supported medium types are 
playable.

Installing the JRE
Installation instructions are given when you select the download. See 
http://www.java.com/en/download/ 

Activating the JRE in OpenOffice.org
Once the JRE is installed, start OpenOffice.org and open Tools > Options > OpenOffice.org 
> Java dialogue which will look something like the following graphic.

Do wait a bit for OpenOffice.org to locate any installed JREs and list them. In the case where 
the JRE is installed in a location other than the standard location of /usr/java/, click the 
Add button and set the path to wherever the JRE is installed. The new JRE should now be 
listed in the dialogue.

Installating the JMF
1. Do review the License Agreement for the JMF. Where possible, install the 

Performance Pack. When, installing the software,execute all commands as the root 
user. Installation as a user limits use of the JMF to that user.
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2. Edit the soffice executable that is used to invoke OpenOffice.org (maybe 
/opt/openoffice.org2.0/program/soffice) and add the following near or at 

else
LD_LIBRARY_PATH="$sd_prog$add_moz_lib"

fi

so it looks like this:
else

LD_LIBRARY_PATH="$sd_prog$add_moz_lib:$JMFHOME/lib"
fi

remembering to substitute $JMFHOME with the path to where JMF is installed and save 
the file.

Integration of the JMF in OpenOffice.org 
Around the JMF to use to be able the file must be added jmf.jar to the Classpath of the 
Office. Select in addition in Extras|Optionen>OpenOffice.org>Java the Button “Class Path”. 
In the appearing dialogue select the switching surface “archives add”. Change into the sublist 
lib the JMF. Select jmf.jar and leave you the dialogues with “OK ONE”. Start 
OpenOffice.org again like it the message required.
The JMF not exclusively consists of Java components. At least with the performance pack 
some components are provided as native LIBRARies. The search path for the run time 
libraries must be adapted accordingly. In addition you must set the environment variable 
LD_LIBRARY_PATH. As is the case for the Classpath also the LD_LIBRARY_PATH is a 
list from path data by a colon from each other separated is.
The instruction looks as follows out:
$ export LD_LIBRARY_PATH=/pfad/zu/JMF2.1.1e/lib
Start now OpenOffice.org by means of soffice. If you made correct everything represent to 
Multimediainhalte in OOo no more problem.
They can transfer the instruction also to the soffice script, then you do not need to enter the 
instruction. Alternatively to it you can build it also into their other Startup/Login Skripte.
A first test
Over to test whether the installation of the JMF was so far successful starts you 
OpenOffice.org and opens an empty document. Open the Gallery (Extras|Gallery) and click 
you doubly on an entry from the range of “sounds”. The Media Player should appear and 
play the selected file.
 
If they hear the clay/tone, then “congratulations!”  the first hurdle is taken: )
(as example video you can e.g. invite motorcycle the video (~1.1MB) to use)
After all these steps you provided the basic structure. Already many audio and video formats 
function, should you however to support for further formats need, then you read on simply. 
Explained in the following sections like one the JMF “rigs”.
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Installation of an additional Plugins: The mp3Plugin
The JMF supported some medium types, many must be retooled however only. Simply to 
retool is the MP3Unterstützung. But there are already a Plugin which you by the JMF side 
downloaded can.
Download yourselves thus the mp3plugin of http://java.sun.com/products/java
media/jmf/mp3/download.html. The Plugin is driven out in form of Zip archives, which 
contain the actual files. Where you the mp3plugin unpack are for OpenOffice.org without 
meaning  for OOo only the “Class Path” attitude in the options counts. It is recommendable 
that you copy the Plugin into a listing lib/ext or directly into lib the listing of the JMF. 
Completely simply because one has then everything together which belonged together. They 
know the Plugin naturally also into the listing lib/ext the JRE to install. They have the agony 
of the choice. : )

Registration of the Plugins in the JMF
So that the mp3plugin in the JMF can be used, you must register the Plugin in the JMF.
For registration you implement the following steps:
Open a terminal window 
the environment variable CLASSPATH set, so that in it both jmf.jar and the mp3plugin.jar 
are indicated:
$ export CLASSPATH=/pfad/zu/jmf.jar: /pfad/zu/mp3plugin.jar
(The paths are separated by a colon) 
the actual registration command implement:
java com.sun.media.codec.audio.mp3.JavaDecoder 
For the conclusion of the registration you are to receive registered ones as only message 
succesfully. Every other message is an indication of an error.
Note: If you installed the JMF as “roots”, you must likewise register the Plugin as “roots”. 
Otherwise the configuration file of the JMF cannot be updated.
Here the procedure is held in a screen SHOT. Installed in this example the mp3plugin.jar as 
above mentioned into a Unterordner lib/ext the JMF.
 

Integration of the Plugins in OpenOffice.org
If you add the file mp3plugin.jar, how described with the installation of the JMF, the 
Classpath of OpenOffice.org in addition (Extras|Optionen>OpenOffice.org>Java, switching 
surface “Class Path”, then “adds archives”)
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Time for the second test
After you OpenOffice.org to havIntegration of the Plugins in OpenOffice.orge again started 
can test you now the MP3Unterstützung. Open in addition for the Mediaplayer over Extras|
Mediaplayer and open you a mp3Datei. The file should be played now.
Installation of a further Plugins: Jffmpeg
Now it becomes somewhat more complex. Still the JMF does not have a support for ogg or 
various video codecs. That is now changed. Load yourselves Jffmpeg from the side 
http://jffmpeg.sourceforge.net/download.html down (you follow the left “Jffmpeg down load 
PAGE”).
Jffmpeg consists of two parts: A JMF component and a system component. The JMF 
component supported not yet all formats libavcodec (FFMPEG) supported, the system 
component closes this gap and serves for it simply the normal system binaries to head for 
(formats support overview that of Jffmpeg). Load thus both down (both jffmpeg1.0.0.jar and 
libjffmpeg1.0.0.so). Again it is all the same in the reason where you the files stores, I 
recommends like also with the mp3plugin the sublist lib/ext the JMF
Note: Designate the file after libjffmpeg1.0.0.so libjffmpeg.so over, since them are 
otherwise not loaded.
Registration of the Plugins in the JMF
As the mp3Plugin must be announced also the Jffmpeg Plugin at the JMF. This is somewhat 
more complex than with the mp3Plugin, because the jffmpeg Plugin does not provide a 
registration function. The necessary attitudes must implement you by hand. That is to be 
created however no witch work and also from inexperienced users to: )
Around the Plugin to register you implement the following steps:
a terminal open 
the environment variable CLASSPATH set, so that in it archives jffmpeg1.0.0.jar are 
contained (archives jmf.jar are added automatically by the Program jmfregistry):
$ export CLASSPATH=/pfad/zu/jffmpeg1.0.0.jar 
the Program jmfregistry implement (is in the Unterordner are the JMF
/pfad/zu/jmfregistry 
Example:
$ CD ~/JMF2.1.1e/
$ export CLASSPATH=. /lib/ext/jffmpeg1.0.0.jar
$ ./bin/jmfregistry
In the program jmfregistry now the following attitudes must be transacted:
Add the following entries in the rider “MIME of type”:
video/vob>vob 
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audio/ogg>ogg 
 
Add the following entries in the rider “Plugins” under “Demultiplexer”
net.sourceforge.jffmpeg.demux.vob.VobDemux 
net.sourceforge.jffmpeg.demux.ogg.OggDemux 
 
Add the following entries in the rider “Plugins” under “codecs”
more net.sourceforge.jffmpeg.VideoDecoder 
more net.sourceforge.jffmpeg.AudioDecoder 
 
“Commit” do not forget to also always operate the Button!

Integration of the Plugins in OpenOffice.org
If you add the file jffmpeg1.0.0.jar the Classpath of OpenOffice.org, as described with the 
installation of the JMF (Extras|Optionen>OpenOffice.org>Java, switching surface “Class 
Path”, then “archives add”) 
Around all codecs of the Jffmpeg package to use to be able you must use the native 
component. In addition one must take up it to the LIBRARY Path also (naturally to have also 
the ffmpeg packages to be installed). Like one the path for run time libraries sets you already 
further above experienced (with the JMF installation). Add simply the path in addition in that 
you the native library (libjffmpeg.so) stored. If you have the Jffmpeg LIBRARY in the 
Unterordner lib/ext the JMF installed, then the instruction reads now
$ export LD_LIBRARY_PATH=/pfad/zu/JMF2.1.1e/lib: /pfad/zu/JMF2.1.1e/lib/ext
Again you have the possibility the path into OpenOffice.org  starting script or into your 
Loginskripte of registering.

Time for the third test
After a restart of OpenOffice.org you can test now the OGG support. Open in addition for the 
Mediaplayer over Extras|Mediaplayer and open you a ogg file. The file should be played 
now.
Note: If necessary you must be able to select the filter of type of file on “all files (*.*)” to 
place thereby you a ogg file.
Functioned that, then you created it. With the combination of JMF and ffmpeg you can play 
now (nearly) everything.
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What to do if it fails?
Only no panic, the problem can be surely solved. Turn to our mailing list 
users@openoffice.org. Consider the following references:
Use a meaningful reference 
Describe *genau* which you already tried. “Are proceeded like that as described in the 
guidance” is too inaccurate. Describe step by step which you where adjusted 
Describe with which action the problem arise 
If the problem concerns only certain files, send a left to the file with (in no case to the 
mailing list send the file!) 
Do not forget also the information to the used system (distribution, JRE version, etc.) 

How to open Microsoft Works Documents in OpenOffice.org 2.x
Matt Godfrey has contributed this workaround for Works users. 
After hours of tinkering, here is a free workaround to get .wps files into OpenOffice.org 2.x 
This has been tested and is working on Windows ®, XP and 2000, with OpenOffice.org 2.x. 
Please verify and report any success or problems to dev@documentation.openoffice.org for 
forwarding to the author. 
Here are the steps:

1. Download and install the free, as of 20060715, "Word Viewer 2003" from 
Microsoft

2. Download and install the free, as of 20060715, "Works 6.0 Converter for Works 
and Word Users" from  Microsoft.

3. Install both.

4. Start Microsoft Office Word Viewer 2003 from the Start > (All) Programs menu. 
5. An open dialogue appears. At the bottom of this dialogue ensure that the "Files of 

type" is set to "All Files(*.*)".
6. Now browse to your .wps file and select it
7. Click open. A warning dialogue will appear. If you trust this file et cetera, click yes 

and like magic your .wps will open!.
8. Select all > edit copy >.
9. Now open OpenOffice.org 2.x writer and do edit paste.
10. You should now be looking at your doc in OpenOffice.org 2.x.
11. Choose Save as from the file  menu and save your document to your preferred format. 

You are now good to go!
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Public Documentation License, Version 1.0
1.0 DEFINITIONS. 

1.1. "Commercial Use" means distribution or otherwise making the 
Documentation available to a third party. 

1.2. "Contributor" means a person or entity who creates or 
contributes to the creation of Modifications. 

1.3. "Documentation" means the Original Documentation or 
Modifications or the combination of the Original Documentation 
and Modifications, in each case including portions thereof.

1.4. "Electronic Distribution Mechanism" means a mechanism 
generally accepted for the electronic transfer of data. 

1.5. "Initial Writer" means the individual or entity identified as the 
Initial Writer in the notice required by the Appendix. 

1.6. "Larger Work" means a work which combines Documentation 
or portions thereof with documentation or other writings not 
governed by the terms of this License. 

1.7. "License" means this document. 

1.8. "Modifications" means any addition to or deletion from the 
substance or structure of either the Original Documentation or any 
previous Modifications, such as a translation, abridgment, 
condensation, or any other form in which the Original 
Documentation or previous Modifications may be recast, 
transformed or adapted.  A work consisting of editorial revisions, 
annotations, elaborations, and other modifications which, as a 
whole represent an original work of authorship, is a Modification.  
For example, when Documentation is released as a series of 
documents, a Modification is: 

A. Any addition to or deletion from the contents of the Original 
Documentation or previous Modifications. 

B. Any new documentation that contains any part of the Original 
Documentation or previous Modifications. 

1.9. "Original Documentation" means documentation described as 
Original Documentation in the notice required by the Appendix, and 
which, at the time of its release under this License is not already 
Documentation governed by this License. 

1.10. "Editable Form" means the preferred form of the 
Documentation for making Modifications to it. The Documentation 
can be in an electronic, compressed or archival form, provided the 
appropriate decompression or de-archiving software is widely 
available for no charge. 

1.11. "You" (or "Your") means an individual or a legal entity 
exercising rights under, and complying with all of the terms of this 
License or a future version of this License issued under Section 5.0 
("Versions of the License"). For legal entities, "You" includes any 
entity which controls, is controlled by, or is under common control 
with You. For purposes of this definition, "control" means (a) the 
power, direct or indirect, to cause the direction or management of 
such entity, whether by contract or otherwise, or (b) ownership of 
more than fifty percent (50%) of the outstanding shares or 
beneficial ownership of such entity.

2.0 LICENSE GRANTS. 

2.1  Initial Writer Grant. 

The Initial Writer hereby grants You a world-wide, royalty-free, 
non-exclusive license to use, reproduce, prepare Modifications of, 
compile, publicly perform, publicly display, demonstrate, market, 
disclose and distribute the Documentation in any form, on any 
media or via any Electronic Distribution Mechanism or other 
method now known or later discovered, and to sublicense the 
foregoing rights to third parties through multiple tiers of 
sublicensees in accordance with the terms of this License.  

The license rights granted in this Section 2.1 ("Initial Writer Grant") 
are effective on the date Initial Writer first distributes Original 
Documentation under the terms of this License. 

2.2. Contributor Grant. 

Each Contributor hereby grants You a world-wide, royalty-free, 
non-exclusive license to use, reproduce, prepare Modifications of, 
compile, publicly perform, publicly display, demonstrate, market, 
disclose and distribute the Documentation in any form, on any 
media or via any Electronic Distribution Mechanism or other 
method now known or later discovered, and to sublicense the 
foregoing rights to third parties through multiple tiers of 
sublicensees in accordance with the terms of this License.  

The license rights granted in this Section 2.2 ("Contributor Grant") 
are effective on the date Contributor first makes Commercial Use of 
the Documentation. 

3.0 DISTRIBUTION OBLIGATIONS. 

3.1. Application of License.

The Modifications which You create or to which You contribute are 
governed by the terms of this License, including without limitation 
Section 2.2 ("Contributor Grant").  The Documentation may be 
distributed only under the terms of this License or a future version 
of this License released in accordance with Section 5.0 ("Versions 
of the License"), and You must include a copy of this License with 
every copy of the Documentation You distribute. You may not offer 
or impose any terms that alter or restrict the applicable version of 
this License or the recipients' rights hereunder. However, You may 
include an additional document offering the additional rights 
described in Section 3.5 ("Required Notices"). 

 3.2. Availability of Documentation.

Any Modification which You create or to which You contribute must 
be made available publicly in Editable Form under the terms of this 
License via a fixed medium or an accepted Electronic Distribution 
Mechanism. 

3.3. Description of Modifications.
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All Documentation to which You contribute must identify the 
changes You made to create that Documentation and the date of any 
change. You must include a prominent statement that the 
Modification is derived, directly or indirectly, from Original 
Documentation provided by the Initial Writer and include the name 
of the Initial Writer in the Documentation or via an electronic link 
that describes the origin or ownership of the Documentation.  The 
foregoing change documentation may be created by using an 
electronic program that automatically tracks changes to the 
Documentation, and such changes must be available publicly for at 
least five years following release of the changed Documentation. 

3.4. Intellectual Property Matters.

Contributor represents that Contributor believes that Contributor's 
Modifications are Contributor's original creation(s) and/or 
Contributor has sufficient rights to grant the rights conveyed by this 
License.

3.5. Required Notices.

You must duplicate the notice in the Appendix in each file of the 
Documentation. If it is not possible to put such notice in a particular 
Documentation file due to its structure, then You must include such 
notice in a location (such as a relevant directory) where a reader 
would be likely to look for such a notice, for example, via a 
hyperlink in each file of the Documentation that takes the reader to 
a page that describes the origin and ownership of the 
Documentation.  If You created one or more Modification(s) You 
may add your name as a Contributor to the notice described in the 
Appendix. 

You must also duplicate this License in any Documentation file (or 
with a hyperlink in each file of the Documentation) where You 
describe recipients' rights or ownership rights. 

You may choose to offer, and to charge a fee for, warranty, support, 
indemnity or liability obligations to one or more recipients of 
Documentation. However, You may do so only on Your own behalf, 
and not on behalf of the Initial Writer or any Contributor. You must 
make it absolutely clear than any such warranty, support, indemnity 
or liability obligation is offered by You alone, and You hereby agree 
to indemnify the Initial Writer and every Contributor for any 
liability incurred by the Initial Writer or such Contributor as a result 
of warranty, support, indemnity or liability terms You offer. 

 3.6.  Larger Works.

You may create a Larger Work by combining Documentation with 
other documents not governed by the terms of this License and 
distribute the Larger Work as a single product. In such a case, You 
must make sure the requirements of this License are fulfilled for the 
Documentation.

4.0  APPLICATION OF THIS LICENSE. 

This License applies to Documentation to which the Initial Writer 
has attached this License and the notice in the Appendix.

5.0  VERSIONS OF THE LICENSE. 

5.1. New Versions.

Initial Writer may publish revised and/or new versions of the 
License from time to time. Each version will be given a 
distinguishing version number. 

5.2. Effect of New Versions.

Once Documentation has been published under a particular version 
of the License, You may always continue to use it under the terms of 
that version. You may also choose to use such Documentation under 
the terms of any subsequent version of the License published 
by______________________ [Insert name of the foundation, 
company, Initial Writer, or whoever may modify this License]. No 
one other than ________________________[Insert name of the 
foundation, company, Initial Writer, or whoever may modify this 
License] has the right to modify the terms of this License. Filling in 
the name of the Initial Writer, Original Documentation or 
Contributor in the notice described in the Appendix shall not be 
deemed to be Modifications of this License.

6.0 DISCLAIMER OF WARRANTY. 

DOCUMENTATION IS PROVIDED UNDER THIS LICENSE ON 
AN "AS IS'' BASIS, WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT 
LIMITATION, WARRANTIES THAT THE DOCUMENTATION 
IS FREE OF DEFECTS, MERCHANTABLE, FIT FOR A 
PARTICULAR PURPOSE OR NON-INFRINGING. THE ENTIRE 
RISK AS TO THE QUALITY, ACCURACY, AND 
PERFORMANCE OF THE DOCUMENTATION IS WITH YOU. 
SHOULD ANY DOCUMENTATION PROVE DEFECTIVE IN 
ANY RESPECT, YOU (NOT THE INITIAL WRITER OR ANY 
OTHER CONTRIBUTOR) ASSUME THE COST OF ANY 
NECESSARY SERVICING, REPAIR OR CORRECTION. THIS 
DISCLAIMER OF WARRANTY CONSTITUTES AN 
ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY 
DOCUMENTATION IS AUTHORIZED HEREUNDER EXCEPT 
UNDER THIS DISCLAIMER.

7.0 TERMINATION. 

This License and the rights granted hereunder will terminate 
automatically if You fail to comply with terms herein and fail to 
cure such breach within 30 days of becoming aware of the breach. 
All sublicenses to the Documentation which are properly granted 
shall survive any termination of this License. Provisions which, by 
their nature, must remain in effect beyond the termination of this 
License shall survive. 

8.0 LIMITATION OF LIABILITY. 

UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL 
THEORY, WHETHER IN TORT (INCLUDING NEGLIGENCE), 
CONTRACT, OR OTHERWISE, SHALL THE INITIAL WRITER, 
ANY OTHER CONTRIBUTOR, OR ANY DISTRIBUTOR OF 
DOCUMENTATION, OR ANY SUPPLIER OF ANY OF SUCH 
PARTIES, BE LIABLE TO ANY PERSON FOR ANY DIRECT, 
INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL 
DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT 
LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK 
STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR 
ANY AND ALL OTHER DAMAGES OR LOSSES ARISING 
OUT OF OR RELATING TO THE USE OF THE 
DOCUMENTATION, EVEN IF SUCH PARTY SHALL HAVE 
BEEN INFORMED OF THE POSSIBILITY OF SUCH 
DAMAGES. 

9.0 U.S. GOVERNMENT END USERS. 

If Documentation is being acquired by or on behalf of the U.S. 
Government or by a U.S. Government prime contractor or 
subcontractor (at any tier), then the Government's rights in 
Documentation will be only as set forth in this Agreement; this is in 
accordance with 48 CFR 227.7201 through 227.7202-4 (for 
Department of Defense (DOD) acquisitions) and with 48 CFR 
2.101 and 12.212 (for non-DOD acquisitions).

10.0 MISCELLANEOUS. 
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This License represents the complete agreement concerning the 
subject matter hereof. If any provision of this License is held to be 
unenforceable, such provision shall be reformed only to the extent 
necessary to make it enforceable. This License shall be governed by 
California law, excluding its conflict-of-law provisions. With 
respect to disputes or any litigation relating to this License, the 
losing party is responsible for costs, including without limitation, 
court costs and reasonable attorneys' fees and expenses. The 
application of the United Nations Convention on Contracts for the 
International Sale of Goods is expressly excluded. Any law or 
regulation which provides that the language of a contract shall be 
construed against the drafter shall not apply to this License.

Appendix 

Public Documentation License Notice 

The contents of this Documentation are subject to the Public 
Documentation License Version 1.0 (the "License"); you may only 
use this Documentation if you comply with the terms of this 
License. A copy of the License is available at 
http://www.openoffice.org/licenses/PDL.rtf. 

The Original Documentation is _________________. The Initial 
Writer of the Original Documentation is ______________________ 
(C) ____. All Rights Reserved. (Initial Writer 
contact(s):_______________[Insert hyperlink/alias].)

Contributor(s): ______________________________________. 

Portions created by ______ are Copyright (C)_________[Insert 
year(s)]. All Rights Reserved.   (Contributor 
contact(s):________________[Insert hyperlink/alias]).

Note: The text of this Appendix may differ slightly from the text of 
the notices in the files of the Original Documentation. You should 
use the text of this Appendix rather than the text found in the 
Original Documentation for Your Modifications.

OpenOffice.org User Guide for 2.x 474

http://www.openoffice.org/licenses/PDL.rtf

	Overview
	Using the Guide

	Important Features with 2.x
	Open Standards XML File Format (OASIS OpenDocument)
	New Multi-pane View
	New CustomShapes (compatible with Microsoft AutoShapes)
	More Slide Transitions and Animation Effects
	Enhanced PDF Export
	New enhanced Database Features
	Mail Merge Wizard
	Enhanced Word Count Feature
	Support for Nested Tables
	Digital Signatures Support
	XForms Support
	WordPerfect® Filters
	Calc now has 65,536 Rows
	Enhanced DataPilot Support
	Native Installers
	Native Desktop Integration
	Floating Toolbars
	Style Paint Brush
	Quickstarter for *NIX Operating Systems
	Multiple Language Support
	New Charting Module

	Chapter 1: Using OpenOffice.org Help
	OpenOffice.org Step-by-Step Help
	Tips
	Turning tips on and off
	Extended Tips
	Turning extended tips on and off


	Help Agent
	Turning the Help Agent on and off


	Chapter 2: Working With OpenOffice.org
	The User Interface
	Starting OpenOffice.org
	The OpenOffice.org Writer Window
	Toolbars in the OpenOffice.org Window
	The Title Bar
	The Menu Bar
	The Toolbars
	Examples of Floating Toolbars
	Using Floating Toolbars
	The document window
	Docking toolbars
	Docking windows
	Changing the Visibility of Buttons on Toolbars

	Opening and Saving Documents
	Opening Documents

	Saving Documents
	Changing the Work Directory
	Saving Documents Automatically
	Backup a File Automatically
	Saving Recovery Information Automatically Every 'n' Minutes


	OpenOffice.org File Formats
	XML file format names
	OpenOffice.org XML file structure
	Definition of the XML formats
	Setting Tabstops

	Sending Documents as E-Mail
	Single Messages
	MailMerge

	Printing Documents
	Displaying Print Previews
	Reduced Printing of Documents
	To print two pages beside one another on one sheet of paper

	Printing in Black and White
	Printing text and graphics in black and white
	Printing all Draw and Impress documents in black and white
	Printing only text in black and white
	Printing all Writer documents with black and white text
	Printing the current Writer document with black and white text


	Printing Brochures

	Spellcheck
	Automatic Spellcheck
	Checking Multilingual Texts
	Starting Spellcheck
	Excluding Text From the Spellcheck


	Adding Writing Aids for Other Languages
	Getting New Writing Aids

	Using Automatic Functions
	Using AutoCorrect and AutoFormat
	Turning off URL Recognition by AutoCorrect
	Undo URL recognition
	Turn off URL recognition

	Other AutoCorrect functions

	Creating a Letter Template With the Wizard
	Find & Replace
	Finding a Word in Text
	Searching for Whole Words Only
	Match Case
	Searching for Text With Wildcards
	Searching Backward
	Current Selection Only
	Searching for Styles
	Searching for Text Attributes
	Searching for Special Formats 
	Similarity Search

	List of Regular Expressions

	Digital Signatures and Printing or Exporting Documents
	Only “open password”, no restriction
	“open password”, restricted
	Permission restricted only
	PDF without restriction (Default behaviour)

	Permissions available
	Printing
	Changes
	Enable copy
	Enable accessibility
	Programming PDF Security in Macros 


	Chapter 3: Managing Text Documents With Writer 
	The OpenOffice.org Writer Functions
	Writing
	Designing and Structuring
	Desktop Publishing with OpenOffice.org Writer
	Calculations
	Creating Drawings
	Inserting Graphics
	Customizable Program Interface
	Drag&Drop
	Extensive Help Functions

	The OpenOffice.org Writer Window
	Windows® of OpenOffice.org Writer

	Entering and Formatting Text
	Entering New Text
	To enter new text:
	Line breaks
	Automatic correction
	Word completion

	Inserting Text
	Switching Between Insert Mode and Overwrite Mode
	Using the keyboard:
	Using the mouse:

	Entering Text Anywhere on a Page
	Selecting and Deleting Text
	Deleting characters
	Deleting text
	Selecting text to delete with the mouse
	Selecting text to delete with the keyboard
	Deleting non-adjacent pieces of text.

	Status bar uses
	Setting the Viewing Zoom Factor
	Editing or Activating Hyperlinks


	Applying Various Fonts 
	Keyboard Navigating and Selection in Writer
	Inserting Special Characters
	Inserting Protected Spaces, Hyphens and Conditional Separators
	Non-breaking spaces
	Non-breaking hyphen
	Hyphen, em-dash and en-dash
	Manual Hyphenation

	Emphasizing Text
	Changing the colour of Text
	Rotating Text
	Defining Borders
	Choose Format from the menu bar, Borders tab page
	Use the Borders floating toolbar with Tables

	Superscripts and Subscripts
	Applying subscripts/superscripts retrospectively

	Writing in Uppercase or Lowercase
	Moving Text Sections in Documents
	Resetting Font Attributes While Typing
	Example procedure for resetting Font Attributes

	Quick Formatting Using the Adjacent Paragraph Format
	Using Sections
	Sections and Columns
	Inserting Sections
	Editing Sections

	Formatting Text With and Without Styles
	Direct Formatting or Formatting With Styles

	The Style Concept in OpenOffice.org
	The Styles in the Styles and Formatting Window
	Paragraph Styles
	Paragraph Style.
	Character Styles
	Hierarchical Styles
	Numbering Styles 
	Creating New Character Styles or Paragraph Styles
	Creating Document Templates
	The Advantages of the Styles and Formatting Window
	Formatting Multiple Paragraphs
	Changing a Style the Easy Way
	Page Styles and Page Numbers
	Create Page Styles
	Editing Page Styles
	Page Breaks as Paragraph Formats
	Changing the Format of Page Numbers
	Page Styles Summary


	Defining default Templates
	Templates and Styles
	Copying Styles Between Templates and Documents
	New Style from Selection
	Transferring Formats With Fill Format Mode
	Updating Styles From Selections
	This is how to update a Style:
	Style can also be updated by using drag and drop:

	Entering and Formatting Text Automatically
	Disabling the AutoCorrect Function
	ASCII Quotation marks are replaced with Custom Quotes
	Sentences always begin with a capital letter
	Three identical characters will become a whole line


	Automatic Spellcheck
	To exclude words from Spellcheck

	Using AutoText
	Defining AutoText
	Using AutoText in Networks
	Printing AutoTexts

	AutoText With AutoComplete
	Exceptions in AutoCorrect
	Example


	Text Frames
	Inserting, Editing and Linking Text Frames
	Inserting Text Frames
	Editing Text Frames
	Linking Text Frames


	Using Text Animation
	Drawing Lines in Text
	Editing Text With FontWork
	Aligning Text With Lines
	Aligning text on a free form line

	Aligning text with straight lines
	The Navigator
	Jumping From One Object to Another in Text
	Jumping to a Specific Page
	Chapters in Navigator

	Indexes and Tables of Contents in Writer
	Defining Index/Table of Contents Entries
	Editing or Deleting Index and Table Entries
	Creating a Table of Contents
	Creating Alphabetical Indexes
	Creating User-Defined Indexes
	Using a Concordance File
	Preparation
	Entering Data
	Example file

	Creating Bibliographies
	Updating, Editing and Deleting Indexes and Tables of Contents
	Editing the Format of an Index/Table of Contents
	Indexes Covering Multiple Documents

	Headings and Numbering
	Numbering and Numbering Styles
	Turning Bullets On and Off
	Turning Numbering On and Off
	Example numbered list with sublevels:

	Outline Numbering
	Automatic Bullets and Numbering
	Numbering Illustrations by Chapters
	Defining Number Ranges

	Using Master Documents and Subdocuments
	Importing Lists From Other Text Programs
	Changing Numbering via the Keyboard

	Interrupting and Continuing Numbering
	Delete the automatic numbering
	Formatting the paragraph
	Continuing numbering with a new starting value

	Numbering Lines
	Line Numbering for All Paragraphs
	Line Numbering for Particular Paragraphs

	Tables in Text
	Inserting Tables
	Inserting an empty table using the mouse:
	Inserting an empty table via the Insert menu or floating toolbar:
	Inserting a single row table by typing ++... or ||...
	Inserting from OpenOffice.org Calc with the clipboard
	Inserting from OpenOffice.org Calc using drag-and-drop

	Deleting Tables
	Inserting Paragraphs Before Tables at Start of Page
	Resize columns, rows, and cells
	Table AutoFormat
	Table properties in general


	Calculating in Text Documents
	Formulae in Text Documents
	Formula Options
	Basic Calculation Functions
	Basic Functions in the Submenu
	Operators
	Statistical Functions
	Trigonometric Functions 
	More Defined Values


	Calculating in Text
	Calculating With formulae Located in Text
	Conditional Text
	Defining and using conditional text – by example
	Defining a conditional variable

	Type “Reminder” in the document, and then add space.
	Defining a condition and the conditional text:

	Displaying the conditional text:

	Calculating in Text Document Tables
	Calculating Across Multiple Tables
	Calculating Cell Totals in Tables
	Merging and Splitting Cells
	Merging Cells in OpenOffice.org Writer
	Splitting Cells in OpenOffice.org Writer
	Merging Cells in OpenOffice.org Calc OLE Objects
	Cancelling the merging of cells in OpenOffice.org Calc OLE Objects

	Inserting or Deleting Rows/Columns Using the Keyboard
	Repeating Multiple Heading Rows in a Table
	Enlarging and Reducing Cells in Text Tables
	Adapting Table Widths

	Images, Drawings, Clipart and FontWork
	Positioning Objects
	Captions and Number Ranges
	Defining Captions
	Editing or deleting captions
	Inserting an object in a number range

	Numbering Illustrations by Chapters
	Inserting Graphics
	Inserting Graphics via dialogue
	Inserting Graphics From OpenOffice.org Draw or Impress
	Inserting Graphics via Drag and Drop From the Gallery
	Adding Graphics To the Gallery via Drag and Drop
	Inserting Graphics With a Scanner

	Inserting a Chart From OpenOffice.org Calc
	Dragging and Dropping the Chart with Move or Copy
	Charts with Linked Data

	Inserting Decorative Horizontal Lines

	Headers, Footers and Footnotes
	Some Notes Concerning Headers and Footers
	Inserting Page Numbers in Footers
	Formatting Headers and Footers
	Defining Different Headers
	Inserting Page Numbers of Continuation Pages
	Inserting Lines Under Headers
	Footnotes and Endnotes
	Inserting and Editing Footnotes
	Inserting a footnote via an icon
	Inserting a footnote via a dialogue
	Tips for Working with Footnotes

	Spacing Between Footnotes

	Spellcheck, Dictionaries, Hyphenation
	Controlling Spellcheck via the dialogue
	Automatic Spellcheck
	To exclude words from the Spellcheck:

	Removing Words From User-Defined Dictionaries
	Hyphenation
	Automatic hyphenation
	Manual Hyphenation

	Thesaurus

	Form Letters, Business Cards and Labels
	Creating Form Letters
	Brief Instructions (For Quick Results)
	Fixed and Variable Fields

	Creating and Printing Labels and Business Cards
	Designing Business Cards via dialogue
	Designing Labels and Business Cards
	Printing Labels With Serial Numbers
	Printing Address Labels

	Avoiding Blank Paragraphs

	Newsletters
	Creating a Newsletter From a Template
	Creating Page Styles
	Editing Headers
	Editing Columns
	Editing Paragraph Styles
	Working with Frames
	Formatting a Frame 
	Anchoring Frames
	Defining a Frame Wrap 

	Defining a Wrap Region 
	Using coloured or Graphic Backgrounds 
	Creating a Table of Contents 
	Further Information
	Using Automatic Hyphenation


	Letters With Envelopes
	Using a Ready-Made Letter Template
	Creating a Letter Template Using the Wizard
	Creating an Envelope Template
	Inserting an Envelope into a Document
	Adjusting the Printer for the Printout 

	Creating and Printing a Letter With an Envelope
	Creating an Single Envelope
	Adding a POSTNET Bar Code to an Envelope
	Get a POSTNET font
	Building a Complete POSTNET Bar Code for Printing


	Adding More Languages to OpenOffice.org
	Setting Text Language
	Adding More Text Languages
	Setting UI Language

	Adding Multiple Language Support using Language Packs

	Chapter 4: Spreadsheets in Calc
	Overview of the Functions in Calc
	Calculating
	Database Functions
	Arranging Data
	Examining and Extrapolating Data
	What-If Calculations
	Dynamic Charts
	Importing and Exporting Data
	Importing into Calc
	Exporting from Calc

	Referencing Data in Networks and the Internet

	The Calc Window 
	Structure of a Spreadsheet
	Rows and Columns
	Multiple Sheets in a Document
	Inserting Sheets
	Renaming Sheets


	Values and Formulae as Cell Contents
	Calculating in Spreadsheets
	Using Built-in Functions
	A Short Description of What Cells Can Contain
	Text
	Numbers

	Calculating With formulae
	Calculating With Dates and Times
	Inserting and Editing Notes

	Handling Multiple Sheets
	Displaying Multiple Sheets
	Working With Multiple Sheets
	Printing Spreadsheets

	Formatting a Spreadsheet
	Formating Numbers
	Dates

	Formatting Cells and Sheets
	Using AutoFormat for Tables

	Layout of Spreadsheets
	Designing Spreadsheets Clearly
	Formatting Text in a Spreadsheet
	Formatting Numbers in a Spreadsheet
	Formatting Borders and Backgrounds for Cells and Pages

	Addressing Cells
	Addresses and References, Absolute and Relative
	Relative Addressing
	Absolute Addressing 
	When to Use Relative and Absolute References

	Addressing by Name
	Recognizing Names as Addressing
	Only Copy Visible Cells
	Referencing a Cell in Another Document

	Using References in formulae
	References to Other Sheets

	Using Charts
	Editing Chart Titles
	Editing Chart Legends
	Adding Texture to Chart Bars
	Editing Chart Axis

	Database Functions in Calc
	Defining Database Ranges
	Creating Records in a Spreadsheet
	Defining Database Ranges
	Sorting Database Ranges
	Filtering Database Ranges
	Grouping Database Ranges and Calculating Subtotals
	Transferring Data From a Data Source to a Spreadsheet
	Opening a Database File in Calc


	Evaluating Data With Calc
	DataPilot
	What use is the DataPilot?
	Creating DataPilot Tables
	Selecting DataPilot Output Ranges
	Editing DataPilot Tables
	Filtering DataPilot Tables
	Updating DataPilot Tables
	Deleting DataPilot Tables

	Consolidating Data
	Applying Goal Seek
	Naming Cells
	Start Goal Seek
	Applying Multiple Operations
	Multiple Operations in Columns or Rows
	Examples
	Calculating With One Formula and One Variable
	Calculating with Several formulae Simultaneously

	Multiple Operations Across Rows and Columns
	Calculating with Two Variables


	Using Scenarios
	Using Ready-Made Scenarios
	Creating Personal Scenarios

	Validity of Cell Contents
	Using Cell Contents Validity
	Sample macro:

	Printing or Exporting Spreadsheets
	Printing Sheet Details
	Defining Number of Pages for Printing
	Printing Sheets in Landscape Format
	Printing Rows or Columns on Every Page

	Saving and Opening Sheets in HTML
	Saving Sheets in HTML
	Opening Sheets in HTML

	formulae and Values as CSV Files
	Exporting formulae and Values as CSV Files
	Importing a CSV File

	AutoFill
	Applying Sort Lists
	Automatic Row Filling
	Protecting Sheets
	Creating a Reference
	Further Information
	Inserting a note 
	Inserting a sheet into another document 
	Displaying formulae 
	Using print ranges 
	Freezing Columns
	Splitting a Calc Window
	Conditional Formatting
	Defining Validity
	Creating Input Help
	Linking Sheet Information


	Chapter 5: Creating Presentations With Impress
	OpenOffice.org Impress Toolbars and Windows®
	How to Create a Basic Presentation
	Creating a Presentation With the Wizard
	Creating a Simple Presentation Without the Wizard
	Switching Presentation Views
	Arranging Slides
	Incorporating Slide Show Effects
	In-Slide Effects

	Showing a Presentation

	Editing Presentations
	Defining Background colours
	Switching Page Styles
	Presentation Styles

	Using Outline View
	Slide Transitions, Effects and Animation
	Automatic Slide Transition
	Effects for Objects
	Selecting Hidden Objects
	Individual Presentations

	Exporting, Printing and Presenting
	Printing a Presentation Slide
	Exporting Presentations as Web Pages
	Exchanging Data via the Clipboard

	Creating a Business Report
	Creating a Business Report in Presentation Form
	Entering Text in the Outline View
	Changing the Slide Layout
	Designing Slides

	Creating a Slide Show
	Defining or Changing Slide Order
	Creating Cross-Fade Effects 
	Starting Presentations 

	Working with Connectors
	"Edge to Edge” Connectors
	"Middle to Middle” Connectors
	Editing Connectors
	Using a Snap Grid 
	Editing Glue Points 

	Hints and Tips for a Successful Presentation
	Using the Mouse as a Pointer
	Changing Bullet Symbols in Outline View
	Inserting, Deleting and Renaming Slides
	Creating and Printing Handouts
	Organizing and Printing Notes
	Using the Navigator
	Edit Jump Targets
	Modifying Object Size
	Creating Additional Objects 
	Changing Font and Font Size 
	Modifying colours 
	Keyboard Navigating and Selection in Impress


	Chapter 6: Creating Drawings with Draw
	OpenOffice.org Draw Functions
	Creating and Publishing Vector Graphics
	Creating 3D Objects
	Manage Organization Charts
	Drawing
	Export
	Construct
	Integrate

	The OpenOffice.org Draw Window
	Toolbars and Windows® in OpenOffice.org Draw
	Drawing Rectangles and Ellipses and Entering Text
	Rotating and Resizing Objects

	Arranging and Aligning Objects
	Arranging Objects
	Aligning Objects
	Drawing Sectors and Segments
	Entering Text
	Normal Text
	Fitting Text to Frames
	Callouts
	Converting Text Into 3D

	Drawing, Editing and Converting
	Curves and Objects
	Drawing Curves

	Editing Curves
	Vectorizing Bitmaps
	Converting Text Characters to Curves
	Converting to Curves, Polygons, 3D

	Working With Objects
	Duplicating Objects
	Cross-Fading Between Two Objects
	Grouping Objects 
	Entering Groups
	Exiting Groups
	Navigating Between Objects of a Group


	Combining Objects and Constructing Shapes
	Combining Objects
	Constructing Shapes
	Shapes - Merge
	Shapes - Subtract


	Graphic Objects in Drawings and Presentations
	Inserting Bitmaps
	Editing Bitmaps
	Applying Text to Bitmaps

	Saving Bitmaps

	Working With colours
	The colour Bar
	Defining Custom colours
	Replacing colours using the Eyedropper

	Gradients and Patterns for Objects and Background
	Defining Gradients
	Defining a custom colour Gradient
	Interactively Defining a colour Gradient
	Organizing the Attribute Tables

	3D Globe
	Creating Texture on a 3D Object
	Using Illumination
	More 3d Effects
	3D Effects: Favourites
	3D Effects: Geometry
	3D Effects: Shading
	3D Effects: Illumination
	3D Effects: Textures and Material 


	Designing 3D Objects From Font Characters
	First Step:
	Second Step:
	Third Step: 
	Fourth Step:
	Fifth Step:
	Using a Grid

	Mechanical or Construction Drawings
	Creating a Construction Plan
	Using Snap Lines

	Using Dimension Lines
	Working With Multiple Layers
	Using One colour per Layer


	Chapter 7: Databases and Data Sources
	Creating a database file
	Creating a table
	Creating a related table
	Creating a relationship between tables
	Creating a data entry form
	Making data entry easier
	Modifying a date field
	Adding a list box to a form
	Adding a combo box to a form
	Changing the tab order of a form

	Viewing Data
	 Copying the form
	Changing the form's properties
	Setting a sort order for a form

	Creating a query to find today's appointments
	Add a sort order to the query
	Changing the Join type in the query

	Creating a report
	Some tips for using the Calendar database
	Adding data to a related table
	Open the form for the related table
	Open the Data Sources window
	Refreshing the form

	Filtering Data

	Registering a Data Source
	Connecting to other types of databases
	Address Books
	Registering an Address Book
	Using the Wizard to import an Address Book 
	Manually Registering an Existing Address Book 
	System Address Book as Data Source
	Importing and Exporting Data in Text Format
	Exporting in CSV Text Format

	Form Design
	Forms in OpenOffice.org
	Available controls
	Customizing controls
	Creating a group of option buttons

	Do any other controls have an wizard?
	Attaching a data source to a form
	Associating data with a field
	Activating form controls in a document
	How to use the form


	Searching in Tables and Form Documents 
	Searching With a Form Filter 
	Operators
	Commands 



	Chapter 8: Customizing OpenOffice.org
	Modifying and Customizing the User Interface of OpenOffice.org
	Configuring the Keyboard
	Configuring Menus
	Changing Toolbars
	Inserting, Moving and Deleting Icons on Toolbars
	Changing Icon Views

	Changing the Look of the User Interface
	Selecting Measurement Units
	Moving, Deleting or Copying Icons

	Sending Faxes and Configuring OpenOffice.org for Faxing
	Creating a LAN Friendly Faxing Solution under Linux
	Creating a LAN Friendly Faxing Solution under Windows
	Sending a Fax via dialogue
	Configuring OpenOffice.org for Faxing via Icon

	Further Information

	Chapter 9: Advanced Techniques
	Copying and Moving Data Using Drag and Drop
	Dragging and Dropping Within a OpenOffice.org Document
	Inserting Objects From the Gallery
	Inserting an object as a copy
	Inserting an object as a link
	Inserting an object as a background graphic
	Inserting an object as a texture (pattern) for another object

	Copying Graphics From the Gallery
	Inserting Graphics From a Document in the Gallery
	Copying Graphics Between Documents
	Copying Draw Objects into Other Documents
	Inserting a Draw object in a text document
	Inserting a Draw object in a spreadsheet

	Drag and Drop With the Data Source View
	Using data in a text document
	Applying data to a table document
	Inserting controls in a text form

	Copying Sheet Areas to Text Documents
	Inserting Data From Spreadsheets
	Inserting Data From Text Documents
	Copying Text Using Drag and Drop

	Revision Marking Function
	Recording and Displaying Changes
	Accepting or Rejecting Changes
	Comparing Versions of a Document
	Merging Versions
	Recording Changes

	Version Management
	Protecting Contents in OpenOffice.org
	Protecting All Documents When Saving
	Turning on protection 
	Turning off protection 

	Protecting Revision Marking
	Turning on revision protection 
	Turning off revision protection 

	Protecting Cell Ranges in Calc
	Protecting Sections in Writer
	Turning on protection 
	Turning off protection 

	Protecting Cells in a OpenOffice.org Writer Table
	Automatic Protection of Indexes and Tables
	Turning on protection 
	Turning off protection 

	Protecting frames, graphics and OLE objects
	Protecting Drawing Objects and Form Objects
	Turning on protection 
	Turning off protection 

	Protecting Records

	Digital Signatures and Encryption1
	Overview
	Certificates
	How to get a Certificate?
	Self-signed certificates
	Certificates from a Certificate Authority


	Integrating a Certificate with OpenOffice.org

	Changing Defaults and Other Configuration Items
	Saving Configuration With Document
	Inserting and Editing Tab Stops
	Moving Tabs on the Ruler
	Changing the Properties of Tabs
	Deleting Tabs
	Changing the Defaults


	Changing the colour of Text
	Inserting Landscape pages into a Portrait-oriented Document

	More on Templates
	Changing Default Templates
	Modifying Default Templates
	Resetting Default Templates
	Using Custom Templates
	Using OpenOffice.org over a Network


	Chapter 10: Introducing OpenOffice.org Basic and Macros
	Accessing the Sample Macros
	Calling the Sample Macros
	Editing the Sample Macros

	The Sample Macros
	AutoText
	ChangeAllChars
	GetTexts
	ReadDir
	Userfields


	Chapter 11: Using OpenOffice.org Math
	Formula Entry
	Tool bar
	Command Icon Box
	Command dialogue Box

	Creating an Equation with dialogue Commands
	Special Formating
	Exponentiation:
	Subscripting:
	Leading and trailing superscript and subscript:
	Centre subscript / superscript:
	Under brace / Over brace:
	Various types of Brackets

	Special Characters
	Special Operators
	Integral Sign:
	Summation Character:
	Product Character:

	Vectors and Matrices
	Vector
	Matrix

	Formatting
	Size
	Colour
	Layout
	Alignment

	Examples

	Chapter 12: Building Forms with Xforms 
	Step-by-Step Procedure

	Chapter 13: Xml Enhancements
	Flat XML filter
	Creating a new Docbook Filter

	Chapter 14: Troubleshooting Common Problems
	Error Message contains “Get Storage: "No Content"”
	Under Windows®
	Multi-user installations:
	Single-user installations:

	UNIX systems

	Outline numbering is not retained after a save.
	How get the page count to not count a title page? 
Or How do I offset the page count?
	What to do when document prints or exports with blank pages 
	What to to do with a General error General input/output error 
	How to recover content from a Openoffice.org file 
	Steps for recovering a damaged Openoffice.org file:

	How to get sounds under Linux? 
	Overview
	Starting
	Installing the JRE
	Activating the JRE in OpenOffice.org
	Installating the JMF
	Integration of the JMF in OpenOffice.org 
	Registration of the Plugins in the JMF
	Integration of the Plugins in OpenOffice.org
	Time for the second test
	Integration of the Plugins in OpenOffice.org
	Time for the third test

	What to do if it fails?

	How to open Microsoft Works Documents in OpenOffice.org 2.x

	Index
	Public Documentation License, Version 1.0

