How to Work with Sections

How to Work with Sections
Version 0.1
First edition: March 2004
First English edition: March 2004
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>iii</td>
</tr>
<tr>
<td>About this guide</td>
<td>iii</td>
</tr>
<tr>
<td>Conventions used in this guide</td>
<td>iii</td>
</tr>
<tr>
<td>Copyright and trademark information</td>
<td>iii</td>
</tr>
<tr>
<td>Feedback</td>
<td>iii</td>
</tr>
<tr>
<td>Acknowledgments</td>
<td>iv</td>
</tr>
<tr>
<td>Modifications and updates</td>
<td>iv</td>
</tr>
<tr>
<td>Creating sections</td>
<td>1</td>
</tr>
<tr>
<td>Opening the Insert Section window</td>
<td>1</td>
</tr>
<tr>
<td>Using the Section tab</td>
<td>2</td>
</tr>
<tr>
<td>Naming sections</td>
<td>2</td>
</tr>
<tr>
<td>Linking sections</td>
<td>2</td>
</tr>
<tr>
<td>Write-protecting sections</td>
<td>3</td>
</tr>
<tr>
<td>Hiding sections</td>
<td>4</td>
</tr>
<tr>
<td>Using the Columns tab</td>
<td>4</td>
</tr>
<tr>
<td>Using a predefined column layout</td>
<td>5</td>
</tr>
<tr>
<td>Specifying the number of columns</td>
<td>5</td>
</tr>
<tr>
<td>Distributing text across columns</td>
<td>5</td>
</tr>
<tr>
<td>Formatting column width and spacing</td>
<td>6</td>
</tr>
<tr>
<td>Formatting separator lines</td>
<td>6</td>
</tr>
<tr>
<td>Reverting to a single-column layout</td>
<td>6</td>
</tr>
<tr>
<td>Using the Indents tab</td>
<td>6</td>
</tr>
<tr>
<td>Using the Background tab</td>
<td>7</td>
</tr>
<tr>
<td>Adding color</td>
<td>7</td>
</tr>
<tr>
<td>Adding a graphic</td>
<td>8</td>
</tr>
<tr>
<td>Deleting color or graphics</td>
<td>9</td>
</tr>
<tr>
<td>Using the Footnotes/Endnotes tab</td>
<td>9</td>
</tr>
<tr>
<td>Customizing footnotes</td>
<td>10</td>
</tr>
<tr>
<td>Customizing endnotes</td>
<td>11</td>
</tr>
</tbody>
</table>

How to Work with Sections
Contents

Saving a new section.................................................................................................................. 12

Maintaining sections.................................................................................................................. 13
  Editing and deleting sections.................................................................................................. 13
    Selecting a section............................................................................................................. 13
  Editing section attributes...................................................................................................... 14
  Deleting sections.................................................................................................................. 14
  Editing the format of a section............................................................................................. 14

Updating links.......................................................................................................................... 15
  Updating links automatically............................................................................................... 15
  Updating links manually...................................................................................................... 16
Overview

About this guide

*How to Work with Sections* shows you step-by-step how to create and maintain sections in a text document using OpenOffice.org Writer 1.1. To understand the instructions, you need to know how to create and edit documents in Writer.

For an introduction to Writer, see:

- *How to Write and Manage OpenOffice.org text documents using Common Features and Styles*, available at [http://documentation.openoffice.org/HOW_TO](http://documentation.openoffice.org/HOW_TO)

Conventions used in this guide

This guide uses the following conventions:

- **Bold** indicates menu options, buttons, and other items that you select on the screen.
- Step-by-step directions are numbered to make them easy for you to follow. When you have a choice, the choices are presented in a bulleted list, just like the bulleted list you're reading now.

Copyright and trademark information

The contents of this Documentation are subject to the Public Documentation License, Version 1.0 (the "License"); you may only use this Documentation if you comply with the terms of this License. A copy of the License is available at: [http://www.openoffice.org/licenses/PDL.rtf](http://www.openoffice.org/licenses/PDL.rtf)

The Original Documentation is *How to Work with Sections*. The Initial Writer of the Original Documentation is Catherine Waterman © 2004. All Rights Reserved. (Initial Writer contact: sparkovich@att.net)

Contributor(s): ________________________________.

Portions created by _____ are Copyright (C)_______ [insert year(s)]. All Rights Reserved. (Contributor contact(s):________________ [insert hyperlink/alias]).

All trademarks within this guide belong to legitimate owners.

Feedback

Please direct any comments or suggestions about this document to [dev@documentation.openoffice.org](mailto:dev@documentation.openoffice.org)
Acknowledgments

Thanks to Sophie Gautier, author of the French native-language document, *Comment Utiliser Les Différentes Sections*, which I used as a reference.

Modifications and updates

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.1</td>
<td>03/01/04</td>
<td>Initial version issued for comment</td>
</tr>
</tbody>
</table>
Creating sections

A section is a block of text that has special attributes and formatting. You can use sections to:

• Write-protect text.
• Hide text.
• Dynamically insert the contents of another document.
• Add columns, margin indents, a background color, or a background graphic to a portion of your document.
• Customize the footnotes and endnotes for a portion of your document.

This chapter shows you how to:

• Open Writer's Insert Section window.
• Use the Insert Section window to customize a new section.
• Save the new section.

Opening the Insert Section window

To open Writer's Insert Section window, follow these steps:

1) Place your cursor at the point in your document where you want to insert the new section. Or, select the text that you want to place in the new section.

2) From the main menu, choose Insert > Section... The Insert Section window opens.

3) Click the Section tab if it isn't already displayed. (See Illustration 1 on page 2.)

The Insert Section window has five tabs:

• Use the Section tab to set the section's attributes.
• Use the Columns tab to format the section into columns.
• Use the Indents tab to set indents in the right and left margins of the section.
• Use the Background tab to add color or a graphic to the section's background.
• Use the Footnotes/Endnotes tab to customize the section's footnotes and endnotes.

The next five parts of this chapter tell you how to use each of these five tabs.

At any time, you can reset a tab to its default settings by clicking the Reset button. (Note, however, that you cannot reset the Section tab. If you wish to undo changes to the Section tab, you must do so manually.)
Creating sections

Using the Section tab

Use the Section tab, pictured in Illustration 1 above, to set the attributes of the current section.

Naming sections

Writer automatically enters a name for the current section in the top box of the New section area. To change the name, simply type over it.

Linking sections

You can insert the contents of another document into the current section and then have Writer update the section whenever the other document is updated. This is called linking the section to the other document.

To link the current section to another document, follow these steps:

1) In the Link area, check the Link check box.
Creating sections

2) Click the (...) button to the right of the **File name** field. The Insert window opens.

3) Find the document whose contents you want to insert and then click the **Insert** button. The Insert window closes and the name of the selected document appears in the **File name** field.

4) If you want to insert only a section of the selected document, select the desired section from the **Section** drop-down list.

If you are familiar with DDE object linking and prefer to use DDE commands for linking, check the **DDE** check box. The **DDE command** field appears, allowing you to enter a DDE command.

You can update links automatically or manually. To learn more, see “Updating links” on page 15.

**Write-protecting sections**

To write-protect the current section so that its contents can't be edited, check the **Protect** check box in the Write protection area.

Note that write-protection only protects the section's contents, not its attributes or format. To prevent others from editing the section's attributes or format, protect the section with a password:

1) Check the **With password** check box. The Enter Password window opens.
Creating sections

2) Enter a password in the **Password** field and then confirm the password by entering it again in the **Confirm** field.

3) Click **OK**. The Enter Password window closes. Anyone who tries to edit the section's attributes or format will be prompted to enter the password.

**Hiding sections**

You can hide the current section so that it won't be displayed on the screen or printed. You can also specify conditions for hiding the section. For example, you can hide the section only from certain users.

To hide a section, check the **Hide** check box in the Hide area.

If you want to hide the section only under certain conditions, enter the desired conditions in the **With Condition** field. The syntax and operators that you use to enter conditions are the same ones that you use to enter formulas. For syntax and a list of operators, see Writer's online help under “Conditions.”

Note that you can't hide a section if the section is the only content on the page or if the section is in a header, footer, footnote, endnote, frame, or table cell.

**Using the Columns tab**

Use the **Columns** tab, pictured in Illustration 6 on page 5, to format the current section into columns.
Creating sections

You can use one of Writer's predefined column layouts, or you can create a customized column layout.

The preview box, located to the right of the Settings area, shows you as you work how the column layout will look.

**Using a predefined column layout**

The Settings area displays five predefined column layouts. To use one of them, simply click the desired layout.

**Specifying the number of columns**

If you prefer to create a customized column layout, you must specify the number of columns that you want. Enter the desired number in the **Columns** spin box of the Settings area.

**Distributing text across columns**

You can choose to distribute text across the columns in one of two ways:

- **Evenly.** If you choose to distribute text evenly, Writer will fill the first line of each column, followed by the second line of each column, and so on.
• **Newspaper-style.** If you choose to distribute text newspaper-style, Writer will fill the columns one at a time, beginning with the first column.

To distribute text evenly, check the **Evenly distribute contents to all columns** check box in the Settings area. Clear this check box if you want to distribute text newspaper-style.

**Formatting column width and spacing**

To create evenly-spaced columns that are all the same width, check the **AutoWidth** check box in the Width and spacing area.

To customize the width and spacing of the columns, follow these steps:

1) In the Width and spacing area, clear the **AutoWidth** check box.

2) On the Width line, enter a width for each column.

3) On the Spacing line, enter the amount of space that you want between each column pair.

Use the arrow keys on the Column line to scroll among the columns.

**Formatting separator lines**

To display separator lines between the columns, follow these steps:

1) From the **Line** drop-down list in the Separator line area, select the type of line that you want.

2) By default, the separator lines are the same height as the columns. If you want the separator lines to be shorter than the columns, use the **Height** spin box to enter the height of the separator lines as a percentage of the height of the columns. For example, if you enter 50%, the separator lines will be half as high as the columns.

3) If you entered a height of less than 100%, use the **Position** drop-down list to select a vertical alignment for the separator lines.

**Reverting to a single-column layout**

To revert to a single-column layout, simply reset the **Columns** spin box to 1. Or, in the Settings area, click the single-column layout that's located to the right of the **Columns** spin box.

**Using the Indents tab**

Use the **Indents** tab, pictured in Illustration 7 on page 7, to set indents in the right and left margins of the current section.

Enter the desired left-margin indent in the **Before section** spin box. Enter the desired right-margin indent in the **After section** spin box. The preview box on the right-hand side of the tab shows you how the section will look with the indents applied.
Creating sections

Using the Background tab

Use the Background tab, pictured in Illustration 8 on page 8, to add color or a graphic to the background of the current section.

Adding color

To add color to the background of the current section, simply click the desired color in the color grid.
Creating sections

Adding a graphic

To add a graphic to the background of the current section, follow these steps:

1) From the As drop-down list, select Graphic. The Background tab displays the graphics options. (See Illustration 9 on page 9.)

2) Click the Browse button. The Find Graphics window opens.

3) Find the graphic file that you want to use and then click the Open button. The Find Graphics window closes and the selected graphic appears in the graphic preview box on the right-hand side of the Background tab. (If you don't see the graphic, check the Preview check box underneath the graphic preview box.)

4) In the Type area of the Background tab, choose how you want the background graphic to appear:
   • To position the graphic in a specific location in the background, select Position and then click the desired location in the position grid.
   • To stretch the graphic so that it fills the entire background area, select Area.
• To repeat the graphic across the entire background area, select **Tile**.

![Insert Section](image)

**Illustration 9 Graphics options on the Background tab**

**Deleting color or graphics**
To delete color or graphics from the background of the current section, follow these steps:

1) From the **As** drop-down list, select **Color**.

2) Click **No Fill** on the color grid.

**Using the Footnotes/Endnotes tab**
Use the **Footnotes/Endnotes** tab, pictured in Illustration 10 on page 10, to customize the current section's footnotes and endnotes.
Customizing footnotes

If you want the current section's footnotes to appear separately from the other footnotes in the document, check the **Collect at end of text** check box in the Footnotes area.

To number the current section's footnotes separately from the other footnotes in the document, follow these steps:

1) In the Footnotes area, make sure that the **Collect at end of text** check box is checked.

2) Check the **Restart numbering** check box.

3) If you want the section's footnotes to start at a number other than 1, enter the desired starting number in the **Start at** spin box.
To edit the format of the section's footnotes, follow these steps:

1) In the Footnotes area, make sure that the **Collect at end of text** and **Restart numbering** check boxes are checked.

2) Check the **Custom format** check box.

3) From the drop-down list to the right of the **Custom format** check box, select a numbering format for the footnotes.

4) To add text to the selected numbering format, use the **Before** and **After** fields. For example, if you want the footnote numbers to be preceded by the word “Note” and followed by a colon, fill the **Before** and **After** fields like this:

![Illustration 11 Customized format for footnotes](image)

**Customizing endnotes**

If you want the current section's endnotes to appear at the end of the section rather than at the end of the document, check the **Collect at end of section** check box in the Endnotes area.

To number the current section's endnotes separately from the other endnotes in the document, follow these steps:

1) In the Endnotes area, make sure that the **Collect at end of section** check box is checked.

2) Check the **Restart numbering** check box.

3) If you want the section's endnotes to start at a number other than 1, enter the desired starting number in the **Start at** spin box.

To edit the format of the section's endnotes, follow these steps:

1) In the Endnotes area, make sure that the **Collect at end of section** and **Restart numbering** check boxes are checked.

2) Check the **Custom format** check box.

3) From the drop-down list to the right of the **Custom format** check box, select a numbering format for the endnotes.
4) To add text to the selected numbering format, use the Before and After fields. For example, if you want the endnote numbers to be preceded by the word “Note” and followed by a colon, fill the Before and After fields like this:

![Illustration of custom endnote format]

Illustration 12 Customized format for endnotes

**Saving a new section**

To save a new section so that it appears in your document, click the Insert button. The Insert Section window closes and the new section appears in your document.
Maintaining sections

This chapter shows you how to:

- Edit and delete sections.
- Update links.

Editing and deleting sections

You can edit a section's attributes and formatting, and you can also delete sections.

Selecting a section

To select the section that you want to edit or delete, follow these steps:

1) From the main menu, choose Format > Sections... The Edit Sections window opens.

Illustration 13 Edit Sections window

2) The name of the current section appears in the Section area, in the field that's above the list box. If you want to edit or delete a different section, click the name of the desired section in the list box. The selected section becomes the current section, and its name appears in the field above the list box.
**Editing section attributes**

To rename the current section, simply type over its name in the Section area.

From the Edit Sections window, you can also edit the current section's link, write-protect, and hide attributes. To learn how to edit these attributes, see:

- “Linking sections” on page 2.
- “Write-protecting sections” on page 3.
- “Hiding sections” on page 4.

**Deleting sections**

To delete the current section, click the **Remove** button. (Note that Writer won't prompt you to confirm the delete! To undo a delete, click the **Cancel** button.)

**Editing the format of a section**

To edit the format of the current section, click the **Options...** button. The Options window opens.
The Options window has four tabs: **Columns, Indents, Background,** and **Footnotes/Endnotes.** To learn how to use these tabs, see:

- “Using the Columns tab” on page 4.
- “Using the Indents tab” on page 6.
- “Using the Background tab” on page 7.
- “Using the Footnotes/Endnotes tab” on page 9.

To reset a tab to its most recently saved settings, click the **Reset** button.

To save your Options settings and return to the Edit Sections window, click **OK.**

### Updating links

You can have Writer update linked sections automatically, and you can also update links manually.

#### Updating links automatically

By default, whenever you open a document that contains links, Writer prompts you to update the links. To have Writer update links without prompting you, or to turn off automatic updating, follow these steps:

1) From the main menu, choose **Tools > Options...** The Options – OpenOffice.org window opens.
2) In the list box on the left, click the plus sign next to Text Document. A list of text document settings appears underneath Text Document.


![Options - Text Document - General](image)

Illustration 16 General text document settings

4) In the Update area, under Update links when loading, select an option:
   - Select Always if you want Writer to update links automatically, without prompting you, whenever you open a document that contains links.
   - Select On request if you want Writer to prompt you before updating links.
   - Select Never if you don't want Writer to update links.

5) Click OK to save your settings. The Options window closes.

**Updating links manually**

To update a link manually, follow these steps:

1) Open the document that contains the link.

2) From the main menu, choose Edit > Links... The Edit Links window opens. (See Illustration 17 on page 17.)

3) The list box on the Edit Links window displays the names of all the files that are linked to the current document. Click the file that corresponds to the link that you want to update.
4) Click the **Update** button. The most recently saved contents of the linked file appear in the current document.

5) To close the Edit Links window, click **Close**.