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Overview

Overview

This document is intented to educate the user on Cross References and how to use them
within an OpenOffice.org Writer document.

Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License,
Version 1.0 (the "License"); you may only use this Documentation if you comply with the
terms of this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf

The Original Documentation is Cross References. The Initial Writer(s) of the Original
Documentation is/are Scott Carr © 2004. All Rights Reserved. (Initial Writer contact(s):
kcarr@openoffice.org.) 

Contributor(s): Scott Carr, Ian Laurenson. 

Portions created by Scott Carr, Ian Laurenson are Copyright © 2004. All Rights Reserved.
(Contributor contact(s):kcarr@openoffice.org, Hillview@paradise.net.nz).

All trademarks within this guide belong to legitimate owners.

Feedback
Please direct any comments or suggestions about this document to:
kcarr@openoffice.org

Acknowledgments
My wife for allowing me to work on this.

Modifications and updates

Version Date Description of Change

0.1 05/11/04 Rough Draft

0.2 03/06/04 Generalized document to include bookmarks and
number range variables, with a table comparing these.
Also included references to open source macros that
makes working with references easier. A note about
hyperlinks and another about sections.
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Using Cross-References

Using Cross-References

Cross References are used to refer to a location of a portion of text or to replicate a portion of
text.

Typical uses of cross-references are to:

• Reference Headings

• Reference tables, figures etc

• To keep track of multiple references to an Entity, Person, Place, or Event

The user creates a Cross-reference source once, and then creates in Writer references to that
source by selecting the reference source from a list instead of manually typing it. This will
create a link between the original reference source and all future references. Any changes to
the original reference source will be reflected in the cross-references.

Cross-reference Sources
There are three sources for cross references:

• Set references

• Bookmarks

• Number range variables

For a comparison of reference sources see Table 1 below.
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Table 1 Comparison of reference sources: set references, bookmarks and variables

Set
Reference

Bookmark Number
range
Variables

Updating references to it Automatic Press F9 Automatic

Highlighting With field shadings
turned on

Never With field shadings
turned on

Hyperlink to it No Yes No – but can hyperlink
to objects that may be
captioned

Jump to reference source
by clicking on reference
in .sxw

Yes Yes Yes

Rename No Yes but doesn't change
references to the
bookmark so these are
left orphaned

No

Delete No Yes but references to it
left orphaned

No

In navigator Yes Yes No

On deleting text that
contains it

Removed but
references to it left
orphaned

Removed but
references to it left
orphaned

Removed but
references to it left
orphaned

Reliably moves as
document changes

Yes ? (Some people have
commented that it is
unreliable)

Yes

Page (the page number in
arabic numerals)

Yes Yes Yes

Chapter (The number of
the outline numbered
paragraph)

Yes Yes Yes

Reference The text highlighted
by the set reference

The text contained
within the bookmark

The text of the entire
paragraph that
contains the variable

Above/Below Yes Yes Yes

As page style (The page
number as displayed)

Yes Yes Yes

Category and number No No The text to the left of
the variable and the
variable's value

Caption text No No Text to the right of the
variable in the
paragraph

Numbering No No The value of the
variable.
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How Do I Create a Set Reference?
To create a Set Reference:

1. Enter the Text you would like to use as a Cross Reference.

2. Highlight the Text that is to be a Cross Reference.

3. Click Insert -> Cross Reference.

4. In the Type list box:  Select Set Reference.

5. In the Name Field:  Enter a Name for this Cross Reference.

6. Click Insert.

7. Click Close.

You now have a Set Reference setup. If View > Field Shadings is ticked you will notice that
the text that you highlighted has a grey background now.  This indicates that set references
are considered a field. The advantage to you is that you know exactly what is being
referenced.

How Do I Create a Bookmark?
To create a Bookmark:

1. Enter the Text you would like to use as a bookmark.

2. Highlight the Text that is to be a Bookmark.

3. Click Insert -> Bookmark...

4. In the text field:  Enter a Name for this bookmark.

5. Click OK.

You now have a bookmark setup.

How Do I Create a Number range Variable?
Number range variables are used in three main ways:

1) In captions

2) User defined

3) Numbering equations

Inserting a caption
To insert a caption:

1. Select the object (table, graphic, etc.) that you wish to caption.

2. Click Insert -> Caption...
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3. Select or type in a new category for this object.

4. Enter a caption for this object.

5. See help for more details on other options in the dialog

6. Click OK.

You now have a number range variable setup for the caption that can be cross referenced.

Defining a Number range variable
Sometimes you may want similar functionality of caption numbers, an automatically
incrementing number, but they aren't related to captions.

To define a variable:

1. Position the cursor where the variable is to go

2. Click Insert -> Fields > Other... (or Control + F2)

3. Select the Variables tab

4. For type select Number range

5. Either select an existing selection or type in a new Name

6. You can optionally give it a specific value (if you want to start at something other than
one)

7. Choose format

8. If you want to include outline numbering specify the level to include and the seperator
character

9. Click Insert.

You now have a user defined number range variable setup.

Numbering Equations
There is a preconfigured autotext entry for equations which uses a number range variable
called Text. To check this out type fn then press F3.

How Do I create a Cross Reference to a reference
source?
1. Place the Cursor where you want the Cross Reference to appear in your text.

2. Click Insert -> Cross Reference.

3. In the Type list box:  Select Insert Reference, bookmark, or the name of the Number range
variable.

4. In the Selection list box:  Select the Cross Reference you want to insert

5. In the Format list box:  Select the format desired. For more detail see the bottom of Table
1 on page 2 above.
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6. Click the Insert button.

How Do I Change the Text in a Cross Reference?
To change a Cross References text, you have to change the original reference.  To find the
original reference click on a Reference you want to change.  The document may shift while it
locates the original reference.

The cursor should appear at the beginning of the Reference.

Now you can change the text of the Cross Reference. For set references with field shading
turned on you can see the extent of the set reference. For bookmarks it is not obvious, so you
may want to check that the text is contained within the bookmark by double clicking on its
name in the Navigator. For number range variables it is the text of the paragraph that contains
the number range (see the bottom of Table 1 on page 2 above.)

Once you are finished with updating the reference, press F9 to update the document with
changes to fields.  You can check any of the other locations in your document to make sure
everything is working properly.

References versus Hyperlinks
A reference is a way of having text entered once and to be able to refer to the location of that
text (e.g. page number, above/below, chapter) or to repeat the content of the referred to text
(e.g. reference). As a by product within Writer by clicking on a reference the cursor will jump
to the reference source. However, when saving in HTML format or exporting as PDF (using
the extended PDF converter macro) these are not hyperlinks and so they are not links in these
formats.

Hyperlinks are for jumping to another location (whether in the same document or somewhere
completely different on the web) and the text of a hyperlink can be whatever you want it to be
and thus they are not updated when the source changes. A way of combining the two
functions within a document can be achieved by using bookmarks in the following way:

1) Select a portion of text that you wish to be the target of a hyperlink and to contain the
text of the reference to it.

2) Insert > Bookmark... > name > OK

3) Position the cursor where you want the hyperlink to go

4) Insert > Cross-reference... > Bookmarks > name > Reference > Insert > Close

5) Select the reference you have just created

6) Create the hyperlink by:

7) Insert > Hyperlink

8) Click the target in document button to the right of the Target text field, click the plus
to the left of bookmark and select name. Alternatively, simply type the name into the
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target text field box.

9) Click apply.

10)Now when the text that is within the bounds of the bookmark is updated, the hyperlink
text will also update when F9 is pressed.

Managing set references and bookmarks
As can be seen in Table 1 there are a number of issues and differences when dealing with
references. Deleting and renaming of set references and bookmarks can cause orphans
(references without a source). Due to differences in what can be done with each it maybe
convenient to change from using set references to bookmarks or bookmarks to set references.
To help with these issues there is an open source macro available from
http://homepages.paradise.net.nz/hillview/OOo/ in a document called
ReferenceManager.sxw. This document explains how to use the macro.

Reference Headings
Current versions of OpenOffice.org do not have the ability to directly cross-reference
headings. To get around this insert set references for the headings and then create cross-
references to them. A more user friendly approach is planned for OOo 2.0 but in the mean
time there is an open source macro available from
http://homepages.paradise.net.nz/hillview/OOo/ in a document called  OutlineCrossRef.sxw.
This document describes how to use the macro including how to cross reference headings of
sub documents of a master document.

Referencing sections
It is also possible to reference sections of either the current document or another document.
An example of where this would be useful is legal documents.

Often legal documents have very similar chunks of text. By using this feature you can create
links to documents so that by updating the one document all other documents with section
links will be updated as well.

To prevent updating a link (so that you don't have the experience of “I thought I changed
that”) it is possible to lock the link.

Index
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Public Documentation License, Version 1.0

1.0 DEFINITIONS. 

1.1. "Commercial Use" means
distribution or otherwise making the
Documentation available to a third
party. 

1.2. "Contributor" means a person or
entity who creates or contributes to the
creation of Modifications. 

1.3. "Documentation" means the
Original Documentation or
Modifications or the combination of
the Original Documentation and
Modifications, in each case including
portions thereof.

1.4. "Electronic Distribution
Mechanism" means a mechanism
generally accepted for the electronic
transfer of data. 

1.5. "Initial Writer" means the
individual or entity identified as the
Initial Writer in the notice required by
the Appendix. 

1.6. "Larger Work" means a work
which combines Documentation or
portions thereof with documentation or
other writings not governed by the
terms of this License. 

1.7. "License" means this document. 

1.8. "Modifications" means any
addition to or deletion from the
substance or structure of either the
Original Documentation or any
previous Modifications, such as a
translation, abridgment, condensation,
or any other form in which the Original
Documentation or previous

Modifications may be recast,
transformed or adapted.  A work
consisting of editorial revisions,
annotations, elaborations, and other
modifications which, as a whole
represent an original work of
authorship, is a Modification.  For
example, when Documentation is
released as a series of documents, a
Modification is: 

A. Any addition to or deletion from the
contents of the Original Documentation
or previous Modifications. 

B. Any new documentation that
contains any part of the Original
Documentation or previous
Modifications. 

1.9. "Original Documentation" means
documentation described as Original
Documentation in the notice required
by the Appendix, and which, at the
time of its release under this License is
not already Documentation governed
by this License. 

1.10. "Editable Form" means the
preferred form of the Documentation
for making Modifications to it. The
Documentation can be in an electronic,
compressed or archival form, provided
the appropriate decompression or de-
archiving software is widely available
for no charge. 

1.11. "You" (or "Your") means an
individual or a legal entity exercising
rights under, and complying with all of
the terms of this License or a future
version of this License issued under
Section 5.0 ("Versions of the
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License"). For legal entities, "You"
includes any entity which controls, is
controlled by, or is under common
control with You. For purposes of this
definition, "control" means (a) the
power, direct or indirect, to cause the
direction or management of such entity,
whether by contract or otherwise, or (b)
ownership of more than fifty percent
(50%) of the outstanding shares or
beneficial ownership of such entity.

2.0 LICENSE GRANTS. 

2.1  Initial Writer Grant. 

The Initial Writer hereby grants You a
world-wide, royalty-free, non-exclusive
license to use, reproduce, prepare
Modifications of, compile, publicly
perform, publicly display, demonstrate,
market, disclose and distribute the
Documentation in any form, on any
media or via any Electronic
Distribution Mechanism or other
method now known or later discovered,
and to sublicense the foregoing rights
to third parties through multiple tiers of
sublicensees in accordance with the
terms of this License.  

The license rights granted in this
Section 2.1 ("Initial Writer Grant") are
effective on the date Initial Writer first
distributes Original Documentation
under the terms of this License. 

2.2. Contributor Grant. 

Each Contributor hereby grants You a
world-wide, royalty-free, non-exclusive
license to use, reproduce, prepare
Modifications of, compile, publicly
perform, publicly display, demonstrate,
market, disclose and distribute the
Documentation in any form, on any

media or via any Electronic
Distribution Mechanism or other
method now known or later discovered,
and to sublicense the foregoing rights
to third parties through multiple tiers of
sublicensees in accordance with the
terms of this License.  

The license rights granted in this
Section 2.2 ("Contributor Grant") are
effective on the date Contributor first
makes Commercial Use of the
Documentation. 

3.0 DISTRIBUTION OBLIGATIONS. 

3.1. Application of License.

The Modifications which You create or
to which You contribute are governed
by the terms of this License, including
without limitation Section 2.2
("Contributor Grant").  The
Documentation may be distributed only
under the terms of this License or a
future version of this License released
in accordance with Section 5.0
("Versions of the License"), and You
must include a copy of this License
with every copy of the Documentation
You distribute. You may not offer or
impose any terms that alter or restrict
the applicable version of this License
or the recipients' rights hereunder.
However, You may include an
additional document offering the
additional rights described in Section
3.5 ("Required Notices"). 

 3.2. Availability of Documentation.

Any Modification which You create or
to which You contribute must be made
available publicly in Editable Form
under the terms of this License via a
fixed medium or an accepted
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Electronic Distribution Mechanism. 

3.3. Description of Modifications.

All Documentation to which You
contribute must identify the changes
You made to create that
Documentation and the date of any
change. You must include a prominent
statement that the Modification is
derived, directly or indirectly, from
Original Documentation provided by
the Initial Writer and include the name
of the Initial Writer in the
Documentation or via an electronic
link that describes the origin or
ownership of the Documentation.  The
foregoing change documentation may
be created by using an electronic
program that automatically tracks
changes to the Documentation, and
such changes must be available
publicly for at least five years
following release of the changed
Documentation. 

3.4. Intellectual Property Matters.

Contributor represents that Contributor
believes that Contributor's
Modifications are Contributor's
original creation(s) and/or Contributor
has sufficient rights to grant the rights
conveyed by this License.

3.5. Required Notices.

You must duplicate the notice in the
Appendix in each file of the
Documentation. If it is not possible to
put such notice in a particular
Documentation file due to its structure,
then You must include such notice in a
location (such as a relevant directory)
where a reader would be likely to look
for such a notice, for example, via a

hyperlink in each file of the
Documentation that takes the reader to
a page that describes the origin and
ownership of the Documentation.  If
You created one or more Modification
(s) You may add your name as a
Contributor to the notice described in
the Appendix. 

You must also duplicate this License in
any Documentation file (or with a
hyperlink in each file of the
Documentation) where You describe
recipients' rights or ownership rights. 

You may choose to offer, and to charge
a fee for, warranty, support, indemnity
or liability obligations to one or more
recipients of Documentation. However,
You may do so only on Your own
behalf, and not on behalf of the Initial
Writer or any Contributor. You must
make it absolutely clear than any such
warranty, support, indemnity or
liability obligation is offered by You
alone, and You hereby agree to
indemnify the Initial Writer and every
Contributor for any liability incurred by
the Initial Writer or such Contributor as
a result of warranty, support, indemnity
or liability terms You offer. 

 3.6.  Larger Works.

You may create a Larger Work by
combining Documentation with other
documents not governed by the terms
of this License and distribute the
Larger Work as a single product. In
such a case, You must make sure the
requirements of this License are
fulfilled for the Documentation.

4.0  APPLICATION OF THIS
LICENSE. 
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This License applies to Documentation
to which the Initial Writer has attached
this License and the notice in the
Appendix.

5.0  VERSIONS OF THE LICENSE. 

5.1. New Versions.

Initial Writer may publish revised
and/or new versions of the License
from time to time. Each version will be
given a distinguishing version number. 

5.2. Effect of New Versions.

Once Documentation has been
published under a particular version of
the License, You may always continue
to use it under the terms of that
version. You may also choose to use
such Documentation under the terms of
any subsequent version of the License
published by Scott Carr. No one other
than Scott Carr (kcarr@openoffice.org)
has the right to modify the terms of this
License. Filling in the name of the
Initial Writer, Original Documentation
or Contributor in the notice described
in the Appendix shall not be deemed to
be Modifications of this License.

6.0 DISCLAIMER OF WARRANTY. 

DOCUMENTATION IS PROVIDED
UNDER THIS LICENSE ON AN "AS
IS'' BASIS, WITHOUT WARRANTY
OF ANY KIND, EITHER
EXPRESSED OR IMPLIED,
INCLUDING, WITHOUT
LIMITATION, WARRANTIES THAT
THE DOCUMENTATION IS FREE
OF DEFECTS, MERCHANTABLE,
FIT FOR A PARTICULAR PURPOSE
OR NON-INFRINGING. THE
ENTIRE RISK AS TO THE

QUALITY, ACCURACY, AND
PERFORMANCE OF THE
DOCUMENTATION IS WITH YOU.
SHOULD ANY DOCUMENTATION
PROVE DEFECTIVE IN ANY
RESPECT, YOU (NOT THE INITIAL
WRITER OR ANY OTHER
CONTRIBUTOR) ASSUME THE
COST OF ANY NECESSARY
SERVICING, REPAIR OR
CORRECTION. THIS DISCLAIMER
OF WARRANTY CONSTITUTES
AN ESSENTIAL PART OF THIS
LICENSE. NO USE OF ANY
DOCUMENTATION IS
AUTHORIZED HEREUNDER
EXCEPT UNDER THIS
DISCLAIMER.

7.0 TERMINATION. 

This License and the rights granted
hereunder will terminate automatically
if You fail to comply with terms herein
and fail to cure such breach within 30
days of becoming aware of the breach.
All sublicenses to the Documentation
which are properly granted shall
survive any termination of this License.
Provisions which, by their nature, must
remain in effect beyond the termination
of this License shall survive. 

8.0 LIMITATION OF LIABILITY. 

UNDER NO CIRCUMSTANCES
AND UNDER NO LEGAL THEORY,
WHETHER IN TORT (INCLUDING
NEGLIGENCE), CONTRACT, OR
OTHERWISE, SHALL THE INITIAL
WRITER, ANY OTHER
CONTRIBUTOR, OR ANY
DISTRIBUTOR OF
DOCUMENTATION, OR ANY
SUPPLIER OF ANY OF SUCH
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PARTIES, BE LIABLE TO ANY
PERSON FOR ANY DIRECT,
INDIRECT, SPECIAL, INCIDENTAL,
OR CONSEQUENTIAL DAMAGES
OF ANY CHARACTER
INCLUDING, WITHOUT
LIMITATION, DAMAGES FOR
LOSS OF GOODWILL, WORK
STOPPAGE, COMPUTER FAILURE
OR MALFUNCTION, OR ANY AND
ALL OTHER DAMAGES OR
LOSSES ARISING OUT OF OR
RELATING TO THE USE OF THE
DOCUMENTATION, EVEN IF
SUCH PARTY SHALL HAVE BEEN
INFORMED OF THE POSSIBILITY
OF SUCH DAMAGES. 

9.0 U.S. GOVERNMENT END
USERS. 

If Documentation is being acquired by
or on behalf of the U.S. Government or
by a U.S. Government prime contractor
or subcontractor (at any tier), then the
Government's rights in Documentation
will be only as set forth in this
Agreement; this is in accordance with
48 CFR 227.7201 through 227.7202-4
(for Department of Defense (DOD)
acquisitions) and with 48 CFR 2.101
and 12.212 (for non-DOD
acquisitions).

10.0 MISCELLANEOUS. 

This License represents the complete
agreement concerning the subject
matter hereof. If any provision of this
License is held to be unenforceable,
such provision shall be reformed only
to the extent necessary to make it
enforceable. This License shall be
governed by California law, excluding
its conflict-of-law provisions. With

respect to disputes or any litigation
relating to this License, the losing party
is responsible for costs, including
without limitation, court costs and
reasonable attorneys' fees and
expenses. The application of the United
Nations Convention on Contracts for
the International Sale of Goods is
expressly excluded. Any law or
regulation which provides that the
language of a contract shall be
construed against the drafter shall not
apply to this License.

Appendix 

Public Documentation License Notice 

The contents of this Documentation are
subject to the Public Documentation
License Version 1.0 (the "License");
you may only use this Documentation
if you comply with the terms of this
License. A copy of the License is
available at
http://www.openoffice.org/licenses/PD
L.rtf. 

The Original Documentation is
_________________. The Initial
Writer of the Original Documentation
is kcarr@openoffice.org (C) 2004. All
Rights Reserved. (Initial Writer contact
(s): kcarr@openoffice.org.)

Contributor(s): Scott Carr, Ian
Laurenson. 

Portions created by Scott Carr are
Copyright (C)2004. All Rights
Reserved.   (Contributor contact(s):
________________[Insert
hyperlink/alias]).

Note: The text of this Appendix may
differ slightly from the text of the
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notices in the files of the Original
Documentation. You should use the
text of this Appendix rather than the
text found in the Original

Documentation for Your
Modifications.

<DOCUMENT TITLE>  12


