Eleven Tips for Moving to OpenOffice.org
By
Bruce Byfield
For the past 18 months, I've been badgering people to try OpenOffice.org (OOo). Slowly, I've
come to realize that talking about free software isn't enough. The problem isn't that people don't
like the idea of free downloads or of joining a project and having a voice in its development. After
all, what's not to like there? The problem is that being sold on free software rarely is enough to
guarantee a smooth transition to OpenOffice.org.
What follows are suggestions I've formulated for making the switch. Even the most open
minded people usually have assumptions to discard. They still have preparations to make and
features to try. Most of all, they have some hours to log before they really can decide whether
OpenOffice.org is right for them. Nobody can help an individual or an office switch if curiosity or
a willingness to explore is missing, but if you pay attention to the tips that follow, you should be
able to remove much of the pain from the process.

1. Don't Expect Features to Be Missing
People always say, “I'd love to use OpenOffice, but... ,” and then they name a feature they
can't live without. If they've glanced at OpenOffice.org, they might claim their musthave feature
isn't there. Most of the time, I can respond by telling them where to find the feature, and they fall
into an embarrassed silence and change the conversation.
Sometimes, this missing musthave response is sincere, but more often it's an excuse. Either
way, I suspect, the assumption behind it is that free software always is inferior to its proprietary
equivalent. When a casual search doesn't immediately unearth the feature, this prejudice is
reinforced.
Even if the assumption were true ( and Linux, Apache, GIMP and Mozilla users all know that it
isn't), the assumption wouldn't be true for OpenOffice.org. Although at the time of this writing
OOo is at version 1.1, StarOffice, its Sunowned predecessor, has a longer history than people
think. In fact, the first version of StarOffice was a DOS word processor released in 1985. Probably
none of the original code remains, but, with two decades of development behind it, the
OpenOffice.org code is mature and mostly complete.
Admittedly, other word processors do have features OpenOffice.org lacks. It doesn't have MS
Word's grammar checker, WordPerfect's Reveal Codes feature or FrameMaker's master pages. But,
OOo has features these rivals don't.
The point is, there's no need for a pessimistic view of OOo's features. Usually, you can be
optimistic and assume the feature is somewhere in the menus. It may not be in quite the same
form with which you are familiar  for example, OOo's outlining tool functions quite differently
from MS Word's  but odds are you can find it in some form, however mutated.

Bruce Byfield

Eleven Tips for Moving to OpenOffice.org

1

2. Don't Expect Features to Be in the Same Place
No doubt about it, the OOo interface is similar to MS Office's. The general menu structure
often is identical, down to the confusing placement of Configure and Options in the same menu.
This similarity between interfaces can ease the switch to OOo, but it can be misleading, too. In
places, OOo has cleaned up and rationalized the MS Office menu structure. Tables, for example,
do not rate a separate menu in OOo; they are placed in the Insert menu instead. At other times,
the same feature has a different name: MS Word's Autosummary, for example, is AutoAbstract in
OOo.
In other words, OOo is a mixture of the familiar and the new. Fortunately, basic functions
usually are in their familiar places, so unsophisticated users are unlikely to get lost. However, if
you're an advanced user, you may need to be more flexible. If a tool isn't where you expect it,
think about what other menu it might be under or what else it might be called. If your
imagination fails, look at the MS Office Feature comparison in the Help files, or look at my more
detailed comparison at
http://www.raycomm.com/techwhirl/magazine/technical/openofficewriter.html. In most cases,
you should find what you need.

3. Don't Expect to Need Training
Even though you may stumble over the placement of some tools, you probably don't need a
long transition period before you or your company can use OOo productively. Most likely, the
transition can be completed in well under a week. Basic users can make the switch easily because
they use a word processor as though it were a typewriter. If they want to italicize a word, they
don't use the Emphasis character style. Instead, they highlight the word and click the italic icon. If
they decide they would rather use a bold font to emphasize words, they go through their
document and change the formatting on each word separately.
The basic methods are not efficient ways to use any word processor, let alone OOo. But,
people who work in this way use only a small set of tools. In OOo, these features generally are
where such users expect to find them. Character and paragraph characteristics, for instance, are
found in the Format menu or on the toolbar, and the spell checker is in the Tools menu. The
transition to OOo may be an ideal opportunity to learn more, but meanwhile, users can complete
their daily work with almost no interruption.
Advanced users may take a day or two longer to adjust. However, in the same way that
knowing one language can help you to learn another one from the same region, knowing one
word processor helps advanced users learn a different one. Advanced users know what to expect,
and they typically have the confidence to search for it on their own. As a result, advanced users
shouldn't need to be trained on OOo, either they can train themselves.

4. Don't Rely on Import/Export Filters for Exchanging Files
At first glance, OpenOffice.org looks to be ideal for exchanging documents with other office
suites, especially MS Office. Several MS formats are available when saving a file, as is a batch
converter (File > AutoPilot > Document Converter). Moreover, in Tools > Option you can set
OOo to save to MS formats by default and to preserve the VB scripts it can't use. What more can
you need? Patience, for one. Truckloads of spare time, for another.
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The truth is, there never has been a completely reliable import or export filter in any office
suite. Chances are there never will be. If there is, my money is on crosscompatibility between
OOo, KOffice and/or GNOME office. These formats are all open source, so at least the
development time will be shorter. But, even with opensource formats, filters are going to cause
problems for the immediate future.
Why? For one thing, writing filters is an intensive and unglamorous job. For proprietary
companies, making the perfect filter is too expensive  aside from the fact that they don't want
you using rivals' software. For free software developers, more interesting projects always are
available. Besides, the people who need filters mostly are not developers, so developers are less
likely to see the need for them.
Just as importantly, many filters involve proprietary formats. This means developers need to
do reverse engineering, a difficult, timeconsuming and sometimes legally risky process. Filters for
MS Office, the main concern, are especially difficult because the format often changes and may not
be even backwardly compatible with earlier versions of itself.
That said, OOo's native XML format makes writing filters easier, and its MS Office filters are
among the best I've seen. Yet even these filters are far from perfect, and users who rely on them
should reconcile themselves to a regular dose of manual reformatting.
If you insist on using other office suites with OOo, try to limit the editable documents
exchanged to short, simply formatted documents. Search OOo Help for About Converting
Microsoft Office Documents to see a list of elements you should avoid. For those elements you do
use, you can improve the results if you use only styles and ensure that both office suites have
access to the same fonts. Even then, you can expect anything other than the simplest bullets to be
garbled. You might consider making a list of allowable formatting to minimize problems.
If users of other office suites don't need to edit a document, select File > Export as PDF and
send it as a PDF file. PDF files are close to an open standard; therefore, this is one filter on which
you can rely.
The best format solutions for exchanging editable documents between office suites probably
are HTML or Simplified DocBook. Both can be viewed in modern browsers, and they can be
opened as text files in word processors, if nothing else. Better yet, get your company or
community using OpenOffice.org by itself. You still may need to share documents with outsiders,
but your daily life will be simpler.

5. Make a List of How to Do the Basic Functions That You Need
Before you switch to OOo, make a list of the basic tasks you or your division does in an office
suite. Try to keep the list to less than 20 tasks. Then spend half an hour experimenting or
browsing the Help section of OOo. Write down how to do these tasks on file cards and distribute
them to everyone. As each person becomes comfortable with the basic tasks, replace the first file
cards with instructions for less common tasks. In days, or even hours, you should find that no one
needs to use the cards.

6. Use the Available Help
OOo comes with a fully developed help system. In earlier versions, the help files often lacked
context and gave circular definitions of features. As of version 1.1, though, the Help section
actually has become an asset instead of a formality.
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Sometime early in the transition, have everyone read the first four links on the Welcome to the
OpenOffice.org Writer Help page. The links provide a good overview for delving deeper into the
program. You also should consider suppressing your natural annoyance and enable the extended
tips and office assistant for a few weeks. Both of these features offer useful information in small
chunks. Although your understanding may seem fragmented at first, in the long run the tips are a
painless way to learn.

7. Start with the AutoPilot Features
One of OOo's features for newcomers is a series of wizards that lead you through the process
of setting up basic documents, such as a letter or memo. You may not find the results exactly fit
your needs, but they are a quick way to get started with OOo. Look under Files > AutoPilot. Just
as importantly, try comparing the instructions in the AutoPilot with the final results. It's a good
way of knowing what office suites in general and OOo in particular can do.

8. Learn to Use Styles
If you're the type of user who manually applies formatting, mark your switch to OOo by
learning how to use styles. Styles save you time in any word processor by allowing you to make
formatting changes once and have them ripple through the document. Styles are especially
important in OOo, because they give you templates not only for paragraphs and individual
characters but also for pages, text frames and lists. Go with this flow and you not only minimize
difficulties, you increase your efficiencies.
The key to styles in OOo is the Stylist, a floating palette found at Format > Stylist. You can use
the Stylist to apply styles quickly as you type and to modify existing styles or create new ones. It
lists styles using several different filters, so you can locate the ones you need quickly.

9. Learn to Use the Navigator
The Navigator (Edit > Navigator) is another floating palette. Like the Stylist palette, it is a key
feature in using OOo effectively. As the name suggests, one of the functions of the Navigator is to
help you move quickly to different parts of the document. Tables, OLE objects or pages you can
jump to almost any element in the document you want. Elements are numbered as you create
them, but if you also give them descriptive titles, the Navigator can display them, making jumping
around even easier.
Don't let the name mislead you, though. The Navigator is far more than a map of your
document. Switch to Headings and it becomes an outlining tool, with the ability to move entire
sections and raise or lower the level of headings with the drag of the mouse. Open a Master
Document, and it becomes a table of contents. You even can use the Navigator to add a Reminder
to the text.
In short, you probably will come to spend a lot of time with the Navigator. And, it is
something for which your experiences with other office suites doesn't prepare you.
As an aside, the default size of the Navigator may be too small. Drag its sides until the
Navigator is at least half again as large as the default, and you can use it without eyestrain.
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10.Look for Hidden Functionality
Unexpected features or shortcuts can be found in any software. These aren't quite Easter eggs
but halfhidden functions that rarely are emphasized or mentioned in the Help. For example, I
quickly found Edit > Undo. Because I generally use the menus or keyboard, though, it took me
several weeks to realize that if I selected the Undo button on the taskbar, I could choose the exact
level of Undo to which I wanted to revert. Similarly, if I want to insert text automatically each
time I use a style, I can use the Before field on the Options tab for list styles and attach that list
style to a paragraph style. Then, every time I use that style, the text in the Before field appears
without me having to type it.
Such surprises do three things: they give you confidence in your knowledge of the program,
they encourage you to keep learning and they offer shortcuts for your daily work. They're well
worth seeking.

11.Take Time before Making a Decision
The first few times you start OOo, your impression simply may be that it's new. It doesn't look
the same as your old word processor, it isn't arranged in the same way and it does some things
differently. For some people, the newness alone is enough to make them cut the experiment short.
Instead of jumping to conclusions, however, wait and learn the program before making a
decision about OOo or any of its features. Forget about your sense of being overwhelmed with the
new and try to get on with your daily tasks. Spend at least 10 15 hours doing routine work
before you even start to make a decision. Then sit down and list the pros and cons of using OOo.
If you decide against OOo, keep it in mind and try another version in a year or two. In the future,
you may find that it fits your needs better. If you're a decisionmaker at a company, you also
might consider contacting the OOo community to see whether your company could sponsor the
development of the features you need. If you do decide to keep OOo, congratulations. You did
your preparation, and you're making the right choice.
Bruce Byfield was product manager at Stormix Technologies and marketing and communications director at Progeny
Linux System. He also was a contributing editor at Maximum Linux and the original writer of the Desktop Debian manual.
Away from his computer, he listens to punkfolk music, raises parrots and runs long, painful distances of his own free will.
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